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Introduction 
GEOPAK is a comprehensive software package that covers every project phase from 
conceptualization to final quantities and construction stake-out.  The software works within the 
MicroStation graphic environment providing true interactive design.  For example, a horizontal 
alignment can be created graphically, it can be calculated with the coordinate geometry component of 
GEOPAK or some interactive combination of the two.  Dynamic on-screen design provides immediate 
interpretation of plan view geometrics for making design choices through visualization. 

Using GEOPAK will help ensure consistency and accuracy of design work and generate a significant 
time savings in the overall effort of producing construction plans. 

1.1   File Names 
GEOPAK uses and/or creates files during the design process.  Several of the more common files are 
detailed in the table below.  

job###.gpk This binary file is created when the user starts a coordinate geometry 
(COGO) session for the first time or created through Project Manager.  
The file may be appended to during the design process. All coordinate 
geometry elements are stored in this file.  Multiple users can access this 
file at the same time, and only one file should be created for each project.  
The "###" is the only variable in this filename.  It represents a job number 
(up to 3 alphanumeric characters) unique to a project and is defined by the 
user upon creation. 

fname###.ioc 
Example: 
align999.ijd 

ASCII input file for loading data during a COGO session. "###" represents 
the job number and "oc" is the operator code (users initials). Filename 
characters are limited to 5 characters plus the 3 job number character 
designation as indicated with the example. 

fname###.ooc 
Example: 
align999.ojd 

ASCII output file created by GEOPAK during a COGO session. Variables 
are the same as defined above.  Filename characters are limited to 5 
characters plus the 3 job number character designation as indicated with 
the example. 

fname.inp  
Example: desxs.inp 

Any ASCII input file for running GEOPAK processes.  Name is user 
defined with a .INP extension.  

fname.dat 
 

A binary file that contains string and point information to be used for digital 
terrain model construction. 

fname.tin A binary file containing triangular surfaces also known as the digital terrain 
model (DTM). 

Project-name.prj Binary file resulting from the creation of a new project. 
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1.2   Accessing GEOPAK 
GEOPAK is started upon entering a MicroStation File.  To verify that GEOPAK is active, scan the 
MicroStation menu bar where the Applications menu appears.  Simply select Applications > 
GEOPAK Road.  When each GEOPAK tool is selected, the corresponding dialog box(es) will appear. 

 

To close a dialog box, the following options are available: 

• Click the X in the upper right corner of the dialog box 
• Select the File > Exit option 
• Or click Cancel on the dialog box 

 
 Use one of the above options that appear in the dialog box. 
 
Exiting the MicroStation file automatically closes all GEOPAK dialog boxes. 

1.3   User Preferences 
When a user begins Geopak for the first time or after Geopak has been reloaded, there are certain 
User Preferences the user needs to set.  The User Preferences dialog box can be accessed from 
Applications > Geopak Road > User Preferences.  The following dialog box appears. 
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Most of the settings in this dialog box can be defined when a project is created within Project 
Manager (See Chapter 2). 

The Working Directory identifies where the data files for a particular project can be found.  If a user 
does not want to work within a specific project, the field may be left blank, and Geopak uses the 
directory wherein the open MicroStation file is located. 

By clicking the Feature Preferences button, the following dialog box is invoked. 

 

This defines the default file utilized for representation of coordinate geometry and survey elements 
when visualization is utilized during an active coordinate geometry session as well as the scale in 
which these elements will be displayed. 

By pressing the COGO Preferences button, the following dialog box is invoked. 

 

The Job (GPK) Directory field specifies the location of the GPK file.  Since multiple people can read 
and write the GPK file simultaneously, it is possible to have this file on a server or in a shared folder.  
If any of the above directory fields are blank, they will default to the Working Directory set in the 
GEOPAK User preferences dialog box. 
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LAB 1:  User Preferences 
Define Design Preferences 

Step 1. Execute C:\data\geo\vdot\PlansPrep\LAB1.EXE.  

 Note: Make sure you accept the path and unzip the files to C:\. 

Step 2. Open the MicroStation file C:\data\geo\vdot\PlansPrep\d17682des.dgn 

Step 3. Access the GEOPAK User Preferences dialog box from the Applications pulldown.  
Applications > GEOPAK Road > User Preferences. 

 The User Preferences dialog box appears as shown. 

 

Step 4. Click the Feature Preferences button and set the Plot Scale to 100 as shown and toggle 
on Apply Best Match Feature. 

 

Step 5. Click OK. 

Step 6. On the GEOPAK User Preferences dialog box, click OK. 

Step 7.  Exit MicroStation. 
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Project Manager 
2.1   Introduction 
Objectives Learn how to set up a project using Project Manager. 

Learn how to utilize Project Manager as a workflow guide. 
Learn how to access GEOPAK dialog boxes from the Project Manager. 

Menu Bar Application Applications > GEOPAK Road > Project Manager 

Road Tool Frame 

  
 

Project Manager is a GEOPAK tool that associates a project with its respective coordinate geometry 
job number, users, working directories and project files.  Project Manager provides the user with an 
easy workflow system that keeps records of processes run throughout the design of a project. 

2.2   Accessing Project Manager 
To access Project Manager, select Applications > 
GEOPAK Road > Project Manager or click the Project 
Manager icon.  The adjacent dialog box appears. 

The current directory is displayed at the top of the dialog  
box.  This may be modified by traversing to a different 
directory in the Directories list box.  Project files (.prj) are 
displayed in the projects list box.   

The remainder of the Project Manager dialog box displays 
information after a project has been selected from the 
Projects list box.  At the bottom of the dialog box are the 
OK and Cancel buttons.  To exit Project Manager, click 
the Cancel button.  To continue in the Project Manager 
process, click the OK button. 

 

2.3   Project Manager Menu Bar 
There are three options on the Menu Bar: Projects, Directory and Admin.  Each of these choices 
has tools contained in the pull down. 

2.3.1   Project Tools 
There are four options under the Projects pull down, New, Edit, Delete and Exit as shown below. 

GEOPAK 2004 Edition Project Manager    2-1 



GEOPAK®__________________________________________________________  

 

The New menu option is used to create a new project.  The .prj file is stored in the directory shown in 
the Directory path at the top of the Project Manager dialog box.  When the New menu option is 
selected, the following Create New Project dialog box appears. 

 

The Project Name can be any number of alphanumeric characters.  The Working Directory 
specifies the location of the project data files and may be manually entered.  In lieu of typing, the 
Select button may be clicked and the appropriate directory selected.  

The Working Directory can be left blank if it is desired to have all of the MicroStation and GEOPAK 
files in a single directory. 

The next field is for keying in the COGO Job Number or the Select button may be clicked and the 
appropriate COGO job number selected. 
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Next, the Preferences button should be clicked, invoking the Project Preferences dialog box.  

 

The user may click on COGO Preferences, then set the particular parameters for each project as well 
as the directories for the COGO job number, COGO input files and COGO output files.  By setting 
these parameters for each project, the user can open a design file in one directory and then open 
another design file in a different directory and still access the correct .gpk file and also save Cogo 
input and output files to the proper directory.  The user simply chooses the project and all parameters 
are automatically set.  After all the information is entered, the OK button is clicked or if the user 
wishes to abort, the Cancel button may be clicked.   

 

NOTE:  If these fields are left blank, the project working directory is used. 

 

Shown below is a sample project that includes a project description, which may be keyed in at the 
bottom of the Create New Project dialog box or added later by accessing it from the Edit menu. 

 

The Edit option on the pull down menu is used to change any settings associated with the currently 
selected project. 

The Delete option on the pull down menu is used to delete any project that has been stored.  The 
user highlights the project in the Projects list box and selects Delete. 

The Exit option on the pull down menu closes the Project Manager and writes the settings to a 
resource file. 
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2.3.2   Directory Tools 
There are two options under the Directory pull down, Create New Directory and Current Working 
Directory as shown. 

 

The Create New Directory option creates a new directory on your computer within the current 
directory.  If the Current Working Directory option is chosen, the directory path in Project Manager 
is changed to that directory.  

2.3.3   Administration Tools 
The Administration menu option is used to set a password on a project, if desired.  

 

2.4   Project Users Dialog Box 
Once a project is highlighted and OK is selected, the Project Users dialog box appears. 

 

This dialog box has three sections: Project Users, User Info and Description.  The Project Users 
list displays a list of users that have been created to work with any project that resides in the current 
projects home directory.  The names shown in Project Users will be the user id’s of the people 
working on that project as specified in the Start Job dialog box.  Within the User Info group box, the 
Full Name field further identifies the user, and displays the full name of the user that is currently 
selected.  The OP Code field displays the Geopak Operator Code of the currently selected user.  The 
Geopak Operator Code is used for all coordinate geometry operations during this session.  The 
Operator Code, along with the Job Number will be utilized whenever a COGO input or output file is 
created by the software.  The Operator Code is typically the user’s initials.  The Description field 
displays the description of the currently selected user. 

Four tools are supported on the Project Users pulldown as depicted in the exploded view below.  
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New The New pull down menu option creates new users.  This option will create 
users only for the selected project. 

Edit Enables the user to change any of the parameters of the currently selected 
user.  (Note: The User cannot be changed.)  This changes the user 
information for the current project only. 

Delete Deletes the highlighted user. 

Password Creates or modifies a password for the selected user.  If the selected user 
already has a password, the user will be prompted to enter the current 
password before continuing. 

Exit Closes the User Dialog box and returns back to the Project Manager dialog box.
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2.5   Road Project Dialog Box 
After a minimum of one user has been defined, click the OK button in the lower left corner of the 
Project Users dialog box or double click on a Project User, which opens the Project Manager dialog 
box. 

 

The top of the dialog box displays the Working Directory, Working Alignment (if defined), User 
and GEOPAK Job Number.  In addition, a toggle for Working Alignment Influence Runs is also 
supported.  The bottom portion of the dialog box displays the various processes supported during the 
design process.  The small square in the upper right corner will condense the dialog box as depicted 
in the graphic below.  

 

2-6    VDOT Plans Preparation Training GEOPAK 2004 Edition 



__________________________________________________________GEOPAK® 

2.5.1   Road Project Dialog Menu Bar 
There are two pull down menu bar options: File and Remember.  When the File option is 
selected, Close and Exit are supported.  

If the Close option is selected, the user is returned to the Applications dialog box.  If Exit 
is selected the user is exited from the Project Manager. 

 
When the Remember option is selected, the user can instruct the software to 
remember the Project, or User in subsequent sessions.  For example, if both 
toggles are activated, and the Project Manager is completely closed (all 
dialog boxes), the invocation of the Project Manager immediately invokes the 
Road Project dialog box (flow chart) and utilizes the project name and user 
name, which were active when the Remember toggles were selected.  

 

If only the Project toggle is activated, the user is returned to the Project Users dialog box in 
subsequent sessions.  This option is particularly useful when numerous users are working on one 
project.  

When the Auto Sink option is enabled, the Road Project flow chart 
sinks behind all open views when any tool is selected from the flow 
chart.  Once the tool is closed, the Road Project flow chart will be 
brought to the top of the view window. 

2.5.2   Working Alignment 
The concept of a working alignment enables the designer to organize a project and to access project 
information without continually typing the required information.  On a simple project, only one working 
alignment may be needed.  However, on a more complicated project, an unlimited number of working 
alignments may be defined.  With each working alignment, the designer can define associated data, 
i.e., name of cross section and plan view files, element symbology, etc.  The designer can easily 
change from one working alignment to another by highlighting the desired alignment listed in the 
Select dialog box.  Once the working alignment is selected, all previously stored data is utilized in 
subsequent processing.  Three tools relating to working alignments are located at the top of the Road 
Project dialog box: 

• Select Button 
• Define button 
• Working Alignment Influence Runs (toggle on left side of dialog box) 
 

 
The Port Viewer (covered in detail in Chapter 13 of the Road 1 Manual) is a tool that enables the 
user to view and manipulate all three major aspects of a road design simultaneously, even 
though they are located in different files.  The Port Viewer tool is only available while working 
within the Project Manager application.  
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2.5.2.1   Select Option 

 

When the Select button is clicked, the Select Working Alignment dialog box appears as depicted to 
the right.  If no working alignments have been defined, UNTITLED appears in the Run List box.  If 
working alignments have been defined, they are listed with the last run time.  The description of the 
working alignment can be seen in the bottom of the dialog box when each Name is highlighted.  To 
select a previously defined working alignment, highlight the run from the list, then click the OK button 
at the bottom of the dialog box.  Double clicking on the Name also selects a previous working 
alignment for subsequent processing.  Clicking the Cancel button will close the Select Run dialog 
box without any File selection.  Several Run options are supported as depicted in the exploded view 
below.   

 

These are detailed in the table below. 

New Create a new working alignment 

Copy Copy a run from an existing Project, a User in the same project or Run 
created by the current user. 

Modify Change the name of the existing working alignment. 

Delete Delete an existing working alignment. 
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2.5.2.2   Define Option 
Once a Run has been selected, clicking the Define button invokes the dialog box depicted below. 

 

The information that can be associated with a working alignment is listed in the left portion of the 
dialog box.  As each option is chosen, the right side of the dialog box will change to reflect the 
information needed as can be seen in the dialog box to the right after Profile View was selected.  

All information entered in these fields can be used in subsequent processes run from Project 
Manager.  In the beginning of a project, much of this information will not be known, but as the user 
goes through the design process, it can be added to the working alignment definitions.  

For example, as soon as a chain has been stored in COGO, the user can enter that information in the 
Plan View fields on the right side of the dialog box.  For a more complete explanation of each option 
shown, please see the GEOPAK Manual or On-Line Help. 

2.6   Project Manager Process 
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The primary Project Manager dialog box is depicted above.  The advantage of utilizing the Project 
Manager rather than selecting functions directly from the Road menu is that pertinent information 
stored within the Project Manager is automatically displayed within the invoked dialog box.  
Therefore, job numbers, chain names, stationing, file names and data associated with the project do 
not have to be typed in each time a dialog box is utilized.  However, if the user chooses to change the 
fields, they have that option. 

Many of the Project Manager processes function identically to their corresponding dialog boxes 
invocation from the Road menu.  However, some of the procedures invoke the Select Run dialog box 
prior to invoking the actual dialog box.  The Select Run dialog box enables the user to set up different 
options to use in alternative design choices or different typicals. 

2.7   Online Help 
More information can be found under Applications > GEOPAK Road > Help > Command 
Reference > Project Manager. 
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LAB 2:   Project Manager 
Introduction 

Step 1. Execute C:\data\geo\VDOT\PlansPrep\LAB2.EXE. 

Step 2. Open the MicroStation file C:\data\geo\VDOT\PlansPrep\d17682dtm.dgn 

Step 3. Invoke the Road Tools tool frame from the MicroStation menu bar by selecting 
Applications > GEOPAK Road > GEOPAK Road Tools. 

 

Step 4. Access Project Manager using the Project Manager icon from the Road Tools tool frame.  

 

Step 5. From the right side of the Project Manager dialog box, in the Directories list box, ensure 
that the project directory is set to: 

  C:\data\geo\VDOT\PlansPrep\  

  

You can navigate quickly to your current working directory by 
using the pulldown Directory > Current Working Directory. 

 

 Select the Projects > New pulldown and create a new project as defined in the table 
below: 

Project name: 17682 

Working Directory:  

Job Number: 101 

Project Description: GEOPAK Plans Preparation Course Project 
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 After filling out the dialog box as shown below, click Preferences. 

 
Step 6. Set the project preferences as shown in the dialog box below. Click OK when complete. 

 

Step 7. After exiting the Preferences dialog box, you will return to the Create New Project dialog 
box.  If everything here is satisfactory, click the OK button. An Alert message is 
displayed stating that Job 101 was not found in the Working Directory in which you 
defined.   

 

 Click Yes to automatically create this job file. 
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Step 8. The main Project Manager dialog box is now displayed and the project has been created 
and ready to be accessed.  To access the project, select the project by single clicking on 
name of the project in the dialog box.  The project is highlighted as shown in the dialog 
box with all pertinent information displayed.  

 

  Click OK to invoke the Project Users dialog box as shown in Step 9. 

Step 9. Create a new user by selecting Users > New from the Project User pull down menu bar. 
Complete the New User dialog box with the name and operator code as shown. 
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Step 10. After populating the dialog box click OK. When prompted to define a password for this 
user, click No. 

 

Step 11. At this point double click the user and you will now see the main Workflow dialog box. 

 

Step 12. Lastly, use the Remember option to have Project Manager remember our Project and 
User.  Enable the Autosink option. 

 

 

 

To create a project, contact the AES Help Desk. 
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2.2   Working Alignment 
Before leaving this exercise, let’s go ahead and begin to set the stage for further design via the 
Project Manager by defining the Working Alignment.  You will usually create a Working Alignment 
for each alignment on your project, but because of time constraints we’ll only do it for alignment 
MAINLINE on our sample project. 

To do this, we’ll need to use the Select and Define buttons on the Project Manager Workflow dialog 
box.  The Project Manager workflow dialog box should still be active (we ‘sank’ it earlier in the lab). 
Access the dialog box by selecting  Window > Road Project: 17682.prj from the MicroStation menu 
bar. 

Step 1. Click the Select button to create a new Working Alignment.  The Working Alignment is 
the active chain that we are designing for. 

 

Step 2. Create a new Working Alignment called MAINLINE as shown below and click OK. 
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Step 3. After creating the run, select the run by highlighting it in the dialog box and clicking OK. 

 

Step 4. You will now return to the main Workflow dialog box.  Click the Define button to access 
the Working Alignment Definition dialog box. 

Step 5. Select the DTM item in the list box and complete the DTM definitions as shown below: 

 

Step 6. Click OK to exit the Working Alignment Definition dialog box. 

Step 7. Exit MicroStation. 
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Coordinate Geometry 
3.1   Introduction 
Objectives Learn to set up and access the coordinate geometry database file. Become 

proficient in using GEOPAK Coordinate Geometry. 

Project Manager Coordinate Geometry 

Tool 

  

Menu Bar Application GEOPAK Road > Geometry > Coordinate Geometry 

The Coordinate Geometry database file (*.GPK file) is comprised of stored geometric elements such 
as points, lines, curves, spirals, chains, parcels and profiles.  When COGO calculations are 
completed, the results are stored in the binary database file, which is then utilized throughout the 
design process with many other applications. 

3.2   Accessing COGO 
When Coordinate Geometry is started, the Start-Up Dialog box appears. 

 

The fields in the Start-Up dialog box are detailed below. 

Project Name Name displayed on reports.  This is an optional entry, with a maximum of 
60 alphanumeric characters.  If Project Manager is active, this field is 
populated automatically. 

Job Number Identifies coordinate geometry database file and is a required field. The job 
number is a maximum of three alphanumeric characters.  If Project 
Manager is active, this field populated automatically. This field is required. 

Operator Code Unique 2-character code which enables multiple users access to database 
file.  The user’s initials are suggested.  Note this field is not required for 
single user access, but highly recommended.  If Project Manager is active, 
this field is populated automatically. 

Subject Description of coordinate geometry work (could relate to the project) with a 
maximum of 48 alphanumeric characters.   
This field is optional. 

After the dialog box is populated, and the OK button is clicked, the main coordinate geometry dialog 
box is invoked. 
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3.3   Coordinate Geometry   

 

The coordinate geometry dialog box is made up of three separate display areas: 

• Tool Bar (1) consisting of drop down options and icons.  The display of specific icons is 
customizable. 

• COGO Key-in (2) this field enables manual entry of COGO commands.  The drop down 
button allows for a history of commands to be reviewed. 

• Output Display Window (3) shows the results generated by the commands. 
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3.3.1   File Commands 

 
The File commands (as displayed in the exploded view above) are detailed in the table below. 

File Utility This option opens another dialog box that contains a group of file utilities that will be 
explained later 

File Restore Loads an ASCII file of GEOPAK commands into the display window.  Note no processing 
occurs.  The file must be named j101ovd.inp, where 101 is the current job number and 
vd is the operator code. 

Import  Imports horizontal and vertical alignments and points from RDS and SDMS format into the 
GEOPAK .gpk file. 

Export  Exports GEOPAK points, chains and profiles into formats for use in various data 
collectors.  

Exit Closes the COGO dialog box and ends the coordinate geometry session. A prompt to 
save the session appears. Yes saves the audit trail, No exits without saving, Cancel 
returns to the COGO session. Whether you pick Yes or No everything you did is still 
saved in the .gpk file. 
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3.3.2 File Utility 
The File Utility option invokes the following dialog box. 

 

 
Load When selected, a menu appears listing all saved input files. Highlight a file, then click 

the OK button. The input lines from the highlighted file are now displayed in the 
display window for viewing, editing, or processing. 

Append This command is for input files only. A new input file is created by copying the 
contents of an existing input file to the end of the current input file.  The Save 
command must be used in order to store this new file. 

Catalog When selected, a menu appears listing all saved input files (under the current 
operator code) in the project directory.  This is for reference only no action is taken. 

Delete When selected, a menu appears listing all saved input files. Highlight a file, then click 
the OK button to remove this file from your project directory.  Although the file is 
deleted, the elements stored as a result of processing the commands are not deleted. 

Output  Writes an ASCII file of the current display for reviewing and / or printing. 
(Fname999.ooc, where 999 is the current job number and oc is the operator code). 

Print Input File Sends your input file to the printer. 

Print Output File Sends your output file to the printer. 

Save Saves the current audit trail to a file. (Fname999.ioc, where 999 is the current job 
number and oc is the operator code.). 

Allow Commands 
to be Added 

When this is toggled on, COGO commands are added to a previously loaded file. 
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3.3.3   Edit Commands 

 
The Edit commands (as displayed in the exploded view above) are detailed in the table below. 

Clear Empties the memory of the current audit trail without saving and initializes the line 
numbers to begin a new sequence of commands.  Note this does not clear the display 
window. 

Delete Deletes input commands in the input buffer by line number (or range of line numbers) and 
re-sequences the line numbers for the remaining commands. 

Editor Opens the GEOPAK COGO Command Editor, which enables the user to edit the current 
input file. 

Insert  Adds a command line to the current input buffer before a specified line number; 
subsequent command lines shift down and line numbering is automatically re-sequenced. 

Modify  Changes a fragment in a command line. The modified command line is not processed 
until a Read command is performed. 

Read All Processes the specified lines in the audit trail. This may be done for the entire file (All) or 
by specifying a range of line numbers (Line Range). 

Type All Displays the content of the audit trail, (All) or a portion of the audit trail by specifying a 
range of line numbers (Line Range). 

Line Range Allows you to specify a beginning line number and ending line number. This range of lines 
can then be either “read” into COGO or just typed/listed in the display window. 

Editor Opens the COGO Command Editor, which enables the user to edit the current input file. 
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3.3.4   Element Commands 
The mainstay of GEOPAK Coordinate Geometry are the various element commands.  Tools are 
supported for storing, stationing, adding additional data, deleting, etc.  GEOPAK supports a wide 
variety of elements:  points, curves, spirals, chains or alignments, parcels, and profiles.  Each 
element is detailed below. 

3.3.4.1   Element > Point 

 

One of the most utilized sets of COGO tools are the point commands, as detailed in the table below. 

Utility Opens the Point Utility dialog box where the following options are available. 

Delete - Deletes a point number (or range of numbers) from the database file. 

Print - Displays the selected point numbers x, y, z coordinates, station value and other 
stored information in the display output window. 

Display - Visualizes the selected point numbers currently stored in the GPK file 
(Temporary Visualization or Permanent Visualization must be turned on). 

Cell Assigns a cell name to a previously stored point. This point and associated cell can 
then be plotted later through D&C Manager. 

Copy Copies points or a point range to a new point number or range within the same 
GEOPAK database file 

Elevation Assigns an elevation to a previously stored point 

Equate Stores a new point with the same values as a previously stored point 

Station Adds a station to a previously stored point. 
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Store Stores a point by key-in coordinates or by 
selecting a location graphically.  A station, 
elevation, point code, cell, feature, or 
description can be optionally stored with the 
point. 

  
Transformation Performs coordinate transformations based on user-defined control pairings 

Compare Points 
to TIN 

Utilizing a set of COGO points (with elevations) compares the COGO elevation to the 
TIN elevation and completes statistical analysis for "goodness of fit." 

Set Elevation 
from TIN 

Utilizing this command, GEOPAK adds or updates an elevation to a previously defined 
point, based on a TIN model. 

3.3.4.2   Element > Curve 

 

The Curve commands (as displayed above) are detailed in the table below. 

Utility Opens the Curve Utility dialog box were the following options are available. 

Reverse – Reverses a previously stored curves direction. 

Delete - Deletes a curve (or range of curves) from the database file. 

Print - Displays the selected curves x, y, z coordinates, station value and other stored 
information in the display output window. 

Visualize - Visualizes the selected curves currently stored in the GPK file (Temporary 
Visualization or Permanent Visualization must be turned on). 

Copy Copies a specified curve to another curve name. 
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Data Calculates the geometric parameters of a curve, displaying values for Delta, Degree, 
Tangent, Length and Radius. 

Segment Defines new curves by dividing a stored curve into segments. 

Station By identifying a curve and a control point on the curve (PC, PI, or PT), a station value may 
be assigned. 

Store Provides various options for defining and storing lines and curves such as Store Curve 
By Tangents as shown below.  

 

3.3.4.3 Element > Spiral 

 

The Spiral commands (as displayed in the exploded view above) are detailed in the table below. 

Utility Opens the Spiral Utility dialog box where the following options are available. 

Delete - Deletes a spiral (or range of spirals) from the database file. 

List/Print - Displays the selected spirals x, y, z coordinates, station value and other 
stored information in the display output window. 

Visualize - Visualizes the selected spirals currently stored in the GPK file (Temporary 
Visualization or Permanent Visualization must be turned on). 

Copy Copies a specified spiral to another spiral name. 

Store Provides various options for defining and storing spirals. 
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3.3.4.4   Element > Chain 

 
The Chain (GEOPAK alignment) commands (as displayed in the exploded view above) are detailed 
in the table below. 

Utility Opens the Chain Utility dialog box where the following options are available. 

Area - Calculates the area of a closed chain. 

Delete - Deletes a chain (or range of chains) from the database file.   

Print - Displays the name of each element in the selected chains. 

Describe - Displays the alignment data of each element in the selected chains. 

Visualize - Visualizes the selected spirals currently stored in the GPK file (Temporary 
Visualization or Permanent Visualization must be turned on). 

Layout Offset Project points onto a chain or compute offset distance and direction between two chains 
at each control point or at user defined intervals of a specified station range. 

Station Provides a method for stationing or re-stationing a chain. 
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Station Equation  Provides a method for applying a station equation to a chain. 

Store Provides three options for storing a chain in the database file, From Elements, Store 
Offset Chain and Store Transition Chain.  The Store Chain From Elements dialog 
box is shown below.  (Chain name can be between 1-9 alphanumeric characters)  

 

3.3.4.5   Element > Parcel 

 

The Parcel commands (as displayed in the exploded view above) are detailed in the table below. 

Utility Opens the Parcel Utility dialog box where the following options are available. 

Delete - Deletes a parcel (or range of parcels) from the database file.   

Print - Displays the elements of composition, the area of tract stored, taken and remaining. 

Describe - Displays the elements of composition, the area of tract stored, taken and remaining 
and a point, bearing, distance description of the specified tract. 

Visualize - Visualizes the selected parcels currently stored in the GPK file (Temporary 
Visualization or Permanent Visualization must be turned on). 

Store Stores a parcel by adding points, curves and spirals. 

Subdivide Divides a parcel into individual lots. 

Editor Edits a parcel. 
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3.3.4.6   Parcel Commands (Manual Entry) 
Several parcel commands are supported only by manual entry and have no associated dialog boxes. 

Store Taken Store the portion of a parcel taken by entering point and curve names in either a 
clockwise or counterclockwise direction. 

Store 
Easement  

Store easements by entering point and curve names in either a clockwise or 
counterclockwise direction. 

Own Parcel  Stores the names of the owners associated with previously stored parcels.  

Make Legal  Creates a metes and bounds description and writes it to a user named text file. See also 
Legal Description Editor for the ability to create detailed and customizable legal 
descriptions. 

 

3.3.4.7   Element > Profile 

 
The Profile commands (as displayed in the exploded view above) are detailed in the table below.  
Note additional commands are supported as keyin only commands.   

Utility Opens the Profile Utility dialog box where the following options are available. 

Delete - Deletes a profile (or range of profiles) from the database file.   

Print - Displays the data of the selected profile from the database file. 

Elevation Provides three options for reporting elevations along a selected profile, Station, Even Station, 
Incremental Stations. 

Offset Stores a new profile within a specified Station Range at a defined vertical offset from the original 
profile. 

Restation Creates a new profile with different stationing from a previously stored profile. 
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3.3.5   View Commands 

 
The View commands (as displayed in the exploded view above) are detailed in the table below. 

Icons Enables the user to customize which icons appear in the tool bar. 

Redefine Displays the Redefine box on the tool bar. 

Visualization Displays the visualization items on the tool bar. 

Format Displays the format items (i.e. number of decimals, station format, etc.) on the tool bar. 

COGO Key-in Displays the COGO Key-in box for entering commands in the dialog box. 

Command 
Output 

Displays the Command Output Window in the dialog box, and controls options for the 
Command Output Window.  The Command output window can also be saved to a text 
file in lieu of using the File > Output command. 

Error Alert Enables the user to activate a beep and/or restore a minimized COGO dialog box when 
an error occurs. 

3.3.6   Tools Commands 

 

The Tools commands are detailed in the table below. 

Navigator Invokes the COGO Navigator.  See Section 3.4. 
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Inverse Calculates the distance and direction between points.   

Locate Stores a point or series of points not by specifying coordinates, but based on 
a previously stored point using several methods.  To locate a point by 
distance and bearing, use the Tools > Locate > Traverse as depicted in the 
dialog box below. 

 

Intersect  Stores a point at the intersection of any two COGO elements. 

 

Best Fit  Calculates a best-fit chain through a set of points. 

Translation and Rotation  Moves, rotates, and scales a data set. 

Map Check  Edits a parcel. 

Roadway Intersections Calculates data for the intersection of two COGO elements, usually chains. 

Cul-de-sacs  Calculates data for a cul-de-sac. 

Redraw Visualized 
Elements  

Re-syncs the visualized COGO elements in the MicroStation file with the 
coordinate geometry data. 
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Clear Visualized Elements 
(Temporary)  

Removes all temporary visualized elements from the view. 

Clear Visualized Elements 
(All)  

Clears all temporary and permanent visualized elements from the 
Microstation file. 

 

3.3.7   User Preferences 

 

The User Preferences (as displayed in the exploded view above) are detailed in the table below. 

Dialog Allows access to COGO Preferences dialog box. 

Redefinition of Elements Toggles the Redefine option on/off.  If Redefine is on, COGO data can be 
redefined/overwritten. 

Visualization Enables the elements to be displayed in the MicroStation file permanently, 
temporarily, or not at all. 

Coordinate Display Toggles between displaying NE or XY coordinates. 

Angle Display Toggles between displaying Bearing or Azimuth. 
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3.4   COGO Navigator 
Feature / Function View, edit and display COGO elements. 

Tools 
 

COGO Menu Bar Tools > Navigator 

 

The COGO Navigator is a tool utilized to easily view and edit COGO data. Store, delete, edit, print 
elements, plus visualization and selection set commands are easily accessible via the Navigator. The 
Navigator can be accessed by the pull down menu COGO > Tools > Navigator or by the Navigator 
icon.  The following dialog box opens. 

 

From the Navigator, points, curves, spirals, chains, survey chains, parcels, and profiles  (all COGO 
elements contained in the coordinate geometry database file; *.gpk) can be added, deleted, modified, 
identified, visualized, printed, or selected. 
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3.4.1   Navigator > Select Tools 
A variety of selection tools can be invoked via the Select pulldown, as depicted in the exploded view 
below. 

 

The Select tools are detailed in the table below. 

Select All Selects all data items of a certain type.  (i.e. all points) 

Invert Selection Selects all items not previously selected, and unselects all items previously 
selected. 

Clear Selection Unselects all items. 

Selection Set Allows the user to create a selection set that meets particular criteria.  
Same as using the Selection Set icon 

Fit View (Selection Set) Fits the selected items to the active MicroStation window. 

Show Selected Elements 
Only 

Only the items in the selection set are displayed in the MicroStation 
window. 

Show All Elements All items in database file are displayed in the MicroStation window. 
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3.4.2   Navigator > Tools 
A variety of tools can be invoked via the Tools pulldown, as depicted in the exploded view below.  
Many can also be invoked via the shortcut icons displayed at the top of the Navigator. 

 

Add Element 

 

Enables the selected type of element to be stored.  When selected, the 
appropriate Store Element dialog box is invoked. 

Delete Element 

 

Deletes the highlighted element. 

Edit Element 

 

Invokes the appropriate Store Element dialog box, populated with the 
associated data of the selected element for editing. 

Identify Element 

 

When clicked and a COGO element is graphically selected, the element is 
highlighted in the display field.  If the selected element is not the displayed 
element type (i.e., curve or point), the element type is also changed.   

Print/Describe Element 

 

Displays the selected element’s data. 

Edit Element Feature Changes the feature code of the element. 

Visualize Element 

 

Displays the selected elements according to their feature code or default 
symbology. 

Unvisualize Element Removes display of  selected elements. 

Visualize All Displays all of the elements of a certain type, or all elements. 

Redraw Visualized 
Elements 

Re-syncs the coordinate geometry data with the data displayed in the 
MicroStation file. 

Clear Visualized 
Elements (Temporary) 

Clears only temporary visualized elements from the view. 

Clear Visualized 
Elements (All) 

Clears all visualized elements from the MicroStation file. 
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Settings Enables the user to define certain actions and behaviors of the Navigator. 
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LAB 3:   Coordinate Geometry 
3.1   Accessing COGO 

Step 1.  Execute C:\data\geo\VDOT\PlansPrep\LAB3.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\PlansPrep\d17682des.dgn. 

 Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 3. Select the Coordinate Geometry icon from the Road Project: 17682.prj workflow dialog 
box. 

 The following COGO dialog box opens.  

 

  This dialog box is completely re-sizable, so you can position it where you’re most 
comfortable. 
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3.2   Store Geometry 
Our course project has 3 alignments. We’ll store two of them using Coordinate Geometry. The first 
alignment will be called MAINLINE and is shown below: 
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3.2.1   Store Points 
Step 1. Select the visualization option Permanent Visualization on the main COGO dialog box. 

Step 2. Access the Store Point dialog box by pressing the Store Point icon 

   

  or using the Element > Point > Store pulldown. 

 

Step 3. To store point D500, manually enter the point number and coordinates as indicated in the 
dialog box below. Activate the Auto Increment toggle which will automatically increment 
the point number by 1 for subsequent Store Point commands. 

 

Step 4. Press the Store Point button to store the point into the COGO database. 

Step 5. Continue storing points D501-D503 by utilizing the coordinates shown on the alignment 
diagram. When complete, exit the Store Point dialog box by pressing the “X” in the upper 
right hand corner. 
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Note that the following point naming conventions should be followed: 
Design – All points should begin with D (e.g. D501, D502, etc.). 
Hydraulic – All points should begin with H (e.g. H501, H502, etc.) 
Survey – All points should begin with S (e.g. S501, S502, etc.) 
Traffic – All points should begin with T (e.g. T501, T502, etc.) 
Right of Way – All points should begin with R (e.g. R501, R502, etc.) 
Environmental – All points should begin with E (e.g. E501, E502, etc.) 
Utilities - All points should begin with U (e.g. U501, U502, etc.) 

 

3.2.2   Store Curves 
Step 1. Access the Store Curve from Tangents dialog box by pressing the Store Curve from 

Tangents icon 

  

 or select Elements > Curve > Store > By Tangents from the COGO menu bar. 

Step 2. To store Curve ML-1, complete the dialog box as shown below and press Store Curve. 

 

NOTE: Pressing the “picture” buttons allows you to select from multiple 
methods of defining the Back and Ahead Tangents 

 

DB:  D500 To D501 

Step 3. To store Curve ML-2, complete the dialog box as shown below and press Store Curve. 

 

NOTE: Visualized points may be selected to complete any field that 
requires defined points or directions. 
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DB:  D501 To D502 

Step 4. Dismiss the Store Curve from Tangents dialog box by pressing the “X” in the upper right 
hand corner. 

3.2.3   Store Chain 
Step 1. Invoke the Store Chain From Elements dialog box by pressing the Store Chain From 

Elements icon 

  

 or select Element > Chain > Store > From Elements from the COGO menu bar. 

Step 2. Fill in the dialog box as shown below. 

 

 

NOTE: You can enter the elements manually or select the visualized 
elements graphically in order to fill in the dialog box. 

 

Step 3. Press Store Chain and dismiss the Store Chain dialog box. The chain MAINLINE should 
be visualized in the design file. 

GEOPAK 2004 Edition LAB 3:   Coordinate Geometry    3-23 



GEOPAK®__________________________________________________________  

3.2.4   Describe Chain 
From the COGO dialog window, let’s preview the geometry of the chain we just stored. 

Step 1. Select the COGO Navigator icon 

  

 or use the Tools > Navigator option on the 
COGO menu bar to access the COGO Navigator 
dialog box. 

Step 2. Set the element option to Chain and highlight the 
chain MAINLINE. 

Step 3. Press the “Print/Describe Element” icon. 

 

 

Step 4. The chain geometry output will be displayed in the main COGO window. 

 

Step 5.  Dismiss the COGO Navigator dialog box by clicking the “X” in the upper right hand 
corner. 
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4.2.5 Create Input and Output Files 
In the following steps we will save an input trail of our commands and an output file with the 
computations of chain MAINLINE. 

Step 1. Access the File Utility dialog by pressing the File Utility icon 

 

or by selecting File > File Utility.  The dialog box below should appear. 

  

Step 2. On the File Utility dialog box, set the option button to Save. 

 

Step 3. Enter “ML” for the Name and “Chain MAINLINE” for the Subject then click Apply. The 
saved file will be called ‘ML101.ivd’ 
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Step 4. To save an output file with the actual results of the computations, set the option button to 
Output on the File Utility dialog.   

 

Step 5. Output File should be set to “ML”.  Click Apply.  The saved file will be called 
‘ML101.ovd’. 

Step 6. Dismiss the File Utility dialog by clicking the X in the upper right hand corner. 
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3.3   Working Alignment 
Now that we have our alignment, we have another piece of information for the Working Alignment 
definition.  

Step 1. Access the Project Manager Road workflow dialog box. 

Step 2. Click the Define button to access the Working Alignment Definition dialog box. 

Step 3.  Highlight the Plan View option and use the File and Select buttons to populate the 
Design File and Chain fields as shown: 

 

Step 4. Click OK. 

3.4   Store Another Alignment 
Using the same general steps we learned in storing the previous alignment, use the diagram below to 
store another chain ‘EBL460’. The beginning station of the chain will be 107+00. 

 

 

Save an input trail of your commands. 
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Exit COGO.  

Exit MicroStation. 
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Graphical COGO 
4.1   Introduction 
Objectives Create and store COGO elements using Graphical Coordinate Geometry 

tools 

Project Manager Coordinate Geometry 

Tool 

 
 

Menu Bar Application GEOPAK Road > Geometry > Graphical Coordinate Geometry 

 

Graphical Coordinate Geometry is a tool that allows the user the ability to store coordinate 
geometry elements into the COGO database (GPK file) graphically.  Points, curves, lines, spirals, 
chains, and parcels can be stored, modified, or deleted.   The COGO elements can be manipulated 
by key-in or a click of the mouse and are stored directly into the COGO database. 

 

Note:  Graphical Coordinate Geometry does not read the exclusive MicroStation 
graphics. 

 

 

NOTE:  When Graphical COGO is invoked, a session of COGO will be started 
automatically. 

 

When Graphical COGO is selected, the main COGO dialog box will appear as below. 
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4.2   Store Elements 
The Store Elements tool box contains eleven icons. 

 

As elements are stored, the visualization parameters in the SMD file (as defined in the user 
parameters) are utilized.  This assumes that the temporary or permanent visualization is activated.  If 
no visualization is active, no elements are visualized. 

When a Store Element command is selected, a sub pallet will appear to allow the user to enter data if 
necessary as depicted below. 

 

The Store Elements commands are detailed in the table below. 

 
Store Point 

The Store Point tool enables the user to store points utilizing Cartesian coordinates (x, y, z 
or N, E, Z) or Curvilinear (station, offset, elevation). 

 
Store Equally Spaced Points 

The Store Equally Spaced Points stores a user-defined number of  points between two 
previously defined points or any two data points.  A line drawn between the two previously 
defined points is not necessary.   

 
Locate Point 

The Locate Point command stores a point based on the distance and direction from a 
previously defined visualized point. 

 
Store Line From Existing Points 

The Store Line from Existing Points utilizes two previously stored points to store a line.   

 
Store Line By 2 Points 

In contrast to the Store Line by Existing Points, the store line by two points command 
requires two new points, rather than existing points.  The command stores the line and the 
new points, utilizing the "next" available point and line names. 

4-2    VDOT Plans Preparation Training GEOPAK 2004 Edition 



__________________________________________________________GEOPAK® 

 

 
Store Tangent Line 

The Store Line Tangent To Element tool stores a line and its two endpoints in the 
coordinate geometry database. 

 
Store Curve By 3 Points 

The Store Circular Curve by Three Points tool stores a circular curve (using chord 
definition).  The stationing is set to 0+00 at the P.C.  The Radius can be manually typed in 
or defined dynamically. 

 
Store Curve By Center 

This tool enables the user to store a circular curve by defining the center point, radius, and 
sweep angle. 

 
Store Tangent Curve Constrained 

The Store a Constrained Tangent Curve tool places a curve tangent to the specified curve 
or line. 

 
Store Tangent Curve Unconstrained 

The Store an Unconstrained Tangent Curve tool places a curve through a specified point 
tangent to the specified curve or line. 

 
Store Tangent Spiral 

The Store Transition Spiral tool quickly places and visually modifies spirals based on an 
initial line or curve. 

4.3   Modify Elements 

 

When a Modify command is selected, a sub pallet will appear to allow the user to enter data if 
necessary as depicted below. 
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The Modify Elements commands are detailed in the table below. 

 
Partial Delete 

The Partial Delete tool enables the user to delete part of a COGO line or curve, creating 
two separate elements. 

 
Extend Plan View Element 

The Extend Plan View Element tool can extend or shorten any COGO element. 

 
Trim Elements 

The Trim Elements tool trims numerous elements to their intersection with another 
element. 

 
Intersect Elements 

The Compute Intersection of Two Element tool stores a new point by trimming or 
extending one element to its intersection with another element.  Note the two elements 
remain intact. 

 
Extend Element to Intersect 

The Lengthen or Shorten an Element tool works functionally the same as its MicroStation 
counterpart. 

 
Extend Elements to Intersect 

The Lengthen or Shorten Both Elements tool works functionally the same as its 
MicroStation counterpart. 

 
Construct Circular Fillet 

The Construct a Fillet Between Two Elements tool works functionally the same as its 
MicroStation counterpart and stores a circular curve between two elements. 

 
Construct Chamfer 

The Construct a Chamfer Between Two Elements tool works functionally the same as its 
MicroStation counterpart and stores a line between two elements.  Both the line and two 
new endpoints are stored in coordinate geometry. 

 
Cut Element 

The Cut Elements into Smaller Elements tool cuts elements into segments. 
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4.4   Manipulate Elements 

 

When a Manipulate command is selected, a sub pallet will appear to allow the user to enter data if 
necessary as depicted below. 

 

The Manipulate Elements commands are detailed in the table below. 

 
Move Plan View Element 

The Move a Plan View Element enables the user to move an element or to make copies. 

 
Rotate Plan View Element 

The Rotate Plan View Element rotates the selected element about a user-defined point.  
The Angle may be manually entered and locked, or dynamically changing. 

 
Copy Parallel 

The Copy Parallel tool works functionally the same as its MicroStation counterpart. 

 
Delete Element 

When using the Delete Element tool, no tool settings dialog box opens. 
Select and accept the element to be deleted.  The element is removed from the 
coordinate geometry database.  This tool works with a MicroStation selection set if 
present.  Warning:  there is no undo for this command. 
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4.5   Groups 

 

When a Group command is selected, the Tool Settings opens to allow the user to enter data if 
necessary as depicted below. 

 

The Groups Commands are detailed in the table below. 

 
Store Chain 

The Store Chain command works in the same manner as the MicroStation Automatic 
Create Complex Chain with the additional benefit that the chain is automatically stored in 
the COGO database. 

 
Store Parcel 

The Store Parcel tool enables the user to store parcels, takings, easements, and other 
types of right of way features.  It is very similar to the Store Chain tool with many of the 
same options. 
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LAB 4:   Store a Chain with Graphical COGO 
4.1   Create Chain REDBUD Using Graphical COGO 

Step 1. Execute C:\data\geo\VDOT\PlansPrep\LAB4.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\PlansPrep\d17682des.dgn.   

 Access the Saved View (Utilities > Saved Views) named “REDBUD”. 

 Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

In the following steps, we’re going to store a chain (REDBUD) that will look similar to the following: 

 

 

Step 3. Access Graphical COGO from the Road Tool Palette using the icon shown below 

 

or you can access it using the Applications > Road > Geometry > Graphical 
Coordinate Geometry pulldown. The tool frame depicted below will activate. 

 

Step 4. Ensure that Permanent Visualization is set on the COGO dialog box and then sink it. 
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Step 5. Access the Store Point tool in Graphical COGO and fill out the dialog box as shown: 

 

 

 After filling out the dialog box, you’ll notice the point is visualized (represented by a circle) 
in the dgn file. Issue a DP anywhere in the dgn file to accept the location of the point. 

Step 6. Access the COGO Window and review the output. Notice that point D700 was stored into 
COGO. 

  

Step 7. Next, access the Locate Point dialog box and fill out as shown: 

 

 Note: The directional bearing is N 49 04 17.00 E. 
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 With your cursor, ID point D700 that was visualized in Step 5. Issue a second DP 
anywhere in the dgn file to validate the location of point D701. Point D700 and Line L1 
will be visualized in the design file and stored into COGO. 

 NOTE: The correct location for our project is to the northeast of the chain Mainline. 

Step 8. Access the Store Tangent Curve Constrained dialog box and fill out as shown: 

 

 With your cursor, ID the line that was visualized in the previous step. 

 Issue a second DP to accept the line. 

 Issue a third DP to identify the direction of the curve. 

 Issue a fourth DP to validate the solution and store the curve. 

 

Step 9. Access the Locate Point dialog box once again and fill out as shown: 

    

 Note: The directional bearing is N 7 45 23.31 W. 

 With your cursor, ID the visualized PT point of the curve. 

 Issue a second DP to validate the solution and store the point. 
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Step 10. Access the Store Chain dialog box and fill out as shown: 

 

 With your cursor, ID the visualized line running between points D700 and D701. 

 Issue a second DP to accept the line. 

 Issue a third DP to accept the direction of the chain and store it into COGO. 

Step 11. Dismiss the Graphical COGO dialog box. Review the output in COGO and notice the 
chain REDBUD has been stored into COGO. 
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4.2 Describe Chain 
From the COGO dialog window, let’s preview the geometry of the chain we just stored. 

Step 1. Select the COGO Navigator icon 

  

 or use the Tools > Navigator option on the 
COGO menu bar to access the COGO Navigator 
dialog box. 

Step 2. Set the element option to Chain and highlight the 
chain REDBUD. 

Step 3. Press the “Print/Describe Element” icon. 

 

 

Step 4. The chain geometry output will be displayed in the main COGO window. 

 

Step 5.  Dismiss the COGO Navigator dialog box by clicking the “X” in the upper right hand 
corner. 
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4.3 Create Input and Output Files 
In the following steps we will save an input trail of our commands and an output file with the 
computations of chain REDBUB. 

Step 1. Access the File Utility dialog by pressing the File Utility icon 

 

or by selecting File > File Utility.  The dialog box below should appear. 

  

Step 2. On the File Utility dialog box, set the option button to Save. 

 

Step 3. Enter “RED” for the Name and “Chain REDBUD” for the Subject then click Apply. The 
saved file will be called ‘RED101.ivd’ 
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Step 4. To save an output file with the actual results of the computations, set the option button to 
Output on the File Utility dialog.   

 

Step 5. Output File should be set to “RED”.  Click Apply.  The saved file will be called 
‘RED101.ovd’. 

Step 6. Dismiss the File Utility dialog box by clicking the “X” in the upper right hand corner. 

Step 7. Clear all the visualized elements from the file using the Tools > Clear Visualized 
Elements (ALL) pulldown.  

 

Step 8. Dismiss the COGO dialog box by clicking the “X” in the upper right hand corner. 

Step 9. Exit MicroStation. 
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Design and Computation Manager 
5.1   Introduction 
Objectives Understand the use of the D&C Manager to plot horizontal alignments into 

MicroStation.  
Understand the format of the hierarchical database and how to use it. 
Be able to use the D&C Manager in conjunction with other GEOPAK tools & 
MicroStation to draw and manipulate elements. 

Project Manager Plan View Design 

Road Tool Frame  

                     

Menu Bar Application GEOPAK Road > Design and Computation Manager 
GEOPAK Road > Plans Preparation > DP Station Offset 
GEPAK Road > Plans Preparation > Draw Transition 

 

The Design and Computation Manager (D&C Manager) is a tool that allows the user to standardize 
graphics elements for drafting and pay item quantities. 

A hierarchical database is used with the Design and Computation Manager. This database stores 
information concerning functional classification and display preferences for each feature and item 
used in a MicroStation file. This file is commonly referred to as the ddb file (*.ddb). 

Categories are used to group and classify the features and items used in creating construction 
drawings.  In the example below, Road Design and Right of Way are both categories.  Categories 
are represented with a folder icon. 
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These categories each may contain sub-categories.  The sub-categories break down each 
classification into more specific items.  For example, Traffic may be broken into several additional 
categories such as Existing and Proposed. 

 
Within a category, the items that are included are designated according to the process that they will 
be used for (as a drafting item indicated by a paintbrush shown in the following diagram): 

 
Each entry represents a specific item.  The various icons representing the function they will be 
utilized for can identify items. 

 Paintbrush (draw design elements) 

 Calculator (quantities calculations) 

 Report icon (default, pavement design, pavement markings, etc.) 
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See calculator icons in diagram below: 

 
The database may also be password protected if desired. This can be used as a security measure to 
protect the integrity of the database file and ensure its consistent application within an organization. 

5.2   Accessing the Design and Computation Manager 
When the Design and Computation Manager is accessed, two dialog boxes are displayed. 

 

The main D&C Manager dialog box is composed of two distinct areas: 

• Across the top are icons for the various modes.  The D&C Manager may be configured to 
operate in seven different modes: Display, Design, Set, Compute, Shape, Pavement 
Marking and Preferences.  As various modes are selected, more icons are displayed 
within this area. 

• The Path box displays the name of the attached database file and your current position 
within the database structure.  It lists the categories, sub-categories and items available 
for selection.  This hierarchical data structure functions much like a directory. Double 
clicking enables the user to move up or down within the database. 

A second dialog box appears differently depending on the mode of operation.  This dialog box 
enables the user to set other options not available on the main dialog box. The dialog box below 
appears when you click on the Design Icon. 
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5.2.1   File Commands 

 

For the GEOPAK designer, the only file command options needed are Open and 
Exit.  The other commands such as Save, Merge and Compress are used by 
personnel who maintain the database. 

As mentioned previously, the Password option may be used to password protect 
the database so a user would not be able to make changes to it. 

5.2.2   Edit Commands 
As a designer, the most-used Edit commands will be Find, Identify and 
Review Item.  

Find – This tool will search the database (from your current location) 
for an item or category.  If the database is password protected, all other 
items will be disabled. 

Identify – This tool will allow you to select an element in the design file 
to identify which item it matches in the database. 

Review Item – This tool will allow you to review the settings/symbology 
for a particular item in the database. 

 

5.2.3   Settings 
Display Settings - temporarily changes the display of 
elements on the screen to one common color, then the 
user may specify additional elements to be viewed in their 
original colors.  This tool enhances visualization when 
working on a complex project. 

Design Settings - sets the maximum gap tolerance and 
deduction tolerance used in computations and the drawing 
scale for placing cells.  

Compute – This dialog box contains fields and options specific to the Compute process. 

Computation Units – This dialog box shows the computational units available for the current system 
- English or Metric. 
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Dialog – This option controls how the level up and level down icons function when clicked when 
using D&C Manager in toolbox mode. 

Criteria Viewer – This toggle is used when a criteria writer is troubleshooting new 3PC. 

 

5.2.4   Favorites 
Add to Favorites - saves current D&C Manager path for easy recall in the 
future. 

Organize Favorites – allows the organization of previously saved paths.  

5.3   Operational Mode - Design 
The Design mode enables the user to draw each roadway element or COGO element (and 
associated attributes) in the design file based on drafting item parameters.  

First, the desired item is highlighted in the main dialog list box, i.e., alignment, edge of pavement, etc. 

 

The Place Influence option sets the level, symbology and attribute tags of elements drawn or copied 
using MicroStation commands.  When the Place Influence toggle is activated, elements are drawn 
using the level, symbology and attributes as defined in the GEOPAK database.  When Place 
Influence is off, elements are drawn using the active level, symbology and attributes of MicroStation. 
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The Draw Cogo Element button is for drawing COGO elements to a design file.  A single click to this 
button prompts the user for a job number, then opens a dialog box that enables the user to choose a 
COGO item to draw. 

 

If an alignment, profile or parcel item is chosen, the Draw Cogo Element button changes to Draw 
Plan and Profile. 

 

If Match Point Text is selected the active MicroStation settings are set to match the drafting 
preferences symbology for points of the selected item. 

 

Adhoc Attributes is used with Place Influence to add Adhoc Attributes to any new element when 
that element is drawn. 

 

If New Element Only is selected and an element is modified or moved, it’s symbology is not changed 
to the selected item. 
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From the secondary dialog box that is opened, click the Draw Plan & Profile button to initiate the 
drawing of COGO elements into the design file. Clicking this button prompts the user for a job number 
(the coordinate geometry database file wherein the COGO elements are stored), and then opens a 
dialog box that enables the user to choose a COGO item to draw. Do Not activate the Place 
Influence toggle when using Draw Plan & Profile. 

 

If utilizing the Design & Computation Manager within Project Manager, you are not 
prompted for a job number since this is associated with the active project. 

Eight operations may be accessed from the Plan 
and Profile Draw dialog box: Points, Lines, 
Curves, Spirals, Chains, Stationing, Parcels, and 
Profiles.  Each of these operations dynamically 
changes the dialog box to reflect the selection 
with the various draw and label features used 
when placing a COGO element in a graphics file. 

 

 

The points and lines dialog boxes have a key-in 
field that allows the user to specify the names of 
the COGO elements to be drawn.  To use the line 
operation, the user must use point numbers to 
specify the ends of the line.  The points/lines are 
drawn immediately after you enter their respective 
names and press the enter key.  To draw more 
than one point or line, place a dash in-between 
the point numbers.  To draw a line without using 
consecutive point numbers, use a forward slash 
(i.e. 10/11). 
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The dialog box settings for curves, spirals, chains, 
stationing, parcels, and profiles have a list box 
that display the names of all curves, spirals and 
chains stored in the active coordinate geometry 
database file.  Highlighting one of the available 
elements initiates further commands to draw the 
element into the design file.  Each type of item 
has a list of parameters that can be optionally 
plotted. 

 

 

 

 

GEOPAK can draw elements to non-active levels.  After elements are drawn, it may be 
necessary to turn on appropriate levels and use the MicroStation fit command to view the 
elements. 
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5.4   DP Station/Offset 
Feature / Function Utilize any station / offset in MicroStation commands requiring a data point. 

Tools 

  

Menu Bar Application GEOPAK Road > Plans Preparation > DP Station Offset 

 

The DP Station/Offset command works in 
conjunction with MicroStation commands and the 
D&C Manager.  It can be used as the data point for 
any MicroStation command.  DP Station/Offset 
provides precision placement of elements based on a 
station and offset of a stored chain.  Uses for this 
command include precision placement of elements 
and window functions. 

 

5.5   Draw Transition 
Feature / Function Draw transition based on a two sets of station / offsets. 

Tools 

 
 

Menu Bar Application GEOPAK Road > Plans Preparation > Draw Transition 

 

The Draw Transition tool draws a line/curve based on a beginning station/offset and an ending 
station/offset relative to a selected chain.  Use of this command includes turn lanes, mailbox 
widening, curve widening and lane transitions.  

 

 

Elements placed with Draw Transition have MicroStation element type curve when the 
beginning and ending offsets are different and MicroStation element type line and/or arc 
when the beginning and ending offsets are the same. 
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LAB 5:   D&C Manager – Plans Production 
5.1 Accessing Design and Computation Manager 

5.1.1   Right Of Way 
Step 1.  Execute C:\data\geo\VDOT\PlansPrep\LAB5.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\PlansPrep\d17682des.dgn 

Step 3. Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 4. Select the icon Plan View Design button from the Road 
Project: 17682.prj workflow dialog box, which opens the Plan 
View Design tool box.  

5.1.2   Traffic 
Step 1.  Execute C:\data\geo\VDOT\PlansPrep\LAB5.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\PlansPrep\d17682Traffic.dgn 

Step 3. Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 4. Select the icon Plan View Design button from the Road 
Project: 17682.prj workflow dialog box, which opens the Plan 
View Design tool box.  

5.2   Drawing Alignments 
Step 1. Select the Design and Computation Manager icon (as indicated above) to invoke the 

Design and Computation Manager shown below. A secondary dialog box will appear to 
be used in conjunction with the Design and Computation Manager dialog box. 

 

5-10    VDOT Plans Preparation Training GEOPAK 2004 Edition 



__________________________________________________________GEOPAK® 

Step 2. Select the item shown in the dialog box below.  

 
Step 3. Next, select the Draw Plan and Profile 

button from the secondary dialog box: 

 

Step 4. Select the Chains operation.  Each of 
the chains will be displayed in the list 
box as shown.  Notice that the options 
that are to be drawn with the chain are 
already activated. Set the Label Scale 
to 25. 

Step 5. To draw the chains, click each name in 
the list box. Only click once!! Each time 
you ID a chain it will be plotted into the 
design file. 
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Step 6. Change the Operation to Stationing 
and modify the dialog settings as shown 
in the image to the right.  

 Annotate each alignment by clicking the 
chain names in the list box. 

Step 7. Review the results of Steps five and six. 

 

 

 

Step 8. Exit the Plan and Profile Draw dialog box but remain in D&C Manager. 

 

5-12    VDOT Plans Preparation Training GEOPAK 2004 Edition 



__________________________________________________________GEOPAK® 

5.2.1   Use Special Application to Label PI’s and Tangent Lines 
Step 1. Do a Fit View to ensure that all alignments are displayed in the view. 

Step 2. Select the Design mode then navigate to Road Design > Special Applications > 
PlTangents  - Draw PI’s and Tangents on  BL’s. 

 

Step 3. Double-Click on the item to kick off the application. 

Step 4. Ensure that all alignments are displayed in the view then click OK on the dialog box 
below. 

 

Step 5. Populate the dialog box as below then click OK. 

 

Step 6. Populate the dialog box as below then click OK. 
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Step 7. Populate the dialog box as below then click OK. 

 

Step 8. When the dialog box below appears, click OK. 

 

Step 9. Populate the dialog box as below then click OK. 

 

Step 10. When the dialog box below appears, click OK. 

 

Step 11. Populate the dialog box as below then click OK. 

 

Step 12. When the dialog box below appears, click Cancel. 

 

Step 13. Review the PI Labels and Tangent Lines that were placed. 
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5.3A   Drawing Right Of Way Features 
We are going to develop roadway features representing the proposed roadway.  The roadway is 
made up of 4 distinct sections: 

• 4 lane divided highway with depressed median from Sta. 200+00 to Sta. 202+00. Left side of 
the roadway will be resurfacing while the right side is new construction. 

• 4 lane divided highway with raised median from Sta. 202+00 to Sta. 204+25. Left side of the 
roadway will be resurfacing while the right side is new construction. 

• 4 lane undivided highway from Sta. 204+25 to Sta. 211+00. 
• 2 Lane highway with Entrances and Exit Ramps from Sta. 211+00 to Sta. 220+00. 

To perform these tasks, two specific GEOPAK tools will be utilized: D&C Manager to determine 
element symbology and Draw Transition to place the elements between specific pairs of stations 
and offsets. Because of time constraints, we will not develop the planametrics for the entire project, 
but just for a select area. 

Step 1. Navigate to the item Road Design > Pavement > 900344 Edge of Pavement.   

Step 2. Select the item 900344 Edge of Pavement and then enable Place Influence. 

Step 3. If desired, click on the Switch to Toolbox Mode (left most icon) icon on D&C Manager. 

 

Step 4. Open the Draw Transition tool from the Plan View Design palette.  Fill in the values as 
shown below then click Draw.  This will draw the right edge of pavement between the 
given station range. 

 

Step 5. Next, modify the dialog box as shown to draw the edge of pavement transitioning from 
204+00 to 205+00. 

 

GEOPAK 2004 Edition LAB 5:   D&C Manager – Plans Production    5-15 



GEOPAK®__________________________________________________________  

5-16    VDOT Plans Preparation Training GEOPAK 2004 Edition 

Step 6. Draw the additional Pavement features shown in the following table.  Check that the 
correct feature is selected in D&C Manager before continuing.   

Note: All items shown in the table fall under the category Road Design. 

Feature Beg. Station Beg. Offset End Station End Offset 

Pavement > 900344 Edge 
of Pavement 200+00 -33.0 204+00 -33.0 

Pavement > 900344 Edge 
of Pavement 204+00 -33.0 205+00 -24.0 

Pavement > 900344 Edge 
of Pavement 205+00 24.0 211+00 24.0 

Pavement > 900344 Edge 
of Pavement 205+00 -24.0 211+00 -24.0 

Pavement > 900344 Edge 
of Pavement 211+00 24.0 212+00 12.0 

Pavement > 900344 Edge 
of Pavement 211+00 -24.0 212+00 -12.0 

Pavement > 900344 Edge 
of Pavement 212+00 12.0 216+00 12.0 

Pavement > 900344 Edge 
of Pavement 212+00 -12.0 216+00 -12.0 

 



__________________________________________________________GEOPAK® 

Step 7. Draw the additional Right Of Way features shown in the following table.  Check that the 
correct feature is selected in D&C Manager before continuing.   

Note: All items shown in the table fall under the category Right Of Way. 

Feature Chain Beg. 
Station 

Beg. 
Offset 

End 
Station 

End 
Offset 

Right of Way > ROW Right of Way Lines MAINLINE 200+00 40.0 213+45.14 40.0 

Right of Way > ROW Right of Way Lines MAINLINE 200+00 -40.0 206+76.86 -40.0 

Right of Way > ROW Right of Way Lines MAINLINE 207+63.
93 -40.0 211+54.06 -40.0 

Right of Way > TMPEAS Temporary Easements MAINLINE 200+00 45.0 213+45.14 45.0 

Right of Way > ROW Right of Way Lines REDBUD 0+38.48 42.0 1+44.20 42.0 

Right of Way > ROW Right of Way Lines REDBUD 0+41.69 -45.0 1+67.58 -45.0 

 

Step 8. Use generic MicroStation commands (Place Line, Copy Parallel, etc.) to develop the two 
Permanent Easements shown below.  The width’s can be whatever you desire.  When 
completed, disable Place Influence, then close D&C Manager. 

Note:  Use item Right of Way > PRMEAS Permanent Easements 

 

Step 9. Exit MicroStation. 
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5.3B   Drawing Traffic Features 
We are going to develop traffic features for our proposed roadway project.   

To perform these tasks, two specific GEOPAK tools will be utilized: D&C Manager to determine 
element symbology and the DP Station/Offset tool to place the traffic cells at specific stations and 
offsets. Because of time constraints, we will not develop the planametrics for the entire project, but 
just for a select area. 

Step 1. Navigate to the item Traffic > Proposed > Junction Boxes > 56004 JB-2A or 2B 
Junction Box. 

Step 2. If desired, click on the Switch to Toolbox Mode (left most icon) icon on D&C Manager. 

 

NOTE:  Place Influence must be toggled on in order for items to be computed. 

Step 3. Open the DP Station/Offset tool from the Plan View Design palette.  Fill in the values 
as shown below. 

 

 

When it is necessary to place elements along an alignment at one of the desired options, 
(i.e. Tangent), it is cumbersome to keep selecting the AA button to set the Active Angle.  
In this case, simply toggle on Auto Angle.  When the toggle is on, redundant selection of 
the AA button is unnecessary as GEOPAK will change the active angle automatically 
every time a new station and offset is keyed in.   

 

Step 4. Next, double click the item 56004 JB-2A or 2B Junction Box in D&C Manager.  This will 
attach the Junction Box cell to your cursor.  Do not click on the screen. 

Step 5. Click the DP button on the DP Station/Offset tool.  The Junction Box should be place at 
the station and offset displayed in the dialog above.   
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Step 6. Use the previous steps to place the Traffic items listed in the table below. 

Note: All items shown in the table fall under the category Traffic > Proposed. 

Feature Beg. Station Beg. Offset 

Junction Boxes > 56004 JB-2A or 2B Junction Box 207+31 43.0 

Junction Boxes > 56004 JB-2A or 2B Junction Box 206+69 -42.0 

Junction Boxes > 56004 JB-2A or 2B Junction Box 206+83 -61.0 

Junction Boxes > 56004 JB-2A or 2B Junction Box 207+74 -52.0 

Pole Foundations  > 51234 Concrete Foundation Signal 
Pole 206+58 34.0 

Pole Foundations  > 51234 Concrete Foundation Signal 
Pole 207+36 38.0 

Pole Foundations  > 51234 Concrete Foundation Signal 
Pole 206+76 -49.0 

 

Step 7. Populate the DP Station/Offset dialog as shown below. 

 

Step 8. Navigate to the item Traffic > Proposed > Controllers > 51030 Prop. Controller 
Cabinet. 

Step 9. Next, double click the item 51030 Prop. Controller Cabinet in D&C Manager.  This will 
attach the Control Cabinet cell to your cursor.  Do not click on the screen.  Set the 
Active Angle to 180.00 as shown below. 

 

Step 10. Click the DP button on the DP Station/Offset tool.  The Controller Cabinet should be 
place at the station, offset, and angle displayed in the dialogs above. 

Step 11. From the MicroStation menu bar select Utilities > Saved Views, access the Saved View 
“POLE1”.  
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Step 12. Use D & C Manager to place the Signal Pole Mast Arm and Hanger Assemblies as 
shown below.   

 Set the Active Angle as shown in the dialog box below for placement of the cells. 

 

 Use the following items: 

 Traffic > Proposed > Signal Pole Mast Arms > 51309 SIG. POLE MP-1 ONE ARM 
22FT 

 Traffic > Proposed > Hanger Assemblies > 51822 SW -1 or 2, ONE WAY 

 

Step 13. From the MicroStation menu bar select Utilities > Saved Views, access the Saved View 
“POLE2”.  

Step 14. Use D & C Manager to place the Signal Pole Mast Arm and Hanger Assemblies as 
shown below.   

 Set the Active Angle as shown in the dialog box below for placement of the cells. 

           

 Use the following items: 

 Traffic > Proposed > Signal Pole Mast Arms > 51321 SIG. POLE MP-1 ONE ARM 
34FT 
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 Traffic > Proposed > Hanger Assemblies > 51822 SW -1 or 2, ONE WAY 

Step 15. From the MicroStation menu bar select Utilities > Saved Views, access the Saved View 
“POLE3”.  

Step 16. Use D & C Manager to place the Signal Pole Mast Arm and Hanger Assemblies as 
shown below.   

 Set the Active Angle as shown in the dialog box below for placement of the cells. 

            

 Use the following items: 

 Traffic > Proposed > Signal Pole Mast Arms > 51321 SIG. POLE MP-1 ONE ARM 
34FT 

 Traffic > Proposed > Hanger Assemblies > 51822 SW -1 or 2, ONE WAY 

Step 17. From the MicroStation menu bar select Utilities > Saved Views, access the Saved View 
“LOOP1”.  

Step 18. Use D & C Manager to place the Loop Detectors as shown below in any location you 
desire.  The DP Station/Offset tool can be used to set the Active Angle for placement of 
the cells.  Use the following item: 

 Traffic > Proposed > Loop Detectors > 51540 6 x 40 Prop. Loop Detector 

 

Step 19. From the MicroStation menu bar select Utilities > Saved Views, access the Saved View 
“LOOP2”.  
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Step 20. Use D & C Manager to place the Loop Detectors as shown below in any location you 
desire.  The DP Station/Offset tool can be used to set the Active Angle for placement of 
the cells.  Use the following item: 

 Traffic > Proposed > Loop Detectors > 51540 6 x 40 Prop. Loop Detector 

 

Step 21. From the MicroStation menu bar select Utilities > Saved Views, access the Saved View 
“LOOP3”.  

Step 22. Use D & C Manager to place the Loop Detectors as shown below in any location you 
desire.  Set the Active Angle at any angle you desire.  Use the following item: 

 Traffic > Proposed > Loop Detectors > 51540 6 x 20 Prop. Loop Detector 

 

Step 23. Exit MicroStation. 

 

 

5-22    VDOT Plans Preparation Training GEOPAK 2004 Edition 



_____________________________________ CHAPTER 6 

Labeling 
6.1   Introduction 
Objectives Learn how to label plan information with Plan View Labeler. 

Familiarize the user with the Cross Section Labeler. 

Project Manager Plan View Design 

Tools 

            

Menu Bar Application GEOPAK Road > Plans Preparation > Plan View Labeling 
GEOPAK Road > Plans Preparation > Profile Labeling 
GEOPAK Road > Cross Sections > Labeling 

6.2   Plan View Labeling 
GEOPAK’s labeling tools allow a user to place “smart” labels in a MicroStation drawing.  These labels 
have the ability to calculate XYZ coordinates, station, offset, direction, length, radius, degree of 
curvature, etc. of the associated element. When the Plan View Labeling icon is selected, the dialog 
box depicted below is displayed. 

 

The label to be placed is displayed in the box on the right side of the dialog box as shown above.  
The Space button places a space in the label at the cursor position.  The Return button starts a new 
line of text.  The Clear button starts a new label.  The Delimit button places a line above or below a 
line of text.  The Place Label button attaches the label to the cursor for placement in the drawing.   

The user can select the various tabs to define / modify the label appearance. 
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6.2.1   Text 
For data to be computed, the job number and the chain need to be selected.  If elevations are to be 
calculated, a TIN file needs to be chosen.   

The Computed Inserts are items that Geopak has the ability to calculate for the chosen item.  The 
list of Computed Inserts changes with the type of element that is chosen.  If a line is chosen, the list 
of Computed Inserts will show inserts of bearing, and length.  If a curve is chosen the list of 
Computed Inserts will change to show inserts of radius, curvature, chord length, etc. 

The User Inserts are inserts that a user may use on a regular basis.  This list can be customized for 
a specific user’s needs. 

There are several methods allowing the user to choose the element to use for calculations in the 
label.   

Select GEOPAK or 
MicroStation Element 

 

Allows the user to identify either a COGO or MicroStation 
element for labeling. 

Data Point Location 

  

Selects a location in the design file that may or may not be 
associated with an element. 

2 GPK Point Line  

 

Selecting lines or points that have been visualized via COGO. 

3 GPK Point Arc  

 

Selection of visualized arcs and points 
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6.2.2   Params. 

 

The Parameters tab enables the user set up the text size and symbology for the label. 

By Current sets the symbology to the current MicroStation settings.  By Element allows the user to 
set the symbology by choosing a MicroStation element.  Set All sets the symbology for all elements 
in the label (text, delimiters, leader lines, etc.).   

By Current 

 

After pressing this button, GEOPAK determines the active 
MicroStation symbology (level, weight, color and style) and 
populates the dialog. 

By Element 

 

After pressing this button, GEOPAK prompts to select a 
previously drawn MicroStation element, and populates the dialog 
with its element symbology. 

D & C Symbology 

 

Pressing this button invokes the Design and Computation 
Manager, wherein the desired item may be selected.  By double 
clicking on an Item, the associated element symbology within the 
Design and Computation Manager is applied to the Labeling 
dialog. 

Set All  

 

GEOPAK reads the current settings (level, weight, color and 
style) within the dialog, and populates the Parameter, Shape and 
Leader dialogs. 
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6.2.3   Shape 

 

The Shape tab allows the user to place a shape around the label, and set the symbology for the 
shape. 

6.2.4   Leader 

 

The Leader tab allows the user to attach a leader from the label to the point.  Different leader types 
and terminators can be chosen.  The active terminator can also be used. 
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6.2.5   Rotate 

 

The Rotate tab allows the label to be rotated.   The rotation can be determined from the current 
angle, the angle of the element, or the alignment angle.  The angle can also be set by two data points 
(first data point set the location, next data point sets the angle) or the active angle. 

6.2.6   Styles 

 

The Styles tab allows a user to choose label symbology from a library of pre-defined styles.  When 
the user chooses the style, all symbology, leaders, shapes, etc. is set up for the user. 

6.2.7   Menus 
The Style Files menu allows the user to open a new style library.  You must be under the Styles tab 
in order to open a style library. 
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In the Options menu, Minimize Dialog Box will minimize the dialog box when Place Label is 
chosen.  The Use Reference File Coordinates option uses the coordinates from the master plan 
view file when placing a label in a plan sheet. 

 

Options > Label Tools invokes the tool frame shown below which enables the user to modify 
Geopak labels.  

 

Options > Label Viewer brings up a dialog box that allows a user to view and place a label.  

 

The Scale > Scale Style menu allows the user to choose a plan scale.  All labels will be adjusted 
according to the plan scale.  The user simply keys in a scale, and chooses a Labeling Style.  The 
corresponding label will be placed at the correct size for the scale that was chosen.  
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6.3   Cross Section Labeling 
The Cross Section Labeling dialog box differs from the Plan View Labeling dialog box only on the 
text tab.  Cross Section Labeling works with the Cross Section Navigator.  The current Cross 
Section Navigator station is shown on the Text tab.  The Computed and User Inserts contain 
values and phrases related to cross-sections. 

 

6.4   Profile Labeling 
The Profile Labeling dialog box differs from the Plan View Labeling dialog box only on the text tab.  
The Chain and Profile must be defined, in addition to profile settings.  The Computed and User 
Inserts contain values and phrases related to profiles. 
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LAB 6A:   Right Of Way Labeling 
6A.1  Accessing the Labeler 

Step 1. Execute C:\data\geo\VDOT\PlansPrep\LAB6.EXE. 

Step 2. Open the MicroStation file c:\data\geo\vdot\PlansPrep\d17682des.dgn. 

Step 3. Access Project Manager. 

Step 4. Select the icon Plan View Design button from the Road Project: Road1.prj workflow 
dialog box. 

Step 5. From the Plan View Design tool bar, select the Plan View Labeler icon. 

 

6A.2  Using Predefined Label Styles 
In the following steps we will use the Plan View Labeler to label Permanent Easements. 

Step 1. Click on the Styles tab. 

Step 2. Traverse with the Item Selector box to locate the following style: 
Labels > Right of Way > Easement Perm. Other Pluses.   Next, double click the 
Easement Perm. Other Pluses style. 

 

Step 3. Click on the Text tab and complete as defined below: 

Job No. 101 

Chain MAINLINE 

TIN File SURVEY.TIN 
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Step 4. Click on the Params. tab and complete as defined below: 

 

Step 5. Click the Set All Parameters icon.  This will set the symbology for the rest of the label to 
match the text. 

 

Step 6. Click on the Shape tab and set the Offset to 1.00: 
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Step 7. Click on the Text tab.  To create a label, select the Data Point Location button and then 
identify the location desired for the location of the label.  The labeler automatically 
calculates the information.  

 

Use the image below as a sample for placement of the labels. 

 

Step 8. Exit the Plan View Labeler.
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6A.3 Use Special Application to Label Right Of Way and 
Easements 

In the following steps we will use a special application to label Right Of Way and Easements. 

 

Note:  In order to use this special application to label Right Of Way, the elements to be 
labeled must be placed in a MicroStation selection set. 

6A.3.1   Label Proposed Right Of Way for Chain MAINLINE 
Step 1. From the MicroStation menu bar select Utilities > Saved Views, access the Saved View 

“ROW1”. 

Step 2. Place the Proposed Right Of Way for chain MAINLINE in a MicroStation selection set. 

Step 3. Invoke Design and Computation Manager from the Plan View Design tool frame 
shown below. 

 

Step 4. Select the Design mode then navigate to Right of Way > Special Applications > 
Pluses – RW/Easements. 

 

Step 5. Double-Click on the item to kick off the application. 
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Step 6. Populate the dialog box as below then click OK. 

 

 NOTE:  Job Number and Chain Name can be entered by using the Select buttons. 

The Offset and Station labels should be placed along the proposed Right Of Way for chain 
MAINLINE.  They can be moved to a new location if you desire. 

6-12    VDOT Plans Preparation Training GEOPAK 2004 Edition 



__________________________________________________________GEOPAK® 

6A.3.2   Label Proposed Right Of Way for Chain REDBUD 
Step 1. From the MicroStation menu bar select Utilities > Saved Views, access the Saved View 

“ROW2”. 

Step 2. Place the Proposed Right Of Way for chain REDBUD in a MicroStation selection set. 

Step 3. Invoke Design and Computation Manager from the Plan View Design tool frame 
shown below. 

 

Step 4. Select the Design mode then navigate to Right of Way > Special Applications > 
Pluses – RW/Easements. 

 

Step 5. Double-Click on the item to kick off the application. 
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Step 6. Populate the dialog box as below then click OK. 

 

 NOTE:  Job Number and Chain Name can be entered by using the Select buttons. 

The Offset and Station labels should be placed along the proposed Right Of Way for chain REDBUD.  
They can be moved to a new location if you desire. 
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6A.3.3   Label Temporary Easement for Chain MAINLINE 
Step 1. From the MicroStation menu bar select Utilities > Saved Views, access the Saved View 

“ROW1”. 

Step 2. Place the Temporary Easement for chain MAINLINE in a MicroStation selection set. 

Step 3. Invoke Design and Computation Manager from the Plan View Design tool frame 
shown below. 

 

Step 4. Select the Design mode then navigate to Right of Way > Special Applications > 
Pluses – RW/Easements. 

 

Step 5. Double-Click on the item to kick off the application. 
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Step 6. Populate the dialog box as below then click OK. 

 

 NOTE:  Job Number and Chain Name can be entered by using the Select buttons. 

The Offset and Station labels should be placed along the Temporary Easement for chain MAINLINE.  
They can be moved to a new location if you desire. 
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LAB 6B:   Traffic Labeling 
6B.1  Accessing the Labeler 

Step 1. Execute C:\data\geo\VDOT\PlansPrep\LAB6.EXE. 

Step 2. Open the MicroStation file c:\data\geo\vdot\PlansPrep\d17682Traffic.dgn. 

Step 3. Access Project Manager. 

Step 4. Select the icon Plan View Design button from the Road Project: Road1.prj workflow 
dialog box. 

Step 5. From the Plan View Design tool bar, select the Plan View Labeler icon. 

 

6B.2  Using Predefined Label Styles 
In the following steps we will use the Plan View Labeler to label Conduit. 

Step 1. Click on the Styles tab. 

Step 2. Traverse with the Item Selector box to locate the following style: 
Labels > Traffic > Conduit w/ Bracket.   Next, double click the Conduit w/ Bracket 
style. 

 

Step 3. Click on the Text tab and complete as defined below: 

Job No. 101 

Chain MAINLINE 

TIN File SURVEY.TIN 
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Step 4. Click on the Params. tab and complete as defined below: 

 

Step 5. Click on the Shape tab and complete as defined below: 

 

Step 6. Click on the Leader tab and complete as defined below: 
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Step 7. Click on the Rotate tab.  Click the Element button under Set Angle By then graphically 
identify chain MAINLINE.  This will set the angle of the label.  The Plan View Labeler 
should appear as below: 

 

 

Note:  Before we place the label we need to gather some information about the Conduit 
to be labeled.  To gather this information we will be using the 3PC AdHoc Attribute 
Manager. 

 

Step 8. From the Applications pulldown select GEOPAK ROAD > GEOPAK Element 
Attributes > 3PC AdHoc Attribute Manager.  The dialog box below should appear. 

 

Step 9. Click the Identify Element icon on the 3PC AdHoc Attribute Manager dialog box then 
graphically identify the conduit labeled Conduit 1.  The dialog box should be populated 
as below.  We will use this information to compose a label. 

 

GEOPAK 2004 Edition LAB 6B:   Traffic Labeling    6-19 



GEOPAK®__________________________________________________________  

Step 10. Click on the Text tab and complete as defined below:  

  

Step 11. Click the Select GEOPAK or MS Element button and then identify the conduit labeled 
CONDUIT 1.   

 

Step 12. The label will be attached to your cursor.  Place the label at a location of you choice.  It 
should look similar to the example below. 
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Step 13. Label CONDUIT 2, CONDUIT 3, and CONDUIT 4 using the previous steps.  An example 
of how the labels might appear is shown below. 

CONDUIT 2 

 

CONDUIT 3 
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CONDUIT 4 

 

Step 14. Exit MicroStation. 

 

6-22    VDOT Plans Preparation Training GEOPAK 2004 Edition 



_____________________________________ CHAPTER 7 

Plan and Profile Sheets (Traffic Only) 
7.1   Overview of Features 
Feature / Function Drawing of plan or plan / profile sheets. 

Tool 

   

Project Manager (Road) Plan and Profile Sheets 

Menu Application GEOPAK Road > Plans Preparation > Plan and Profile Sheets 

 

The main feature of the 2001 Plus application is a simplified user interface, compared to the Classic 
application.  In this way, users can quickly and easily generate a variety of plan, plan / profile and 
tabular data sheets. 

In order to maintain compatibility with the Classic application and ease the transition for those users 
who want to utilize the 2001 Plus application, 2001 Plus supports importing .dat files utilized in the 
Classic application, and converting them to the new Port-oriented format.  Dat files were the 
equivalent of the Sheet Library in the Classic application. 

2001 Plus supports any combination of Ports on a sheet for maximum flexibility. 

2001 Plus provides powerful handling of MicroStation reference files.  This is accomplished by having 
other MicroStation files serve as patterns for the reference file attachments.  These are called motif 
files. 

2001 Plus has the option to automatically make a notch in the clipping shape at layout time to make 
room on the sheet for a title block.  This is done by putting the clipping shape pattern into the sheet 
cell. 

Extended Stationing is used as a means to allow sheets to be placed partially off of an alignment or 
even completely off of the alignment. 

2001 Plus has the ability to place sheets with a Right to Left Station progression, which is opposite of 
the standard used in roadway design.  This was added for users doing rail design. 

A thorough capability is provided to perform sheet numbering.  Alphanumeric prefixes and suffixes as 
well as changing the start number of the sheets and rearranging the ordering are all supported in 
2001 Plus. 

2001 Plus supports Profile Stair Stepping.  In situations with steep grades or narrow profile ports, 
sometimes the profile goes off the top or bottom of the port before it gets to the end of it.  To handle 
this, users would put a break in the profile port and adjust the elevations to bring the coverage up or 
down to where it needs to be.  Within 2001 Plus, GEOPAK automatically locates these breaks and 
plots the profile clipping shapes in accordance with that.  This adjustment carries through, then, to the 
sheet design file. 
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Profile Gap Equalities -- If a Profile has been plotted with the Gap option turned on, the coverage of 
the sheet is now adjusted so that subsequent sheets remain aligned with the grid. 

Raster Manager -- Descartes is not supported by the application.  Raster Files are now to be 
referenced via the Raster Manager application available via Bentley Select. 

Tabular Data Application -- Sheet Clip places Clipping Shapes suitable for Tabular Data.  However, 
the actual placement of the tabular values in the dgn file is now done via the Draw Tabular Annotation 
(Sheet Clip Mode) tool.  This approach allows the power and flexibility of the Draw Tabular Annotation 
application to be used with sheets. 

Digital InterPlot – The Digital InterPlot Plot set can be created during the sheet clipping process. 

 

7.2  Invoking The Main Dialog Box 
When the GEOPAK User Preferences is set to 2001 Plus and Plan and Profile Sheet tool is selected, 
the GEOPAK Sheet Layout dialog box depicted below opens. 

 

The dialog box is comprised of the title bar which displays the current Sheet Library, the main menu 
bar, short-cut icons, and the Sheet Name Selector and Plot Scale fields. 

The first time the application is invoked, it opens up a default.psl sheet library located in the 
\geopak\bin\ folder if the configuration variable isn’t defined. 

The Plot Scale will be displayed in the proper units depending on how it is set in the User 
Preferences. 

7.2.1   Sheet Library 

 

The parameters for each sheet are defined in a Sheet Library.  In order to lay out or clip sheets, a 
Sheet Library must be attached to the current session.  The name of the currently attached Sheet 
Library is shown in the title bar.  Sheet Libraries have an extension of psl.  An unlimited number of 
different sheets can be stored within one library. When the user begins the sheet process, they select 
the desired sheet layout from the attached library, which loads the associated parameters. 

If a different Sheet Library is needed, it can be attached via the menu items File > Sheet Library > 
Attach.  It is also possible to review or make changes to the Sheet Library by selecting File > Sheet 
Library > Edit.  Detailed information on the set-up of the Sheet Library can be found in the online help 
section entitled "Sheet Library Set-up." 
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7.2.2   Main Menu Bar Overview 

 

Four options are supported in the main menu bar: 

• File 
• View 
• Settings 
• Tools 

7.2.2.1   File Menu Options 
Two tools are supported in the File pulldown and are detailed in the sub-sections below. 

• Sheet Library 
• Exit 

7.2.2.1.1   Sheet Library 
The Library file contains the various parameters, cells, and dimensions for creating sheets.  In this 
menu option, a new Library can be created, an existing Library can be edited, or the user can define 
(Attach) the desired Library.  For a detailed discussion of setting up and editing a Library, refer to the 
online documentation "Sheet Library Set-Up." 

 

7.2.2.1.2   Exit 
Exits the Plan and Profile Sheets application, but does not close the MicroStation file. 
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7.2.2.2   View Menu Options 
Three tools are supported in the View pulldown and are detailed in the table below. 

Filter by Sheet 
Name 

The clipping shapes of the currently selected sheet name are displayed.  A 
MicroStation update view will need to be issued if “Automatic Update” is not 
toggled on. 

Filter by Scale The clipping shapes of the currently selected Scale are displayed.  A 
MicroStation update view will need to be issued if “Automatic Update” is not 
toggled on. 

NOTE:  “Filter By Sheet Name” and “Filter By Scale” can be used together. 

Automatic 
Update 

If this is toggled on when “Filter By Sheet Name” or “Filter By Scale” is 
selected the view is automatically updated. 

 

7.2.2.3   Settings Menu Options 
One tool is supported in the Settings pulldown and is detailed in the table below. 

Settings Sheet 
Layout  

When the Sheet Layout tool is selected, the dialog box depicted below 
opens.  Three settings are supported within the dialog box including Left to 
Right or Right to Left layout, Stair Stepping for profiles, and sheet view 
attributes. 

 
• Sheet Layout Progression: 

Left To Right (Standard) 
   Right To Left (Rail) 

• Profile Stair Stepping: 
Off 
On 

• Sheet View Attributes: 
Use Current Design File 
Customize With Motif File 
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7.2.2.4   Tools Options 
Eight tools are supported in the Tools pulldown and are detailed in the sub-sections below. 

• Identify Sheet 
• Sheet Composition 
• Sheet Layout 
• Sheet Clip 
• Sheet Modify 
• Sheet Number Manager 
• Draw Tabular Annotation (Sheet Clip Mode) 
• Processing Classic Plan & Profile Runs (Not covered in this manual) 
 

7.2.2.4.1   Identify Sheet 
Select Identify Sheet, then select and accept a previously placed clipping shape.  GEOPAK 
determines the settings utilized to place the original sheet and automatically populates the dialog box 
with the Sheet Name and Scale.  In addition, the Sheet Name, Scale, Sheet Number and Port are 
displayed in the MicroStation prompt field at the bottom of the screen.  If the parameters for the 
selected sheet are not found within the current library, a warning message is displayed indicating the 
sheet is not found, the name of the current library, and the name of the library used to place the 
original sheet.  

                                

7.2.2.4.2   Sheet Composition 
This menu item opens the Sheet Composition dialog box, wherein drawing area, overlapping options 
and other project specific variables are defined.  One sample dialog box is depicted below. 

                                         

GEOPAK 2004 Edition Plan and Profile Sheets (Traffic Only)    7-5 



GEOPAK®__________________________________________________________  

7.2.2.4.3   Sheet Layout  
The Layout dialog box is utilized to define the GEOPAK Job Number, alignments, and / or profiles for 
the desired sheets.     

 

Fields are also supported for stationing, if only part of the chain is being utilized for sheet layout. 

7.2.2.4.4   Sheet Clip  
Once the sheets have been laid out and any modifications complete, the sheets are ready to be 
clipped and drawn for the final production sheets.  The Clip dialog box is utilized to complete these 
tasks, as detailed below. 

Create Digital InterPlot Plot Set – Allows the creation of the Digital InterPlot Plot Set during the 
Layout Sheets process. 
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7.2.2.4.5   Sheet  Modify  
After the sheets are laid out, the user may want to adjust individual sheets to conform to the project 
limits, etc.  This can be accomplished utilizing the tools in the Modify dialog box, which is illustrated 
below. 

 

The two icons in the upper left corner are utilized to Slide sheets (along the alignment, rotating, 
offsetting) and Modify Drawing Area.  The Slide options are illustrated above, while the graphic below 
depicts the Modifying Drawing area. 

 

The user can select the sheet to be modified from the pick list or by graphic identification.  Sheets can 
also follow the movement of the selected sheet, i.e., moving one sheet to left moves all proceeding or 
following sheets to the left by the same amount. 
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7.2.2.4.6   Sheet Number Manager 
After the sheets are laid out, the Sheet Number Manager can be invoked as depicted below, 
populated with the current sheets. 

 

The actual sheet number can be modified, prefix and suffix added, and other labeling options by 
utilizing the Edit Sheet Number (fourth icon down in the grouping to the right of the list box). 

 

Another option is changing the order the sheets are drawn. 
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7.2.2.4.7   Draw Tabular Annotation (Sheet Clip Mode) 
When the Draw Tabular Annotation tool is selected, the Draw Tabular Annotation dialog box is 
opened, as depicted below.  

 

The user can define the tabular data to be included within the plan /profile sheets.   

7.2.3   Dialog Box Icons 
Six short-cut icons are supported for ease of use.  These icons correspond to tools located within the 
menu bar pulldowns and are detailed in the table below. 

 
Sheet Composition  (Sheet > Composition). 

 
Layout Sheets  (Sheet > Layout). 

 
Clip Sheets  (Sheet > Clip). 

 
Modify Sheets  (Tools > Modify). 

 
Sheet Number Manager  (Tools > Sheet Number Manager). 

 
ID button (Tools > Identify Sheet). 
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7.2.4   Sheet Name Selector and Plot Scale 

 

Two parameters are global to the entire application and are shown on the main dialog box:  

• The Sheet Name Selector enables the user to select which sheet is to be placed in the next 
Layout operation.  The drop down list displays all sheets in the currently attached Sheet 
Library. 

• The Plot Scale text item determines the scale at which sheets will be placed in the 
layout.dgn. 

7.3  Primary Work Flow 
The approach taken by this application is to represent the reference-clipping boundary of each Port 
on each Sheet.  The clipping boundary is represented by MicroStation Shapes, referred to as Clipping 
Shapes. 

For each project, there is one design file which contains all of the Clipping Shapes for a project, for 
example, layout.dgn.  All design elements exist in files referenced to layout.dgn.  It is recommended 
that layout.dgn have only Clipping Shapes in it. 

The Primary Work Flow consists of two operations: 

• Layout of sheets – places clipping shapes into layout.dgn file. 
• Clipping sheets - reads the Clipping Shapes from the Layout dgn and creates new design 

files which include all required reference files which are clipped at the correct boundaries 
along with the Sheet Cell and other annotations. 

 

There are two options for Clipping Sheets: Rotate View and Rotate Reference. 

When Sheets are clipped using the Rotate View option, the sheet cell and the view are moved and 
rotated such that they are coordinately correct with the clipping shape of Port One.  This arrangement 
allows only one sheet per design file. 

When Sheets are clipped using the Rotate Reference option, the sheet cell and view are not rotated.  
The reference files are rotated and moved to be in the correct location with respect to the sheet cell.  
The arrangement allows multiple sheets to be placed in one design file. 

7.4   Ports 
Each Sheet consists of one or more Ports.  A Port can be considered a window into the design.  For 
each sheet that is placed into a layout.dgn, each Port on that sheet is placed as a Clipping Shape. 

7.4.1   Port Types 
There are three types of Ports: Plan, Profile, and Tabular Data.  It should be noted the 2001 plus 
version of Plan and Profile Sheet Composition does not place tabular data values.  The application 
places Clipping Shapes designed to include Tabular Data.  The actual placement of the Tabular Data 
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values is accomplished by the Draw Tabular Annotation (Sheet Clip Mode) tool in coordination with 
the Plan and Profile Sheet Composition application. 

7.4.2   Port Information 
Before laying out sheets, each Port must have its Port Information filled out.  The Port Information 
Dialog boxes are opened by double-clicking the corresponding row in the Layout Dialog box. 

Plan Ports only need the controlling chain, an offset value, and the name of the motif file for the given 
Port.  If the “Use Current Design File” option is selected, Current will be displayed in the dialog box 
instead of a Motif File name. 

Motif files are used to determine reference file attachment.  

Profile Ports require the name of the controlling profile in addition to all the information found in a 
profile cell. 

Tabular Data Ports require the same kind of information that Profile Ports do, but also may optionally 
have the ability to stagger the placement of the ports.  This staggering allows the Clipping Shapes to 
be longer without conflicting so that they may accommodate margin labels. 

7.5   Sheet View Attributes 
Two options are supported for Sheet View Attributes: 

Use Current Design File – All reference file attachments, active levels, etc., are based on the current 
design file.  An optional toggle is supported to Save the Full Path of reference files.  This toggle is 
only for the design file that contains the clipping shapes. 

Customize with Motif Files - A blank file is utilized as a pattern file for the reference file 
attachments.  Also levels can be turned on or off as desired.  We call these files motif files.   

7.5.1   Use Current Design File 
The user can control reference file attachment without the use of Motif Files by selecting the Use 
Current option for Sheet View Attributes.  When this option is used, the Current dgn file (in which 
clipping shapes have been layed out) is used like a Motif file in that it’s reference file attachment 
information carries over to each Port during Clipping. 

Also the design file containing the clipping shapes will be attached as a reference file for each port to 
accommodate users that wish to place there clipping shapes in the proposed design file. 

The advantage of Use Current Design File is that the user does not need to concern themselves with 
setting up motif files.  What they see in the layout design file is what they will get in clipped sheet files.  
However, when Use Current Design File is that selected option, it is not possible to have different 
reference file settings for different Ports on the same sheet.  All Ports must have the same 
attachment information and can’t be customized. 

The Save Full Path toggle is used for the Current Design File only when the sheets will be placed in a 
different directory than the reference files. 
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7.5.2   Customize With Motif Files 
It is sometimes necessary to have two or more Ports on a sheet which have differing reference file 
attachment settings.  This could happen with two Plan Ports which cover the same area but show 
different aspects of the project.  For example, the top Port would show the proposed design and the 
bottom Port would show traffic control.  This could be considered as the two Ports on the same sheet 
having different themes or different motifs. 

The question arises as to how the various reference file settings are to be controlled for each Port.  
This is done by using another design file to serve as a pattern for the reference file attachment 
information.  For every Port, there would be a motif file specified by its file name.  The Ports on each 
sheet may have the same or different Motif Files. 

During a Clip operation, the reference file attachment information is read from the motif file for each 
Port.  When a Port is placed into the final sheet file, all reference files which are attached to the 
corresponding Motif File are attached to the final sheet design file.  All reference level view on/off 
settings of the motif file are also applied to the reference file attachment in the final sheet design file.  
Note the clipping shapes are still used to define the Clip Boundary of each reference file associated 
with that Port. 

In the example described above of a sheet with Design and Traffic Control, the top Port could have a 
Motif File named design_motif.dgn.  The bottom Port could have a Motif File named Traffic_motif.dgn.  
At any time before sheets are clipped, the Motif Files (which would normally be blank) must be 
opened, desired levels should be active, and the reference files attached.  The reference file names 
and their paths used for the motif file must match exactly to the reference files and associated paths 
in the original file.  Therefore, the user will normally set up the motif files on a project by project basis, 
unless an organization has a standardized set of file naming conventions and level structure utilized 
on every project, where a single set can be developed for the entire organization. 
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7.6   Sheet Composition 
When the Sheet Composition tool is accessed, the dialog box depicted below opens. 

                                

The graphic illustrates the various values required in the dialog box.  Directly below, four options are 
supported, as illustrated in the exploded view above: 

• By Begin Station/Overlap 
• By Station Range:  Inside Out 
• By Station Range:  Outside In 
• By Station Range:  Radial 
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7.6.1   By Begin Station/Overlap Option 
When the By Begin Station/Overlap option is selected, the Clip group box containing the Drawing 
parameters, Overlap options and associated fields as depicted in the graphic below: 

 

Before these options are reviewed, a discussion of the Active Drawing Area, located within the Clip 
group box, is warranted.  Several dimensions are found within the Clip group box.  These include: 

• Maximum Drawing Area (display only) 
• Horizontal 
• Drawing Shown 
• Vertical 
• Active Drawing Area (display only, calculated by GEOPAK) 
 

The graphic below illustrates each dimension for the subject sheet.  In addition, a portion of the 
adjoining sheet to the left is shown in order to depict the overlap.  Notice that the alignment is also 
displayed from approximately station 289+00 to 292+00. 
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First, GEOPAK utilizes the Maximum Drawing Area based on the Sheet Name and Scale selected in 
the main Sheet Layout dialog box, in our example, 400.00 x 176.75.  Then the Clip Vertical is 
subtracted twice, once for the top and once for the bottom.  In this case,  

   176.75 - 10 - 10 = 156.75 

which is shown in the Active Drawing Area.  The same method is utilized for the Horizontal 
computations.  The horizontal clip is subtracted twice, once for the right side and once for the left 
side.  In this case,  

   400.00 - 10 - 10 = 380.00 

which is shown in the Drawing Shown and the Active Drawing Area. 

 

Once again referring to the graphic above, GEOPAK considers the Overlap shown on the left side 
between the two adjoining sheets.  The Overlap toggle has two options as depicted in the exploded 
view below: 

 
• Percentage 
• Fixed Distance 

When the Percent option is selected, the designer keys in the desired overlap in percent format in the 
Overlap field.  Note the percent sign (%) is not required.  The Percentage is calculated utilizing the 
Drawing Shown value.  In this example, the 5.26% overlap is 156.75 feet (5.26% of 176.75). 

In our Percentage example, the overlap is 5.26%.  Therefore, a 20.00 foot overlap in clip areas is 
present between successive sheets. 

If the Fixed Distance option is utilized, the Value field is in master units, i.e. feet or meters.   
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When placing sheets on a curve, the chord of the curve where it intersects the inside border is utilized 
to orient the sheet as depicted in the graphic below: 

 

Since the By Begin Station/Overlap Sheet Composition option uses a chord distance to compute 
the length of the sheet, in the area of a curve more stationing will be covered.  On a Plan/Profile 
sheet, this means there will be unequal coverage between the Plan and Profile.  With this in mind, it is 
recommended that By Begin Station/Overlap Sheet Composition option be used for a Plan only 
case. 

7.6.2   By Station Range  Inside Out Option 
The By Station Range:  Inside Out option orients sheets between a rounded station interval.  This 
interval is entered in the Station Range field.  When utilizing this option, the Clip group box also has 
a slightly different look as seen in the graphic depicted below. 

 

Now the Active Drawing Area is not constant, but displays Variable in the output field.   
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The Horizontal keyin has a slightly different meaning which can be best illustrated with an example.  
Let's use 500 feet for the Station Range, and 15 feet Horizontal.  The dialog box is depicted below. 

 

Utilizing the dialog box above, the following sheets are generated. 

 

The first step when the sheets are drawn is to determine the stationing for each sheet.  Our first sheet 
will be oriented between stations 115+00 to 120+00. GEOPAK then expands the sheet clip area by 
the Horizontal keyin distance.  Looking at a detail of the beginning of the project, the clip area is 
expanded fifteen feet before station 115+00 as seen in the graphic below.  Note the inside border is 
the dashed line, and station 115+00 and its associated tick mark are shown. 

 

The curve is calculated slightly different.  The second sheet in this series is on a curve.  The station 
range is 120+00 to 125+00.  A chord is drawn for the curve between stations 120+00 and 125+00 as 
seen in the graphic below. 
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Notice that the inside sheet border is wider than the chord.  The software will extend the chord the 
amount of the Horizontal keyin (in our example, fifteen feet) to establish the vertical edge of the inside 
border as seen in the detail below. 
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7.6.3   By Station Range  Outside In Option 
The By Station Range:  Outside In option orients sheets between a rounded station interval.  This 
interval is entered in the Station Range field.  When utilizing this option, the Clip group box also has 
a slightly different look as seen in the graphic depicted below. 

 

The Outside In option is slightly different as seen in the dialog box below. 

 

The Clip Area is no longer variable, but a constant based on the Sheet Size as well as the 
Horizontal and Vertical fields.  In our example, the same 500 feet is keyed in.  When generating the 
sheets, GEOPAK determines the center of the sheet, and the corresponding station.  In our example 
the midpoint of the stationing for the sheet from 120+00 to 125+00 is 122+50.  This point will be 
placed at the midpoint of the sheet as depicted in the drawing below: 
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Since the clip area covers a constant station range, the length of the clipping shape will vary 
depending on the curvature of the alignment. 

7.6.4   By Station Radial Option 
The By Station Range:  Radial option orients sheets between a rounded station interval.  This 
interval is entered in the Station Range field.   

 

An example best describes how this feature works.  In the dialog box below, each sheet has a station 
range of 500 feet.  Based on the station ranges in the bottom of the dialog box, the first sheet would 
encompass station 120+00 to 125+00, while the second sheet would include stations 125+00 to 
130+00. 
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To draw this second sheet, GEOPAK locates the midpoint station 122+50, which in our example is on 
a curve.  Utilizing the chord of curve as the vertical center, GEOPAK draws the top and bottom of the 
clip regions 217.5 feet from the chord, making the clip region 435 feet high.  This is computed from 
the sheet size of 475 minus the vertical keyin of 20 for the top and 20 for the bottom, resulting in a 
435 feet height. 

In the next step, GEOPAK moves to station 125+00 and draws the clip border radial to the alignment 
at the specified station until it intersects with the previously computed top and bottom clip regions.  
The same process is repeated at the other end of the sheet, i.e., 130+00.  Therefore, the inside clip 
region is trapezoidal as depicted in the graphic below. 

 

Since the clip area covers a constant station range, the length of the clipping shape will vary 
depending on the curvature of the alignment. 
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LAB 7:   Plan Only Sheets 
7.1 Getting Started 

Step 1.  Execute C:\data\geo\VDOT\PlansPrep\LAB7.EXE. 

Step 2. Open the Microstation file c:\data\geo\VDOT\PlansPrep\d17682work.dgn.   

 Access Project Manager. 

7.2 Plan Sheet Layout Process 
Step 1. Click the Plan & Profile Sheets button from the Road Project: 17682.prj workflow 

dialog box. 

Step 2. Create a run named Plan to set up the plan sheets. Initially, the dialog box will appear 
similar to the one shown below. 

 

Step 3. Select Settings>Sheet Layout.  Change “Sheet View Attributes” option to Customize 
with Motif Files then click OK.  The completed dialog box is shown below. 

 

Step 4. On the GEOPAK Sheet Layout dialog box, select PLAN from the sheet list then set the 
scale to 25.00 ft/in.  The GEOPAK Sheet Layout dialog box should appear as below. 
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Step 5. Press the Sheet Composition icon.  Populate the Sheet Composition dialog box as 
below. 

 

 

Note:  The Vertical setting will trim off the top and bottom of the clipping shape so that 
plan data will not be placed inside the title blocks on the sheet. 

 

Step 6. Dismiss the Sheet Composition dialog box by pressing the X in the upper right hand 
corner. 

Step 7. Press the Layout Sheets icon.  The GEOPAK Job number 101 should be set from 
Project Manager. 

Step 8. Double click on Port 1.  Set the Chain to MAINLINE by selecting it from the option list. 

Step 9. Press the Create Motif File icon. 
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Step 10. Populate the Create Plan Motif File dialog box as below. 

 

 

Note:  The Seed File can be selected by pressing the Select Seed Motif File icon then 
selecting Plan-Motif.dgn.  The Target File name should be entered manually. 

 
Step 11. Press OK on the Create Plan Motif File dialog box.  A file named Plan-Motif.dgn should 

be created in the working directory and the Plan Port Data dialog box should appear as 
below. 

 

Step 12. Press OK on the Plan Port Data dialog box.  The Layout Sheets dialog box should now 
appear as below. 

 

Step 13. In the Layout Sheets dialog box, set the Extend value for the Begin Station to –200.00.  
This will force the first sheet to end at Station 205+00.00.  The dialog box should appear 
as below.  Click the Layout 4 Sheets button to draw the clipping shapes into the design 
file. 
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 4 clipping shapes should be placed for the Plan port. 

Step 14. Dismiss the Layout Sheets dialog box by pressing the X in the upper right hand corner. 

Step 15. Exit the Plan and Profile Sheet dialog box and save your run.  Review the results. 

7.3 Motif File Setup 
In the following steps we will set up the Motif Files created in the previous section so that the Plan 
view file will be displayed in the Plan Port. 

Step 1. Open Plan-Motif.dgn. 

Step 2. Attach d17682des.dgn as a reference file.  Do a Fit View and Save Settings if 
necessary. 

Step 3. Open d17682work.dgn. 

 

Note:  Any design file that needs to be clipped to the sheets should be attached to the 
Motif Files (e.g. Survey, Utilities, Contours, etc.). 

7.4 Renumber Sheets 
Step 1. Click the Plan & Profile Sheets button from the Road Project: 17682.prj workflow 
dialog box.  Access the Plan run. 

Step 2. Press the Sheet Number Manager icon. 

Step 3. Select Sequence Numbers 1 through 4 then press the Edit Sheet Number button. 
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Step 4. Populate the Edit Sheet Number dialog box as below then push OK. 

 

The Sheet Number Manager dialog box should appear as below. 

 

Step 5. Dismiss the Sheet Number Manager dialog box by pressing the X in the upper right 
hand corner.  Press Yes when prompted to Save Settings. 
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7.5 Clip Plan Sheets 
You should still be in the Plan run from the previous section. 

Step 1. Press the Clip Sheets icon.  Populate the Clip Sheets dialog box as below.  

 

 

Note:  The Sheet Title field will be used to place the Route Number. 

 

Step 2. Click the Process Sheets button to create the plan sheets. 

Step 3. Dismiss the Clip Sheets dialog box by pressing the X in the upper right hand corner. 

Step 4. Exit the Plan and Profile Sheet dialog box and save your run. 

Step 5. Open any of the newly created Plan Sheet files to see the resulting sheets. 

Step 6. Exit MicroStation. 
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D&C Manager – Quantities (Traffic Only) 
8.1   Introduction 
Objectives Understand the operational modes of the D&C Manager including 

calculating automated quantities. 

Project Manager Plan View Design 

Tools 

                      

Menu Bar Application GEOPAK Road > Design and Computation Manager 

 

The Design and Computation Manager (D&C Manager) is a tool that enables the user to standardize 
graphics elements for drafting and pay item quantities.  To review how to access the Design and 
Computation manager, see session 5. 

One of the major goals of any design project is the cost-effective development of plans production 
sheets.  This includes construction plans, profile sheets, estimated quantities, and various other 
sheets needed to actually construct the design.  Although generic MicroStation commands can be 
utilized to produce the required sheets, several GEOPAK tools can be used in conjunction with the 
Design and Computation Manager and these MicroStation commands  to help automate the process.   

Other GEOPAK tools are within the Design and Computation Manager and various plan view 
functions: 

• Controlling Various MicroStation Copy Functions utilizing the Place Influence option and the 
Design mode 

• Controlling the MicroStation Display Filters (Display mode) 
• Changing the MicroStation symbology via GEOPAK Items (Set mode) 
• Identification of plan view areas to incorporate into the automated quantities (Shape mode) 
• Plan view quantities (Compute mode) 
• Pavement Markings 
• Pavement Symbols 

8.2   Operational Modes 
Several operational modes are supported within the Design and Computation Manager.  The Design 
mode was discussed in session 5.  In this session, the following modes are reviewed: display, set, 
shape, compute and pavement markings. 

8.2.1   Display 
Display mode is used to enhance on screen visualization by enabling the user to manipulate the 
display of GEOPAK intelligent elements.  
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The feature(s) to be visualized are added to the Collection box – the bottom window of the D&C 
Manager dialog box when set to Display or Compute modes.  Individual items or entire categories 
can be placed in the collection by utilizing the Add to Collection icon as shown below. 

     

Three display options are supported for the display of the items in the Collection box. 

• Highlight - changes those items stored in the collection area to the MicroStation highlight 
color. 

• Not - simply turns off the display of the collection items leaving everything else on. 
• Only - will turn off everything but the collection items. 

Before utilizing the display filters, visualization is enhanced if all the elements on the screen are gray, 
or another singular color, rather than the vast conglomeration of color seen on the screen for a typical 
project.  Therefore, to set the color, select Settings > Display from the menu bar.  The Display 
Preferences dialog box appears. 

 

8.2.2   Set 
The Set mode allows the user to assign attributes from the ddb database to existing graphical 
elements in the file.  Three methods are available for specifying the graphic elements to be changed: 
individual element selection, Complex Chain or MicroStation Selection Set. 

When changing individual elements, highlight the desired item in the D&C Manager dialog box.  Click 
Set, then datapoint the element to modify, then datapoint off the element to accept. 

Complex Chain automatically creates a chain from graphic elements and applies the attributes of the 
highlighted item in the content box. 
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To modify the symbology of many elements to a single item, create a MicroStation Selection Set of 
the elements.  Next, click Set to transfer the attributes of the item selected in the D&C Manager to the 
items identified in the MicroStation design file. 

     

8.2.3   Compute 
An important, yet time-consuming part of any project is the computation of quantities. Through the 
Compute mode of the Design and Computation Manager, GEOPAK offers tools that make the 
completion of this task much quicker and easier.  In addition, since the software utilizes the plan view 
construction drawings to compile quantities, discrepancies between the drawings and the tabulated 
quantities are non-existent.  Chosen items within either the View or a Fence are calculated 
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Once the MicroStation plan view design file is accessed, the first step is to invoke the Design and 
Computation Manager and click the shortcut button at the top of the dialog box to Compute. 

The dialog box changes dynamically to reflect the compute operation. 

The Design and Computation Manager dialog box is resizable.  Within the dialog box, the sash (long, 
thin bar between list boxes) enables the user to adjust the partition between the list and collection 
boxes while the overall dialog box size remains constant.  Simply place the cursor over the sash and 
dynamically move. 

In addition to dynamically adjusting the main dialog box to reflect the compute operation, the auxiliary 
dialog box is invoked as depicted below.  Note if the auxiliary dialog box was already invoked from 
another operation, it dynamically changes to reflect the Compute operation. 

The next step is the selection of the correct item from the hierarchy.  GEOPAK computes quantities 
only for those hierarchical items that are configured for the computation of quantities. 

Two selection methods can be employed.  The first method is to select an entire category.  GEOPAK 
computes quantities for every item found in the selected category as well as any child categories.  
This is accomplished by double clicking through the groups until the desired category is contained in 
the Content list box.  Single click onto the desired category and click the Add to Collection button at 
the top of the dialog box. 

The second method involves the selection of individual features.  This is accomplished by double 
clicking through the categories until the desired item appears in the hierarchy list box.  When seen in 
the hierarchy list box, a single click onto the desired item and subsequent click of the Add to 
Collection button places the item in the Collection box. 

Several output formats are available as described in the table below. 

 

NOTE:  All Extents options are sensitive to the Inside, Overlap and Clip modes. 

 

 

Job Number GEOPAK Coordinate geometry database (GPK) file wherein the specified chain is 
stored. 

Extents > Active 
Design File 

If the Active Design File toggle is selected, all selected items that are in 
MicroStation file will be computed. 

Extents > View If the View toggle is selected, only selected items that can be seen in 
MicroStation view one will be computed.  If the view includes area outside of the 
Range, the Range will override. 

Extents > Fence If the Fence toggle is selected, a fence must be placed, and all specified 

8-4    VDOT Plans Preparation Training GEOPAK 2004 Edition 



__________________________________________________________GEOPAK® 

graphical features which are inside both the fence and the Range will be 
tabulated. 

Extents > Boundary 
Element 

If the Boundary Element toggle is selected, all selected items that are in a 
selected Boundary Element will be computed. 

Extents > Station 
Range 

If the Station Range toggle is selected, all selected items that are within a 
selected Station Range will be computed. 

Extents > Sheet 
Range 

If the Sheet Range toggle is selected, all selected items that are in a selected 
Plan Sheet Clip Boundary will be computed. 

Extents > Selection 
Set 

If the Selection Set toggle is selected, all selected items that are in a MicroStation 
Selection Set will be computed. 

Extents > Boundary 
Selection Set 

If the Boundary Selection Set toggle is selected, all selected items that are in a 
group of boundary elements within a MicroStation Selection Set will be computed. 

Highlight During 
Computation 

When activated, all MicroStation elements utilized in computations are highlighted 
in the selected color. 

Baseline Reference > 
Chain 

Requires a minimum of one chain which must be stored in the specified job 
number.   

Baseline Reference > 
DGN 

The user can graphically select a DGN Element to be used as a Baseline 
Reference. 

Baseline Reference > 
None 

When None is selected, nothing is used as a Baseline Reference. 

Identify Chain The Identify Chain Selector allows the user to graphically select the desired 
chain.   

Range Left and right offset limits (in master units) from the chain where the quantities will 
be computed.  Any specified item located outside of the limits is not included in 
the report 

Begin/End Station Station range for computing quantities 

Compute Quantities Commences the computation process. 
 

After the desired quantities have been computed, a second dialog box will be displayed containing 
the computed quantities.  The dialog box is shown below. 
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Several output formats are available as described in the table below. 

 
Comp Book  A more detailed report that lists not only quantity summaries, but also 

geometric properties such as plan view coordinates and station/offsets for 
located elements.  File is in ASCII format. 

Item Report Quantities Summary listing pay items, descriptions, units and total 
quantities for located elements.  File is in ASCII format. 

Item Tables  Contains the same information as the Item Report, but formatted in tabular 
form. 

DBMS Very detailed information including calculated and rounded quantities, 
geometric properties, pay item numbers, descriptions, station / offset 
values, etc. The format is the selected database (i.e., Microsoft Access, 
Oracle, SQL Server, and dbase. 

CSV By Item Quantities Summary listing pay items, descriptions, units and total 
quantities for located elements.  Format is in CSV format. 

CSV By 
Element  

A more detailed report that lists not only quantity summaries, but also 
geometric properties such as plan view coordinates and station/offsets for 
located elements.  Format is in CSV format. 

 
Run A method of grouping various quantities and / or pay items. 

Phase Quantities can be separated into various phases, as a means to group 
various pay items.  Default phases include:  Design, Preliminary, and 
Final.  Note the user can add new phases, but must be aware of naming 
limitations of downstream applications (i.e., Transport links in Quantities 
Manager.) 
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8.2.4   Shape 
The placement of shapes for area quantities is simple and fast when utilizing the shape mode.  In 
order to place a shape, GEOPAK must identify a closed area.  This area can be defined by 
intersecting elements, which do not have to be clipped or shortened to define the closed area.  There 
are three options for placing shapes depending on the complexity of the plan view and the type of 
area where quantities are desired: 

• Automatic - best utilized when the elements forming the shape do not conflict with other 
elements in the view. 

• Semi-auto - utilized when the plan view has more conflicting elements or where the selection 
of an area produces very small shapes.  In this method, the user is prompted when each 
element is selected to determine the path of the software in producing shapes. 

• Exclusive - This option utilizes the automatic option, but in addition, prompts the user for the 
identification of an area inside the original shape that is excluded from the area quantity.  The 
Exclude mode is useful for curb and gutter around a traffic island. 

Any of the three options may be chosen during the course of shape placement.  To change from one 
option to another, simply adjust the option button on the left side of dialog box. 
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8.2.5   Pavement Marking 

 
The Pavement Marking mode allows the user to place pavement marking including striping, and 
symbols. 

The various tools are detailed in the table below. 

Striping 

 

Places single or double, solid or skip pavement stripes. 

Separation 

 

Places traffic separation pavement marking. 

Chevron Diverge  

 

Places pavement chevrons in areas of diverging traffic. 

Chevron Merge 

 

Places pavement chevrons in areas of merging traffic. 
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8.2.5.1   Single Striping  
This dialog box offers predefined configurations for single stripe 
and double stripe options to easily control the type of striping 
being placed. 

The pay item reflects the currently selected pay item in the D&C 
Manager dialog box; however, it may be changed at any time 
during the process. 

Next, define the start option by selecting Solid or Skip (or a 
combination thereof).  If Skip is active, the user must define the 
stripe and skip lengths.  If an ending stripe is shorter than the 
Tolerance value, it will not be drawn. 

A beginning and ending point for the limits of striping are 
entered from digitized points on the screen. 

The lower portion of the dialog box provides tools for identifying 
the reference element on which the striping will be based. 

 

After clicking Draw Stripes, the user must enter a data point on either side of the reference element 
to begin striping.  Striping is placed at the indicated offset value; the data point controls whether 
striping is offset left or right.  Striping is placed as a graphic group. 

8.2.5.2   Double Striping 
The process for Double Striping is the same as Single, except 
for having two pay item placement options, Inside and Outside 
and a user definable Distance Between Stripes.  The user must 
select either the Inside or Outside button for the highlighted 
(D&C Manager) pay item to be displayed in the dialog box.  
Separate quantities are calculated for each stripe.  

The remaining process is the same as described above. 
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8.2.5.3   Separation 
This option draws pavement markings between two sets of 
selected elements.  Elements may be either GEOPAK or 
MicroStation generated.  

Once a pay item has been selected, the user may set the 
Distance Between Stripes and the Slash Stripe Angle.  
Tolerance functions the same as for striping. 

A Begin DP and End DP should be issued before the Reference 
DP is identified.  The Reference DP must fall between the 
beginning and ending DP.  It marks the location of the first 
pavement marking and determines the direction of the slashed 
stripe.  All other markings will be based on the first stripe. 

Tools for defining the limits of the pavement markings are located 
at the bottom of the Separation dialog box.  ID Intersection 
identifies the elements where the striping will terminate.  ID 
Location is the set of elements from which the striping begins. 

 

After the Draw Separation button is selected, the user must issue a data point in the graphics file for 
the pavement markings to be displayed. 

8.2.5.4   Chevron Diverge 
Once the pay item and its relative parameters have been defined, 
there are three points needed to define the chevron: Gore, 
Breaking Line and Point. 

The Gore point defines the wide end of the gore. 

The Breaking Line point must fall between the two sides of the 
gore and sets the location of the point at which the chevron 
diverts in a different direction. 

The Point represents the narrow end of the gore where chevrons 
are to stop. 

Use the Side 1 and Side 2 buttons to identify the sides of the 
gore.  Once the Draw Chevron Diverge button is selected, the 
chevrons are displayed. 

8-10    VDOT Plans Preparation Training GEOPAK 2004 Edition 



__________________________________________________________GEOPAK® 

8.2.5.5   Chevron Merge 
This process works basically the same as Chevron Diverge 
except the two points, Gore and Breaking Line, have been 
combined into one point that serves both functions.  

The Gore and Break DP should be located near the wide end 
of the chevron.  It simultaneously sets the beginning of the 
pavement markings and the point at which the chevron will 
break. 

The remainder of the process is as described above. 
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LAB 8:   Quantities with D&C Manager 
8.1   Accessing Plans Production Tools 

Step 1. Execute C:\data\geo\VDOT\PlansPrep\LAB8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\vdot\PlansPrep\d17682Traffic.dgn. 

Step 3. Access the Road Workflow dialog box in Project Manager. 

 Click the Plan View Design button.  This opens the Plan View Design tools tool 
frame.  Open Design and Computation Manager by clicking the left most icon. 

 

Step 4. D&C Manager should open up to the standard VDOTenglish.ddb. 

  Navigate to the category Traffic > Proposed as shown. 
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8.2   Compute Quantities 
Step 1. Set the current D&C mode to Compute. 

 Highlight the item Junction Boxes > 56004 JB-2A or 2B, Junction Box. This will make 
it the active item for computing quantities. 

 

Step 2. Use the Display options to make sure there are graphics to compute for this item. 

 By clicking on the icon as shown below, all graphics except the appropriate Junction Box 
graphics should be turned off. 

 

Step 3. Populate the supplemental dialog box as shown below. 

 

Step 4. Since we are doing the quantities based on what is displayed in View 1, be certain to fit 
all graphics in View 1. 

Step 5. Click Compute Quantities.  Review the output.   
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Step 6. Now let’s see how to compute multiple items at one time. 

 Returning to the main D&C dialog box, add the Junction Box item to the collection box as    
shown: 
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Step 7. Also, add the items listed below to the collection box: 

Traffic > Proposed > Pole Foundations > 51234 Concrete Foundation Signal Pole 

Traffic > Proposed > Controllers > 51030 Prop. Controller Cabinet 

Traffic > Proposed > Signal Pole Mast Arms > 51309 SIG. POLE MP-1 ONE ARM 22FT 

Traffic > Proposed > Signal Pole Mast Arms > 51321 SIG. POLE MP-1 ONE ARM 34FT 

Traffic > Proposed > Hanger Assemblies > 51822 SW -1 or 2, ONE WAY 

Traffic > Proposed > Loop Detectors > 51540 6 x 40 Prop. Loop Detector 

Traffic > Proposed > Loop Detectors > 51540 6 x 20 Prop. Loop Detector 

Traffic > Proposed > Conduit > All Sizes, Metal or PVC 

 

The D & C Manager dialog box should appear as below. 
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Step 8. Click Compute.  Review the output.   

 

Step 9. Next we will export the quantities to an Item Report.  Set the Export Format option to 
Item Report.  Enter the output file name item.txt.  The dialog should appear as below. 

 
Step 10. Click Export.  A file named item.txt should be created in the working directory. 
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Step 11. Open item.txt using the GEOPAK editor.  The file should appear as below. 

 

Step 12. Dismiss the GEOPAK editor. 

Step 13. Exit Design and Computation Manager. 

Step 14. Exit MicroStation. 
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LAB 9:  Special Applications 
9.1   Right of Way Data Sheet 

This special application will read an Excel spreadsheet created from RUMS. It will then take the 
information from the spreadsheet and automatically fill out a Right of Way Data Sheet. 

Step 1. Execute C:\data\geo\VDOT\PlansPrep\LAB9.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\PlansPrep\d17682RWSheet.dgn 

Step 3. Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 4. Select the icon Plan View Design button from the Road Project: 17682.prj workflow 
dialog box, which opens the Plan View Design tool box. 

 

Step 5. Select the Design and Computation Manager icon (as indicated above) to invoke the 
Design and Computation Manager shown below. 
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Step 6. Navigate to the item shown in the dialog box below. 

 

Step 7. Double-Click on the item to kick off the application. You will see the dialog below: 

 

Step 8. Using the Select buttons on the dialog, set the dialog to appear as shown below: 

 

Step 9. Click OK. 

Step 10. You will see the following warning: 
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In order for this application to work correctly, the Excel 
spreadsheet containing the information from RUMS MUST be 
open. If it’s not, the application will not be able to read it. 

 

Step 11. At this point we need to open the Excel spreadsheet (Excel From RUMS English.xls).  

   Minimize MicroStation, open the spreadsheet in Excel, then re-expand MicroStation to 
continue our application. 

 

 

Note that when the spreadsheet was opened makes no 
difference (i.e. it could have been opened before we kicked off 
the application). It only matters that the spreadsheet is opened 
before we continue from this point. 

 

Step 12. Click OK. 

Step 13. Dismiss D&C Manager and review the information plotted on the sheet. 

Step 14. Exit MicroStation. 

Step 15. Exit Excel. 
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9.2   Traffic Engineering Conduit and Cable Placement 
This special application automates the placement and computations of conduit and cable. 

Step 1. Open the MicroStation file c:\data\geo\VDOT\PlansPrep\d17682Traffic.dgn 

Step 2. Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 3. Select the icon Plan View Design button from the Road Project: 17682.prj workflow 
dialog box, which opens the Plan View Design tool box. 

 

Step 4. Navigate to the item as shown below and make sure that you have the Design Mode icon 
selected. 

 

Step 5. In the secondary dialog, enable the Place Influence toggle. 

 

Step 6. With the Conduit item selected (Step 4) and the Place Influence toggle enabled (Step 5), 
place a Microstation line between Junction #1 and Junction #2. 

9-4    VDOT Plans Preparation Training GEOPAK 2004 Edition 



__________________________________________________________GEOPAK® 

Step 7. When prompted, set the Conduit size to 2” then click OK. 

 

Step 8. Set the Conduit Material type to PVC then click OK. 

 

Step 9. Set the Conductor Cable type to 14/5 then click OK. 

 

Step 10. When prompted to add another conductor cable, select Yes then click OK. 

 

Step 11. Set the Conductor Cable Type again to 14/5 then click OK. 

 

Step 12. When prompted to add another conductor cable, select No then click OK. 

 

Step 13. Repeat steps 6-12. This time place a 3” Metal conduit between Junction #2 and Junction 
#3 and place two 14/2 Shielded conductor cables. 

Step 14. Repeat steps 6-12. This time place a 2” PVC conduit between Junction #3 and Junction 
#4 and place two 14/2 Shielded conductor cables. 
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Step 15. Select the Compute Mode icon as shown. The secondary dialog will change. 

 

 

Step 16. Press the Add to Collection Box icon to add the Conduit item to the collection box. 
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Step 17. Highlight the Cable category then press the Add to Collection Box icon again to add the 
Cable category the collection box. 

 

Step 18. Populate the secondary dialog as shown. 

 

Step 19. Ensure that the Conduit and Cable placed in steps 4 through 14 is displayed in the view 
then click the Compute Quantities button. 

Step 20. A sample output is shown below.  Your actual quantities may differ depending on the 
placement of the Conduit. 

 

GEOPAK 2004 Edition LAB 9:  Special Applications    9-7 



GEOPAK®__________________________________________________________  

Step 21. Next we will export the quantities to an Item Report.  Set the Export Format option to 
Item Report.  Enter the output file name item.txt.  The dialog should appear as below. 

 
Step 22. Click Export.  A file named item.txt should be created in the working directory. 

Step 23. Open item.txt using the GEOPAK editor.  The file should appear as below. 

 

Step 24. Dismiss the GEOPAK editor. 

Step 25. Dismiss the Computation Results dialog box. 
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9.3 Pavement Striping 
In this section we will place Pavement Striping then compute quantities for the Pavement Striping. 

9.3.1   Accessing Plans Production Tools 
Step 1. Access the Road Workflow dialog box in Project Manager. 

 Click the Plan View Design button.  This opens the Plan View Design tools tool 
frame.  Open Design and Computation Manager by clicking the left most icon. 

 

9.3.2   Pavement Striping - Skip 
In this section, we are placing pavement striping parallel to the main alignment. 

Step 1. Attach the Saved View “SKIP”. 

Step 2. Change the Mode to Pavement Marking and select Traffic > Proposed > Striping > 
LINE4 – 4’ Line 

 

Step 3. Select the Striping Operation as shown above to access the Striping dialog box. 
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Step 4. Populate the Draw Striping dialog box as shown below. 

 

Note:  Be sure that your graphic group lock is off before the next step. 

Step 5. We are only going to strip a small portion of our project.  Click Draw Stripes.  The 
striping is attached to the cursor.  You can move to either side of the baseline and place 
the striping.  Data point on the left side of the alignment. 

Step 6. Click Reset (right mouse click). 

Step 7. Click Draw Stripes again to place the striping on the other side of the road.  The finished 
striping should appear as below. 

 

Step 8. Dismiss the Draw Striping dialog box by clicking on the X in the upper right corner of the 
dialog box. 
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9.3.3   Pavement Striping – Gore Area 
Step 1. Attach the Saved View “GORE”. 

Step 2. Leave the Mode set to Pavement Marking and select Traffic > Proposed > Striping > 
LINE24 – 24” Line 

 

Step 3. Select the Chevron Diverge Operation as shown above to access the Draw Chevron 
Diverge dialog box. 

Step 4. Populate the top portion of the Draw Chevron Diverge dialog box as shown below. 
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Step 5. Set the Gore coordinates by pressing the Gore Point button then selecting the location 
indicated below. 
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Step 6. Set the Breaking Line coordinates by pressing the Breaking Line button then selecting 
the location indicated below. 
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Step 7. Set the Point coordinates by pressing the Diverge Point button then selecting the 
location indicated below. 

 

Step 8. Set Side 1 and Side 2 options to Complex Chain. 

Step 9. Click the Identify DGN Element button for Side 1 then select the elements on the left 
side of the gore area.    Continue to data point until all the elements have been 
highlighted.   

Step 10. Click the Identify DGN Element button for Side 2 then select the elements on the right 
side of the gore area.    Continue to data point until all the elements have been 
highlighted. 

Step 11. Click Draw Chevron Diverge, then move the cursor to the inside of the gore area and 
issue a datapoint.   
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The gore area should be striped as below. 

 

 

Step 12. Turn on levels 1-7 to review the completed gore area. 

Step 13. Dismiss the Draw Chevron Diverge dialog box by clicking on the X in the upper right 
corner of the dialog box, but leave the main D&C Manager dialog active. 
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9.3.4   Compute Quantities 
Step 1. Attach the Saved View “SKIP”. 

Step 2. Change the current D&C mode to Compute. 

 

Step 3. Click item LINE4 – 4” Line to make it the active item for computing quantities. 

Step 4. Set the supplemental dialog box as shown below then click Compute Quantities. 

 

Step 5. A sample output is shown below.  Your actual quantities may differ. 
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Step 6. Next we will export the quantities to an Item Report.  Set the Export Format option to 
Item Report.  Enter the output file name strip.out.  The dialog box should appear as 
below. 

 
Step 7. Click Export.  A file named strip.out should be created in the working directory. 

Step 8. Open strip.out using the GEOPAK editor.  The file should appear as below. 

 

Step 9. Dismiss the GEOPAK editor. 

Step 10. Dismiss the Computation Results dialog box. 
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Step 11. Attach the Saved View “GORE”. 

Step 12. Click item LINE24 – 24” Line to make it the active item for computing quantities. 

Step 13. Set the supplemental dialog box as shown below then click Compute Quantities. 

 

Step 14. A sample output is shown below.  Your actual quantities may differ. 

 

Step 15. Next we will export the quantities to an Item Report.  Set the Export Format option to 
Item Report.  Enter the output file name gore.out.  The dialog box should appear as 
below. 

 
Step 16. Click Export.  A file named gore.out should be created in the working directory. 
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Step 17. Open gore.out using the GEOPAK editor.  The file should appear as below. 

 

Step 18. Exit MicroStation. 
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Existing Ground Profiles (Optional) 
10.1   Introduction 
Objectives Learn to draw and store existing ground profiles extracted from a surface 

model. 

Project Manager NOTE: This application is not available through Project Manager 

Tools 

 
 

Menu Bar Application GEOPAK Road > Plan Preparation > Draw Profile 

 

The Draw Profile tool enables the user to draw several profiles from a variety of sources 
simultaneously. 

• GEOPAK coordinate geometry database wherein the vertical alignment is stored.   
• GEOPAK binary TIN file, Site Model or Site Object.  The Site Model or Object are created 

utilizing GEOPAK Site Modeler software and are stored within the GEOPAK Site project (gsf) 
file. 

 

In addition, if the source data is TIN files or site components, the resultant profile may optionally be 
stored within the coordinate geometry database. 

GEOPAK 2004 Edition Existing Ground Profiles (Optional)    10-1 



GEOPAK®__________________________________________________________  

10.2   Invoking the Draw Profile Tool 
The generation of profiles must be invoked from within the 2D MicroStation design file wherein the 
profile is to be drawn.  When the tool is selected, the dialog box depicted below opens.   

 

The initial entries that are required are the Job Number and Chain name.  Once selected, click the 
Dialog Profile Cell Control icon(to the right of the Job Number field).  This will invoke the Profile 
Cell Control window shown below.   

 

Select the Active Chain that the new or existing profile is to be stationed along.  If no profile cell 
exists, click the Place Profile Cell icon along the right side of the window to place a new cell.  If 
multiple profile cells exist, highlight the desired cell and click the Activate Profile Cell icon. 

10.2.1   Update Options 
Four update options exist that allow the user the control needed to tell the software what to do if a 
profile has been previously drawn in the file and needs updated.  The options are toggled off / on by 
each selection of the option by clicking the Update Options pulldown.  The check to the left of the 
option indicates the option is active.  Only one option may be active at any given time, therefore, if an 
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option is selected, the previous active option is de-activated.  The four options are detailed in the 
table below. 

Delete Existing Elements and 
Redraw 

When this option is activated, any profiles previously drawn with 
this tool are deleted and new ground lines are drawn. 

Delete Non-Modified Elements 
and Redraw 

When this option is activated, any profiles previously drawn with 
this tool and not modified with any MicroStation commands are 
deleted and new ground lines are drawn. 

Draw on Top of Existing When this option is activated, any previously drawn profiles are 
ignored and a new set is drawn, resulting in multiple copies of 
each profile. 

Query When activated, the user is prompted each time the Draw button 
is pressed. 

 

10.2.2   Surfaces Tab 
The Surfaces tab defines the surfaces utilized as source data when drawing profiles.  Multiple 
surfaces from a variety of sources can be drawn in a single processing.  When the tab is selected, 
the dialog box dynamically changes as depicted below. 

 

Each surface to be drawn must be added to the list box.  This is accomplished via the action / edit 
buttons on the right side of the dialog box.  Each surface draws a cross section line string or lines.  
When a line is added to the list box, the profile is drawn.  Note:  clicking on the draw toggle in the list 
box deletes or redraws the profile. 
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To add to the list box, simply select the source data and method, Display Settings, Tolerances and 
Offsets, and then add the profile to the list.  Once a profile is drawn, it may be updated at any time by 
using the Update Profile icon.  Refer to the Update Options section to review those options.  Any 
profile may optionally be stored to the GPK file if desired. 

10.2.3   Display Settings 
The Display Settings group box specifies the element symbology of the cross section elements being 
generated.  The symbology may be specified using Level Symbology or a feature selected from a 
D&C Manager database. 

To use By Level Symbology, set the option to By Level Symbology, then double click on the 
graphic.  This opens the Set Feature dialog box, wherein the symbology can be specified.  Click OK 
when completed. 

To use By Feature, set the option to By Feature.  Next, press the Paintbrush icon, which invokes the 
current Design and Computation Manager.  Select the desired item, and then press the OK button, 
which closes the Design and Computation Manager, and populates the Draw Profile Display Settings 
group box. 

10.2.4   Filter Tolerances 
Both Horizontal and Variance filter tolerances are considered together for each pair of profile 
segments.  The middle point is deleted if both segment lengths are less than the Horizontal filter 
tolerance while the projected distance between the mid-point and the chord between the two end 
points is less than the Variance tolerance. 

 

10.2.5   Offsets 
Vertical or Horizontal Offsets may be specified in terms of master units (i.e., feet or meters).  The 
Horizontal Offset is the distance offset from the Chain.  Once the horizontal location for the profile is 
determined, the data source is utilized to determine the profile.  Any Vertical Offset is applied after 
the profile is generated from the source data. 
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10.2.6   Store Profile to COGO 

 

When the profile is drawn, it may also be stored in COGO by 
pressing this button, which opens the dialog box depicted 
below left. 

 

The profile may be stored, or just the input file may be 
created.  If an input file is created, the Operator Code and 
File Name are required.  If the dialog box is invoked while in 
a 3D file, the user may toggle on the option to create a 3D 
profile string. The 3D profile string consists of the circles 
denoting every location where the design centerline 
intersects topographic elements.  If the circles are not 
deleted at this time, they can be deleted at any time with a 
single application of the MicroStation "Delete Element" 
command. 

10.2.7   Cogo Tab 
The Cogo Tab is utilized for drawing any profile that has been previously stored into the GPK file. 

 

To draw a profile, first select the Profile Name to be drawn.  The Vertical Offset defaults to a value 
of 0, but can be set to any value.  This instructs the software to draw the profile at a distance above 
or below the elevations in the GPK file.  Station Limits may also be specified to have the software 
draw only a portion of the profile.  If the Display Settings are set to By Feature and a feature is 
selected, the Options area of the dialog box is un-ghosted.  This is where various labeling options for 
the profile can be specified.  If a value is given for the Strip Grade Increment, elevations will be 
placed at that increment along the bottom of the profile. 
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10.2.8   Projection Tab 
The Projection tab can be used when the chain / profile to be drawn is different than the chain / profile 
used to create the profile cell. 

 
Each projected profile to be drawn must be added to the list box.  This is accomplished via the action 
/ edit buttons on the right side of the dialog.  When a line is added to the list box, the profile is drawn. 
Note: Clicking on the draw toggle in the list box deletes or redraws the profile. 
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10.3   Profile Report 
To review a textual report listing stations and elevations of a ground profile, open the GEOPAK 
Coordinate Geometry dialog box.  A couple of different methods can be used to create this listing for 
any profile.   

By selecting Element > Profile > Utility then 
highlighting a specific profile name and clicking Print.  
The results of this command will be displayed in the 
Command Output window of the Coordinate 
Geometry dialog box.  To obtain a hardcopy of this 
information, create an output file using the File > File 
Utility > Output command and supply a filename of 
1-5 characters.  Then use the File > File Utility > 
Print Output File command to print this to the 
default system printer.  

The second method utilizes the COGO Navigator tool 
to create the Print Profile command.  The 
advantage to this method is that multiple profiles can 
be identified at once and printed to the Command 
Output window.  Start the COGO Navigator by 
clicking Tools > Navigator or selecting the icon from 
the COGO dialog box.  Change the Element to 
Profile then highlight the desired profile(s).  Once 
selected, click the Print/Describe Element icon on 
the Navigator to process the profile(s). 

 

10.4   Drawing Profiles with D&C Manager 
As with other COGO elements, 
Design and Computation Manager 
will be utilized to draw any type of 
profile into a MicroStation file:  
existing roadway, proposed 
roadway, utility, special ditch, etc.  
To get started, open D&C Manager 
then navigate to the desired item for 
plotting of the profile.  Upon 
selecting an item, click on the Draw 
Plan & Profile button on the 
supplemental D&C dialog box. 
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The next dialog box that appears is the GEOPAK Draw Plan & Profile window, as depicted below. 

 

If it is not already selected, change the Operation to Profiles.  Displayed in the window is a list of 
profiles currently stored in the GPK file.  Along the right side of the window are labeling options for the 
profile that is to be plotted.  Configure these as desired before selecting a profile to plot.   

• VPI Labels – Labels the station and elevation of the VPI – typically turned off for plotting of 
existing profiles. 

• Horizontal Axis – Places stations along the bottom of the profile. 
• Vertical Axis – Places elevations along the left side of the profile. 
• VC Parameters – Labels the length of the vertical curve if applicable. 
• VPC/VPT Labels – Annotates the station and elevation of a vertical curves control points. 
• Stopping Sight Distance – Places text for crest vertical curves representing the curves 

stopping sight distance as defined by AASHTO. 
 

After selecting a profile to plot, the dialog box below opens.  Since a profile does not have XY 
coordinates, the user must specify a location in the MicroStation file to place the profile and a scale at 
which to plot the profile.  When using a ratio other than 1:1, the horizontal dimensions of the profile 
remain true and the vertical is exaggerated. 
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The location can be selected by clicking on the 
DP button then specifying a location in the file by 
issuing a data point in the view.  The coordinates 
can also be keyed in to the dialog box.  A Profile 
Cell can be drawn into the file to represent the 
location of the data point and associated 
information.  This cell can be used in any other 
GEOPAK tool that needs to know the location of 
the profile.  A PGL Chain must be selected before 
drawing the profile cell.  This chain will be the 
chain that the profile is stationed along.   

If a value is specified for the Strip Grade 
Increment, elevations will be calculated at the 
desired interval along the profile and placed just 
above the Horizontal Axis Labels (stations). 

Click OK to draw the profile. 
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LAB 10:   Existing Ground Profiles 
In this exercise, existing ground profiles will be drawn representing the centerline of chain MAINLINE. 

10.1   Draw Existing Ground Centerline Profile 
Step 1. Execute C:\data\geo\VDOT\PlansPrep\LAB10.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\PlansPrep\d17682prof.dgn 

 Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 3. The file d17682des.dgn should be attached as a reference. 

Step 4. Select the Draw Profile tool from the Road Tools palette.   

 

 The dialog box below will open. 
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Step 5. Select chain MAINLINE. 

Step 6. Click the Dialog Profile Cell Control icon (to the right of Job Number).   

 

 Set the Active Chain to MAINLINE. 

 

Step 7. Click the Place Profile Cell icon on the right side of the dialog box.  This will open the 
Place Profile Cell dialog box. 

 

Step 8. Fill the dialog box out as shown above and then DP somewhere to the right of the plan 
view reference file in order to place the profile cell into the design file.   

 Fit the view contents.   

 Close the Profile Cell Control dialog box. 

Step 9. From the Surfaces tab, select the folder icon in the Details area, then select the 
SURVEY.TIN file for the TIN File to cut the profile.  Set the Method to Triangles.  This 
instructs the software to compute elevations at each location that the chain intersects a 
triangle leg from the TIN. 
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Step 10. Use By Feature mode in the Display Settings area of the dialog box.  Click the 
Paintbrush icon and select the item shown below. 

 

 

 Press OK. 

Step 11. Click the Add Surface Settings icon to add the profile to the list box as well as draw the 
profile into the Microstation file. 
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10.2   Store Profiles into COGO Database 
Step 1. Click the Store Surface in COGO icon.   

 

 This will invoke the Store Profile dialog box. 

 

Step 2. Fill out the dialog box as shown above and click Apply.  ‘MLG101.ivd’ will be created in 
the working directory.  This file will contain the COGO commands used to create the 
existing ground profile.   

Step 3. Dismiss the Store Profile dialog box by clicking the X in the upper right hand corner. 

Step 4. Click the Remove Surface icon.  This will erase the profile from the DGN file.  We will re-
draw the profile shortly. 
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10.3   Review Profiles in COGO 
Step 1. Access the coordinate geometry tool.  (Press the Coordinate Geometry button on the 

workflow dialog box).  This will open the Coordinate Geometry dialog box. 

Step 2. Select Element > Profile > Utility from the COGO menu bar to invoke the Profile Utility 
dialog box. 

 

Step 3. Select the profile ‘MLGROUND’ then click the Print icon. 

Step 4. Review the profile information in the COGO output display window. 

Step 5. Close the Coordinate Geometry dialog box (use X in upper right corner of the dialog box).  
When prompted to save the COGO session select NO. 
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10.4   Drawing & Labeling the Existing Centerline Profile 
Next, we are drawing and labeling the existing profile utilizing the Draw Profile tool’s COGO tab. 

Step 1. Click the COGO tab and set the Label Scale to 25 in the upper right hand corner. 

Step 2. Select Profile Name MLGROUND from the drop down list in the Details area. 

Step 3. Under the Display Settings set the option to By Feature.  Select the feature shown 
below and click OK. 

 

Step 4. Click General in the Options area and set the Strip Grade Increment to 50.  This will 
label the elevations every 50’ along the bottom of the profile area. 

 

Step 5. Click the Add Cogo Profile Settings icon to draw the profile.  This will draw the existing 
ground profile with the proper symbology in addition to labeling the stations and 
elevations along the bottom of the profile and the elevations along the left side of the 
profile. 

Step 6. Dismiss the Draw Profile dialog box by clicking the X in the upper right hand corner. 
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10.5   Project Manager - Define 
We are completing the Profile View and Location sections of the Working Alignment Definition in 
Project Manager. 

Step 1. From the Workflow dialog box of Project Manager, press the Define button. 

Step 2. Highlight the Profile View option and populate the dialog box as depicted below. 

 

 

 

We have not designed the proposed profile; therefore, we will return to populate this field in 
a later exercise. 

 

Step 3. Highlight the Location option.  To quickly populate this category within working 
alignment, click Identify Cell, then data point on the cell for the centerline profile in the 
file and accept. 

Note:  Your coordinates may be different than those shown below.  That is not a problem. 

 

Step 4. Press the OK button to save the updates and close the dialog box. 

Step 5. Exit MicroStation. 
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Vertical Alignment Generators (Optional) 
11.1   Introduction 
Objectives To create and store vertical alignments using the Vertical Alignment 

Generator. 

Project Manager Vertical Alignment 

Tools 

       

Menu Bar Application GEOPAK Road > Geometry > Layout Profiles (VPI Based) 

GEOPAK Road > Geometry > Layout Profiles (Component Based) 

 

GEOPAK has a variety of tools for generating and storing a proposed profile.  Those tools include: 

• 

• 

• 

The Vertical Alignment Generator (VPI Based) is a GEOPAK tool that can 
graphically create and modify proposed design profiles or modify an existing ground 
profile.  The designer can generate a profile based on VPI data, design speeds, 
stopping sight distances, and K values.  These operations may be accomplished 
through a dialog box and/or by dynamic manipulation of graphic elements. 

The Component Based Vertical Alignment tools provide the user with a myriad of 
tools to place, modify and delete profile components.  Tool boxes organize tools to 
include the placement of tangent lines, a variety of vertical curves.  Components 
interact with each other to automatically trim vertical curves, connect various 
elements, and modify, copy and rotate components.  The user also has the option to 
store completed profiles in the coordinate geometry database. 

A profile may also be created with Coordinate Geometry (COGO) input (key in 
commands).  In addition, there are VC commands that compute and display vertical 
geometry and the parameters associated to aid in the development and generation of 
vertical alignments used in conjunction with Store Profile commands.  VC commands 
define parabolas for various combinations of stations, elevations, grades, slopes and 
the rate of vertical curvature (K value), and also define the tangents between two 
parabolas or between a parabola and a point. 

This chapter focuses on the two graphical based tools - Vertical Alignment Generator and 
Component Based Vertical Alignment. 
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11.2   Vertical Alignment Generator 

11.2.1   Accessing 
When selecting the Vertical Alignment generator, the first dialog 
box that appears is labeled Settings, as depicted here.  The 
entries in this box set the parameters and define the location 
within the design file where the profile components are to be 
displayed.  All fields must be completed before the design 
process can begin.  Once the OK button is pushed, the Vertical 
Profile Generator dialog box appears. 

Note: This tool also utilizes the cell that was drawn in the 
previous exercise by using the Identify Cell button.. 

 

11.2.2   Using the Vertical Alignment Generator 
This tool enables a user to load a previously stored profile or create a new profile.  You will notice the 
dynamic changes in the dialog box throughout the vertical alignment design. 
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Various design parameters must be defined prior to designing a new profile; which are discussed in 
the options supported under the three menu options; File, Tools, and User. 

11.2.3.1   File 
 

 

Clear - clears the profile display from MicroStation graphics and removes all VPI’s 
from the dialog box. 

Draw - write the graphic elements of the profile to the MicroStation file. 

Load - retrieves a previously stored profile from the coordinate geometry database 
(.gpk) 

Save - stores a new profile or updates (redefines) a previously stored profile under the 
same name. 

Save As - is used to store the profile or to save a modified profile under a different 
name. 

Exit - ends the process. 

11.2.3.2   Tools 
 

 

Critical Points - Vertical curves may also be defined by one or two critical points – i.e. 
the curve will pass through these points  If mathematically solvable, the vertical curve 
will be drawn and the design speed display adjusted to fit the current parameters. 

Issue Data Point - Permits the user to type in stations and elevations, issue a data 
point that can be part of a MicroStation place line, place a cell or perform other generic 
operations.  This is useful in displaying visual references within the profile that need to 
be considered in design of the vertical profile. 

11.2.3.3   User 
 

 

Preferences - sets the rounding parameters for each of the items listed in the dialog box.  
Also contains a toggle that will force the dialog box to window center the view on the current 
VPI.   

K Values - is a table of stopping sight distance K-values for crest and sag conditions for 
various design speeds.  These values are based on the AASHTO Green Book. 
Settings - recalls the Settings dialog box that first appeared upon initializing Vertical 
Layout. 
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11.2.4   Creating A New Profile 

 

The enter/tab key must be used to ensure values are accepted. 

 

A new profile can be created with the following steps: 

Step 1. Place the first VPI using one of the four supported options. 

• 

• 

• 

• 

Type station and elevation of the VPI into the appropriate fields in the Profile 
Generator dialog box. 

Enter station of VPI as precision input (type in value), and allow the elevation to be 
defined through dynamic cursor placement on screen. 

Elevation is defined via precision input, and the station is defined through dynamic 
cursor placement on screen. 

Both values for the VPI can be established dynamically on screen by clicking on the 
Dynamic button and placing a DP in the view at the desired station and elevation. 

 
Step 2. Define ahead (or back tangent) 

 Station, elevation, grade and length parameters may be defined via precision input, 
dynamic manipulation or a combination of both. 

Step 3. Define remaining VPI’s and Grades 

 A repetition of Step 2 with an option to insert VPI’s between two existing VPI’ s. 

Step 4. Define Vertical Curves 

 Simply define the design speed from the Speed option button and GEOPAK will 
reference the K-value table and draw the vertical curve.  If a curve overlap occurs, an 
overlap message will be displayed in the dialog box along with the overlap length.  
Length of Curve or K-value may also be keyed in. 

Step 5. Adjusting Curve Lengths 

 The vertical curve can be modified by directly keying in either the K-value, curve length or 
defining the design speed in the dialog box.  You will see the values computed 
automatically adjust to reflect the results of any modifications. 

Step 6. Save the Profile 

 Click File > Save As to name and save the newly created profile.  The names of profiles 
are any 1-9 alphanumeric characters. 
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11.2.5   Precision Placement Options 
 

 

Options available for creating or modifying vertical curves, VPI’s and grade lines:  
• OFF - Values change. 
• INC (Increment) - Ensures that the designated profile parameter will be adjusted as 

defined in the Preferences dialog box. 
• LCK (Locked) - Forces selected operations to maintain the designated profile 

parameters. 

11.3   Component Based Vertical Alignment 
This tool requires COGO and the active chain control to be active.  If a COGO session in not open, 
an Alert message is displayed.   

11.3.1   Accessing 
When the tool is selected, the tool frame illustrated below opens.   

 

The 2x2 tool frame is similar to the MicroStation main tool frame.  It is not resizable, but dockable.  
Each icon in the tool frame is a tool box that one can "tear off" to become a "tool box." The individual 
tool boxes can be docked and resized.  There are four tool boxes, with the following titles: 

• Place Vertical Alignment Lines 
• Place Vertical Alignment Curves 
• Profile Tools 
• Manipulate Vertical Alignment Elements 

11.3.2   Place Vertical Alignment Lines 

 

The Place Vertical Alignment Lines tools are detailed in the table below. 

 
Create a Profile Line by Two Points 

This tool enables the user to place a profile line by defining two points.  Optionally the 
slope or length of the line may be fixed. 

 
Create a Profile Line Tangent to One Element 

This tool enables the user to place a profile line tangent to a curve. 

 
Create a Profile Line Tangent to Two Elements 

This tool enables the user to create a Vertical Alignment line tangent to two curves. 
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11.3.3.   Place Vertical Alignment Curves 

 

The Place Vertical Alignment Curves tools are detailed in the table below. 

 
Place a Vertical Curve by Three Points 

This tool enables the user to place a profile curve by three points. 

 
Place a Vertical Curve by High Point 

This tool enables the user to place a vertical curve by defining a high point (or in the 
case of a sag curve, the low point). 

 
Place a Vertical Curve Tangent to One Element and Through One Point 

This tool enables the user to place a profile curve tangent to one element (line or curve) 
and defining a pass through point. 

 
Place a Vertical Curve Tangent to One Element Given High Point 

This tool enables the user to place a profile curve tangent to one element and defining a 
high point or low point. 

 
Place a Vertical Curve Tangent to Two Elements 

This tool enables the user to place a profile curve tangent to two elements (any 
combination of lines and curves). 

11.3.4   Manipulate Vertical Alignment Elements 

 

The Manipulate Vertical Alignment Elements tools are detailed in the table below. 

 
Move a Profile View Element 

This tool enables the user to move an element or to make copies.  Note the moved or 
copied element must remain within the confines of the profile cell and associated delta 
top and bottom values. 

 
Rotate a Profile View Element 

This tool rotates the selected tangent about a user-defined point. 

 
Extend a Profile View Element 

This tool can extend or shorten any Vertical Alignment element, either tangent or 
vertical curve. 
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11.3.5   Profile Tools 

 

The Profile Tools tools are detailed in the table below. 

 
Store a Vertical Alignment in COGO 

This tool enables the user to store graphical profile components (lines and curves) into 
coordinate geometry.   

 
Graphical Profile Preferences 

This tool enables the user to define the preferences utilized within the Component 
Based Profile Generator such as the profile element symbologies and the profile name 
prefix. 

 
Import Vertical Alignment from COGO 

This tool enables the user to import (draw) a previously stored profile from the 
coordinate geometry database. 

 
Place Profile Cell Anchor 

This tool enables the user to place the profile required as a prerequisite to any profile 
creation.  Note the profile cell may be placed by many other applications in GEOPAK, 
i.e., D&C Manager, Vertical Alignment Generator, Project Manager and Plan / Profile 
Sheets. 

 
Profile Cell Control 

The Profile Cell Control dialog box enables the user to place or manipulate profile cells 
and associated data. 

 

11.4   Active Chain Control 
The GEOPAK Active Chain Control is an excellent tool, enabling the user to manage plan, profile, 
and cross section views simultaneously.  It also allows usage of MicroStation tools to place elements 
in any view in accordance with the curvilinear coordinates settings. 

The Active Chain Control requires COGO to be running.  If the tool is selected without COGO 
activated, the Chain list is empty.  In addition, the files must be referenced (i.e., plan, cross section, 
and profile) before utilizing the tool. 

When invoked, the dialog box depicted below opens. 

 

First, select the desired chain from the Chain list box at the left end of the tool box, as depicted 
below.  This list is updated each time a chain is created/deleted or a new GPK file is opened. 
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Four icons are supported to the right of the chain list field and are detailed in the table below. 

 
Graphically select the active chain candidate.   

 
Opens the “Precise Curvilinear Coordinates” dialog box, that allows entering 
precise curvilinear coordinates relative to the active chain. 

 
Activates the current Profile system, which is associated to a Profile Cell.  
The Profile Cell can stay in the master file or in any of the reference files.  If 
there are several Profile cells relative to the active chain, it is possible to 
designate the active one in the Profile Cell Control dialog box.  When the 
right button is pressed, a pop-up menu appears : 

 

The first option of the pop-up menu allows placing a Profile cell.  The second 
option allows getting information about Profile cells that stays in master and 
reference files and select the active one if there are several profile cells. 

 
Activates the current Cross Section system.  If there are several reference 
files containing XS cells relative to the active chain, it is not possible to 
activate the Cross Section Representation System.  In this case, an alert 
dialog box is displayed. 

 

The right side of the toolbox has eight icons, which set each view to plan, profile or cross section 
view.  By right clicking an icon, any view can be set to any of the 3 possible views.  For example, if 
there is an active profile cell, setting a view to profile will immediately fit the profile within the limits of 
the view. 
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LAB 11:   Proposed Profiles 
11.1   Generate the Proposed Profile 

Step 1. Execute  

 C:\data\geo\VDOT\PlansPrep\LAB11.EXE. 

Step 2. Open the MicroStation file: 

 C:\data\geo\VDOT\PlansPrep\d17682prof.dgn 

 Access Project Manager.  It should automatically 
access the Road workflow dialog box since we 
“remembered” the options in Exercise 2. 

Step 3. Select the Vertical Alignment button from the Road 
Project: 17682.prj workflow dialog box. 

 

 

 

Step 4. All of the information in the invoked Settings dialog box should be automatically 
populated based upon the information we provided in the DEFINE dialog box in Exercise 
8. 

Step 5. Press the OK button to commence development of the proposed profile. 

Step 6. Provide the initial VPI Station = 200+00 and the initial VPI Elevation = 2021.53 as shown 
in the diagram below. Be sure to press Enter after each entry is made. 
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Step 7. Press the Insert After button and complete the VPI Station and Elevation of the 
subsequent VPIs as detailed in the table below. 

VPI Station Elevation 

2 202+00 2029.88 

3 206+50 2011.02 

4 216+00 2095.00 

5 222+00 2099.00 

Step 8. Press the Prev button to return to VPI 2 as shown in the diagram below. 

  

Step 9. Enter a symmetrical vertical curve Length of 300.  (The K value and Design Speed are 
automatically computed.) 

  

Step 10. Using the table below, enter the following vertical curve lengths. 

VPI Length 

3 400 

4 550 
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Step 11. When completed, select File > Save As from the Profile Generator to save the profile.  
Populate the dialog box as below then click OK.   ‘PROP101.ivd’ will be created in the 
working directory.  This file will contain the COGO commands used to create the 
proposed profile. 

 

Step 12. Exit the profile generator.  When prompted to save your profile, answer No since we did 
that in Step 10.  When prompted to save your Vertical Alignment settings, press Yes. 

Step 13. Open Cogo and use the Element > Profile > Utility tool to see a listing of information 
about the profile.  The Print option will provide elevations at any station or increment of 
stations desired. 

 

Step 14. Dismiss the File Utility dialog by clicking the X in the upper right hand corner. 

Step 15. Dismiss the COGO dialog by clicking the X in the upper right hand corner.  When 
prompted to “Save Session Before Exiting?” click No. 
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11.2   Drawing the Proposed Centerline Profile 
Next, we are drawing the proposed profile utilizing the Draw Profile tool’s COGO tab. 

Step 1. Open the Draw Profile tool. 

 

Step 2. Set Chain to MAINLINE by selecting it from the dropdown list. 

 

Step 3. Click the COGO tab and set the Label Scale to 25 in the upper right hand corner. 

Step 4. Change the Profile Name to MAINLINE.  Set the feature as shown below and click OK. 
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Step 5.  Under the Options section of the dialog, select General.  Populate the dialog box as 
below. 

   

Step 6.  Under the Options section of the dialog, select VPI.  Populate the dialog box as below. 

   

Step 7.  Under the Options section of the dialog, select VC.  Populate the dialog box as below. 

   

Step 8. Click the Add Cogo Profile Settings icon to draw the proposed profile for the project. 

Step 9. Dismiss the Draw Profile dialog box by clicking the X in the upper right hand corner. 

Step 10. Review the proposed vertical alignment. 
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11.3   Update the Project Manager 
We are completing the Profile View of the Working Alignment Definition in Project Manager. 

Step 1. Press the Define button from the Workflow dialog box of Project Manager, 

Step 2. Highlight the Profile View option and populate the Proposed Profile field as depicted 
below. 

 

Step 3. Press the OK button to save the updates and close the dialog box. 

Step 4. Exit MicroStation. 
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Existing Ground Cross Sections (Optional) 
12.1   Introduction 
Objectives To generate existing ground cross sections based on a horizontal 

alignment and the surface model beneath the alignment, and to review the 
sections utilizing the Cross Section Navigator tool. 

Project Manager Draw Pattern and Existing Ground Cross Section 

Tools 

          

Menu Bar Application GEOPAK Road > Cross Sections > Draw Pattern by Station Range 
GEOPAK Road > Cross Sections > Ground Cross Sections from DTM 
GEOPAK Road > Cross Sections > Navigator 

 

The prerequisites to generate existing cross-sections utilizing digital terrain modeling are: 

• GEOPAK coordinate geometry database wherein the horizontal alignment is stored. 
• GEOPAK binary TIN file, Site Model or Site Object.  The Site Model or Object are created 

utilizing GEOPAK Site Modeler software and are stored within the GEOPAK Site project (gsf) 
file. 

• Pattern lines if pattern by design is to be utilized. 
 

The generation of existing ground cross sections must be invoked from within the 2D MicroStation 
design file wherein the sections are to be drawn.  GEOPAK does not create this MicroStation design 
file.  The user creates the blank design file utilizing the desired seed file, and then GEOPAK draws 
into it. 
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12.2   Pattern Lines 
Project Manager Draw Pattern 

Tools 

      

Menu Bar Application GEOPAK Road > Cross Sections > Draw Patterns By Station Range 

 

Pattern lines are graphical lines and/or line strings in a MicroStation design file that define locations at 
which the cross sections will be cut. 

From the Project Manager you will select Draw Pattern, and create or select an existing run.  When 
completed, the following Draw Pattern Lines dialog box appears.  

 

Once all of the fields have been completed, and the application is initiated, graphic lines (on the 
specified level, color and style) are drawn along the chain.  This is a visual representation of the 
location of the cross sections to be generated. 

Six methods are supported for drawing the pattern lines: 

• Increment – starts at the beginning station, and draws a pattern line at the given increment. 
• Even – draws pattern lines at stations divisible by the given value. 
• Once – draws a pattern line at a given station. 
• Critical Points Horizontal – draws a pattern line at each of the critical point (i.e. POT, PC, PT, 

etc.) within a chain. 
• Critical Points Vertical – Draws a pattern line at each VPC and VPT in addition to the sag and 

crest station of vertical curves based on the profile defined in the dialog box. 
• Superelevation Transitions - The current design file is scanned for Superelevation shapes 

created with the specified chain.  A pattern line is drawn at the beginning and end of each 
Superelevation shape, ignoring the beginning and ending station fields in the dialog box.  
Note the Superelevation shapes cannot be in a reference file. 

 
The pattern lines are drawn into the current MicroStation design file.  The user can use the 
MicroStation Place Smartline or Place Line command to draw additional pattern lines at any user 
defined location.  In addition, MicroStation commands can be utilized to modify pattern lines drawn 
via the dialog box to lengthen, shorten, delete, copy, move, etc.   

NOTE: This should be completed before the existing ground cross sections are generated. 
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12.3   Generating Cross Sections 
Project Manager Existing Ground Cross Section - Note a run must be created. 

Tools 

  

Menu Bar Application GEOPAK Road > Cross Sections > Draw Cross Sections from Surfaces 
 

Once the pattern lines have been drawn, the cross sections can be generated.  Note the Job Number 
must be defined in order to populate the Chain list.  Once the Chain is defined, the dialog box 
unghosts as depicted below. 

 

The rest of the dialog box consists of a menu bar with three listings: 

File Standard file utilities to load, or save settings, plus a dialog box exit 
option. 

Edit Options to Cut, Copy and Paste rows in the surfaces list box.  Also, 
save and restore settings in the RSC file or clear list of all surfaces. 

Update Options: User-defined options on how the software handles the redrawing of 
cross sections. 

Delete Existing Elements 
and Redraw  

When this option is activated, any existing ground lines previously 
drawn with this tool are deleted and new ground lines are drawn. 

Delete Non-modified 
Elements and Redraw  

When this option is activated, any existing ground lines previously 
drawn with this tool are deleted and new ground lines are drawn. 

Draw on Top of Existing  When this option is activated, any previously drawn ground lines are 
ignored and a new set is drawn, resulting in two sets of ground lines. 
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Query When activated, the user is prompted each time the Draw button is 
clicked. 

 

 

Two tabs on the dialog box support the input data required to draw cross sections: 

XS Cells  Defines the location of cross sections utilizing either pattern by station or 
pattern by design.  In addition, the scale and spacing are defined within this 
tab. 

Surfaces Define the surfaces utilized for drawing cross sections.  Note multiple 
surfaces may be drawn in a single processing.  Source data includes 
GEOPAK TIN files, Site Models, or Site Objects. 

 

On the XS Cells tab, the Pattern group box has three choices: 

Pattern by Station  Utilizes Begin and End Station values in addition to an Increment/Even option 
and Left and Right Offset fields to determine cross section location.  This 
works well when no sections are needed that are at odd stations, skewed or 
kinked relative to the Chain. 

Pattern by DGN  This method utilizes graphical representation and draws one cross section for 
each line or line string of the specified parameters.  Those parameters include 
Design File which is the name of the file that contains the lines and line 
strings in addition to their associated symbology. 

In Existing Only  No user input is required, as this option draws ground lines only for cross 
section cells which were previously drawn.  Therefore, no other pattern 
requirements are needed. 

 

On the Surfaces tab, the (Filter Tolerances group box has two fields: Horizontal and Variance.  
Both Horizontal and Variance filter tolerances are considered together for each pair of cross section 
segments.  The middle point is deleted if both segment lengths are less than the Horizontal filter 
tolerance while the projected distance between the mid-point and the chord between the two end 
points is less than the Variance tolerance. 
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12.4   Cross Section Navigator 
Project Manager Not accessible from within Project Manager 

Tools 

  

Menu Bar Application GEOPAK Road > Cross Sections > Navigator 

 

The Cross Section Navigator tool is used to view and traverse between cross sections.  It can also be 
used to draw cross section information. 

When the Navigator is invoked, the following dialog box appears.  

 

The user can scan through the cross sections by either choosing the station from the drop down list, 
or by using the First Section, Previous Section, Next Section, or Last Section icons (arrowheads).  
The Reset Navigator icon window centers the current station to the view.   

 

The Open View Control Dialog Box enables the user to open several windows to 
view different portions of the cross section at the same time.  The user can view the 
whole cross section in view 1, the left side in view 2, and the right side in view 3, etc. 

 

Cross section elements can be added or modified using MicroStation tools or GEOPAK cross section 
drawing tools, as detailed in the table below. 

DP Offset Elevation 

 

Data points at a given offset/elevation, or find the offset/elevation of the 
cursor location. 

 

DP Delta Distance 
Slope 

 

Draws a line at a given horizontal distance and slope.  

 

XS Active Angle 
Tool 

 

Sets the active angle to the given value.  If a MicroStation tool is used with 
the active angle option, this value is used. 
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Draw XS Line  

 

Draws a cross section line.  The length and/or slope can be specified.  

 

12.5   Summary - Basic Steps to Creating Existing Ground 
Cross Sections from a DTM 

Step 1. Requires a horizontal alignment stored in  *.GPK file. 

Step 2. Requires an existing triangle file (TIN) from a DTM. 

Step 3. Draw pattern lines. 

Step 4. Process cross sections using Draw Cross Sections tool. 

Step 5. Review and modify (if necessary). 
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LAB 12:   Existing Ground Cross Sections 
12.1   Draw Patterns 

The first step is drawing MicroStation lines or line strings to define the location of the existing ground 
cross sections.  

Step 1.  Execute C:\data\geo\VDOT\PlansPrep\LAB12.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\PlansPrep\d17682work.dgn 

 Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 3. Select the Draw Pattern button from the Road Project: 17682.prj workflow dialog box. 

Step 4. Create a new run called MAINLINE.  Select the newly created run then click OK. 

Step 5. Populate the dialog box as depicted below.  

 

Step 6. Double click the Level Symbology graphic.  Populate the Set Feature dialog box as 
below then click OK. 

 

Step 7. Click Draw Pattern Lines to initiate the plotting of the patterns into the design file for the 
station range supplied. 
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Step 8. Populate the dialog box as depicted below.  

 

Step 9. Double click the Level Symbology graphic.  Populate the Set Feature dialog box as 
below then click OK. 

 

Step 10. Click Draw Pattern Lines to initiate the plotting of the patterns into the design file for the 
station range supplied. 

Step 11. Review the pattern lines. 

Step 12. Dismiss the Draw Pattern Lines dialog box by clicking the X in the upper right hand 
corner.  When prompted to “Save Settings” click “Yes”. 
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12.2   Update Project Manager 
We are completing the Pattern section of the Working Alignment Definition in Project Manager. 

Step 1. From the Workflow dialog box of Project Manager, click the Define button. 

Step 2. Highlight the Pattern option and populate the dialog box as depicted below. Since we are 
in the pattern file, you can use the Select button to accomplish this task rather than 
manually typing in the information. 

 

NOTE:  Be sure to use colors 4 and 5. 

 

 

Step 3. Click OK to close the Working Alignment dialog box. 
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12.3   Generate Existing Ground Cross Sections 
Step 1. Open the MicroStation file c:\data\geo\VDOT\PlansPrep\d17682xsmainline.dgn 

Step 2. Click the Existing Ground Cross Sections button on the Project Manager dialog box. 

Step 3. Create a run called MAINLINE.  Select the newly created run then click OK. 

Step 4. Generate the existing ground cross-sections by populating the dialog box as shown on 
the following dialog boxes and clicking the Draw button to initiate the routine. 

Note:  The Display Settings for the existing ground line are set to level 1, color 1, weight 5, style 2.   

   

 

NOTE:  Do not forget to click the Modify icon to update the symbology 
settings. 

Step 5. Dismiss the Draw Cross Sections dialog box by clicking the X in the upper right hand 
corner.  When prompted to “Save Settings” click “Yes”. 

12-10    VDOT Plans Preparation Training GEOPAK 2004 Edition 



__________________________________________________________GEOPAK® 

12.4   Review Cross Sections 

      

 

Step 1. Select the Cross Section Navigator tool from the Road Tools tool frame. 

 

Step 2. Use the Cross Section Navigator to browse and check your existing cross sections.  

Step 3. Dismiss the Cross Section Navigator dialog box by clicking the X in the upper right 
hand corner when done.  

 

GEOPAK 2004 Edition LAB 12:   Existing Ground Cross Sections    12-11 



GEOPAK®__________________________________________________________  

12.5   Update Project Manager 
We are completing the Cross Section and Existing Ground sections of the Working Alignment 
Definition in Project Manager. 

Step 1. Highlight the Cross Section View option and populate the dialog box as depicted below: 

 

Step 2. Highlight the Existing Ground option and populate the dialog box as depicted below 

 

Step 4. Click the OK button to close the dialog box. 

Step 5. Upon reviewing the sections, it is desirable to “lock” the elements to prevent accidental 
deletion or modification in later steps.   

 Select Edit > Select All from the MicroStation menu bar.  Then select Edit > Lock to 
lock the elements. 

Step 6.  Exit MicroStation. 
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Superelevation (Optional) 
13.1   Introduction 
Objectives Learn to use GEOPAK Automated Superelevation dialog box and 

Autoshape Builder to apply superelevation to a roadway. 

Project Manager Calculate Superelevation 

Tools  

                         
 

          

 

 

 

 

Menu Bar Application GEOPAK Road > Cross Sections >Superelevation Shape Manager Tools 

 

GEOPAK supports a myriad of options for the definition of pavement on proposed cross sections.  
They range from a single slope specification emanating from a baseline / profile on each section, to a 
complicated multiple roadway, each with its own superelevation transitions. 

The most basic is the project where no superelevation transitions are required, i.e., the roadway 
slope for all pavement (if any) can be specified as a single value.  In this case, the slope can be 
defined with the proposed cross section processing and any additional superelevation work is not 
required. 

Another option is the definition of superelevation when roadways are constant widths without tapers, 
i.e., turn lanes, acceleration and deceleration lanes, etc.  In these areas, the automated 
superelevation can be utilized, based on a user-defined design speed and considering the geometry 
of the specified roadway.  After careful review of the data (in ASCII format) and overriding the 
computed values, GEOPAK draws pavement representations as complex shapes into a MicroStation 
2D design file. 

A third option is the definition of superelevation when roadways are not constant widths, i.e., gore 
areas, turn lanes, acceleration and deceleration lanes, etc.  In these areas, graphic elements within a 
MicroStation 2D design file are utilized to create complex shapes which define the superelevation 
transitions. 

A combination of these tools can be combined with a project, or even within a single roadway.  The 
shapeless mode is excellent for rural applications, low volume city streets, frontage roads, etc., while 
the automated method quickly generates automated shapes for more complex roadways.  Any area, 
which cannot be defined via the automated method, can be augmented by the graphical method.  

For some users, only simple narrow shapes will be required when designing new roadways or 
performing slope correction for reconstruction projects.  The proposed cross section criteria will 
stretch the pavement out to the true proposed edge of pavement based on finding plan view elements 
that represent the EOP. 
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13.2   Automated Superelevation (AutoShape Input File Maker) 
Project Manager Calculate superelevation 

Tools 

      

 

The GEOPAK Superelevation package enables the user to create, edit, and run an autoshape input 
file quickly, basing it on an existing COGO alignment. 

A rich set of preferences is available which gives the user complete control over every aspect of the 
standardization of the superelevation design process.  AASHTO Method V is available as a default, 
along with the ability to employ user-defined lookup tables both for e (superelevation rate) and for 
runoff length.  User-defined equations may also be entered to compute these values.  A thorough set 
of options is available for resolving the superelevation conflicts of Reverse Curves, Compound 
Curves, Broken Back Curves, and Short Curves.  

GEOPAK calculates superelevation transition 
locations for any alignment stored into the 
coordinate geometry database.  The main 
superelevation dialog box is simple and 
straightforward, allowing the user to select 
which preference file is to be used for the 
current session, as well as enabling the entry 
of the typical section lane configuration in the 
simple engineering terms of Number of 
Lanes, Lane Widths, Median Width (if any), 
and Cross Slope.  More complex lane 
configurations may be represented as 
needed. 

Upon computation of the superelevation 
parameters (cross slopes and stationing), the 
information is stored in an ASCII file, where 
the user may review and modify the 
transitions, if desired.  After reviewing the 
information, the ASCII file is executed from 
the Autoshape Builder to generate 
superelevation shapes. 

 

 

Job Coordinate geometry database wherein the desired chains and profiles are 
stored. 

Chain GEOPAK baseline chain dictating the horizontal geometry for which 
superelevation transitions are calculated.  This chain is also called the Shape 
Cluster Baseline in the Auto Shape input file.   

Begin Station When the chain is defined, GEOPAK populates the Begin Station with the 
default beginning of the chain.  To compute superelevation for part of a chain, 
adjust the station.  
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End Station When the chain is defined, GEOPAK populates the End Station with the 
default beginning of the chain.  To compute superelevation for part of a chain, 
adjust the station.  

Design Speed Design speed that determines what Design Speed is to be used either in the 
tables or equations for e and length computations. 

Preference File 
   e selection 
L selection 

The Preferences File combo box selects which Preference File is to be used 
for this computation.  The various Preferences Files which are available in the 
combo box are determined by what files have the .sep file extension in the 
Preference Files Path on the User Directories dialog box.  When it is set, the 
available e and length Selection combo boxes are filled in according to the csv 
file names as specified in the Preferences File.  Those combo boxes 
determine which table within the .csv file will be used for computation. 

Facility Facility determines whether the roadway cross section is to be divided or 
undivided.  This option determines two things.  For the dialog box box, it 
determines whether or not the values Profile, Tie (Offset or PGL), and or the 
Tie or PGL values may be different.  If they are different then two shape 
clusters are to be generated, which usually is required for a median.  The state 
of the Facility option button also determines which Preference is used as found 
on the Distribution tab of the Preferences dialog box.   

Left / Right tabs The area enclosed in the Left / Right tabs are for the determination of values 
specific to shape clusters.    

NOTE: The right and left tabs contain data pertaining to each lane within each 
roadway.  If the Facility is undivided, then the left tab is for the left lane(s) while 
the right tab is for the right lane(s).  If the Facility is divided, then the right tab is 
for the entire right roadway, while the left tab is for the left roadway.   

Create Input File ASCII file wherein GEOPAK creates the autoshape input file.  DO NOT include 
the extension, as GEOPAK adds .inp to the field.  

Generate 
Superelevation 
Transitions 

Commence automatic superelevation calculations 

Profile  GEOPAK profile defined as the Shape Cluster Profile in the Auto Shape input 
file.   

Tie Offset - Horizontal distance from the Profile (PGL) to the Chain.  

PGL Chain - Chain stored in the gpk file that the shapes will be computed 
from. This chain does not require a profile be stored with it as the defined 
profile will be applied to this chain. 

Offsets Offsets define the dimension of the shape (usually a lane) by two offset 
distances from the baseline.  Note that tapers are not supported.  Offset 
distances are negative if measured to the left.  .  Each lane must have the 
same offset on the left as the left adjacent lane and must have the same offset 
on the right as the right adjacent lane (no gaps in offsets).  Computation may 
not proceed if this condition is not met. 

% Slope Cross slope of each shape in normal crown in percent format.  A negative sign 
denotes the roadway going downward, while emanating away from the PGL.  
A Normal Crown section of 2.0% would, therefore, be entered as –2.0.  Lane 
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offset values are entered in terms of master units, i.e., feet or meters. 

Dependent / 
Independent 

One dependent shape, which is based on the profile, is required for each 
cluster.  Other shapes, drawn not based on the profile, but on adjoining lanes, 
are independent.  For example, turn lanes are drawn abutting next to the 
mainline roadway, so they are independent.  However, a lane based on the 
profile for its initial elevation, such as one of the through lanes, is profile 
dependent. 

 

Edit buttons: 
Add 
Delete 
Edit 

To add a line to the list box, type in the values in the edit fields, then click the 
Add icon.  To delete a line, highlight the desired line, then click the Delete icon.  
To modify a line, highlight the desired line, (which is then displayed in the edit 
fields), change the desired values, then click the Edit icon, which updates the 
list box. 

Quick Entry 

 

 

Enables the user to populate the shape cluster list boxes quickly while entering 
the data using engineering terminology.  When clicked, the dialog box depicted 
below opens. 

 

Rectify Lanes 

(Bottom tool to the 
right of the list box) 

If Offset values have been entered that create a gap between lanes, the 
Rectify Lanes option will remove this gap.  Click the Rectify Lanes button 
and the values will be modified so that any gaps will be removed. 

Selection of the Generate Superelevation Transitions button performs the actual superelevation 
computations.  Three things happen at this point.   
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● First, the superelevation transitions as 
computed by GEOPAK are written to 
the Autoshape Input File specified by 
the user (in the Create Input File field).  

● Second, the log file is written.   
● Finally, the Autoshape Input File is 

loaded into the text editor running 
within MicroStation.  This Autoshape 
Input File Editor has an icon at the top 
that allows the Autoshape Input File to 
be run.  Autoshape Input files can also 
be run from the Autoshape Builder. 

 

13.2.1   Example - Auto Shape ASCII Input File 
/* Superelevation Settings and Parameters: 
Project Name:  C:\data\geo\vdot\PlansPrep\17682.prj 
User:          C:\data\geo\vdot\PlansPrep\projdbs\VDOT 
Run Name:      MAINLINE 
Unit System is english. 
Created input file "mainline_shapes.inp". 
Created activity log file "mainline_shapes.log". 
Created on Wed, Nov 06, 2002 at 13:11. 
Using Preference File "english standard" 
Using e Selection of "rural". 
Using Length Selection of "rural" 
Using Design Speed of 35.000000. 
  
*/ 
  
auto shape 
job number = 101 
  
   auto shape set 
      shape cluster baseline   = MAINLINE 
      shape cluster profile    = MAINLINE 
      shape cluster tie        = 0.0000 
      dependent shape 
      chain  /  offset 
         MAINLINE   -8.0000 
         MAINLINE   -20.0000 
      filler line station / slope 
           200+00.000000   -2.0000 
           206+46.876488   -2.0000 
           208+45.876488    4.8000  /* Curve ML-1 */ 
           209+80.032227    4.8000  /* Curve ML-1 */ 
           211+79.032227   -2.0000 
           213+13.162662   -2.0000 
           213+31.032227   -2.6000  /* Curve ML-2 */ 
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           219+02.785686   -2.6000  /* Curve ML-2 */ 
           219+20.655251   -2.0000 
           222+06.840000   -2.0000 
  
   auto shape set 
      shape cluster baseline   = MAINLINE 
      shape cluster profile    = MAINLINE 
      shape cluster tie        = 0.0000 
      independent shape 
      chain  /  offset 
         MAINLINE   -20.0000 
         MAINLINE   -32.0000 
      filler line station / slope 
           200+00.000000   -2.0000 
           206+46.876488   -2.0000 
           208+45.876488    4.8000  /* Curve ML-1 */ 
           209+80.032227    4.8000  /* Curve ML-1 */ 
           211+79.032227   -2.0000 
           213+13.162662   -2.0000 
           213+31.032227   -2.6000  /* Curve ML-2 */ 
           219+02.785686   -2.6000  /* Curve ML-2 */ 
           219+20.655251   -2.0000 
           222+06.840000   -2.0000 
  
   auto shape set 
      shape cluster baseline   = MAINLINE 
      shape cluster profile    = MAINLINE 
      shape cluster tie        = 0.0000 
      dependent shape 
      chain  /  offset 
         MAINLINE   8.0000 
         MAINLINE   20.0000 
      filler line station / slope 
           200+00.000000   -2.0000 
           207+63.935312   -2.0000 
           208+45.876488   -4.8000  /* Curve ML-1 */ 
           209+80.032227   -4.8000  /* Curve ML-1 */ 
           210+61.973403   -2.0000 
           211+94.032227   -2.0000 
           213+31.032227    2.6000  /* Curve ML-2 */ 
           219+02.785686    2.6000  /* Curve ML-2 */ 
           220+39.785686   -2.0000 
           222+06.840000   -2.0000 
  
   auto shape set 
      shape cluster baseline   = MAINLINE 
      shape cluster profile    = MAINLINE 
      shape cluster tie        = 0.0000 
      independent shape 
      chain  /  offset 
         MAINLINE   20.0000 
         MAINLINE   32.0000 
      filler line station / slope 
           200+00.000000   -2.0000 
           207+63.935312   -2.0000 
           208+45.876488   -4.8000  /* Curve ML-1 */ 
           209+80.032227   -4.8000  /* Curve ML-1 */ 
           210+61.973403   -2.0000 
           211+94.032227   -2.0000 
           213+31.032227    2.6000  /* Curve ML-2 */ 
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           219+02.785686    2.6000  /* Curve ML-2 */ 
           220+39.785686   -2.0000 
           222+06.840000   -2.0000 
  
   Plot Parameters 
      Dependent Shape 
         lv = 63 
         co = 6 
         lc = 0 
         wt = 2 
      Dependent Text 
         lv = 63 
         co = 6 
      Independent Shape 
         lv = 63 
         co = 1 
         lc = 0 
         wt = 2 
      Independent Text 
         lv = 63 
         co = 1 
  
Write shapes into dgn = C:\data\geo\vdot\PlansPrep\d17682work.dgn 

13.3   Draw Shapes into Plan View File 
Project Manager None 

Tools  

                       

 

 

Menu Bar Application GEOPAK Road > Cross Sections >Superelevation Shape Manager Tools 

 

Once the shape input file (fname.inp) has been created and reviewed, the designer can run the input 
file to place the superelevation shapes into the specified graphics file.  To use the interactive method 
to define roadway superelevation (in a .dgn file) the designer pushes the Autoshape Builder icon 
from the Superelevation Shape Manager Tools tool bar (or alternately from this same icon within the 
Text Editor as described above).  

 

Input File  Name of .inp file (fname.inp) created by the Automated superelevation 
generation containing the transitions. 

Display Only  Create the shapes in “Display Only” mode.  That is, they are not written to the 
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design file and a view Update operation eliminates them, as does zoom in, etc. 

Override Input 
File Level 
Symbology 

This option is used to override the Plot Parameters settings in the Superelevation 
Shapes input file. 

 

The shapes are placed in a 2D graphics file on level 63 by default.  The plot parameters can be 
modified in the input file with a text editor prior to building the shapes into the graphics file or with the 
User > Symbologies pull down on the Automated Superelevation dialog box. 
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13.4   Shape Analysis Tools 
Tools  

                         
          

 

 

Menu Bar Application GEOPAK Road > Cross Sections >Superelevation Shape Manager Tools 

 
The tools in the Superelevation Shape Manager Tools toolbox are detailed below. 

Auto. Superelevation 

 

Performs the actual calculations and stores the results in an ASCII file, known 
as the autoshape input file. 

Autoshape Builder 

 

Processes the autoshape input file and draws corresponding complex shapes in 
the specified 2D design file. 

Shape Maker 

 

Graphical method of drawing irregular superelevation shapes.  This method is 
utilized for gore areas, turn lanes, etc. 

Shape Analyst 

 

The Shape Analyst tool provides information on any point within a GEOPAK 
superelevation shape. 

Shape Profiler 

 

The Shape Profiler tool provides profile information based on user-define 
increments intersecting a GEOPAK superelevation shape. 

Shape Editor 

 

The Shape Editor tool enables the user to dynamically change parameters on a 
previously created shape.  This includes filler line stationing, dynamic moving of 
shapes, etc. 

Shape Selector 

 

The Shape Selector tool highlights or selects shapes based on a wide range of 
user queries or filters. 

Shape Properties 

 

The Shape Properties tool provides information on any GEOPAK 
superelevation shape.  In addition, this shape information can be modified on 
individual shapes of selections of shapes. 

Shape To DTM 

 

Provides the option to store a DTM Dat file from the superelevation shapes. In 
addition, it can plot the calculated elevations into the design file at a user 
specified interval. 
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13.4.1   Shape Analyst 
The Shape Analyst tool is extremely useful, as it provides information on any point within a GEOPAK 
superelevation shape. 

 

Before using this tool, the Job Number must be selected.  Upon selecting a Job Number, a Chain 
must be selected that the shapes are defined relative to.  If Display Only is enabled, information like 
elevation and a flow arrow are drawn to the view, but they are not written as elements to the active 
MicroStation file. 

When the Cross Section toggle is not activated and a data point is issued within a shape, the 
elevation of the data point and a flow arrow are displayed.  When the toggle is activated, a dashed 
line is placed through the data point, radial to the shaped cluster baseline.  In addition to the elevation 
and flow arrow placed at the data point, elevations are displayed where the cross section line 
intersects any superelevation shape and cross slopes are labeled for each shape. 

The By Sta/Offset button causes the current Station / Offset value to be projected back onto the 
shape cluster baseline and the elevation of the projected point is displayed.  This option can be 
manual entry only and requires no data point on the screen. 

The DP button works within a superelevation shape whose X, Y coordinates are utilized to compute 
station / offset from the specified shape cluster baseline, which is subsequently utilized in conjunction 
with the shape to compute the various slopes and elevations.  After the DP button is clicked, 
numerous data points can be placed.  It is not necessary to click the DP button again.  Each 
corresponding station / offset is displayed along with the associated output information. 

The Dynamic button activates the dynamic mode.  As the cursor moves across the screen, any 
momentary pause places the elevation and flow arrow in the MicroStation file and computes and 
displays the analysis information. 

The Extrapolate Fixed Slope toggle is another option supported in the Shape Analyst tool.  The 
option is utilized when the data point, dynamic point or station / offset is outside of the shape.  When 
the option is not activated, the data point is projected back to the shape's chain.  The elevations at 
the edges of the shape are displayed and the slope of the outside shape is projected to the data 
point.  When the toggle is enabled, the user defined slope is projected from the outer most shape to 
the data point to determine an elevation. 
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13.4.2   Shape Profiler 
The Shape Profiler tool computes elevations along any GEOPAK Shape or MicroStation element at a 
user specified interval.  The element can be inside or outside of the shapes. 

 

The Job field can be populated by key in or using the Select… button.  After selecting a GPK file, 
click Identify Shape and data point on any shape along the desired Chain.  Set the From Station 
and To Station fields by keying in values or using the DP buttons. 

 

Even should be selected when it is desired to have the elevations compute at the even station 
values.  Increment will allow the elevations to be computed starting at the From Station, then adding 
the increment value to that station.  Intersect is used with an element to compute elevations at all 
locations that the element intersects the shape(s). 

The Elevation Along toggle can be set to Shape or Element.  When set to Shape, elevations will be 
computed based on the Even/Increment value along both longitudinal edges of the shape.  When set 
to Element the elevations are computed along the element based on the Even/Increment/Intersect 
toggle. 

Continuous Extrapolation allows the user to identify multiple longitudinal elements outside of the 
shape area and compute elevations by a user defined Slope and one of three methods:  Radial to 
Baseline, Radial From Element, or Radial to Element. 
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LAB 13:   Superelevation 
As a reminder, our project contains distinct sections: 

Section 1 4 lane divided highway with depressed median from Sta. 200+00 to Sta. 202+00. 
Left side of the roadway will be resurfacing while the right side is new 
construction. 

Section 2 4 lane divided highway with raised median from Sta. 202+00 to Sta. 204+25. Left 
side of the roadway will be resurfacing while the right side is new construction. 

Section 3 4 lane undivided highway from Sta. 205+00 to Sta. 211+00. 

Section 4 2 Lane highway with Entrances and Exit Ramps from Sta. 211+00 to Sta. 220+00. 

Section 5 Exit Ramp (RampA) 

 

Based on this information, normally we would need to process the Superelevation separately for each 
of the above sections. Due to time constraints, we will only calculate superelevation for the 
section from Sta. 205+00 to Sta. 211+00. 

13.1   Automated Superelevation 
Step 1.  Execute C:\data\geo\VDOT\PlansPrep\LAB13.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\PlansPrep\d17682work.dgn 

Step 3. Click the Calculate Superelevation button from the Road Project: 17682.prj workflow 
dialog box.  
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Step 4. Create a new run called ‘ML’ 
and click OK.  Once the 
Automated Superelevation 
dialog box has been invoked, the 
dialog box on the right will be 
displayed. 

 Fill out the upper portion of the 
dialog box as shown. 

Step 5. The profile from which the 
shapes should be computed 
should be set to MAINLINE for 
both the Left and Right roadway 
tabs. 

Step 6. The Tie option should be set to 
offset and the offset value 
should be set to 0.0 to force the 
PGL (Profile Grade Line) to run 
along the centerline of 
construction (MAINLINE). 

 

Step 7. Press the Quick Entry icon as shown in the image below. 
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Step 8. Fill out the Quick Entry dialog box as shown below and press OK. 

 

 

NOTE:  Quick Entry can be used only if the lane configuration to the left and right sides 
of the baseline are the same. 

 

Step 9. Provide an Input Filename (shapes.inp) to store the computed transitions for this station 
range. 

 The dialog box should appear as shown: 

 

Step 10. Click the Generate Superelevation Transitions button to initiate the calculation of the 
transitions for the Left and Right roadway. 
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Step 11. Review the computations within the Text Editor dialog box. 

 

 

Step 12.  To build these shapes into the graphics file, click the Autoshape Builder 
icon within the Text Editor dialog box.  This will automatically draw the 
shapes into your design file on level 63.  

Step 13. Close the Text Editor dialog box as well as the automated superelevation dialog box.  
When prompted to Save Superelevation settings, click Yes. 

Step 14. Review the Superelevation shapes created in the design file. 

GEOPAK 2004 Edition LAB 13:   Superelevation    13-15 



GEOPAK®__________________________________________________________  

13.2   Update the Project Manager 
We are completing the Plan View category of the Working Alignment Definition in Project Manager. 

Step 1. From the Workflow dialog box of Project Manager, click the Define button. 

Step 2. Highlight the Plan View > Shapes option and populate the Shapes Design file as shown 
below: 

 

Step 3. Click the OK button to save the updates and close the dialog box. 

Step 4. Exit MicroStation. 
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Cross Section Sheets (Optional) 
14.1   Introduction 
Objectives Learn the procedures for laying out cross section sheets. 

Project Manager Cross Section Sheets 

Tools 

          

Menu Bar Application None, except batch processing of an input file. 

 

The GEOPAK sheet layout component provides an automated tool to draw cross section data in a 
format suitable for producing hard-copy cross section construction drawings.  The input includes 
specifying sheet layout parameters as well as the graphic design file where the cross sections were 
originally created by GEOPAK.  The output is a MicroStation design file of the cross sections.  Each 
cross section is displayed as a reference file and labels such as baseline, station, offsets and 
elevation are added.  There are several advantages to using sheet input: 

• The cross sections will be sorted in numeric order for the specified baseline.  

• The cross sections will be spaced closer together. 

• The original cross section file is left intact and any modifications to the cross sections will be 
automatically displayed in the sheet file due to the use of reference files. 

• The cross sections are placed into "sheet format" according to user specified criteria. 

The parameters for each sheet are defined in a Sheet Library.  In order to lay out sheets, a Sheet 
Library must be attached to the current session.  The name of the currently attached Sheet Library is 
shown in the title bar.  Sheet Libraries have an extension of xssl.  An unlimited number of different 
sheets can be stored within one library. When the user begins the sheet process, he selects the 
desired sheet layout from the attached library, which loads the associated parameters. 

If a different Sheet Library is needed, it can be attached via the menu items File > Sheet Library > 
Attach.  Detailed information on the set-up of the Sheet Library can be found in the online help 
section entitled "Sheet Library Set-up." 
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14.2 Accessing The Cross Section Sheet Layout Tool 
The Cross Section Sheet tool can be accessed by selecting Applications > GEOPAK ROAD > 
Cross Sections > Cross Section Sheet Composition.  It can also be invoked from Project 
Manager by clicking the Cross Section Sheets button or by selecting the Cross Section Sheet 
Composition icon from the GEOPAK ROAD tool frame.   

Once the Cross Section Sheet Composition tool is selected, the dialog below appears. 

 

14.2.1 File Menu 
File > Sheet Library 

TOOL DESCRIPTION 

New Create a new Sheet Library. 

Attach Attach a Sheet Library. 

Save Saves a Sheet Library. 

Save As  Save a Sheet Library as a new name. 
 

File > Sheet 

TOOL DESCRIPTION 

New Create a new Sheet in a Sheet Library. 

Delete Delete a Sheet in a Sheet Library. 

Copy Copy a Sheet in a Sheet Library. 

Update Update a Sheet in a Sheet Library. 
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File > Load V7 Input File 

This option gives the user the ability to load an ASCII input file that was created in previous versions 
of GEOPAK. 

File > Save Settings 

Saves all dialog settings in Project Manager. 

File > Layout Sheets 

Layout cross sections into sheet format. 

File > Exit 

Exit the Cross Section Sheet Composition application. 

14.3 Cross Section Sheets Dialog 
The left side of the dialog contains the list of parameters required to generate cross section sheets.  
When each parameter is selected, the dialog changes as do the key-in fields to reflect the selected 
parameter. 

XS DGN File – Tells the software where to locate the cross sections. The Chain and stationing will be 
filled out automatically if defined via the project manager. By default, the software will find all 
elements within the confines of the cross section cell.  
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Sheet DGN File - Specifies which file the cross section sheets will be placed in. Also allows you to 
set the horizontal and vertical scale at which they are to be laid out and the coordinate location in the 
MicroStation Design file at which the sheets will be placed.  If Detach Existing Sheets before 
Processing is toggled on, then all elements in the file are removed and existing reference files are 
detached before processing. 

 

Attachemnt: All Sheets In Active Model – All sheets are placed in the active model 

  One Sheet Per Model – Each sheet is placed in a separate model 

  One Sheet Per Model / Display All – Each sheet is placed in a separate model and 
all sheet are attached to the active model  
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Sheet Dimensions/Cell – Sheet Dimensions defines the Sheet Height and Sheet Width to be used 
for the cross section sheet.  When Place Sheet Cell is toggled on, the application will place a sheet 
border cell from the specified cell library.  A scale can be applied and the sheet cells can be placed 
as Shared Cells.  Sheet Offset from Cell Origin is the X and Y offset from the sheet border cell 
origin. 

 

There are two options for Sheet Cell Placement.  The sheet border cell can be placed in the sheet 
file with the cross section reference files as shown above.  It can also be placed once in a reference 
file then the sheet cell file is attached to the file that contains the cross section reference files as 
many times as it is needed.  This option is shown below. 
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XS Search Criteria – Indicates the search criteria (symbology) for the data to be used as input to the 
sheet layout software.  If you need to look farther than that (i.e. outside of the cell), you can use the 
Lower and Upper Range Limit values to extend beyond the cell limits.  The Horizontal Search will 
look outside the limits of the Sheet Dimensions. 

 

Sheet Stack Orientation – Determines whether you want the sheets to be stacked vertically or 
horizontally.  Also allows you to set the maximum number of sheets you want placed per column in 
the file as well as the Horizontal and Vertical spacing between sheets. 
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Sheet Stack Columns – Determines whether you want a single stack or a double stack of cross 
sections per sheet.  Baseline X Offset defines the distance from the left-hand edge of the sheet to the 
zero offset position (i.e. baseline) of the cross sections.  If you select Double Stack, you can give an 
offset value which is the distance of the second stack from the left hand edge of the sheet.  There are 
also options for Triple and Quadruple stacking. 

 

Margins and Spacing – Cross Section Clip Limits defines the clipping limits from the left hand edge 
of the sheet.  To the left of the Left Clip X Offset remains clear space and to the right of the Right Clip 
X Offset remains clear space.  All minimum spacing requirements as well as the maximum allowable 
vertical size of any cross section is also set here. 
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Station Labels – Allows you to define the station label locations and plot parameters. 

 

Offset Labels – Allows you to define the offset label positions, increments and plot parameters. 
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Elevation Labels – Allows you to control the elevation label locations, increment and plot 
parameters.  Add Top Elevation Label - Activating this toggle adds another elevation label above the 
current labels placed within the elevation labels parameters.  If two sets of elevations labels are 
placed (one on each side of the section), the top elevation is added to both. 

Add Bottom Elevation Label - Activating this toggle adds another elevation label below the single 
label placed within the elevation labels parameters.  If two sets of elevations labels are placed (one 
on each side of the section), the bottom elevation is added to both. 

 

Earthwork Quantity Labels – The user can define the ASCII file that contains the earthwork quantity 
information, as well as set the symbology and location of the earthwork quantity labels.  This will use 
the information gathered during the earthwork run to place the earthwork quantity labels on the cross 
section sheets. 
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Sheet Labels – Allows the placement of numerous labels.  There are three sets of labels that can be 
placed where the labels change from sheet to sheet.  These labels include Sheet Number, Begin 
Station, and End Station.  Any number of custom labels can also be placed.  These labels would be 
something that does not change from sheet to sheet such as Project Number, Designer, etc.  A list of 
labels can be created and each label can have it’s on symbology.  Location of the labels is controlled 
by the DP Origin and DP Label Justification Point buttons.  The DP Origin button locates the origin of 
the sheet cell and the DP Label Justification Point button sets the X and Y Offset from the sheet cell 
origin for the placement of the label. 

 

Digital InterPlot – Allows the creation of the Digital InterPlot Plot Set during the Layout Sheets 
process. 
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14.4 Generating Sheets 
From the Files menu, the Layout Sheets option will process all 
parameters that have been set in the Cross Section Sheets dialog 
box.  There is also a Layout Sheets button on the main dialog. 
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LAB 14:   Cross Section Sheets 
14.1   Cross Section Sheet Layout 

Step 1.  Execute C:\data\geo\VDOT\PlansPrep\LAB14.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\PlansPrep\d17682xsheet.dgn 

Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 3. Select the Cross Section Sheets button from the Road Project: 17682.prj workflow 
dialog box. 

Step 4. Create a new run called MAINLINE. 

Step 5. Select File > Sheet Library > Attach.  Select 
C:\data\geo\VDOT\PlansPrep\VDOTENG.xssl then click Open if the Windows File 
Open dialog is used or OK if the MicroStation File Open dialog is used. 

XS DGN File should already be populated with d17682xsmainline.dgn since this was set in the 
Working Alignment definition of Project Manager. 

 

We will be using “xsheet” as the sheet name for our Cross Section Sheet layout. 
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Step 6. Click Select Sheet DGN File and select the sheet design file d17682xsheet.dgn.  
Toggle on “Detach Existing Sheets before Processing”. 

 

Step 7. Select Earthwork Quantity Labels.  Click Select Earthwork Data File Icon and select 
the earth.txt file created in the previous chapter. 
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Step 8. Turn off level 50 then select File > Save Settings from the MicroStation pulldown menu. 

Step 9. Process the cross sections onto the sheets using either the File > Layout Sheets 
pulldown or by clicking the Layout Sheets button on the Cross Section Sheet 
Composition dialog box. 

Step 10. Dismiss the Cross Section Sheet Composition dialog box by pushing the “x” in the 
upper right hand corner. 

Step 11. When prompted to Save Settings, click Yes. 

Step 12. When the Cross Section Sheet Layout process is completed, you will be in the sheet file.  
Review your work. 

Step 13. Exit MicroStation. 
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XS Reports & Limits of Construction 
(Optional) 
15.1   XS Reports 

Objectives Create various cross section reports:  
 - for plan use (design elements and quantities) 
 - as input for other programs and/or applications of GEOPAK 
 - for construction layouts. 
Create and draw construction limits in the plan view file. 

Project Manager Reports and XS Quantities 
Limits of Construction 

Tools 

            

Menu Bar Application GEOPAK Road > Cross Sections > Cross Section Reports 
GEOPAK Road > Cross Sections > Construction Limits 

 

The GEOPAK Cross Section Report Utility can extract up to sixteen 
different reports from original and design cross-sections.  For each report 
generated, the user must set the parameters of the existing and/or design 
cross sections.  GEOPAK also provides an option to make custom 
headers for each of the reports via the User pull down menu. 

15.1.1   Custom Header 

 

From the XS Report dialog box, select User > Preferences.  A Report 
Header dialog box will appear with all options ghosted out.  To activate the 
individual fields simply toggle on the box next to the desired field.  Once 
you have completed the dialog box, the information will be saved as an 
.hdr file.  This allows for the creation of a separate header for each type of 
report.  The tolerance field determines the maximum gap allowed between 
cross section elements.   
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15.1.2   Blue and Red Top 
Based on the dialog box settings, GEOPAK determines the offset and elevation of a slope and its 
breakpoints.  Blue refers to the top of pavement and Red is the top of subgrade.  The user must 
determine this by indicating text and level, color, weight and style for each surface. 

15.1.3   Clearing 
The Clearing Report is useful for obtaining clearing and grubbing quantities.  For each station, 
GEOPAK will list the clearing distance on each side of the chain and the width of any exception.  You 
can obtain the results in the appropriate units.  Toggle boxes for Cut Slope Rounding, Additional 
Clearing in Cut and Fill, and Minimum Clearing Width are provided for increased control over the 
output. 

GEOPAK can also generate quantity sub-totals based on the value specified in Sub Every. 

To use the Except Width option, you must have an existing ASCII file that includes the Beginning 
and Ending Station and Exception Width. 

Once everything is set, you can output the information to an ASCII file 

15.1.4   Closure 
The Closure Report provides information on the intersection point between the user defined 
proposed finish grade and existing ground.  In addition to the ASCII report, the designer may instruct 
GEOPAK to close any gap either by drawing a vertical line between the endpoint of the proposed 
finish element and the existing ground or extending the slope of the last proposed element to 
intersect existing ground.  The procedure will not extend existing ground.  The Closure Report can 
be accessed within any MicroStation cross section file by selecting Closure from the main XS Reports 
dialog box. 

15.1.5   DTM Input 
This process generates XYZ coordinates from cross section elements and places this information into 
an ASCII file for use by the DTM portion of GEOPAK.  To use this dialog box simply enter the .gpk job 
number, chain name and station range.  GEOPAK will read the cross section elements based on 
level, weight, color and style. 
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15.1.6   DTM Proposed 3D 
This report is similar to DTM Input except that you can set both original and proposed cross sections 
at the same time.  This report also differs in that it makes break lines across the cross sections.   

15.1.7   HEC – 2 
This process reads cross section elements and formats the information in an ASCII text file suitable 
for use in the HEC-2 hydraulic program. 

15.1.8   HEC RAS 
This process reads cross section elements and formats the information in an ASCII text file suitable 
for use in the HEC RAS hydraulic program. 

15.1.9   Multi-Line 
This report is useful in creating cross-sections for staged construction.  Begin by entering the job 
number, chain name and station limits.  Primary cross section element parameters must be 
completed before secondary element parameters.  This is important due to the order in which 
GEOPAK reads the information.  Once all the parameters have been entered, the new cross sections 
may be drawn to the design file or you may choose the display only option.  An ASCII text file will be 
generated. 

15.1.10   Profile Grade 
The Profile Grade Report is one of the most versatile reports available.  It prints existing ground and 
design grade elevations and low point elevations for each cross section.  Additionally, this report has 
the ability to search either for the low points or any text string that you specify and create horizontal 
and vertical alignments and store them directly into the .gpk.  Horizontal alignments created from this 
report will have no curves. 

15.1.11   Radial Staking 
The Radial Staking Report is a specialized report created for the U.S. Federal Highway 
Administration (FHWA). 

 15.1.12   RT 40 
The RT 40 Report produces RDS based RT40 data.  To use this dialog box simply fill in the job chain 
name, stationing range and the parameters of the cross section elements you wish to use. 

15.1.13   Seeding 
Other than the usual entries, the user must enter the parameters of the elements to be seeded. 

This dialog box includes slope and subtotal options as well as a way to limit the number of segments 
read (By-Pass Segments).  The user may also establish additional seeding specifications 
(Additional Distance). 
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Once all of the settings are complete, the report will produce seed or sod quantities written to an 
ASCII output file for use in plan quantities.  

15.1.14   Slope Stake 
The Slope Stake Report is a special format report developed for the FHWA.  This report generates 
offsets, elevations and superelevation information for each cross section.  To generate this report fill 
in the usual cross section parameters plus Subgrade and Hub Staking information. When complete, 
push Apply and the report is written into an ASCII file. 

 15.1.15   Staking Detail 
The Staking Detail Report determines the tie down point between the proposed finished grade and 
the existing ground.  GEOPAK will list the right and left offset, elevation, and slope of the finish grade 
and superelevation rate for each cross section.  To create this report, fill in the project information and 
desired cross section elements’ parameters.  Once complete, you have the choice between two 
formats, a FHWA ASCII report or a Montana DOT report (includes ditch elevations). 

15.1.16   WSPRO 
This report takes the cross section elements and turns them into an ASCII file for use as input in the 
WSPRO hydraulic analysis program. 

 15.1.17   XS List 
This report creates a listing of elevations and offsets for each cross section element according to user 
defined parameters.  You have the option of creating either an original cross section list or a design 
cross section list.  These reports are very similar to RDS cross section lists. 
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15.2   Limits of Construction 
Project Manager Limits of Construction.  Note a run must be created. 

Tools 

                      

Menu Bar Application GEOPAK Road > Cross Sections > Cross Section Reports 
GEOPAK Road > Cross Sections > Construction Limits 

 

When the Limits of Construction dialog box is invoked, the 
Limits of Construction dialog box opens.  

The user must specify the Job number, the chain name, and 
the file containing the plan view information.  The Existing 
Ground and the Proposed Finish Grade sections should 
already be set correctly if Project Manager is utilized.   

The Parameters button opens the dialog box below.  The 
symbology for the cut, fill, and transition construction limits 
can be set in this dialog box.  

 

 

 

The Place Construction Limit toggle allows the user to place various text strings along the 
construction limits.  Selecting the Parameters button, and making the desired changes in the dialog 
box shown on the next page will set the symbology for these text strings. 

 

The Radius of Display field is the size of the display circle when GEOPAK is scanning the cross-
sections. 
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The last option in the main Limits of Construction dialog box is the Tie Down Option.  There are 
two Tie Down Options.  If the All Tie Down option is set, all tie downs within a section are plotted.  
(I.e. wide medians, outer roadways, ramps, etc. may have tie downs in between the limits of the main 
roadway, and the outer roadway or ramp.)  If the Outer Tie Down option is selected, then only the 
outmost tie downs are plotted.   

 

Once the Apply button is clicked, the limits of construction and the optional text are drawn into the 
plan view file at the specified symbology. 
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LAB 15:   Cross Section Reports, Driveway 
Profiles, and Limits of Construction 
15.1   Cross Section Reports 

Step 1. Execute C:\data\geo\VDOT\PlansPrep\LAB15.EXE. 

Step 2. Open c:\data\geo\vdot\PlansPrep\d17682xsmainline.dgn. 

Step 3. Access Project Manager. 

Step 4. Select Reports and XS Quantities. 

Step 5. From the XS Reports dialog box, select the User > Preferences 
dialog box. 

 

 Set the tolerance to .001. 

 Dismiss the Report Header dialog box. 

Step 6. From the XS Reports dialog box, select the Profile Grade report.  

 

We are going to use this report to create a Chain and Profile along our left edge of shoulder. We’ll 
use this information later to help in the creation of our driveway profiles. 
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Step 7. Fill out the Profile Grade dialog box as shown.  The symbology settings for Existing 
Ground Line and Proposed Finish Grade should be set correctly from the Working 
Alignment Definition from Project Manager.  To add the Text Search information to the 
collection box, push the ADD button.  (Store Text:  EOSLOUT) 

 

  

Step 8. Click Apply.   After processing is complete, dismiss the Profile Grade Report dialog 
box. 

Step 9. Access COGO. 

Step 10. Access COGO Navigator using the icon  

  or use the Tools > Navigator pulldown. 
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Step 11. Use the Chain option to see a list of the stored chains. 
Notice EOSL has been stored. 

 

 

Step 12. Use the Profile option to see a list of the stored 
profiles. Notice EOSL has been stored 

Step 13. Exit COGO. 

 

Step 14. From the XS Reports dialog box, select the DTM 
Input report. 

We’ll use this report to create a proposed model (dtm) from our 
cross sections. We’ll also use this information later in the creation 
of our driveway profiles. 

Step 15. Fill out the DTM Input dialog box as shown and click 
Apply. 

 

  

 

Note: The levels for XS Elements should only refer to 2-4. These are the levels that make 
up the top of Finish Grade. 

Note that in Step 15 we only created a .dat file. This is an ascii file that is used to create 
the DTM. We’ll create the dtm in the next section. 

Step 16. After processing is complete, dismiss the DTM Input dialog box. 

Step 17. Also dismiss the XS Reports dialog box. 
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15.2   Driveway Profiles 
Step 1. Before beginning the process to create the driveway profiles, we’ll need to create the 

proposed DTM.  

 Select the Existing Ground button from the Road Project: 17682.prj workflow dialog 
box. 

Step 2. Select the previously created run ‘ground1’ and press OK. 

Step 3. Select the Build Triangles icon from the DTM Tool Palette. 

 

Step 4. Fill out the Build Triangles dialog box as shown and click Process. 

 

Step 5. Dismiss the Build Triangles dialog box.  When prompted to save settings, push Yes.   
Dismiss the DTM Tool Palette. 

Step 6. Open the Microstation design file c:\data\geo\vdot\PlansPrep\d17682work.dgn.  

 Note that pattern lines have been placed at the driveway locations. These pattern lines 
have the following symbology: LV=51, CO=2, WT=2. 

Step 7. Open the Microstation design file c:\data\geo\vdot\PlansPrep\d17682driveways.dgn. 

Step 8. Select the Existing Ground Cross Sections button from the Road Project: 17682.prj 
workflow dialog box. 

 Create a new run ‘DRIVEWAY’ and click OK. 
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Step 9. Fill out the dialog boxes as shown and click Draw. 

  

 

 

Proposed Surface Symbology (lv = 1, co=4, lc=0, wt=3) 

Existing Surface Symbology (lv=1, co=1, lc=2, wt=5) 

 

Step 10. Dismiss the Draw Cross Sections dialog box and Save Settings. 

 

Review the ground lines drawn. Notice that the proposed ground line may not terminate 
precisely on the existing ground. This is because elevations are being interpolated 
between proposed cross sections. 

You can tie this down manually or you can use the XS Reports > Closure Report. 

 

Step 11. Select the Proposed Cross Sections button from the Road Project: 17682.prj workflow 
dialog box. 

 Create a new run ‘DRIVEWAY’ and click OK. 
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Step 12. Fill out the XS DGN File category as shown: 

  

Step 13. Fill out the Pattern category as shown: 

 

Step 14. Fill out the Existing Ground category as shown: 
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Step 15. Fill out the Shapes category as shown: 

 

Step 16. Under the Shape Clusters category, add the Mainline chain and profile to the list box as 
was done in previous exercises. 
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Step 17. Press the Typical button to access the Typical Section Generator.  

 Select the Typical ENTR and press Apply. 

 

NOTE:  Press the Description button and review the documentation. 

Step 18. Your dialog box should fill out automatically and look like the following: 
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Step 19. Select the Define Variables category.  Modify the following variables as shown: 

Name of Working File d17682work.dgn 
Name of Cross-Section File d17682driveways.dgn 
Lt Ent Take-Off Align Name EOSL 

Step 20. Select the Plot Parameters category.  Double click the sample graphics box under XS 
Lines.  Set the symbology as below then click OK. 

   

Step 21. Under the Text section, ensure that Line Text, Station Text, and Baseline Name Text 
are toggled off.  

Step 22. Toggle off all the options in the Plot section.  The dialog box should appear as below. 

 

At this point we are ready to process the DRIVEWAY cross sections. 

Step 23. Click Files > Save Settings then click Files > Run. 

Step 24. When processing is complete, click Exit to return to the Process Cross Sections dialog 
box. 

Step 25. Close the Proposed Cross Sections dialog box by using the “X” on the upper right of the 
dialog box or by using the Files > Exit pulldown. 

 When prompted to Save Settings, answer Yes. 

Step 26. Use Cross Section Navigator to review the cross sections. 
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15.3   Plan View Limits of Construction 

Step 1. Open the Microstation design file c:\data\geo\vdot\PlansPrep\d17682xsmainline.dgn. 

Step 2. From the Road workflow dialog box, select Limits of Construction.  Create a run called 
MAINLINE. 

Step 3. Populate the Limits of Construction dialog box as shown: 

      

 

NOTE:  The Existing Ground Line symbology should be OK since it was set in the 
Working Alignment Definition in Project Manager but the Proposed Finish Grade 
symbology will need to be set as shown above. 

Step 4. Click the Parameters button to open the Plot Parameters dialog box.  To access each of 
the Set Feature dialog boxes, double click on the sample graphics box in each section.  
Populate as shown: 

 

 Cut                        Fill   Transition 
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Step 5. Click OK to close the Plot Parameters dialog box.   

Step 6. Click Apply to process the Limits of Construction. 

Step 7. Exit the Limits of Construction dialog box and Save Settings. Review the limits of 
construction in c:\data\geo\vdot\PlansPrep\d17682des.dgn. 

 

Since GEOPAK does not create the Limits of Construction exactly like VDOT would like to see them, 
we will use a special application to update them to the correct symbology. 

 

Step 8. From the Road workflow dialog box, select Plan View Design.  

Step 9. From the Plan View Design tool palette, select D&C Manager.   

Step 10. Navigate to the category Road Design > Special Applications. 

Step 11.  Important!   Make sure that all of your Limits of Construction are shown in View 1. 

Step 12. Within this category, double-click on the item Update LOC. 

Step 13. At the following prompt, click OK. 

 

Step 14. Enter the Job Number as shown and click OK. 

 

Step 15. Enter the baseline name as shown and click OK. 

 

Step 16. Set the units to English as shown and press OK. 
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Step 17. Set the scale as shown and click OK. 

 

Step 18. Dismiss D&C Manager and review the changes made to the Limits of Construction. 

Step 19. Exit MicroStation. 

 

 

15-  VDOT Plans Preparation Training GEOPAK 2004 Edition 18   




