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1 
CHAPTER OBJECTIVES   

In this chapter, you will create and store horizontal chains using Graphical Coordinate Geometry tools 
as well as the component tools within the Horizontal Alignment Generator.  

GRAPHICAL COORDINATE GEOMETRY 

INTRODUCTION 
Graphical Coordinate Geometry is a tool that allows the user to store coordinate geometry elements 
into the COGO database (GPK file) graphically. Points, curves, lines, spirals, chains, and parcels can 
be stored, modified, or deleted. The COGO elements can be manipulated by key-in or a click of the 
mouse and are stored directly into the COGO database. 

Note Graphical Coordinate Geometry does not read the exclusive MicroStation graphics. 

ACCESSING 
Graphical Coordinate Geometry is not accessed from Project Manager. It can be invoked by 
selecting Applications > GEOPAK ROAD > Geometry > Graphical Coordinate Geometry or by 
selecting the Graphical COGO icon from the GEOPAK ROAD tool frame. 

 
Note A session of COGO must be active. 

After Coordinate Geometry is activated and Graphical COGO is selected, the main COGO tool box 
will appear as shown below. 
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STORE ELEMENTS 
The Store Elements tool box contains eleven icons. 

 
As elements are stored, the visualization parameters in the SMD file (as defined in the user 
preferences) are utilized. This assumes that the temporary or permanent visualization is activated. If no 
visualization is active, no elements are visualized. 

When a Store Element command is selected, the Tool Settings dialog opens to allow the user to enter 
data as shown below. 

 

 
The Store Elements commands are detailed in the following table. 

 
Store a Point 
The Store a Point tool enables the user to store points utilizing either Cartesian 
coordinates (x, y, z or N, E, Z) or Curvilinear (station, offset, elevation). 

 
Store Equally Spaced Points 
The Store Equally Spaced Points stores a user-defined number of points between 
two previously defined points or any two data points.  A line drawn between the 
two previously defined points is not necessary.   

 
Locate Point 
The Locate Point command stores a point based on the distance and direction from 
a previously defined visualized point. 

 
Store Line From Existing Points 
The Store Line from Existing Points utilizes two previously stored points to store a 
line. 

 
Store Line By 2 Points 
The store line by two points command requires two new points, rather than existing 
points.  The command stores the line and the new points, utilizing the "next" 
available point and line names. 

 
Store Tangent Line 
The Store Line Tangent To Element tool stores a line and its two endpoints in the 
coordinate geometry database. 

 
Store Curve By 3 Points 
The Store Circular Curve by Three Points tool stores a circular curve (using chord 
definition).  The stationing is set to 0+00 at the P.C.  The Radius can be manually 
typed in or defined dynamically. 
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Store Curve By Center 
This tool enables the user to store a circular curve by defining the center point, 
radius, and sweep angle. 

 
Store Tangent Curve Constrained 
The Store a Constrained Tangent Curve tool places a curve tangent to the specified 
curve or line. 

 
Store Tangent Curve Unconstrained 
The Store an Unconstrained Tangent Curve tool places a curve through a specified 
point tangent to the specified curve or line. 

 
Store Tangent Spiral 
The Store Transition Spiral tool quickly places and visually modifies spirals based 
on an initial line or curve. 

MODIFY ELEMENTS 

       
When a Modify command is selected, the Tool Settings dialog opens to allow the user to enter data as 
shown below. 

 
The Modify Elements commands are detailed in the following table. 

 
Partial Delete 
The Partial Delete tool enables the user to delete part of a COGO line or curve, 
creating two separate elements. 

 
Extend Plan View Element 
The Extend Plan View Element tool can extend or shorten any COGO element. 

 
Trim Elements 
The Trim Elements tool trims numerous elements to their intersection with another 
element. 

 
Intersect Elements 
The Compute Intersection of Two Element tool stores a new point by trimming or 
extending one element to its intersection with another element.  Note the two 
elements remain intact. 

 
Extend Element to Intersection 
The Lengthen or Shorten an Element tool works functionally the same as its 
MicroStation counterpart. 

 
Extend Elements to Intersection 
The Lengthen or Shorten Both Elements tool works functionally the same as its 
MicroStation counterpart. 

 
Construct Circular Fillet 
The Construct a Fillet Between Two Elements tool works functionally the same as 
its MicroStation counterpart and stores a circular curve between two elements. 
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Construct Chamfer 
The Construct a Chamfer Between Two Elements tool works functionally the same 
as its MicroStation counterpart and stores a line between two elements.  Both the 
line and two new endpoints are stored in coordinate geometry. 

 
Cut Element 
The Cut Elements into Smaller Elements tool cuts elements into segments. 

MANIPULATE ELEMENTS 

             
When a Manipulate command is selected, a sub pallet will appear to allow the user to enter data as 
shown below. 

 
 

 
Move Plan View Element 
The Move a Plan View Element enables the user to move an element or to make 
copies. 

 
Rotate Plan View Element 
The Rotate Plan View Element rotates the selected element about a user-defined 
point.  The Angle may be manually entered and locked, or dynamically changing. 

 
Copy Parallel 
The Copy Parallel tool works functionally the same as its MicroStation counterpart. 

 
Delete Element 
When using the Delete Element tool, no tool settings dialog opens. 
Select and accept the element to be deleted.  The element is removed from the 
coordinate geometry database.  This tool works with a MicroStation selection set if 
present. 

Warning There is no undo for this command. 
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GROUPS 

           
When a Group command is selected, the Tool Settings dialog opens to allow the user to enter data as 
shown below. 

 
                                                     

The Groups Commands are detailed in the following table. 

 
Store Chain 
The Store Chain command works in the same manner as the MicroStation 
Automatic Create Complex Chain with the additional benefit that the chain is 
automatically stored in the COGO database. 

 
Store Parcel 
The Store Parcel tool enables the user to store parcels, takings, easements, and 
other types of right of way features.  It is very similar to the Store Chain tool with 
many of the same options. 
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LAB EXERCISE:   GRAPHICAL COGO 
> STORING AN ALIGNMENT 

1. Open the MicroStation file c:\data\geo\vdot\road2\60843\alignments.dgn. 
2. Attach the saved view ALIGN1. 
3. We will attempt to store the alignment shown below. 

 
4. Access Project Manager and open the project 60843. (Select the user Mary to access). 
5. Select the Graphical Coordinate Geometry tool by selecting Applications > GEOPAK 

Road > Geometry > Graphical Coordinate Geometry. 

 
6. Select Permanent Visualization on the main COGO dialog. 
7. From the Elements pulldown select Next Available Settings. 
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8. Enter the settings as shown below. 

 
9. From the Graphical COGO tool box tear off the tool bar for Store Elements and click on the 

Store a Point option. 

 
10. Locate point D1010 at station 119+30.36 at a zero offset. 

 
11. Select the Locate Point option and locate point D1011 at the bearing and distance shown 

below. 
 

Bearing S 72 39 19.69 W 

Distance 17.29 

 

 
12. Use the Store Tangent Curve Constrained tool to place a curve using the settings below. 

 
13. Select the Store Tangent Line tool to place a line with the bearing and distance shown 

below. 
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14. Use the Store Tangent Curve Constrained tool again to place a curve with the settings 

below. 

 
15. Finally, use the Store Tangent Line tool to place a line with the bearing and distance shown 

below. 

 
16. Now that all of the points, curves and lines have been stored we will store the chain in 

coordinate geometry. From the Graphical COGO tool box click the Store Chain tool. 

 
17. Store the chain using the information shown below. 
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18. You should now have a chain matching the description below. Describe the chain and 
compare to the report. 
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HORIZONTAL ALIGNMENT GENERATOR 

INTRODUCTION 
The Horizontal Layout tools enable the user to create or modify horizontal geometry (using numerous 
tools) including placing spirals, curves, tapers, specified bearings and curves, complex ramp loops and 
connectors, and all using user-defined parameters. 

Note A session of COGO must be active. 

ACCESSING 
Clicking Horizontal Alignment from the Road Project: Road1.prj dialog within Project Manager 
opens the tool frame shown below. 

 
When File > Preferences is selected, the Preferences dialog appears and allows the user to set certain 
preferences. 

 



Lines / Curves Tools 
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The Design Tables option allows the user to set up design tables for Symmetrical 3 Centered Curves, 
Asymmetrical 3 Centered Curves, Symmetrical Taper Curves, Asymmetrical Taper Curves, and Spiral 
Curves. These files are stored in an ASCII format. 

 
The Tools option allows the user to open the Main dialog or any of the dialogs needed to store a 
horizontal alignment. 

 
Values within the dialogs dynamically change simultaneously with dynamic graphic modifications. 

Note Spiral and compound curve commands do not support dynamic manipulation. 
 

LINES / CURVES TOOLS 

 
The Lines / Curves commands are detailed in the following table. 

 
Store Line By 2 Points 
The store line by two points command generates two new points and a new line.  The 
command draws the line and the new points. 

 
Store Tangent Line 
The Store Tangent Line tool stores a line and its two endpoints in the coordinate 
geometry database. 

 
Store Curve By 3 Points 
The Store Circular Curve by Three Points tool stores a circular curve (using chord 
definition). 

 
Store Curve By Center 
This tool enables the user to store a circular curve by defining the center point, radius, 
and sweep angle. 

 
Store Tangent Curve Unconstrained 
The Store an Unconstrained Tangent Curve tool places a curve through a specified 
point tangent to the specified curve or line. 

 
Place Simple Curve 
This tool enables the user to store a circular curve.  Options include offsets, truncate, 



Curve Combinations Tools 
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and the ability to modify once the first curve is displayed. 

 
Place Simple Transition 
This tool enables the user to draw a transition element between two arcs.  Options for 
the Transition element include:  Tangent, Curve, or Spiral.  As the Transition option 
is changed, the dialog dynamically changes to reflect the selection.   

CURVE COMBINATIONS TOOLS 

 
The Curve Combinations commands are detailed in the following table. 

 
Place Turning Paths 
This tool enables the user to draw turning paths. 

 
Place Compound Curves 
This tool enables the user to draw a compound curve between two elements. 

 
Place Three Centered Curves 
This tool enables the user to draw a three-centered curve between two elements. The 
Design Vehicles group enables the user to select the desired vehicle, based on the 
data from files stored in the User Preferences. 

 
Place Taper Curves 
This tool enables the user to draw taper curves between two elements. The Design 
Vehicles group enables the user to select the desired vehicle, based on the data from 
files stored in the User Preferences. 

 
Place Reverse Curves 
This tool enables the user to store reverse curves between two elements. An option is 
supported for an intermediate user-defined Tangent Length. 

SPIRAL COMBINATIONS TOOLS 

 
 

 
Place SC Tangent To Line 
This tool enables the user to store a spiral / curve combination tangent to a line. 

 
Place ST Tangent To Curve 
This tool enables the user to store a spiral / tangent combination tangent to a curve.   

 
Place SC Tangent To Curve 
This tool enables the user to store a compound spiral / curve combination tangent to a 
curve. 

 
Place SCS (Intersecting Elements) 
This tool enables the user to store a spiral / curve combination tangent to a line. The 
Design Table enables the user to select the desired Design Speed / Lanes and Degree 
based on the data from files stored in the User Preferences. 

 
Place STS (Disjoint Curves) 
This tool enables the user to store a spiral tangent spiral combination tangent between 
two elements. 
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Place SCS (Disjoint Curves) 
This tool stores a spiral curve spiral combination between two curves. Note the tool 
also works with overlapping curves. The Design Table enables the user to select the 
desired Design Speed / Lanes and Degree or Radius based on the data from files 
stored in the User Preferences. 

COMPLEX TRANSITIONS TOOLS 

 
 

 
Place Complex Ramp 
This versatile tool enables the user to draw simple to complex ramp geometry. 

 
Place Ramp Connector 
This versatile tool enables the user to draw simple to complex ramp connectors, 
with a variety of options. 

 

ALIGNMENT TOOLS 

 
 

 
Place Dynamic Alignment 
The first Alignment tool is used to place a dynamic alignment. You initially select 
and accept a beginning element. By moving the cursor, the length of curve and 
dynamic ahead element change.  Continue placing data points to create curves and 
intermediate tangents. At any time during the process, the Entry Radius may be 
changed. Any subsequent curves are placed with the revised Radius. 

 
Place PI Alignment 
The second Alignment tool is used to place a PI based alignment. 

 
Store Chain 
The third Alignment tool is used to store a chain comprised of graphical elements. 
This works similar to Automatic Create Complex Chain, while the chains are 
automatically being stored into the COGO database file. 
 

 

 

MANIPULATE TOOLS 
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Move Plan View Element 
The Move a Plan View Element enables the user to move / translate an element or 
to make copies. 

 
Rotate Plan View Element 
The Rotate Plan View Element rotates the selected element about a user-defined 
point. The Angle may be manually entered and locked, or dynamically changed. 

 
Extend Plan View Element 
The Extend Plan View Element tool can extend or shorten any element. 

 
Delete Element  
When using the Delete Element tool, no tool settings dialog opens. 
Select and accept the element to be deleted. The element is removed from the 
coordinate geometry database. This tool works with a MicroStation selection set if 
present. 
Warning:  there is no undo for this command. 
 

 

 

LAB EXERCISE:  GRAPHICAL COGO & HORIZONTAL ALIGNMENT GENERATOR 
> STORING AN ALIGNMENT 

1. Open the MicroStation file c:\data\geo\vdot\road2\60843\alignments.dgn. 
2. Attach the saved view ALIGN2. 
3. Access Project Manager and open the project 60843. (Select the user Mary to access) 
4. Access Graphical COGO and the Horizontal Alignment Generator. 
5. Begin by locating point D1016 at station 76+91.40 on the MAINLNE at a zero offset. 

Note Use Graphical COGO to locate the point 

 
6. Next from the Horizontal Alignment tools select the option Store Line by 2 Points and 

enter the information shown below. The beginning point will be point D1016 that we 
previously stored. 

 
7. Once the line has been placed select the tool to place a Dynamic Alignment from the 

Alignments tool bar. Horizontal Alignment > Tools > Alignment 

 
8. Begin by data pointing on the tangent line we drew in the previous step. 



Lab Exercise:  Graphical COGO & Horizontal Alignment Generator 
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9. Enter the information into dialog to control the placement of the alignment. 

 
10. Data point again to store the curve. 
11. Now enter the tangent length to place the final tangent line. 

 
12. Data point to place the tangent. 
13. Right click the mouse to exit the alignment. 
 



Lab Exercise:  Graphical COGO & Horizontal Alignment Generator 

 

 
 Copyright © 2006 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 1-16 

> STORING THE ALIGNMENT 

1. Select the Store Chain tool from the Alignments tool bar. 

 
2. Enter the information below and then data point on the alignment to store the chain in coordinate 

geometry. 

 
3. Review the chain description in coordinate geometry. 

 
 
 



Lab Exercise:  Graphical COGO & Horizontal Alignment Generator 
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> REVERSE CURVES 

1. Select the Copy Parallel tool from the Graphical COGO tool bar and copy the tangent portion of 
CHN2 100’ to the left side. 

 
2. Next select the Place Reverse Curves from the Curve Combinations tool bar. 

 
3. Enter the radius information in the dialog shown below and select the 2 tangent lines. Be sure to 

truncate the correct tangent. 

 
4. Change the truncate option to Ahead and repeat the process tying into the curve on the original 

alignment CHN2. 



Lab Exercise:  Graphical COGO & Horizontal Alignment Generator 
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5. You should end up with a detour similar to the one shown below. 
 

 

 
6. Use the Store Chain tool to store the chain into coordinate geometry. 

 
 

 



Lab Exercise:  Graphical COGO & Horizontal Alignment Generator 
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> COMPLEX TRANSITIONS 

1. From the MicroStation dropdown menu select Utilities > Saved Views. 
2. Select ALIGN3 then click Apply. 
3. Dismiss the Saved Views dialog by clicking the X in the upper right corner. 
4. Select the Preference pulldown and set the Element Names as shown below. 

 
5. Select the Tools > Complex Transitions pulldown to access the following menu bar. 

 
 

6. Select the first of the two icons to access the Place Complex Ramp dialog. Populate the dialog as 
shown below. 

 
7. Use your cursor to ID chain MAINLINE with a datapoint, then issue another datapoint to accept 

it. 
8. Next, use your cursor again to ID chain WOLFTRAP with a datapoint. The ramp will now 

dynamically visualize. 
9. Issue a datapoint in the southwest quadrant to store the ramp as shown in the following diagram. 



Lab Exercise:  Graphical COGO & Horizontal Alignment Generator 
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10. Change the toggle on the dialog to Loop (Exterior Construction). 

 



Lab Exercise:  Graphical COGO & Horizontal Alignment Generator 
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11. Using the technique in the previous steps place the loop in the SE quadrant of the intersection. 

 
12. Close the Complex Transitions dialog. 
 

> PI ALIGNMENT TOOL 

1. Attached the saved view ALIGN4. 
2. Select File > Preferences form the main Horizontal Alignment tool bar. 
3. Set the preferences for PI Alignment Display. 

 
4. Next make the following settings for the PI Alignment Design. 



Lab Exercise:  Graphical COGO & Horizontal Alignment Generator 
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Note The path to the Superelevation Preference Directory may vary depending on location of 

superelevation preferences. 
5. Change the COGO Element Names to match the dialog below. 

 
6. Close the Preference dialog. 
7. From the Tools pulldown select the Alignment tool. 

 



Lab Exercise:  Graphical COGO & Horizontal Alignment Generator 
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8. Click the middle icon to open the PI Alignment tool. 

 
9. Click the icon to Load Graphic Element To Table. 
10. Data point on graphic and follow prompts to load. 
11. This will place the geometry into the table for editing. 

 
12. Click on the curve radius and change it to 1000’. 
13. Click on the icon to save the alignment and key in the information below. 

 
14. Click OK. 
15. Exit MicroStation. 



Lab Exercise:  Graphical COGO & Horizontal Alignment Generator 
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Coordinate Geometry 
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2 
CHAPTER OBJECTIVES 

In this chapter, you will create and store parcel data using Parcel Editor in COGO as well as 
Graphical Coordinate Geometry tools.    

INTRODUCTION 
The Coordinate Geometry database file (*.GPK file) is comprised of stored geometric elements such as 
points, lines, curves, spirals, chains, parcels and profiles. When COGO calculations are completed, the 
results are stored in the binary database file, which is then utilized throughout the design process with 
many other applications. 

ACCESSING COGO 
When Coordinate Geometry is started, the Start-Up dialog appears. 

 

Project Name Name displayed on reports. This is an optional entry, with a maximum of 60 
alphanumeric characters. If Project Manager is active, this field is populated 
automatically. 

Job Number Identifies coordinate geometry database file and is a required field. The job number is a 
maximum of three alphanumeric characters. If Project Manager is active, this field 
populated automatically. This field is required. 

Operator Code Unique 2-character code which enables multiple users access to database file. The user’s 
initials are suggested. Note this field is not required for single user access, but highly 
recommended. If Project Manager is active, this field is populated automatically. 

Subject Description of coordinate geometry work (could relate to the project) with a maximum of 
48 alphanumeric characters. 
This field is optional. 

After the dialog is populated and OK is clicked, the main coordinate geometry dialog is invoked. 

Note If Project Manager is open the COGO login dialog will not appear. 



Coordinate Geometry Preferences 
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COORDINATE GEOMETRY PREFERENCES 
Two options have been enhanced on the Feature Preference portion of Coordinate Geometry. The 
preference dialog is now made up of four optional settings in addition to the smd selection. This dialog 
can be accessed from Applications > GEOPAK Road > User Preferences. The options include: 

• Apply Best Match feature 

• Use Shared Cells 

• Plot Scale  

• Point Label Redraw 

 
The options for Use Shared Cells and Point Label Redraw add new functionality and control over 
how features are displayed when storing or re-visualizing in COGO. 

Using the Use Shared Cells option will place features identified by cells by using the shared cell 
functionality of MicroStation. 

The first time you place a cell with Use Shared Cells on, the shared cell definition (elements 
comprising the cell) is stored in the DGN file in much the same way as it is stored in the cell library. 
To place subsequent instances of the shared cell, the cell library does not need to be attached. In other 
words, a shared cell can have many instances in a DGN but only one definition. 

For an unshared cell, on the other hand, the library definition is stored in the DGN file each time the 
cell is placed. Using shared cells can therefore be a way to reduce DGN file size. The reduction is 
greatest in files with cells that have a large number of component elements and/or instances. 

The use of shared cells is recommended for these reasons: 

• Shared cells are faster to place and manipulate than unshared cells. The first time a cell is 
placed in the DGN file, the cell library in which it is stored must be attached. If the cell is 
placed as a shared cell, it is not necessary to have the cell library attached to place additional 
instances of that cell. 

• All instances of a shared cell in the DGN file are replaced when any instance of that shared 
cell is replaced. 

• Shared cells usually reduce DGN file size, thereby improving performance. 

POINT LABEL REDRAW 
The Pont Label Redraw option that has been added to the user preferences allows control over how 
point labels are displayed in relation to a point symbol when visualized or redrawn. 

 
 



Next Available Element 
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Position by SMD Settings -  the label is drawn with parameters defined within the specified survey 
database (SMD) when the map is redrawn. 

Position relative to symbol – the user can move the point name, elevation, etc. using MicroStation 
tools and if the data is remapped the labels will retain their same position relative to the point symbol 
at the new mapped position. 

NEXT AVAILABLE ELEMENT 
In the main COGO dialog there is now an option to provide user input for the next available element 
names. This is located under the Element pulldown. 

 
Once accessed the following dialog appears allowing the user to key-in the desired names to begin 
storing COGO elements. 

 

EXPANDED ELEMENT NAMES 
A major enhancement to the coordinate geometry database is the ability to accept expanded element 
names. Each element type in coordinate geometry will now accept up to 15 characters for the 
associated name. 



Rename Elements 
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This standardization includes all elements that can be stored in coordinate geometry and applies across 
all dialogs. 

RENAME ELEMENTS 
A new command has been added to facilitate renaming of COGO elements. The command structure is 
listed below. 

RENAME element type oldname newname 

Example: RENAME CURVE a12 a13 

Note The RENAME operation may be done inside Navigator as an in-place edit operation to the 
name column. 

When renaming an element inside COGO Navigator it is simply a matter of clicking on the desired 
element name and keying in a new name. 

 

CHANGE ELEMENT 
Similar to the rename command new functionality has been added in order to change elements within 
COGO. The command structure is listed below. 

CHANGE elementType elementName parameterName parameterValue 

Examples:  

CHANGE POINT name X newValue 

CHANGE POINT name Y newValue 



Database Utilities 
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CHANGE POINT name Z newValue 

CHANGE POINT name FEATURE newValue 

CHANGE POINT name DESCRIPTION newValue 

CHANGE POINT name STATION newValue 

Note The CHANGE operation may be done inside Navigator as an in-place edit operation to the 
appropriate column.  

When changing an element inside COGO Navigator it is simply a matter of clicking on the desired 
filed in the desired column and providing the desired change. 

 

DATABASE UTILITIES 
New database utilities have been provided in order to make it easier to validate, clean and compress the 
gpk file. These tools can be accessed from the File pulldown on the main Coordinate Geometry dialog. 

 
When accessed, the following dialog will appear that contains a field for the job number and two 
buttons that will perform the desired operation. 



Merge Database 
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Validate – Looks for problems and errors in the GPK database and reports findings. Does not attempt 
to clean or compress the database. 

 
Clean and Compress – Rebuilds and compresses the GPK database.  

 
Both of these commands work similar to the previous key-in of Rebuild Database. 

MERGE DATABASE 
Another valuable tool that has been added to coordinate geometry is the ability to merge another gpk 
into the existing one. This option is located under the File > Import pulldown. 



Navigator 
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The subsequent dialog will allow the selection of a secondary gpk database to import directly into the 
open gpk. 

 
Note If REDEFINE is turned off there will be no risk of overwriting elements in the open gpk. 

NAVIGATOR 
Many new options and functionalities have been added to the coordinate geometry navigator. These 
include: 

• User Defined Column Headers 

• In-Place Editing 

• Export Preferences 

• Import Preferences 

• Row Selection 

USER DEFINED COLUMNS 
User defined column headers allow the user to customize the types of column the navigator 
displays. By right clicking on the column headers a list is provided that controls what is displayed. 
The list of available headers is dictated by the toggle for element type. For example when the 
element type is set to Parcel then the header options are parcel specific. 



Navigator 
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When the element toggle is set to curves, likewise all header options are curve related. 

 
Columns may be moved in the display by selecting the column and sliding to the location on the 
dialog where it is preferred. 

IN-PLACE EDITING 
All of the options in the Navigator will now support In-Place editing of values. This just requires a 
simple click on the value to be changed and then keying in the desired change. In the case of a curve 
name you click on the existing curve name and simply type over with the new name. 



Navigator 
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EXPORT PREFERENCES AND SETTINGS 
In order to save preferences of navigator, two new options have been added to the Tools pulldown. 
These are Export Preferences and Export Settings. 

Export Preferences - allows the user to create and save a user defined preference file for exporting 
data to a csv file. The desired item in the Data column is highlighted then added to the Selected Data 
column using the arrows in the center of the dialog. Once all the desired data has been added, a Format 
Name and Format Description are provided and the file can be saved. 

Multiple Format Names can be added to the same file to be used for selection when exporting. 

 
 

 

 



Parcels 
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Export Selection – allows exporting data using a previously defined preference file. 

 
This option requires that the desired elements in the COGO Navigator be selected or highlighted prior 
to executing. Each element highlighted or selected will be exported to the selected csv file. 

 

PARCELS 
The parcel interface and additional attributes have been greatly enhanced with version 8.8. 
Enhancements include: 

• Additional Occupied Type 

• User Defined Attributes 

• Interface Modifications 

 

OCCUPIED TYPE 

 
The new occupied type can be added to a parcel to represent a portion of a parcel that is set aside for 
something such as an inhabited area. This would then be reflected in area totals where a right-of-way 
taking has occurred and it overlaps a portion of a parcel designated as occupied. The resulting areas 
would be indicated as shown below: 



Parcels 
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Total occupied area:          59542.65531  m² =     5.95427 ha =    14.71325 a 

Occupied in taken area:       58519.61057  m² =     5.85196 ha =    14.46045 a 

Net taken area:               23754.67123  m² =     2.37547 ha =     5.86988 a 

 

USER DEFINED ATTRIBUTES 
Functionality has been added to the parcel element type to attach user defined attributes. These can 
include any information that the user wishes to associate with a parcel such as address, deed books, etc.  

The command line syntax for adding attributes to parcels is shown below. 

Maximum attribute name length = 24 and string size = 256 

STORE ATTRIBUTE elementType elementName  PARCEL parcelName NAME attributeName 
TYPE NUMERIC/STRING VALUE attributeValue 

DELETE ATTRIBUTE elementType elementName  PARCEL parcelName NAME attributeName 
TYPE NUMERIC/STRING 

CHANGE ATTRIBUTE elementType elementName  PARCEL parcelName NAME attributeName 
TYPE NUMERIC/STRING VALUE attributeValue 

Note The user attribute may be specified in graphic COGO and COGO’s Store Parcel dialog 
without using the command line.  

 

 

 

The ability to setup a list of default preferences is also available. This is accomplished by accessing the 
Default Attributes Preferences option from the Element > Parcel pulldown. 

 
 

The dialog is used to compile a list of default preferences that will be displayed when storing any 
parcel. Values for each attribute can be changed as parcels are added to the database. 



Parcels 
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When the Store Parcel dialog is accessed the list of defaults will be displayed in the bottom. 

 
The attribute values are changed by simply clicking on any one of the three columns and providing an 
overriding value. 

Parcel attributes can also be changed directly from the COGO Navigator. This is done by highlighting 
the previously stored parcel and right clicking. This action will present a menu where one option will 
be Change Parcel Attribute as shown below. 



Parcels 
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Once selected, the attribute editing dialog will appear allowing for the adding, deleting or changing of 
the user attributes. 

 
 



Graphical COGO 
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GRAPHICAL COGO 
Graphical COGO also supports the addition of user defined attributes when storing graphically. This is 
accessed via the Store Parcel dialog as shown below. 

 
The functionality is identical to assigning the attributes in classic COGO. 

The new Occupied type has also been added to the graphical Store Parcel dialog as shown below. 

 
New Flood functionality has also been incorporated into the store graphical parcel dialog. This will 
allow the use of MicroStation’s flooding capabilities for generating areas. 

 



Graphical COGO 
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Map Check / Store Parcel 

The Map Check/ Parcel Editor tool enables the user to store or edit parcels (based on directions, 
distances, and curve data), and compute closure. Parcels can be loaded from the coordinate geometry 
database or manually typed in. Once a parcel is complete, clicking Store Parcel stores or updates the 
parcel in the database. 

 
The top section of the dialog has several important fields, as detailed in the table below. 

 

Parcel Name 

 Key-in Combo box provides for the selection of a previously stored parcel or key in for a new parcel 
number. 

  

Load 

 If desired, a previously stored parcel may be selected. Simply select the name from the Parcel Name 
list, then press the Load button. GEOPAK populates all associated data within the dialog. Regardless 
of how the parcel was originally stored, the two specified curve parameters at the time of loading are 
utilized. 

  

Curve Parameters:Radius, Arc, Chord, Delta 

 Two parameters must be utilized to store curves within the parcel. Select the two desired parameters, 
as GEOPAK does not allow selection of the same parameter in both fields. Note: they can be changed 
at any time during the parcel description to enable the user to use Radius and Chord for one curve, and 
Delta and Arc for another. 

  

Owner: 

 When a previously stored parcel with attached owner is loaded, the Owner(s) are displayed. Note this 
is a display only field, as owners must be added within a command line in COGO. 

  



Lab Exercise: Entering Parcel Data 
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Improvements 

 When a previously stored parcel with attached improvement is loaded, the Improvements are 
displayed. Note this is a display only field, as improvements must be added within a command line in 
COGO. 

  

Preferences 

  
Compute options include Curves Only or Points and curves. When points are included, a Starting Point 
number is required. Closure options include Internal Bearing and Distance or Displayed Bearings an 
Distance. 

  

Starting NEZ 

  
The starting point can be a COGO point, selected from a visualized element or type into the Pt. Num 
field. When populated, the North and East are automatically displayed. If a new point number is 
utilized, then North and East coordinates must be entered. 

 

LAB EXERCISE: ENTERING PARCEL DATA 
> PARCEL EDITOR 

1. Open the MicroStation file C:\DATA\GEO\VDOT\ROAD2\60843\s60843.dgn. 
2. Attach the saved view ISTAR. 
3. Access Project Manager and open the existing project 60843. 
4. Use the user Mary to access the project. 
5. Click on the button to open Coordinate Geometry. 
6. Select Element > Parcel > Editor. 



Lab Exercise: Entering Parcel Data 
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7. Begin by clicking the Starting NEZ button and entering the POB coordinates. 

Northing 301688.7532 

Easting 3876313.6897 

8. Begin with point number D150. 

 
9. Close the Starting NEZ dialog. 
10. Next, enter the Name 4200 for the parcel and set the Parcel Type to Parent. 



Lab Exercise: Entering Parcel Data 
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11. Begin entering the metes and bounds outlined below. 

Note Notice the POB and the direction of the bearings. 

 
12. When completed you should have all of the metes and bounds entered in the dialog as shown 

below. 



Lab Exercise: Entering Parcel Data 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 2-19 

 
13. Click the Closure button and review the closure in COGO. 
14. Click the Store Parcel button to store the parcel. 
 

> STORING PARCEL ATTRIBUTES 

1. Select from the COGO Element pulldown Parcel > Default Attribute Preferences. 
2. Add each attribute into the dialog as shown below. 

 
3. Click the Apply button. 
4. Now select Element > Parcel > Store. 



Lab Exercise: Entering Parcel Data 
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5. Include the points as shown below and store the parcel. 

 
6. From the Navigator print the parcel and review the information. 

 
 



Lab Exercise: Graphical COGO 
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LAB EXERCISE: GRAPHICAL COGO 
> STORING A RIGHT-OF-WAY TAKE 

1. Select Applications > GEOPAK Road > Geometry > Graphical Coordinate Geometry. 

 
2. Turn off all levels with the exception of the parcel boundary including the existing right-of-way. 
3. Set the active level to Default. 
4. Place a line representing a proposed right-of-way similar to the image below. 

 
5. Click the icon to store a parcel. 



Lab Exercise: Graphical COGO 
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6. Enter the information as shown below. 

 
7. Data point inside the area making up the right-of-way take. 
8. Enter a second data point to accept the direction for storing the right-of-way take. (A right mouse 

button click will reverse the direction of the arrows). 
9. Next, move your cursor around the perimeter of the area making up the right-of-way take and pick 

a POB for beginning the area and enter a data point. 
10. Print the Parcel in Coordinate Geometry and review the data. 

 



Lab Exercise: Chain Manipulation 
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LAB EXERCISE: CHAIN MANIPULATION 
> REMOVING STATION EQUATIONS 

1. From the COGO Navigator set the Element toggle to Chains. 
2. Highlight all of the chains in the list window and Visualize them. 
3. From the COGO Navigator select Tools > Settings. 
4. Turn on the setting to Window Center Visualized Element. 

 
5. Click OK. 
6. In the Navigator select chain GRAFTONLT. 

 
7. Click the Print/Describe icon on Navigator and review the alignment data. 
8. Notice the curve name is GRAFTLT. In the next steps we will modify the curve. 
9. Change the Element toggle on Navigator to Curve. 
10. Find the curve GRAFTLT in the list window and double click on it. 
11. Change the radius to 100.00 (make sure that REDEFINE is turned ON). 



Lab Exercise: Chain Manipulation 
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12. Click Store Curve. 
13. Describe the chain again and review the data. (Notice that station equations have automatically 

been incorporated at the PC & ending stations due to the change in the curve). 

 
14. From the Navigator double click on the chain GRAFTONLT. 
15. Change the station toggle to Begin Station and make sure the value is 10+00.00. 



Lab Exercise: Chain Manipulation 
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16. Click the Store Chain button. 
17. Highlight the chain in Navigator and click the Print/Describe icon. 
18. Notice now that the chain has been re-stationed through the curve, eliminating the station 

equations. 

 



Lab Exercise: Chain Manipulation 
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> INCLUDING STATION EQUATIONS 

1. In the next example we will incorporate a desired station equation in the same alignment at PT 
station of the curve. 

2. From the main COGO dialog select Element > Chain > Station Equation. 
3. Enter the information as shown in the dialog below. 

 
4. Now describe the chain again and review the data. 

 
5. Exit MicroStation 

 



Vertical Alignments 
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3 
CHAPTER OBJECTIVES   

In this chapter, you will create and modify vertical alignments using the Vertical Alignment 
Generator and the Component Based Profile Generator.  

INTRODUCTION 
The Vertical Alignment Generator is a GEOPAK tool that can graphically create and modify 
proposed design profiles or modify an existing ground profile. These operations may be accomplished 
through a dialog box and/or by dynamic manipulation of graphic elements. 

Several best fit options have been added to the Vertical Alignment Generator to provide the ability to 
compute profile components automatically from MicroStation graphics. Similar to the horizontal Best 
Fit application, it requires a selection of the graphical elements in order to perform the computations. 

ACCESSING 
The Vertical Alignment Generator can be accessed by selecting Applications > GEOPAK ROAD > 
Geometry > Layout Profiles (VPI Based). It can also be invoked from Project Manager by clicking 
the Vertical Alignment button or by selecting the VPI Based Vertical Alignment Design Tools icon 
from the GEOPAK ROAD tool frame. 

When selecting the Vertical Alignment generator, 
the first dialog that appears is labeled Settings, as 
depicted here. The entries in this box set the 
parameters and define the location within the 
design file where the profile components are to be 
displayed. All fields must be completed before the 
design process can begin. Once OK is clicked, the 
Vertical Profile Generator dialog appears. 

Note This tool also utilizes the cell that was 
drawn in the previous exercise by 
using the Identify Cell button. 

 

 



Using the Vertical Alignment Generator 
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USING THE VERTICAL ALIGNMENT GENERATOR 
This tool enables a user to load a previously stored profile or create a new profile. You will notice the 
dynamic changes in the dialog throughout the vertical alignment design. 

 

 
Various design parameters must be defined prior to designing a new profile; which are discussed in the 
options supported under the three menu options; File, Tools, and User. 

FILE 

 
 

Clear - clears the profile display from MicroStation graphics and removes all VPIs from 
the dialog box. 
Draw - write the graphic elements of the profile to the MicroStation file. 
Load - retrieves a previously stored profile from the coordinate geometry database (.gpk) 
Save - stores a new profile or updates (redefines) a previously stored profile under the 
same name. 
Save As - is used to store the profile or to save a modified profile under a different name. 
Exit - ends the process. 

TOOLS 

 
 

Critical Points - Vertical curves may also be defined by one or two critical points – i.e. 
the curve will pass through these points if mathematically solvable, the vertical curve 
will be drawn and the design speed display adjusted to fit the current parameters. 
Issue Data Point - Permits the user to type in stations and elevations, issue a data point 
that can be part of a MicroStation place line, place a cell or perform other generic 



Creating A New Profile 
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operations. This is useful in displaying visual references within the profile that need to 
be considered in design of the vertical profile. 

USER 

 
 

Preferences - sets the rounding parameters for each of the items listed in the dialog 
box.  Also contains a toggle that will force the dialog to window center the view on the 
current VPI. 
K Values - is a table of stopping sight distance K-values for crest and sag conditions for 
various design speeds.  These values are based on the AASHTO Green Book. 
Settings - recalls the Settings dialog box that first appeared upon initializing Vertical 
Layout. 

CREATING A NEW PROFILE 
Warning The enter/tab key must be used to ensure values are accepted. 

A new profile can be created with the following steps: 

1. Place the first VPI using one of the four supported options. 
 Type station and elevation of the VPI into the appropriate fields in the Profile Generator 

dialog. 
 Enter station of VPI as precision input (type in value), and allow the elevation to be 

defined through dynamic cursor placement on screen. 
 Elevation is defined via precision input, and the station is defined through dynamic cursor 

placement on screen. 
 Both values for the VPI can be established dynamically on screen by clicking on the 

Dynamic button and placing a DP in the view at the desired station and elevation. 
2. Define ahead (or back tangent). 

Station, elevation, grade and length parameters may be defined via precision input, dynamic 
manipulation or a combination of both. 

3. Define remaining VPI’s and Grades. 
A repetition of Step 2 with an option to insert VPI’s between two existing VPI’s. 

4. Define Vertical Curves. 
Simply define the design speed from the Speed option button and GEOPAK will reference the 
K-value table and draw the vertical curve. If a curve overlap occurs, an overlap message will 
be displayed in the dialog box along with the overlap length. Length of Curve or K-value may 
also be keyed in. 

5. Adjusting Curve Lengths 
The vertical curve can be modified by directly keying in either the K-value, curve length or 
defining the design speed in the dialog box. You will see the values computed automatically 
adjust to reflect the results of any modifications. 

6. Save the Profile. 
7. Select File > Save As to name and save the newly created profile. The names of profiles are 

any 1-9 alphanumeric characters. 

PRECISION PLACEMENT OPTIONS 

 

 

Options available for creating or modifying vertical curves, VPI’s and grade lines:  
 OFF - Values change. 
 INC (Increment) - Ensures that the designated profile parameter will be 

adjusted as defined in the Preferences dialog. 



Best Fit Line 
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 LCK (Locked) - Forces selected operations to maintain the designated profile 
parameters. 

 

BEST FIT LINE 
The Best Fit Line tool is located on the Vertical Profile Generator under the Tools > Best Fit 
pulldown. 

 
The Best Fit Line tool will allow the user to select any graphical line, whether it is a type 3 or type 4 
MicroStation element, to perform a best fit solution. This solution will be reported back in a display 
window similar to the one below with all geometrical information. 

 
This information can then be analyzed to aid in the input of grade information into the vertical 
alignment generator if desired. 

BEST FIT PARABOLA 
The Best Fit Parabola tool is located on the Vertical Profile Generator under the Tools > Best Fit 
pulldown. 



Best Fit Profile 
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The Best Fit Parabola tool will allow the user to select any graphical line, whether it is a series of 
type 3, a type 4 or a type 12 (complex chain) MicroStation element, to perform a best fit solution. This 
solution will be reported back in a display window similar to the one below with all geometrical 
information. 

 
This information can then be analyzed to aid in the input of grade information into the vertical 
alignment generator if desired. 

BEST FIT PROFILE 
The main difference in the Best Fit Profile and the other Best Fit options is that Best Fit Profile will 
actually populate the vertical alignment generator dialog with a complete profile grade. 

Once the settings are made in the preference dialog and the element selected a best fit profile is 
generated. The user can then review and analyze the grade, deleting or inserting PI’s where desired. 

 
When the Identify Element button is selected the main vertical alignment generator dialog will 
populate as shown below. 



Best Fit Profile 
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LAB EXERCISE: PROFILES 
> BEST FIT PROFILE 

1. Open the MicroStation file C:\DATA\GEO\VDOT\ROAD2\60843\d60843prof.dgn. 
2. Attach the saved view PRO1. 
3. Access the Vertical Alignment Generator. (Applications > GEOPAK Road > Geometry > 

Layout Profiles VPI Based). 
4. In the Settings dialog click the Identify Cell button and data point on the profile cell displayed in 

the MicroStation view. 

 
5. Key in the Operator Code of mw. 
6. Click OK. 
7. From the Vertical Alignment Generator dialog select Tools > Best Fit > Profile. 
8. Make the settings as shown below. 

 
9. Click the Identify Element button and data point on the graphical profile in the MicroStation 

view. 
10. Click another data point anywhere to accept. 
11. The main Vertical Alignment Generator dialog should be populated as shown below. 
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12. Review and edit the proposed grade removing unwanted VPI’s and adjust curve lengths as desired. 
13. When completed select File > Save Profile As and provide the name as shown below. 

 
14. Clear the profile from the Vertical Alignment Generator. 
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> VERTICAL ALIGNMENT GENERATOR 

1. Using the same existing profile as a reference we will now enter grade information to store an 
additional profile. 

2. Begin by keying in the first VPI at STA=0+00 ELEV=29.78. 
3. Using the following table key-in the remaining VPI information. 

Station Elevation 

16+56.72 33.39 

26+13.83 0.79 

37+92.45 38.40 

47+83.33 35.24 

4. Now using the Previous button return to VPI 2. 
5. Select a Design Speed of 60 MPH. 

 
6. Using the Next button set the Design Speed to 60 MPH for each of the following VPI’s. 
7. Select File > Save Profile As and save the profile as EPLT2. 

 
8. Close the Vertical Alignment Generator. 
 
 



Component Based Profiles 
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COMPONENT BASED PROFILES 

INTRODUCTION 
The Component Based Vertical Alignment tools provide the user with a myriad of tools to place, 
modify and delete profile components. Tool boxes organize tools to include the placement of tangent 
lines, and a variety of vertical curves. Components interact with each other to automatically trim 
vertical curves, connect various elements, and modify, copy and rotate components. The user also has 
the option to store completed profiles with the coordinate geometry database. 

ACCESSING 
This tool requires the active chain control to be active. In addition, an active chain and an active profile 
must be defined. The profile may not have a gap. If these conditions are not met, an Alert Message is 
displayed. 

 
When the prerequisites have been met and the tool is selected, the tool frame is opened. 

The Component Based Profile tools are accessed from Applications > GEOPAK Road > Geometry 
> Component Based Profiles. 

 
There are four primary tool boxes for placing profile components. 

Place Lines   

Places Curves   

Manipulate  

Profile Tools  
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LAB EXERCISE: COMPONENT BASED PROFILES 
> COMPONENT BASED PROFILES 

1. Using the same existing profile from the previous exercise as a reference, select Applications > 
GEOPAK Road > Project Manager > Active Chain Control. 

 
2. Set the Active Chain to EPLT1. 
3. Right click on the icon representing View 1 and set the view to Profile. 
4. Select Applications > GEOPAK Road > Geometry > Component Based Profiles. 
5. Select the tool to Create a Profile Line by 2 Points. 

 
6. Key-in the grade as shown below and check the toggle ON. 

 
7. Place a line from the beginning of the existing profile approximately 1400 feet. 
8. Next select the tool to place a Tangent Profile Curve. 

 
9. Snap to the end of the previously placed tangent and using the approximate values in the dialog 

below, place a curve. 

 
10. Select the tool to place a Tangent Line Unconstrained. 

 
11. Using the approximate values below place the tangent line from the previous curve. 

 
12. Use the Create Profile Line By 2 Points and place a line on the uphill slope (reference the image 

in step 14). 
13. Select the tool to Create Profile Curve Between 2 Elements. 

  
14. Using the approximate values below snap to the first tangent line and then the second. 
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15. Finish out the profile using the tools we just discussed. 
16. Once completed with the profile select the Store Profile icon. 

 
17. Provide a name and then select the profile element. 

 
18. Exit MicroStation. 
 



Draw Profiles 
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DRAW PROFILES 

INTRODUCTION 
The Draw Profile tool enables the user to draw several profiles simultaneously from a variety of data 
sources. 

• GEOPAK coordinate geometry database wherein the vertical alignment is stored. 

• GEOPAK binary TIN file, Site Model or Site Object. If you have not already created your binary 
TIN file, see the DTM online documentation for a detailed discussion of the Digital Terrain 
Modeling features. The Site Model or Object are created utilizing GEOPAK Site Modeler 
software and are stored within the GEOPAK Site project (gsf) file. 

In addition, if the source data is TIN files or site components, the resultant profile may be stored within 
the coordinate geometry database. 

ACCESSING 
The generation of profiles must be completed from within the 2D MicroStation design file wherein the 
profile is to be drawn. 

 



Tabs 
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The first entries required in the dialog are at the top of the dialog. These include: 

Job Number  Required to identify the coordinate geometry database wherein the chain 
for generating the profiles is stored.  

Chain Required to reference an alignment within each cross section. The 
subsequent specifications of station ranges and left/right offsets are 
computed relative to this baseline when pattern by station is utilized. If 
pattern by design is utilized, the intersection of each pattern line with the 
baseline determines the station of the cross section.  

Dialog Profile Cell Control Clicking this button opens the Profile Cell Control dialog, wherein the 
current profile cells are listed along with associated station, elevation, etc. 

• A profile cell is required in order to un-ghost the majority of the Draw Profiles dialog. It can be placed by any 
method within GEOPAK prior to drawing profiles. 

Two additional buttons / fields are located at the top of the dialog and are detailed below. 

Update Profile This button updates any previously drawn profile. 

Label Scale Utilized when the By Feature Display settings option is utilized. The 
specified Label Scale is compared to the scale within the D&C Item and 
proportionalized. Note this option is only utilized if the text setting is set 
to scale, not fixed. 

Note The Job Number must be defined in order to populate the Chain list. Once the chain and 
profile cell is defined, the dialog un-ghosts. 

TABS 
Three tabs on the dialog support the input data required to draw profiles: 

Surfaces: Defines the surfaces utilized for drawing profiles. Note multiple surfaces may be drawn in a 
single processing. Source data includes GEOPAK TIN files, Site Models, or Site Objects. 

COGO: Defines the COGO data utilized for drawing profiles. 

Projection: Used when the chain / profile to be drawn is different than the chain / profile used to 
create the profile cell. 



Surfaces Tab 
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SURFACES TAB 
The Surfaces tab defines the surfaces utilized as source data when drawing profiles. Multiple surfaces 
from a variety of sources can be drawn in a single processing. 

 
Each surface to be drawn must be added to the list box. This is accomplished via the action / edit 
buttons on the right side of the dialog. When a line is added to the list box, the profile is drawn. Note: 
clicking on the draw toggle in the list box deletes or redraws the profile. 

Edit Buttons: 

Add, Modify, Delete 

 

To add to the list box, simply select the source data type and data, then 
populate the Display Settings, Filter Tolerances and Offsets. Then click Add to 
the right.  

To delete a line from the list box, simply highlight the line to be deleted and 
click Delete. 

Modify a line by highlighting the desired line in the list box, make the desired 
changes in the fields directly below the list box, then click Modify.  

Store Surface as 
Profile in COGO 

 

When the profile is drawn, click to open the Store Profile dialog, to store the 
profile in COGO. 



Source Data 
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The profile may be stored, or just the input file may be created. If an input file 
is created, the Operator Code and File Name are required. If the dialog is 
invoked while in a 3D file, the user may toggle on the option to create a 3D 
profile string.  

The 3D profile string consists of the circles denoting every location where the 
design centerline intersects topographic elements. If the circles are not deleted 
at this time, they can be deleted at any time with a single application of the 
MicroStation "Delete Element" command. 

SOURCE DATA 
The list box displays the source data dialog items. These are described in the following table. 

Model 
Object 
Object+Slopes 
Model Base 
TIN File 

If a site model project is active when the Draw Profile dialog is opened, several 
options are supported for source data. When the type is set to Model, Object, 
Object+Slopes or Model Base, all components of the specified type in the 
current site project are listed. The user selects the desired component from the 
list. When site components are utilized, no file icon is displayed. If a site 
project is not open, the only option is a TIN file. Pressing the Files button 
invokes the TIN Files Manager, wherein the desired file may be specified. 

Method: 
Triangles 
Break Lines 
POT 
Increment 
Even 

Interval between successive VPIs in terms of master units, i.e., feet or meters.  

If a TIN File is utilized, triangles are interpolated to determine the elevation 
defining the profiles. However, if a site component is utilized, the user may 
select break lines. In this case, any surface line drawn between two break lines 
in the site component will interpolate only between the break lines, not the 
triangles.  

The Increment option creates a profile where the user specifies the incremental 
distance between successive VPI points on the existing ground profile where 
the first VPI point is coincident with the Beginning Station. 

The Even method specifies the incremental distance between successive VPI 
points on the existing ground profile where the first VPI point is rounded to the 
next highest even station from the Beginning Station. For example, if the 
Beginning Station is 10+015 and the Even value is 25, the VPIs would be 
generated at 10+025, 10+050, etc. 

The POT method creates a profile with VPIs at every location where a POT 
occurs in the referenced chain. 

 



COGO Tab 
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COGO TAB 

 
Multiple profiles may be drawn by populating the tab, then utilizing the edit buttons on the right side 
of the list box. 

Edit Buttons: 

Add, Modify, Delete 

  

 

To add to the list box, simply select the source data type and data, then 
populate the Display Settings, Filter Tolerances and Offsets. Then click 
Add to the right. 

To delete a line from the list box, simply highlight the line to be deleted 
and click Delete. 

Modify a line by highlighting the desired line in the list box, make the 
desired changes in the fields directly below the list box, then click 
Modify. 

Station Limits and Vertical Offset are identical to the Surfaces tab. To define the symbology of the 
profile(s), the user may specify the parameters via the By Symbology option, or By Feature. When 
the By Feature option is selected, the user must identify an Item from the Design and Computation 
Manager. Other options which are found on the Draw Plan and Profile dialog within Design and 
Computation Manager are also supported within the Draw Profile dialog, i.e., General Labels, VPI, 
VPC, etc. Simply highlight the desired option in the list box, then set the toggles and fields 
accordingly. Scale for Custom Line Styles is also supported.  



Projection Tab 
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PROJECTION TAB 
The Project tab can be used when the chain / profile to be drawn is different than the chain / profile 
used to create the profile cell. When the Projection tab is selected, the dialog dynamically changes, as 
shown below. 

 
Each projected profile to be drawn must be added to the list box. This is accomplished via the action / 
edit buttons on the right side of the dialog. When a line is added to the list box, the profile is drawn. 
Note: clicking on the draw toggle in the list box deletes or redraws the profile. 

Edit Buttons: 

Add, Modify, Delete 

  

To add to the list box, simply select the Type, Chain, Profile, and Vertical 
Offset, then populate the Display Settings, Filter Tolerances and 
Extraction from TIN, if desired. Then click Add to the right. 

To delete a line from the list box, simply highlight the line to be deleted 
and click Delete. 

Modify a line by highlighting the desired line in the list box, make the 
desired changes in the fields directly below the list box, then click 
Modify. 

The following fields are defined in the Details group box. 

Type A COGO chain or Survey chain may be utilized. 

Chain: After the desired Type has been selected, the Chains in the current 
GPK are listed for selection. 

Profile (COGO Chain option only) Select the profile to be utilized. 

Vertical Offset Offset in terms of master units. Any Vertical Offset is applied 
after the profile is generated from the source data. 

 



Lab Exercise: Profiles 
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LAB EXERCISE: PROFILES 
> DRAWING PROFILES 

1. Open the MicroStation file C:\DATA\GEO\VDOT\ROAD2\60843\d60843prof.dgn. 
2. Select Applications > GEOPAK Road > Plans Preparation > Draw Profiles. 
3. From the Draw Profiles dialog open the Profile Cell Control dialog and set the Active Chain to 

EPLT1. 

 
4. Select the COGO tab on the dialog. 
5. In the Display portion of the dialog set the profile to PROF1. 

 
6. In the Display Settings portion of the dialog set the toggle to By Feature and click on the 

paintbrush icon. 



Lab Exercise: Profiles 
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7. From the D&C Manager select the feature PROP255. 

 
8. Click OK. 
9. Click the Add Profile icon on the right side of the list window to add the profile in the list and 

draw graphically. 

 
 

 



Lab Exercise: Profiles 
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> PLOTTING DITCHES 

1. While still on the COGO tab, change the profile to DITCHL1. 
2. Set the Display Settings to By Feature and select the feature DitchL. 

 
3. Click OK. 
4. In the Options settings, highlight VPI. 
5. Toggle ON the Grade Labels. 

 
6. Make sure that all toggles are OFF for the other Options settings. 
7. Add the ditch to the list window. 
8. Change the feature to DitchR. 



Lab Exercise: Profiles 
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9. Change the profile to DITCHR1. 
10. Add this ditch to the list window. 

 
11. These ditches can be manipulated with any MicroStation command and moved to the desired 

location in the profile view. 
 



Superelevation 
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4 
CHAPTER OBJECTIVES  

In this chapter you will review the preferences and dialogs for computing superelevation. Also 
included will be instruction on Shape Manager tools. 

INTRODUCTION   
GEOPAK supports a myriad of options for the definition of pavement on proposed cross sections. 
They range from a single slope specification emanating from a baseline / profile on each section, to 
complicated multiple roadways, each with its own superelevation transitions. 

The most basic is the project where no superelevation transitions are required, i.e., the roadway slope 
for all pavement (if any) can be specified as a single value. In this case, the slope can be defined with 
the proposed cross section processing and any additional superelevation work is not required. This 
process will be utilized in Exercise 12 when we have GEOPAK draw the existing shoulder and 
pavement on the sections – shapeless. 

Another option is the definition of superelevation when roadways are constant widths without tapers, 
i.e., turn lanes, acceleration and deceleration lanes, etc. In these areas, the automated superelevation 
can be utilized, based on a user-defined design speed and considering the geometry of the specified 
roadway. After careful review of the data (in ASCII format) and overriding the computed values, 
GEOPAK draws pavement representations as complex shapes into a MicroStation 2D design file. 

A third option is the definition of superelevation when roadways are not constant widths, i.e., gore 
areas, turn lanes, acceleration and deceleration lanes, etc. In these areas, graphics elements within a 
MicroStation 2D design file are utilized to create complex shapes which define the superelevation 
transitions. 

A combination of these tools can be combined with a project, or even within a single roadway. The 
shapeless mode is excellent for rural applications, low volume city streets, frontage roads, etc., while 
the automated method quickly generates automated shapes for more complex roadways. Any area 
which cannot be defined via the automated method can be augmented by the graphical method. 



Accessing Automated Superelevation (AutoShape Input File Maker) 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 4-2 

ACCESSING AUTOMATED SUPERELEVATION (AUTOSHAPE INPUT FILE MAKER) 
The Automated Superelevation tool can be accessed by selecting Applications > GEOPAK ROAD > 
Cross Sections > Superelevation Shape Manager Tools. It can also be invoked from Project Manager 
by clicking the Calculate Superelevation button or by selecting the Automated Superelevation icon 
from the GEOPAK ROAD tool frame. 

The GEOPAK Superelevation package enables the user to create, edit, and run an autoshape input file 
quickly, basing it on an existing COGO alignment. 

A set of preferences is available which gives the user complete control over every aspect of the 
standardization of the superelevation design process. AASHTO Method V is available as a default, 
along with the ability to employ user-defined lookup tables both for e (superelevation rate) and for 
runoff length. User-defined equations may also be entered to compute these values. A thorough set of 
options is available for resolving the superelevation conflicts of Reverse Curves, Compound Curves, 
Broken Back Curves, and Short Curves.  

GEOPAK calculates superelevation 
transition locations for any alignment 
stored into the coordinate geometry 
database. The main superelevation 
dialog is simple and straightforward, 
allowing the user to select which 
preference file is to be used for the 
current session, as well as enabling the 
entry of the typical section lane 
configuration in the simple engineering 
terms of Number of Lanes, Lane 
Widths, Median Width (if any), and 
Cross Slope. More complex lane 
configurations may be represented as 
needed. 
Upon computation of the superelevation 
parameters (cross slopes and 
stationing), the information is stored in 
an ASCII file, where the user may 
review and modify the transitions, if 
desired. After reviewing the 
information, the ASCII file is executed 
from the Autoshape Builder to generate 
superelevation shapes. 
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Job Coordinate geometry database containing the desired chains and profiles. 

Chain GEOPAK baseline chain dictating the horizontal geometry for which 
superelevation transitions are calculated.  This chain is also called the Shape 
Cluster Baseline in the Auto Shape input file.   

Begin Station When the chain is defined, GEOPAK populates the Begin Station with the 
default beginning of the chain.  To compute superelevation for part of a chain, 
adjust the station.  

End Station When the chain is defined, GEOPAK populates the End Station with the 
default beginning of the chain.  To compute superelevation for part of a chain, 
adjust the station.  

Design Speed Design speed that determines what Design Speed is to be used either in the 
tables or equations for e and length computations. 

Preference File 
   e selection 
   L selection 

The Preferences File combo box selects which Preference File is to be used 
for this computation.  The various Preferences Files which are available in the 
combo box are determined by what files have the .sep file extension in the 
Preference Files Path on the User Directories dialog.  When it is set, the 
available e and length Selection combo boxes are filled in according to the 
csv file names as specified in the Preferences File.  Those combo boxes 
determine which table within the .csv file will be used for computation. 

Facility Facility determines whether the roadway cross section is to be divided or 
undivided.  This option determines two things.  For the dialog box, it 
determines whether or not the values Profile, Tie (Offset or PGL), and or the 
Tie or PGL values may be different.  If they are different then two shape 
clusters are to be generated, which usually is required for a median.  The state 
of the Facility option button also determines which Preference is used as 
found on the Distribution tab of the Preferences dialog.   

Left / Right tabs The area enclosed in the Left / Right tabs are for the determination of values 
specific to shape clusters.    
NOTE: The right and left tabs contain data pertaining to each lane within 
each roadway.  If the Facility is undivided, then the left tab is for the left 
lane(s) while the right tab is for the right lane(s).  If the Facility is divided, 
then the right tab is for the entire right roadway, while the left tab is for the 
left roadway.   

Create Input File ASCII file wherein GEOPAK creates the autoshape input file.  DO NOT 
include the extension, as GEOPAK adds .inp to the field.  

Generate 
Superelevation 
Transitions 

Commence automatic superelevation calculations 

Profile  GEOPAK profile defined as the Shape Cluster Profile in the Auto Shape 
input file.   

Tie Offset - Horizontal distance from the Profile (PGL) to the Chain.  
PGL Chain - Chain stored in the gpk file that the shapes will be computed 
from. This chain does not require a profile be stored with it as the defined 
profile will be applied to this chain. 

Offsets Offsets define the dimension of the shape (usually a lane) by two offset 
distances from the baseline.  Note that tapers are not supported.  Offset 
distances are negative if measured to the left.  .  Each lane must have the 
same offset on the left as the left adjacent lane and must have the same offset 
on the right as the right adjacent lane (no gaps in offsets).  Computation may 
not proceed if this condition is not met. 
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% Slope Cross slope of each shape in normal crown in percent format.  A negative 
sign denotes the roadway going downward, while emanating away from the 
PGL.  A Normal Crown section of 2.0% would, therefore, be entered as –2.0.  
Lane offset values are entered in terms of master units, i.e., feet or meters. 

Dependent / 
Independent 

One dependent shape, which is based on the profile, is required for each 
cluster.  Other shapes are drawn not based on the profile, but on adjoining 
lanes, and are independent.  For example, turn lanes are drawn abutting next 
to the mainline roadway, so they are independent.  However, a lane based on 
the profile for its initial elevation, such as one of the through lanes, is profile 
dependent. 

Edit buttons: 
Add 
Delete 
Modify 

Add – populate the fields and click Add. 
  To delete a line, highlight the desired line, then click the Delete button.  To 
modify a line, highlight the desired line, click once on the value to be 
modified.  The value will be placed in an edit mode.  Change the value then 
hit enter or tab out of the field. 

Quick Entry 
(second to bottom 
tool to the right of 
the list box) 

 

Enables the user to populate the shape cluster list boxes quickly while 
entering the data using engineering terminology.   

 

Rectify Lanes 
(bottom tool to the 
right of the list 
box) 

 

If Offset values have been entered that create a gap between lanes, the Rectify 
Lanes option removes this gap.  Click Rectify Lanes and the values will be 
modified so that any gaps are removed. 

 



Accessing Automated Superelevation (AutoShape Input File Maker) 
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Selection of the Generate Superelevation Transitions button performs the actual superelevation computations. Three 
things happen at this point. 

 First, the superelevation 
transitions as computed by 
GEOPAK are written to the 
Autoshape Input File 
specified by the user (in the 
Create Input File field).   

 Second, the log file is 
written.   

 Finally, the Autoshape 
Input File is loaded into the 
text editor running within 
MicroStation.  This 
Autoshape Input File Editor 
has an icon at the top that 
allows the Autoshape Input 
File to be run.  Autoshape 
Input files can also be run 
from the Autoshape 
Builder. 

 

 



Draw Shapes into Plan View File 
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DRAW SHAPES INTO PLAN VIEW FILE 
The Autoshape Builder is NOT accessible from Project Manager but can be invoked by selecting 
Applications > GEOPAK ROAD > Cross Sections > Superelevation Shape Manager Tools or by 
selecting it from the GEOPAK ROAD tool frame. 

Once the shape input file (fname.inp) has been created and reviewed, the designer can run the input file 
to place the superelevation shapes into the specified graphics file. To use the interactive method to 
define roadway superelevation (in a .dgn file) the designer selects the Autoshape Builder from the 
Superelevation Shape Manager Tools tool bar (or alternately from this same tool within the Text Editor 
as described above). 

 

Autoshape Input 
File  

Name of .inp file (shapes.inp) created by the Automated superelevation 
generation containing the transitions. 

Display Only  Create the shapes in “Display Only” mode.  That is, they are not written to the 
design file and a view Update operation eliminates them, as does zoom in, etc. 

Override Input 
File Level 
Symbology 

This option is used to override the Plot Parameters settings in the Superelevation 
Shapes input file. 

The shapes are placed in a 2D graphics file on level 63 by default. The plot parameters can be modified 
in the input file with a text editor prior to building the shapes into the graphics file or with the User > 
Symbologies pull down on the Automated Superelevation dialog. 



Superelevation Shape Manager Tools 
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SUPERELEVATION SHAPE MANAGER TOOLS 
The Superelevation Shape Manager tools can be invoked by selecting Applications > GEOPAK 
ROAD > Cross Sections > Superelevation Shape Manager Tools or by selecting it from the 
GEOPAK ROAD tool frame. 

The tools in the Superelevation Shape Manager Tools toolbox are detailed below. 

 
Automated Superelevation - performs the actual calculations and stores the results in 
an ASCII file, known as the autoshape input file. 

 
Autoshape Builder - processes the autoshape input file and draws corresponding 
complex shapes in the specified 2D design file. 

 
Shape Maker - graphical method of drawing irregular superelevation shapes.  This 
method is utilized for gore areas, turn lanes, etc. 

 
Shape Analyst - provides information on any point within a GEOPAK superelevation 
shape. 

 
Shape Profiler - provides profile information based on user-define increments 
intersecting a GEOPAK superelevation shape. 

 
Shape Editor - dynamically change parameters on a previously created shape.  This 
includes filler line stationing, dynamic moving of shapes, etc. 

 
Shape Selector - highlights or selects shapes based on a wide range of user queries or 
filters. 

 

Shape Properties - provides information on any GEOPAK superelevation shape.  In 
addition, this shape information can be modified on individual shapes of selections of 
shapes. 

 

Shape to DTM - provides the option to store a DTM Dat file from the superelevation 
shapes. In addition, it can plot the calculated elevations into the design file at a user 
specified interval. 

 



Shape Analyst 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 4-8 

SHAPE ANALYST 
The Shape Analyst tool is extremely useful, as it provides information on any point within a 
GEOPAK superelevation shape. 

 

Before using this tool, the Job Number must be selected. Upon selecting a Job Number, a Chain must 
be selected that the shapes are defined relative to. If Display Only is enabled, information like 
elevation and a flow arrow are drawn to the view, but they are not written as elements to the active 
MicroStation file. 

When the Cross Section toggle is not activated and a data point is issued within a shape, the elevation 
of the data point and a flow arrow are displayed. When the toggle is activated, a dashed line is placed 
through the data point, radial to the shape cluster baseline. In addition to the elevation and flow arrow 
placed at the data point, elevations are displayed where the cross section line intersects any 
superelevation shape and cross slopes are labeled for each shape. 

The By Sta/Offset button causes the current Station / Offset value to be projected back onto the shape 
cluster baseline and the elevation of the projected point is displayed. This option can be manual entry 
only and requires no data point on the screen. 

The DP button works within a superelevation shape whose X, Y coordinates are utilized to compute 
station / offset from the specified shape cluster baseline, which is subsequently utilized in conjunction 
with the shape to compute the various slopes and elevations. After the DP button is clicked, numerous 
data points can be placed.  It is not necessary to click the DP button again. Each corresponding station / 
offset is displayed along with the associated output information. 

The Dynamic button activates the dynamic mode. As the cursor moves across the screen, any 
momentary pause places the elevation and flow arrow in the MicroStation file and computes and 
displays the analysis information. 

The Extrapolate Fixed Slope toggle is another option supported in the Shape Analyst tool. The 
option is utilized when the data point, dynamic point or station / offset is outside of the shape. When 
the option is not activated, the data point is projected back to the shape's chain. The elevations at the 
edges of the shape are displayed and the slope of the outside shape is projected to the data point. When 
the toggle is enabled, the user defined slope is projected from the outer most shape to the data point to 
determine an elevation. 

SHAPE PROFILER 
The Shape Profiler tool computes elevations along any GEOPAK shape or MicroStation element at a 
user specified interval. The element can be inside or outside of the shapes. 



Superelevation Preferences 
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The Job field can be populated by key in or using the Select… button. After selecting a GPK file, click 
Identify Shape and data point on any shape along the desired Chain. Set the From Station and To 
Station fields by keying in values or using DP. 

Even should be selected when it is desired to have the elevations compute at the even station values. 
Increment will allow the elevations to be computed starting at the From Station, then adding the 
increment value to that station. Intersect is used with an element to compute elevations at all locations 
that the element intersects the shape(s). 

The Elevation Along toggle can be set to Shape or Element. When set to Shape, elevations will be 
computed based on the Even/Increment value along both longitudinal edges of the shape. When set to 
Element the elevations are computed along the element based on the Even/Increment/Intersect 
toggle. 

Continuous Extrapolation allows the user to identify multiple longitudinal elements outside of the 
shape area and compute elevations by a user defined Slope and one of three methods: Radial to 
Baseline, Radial From Element, or Radial to Element. 

SUPERELEVATION PREFERENCES 
A set of preferences is available which gives the user complete control over every aspect of the 
standardization of the superelevation design process. AASHTO Method 5 is available as a default, 
along with the ability to employ user-defined lookup tables both for e (superelevation rate) and for 
runoff length. User-defined equations may also be entered to compute these values. A thorough set of 
options is available for resolving the superelevation conflicts of Reverse Curves, Compound Curves, 
Broken Back Curves, and Short Curves. 

Superelevation Preferences are saved to disk in a file of ASCII format with an extension of .sep. Users 
may edit the file in a text editor, or they may edit it with the Superelevation Preferences Editor. 

When editing a Preferences file with a text editor, comments may be inserted. Comments are 
delineated with a dollar sign ('$'). Comments may take up an entire line, or may be on the same line as 
a data entry. When a $ is found on a line, GEOPAK does not read that line any further. Although there 
is no way to edit the comments in the Preferences dialog, comments are not lost when the .sep file is 
edited via the dialog. 



E Tab 
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E TAB 
The first step in the process is the computation of e for each curve. Regardless of the manner of 
computation, e computation is based on the curvature of each curve and the Design Speed. When the E 
tab is selected, the dialog dynamically changes as shown below. 

 
  

E Method: 
Radius Table 
AASHTO Method 5 
Equation 

This option determines which method GEOPAK uses to compute 
e.  

Table name AASHTO Method 5 or Radius Table - this field contains the 
name of the csv file in which to find the tables. Generally, no 
path should be given in the file name since these are controlled 
by Environmental Variables and/or user control in the 
Superelevation Computation dialog. If a path is specified along 
with the csv file name, that path will be used regardless of other 
methods of setting the path such as Environmental Variables.  

Equation - text field is the location where the equation is 
entered. Click Files to select the file. Clicking Edit opens the 
editor specified in the environmental variable 
GPK_SUPER_EDITOR and should normally be set to Excel or 
some type of spreadsheet application. 

Speed Interpolation: 
Linear 
Closest Entry 
Conservative Entry 

Specifies how GEOPAK is to interpolate between Design Speed 
columns if the user selects a Design Speed which is not found in 
the table. Speed Interpolation applies to both the AASHTO 
Method 5 table and Radius Table for e computation,  

Radius Interpolation: 
Linear 
Closest Entry 
Conservative Entry 

Radius Interpolation only applies to the Radius Table option. 
This interpolation option button specifies how GEOPAK is to 
interpolate between Radius Rows if the given Radius does not 
have a corresponding row with an exact match in the table. 
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E Rounding Increment Applies to e regardless of how it is computed. . This is simply 
rounding to the nearest evenly divisible number of the rounding 
value. For example, if e-rounding were set to 0.25, and e as it is 
computed from a table comes out to be 3.789, the value would be 
rounded to 3.75, which is evenly divisible by 0.25. Set a value of 
0.00 to disable the rounding of e. 

 

RUNOFF TAB 
The second step in the process of computing Superelevation transitions is the computation of 
Unadjusted Length, which is the Runoff Length as if the roadway had two lanes only. (Adjusted 
Length is the true Runoff Length, adjusted for the true roadway width.) In all methods of computation 
of Unadjusted Length, the computation is based on the rounded e value for each curve. 

 
 



Tangent Runout Tab 
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TANGENT RUNOUT TAB 
Tangent Runout is the distance from a Cross Slope of Normal Crown to a Cross Slope of zero as 
depicted here: 

 
 

Three methods are available to compute Tangent Runout Length: By Relative Gradient, Fixed 
Distance, or Equation 

 
 



Adjust Factors Tab 
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ADJUST FACTORS TAB 
The user can control Adjustment Factor settings for three lanes up to twelve lanes. If a roadway has 
more than twelve lanes, the length adjustment is made according to the settings for twelve lanes. 

 
 

DISTRIBUTION TAB 
After Adjusted Lengths have been computed for non-spiraled ends of circular curves, the transition is 
distributed over the curve and its adjacent tangents and stationing is computed relative to the PC and 
PT. The amount of the transition which falls on the tangent is termed Percent on Tangent. Options are 
provided to base that percentage on Total Length or on Runoff Length. 

 
 



Rotation Tab 
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ROTATION TAB 
The Rotation tab provides a means to indicate how the super will be rotated and the axis point the 
rotation will occur. 

 
 

REVERSE CURVES TAB 
Reverse Curves occur when two adjacent curves which deflect in opposite directions have 
superelevation transitions which overlap or are in close proximity. Two levels of conflict are defined 
for Reverse Curves: Critical and Supercritical. The determining factors for defining a conflict as 
Critical or Supercritical are both based on the Length of Normal Crown existing between the two 
transitions. (Note that overlapping transitions may be considered to have a negative Length of Normal 
Crown.) 



Compound Curves Tab 
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The distinction, then, between Critical and Supercritical has to do with how the conflict is handled. If 
the conflict is Critical, adjustments are made so that the Minimum Normal Crown Length is 
maintained. If the conflict is Supercritical, the transitions of the two curves are merged and Normal 
Crown never occurs between the conflicting curves. When GEOPAK checks for this conflict, it first 
checks to see if the Length of Normal Crown violates the Supercritical threshold. If it does not, 
GEOPAK then checks the Critical threshold. This means that if the value for Maintain Minimum 
Length is less than or equal to Supercritical Length, no conflict would ever be handled as Critical. Also 
note that either value may be negative, although this is ill-advised for Maintain Minimum Length. 

 
 

COMPOUND CURVES TAB 
The dialog contains settings for two types of conflicts in which two adjacent curves deflect in the same 
direction. "Compound Curves" are when two curves deflect in the same direction and have no 
intermediate tangent section, but instead share a common station, the PCC. "Broken Back Curves" 
occur when two curves deflect in the same direction and have an intermediate tangent section which is 
short enough that the superelevation transitions of the two curves overlap or nearly overlap. 

 
 



Short Curves Tab 
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SHORT CURVES TAB 
The Short Curve conflict occurs when the length of the fully superelevated portion of the curve is 
shorter than the desired minimum. This is not a conflict between two adjacent curves as the other 
conflict types, but is instead an undesirable situation occurring on a single curve. 

 
 

SUPERELEVATION TRANSITION CONFLICT RESOLUTION 
Superelevation Transition Conflicts occur when the stationing of the superelevation transitions of two 
adjacent curves overlap, or when the fully superelevated station range on one curve is too short. 

When curve conflicts occur, GEOPAK attempts to resolve them by adjusting relative gradients, 
distribution percentages or e values, depending on the applicable preferences. 

Before writing the autoshape input file, GEOPAK scans the filler line stationing created by prior 
processes in the superelevation flowchart for conflicts. 

 

 



Lab Exercise: Superelevation Shape Manager Tools 
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LAB EXERCISE: SUPERELEVATION SHAPE MANAGER TOOLS 
The Shape Maker window permits graphical and interactive creation of superelevation shapes. 
Interactive shape creation is typically required only for those areas where the longitudinal edges of the 
shapes have not been stored as GEOPAK chains or offset chains. The left-turn bay shown below is an 
example of a shape that is typically created from the Shape Maker Window. 

> SHAPE MAKER 

1. Open the MicroStation file c:\data\geo\vdot\road2\60843\d60843work.dgn. 
2. Attached the saved view Shape Maker. 
3. Turn off enough levels to have a clear image of the left turn lane shown below. We need this area 

clear of elements in order to shape. 

 
4. Select Applications > GEOPAK Road > Cross Sections > Superelevation Shape Manager 

Tools. 

 
5. Click the third icon from the left to access Shape Maker. 
6. Set the Shape Parameters portion of the dialog like the one shown below. 

 
7. In the Filler Line portion of the dialog set the Method to By Station. 
8. Enter a station value of 121+83.00. 
9. Key-in a slope of -3.0. 



Lab Exercise: Superelevation Shape Manager Tools 
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10. Click the Create button. 

 
11. Create another Filler Line at station 125+72.56 with the same slope of -3.0. 

 
12. With the toggle at the bottom left of the dialog set to Automatic, click the Draw button and data 

point inside the turn lane. 
13. You should now have the turn bay shaped. 

 



Lab Exercise: Superelevation Shape Manager Tools 
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> SHAPE ANALYST 

The Shape Analyst tool is extremely useful, as it provides information on any point within or outside a 
GEOPAK superelevation shape. This tool supports all GEOPAK superelevation shapes, including 
those with non-linear (parabolic) transitions, non-zero ties and PGL chains. 
1. Click on the fourth icon from the left on the Shape Manager tool bar. This will invoke the Shape 

Analyst tool. 

 
 
2. Using the chain list pull down set the chain to NBL. 
3. Click the DP button and data point on a shape. (Make sure the Extrapolate Fixed Slope is turned 

OFF). 



Lab Exercise: Superelevation Shape Manager Tools 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 4-20 

4. This should produce slope and elevation information on the shapes as shown below. 
 

 
Note You may have to change the symbology settings to view the text more easily. This can be 

done by selecting the Preference pulldown in the upper left of the dialog. 
5. Turn ON the Extrapolate Fixed Slope toggle. 
6. Enter a slope of -3.0. 

 
7. Click the DP button and data point outside of the shapes. 
8. This will compute an elevation at the data point by projecting the desired slope. 

Note An explanation of Extrapolate Fixed Slope is outlined below. 
The Extrapolate Fixed Slope option is utilized when the data point, dynamic point or station / offset is 
outside of the shape. When the option is not activated, the data point is projected back to the shape's 
chain. The elevations at the edges of the shape are displayed and the slope of the outside shape is 
projected to the data point. 



Lab Exercise: Superelevation Shape Manager Tools 
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When the option is toggled ON and set to a specific slope, the slope is projected from the outside shape 
to the data point to calculate an elevation at that point. 

> SHAPE PROFILER 

The Shape Profiler will generate profile information based on projections from superelevation shapes. 
It can also generate profiles along any shape. 
1. Click the fifth icon from the left on the Shape Manager tool bar. 
2. This will invoke the Shape Profiler as shown below. 

 
3. Set the options in the dialog as shown below making sure to identify the From Station and To 

Station. 

 
4. Once the settings have been made click the Identify Shape button at the bottom of the dialog and 

data point on the left turn bay shape created in the previous exercise. 
5. Click one more data point to Accept. 



Lab Exercise: Superelevation Shape Manager Tools 
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6. This will compute elevations around the perimeter of the shape as shown below. 

 
7. Next select the User > Preference pulldown in the upper left of the dialog and toggle ON the 

option to Store COGO Point setting the Beginning Point Number to D610. 

 
8. Click OK. 
9. Click the Identify Shape button next to the chain field and data point on the farthest right side 

shape. 
10. Set the Elevation Along option to Element. 

 
11. Click the Identify Element button at the bottom of the dialog and data point on the existing curb 

line to the right of the shape. 



Lab Exercise: Superelevation Shape Manager Tools 
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12. The shape slope will be project to the element and points stored in COGO at the desired 
increment. 

 
Note The Store Profile By Numbers command in Coordinate Geometry generates and stores a new 

profile name defined by previously stored points in either A) a sequence pa-pi or B) a random 
list. Sequential stationing and given elevation values must be stored with points prior to 
execution of both formats. SYNTAX: STO PRO name  pa-pi 

 

> SHAPE PROPERTIES 

The Shape Properties tool allows the user to review all the information associated with a particular 
shape. In addition to reviewing each aspect of the shape properties may be changed or edited. 
 
1. Click the eighth icon from the left on the Shape Manager tool bar. 
2. This will invoke the Shape Properties tool. 

 
3. Toggle ON each of the properties. 
4. Click on the ID button and data point on a superelevation shape. 

Note Any of the information in the dialog may be changed by editing the values and using the Set 
button to identify the shape. 



Lab Exercise: Superelevation Shape Manager Tools 
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Cross Sections 
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5 
CHAPTER OBJECTIVES   

In this chapter we will review the Ancillary Features application and new enhancements in the latest 
version. These include: 

• New Update Options  

• AdHoc Functionality 

Also a brief discussion on Tolerance settings will be included. 

INTRODUCTION 
The Ancillary Features application is used to draw supplemental information onto cross sections and 
profiles. This can be things such as right-of-way lines, drainage pipes and utilities. 

 



Accessing 
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ACCESSING 
The Ancillary Features application can be accessed from Applications > GEOPAK Road > Cross 
Sections > Draw Ancillary Features. 

OVERVIEW 
The dialog settings can be saved into a settings file via the File pulldown menu. This file can then be 
loaded at anytime to restore the settings of the dialog. 

Each ancillary feature to be drawn must be added to the list box. Once added, each feature can then be 
modified or deleted as needed. 

 
The Intersecting Elements portion of the dialog is where you specify how to determine the offset 
(plan view location) and elevation of the ancillary feature. 

 



Overview 
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There are four options with which to specify the offset location of the ancillary feature: 

• Chain - allows you to specify any COGO chain. This chain will then be used to calculate the 
offset of the ancillary feature. 

• Survey Chain - allows you to specify any Survey chain. This survey chain will then be used 
to calculate the offset of the ancillary feature. 

• Level Symbology - allows you to specify the graphical symbology of a specified feature. 
Note that with this option you must also specify the DGN file where the feature is located. 

• Feature - allows you to specify a D&C Item Name. The symbology specified by this item 
name will then be used to search for the specified ancillary feature. Note that with this option 
you must also specify the DGN file where the feature is located. 

 

There are also multiple options with which to specify the elevations of the ancillary feature: 

• TIN -The TIN option works in conjunction with the Vertical Offset. First, the elevation of the 
DTM at the chain location will be calculated, then the vertical offset (depth of cover) will be 
applied to determine the elevation of the ancillary feature. 

• Level Symbology - The Level Symbology option also works in conjunction with the Vertical 
Offset. In this case the offset is calculated from a Graphical Element in the dgn file (usually 
either a ground line or existing profile). 

• Feature - The Feature option also works in conjunction with the Vertical Offset. This is very 
similar to the Level Symbology, except in this case the symbology is taken from the D&C 
Feature. The offset is again calculated from a Graphical Element in the dgn file (usually either 
a ground line or existing profile). 

• AdHoc Attribute – This is a new enhancement that will allow you to attribute an element and 
will cause the elevation to be read from a graphical element containing the adhoc name 
“Profile” and “Offset”. 

The Display Settings portion of the dialog is where you specify how to display the ancillary feature on 
the cross sections or profile. 

 



Update Options 
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You have three options with which to specify how the ancillary data will be displayed. 

• Cell - The cell library can either be attached to the dgn file OR it can be read from the 
MS_Celllist variable. 

• Symbol - You can control the justification of the symbol, as well as the height and width of 
the symbol. 

• Text - Note the standard Text Symbology dialog can be used to set the text symbology. The 
angle of the text can also be controlled. 

 

UPDATE OPTIONS 
The new application now supports Update Options much the way the Existing Ground Cross Section 
application does. These options allow the user to choose from one of four modes. 

 
The options are toggled off / on by each selection of the option. The check to the left of the option 
indicates the option is active. Only one option may be active at any given time, therefore, if an option 
is selected, the previous active option is de-activated.  

Delete Existing Elements and Redraw 

 Any ancillary feature lines previously drawn with this tool are deleted and new features are drawn. 

 Delete Non-modified Elements and Redraw 

 Only features previously drawn with this tool AND have not been modified are deleted and new 
features are drawn. Any features previously drawn with this tool and modified are left intact. 

 Draw on Top of Existing 

 Any previously drawn features are ignored and a new set is drawn, resulting in two sets of features. 

 Query 

 When activated, the user is prompted each time Draw is clicked. 

The user must select one of the three options and click Apply to commence processing. Clicking 
Cancel closes the dialog with no subsequent processing. 

 

LAB EXERCISE: ANCILLARY DATA 
> MAPPING UTILITIES 

1. Open the MicroStation file C:\DATA\GEO\VDOT\ROAD2\60843\su60843.dgn. 
2. Access the Ancillary Features application. (Applications > GEOPAK Road > Cross Sections > 

Draw Ancillary Features). 
3. In the main dialog set the job number to 101. 

 



Lab Exercise: Ancillary Data 
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4. From the main Ancillary Features dialog set the Intersecting Element toggle to Level 
Symbology. 

5. Open the symbology dialog and using the match button data point on the element representing the 
sewer line to set the symbology. 

 
6. Close the Symbology dialog. 
7. In the field for DGN File, set the file to su60843.dgn. 
8. Open the MicroStation file d60843xsmainline.dgn. 
9. Click on the Extract Elevation toggle and set the toggle to Level Symbology. 
10. Open the symbology dialog and using the match button data point on the element representing the 

existing ground to set the symbology. 

 
11. Close the symbology dialog. 
12. In the Vertical Offset field key-in -6.0. 



Lab Exercise: Ancillary Data 
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> DISPLAY SETTINGS 

1. In the Display Settings portion of the dialog change the toggle to Symbol. 
2. Set the symbology as shown below. 

 
3. Click OK. 
4. Set the symbol to the circle option. 



Lab Exercise: Ancillary Data 
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5. Set the remaining options as shown below. 

 
6. Using the icons on the right side of the list window, add the utility into the list window. 

 
7. Change the Display Setting toggle to Text. 



Lab Exercise: Ancillary Data 
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8. Set the symbology and text settings as shown below. 

 
9. Click OK. 
10. In the Label field key-in ELEV=. 
11. Now select the Intrinsic Variable, Elevation using the pulldown under the yellow question mark. 
12. This will create an elevation label and should look like the dialog below. 

 



Lab Exercise: Ancillary Data 
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13. Using the icons on the right side of the list window, add the text item into the list window. 

 
14. Click the Draw button. 
15. When prompted set the Update Option as shown below and click Apply. 

 



Tolerance 
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TOLERANCE 
Filter Tolerance 

Both Horizontal and Variance filter tolerances are considered together for each pair of cross section 
segments. The middle point is deleted if both segment lengths are less than the Horizontal filter 
tolerance while the projected distance between the mid-point and the chord between the two end points 
is less than the Variance tolerance. 

 

 
 

 



Tolerance 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 5-11 

Default Tolerances 

Any cross section processing can accept a tolerance value that defines the distance such that two 
elements with endpoints closer together than the tolerance values are assumed to be connected. In 
addition, if two elements whose minimum distance apart is less than the tolerance then they are 
considered to be coincident. The table below depicts default tolerances (i.e., tolerances used by the 
software if the user does not explicitly define a tolerance). 

Function Default 
Tolerance
(English) 

Default 
Tolerance 
(Metric) 

Ancillary data 0.10 0.030 

Earthwork 0.01 0.003 

Existing ground profile 0.50 0.152 

Existing ground cross section 0.50 0.152 

Plan view limits of construction 0.10 0.030 

Proposed profile from cross sections 0.10 0.030 

Proposed cross sections 0.10 0.030 

Reports - Hydraulic 0.10 0.030 

Reports - Critical Points 0.01 0.003 

Reports - All Others 0.01 0.003 

Auto shapes 0.75 0.03 

Sheet layout 1.00 0.300 
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6 
CHAPTER OBJECTIVES   

In this chapter, you will learn: 

 The procedures for calculating earthwork quantities with GEOPAK 
 How to use Project Manager to set up and process an earthwork run    

INTRODUCTION 
GEOPAK forms graphical earthwork shapes in a (MicroStation) cross section design file to represent 
the end areas used to calculate volumes by the end-area method. These shapes are created when the 
designer processes an earthwork run in which the existing ground, finished grade, base, etc. are 
identified by level, color, weight and type. 

ACCESSING 
When Earthwork in the Road Project Manager is clicked, the Select Run dialog is displayed.  An 
existing run may be selected or new run may be started. When complete, click OK, which closes the 
Select Run dialog and opens the earthwork dialog. 

 
The left side of the dialog contains the list of parameters required to compute earthwork. When each 
parameter is selected, the dialog changes the key-in fields to reflect the selection. 
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For example, when EW Shapes is selected, the dialog changes as illustrated below. 

 

EARTHWORK DIALOG 

XS DGN FILE 
In XS DGN File the user can specify the file name in which to find the cross-sections. Tolerance 
specifies the maximum distances between two elements (in a cross section) to be considered as 
adjoining. Vertical Search Distance specifies the distance above and below the cross-section to look 
for elements pertaining to that cross-section. Baseline specifies the GEOPAK COGO chain the cross-
sections are based from. Begin/End Station specifies the beginning and ending stations to perform the 
earthwork calculations. 
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SOIL TYPES 
The Soil Types dialog requires the user to define the symbology and shrinkage/swell factors to be 
used. 

 
The user must first select the Class of the soil type. 

Existing Ground - Identifies the surface of the existing ground.  This classification is required to 
calculate earthwork. It also defines the default excavation material. 

Proposed Finish Grade - Surface of the proposed roadway. This classification is required to calculate 
earthwork and defines the default fill material. 

Existing Suitable - Material between excavation limits that is to be removed only when it encroaches 
on the proposed design. For example, if the proposed design is in fill, therefore above the existing 
suitable, it is not removed. 

Existing Unsuitable - Material between excavation limits that is to be removed in all circumstances. 

Proposed Undercut - Proposed layers that are not part of the finish grade, i.e. pavement layers, 
shoulder layers. 

Excavation Limit - Pairs of vertical lines drawn in the cross-sections to define the limits of removal 
for any existing suitable or unsuitable material. 
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Once the Classification is chosen, a Soil Type, the element symbology of the material, and the 
shrinkage/swell factors need to be entered. A Classification, except Existing Ground, can be listed 
multiple times.  The Soil Type determines how the cut and fill are calculated. For example, a user 
creates an earthwork run with a classification of Existing Ground with a soil type of Existing, 
classification of Proposed Finish Grade with a soil type of Suitable_Grading, and a classification of 
Proposed Undercut with a soil type of Pavement. The output from the run would look as follows. 
Material Name  End Areas Unadjusted  Adjusted Mult Mass 
Station     Volumes  Volumes  Factor Ordinate 

(square  (cubic  (cubic                    
ft)         ft)         ft)                  

--------------------------------------------------------------------------------- 
287+00   
SUITABLE_GRADING 
Excavation  0.00  0      0  1.00 
Fill    12.32  336     336  1.00 2887 
EXISTING 
Excavation  25.88  654     654  1.00 
Fill    0.00  0      0  1.00 3541 

 

In the same example, if both classifications of Existing Ground and Proposed Finish Grade had the soil type of 
Suitable_Grading, then the output would look as follows. 

Material Name  End Areas Unadjusted  Adjusted Mult Mass 
Station     Volumes  Volumes  Factor Ordinate 

(square  (cubic  (cubic                    
      ft)    ft)          ft)                  
--------------------------------------------------------------------------------- 
287+00 
SUITABLE_GRADING 
Excavation  25.88     654     654  1.00 
Fill   12.32     336     336  1.00 3541 

 

As can be seen from the above examples, when the soil types for the Existing Ground and Proposed 
Finish Grade classifications were named differently, both soil types appeared in the output. When the 
soil types for the Existing Ground and Proposed Finish Grade classifications were named the same, the 
quantities for each classification were combined into one soil type. By paying close attention to the soil 
types, the user can specify when material can be re-used and exactly where a specific soil type should 
be placed. 

Once the Classification and Soil Type are chosen, the user can select the Element Symbology to define 
that particular Soil Type and the Multiplication Factors for the Soil Type. The Match button can be 
used to select the Element Symbology. Once the Match button is selected, the user can select the 
elements in the MicroStation view. The symbology of that element will be added to the symbology list 
used to define the Soil Type. 
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EW SHAPES 
Earthwork Shapes enables the earthwork shapes to be drawn with the associated symbology. The 
colors of the earthwork shapes can be stratified, so that cut and fill or each soil type are different. 

 

OUTPUT FORMAT 
Output Format enables the user to specify which items to show in the earthwork report. 

 
With this command, any combination of the three classifications of excavation volumes can be 
formulated. For example, if the user desires to combine all three into an earthwork listing of simply cut 
and fill, press the < or > arrows until the desired option is displayed. Options include: 

 Common Exc, Subgrade Exc, Subsoil Exc, and Fill 
 Excavation (Common and Subgrade), Subsoil Exc, and Fill 
 Excavation (Common and Subsoil), Subgrade Exc, and Fill 
 Excavation (Subgrade and Subsoil), Common Exc, and Fill 
 Excavation (all types) and Fill 
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ADD/SUB VOLUMES 
Add/Subtract Volumes allows the user to enter volumes to be added or subtracted from the total 
earthwork calculated from the available sections. The user can specify whether to add excavation or 
fill, the soil type, the station, and the volume to be added. 

 

CENTROID ADJUSTMENT 
Earthwork volumes are calculated by averaging end areas and then multiplying these averaged areas by 
the distance between two successive cross sections as measured along the baseline. If the bulk of the 
cross section areas are located predominantly to either the left or the right of the baseline, as in a 
detour, an error occurs in the volume calculations for all non-tangential portions of the baseline. This 
error can be negligible or substantial depending on the degree of baseline curvature as well as the 
degree to which cross section areas are offset about the baseline. These types of errors can be 
optionally accounted for via specification of the Centroid Adjustment. 
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SKIP AREAS 
Skip Areas enables the user to specify an area (i.e. bridge exception) in which not to calculate 
earthwork volumes. These volumes, though not included in the Mass Ordinate, will still display in the 
station reporting. 

 
 

IGNORE AREAS 
There have been a couple of enhancements to the earthwork computations to provide better reporting 
of earthwork functions. The first of these is the addition of Ignore Areas. 

Ignore Areas allows the user to insert a range of stations to be completely ignored during earthwork 
computations. The end areas and volumes will not be computed between the beginning and ending 
station as if the sections did not exist. 
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SPLIT SUMMARY TOTALS 
The second enhancement involves the reporting of earthwork quantities. There is now the ability to 
report Split Summary Totals. This will report any addition or subtraction of volumes in a separate 
column in the summary portion of the report as shown below. 
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SHEET QUANTITIES 
Sheet Quantities allows a user to write an earthwork quantity file to be used when plotting cross-
section sheets. 

 
The name of the ASCII file can be chosen or entered. The user then selects the columns in which to 
place the quantity, the number of decimal places, the total column width, the soil type, the earthwork 
operation, and the type of quantity. 

This information is written to the ASCII file, and can be used to plot the quantities on the cross-section 
sheets. 

From the Files menu, the Run option processes all parameters that have been set in the Earthwork 
dialog. The Save Settings option saves all information in the Earthwork dialog. The Export option 
saves the parameters in the Earthwork dialog as an ASCII input file. The Exit option exits the 
Earthwork dialog. 

PROCESSING 
After all necessary information has been entered, the user has two options. The preferred method of 
running the earthwork is to select the Run option. The following dialog appears and the user may 
proceed by entering a log file name, choosing the Pause On Each Section option and then clicking 
Apply. The second method is to export the information as an ASCII input file, then use the Process 
Cross Sections tool. 

 
The earthwork quantities are written to the bottom of the log file and can be reviewed in any standard 
ASCII text editor. 
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Most people are comfortable dealing with earthwork 
as long as it involves standard cut and fill volumes.  
However, once it goes beyond standard cut and fills 
it can sometime become confusing.

We will now delve into these more advanced 
earthwork topics. GEOPAK is fully capable of 
calculating just about any type of earthwork scenario 
a user can come up with. However, in order to utilize 
these capabilities the user must understand both how 
the earthworks are calculated and the different 
material classes and their uses.

 
 

Before we go too far, let’s first make sure we 
understand the method that GEOPAK uses to 
calculate earthwork. In its algorithm to calculate 
earthwork, GEOPAK does 3 things:

Find an enclosed area

Determine the material type of the area

Determine the centroid of the area
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Find an enclosed area
 

 

Determine the centroid of the area
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Determine the centroid of the area
 

 

Determine the centroid of the area
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Determine the material type of the area
 

 

How does it determine the material type?

First, it intersects the graphical element directly 
below the centroid. It then matches the 
intersected symbology to the defined material 
types. Existing Unsuitable Material

soil type = EX_PAVEMENT 
roadway exc mult factor = 1.000000
subsoil exc mult factor = 1.000000
fill mult factor = 1.000000

type = line, line_string
lvname = XS Existing Pavement
co = 3
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This is why you can get quantities for just about 
anything on a cross section, as long as you 
distinguish the element symbologies correctly.

Butiminous_Asphalt

Rock_Base

Concrete

 
 

Existing Ground
soil type = Suitable_Grading
roadway exc mult factor = 1.000000
subsoil exc mult factor = 1.000000
fill mult factor = 1.000000

type = line, line_string
lvname = XS Existing Ground
co = 0
lc = 3

But this algorithm can sometimes “fail” because of 
the shape configuration.
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Proposed Undercut
soil type = Aggregate_Base
roadway exc mult factor = 1.000000
subsoil exc mult factor = 1.000000
fill mult factor = 1.000000

type = line, line_string
lvname = XS Aggregate Base
co = 6
lc = 0

But this algorithm can sometimes “fail” because of 
the shape configuration.

 
 

Now that we know “how” the earthwork areas are 
calculated, let’s look at how we can use the material 
classes and soil types to control how the quantities 
are reported.

There are 6 functional classes of earthwork supported 
by GEOPAK. 

Existing Ground Line

Proposed Finish Grade

Proposed Undercut

Existing Suitable

Existing Unsuitable

Excavation Limits  
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Within each class, you can have multiple soil types. 
The soil type is nothing more than a “name” for the 
material and will be used for all reporting purposes.
Existing Unsuitable Material

soil type = TOPSOIL 

Existing Unsuitable Material
soil type = Existing_Base

 
 

For each soil type you must specify the appropriate 
shrink/swell factors.
Existing Unsuitable Material

soil type = TOPSOIL 
roadway exc mult factor = 1.000000
subsoil exc mult factor = 1.000000
fill mult factor = 1.000000

Existing Unsuitable Material
soil type = Existing_Base
roadway exc mult factor = 1.000000
subsoil exc mult factor = 1.000000
fill mult factor = 1.000000
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Also, for each soil type you must specify the graphical 
symbology of the cross section element.
Existing Unsuitable Material

soil type = TOPSOIL 
roadway exc mult factor = 1.000000
subsoil exc mult factor = 1.000000
fill mult factor = 1.000000

type = line, line_string
lvname = XS Topsoil

Existing Unsuitable Material
soil type = Existing_Base
roadway exc mult factor = 1.000000
subsoil exc mult factor = 1.000000
fill mult factor = 1.000000

type = line, line_string
lvname = XS Existing Base

 
 

Why are the classes important? It’s not enough to 
just call something “topsoil” or “existing base”. The 
software has to do know the purpose or function of 
the material. 

For example, do you want to excavate or fill? Is 
the material suitable for re-use or not?

Topsoil Existing Base
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Existing Ground Line

Proposed Finish Grade

Material Classes

 
 

These are the only two material classes that are 
required in order to calculate earthwork:

Existing Ground Line
Proposed Finish Grade

Specifying these two classes will give you the 
basic cut and fill quantities.
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Existing Ground Line

Proposed Finish Grade

Existing Suitable

Material Classes

 
 

The soil types specified with the proposed finish 
grade and existing ground are important as they 
are used as the default fill material and default 
excavation material.

Note: Always use the same name!

Proposed Finish Grade                      Existing Ground Line
soil type = Suitable_Grading soil type = Suitable_Grading
roadway exc mult factor = 1.0            roadway exc mult factor = 1.0
subsoil exc mult factor = 1.0              subsoil exc mult factor = 1.0
fill mult factor = 1.0                             fill mult factor = 1.0
type = line, line_string type = line, line_string
lvname = XS Finish Grade                 lvname = Existing Ground
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Existing Suitable

Existing Suitable is defined just like the other material 
classes. You must define a soil type, shrink/swell 
factors and the proper graphical symbology.

Existing Suitable Material
soil type = TOPSOIL 
roadway exc mult factor = 1.0
subsoil exc mult factor = 1.0
fill mult factor = 1.0
type = line, line_string
lvname = XS Topsoil

 
 

Existing Suitable
Material classified as Existing Suitable is removed only
if its excavation is needed to build the proposed 
design. 

Excavation Required - None    

Existing Pavement
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Existing Suitable
Material classified as Existing Suitable is removed only
if its excavation is needed to build the proposed 
design. 

Excavation Required - Partial   

Existing Pavement

 
 

Existing Suitable
Material classified as Existing Suitable is removed only
if its excavation is needed to build the proposed 
design. 

Excavation Required - All   

Existing Pavement

 
 



Processing 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 6-22 

Existing Suitable
The classification of Existing Suitable does not affect 
whether material is reused. That is controlled by soil 
type nomenclature. 

Note: We’ll discuss this in more detail after we cover 
the Proposed Undercut classification.

 
 

Existing Ground Line

Proposed Finish Grade

Existing Suitable

Existing Unsuitable

Material Classes
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Existing Unsuitable

Existing Unsuitable is also defined just like the other 
material classes. You must define a soil type, 
shrink/swell factors and the proper graphical 
symbology.

Existing Unsuitable Material
soil type = Bituminous_Pavement
roadway exc mult factor = 1.0
subsoil exc mult factor = 1.0
fill mult factor = 1.0
type = line, line_string
lvname = XS Existing Bit Pavement

 
 

Existing Unsuitable
By default, material classified as Existing Unsuitable is 
removed only if its excavation is needed to build the 
proposed design. 

Excavation Required - None    

Existing Pavement
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Existing Unsuitable
By default, material classified as Existing Unsuitable is 
removed only if its excavation is needed to build the 
proposed design. 

Excavation Required - Partial   

Existing Pavement

 
 

Existing Unsuitable
By default, material classified as Existing Unsuitable is 
removed only if its excavation is needed to build the 
proposed design. 

Excavation Required - All   

Existing Pavement
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Existing Unsuitable
The classification of Existing Unsuitable does not
affect whether material is reused. That is controlled by 
soil type nomenclature. 

Note: We’ll discuss this in more detail after we cover 
the Proposed Undercut classification.

 
 

Existing Unsuitable
There are times when you want to “force” the 
excavation of Existing Unsuitable material, such as in 
the example below.   

One way to do this is to use 
Excavation Limits.

Existing Pavement
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Existing Ground Line

Proposed Finish Grade

Existing Suitable

Existing Unsuitable

Excavation Limits

Material Classes

 
 

Excavation Limits

Excavation Limits are short lines drawn onto the cross 
sections. They are defined differently from the other 
material classes. They only require a graphical 
symbology. No soil type or shrink/swell factors are 
needed.

Excavation Limits
type = line
lvname = XS Excavation Limits
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There are 3 rules to be aware of when using 
Excavation Limits.

Rule #1 - Excavation limits must be used in pairs 
on a required section. An odd number of limits is 
not supported.

 
 

There are 3 rules to be aware of when using 
Excavation Limits.

Rule #2 - The limits must be lines. Any other 
element types (line_strings, curves, curve_strings, 
arcs, etc.) are not supported.
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There are 3 rules to be aware of when using 
Excavation Limits.

Rule #3 - The endpoint should not be within an 
area where earthwork quantities are needed.

Much better!

 
 

Excavation Limits have several uses:

1.  Force the excavation of unsuitable material.

2.  As their names suggests, they are used to 
determine the actual “limits” of the 
excavation of unsuitable material.

3.  Delineate specific earthwork processing areas 
on a cross section.
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1.  Force the excavation of unsuitable material.

Example: Without Excavation Limits

Existing Unsuitable Material
soil type = Bituminous_Pavement
roadway exc mult factor = 1.0
subsoil exc mult factor = 1.0
fill mult factor = 1.0
type = line, line_string
lvname = XS Existing Bit Pavement  

 

1.  Force the excavation of unsuitable material.

Example: With Excavation Limits

Existing Unsuitable Material
soil type = Bituminous_Pavement
roadway exc mult factor = 1.0
subsoil exc mult factor = 1.0
fill mult factor = 1.0
type = line, line_string
lvname = XS Existing Bit Pavement  

 



Processing 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 6-30 

Even though excavation limits are used to force the 
extraction of unsuitable material, there are times when 
suitable material will have to be extracted in order to 
get to the unsuitable material such as in the example 
below.

Topsoil (Existing Suitable)

Clay (Existing Unsuitable)

 
 

2.  As their names suggests, they are used to 
determine the actual “limits” of the excavation of 
unsuitable material.

The unsuitable material will only be 
excavated within the confines of the 
defined Excavation Limits.
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3. Delineate specific earthwork processing areas on a 
cross section. This can be done in two ways:

Through the use of multiple excavation limits

Through the use of the option 

calculate only between excavation limits 

 
 

Through the use of multiple excavation limits

Topsoil (Existing Suitable)

Clay (Existing Unsuitable)
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Through the use of the option 

calculate only between excavation limits 

 
 

Example: Without the option enabled

Without the option enabled, notice that you get 
quantities for BOTH roadways.

But no existing suitable or unsuitable 
materials are excavated beyond the excavation 
limits.
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Example: With the option enabled

With the option enabled, note that you ONLY get 
quantities within the confines of the excavation 
limits.

This is an excellent tool for doing staged 
construction or projects where separate 
quantities are required for different roadways.

 
 

Existing Ground Line

Proposed Finish Grade

Existing Suitable

Existing Unsuitable

Excavation Limits
Proposed Undercut

Material Classes
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Proposed Undercut

Proposed undercuts are used to define any 
proposed component which is not part of the proposed 
finished grade. 

The soil type is not the material being removed, but 
what the area will be backfilled with. 

All proposed undercuts must tie to another 
proposed undercut or proposed finish grade, not to 
existing ground. 

 
 

Existing Ground Line

Proposed Finish Grade

Note: Any proposed element can be 
considered part of the Proposed Finish Grade 
if you want it to (as shown in this example).
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However, if you want quantities from those areas, 
you would classify them as Proposed Undercuts 
and give them their own symbology.

Topsoil

Pavement

Aggregate Base

Subbase

Remember! For Proposed Undercuts, the soil type is 
not the material being removed, but what the area will 
be backfilled with.

 
 

Topsoil

Pavement

Aggregate Base

Subbase

Proposed Undercuts elements must connect 
to either a Proposed Finish Grade element 
or another Proposed Undercut element.

Suitable Grading
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Proposed Undercuts have 3 uses:

1. To excavate existing material and 
replace/backfill with another.

2. To calculate a quantity for a material layer 
(e.g. pavement layer).

3. To re-use material.

 
 

1. To excavate existing material and 
replace/backfill with another.

Exist_Base

Suitable_Grading

Rock_Base
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Topsoil

Pavement

Aggregate Base

Subbase

2.  To calculate a quantity for a material layer 
(e.g. pavement layer).

 
 

3.  To re-use material.

Existing Suitable/Unsuitable
The classification of Existing Suitable/Unsuitable does not
affect whether material is reused. That is controlled by soil 
type nomenclature. 

Note: We’ll discuss this in more detail after we cover the 
Proposed Undercut classification.

* From previous slide
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3.  To re-use material.

Existing Unsuitable
soil type = Topsoil
roadway exc mult factor = 1.0
subsoil exc mult factor = 1.0
fill mult factor = 1.0
type = line
lvname = XS Existing Topsoil

Proposed Undercut
soil type = Topsoil
roadway exc mult factor = 1.0
subsoil exc mult factor = 1.0
fill mult factor = 1.0
type = line
lvname = XS Prop Topsoil

 
 

Excavation Types

Common Excavation 
Excavation volumes that are not backfilled with an 
earthwork material. This includes the excavation required 
for cut sections as well as for pavement thickness, shoulder 
thickness, etc.

Subgrade Excavation
Excavation volumes that are backfilled with an earthwork 
material.

Subsoil Excavation
Excavation required to remove unsuitable material either 1) 
down to the bottom of the proposed template or 2) down to 
the bottom of the unsuitable material layer in cases where 
excavation limits are defined. 
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Common Excavation 
Excavation volumes that are not backfilled with an 
earthwork material. This includes the excavation required 
for cut sections as well as for pavement thickness, shoulder 
thickness, etc.

 
 

Subgrade Excavation 
Excavation volumes that are backfilled with an earthwork 
material.

Proposed Undercut
soil type = Suitable_Grading
roadway exc mult factor = 1.0
subsoil exc mult factor = 1.0
fill mult factor = 1.0
type = line, line_string
lvname = XS Proposed Undercut
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Subgrade Excavation 
Excavation volumes that are backfilled with an earthwork 
material.

 
 

Subsoil Excavation 
Excavation required to remove unsuitable material either 1) 
down to the bottom of the proposed template or 2) down to 
the bottom of the unsuitable material layer in cases where 
excavation limits are defined. 

Excavation Limits
lvname = XS Excavation Limits
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Subsoil Excavation 
Excavation required to remove unsuitable material either 1) 
down to the bottom of the proposed template or 2) down to 
the bottom of the unsuitable material layer in cases where 
excavation limits are defined. 

 
 

Excavation Types

If you don’t care about breaking your excavation 
quantities out separately, you can combine them.

combine common exc + subgrade exc + subsoil exc
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LAB EXERCISE: EARTHWORK 

> STAGED CONSTRUCTION AND MULTIPLE ROADWAYS 

1. Open the file C:\DATA\GEO\VDOT\ROAD2\60843\d60843xsmainline.dgn. 
2. Access the project 60843 through Project Manager using the user name Mary. 
3. Click the Earthwork button and create a new run Mainline. 
4. The XS DGN File portion of the dialog should fill automatically from the Working Alignment 

information. 

 
5. Select the Soil Types option and set Existing Ground and Proposed Finished Grade. These 

should match the Working Alignment definitions set in Project Manager. 
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6. In this step we will place Excavation Limits just on the right side of the typical. Set the level to 
Default and place the Excavation Limit lines on several sections as shown below. 

 
7. Change the Classification toggle to Excavation Limits and set the symbology then Add to the 

list window. 

 
8. Select the Earthwork Shape option and set as shown below. 

 
9. Set the Output Format as shown below. 



Processing 
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10. Select File > Save Settings then File > Run and make the settings shown below. 

 
11. Click Apply. 
12. Review the sections and the output. 

 
 



Digital Terrain Modeling 
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7 
CHAPTER OBJECTIVES  

In this chapter we will review the process of creating proposed Digital Terrain Models from proposed 
cross sections.   

INTRODUCTION 
The GEOPAK Cross Section Report Utility can extract up to sixteen different reports from original 
and design cross-sections.  For each report generated, the user must set the parameters of the existing 
and/or design cross sections.   

 

CREATING DTM REPORT 
For each station, GEOPAK locates every specified cross section element and generates an x, y, z file of 
spot elevations suitable for use with the DTM tools. The created file is a DAT file which can be 
directly utilized in the Build Triangles dialog. Additional fields not required for the Build Triangles 
application are ignored. Note that no decision tree is provided to differentiate between existing ground 
and proposed finish grade elements. If this is required, utilize the DTM Prop 3D report. 

 

 



Report Output 
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REPORT OUTPUT 
The first column (1) is utilized by the DTM software to identify the rest of the line as a spot elevation. 
The next three columns are x, y, and z respectively. Note that no header is added to the file as it is not 
required by the DTM software. 

1 522741.21734264 1832287.79561256 7417.00300000  

1 522747.84993873 1832281.28536007 7417.25310000  

DTM PROP 3D 
GEOPAK locates specified proposed cross section elements and existing ground, and generates an x, 
y, z file of vertices for break lines suitable for use with GEOPAK's Digital Terrain Modeling. Each 
cross section generates one break line. In the hierarchy, the path follows (from left to right) existing 
ground until a proposed finish grade element is intersected. The proposed path is followed until it ties 
back to an existing ground element. 

 

REPORT OUTPUT 
The first column (2 or 3) is utilized by the DTM software to identify the line as the beginning or 
subsequent vertex of a break line. The next three columns are x, y, and z respectively. The rest of the 
line is comment information and not utilized by GEOPAK. Note that no header is added to the file as it 
is not required by the DTM software. 

3 498007.60673158 223314.62880123 882.96601000 1 1 118+00.0 r 1  

3 498015.72589151 223316.31181223 884.00901000 1 1  

3 498017.58141269 223317.52559625 884.95300000 1 1  

3 498017.78633116 223319.43367284 885.93900000 1 1  

3 498077.29111542 223329.07359423 885.93900000 1 1  

3 498098.50954625 223333.47193751 884.95300000 1 2  

3 498102.80506063 223334.36234957 889.27347000 2 2  

3 498113.04417381 223336.48480316 890.47812000 2 2  

3 498117.85853969 223338.93378900 892.08431000 2 2  

3 498155.18206826 223345.21952737 891.28121000 -1 1 118+50.0 r 1 
2 498172.50980731 223348.81138133 888.87192000 2 2  
3 498188.65610203 223352.15833458 874.01462000 2 2  
3 498200.07665864 223354.52569315 874.01462000 2 2  



DTM Editing 
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DTM EDITING 
GEOPAK provides an editing tool that allows the user to change, modify or manipulate any feature 
contained in the model. The tool facilitates placing or inserting break lines, modifying contours and 
triangles as well as changing elevation of existing triangles. 

 
 

Edits made with this tool will not be saved until the Save button is selected. This allows the user to 
abandon an editing session without having an impact on the tin file. 

There is also an Undo option so that modifications may be undone up to the last time there was a Save 
operation performed. 



DTM Editing 
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ADD VERTEX 
The Add Vertex tool is utilized to add additional spot elevations either internal or external to an 
existing model. 

The user has the option of keying in the desired values in the X, Y, and Z fields or interactive editing 
by clicking DP. Moving the cursor over the screen displays the cursor coordinates in the dialog. The X 
and Y values are the true coordinates of the cursor, while the Z value is the elevation of the specified 
TIN at the cursor's X, Y value. GEOPAK will also display the triangles on the fly, i.e. as the cursor is 
moved, the generated triangles are adjusted. 

 
 

DELETE VERTEX 
Another option is Delete Vertex. Two options are supported for editing: Re-Triangulate or Create 
Void. 

The Re-Triangulate option deletes the specified point, then re-triangulates the model without it. When 
ID Vertex is clicked and the specified point is identified on the screen with a data point, the affected 
vertex, triangle sides, and all associated display elements (i.e., contours, flow arrows, etc.) are 
highlighted. 

 
 



DTM Editing 
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MOVE VERTEX XY 
This tool provides a means to change the horizontal location of an existing vertex. 

Click ID Vertex and the point to be moved is identified by a data point on the screen. The affected 
vertex, triangle sides, and display elements are highlighted, while the X, Y, and Z values of the vertex 
are displayed in the dialog. 

 
 

MOVE VERTEX Z 
This option allows the user to change the elevation of an existing vertex. Click ID Vertex and the 
vertex whose elevation is to be moved is identified by a data point on the screen. The affected vertex, 
triangle sides, and display elements are highlighted. 

 
 



DTM Editing 
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POLYGON MOVE Z 
This tool will allow the user to move a specified polygon by changing the elevation on each vertex. 
Two options are supported to specify the value of the change in elevation: Drape or Elevation. In 
Drape, either positive or negative values (in master units) dictate the amount GEOPAK moves the 
polygon above or below the model. In the other option, Elevation, GEOPAK moves the appropriate 
vertices and optionally, the polygon, to the specified elevation. The toggle next to the desired option 
must be activated. 

If the polygon has been placed prior to selecting the Polygon Move Z option, then the Select option 
should be utilized. If the Place button is pressed, the software prompts for drawing the polygon as part 
of the Move procedure. To commence the procedure, press the Apply button. 

 
 

DELETE LINE 
This option will allow the user to delete a line external to the main body of the tin file. 

 
 

 

SWAP LINE 
The Swap Line option will change the direction in which a triangle has been computed. 
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 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 7-7 

 

INSERT BREAK LINE 
In contrast to the Insert Drape Line, the Insert Break Line utilizes the x, y, and z coordinates from 
the break line element, so it must be placed at the desired X, Y, and Z location. 

Two methods of insertion are supported: Place and Select. Select is utilized if the break line has been 
previously drawn, while Place is used if no prior break line elements have been drawn. 

 

 
 

INSERT DRAPE LINE 
The Insert Drape Line option utilizes the X, Y coordinates of an element placed in the MicroStation 
file however the Z value is determined from the TIN model. 



DTM Editing 
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If the drape element has been previously drawn into the MicroStation file, then the Select option 
should be utilized. When Select is clicked, GEOPAK prompts the user to identify and accept the 
previously drawn element. When Place is clicked, the user is prompted to draw the desired drape line. 
Note that the Z value of the drape line being drawn is inconsequential, as the Z values are determined 
from the specified TIN model. 

After the drape line has been identified, click Insert to commence the process. The drape element is 
drawn for reference onto the original TIN model. 

 

DELETE TRIANGLE 
If an external triangle is selected, it is deleted from the model and the TIN hull is updated accordingly. 
If an internal triangle is selected, a void will be created in the model. The void will be reflected in 
subsequent processing of either the Load Voids tool or Triangle Statistics tool. 

 
 

DELETE LINE TRIANGLE 
The Delete Triangle Line tool uses a user-placed line and deletes all triangles which intersect the line. 
If external triangles are selected, they are deleted from the model and the TIN hull is updated 
accordingly. If internal triangles are selected, a void will be created in the model. The void will be 
reflected in subsequent processing of either the Load Voids tool or Triangle Statistics tool. 



Lab Exercise: Cross Section Reports 
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LAB EXERCISE: CROSS SECTION REPORTS 
> DTM PROPOSED 3D 

1. Open the MicroStation dgn file C:\DATA\GEO\VDOT\ROAD2\60843\d60843xsmainline.dgn. 
2. Access the project 60843 via Project Manager using Mary as the user name. 
3. From Project Manager click the Reports & XS Quantities button. 
4. Click the DTM Proposed 3D button. 

 
5. Provide a file name to be created from the process. 
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6. The symbology for Existing Ground and Proposed Finish Grade should populate according to 

the Working Alignment Definition. 
7. Change the ending station to 49+00. 
8. Click Apply. 
 



Lab Exercise: Cross Section Reports 
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> BUILDING THE TIN FILE 

1. Create a new dgn file named 3D.DGN. 
2. Make sure to use a 3D seed file or create a 3D model in the new dgn. 
3. Click the Existing Ground button on Project Manager and create a new run. 
4. Select the DAT file created in the previous exercise. 
5. Provide a TIN file name. 
6. Set Dissolve Option to Side and enter a value of 50. 

 
7. Click Process. 
8. Close the Build Triangles dialog. 
 

> LOAD DTM FEATURES 

1. Access the Load DTM Features dialog. 
2. Use the Browse button to locate the file 3D.TIN. 

 
3. Turn all features off except for Triangles. 
4. Click Load. 
5. Review the Proposed DTM. 



Lab Exercise: TIN Editing 
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LAB EXERCISE: TIN EDITING 
> EDITING TRIANGLES 

1. Click the icon to access the TIN Edit Tools. 
2. Enter the settings in the Display Settings dialog as shown below. 

 
3. Click OK. 
4. Zoom in anywhere on the DTM. 
5. Select the option to Add Vertex. 

 
6. Click the DP button and move your cursor onto the screen. 
7. Data point on the screen to set the coordinates in the dialog. 
8. Key-in the desired elevation. 
9. Click the Add button. 



Lab Exercise: TIN Editing 
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> ADDING BREAK LINES 

1. Select the option to Insert Break Line. 

 
2. Click the Place button. 
3. In the following dialog make the settings as shown. 

 
4. Click the Start button and Data Point on the screen. 
5. Place the second data point some distance from the first. 
6. Click the right mouse button to end the operation. 
7. Click the Insert button on the dialog. 
8. This will place a break line that begins 2’ lower than the original ground at the start point and tie 

to existing ground at the second point. 
 



Lab Exercise: TIN Editing 
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> DELETING TRIANGLES 

1. Select the option to Delete Triangles. 

 
2. Click the Id Triangle button. 
3. Data point on a triangle in the MicroStation view. 
4. This tool effectively removes unwanted triangles from the TIN file. 

 



Labelers 
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8 
CHAPTER OBJECTIVES 

In this chapter we will: 

 Learn how to label plan information with Plan View Labeler 

 Familiarize the user with the other labelers  

INTRODUCTION   
GEOPAK’s labeling tools allow a user to place “smart” labels in a MicroStation drawing. These labels 
have the ability to calculate XYZ coordinates, station, offset, direction, length, radius, degree of 
curvature, etc. of the associated element. 

ACCESSING THE PLAN VIEW LABELER 
The Plan View Labeler can be accessed by selecting Applications > GEOPAK ROAD > Plans 
Preparation > Plan View Labeling. It can also be invoked from Project Manager by clicking the Plan 
View Design button or by selecting the Plan View Labeling tool from the GEOPAK ROAD tool 
frame. 

PLAN VIEW LABELING 
When the Plan View Labeling icon is selected, the dialog shown below is displayed. 

 



Text 
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The label to be placed is displayed in the box on the right side of the dialog as shown above. The 
Space button places a space in the label at the cursor position. The Return button starts a new line of 
text. The Clear button starts a new label. The Delimit button places a line above or below a line of 
text. The Place Label button attaches the label to the cursor for placement in the drawing. 

The user can select the various tabs to define / modify the label appearance. 

TEXT 
For data to be computed, the job number and the chain need to be selected. If elevations are to be 
calculated, a TIN file needs to be chosen. 

The Computed Inserts are items that GEOPAK has the ability to calculate for the chosen item. The list 
of Computed Inserts changes with the type of element that is chosen. If a line is chosen, the list of 
Computed Inserts will show inserts of bearing, and length. If a curve is chosen the list of Computed 
Inserts will change to show inserts of radius, curvature, chord length, etc. 

The User Inserts are items that a user may use on a regular basis. This list can be customized for a 
specific user’s needs. 

The Identify Element button allows the user to choose the element to use for calculations in the label. 
The Data Point button will let the user pick a specific point to calculate the coordinates, station, or 
offset for. 

PARAMETERS 

      
The Parameters tab enables the user set up the text size and symbology for the label. 

By Current sets the symbology to the current MicroStation settings. By Element allows the user to set 
the symbology by choosing a MicroStation element. Set All sets the symbology for all elements in the 
label (text, delimiters, leader lines, etc.). 



Shape 
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SHAPE 

 
The Shape tab allows the user to place a shape around the label, and set the symbology for the shape. 

LEADER 

 
The Leader tab allows the user to attach a leader from the label to the point. Different leader types and 
terminators can be chosen. The active terminator can also be used. 



Rotate 
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ROTATE 

 
The Rotate tab allows the label to be rotated. The rotation can be determined from the current angle, 
the angle of the element, or the alignment angle. The angle can also be set by two data points (first data 
point set the location, next data point sets the angle) or the active angle. 

STYLES 

 
The Styles tab allows a user to choose label symbology from a library of pre-defined styles. When the 
user chooses the style, all symbology, leaders, shapes, etc. are set up for the user. 

MENUS 
The Style Files menu allows the user to open a new style library. You must be under the Styles tab in 
order to open a style library. 

Options > Minimize Dialog minimizes the main dialog (when the Place Label button on the main 
dialog is pressed) to allow for easier label placement. The Label Viewer can be used in conjunction to 
still view the sample contained in the Label dialog. 

The main labeling window can be maximized by selecting the Restore Label Dialog icon within the 
appropriate View Label Control tool frame or the labeling tool on the main Road, Site, or Drainage 
tool frame. 

Options > Use Reference File Coordinates - When labeling elements within a reference file, it is 
useful to utilize the reference file coordinates, rather than the current active file. Simply activate the 
toggle, and subsequent computed text inserts using reference file elements or data points will reflect 
the reference file coordinates, if the snap and locate in the reference file are active. 

Options > Use DP Element Association - This option will enable the association between MS 
elements and DP (data point) labels that are snapped to the element. If the element is modified, the 



Menus 
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point labels will move with the element when the Label Update feature is used. This applies only to 
elements within the active design file. 

Options > Label Tools invokes the tool frame shown below which enables the user to modify 
GEOPAK labels. 

 
Options > Label Viewer brings up a dialog that allows a user to view and place a label. 

 
The Scale > Scale Style menu allows the user to choose a plan scale. All labels will be adjusted 
according to the plan scale. The user simply keys in a scale, and chooses a Labeling Style. The 
corresponding label will be placed at the correct size for the scale that was chosen. 

Tools > Label Updater - The Label Update tool is a powerful tool for updating GEOPAK labels. 
When alignments are updated, TIN files modified, labels moved, etc., GEOPAK "remembers" the 
computed text information utilized in the placement of the original label. Therefore, the software can 
update the label based on updated data. The tool utilizes the dialog shown below. 

 



Menus 
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Tools > Selection Set Labeling - The Selection Set Label tool is a powerful tool for placing or 
updating labels within a selection set. 

When the Selection Set Labeling tool is activated from the pulldown menu, the dialog shown below 
opens. 

 
Tools > Plan Label Preferences – Allows for the customization of the plan view labels. Options 
include Bearing, Distance, Elevation, and Area. 

When the Plan Label Preferences tool is activated from the pulldown menu, the dialog shown below 
opens. 

 



Cross Section Labeling 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 8-7 

CROSS SECTION LABELING 
The Cross Section Labeling dialog differs from the Plan View Labeling dialog only on the text tab. Cross Section 
Labeling works with the Cross Section Navigator. The current Cross Section Navigator station is shown on the Text 
tab.  The Computed and User Inserts contain values and phrases related to cross-sections. 

 

ACCESSING THE CROSS SECTION VIEW LABELER 
The Cross Section View Labeler can be accessed by selecting Applications > GEOPAK ROAD > 
Cross Sections > Cross Section Labeling. It can also be invoked by selecting the Cross Section 
Labeling icon from the GEOPAK ROAD tool frame. 

PROFILE LABELING 
The Profile Labeling dialog differs from the Plan View Labeling dialog only on the text tab. The 
Chain and Profile must be defined, in addition to profile settings. The Computed and User Inserts 
contain values and phrases related to profiles. 

The user must supply the Reference Station, Elevation, Scales, and Profile Reference Point which 
were used to draw the profile. If a profile cell has been previously placed, Identify Cell can be clicked 
and the cell identified. This automatically populates the fields in the Profile Settings. In addition, 
whether the profile was drawn with gaps or no gaps in the presence of station equations must also be 
set. 

 

 



Accessing The Profile View Labeler 
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ACCESSING THE PROFILE VIEW LABELER 
The Profile View Labeler can be accessed by selecting Applications > GEOPAK ROAD > Plans 
Preparation > Profile Labeling. It can also be invoked by selecting the Profile Labeling icon from 
the GEOPAK ROAD tool frame. 

Note If after placing any label with any of the labeling tools a label should need to be modified, it is 
important that the Label Tools be used to modify the label. Each label is in fact a cell with 
intelligence and the Label Tools accessed from any of the labelers will maintain the 
intelligence associated with each label. 

 

 



Lab Exercise:   Labeling 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 8-9 

LAB EXERCISE:   LABELING 
> ACCESSING THE PLAN LABELER 

1. Open the MicroStation file C:\DATA\GEO\VDOT\ROAD2\60843\d60843work.dgn. 

2. Access the project 60843 via Project Manager. 

3. Click the Plan View Design button on the main Project Manager dialog. 

4. From the Plan View Design tool bar, click DP Station Offset. 

5. Zoom in around Sta. 10+00.00, near the beginning station of the Curb & Gutter section, and 
complete the dialog as shown below. 

 
6. Next, select the MicroStation Zoom In tool and click the DP button on the above dialog. 

Continue to data point as the view is zoomed in onto this area of interest. 

7. Close the DP Station Offset dialog. 

8. From the Plan View Design tool bar, click the Plan View Labeler tool. 

 



Lab Exercise:   Labeling 
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> USING PREDEFINED LABEL STYLES 

1. Select the Styles tab. 

2. Traverse with the Item Selector box to locate the following style: 
Labels > Point Labels > StaOff. 

3. Next, double click the StaOff style. 

 
4. Move back to the Text tab and complete as defined below: 

Job No. 101 

Chain MAINLINE 

TIN File s60843.tin 

Note In the following steps, we will use the Plan View Labeler to label the beginning station and 
offset for the sidewalk and curb section as well as the ending station and offset for the paved 
shoulder sections. 

5. To begin the process, select the DP button and then identify the location that you wish for the 
Station and offset to be computed. The labeler automatically calculates the information. 

 
6. Use the Params., Shape, Leader and Rotation tabs to experiment with different labeling 

styles. 

7. To place the label, return to the Text tab and click the Place Label button. 

8. The label is now attached to your cursor (without the leader for the delimiter). 

9. Data point at the location you wish the text to be located. 



Lab Exercise:   Labeling 
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10. A second data point will define the side of the label, which the leader line will be drawn from 
the delimiter line to the computed location. 

 



Lab Exercise:   Labeling 
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> CREATING AND SAVING A NEW LABEL STYLE 

1. Select the Text tab then click Clear below the label composition window. 

2. Start Coordinate Geometry and set visualization to Permanent Visualization. 

3. Select Tools > Navigator. In the Navigator window, set the Element to Parcel. 

 
4. Select Tools > Settings and toggle ON the option to Window Center Visualized Elements. 

 
5. Highlight the Parcel 4200. 

6. Click on the Paintbrush to visualize it then close COGO. 

7. On the Plan View Labeler dialog, click the Select GEOPAK or MS Element icon, then 
identify any of the lines representing the parcel and accept. The computed text inserts should 
now contain items such as Name, Area, and Perimeter. 



Lab Exercise:   Labeling 
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8. In the composition window key-in NAME. 

 

 
 

9. Double click on the item in the Computed Text window shown as Name. 

 
10. Enter a carriage return in the composition window. 

11. Key-in Area=. 



Lab Exercise:   Labeling 
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12. Double click on the item in the Computed Text window shown as Area. 

13. Key-in SF after the area. 

 
14. Select the Params. Tab and set the Height, Width, and Line Sp. to 5.0 and the Justification 

to Center-Center. 

 
15. Select the Shape tab, set the Shape Preferences to No Shape. 

 



Lab Exercise:   Labeling 
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16. Select the Leader tab and set the Leader Type to NO Leader and the set the Terminator to 
No Terminator. 

 
17. Click Rotate tab. Set the angle to zero. 

 
18. Click the Place Label button and place the label in the parcel. 

19. Select the Styles tab. 

20. In the Item Selector window, double click Labels. 

21. Click New Category. 

22. Create a category named Parcels. 

 
23. Highlight the Parcels category and click New Style. 



Lab Exercise:   Labeling 
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24. Create a Style named Area. 

 
25. Exit MicroStation. 

 

> PROFILE LABELER 

1. Open the MicroStation file C:\DATA\GEO\VDOT\ROAD2\60843\d60843prof.dgn. 
2. Attach the saved view PRO1. 
3. Access the Profile Labeler – (Applications > GEOPAK Road > Plans Preparation > Profile 

Labeling. 

 
4. Click the Profile Settings button on the main dialog. 



Lab Exercise:   Labeling 
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5. Click the Identify Cell button and data point on the profile cell. 

 
6. Click OK. 
7. Set the Chain and Profile on the main dialog as shown below. 

 
8. Click the Styles tab and double click on the Sta/Elev label style in the Point category. 

 
9. Return to the Text tab and click the Point icon. 
10. Snap to a point on the profile. 



Lab Exercise:   Labeling 
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11. Click the Place Label button on the main dialog and place the label in the DGN file. 

 
12. You should now have a Station and Elevation label as shown below. 

 
13. Exit MicroStation. 
 

Note If after placing any label with any of the labeling tools, a label should need to be modified, it is 
important to use Label Tools to modify the label. Each label is a cell with intelligence and the 
Label Tools accessed from any of the labelers will maintain the intelligence associated with 
each label. 

 

 
 



Active Chain Control 
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9 
CHAPTER OBJECTIVES  

In this chapter, you will be familiarized with the Active Chain Control tool so that it can be used to 
review projects in multiple views with ease.  

INTRODUCTION 
The GEOPAK Active Chain Control is an excellent tool, enabling the user to manage plan, profile, 
and cross section views simultaneously. It also allows usage of MicroStation tools to place elements in 
any view in accordance with the curvilinear coordinates settings. One advantage of this tool is that you 
can use stations beyond the limits of the chain with any MicroStation command. 

ACCESSING ACTIVE CHAIN CONTROL 
The tool can be opened by selecting Applications > GEOPAK Road > Active Chain Control. When 
invoked the dialog shown below opens. 

 
First select the desired Job and Chain name from the combo boxes to use as the active chain. Four 
icons are supported to the right of the chain list field and are detailed in the following table. 

 



Accessing Active Chain Control 
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Graphically select the active chain candidate. 

 
Opens the “Precise Curvilinear Coordinates” 
dialog that allows entering 
stations/offsets/elevations relative to the active 
chain. 

 
 

 

 

 
 

Activates the current Profile system, which is 
associated to a Profile Cell. The Profile Cell can 
stay in the master file or in any of the reference 
files. If there are several Profile cells relative to 
the active chain, it is possible to designate the 
active one in the Profile Cell Control dialog. 
When the right mouse button is pressed, a pop-
up menu appears : 

The first option of the pop-up menu allows 
placing a Profile cell. The second option allows 
getting information about Profile cells that stays 
in master and reference files and selects the 
active one if there are several profile cells.  

 
Activates the current Cross Section system. If 
there are several reference files containing XS 
cells relative to the active chain, it is not possible 
to activate the Cross Section Representation 
System. In this case, an alert dialog is displayed 

 

The right side of the toolbox has eight icons which set each view to plan, profile or cross section view. 
By right clicking an icon, any view can be set to any of the 3 possible views. For example, if there is 
an active profile cell, setting a view to profile will immediately fit the profile within the limits of the 
view. 

 
 



Curvilinear Coordinates 
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CURVILINEAR COORDINATES 
The Curvilinear Coordinates tool enables the user to enter precise curvilinear coordinates relative to 
the active chain. It can be utilized in conjunction with generic MicroStation commands such as place 
line and place cell. 

 
 

 

S:  Station along actual active chain. If the lock toggle is on, the cursor 
follows a perpendicular to the chain in plan views, and a vertical line in 
Profile views.  

Ext.:  Extension to the station along actual active chain. A negative value 
means that the extension is before the beginning of the chain. A positive 
value means that the extension is after the end of the chain.  

O:  Offset from the actual active chain. If the lock toggle is on, the cursor 
follows a fixed offset to the chain in plan views.  

Z:  Use this field to enter elevation. If the lock toggle is on, the cursor 
follows a horizontal line in Profile views.  

DS:  Delta station from the previous data point or tentative point. If the lock 
toggle is on, the cursor will follow a perpendicular to the chain in plan 
views, and a vertical line in Profile views.  

DO:  Delta offset from the previous data point or tentative point. If the lock 
toggle is on, the cursor follows a fixed offset to the chain in plan views.  

DZ:  Use this field to enter delta elevation from the previous data point or 
tentative point. If the lock toggle is on, the cursor will follow a 
horizontal line in Profile views.  

Permanent Lock  When this toggle is checked, coordinate locks remain active, even after 
a data point is issued.  

Apply  Click to send a data point to the input queue. Entering a data point by a 
click in a view has the same effect.  
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LAB EXERCISE: ACTIVE CHAIN CONTROL 
> SETTING UP CHAIN CONTROL 

1. Open the MicroStation file C:\DATA\GEO\VDOT\ROAD2\60843\d60843work.dgn. 
2. Reference the files d60843prof.dgn and d60843xsmainline.dgn to coincidently. 
3. Access the Active Chain Control (Applications > GEOPAK Road > Active Chain Control). 

 
4. Set the Job and Chain as shown above. 
5. Open Views 2 and 3 and stack them on the right side of View 1. 
6. Right click on each icon 1 thru 3 and set accordingly. 

1 Plan 

2 Profile 

3 Cross Section 

7. You should have your views setup looking similar to the image below. 

 
8. Zoom into the beginning of the project in Plan view. 
9. Click the Curvilinear Coordinates icon. 
10. Select the MicroStation Place Line command. 
11. Key in a station of 10+25 and an offset of -100. (Lock the values). 



Lab Exercise: Active Chain Control 
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12. Click Apply. 
13. After moving the cursor back to the view, you will notice that the line began at the desired 

location. 
14. In the Curvilinear Coordinates dialog, key in delta station values of 500 and delta offset value of 0. 

 
15. Click Apply. 
16. This will place the second endpoint of the line at station 15+25 offset -100. 
 

> USING ACTIVE CHAIN CONTROL WITH PROFILES 

1. Click on the icon for View 2 on the main tool bar. 
2. Move you cursor in View 2. (Notice the cross hair following along in View 1). 
3. This can be used the same as in the previous exercise to place elements at certain elevations along 

the profile. 
4. Key-in the Station and Elevation values in the Curvilinear Coordinate dialog as shown below. 

 
5. Select the MicroStation command Place Circle. 
6. Set the Method to Diameter. 

 
7. Click the Apply button on the Curvilinear Coordinates dialog. 
8. Move you cursor to the profile view to place the second point on the circle. 



Lab Exercise: Active Chain Control 
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> USING ACTIVE CHAIN CONTROL WITH CROSS SECTIONS 

1. Click on the icon for View 3 on the main tool bar. 
2. Right click on the same icon and select Cross Section Navigate. 

 
3. You can use the Navigator to traverse through the cross sections. 
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10 
CHAPTER OBJECTIVES 

In this chapter we will: 

 Overview the original data supplied for this project   

 Formulate a design strategy  

INTRODUCTION 
Designers will realize that every “at grade” intersection has its own specific design issues. 

What may look the same from plan view may be a totally different design vertically due to the existing 
vertical conditions or specific requirements. 

The amount of reconstruction of existing roadway can completely change the designers approach to 
two seemingly similar geometrical layouts. 

We shall investigate the design constraints of this particular project and formulate an initial design 
strategy. This strategy may need to be varied or modified further along the design path based on 
outcomes at each step, but we need some strategy to begin with to make a start. 

We will overview the supplied data and constraints for this specific situation. 



Project Overview 
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PROJECT OVERVIEW 
This training session evolved from a project sent to Bentley by a client who was seeking assistance. 
The steps we will undertake in this training session mirror those formulated during the process of 
assisting the client. 

We will look at the information that was supplied when this project started. 

The client had completed a survey of the existing conditions, created a TIN file, completed the 
geometric layout of the new intersection, and designed a controlling Chain and Profile. 

The Chain (VAN1) and Profile (PROPVAN1), together forming the control alignment, were approved 
by the project engineer and could not be modified. 

Other constraints included the strict requirement to tie down to original within the existing Right Of 
Way and a maximum length of reconstruction on the services roads of 150 feet. 

> OVERVIEW THE SUPPLIED DATA AND DESIGN CONSTRAINTS 

1. Open the file C:\data\geo\site\roundabout\Step2\LHSRAB.dgn.  

This file will initially display the reference file that contains the survey information from the existing 
intersection arrangement. 
2. We shall discuss in the class the existing arrangement on the intersection.  

Note that the controlling alignment is based on an existing overpass bridge. 
3. Continuing with the file LHSRAB.dgn, select the File>Reference tool. 
4. Toggle OFF the reference file existing.dgn and toggle ON the reference file proposed.dgn. 

We shall discuss the proposed layout and, based on this layout, what are the requirements to begin a 
Site Modeler project. 
5. Toggle OFF the reference file proposed.dgn. 
6. Select Settings > Level > Display and turn on all levels in the active DGN. 

This shows all of the plan view graphical elements required to begin this project.  We shall discuss the 
graphical elements that are displayed and their significance. 

 
7. Open Design and Computation Manager (Applications > GEOPAK Site > Design and 

Computations Manager). 

In PowerCivil the menu item is Civil > Plans Production > Design and Computation Manager. 
8. Open the file C:\Data\Geo\Site\Standards\site.ddb. 
9. Using the ID function of D&C Manager, review the features attached to the various lines 

drawn in the DGN file. 



Project Overview 
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10. Close the Design and Computations Manager dialog. 



Design Strategy 
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DESIGN STRATEGY 
We need to formulate a design strategy based on the constraints of the project, the given information 
and the desired project outcome. 

This strategy could change during the course of this project due to design issues or constraints that are 
either unknown or unforeseen at this time. 

Modification of a design strategy is typical of intricate design projects. Site Modeler tools provide the 
flexibility required to incorporate changes as they arise. 

> FORMULATE A DESIGN STRATEGY 

There are a number of different design philosophies for designing roundabouts. We will not be examining 
all of the different theories in this class. The philosophy that we will use is one that treats the traffic circle 
portion of the intersections as an “upside down plate”. This means that irrespective of the orientation of 
the traffic circle, the outside edge always forms a plane surface. 

STEP 1 
Constraints 

The control alignment is set. It cannot be changed. 
Maximum allowable reconstruction of the services roads is 150 feet. 
Right Of Way cannot be altered. 

This means we stay as close as possible to the existing intersection elements and elevations. 
1. Given the constraints, we need to design the intersection based around the control alignment 

and create the traffic circle portion of the intersection so it is as close to the existing 
intersection elevations as possible. 

2. Creation of the traffic circle will be based on a plane that is defined relative to the Control 
Alignment. After the plane is created the outside edge of the Traffic Circle will be draped 
onto the construction plane and then the inside edge of the Traffic Circle will be created at a 
positive 2% slope from the outside edge. 

3. We shall then analyze the difference in elevation between the outside edge of the traffic circle 
and the existing surface at critical points and, if required, redesign the traffic circle until we 
have achieved a satisfactory stage of the design. 

4. The incoming roadway profiles (other than the control alignment) will be designed based on 
the traffic circle elevations. 

5. The incoming roadways will be modeled based on the design profiles. 
6. Curb returns will initially be defined based on the most appropriate adjacent element then 

modified as required. 
7. The median islands will be created based on the finished pavement surface. 
 
 



Design Strategy 
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STEP 2 
Objectives 

 Create a construction object based on the control alignment 

 Create and analyze the traffic circle 

 Modify and re-analyze the traffic circle 

Introduction 
Based on the design strategy that we have set, we need to devise a way to assign elevations to the 
outside edge of the traffic circle. 

As an additional consideration, we should formulate this step with the thought that it may need to be 
redesigned (probably will need to be redesigned) and that we should create this element with the 
redesign issue in mind. 

The use of construction objects with Site Modeler is a very powerful way to assign elevations to 
irregular or complex elements AND provide a way to make redesign a very fast and painless process. 

Tools to be used 
• Site Modeler > Object > New 

• Site Modeler > Elements > Composite Section 

• Site Modeler > Elements > New/Edit > Drape on Model/Object 

• Site Modeler > Elements > New/Edit > Section 

• Site Modeler > Elements > Information 

• Site Modeler > Analysis > Profile 



Lab Exercise: Create a Construction Object 
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LAB EXERCISE: CREATE A CONSTRUCTION OBJECT 
A construction object is defined as a site modeler object that is in the modeler project but not 
necessarily part of the model. Its primary use is to simplify the process of assigning, and then 
reassigning, elevations to irregular or complex site modeler elements. 

The methodology we will use to create the construction object is to create a new object and, within that 
object, define a surface plane based on the Control Alignment. 

>  OPEN AN EXISTING PROJECT 

1. Open the DGN file c:\data\geo\data\Site\RoandAbout\Step2\LHSRAB.dgn. 
2. Select the site modeler tool (Applications > GEOPAK Site > Site Modeler > Site 

Modeling). 

In PowerCivil select Civil > Modeler. 

 
3. Click Browse. Select the file C:\Data\Geo\Site\Roundabout\Step2\LHSRAB.gsf. 

This is a Site Modeler project that has already been created that includes the existing ground TIN file as 
the Object “Ground 1” and a Model called “RAB” that has the Ground 1 Object as its base. 
4. Click OK. 

 



Lab Exercise: Create a Construction Object 
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> CREATE A CONSTRUCTION OBJECT 

1. Select the new object tool (Modeler > Object > New).  

 
2. Select object type “Construction” and name “Temp1” as shown above. Also make sure to turn 

off the check mark for “Add to Active Model.” 

We are not including this object in the model because it is not part of our design. This object will be used 
simply to define a plane on which to drape our traffic circle. 
3. Click OK. 

> CREATE THE CONSTRUCTION SURFACE USING COMPOSITE SECTION 

1. Select the composite section tool (Modeler > Tools > Composite Section). 
2. File > Open. Select the Composite Sections setting file 

C:\Data\Geo\Site\Roundabout\Step2\TempObjectZeroPercentSlope.sec. 

 
3. Turn on the check mark to Add to Active Object and set the object to Temp1. 



Lab Exercise: Create a Construction Object 
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4. Set the Primary Element Definition to “Chain-Profile” and then press the Alignment 
Definition button and set as shown below. The feature “TempCL” is located in D&C 
Manager at Drafting Standards > General > TempCL. 

 
5. Click OK 

Ensure that the Active Object is “Temp 1”. Check the Active Object Control dialog. 
6. Click Apply.  

We have now created a surface that is 190 feet wide (95 feet both sides of the control alignment) and is 
projected at 0% from on the control alignment. While this surface has no slope in the north/south 
direction, it will still drain based on the longitudinal slope of the alignment it was created from. 

 



Lab Exercise: Create the Roundabout Object 
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LAB EXERCISE: CREATE THE ROUNDABOUT OBJECT 
Based on the design strategy that was discussed earlier, we will now start to create the elements that 
will make up our intersection (roundabout). 

We first need to create an object to place the roundabout elements into. 

Then we will drape the outside edge of the traffic circle onto the Construction Object. 

Last step is to create the inside edge of the traffic circle to give us the 2% pavement cross slope within 
the traffic circle. 

> CREATE THE ROUNDABOUT OBJECT. 

1. If you have not done so already, save your site project (Modeler > Project > Save). 
2. On the Active Site Object Control set the active model back to RAB. 

  
3. Now create a new object (Modeler > Object > New). 

 
4. Select they Object type “Roadway”. 
5. Overwrite the default Object Name with “RAB1”. 
6. Toggle ON Add to Active Model. 

This object is an actual part of our design so we add it to the model. 
7. Click OK. 



Lab Exercise: Create the Roundabout Object 
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> CREATE OUTSIDE EDGE OF TRAFFIC CIRCLE ELEMENT 

1. Select the new element tool (Modeler > Elements > New/Edit). 
2. Set dialog as shown below. 

 
3. Click Define Elements > Select Elements (indicated by arrow above). 
4. Select the outside edge of the traffic circle. 
5. Click Apply. 

 



Lab Exercise: Create the Roundabout Object 
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> CREATE THE INSIDE EDGE OF THE TRAFFIC CIRCLE 

1. We will use the section capabilities of the New/Edit element tools to compute the inside edge 
of pavement of the traffic circle. Select Modeler > Elements > New/Edit > Section. 

2. Populate the dialog as shown below. 

 
3. Key in the values in the key in fields. Offset distance = 30.0, Offset Elev = 0.6. This is 

equivalent to 2%. 
4. Click Select (indicated by lower arrow) and select the D&C Manager item “DesRAB1”. 
5. Click Add List Item (indicated by upper arrow). 

The Design and Computation Manager item “RAB” can be located at PayItem > Plan > Roadway > 
DesRAB1. 
6. Click Reference Elements > Select Reference Elements. 
7. Select the outside edge of the traffic circle. 
8. Click Set. Point the direction of the dynamic graphic inside the selected element as shown 

below. Data point to accept the direction. 

 
9. Click Apply. 

There should be a new element created and the contours of the RAB Object should indicate a 2% 
pavement cross slope. 



Lab Exercise: Create the Roundabout Object 
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Note:  This cross slope can be interrogated using the Analysis>Height tool. 

 



Lab Exercise: Analyze the Traffic Circle 
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LAB EXERCISE: ANALYZE THE TRAFFIC CIRCLE 
At this time, we need to determine if this first attempt at the traffic circle meets the design constraints 
which were set. Specifically, how closely do we match the existing elevations? We need to determine 
the difference in elevation between the proposed and the existing ground. 

The critical locations to check this difference in elevation are at the centerline of the incoming ramps 
and service roads. 

As the control alignment has previously been set as a constraint, there is no need to check the elevation 
differences for these roads. 

There is more than one tool that would be suitable for the analysis task that we have. The tool we will 
use is the Analysis > Profile tool. Another option would be the Elevation Differences tool. 

We will opt for the Profile tool in this case due to the very visual and specific feedback it provides. 

> USING THE ANALYSIS>PROFILE TOOL 

1. Use the Microstation view controls to set the focus of your view window to the North Ramp 
(as shown below). 

 

Location to create 
Analysis Profile. 

 



Lab Exercise: Analyze the Traffic Circle 
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2. Open the profile tool (Modeler > Analysis > Profile). The following dialog will activate. 

 
3. Populate the dialog as shown. 
4. Click the Profile tab. 
5. Click Place Element and draw a line in plan. 

Note: The line should pass from the traffic circle surface onto the North Ramp roadway at approximately 
the ramp centerline. 

The profile view of the Site Profile tool will now display the two surfaces. We can immediately see the 
difference in elevation between the surfaces. 

 
6. Click the Preferences tab. 
7. Toggle ON the Major and Minor Vertical Grid intervals. 



Lab Exercise: Analyze the Traffic Circle 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 10-15 

 
8. Click the Profile tab. The Profile will now be displayed showing the vertical grid intervals. 

 
 
9. Investigate the elevation difference in the same manner at the South Ramp and the North and 

South Service Roads. 



Lab Exercise: Modify the Traffic Circle 
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LAB EXERCISE: MODIFY THE TRAFFIC CIRCLE 
Our analysis determines that the current elevations of the traffic circle are not acceptable. We will 
modify these elevations and re-analyze the result. 

As the traffic circle elevations are based on the plane created in the construction Object, all we need to 
do is modify the construction Object and the traffic circle will automatically reflect these changes. 

This can be accomplished due to the Site Modeler “association” technology. Site Modeler tracks and 
remembers the way that elements are created. Using this tracking system provides the User with a 
powerful tool to automatically update linked pieces of data. 

If we remember back to what we have done, the construction object is a simple surface based on the 
control alignment chain and profile. The outside of the traffic circle is dependent on that construction 
surface and was created from it (Elements > New/Edit > Drape on Object). The inside of the traffic 
circle was created based on the outside element (Elements > New/Edit > Section). Therefore, if we 
modify the construction surface, all of the traffic circle elements will update to reflect the surface 
change. 

> MODIFY THE CONSTRUCTION OBJECT 

1. If you haven’t done so already then save the project (Modeler > Project > Save). 
2. Make sure level TempCL is turned on. It contains the elements for the Temp1 object which 

we need to modify. 
3. Start the element information tool (Modeler > Elements > Information). 

 
Note: This tool is also located on the Active Site Object toolbar. 

 
4. Choose the construction surface centerline element. 



Lab Exercise: Modify the Traffic Circle 
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5. Click the Association tab and set the options to Dependent Associations. 

 
6. Click composite section button. The composite section dialog will open with the settings used 

to create this element. 

Note:  We will edit the Left Side and Right Side element so they provide a 1% cross slope from left to 
right. 
7. Left Side. Select the parallel element. Change the slope to 1%. 
8. Click Modify List Item to modify the value. 
9. Right Side.  Select the parallel element. Change the slope to -1%.  
10. Click Modify List Item to modify the value. 
11. Click Apply. 

This will update all of the elements that are linked to the construction surface. 

Set RAB 1 as the active Object on the Active Site Object Control dialog to see the effect on the RAB 
object. 

 
Use the Analysis>Profile tool to repeat the analysis of the incoming roadways to visually see the 
difference that this has made. 

Note:  We will accept this design and move on to the next design stage. 

Composite 
Section 



Lab Exercise: Modify the Traffic Circle 
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STEP 3 
Objectives 

 Design the incoming profiles for the ramps and service roads. 

Introduction 
Now that we have decided that the first design step is acceptable, the next logical step is to design the 
incoming roadway profiles. 

This could have been completed earlier in the design process but would have been quite difficult and 
resulted in data that may have needed to be revised. 

Starting this process now gives us a distinct advantage in that we now know what the elevations of the 
traffic circle are and we can use this information to make intelligent design decisions. 

The process we shall use is as follows. 

• Create existing surface profiles based on the Model for each incoming roadway. 

• Design the proposed profile for each incoming roadway. 

Tools to be used 
• Site Modeler > Object > Draw Profile. 

• Applications > GEOPAK Site > Active Profile Control. 

• Applications > GEOPAK Site > Geometry > Layout Profile (Component Based). 



Lab Exercise: Create Model Surface Profiles 
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LAB EXERCISE: CREATE MODEL SURFACE PROFILES 
To ensure that all students have the same data, we will start this exercise in a new dataset. 

> OPEN THE SITE PROJECT 

1. Open the file C:\Data\Geo\Site\Roundabout\Step3\LHSRAB.dgn. 
2. Start modeler (Applications>GEOPAK Site>Site Modeler>Site Modeling). 

Note:  In PowerCivil use menu (Civil > Modeler). 

 
3. Click Browse. 
4. Select the file C:\Data\Geo\Site\Roundabout\Step3\LHSRAB.gsf. 
5. Click OK. 

 



Lab Exercise: Create Model Surface Profiles 
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> CREATE MODEL SURFACE PROFILES 

1. Open another Microstation window (view 2) and pan across to an empty portion of screen. 
We will use this window for working with profiles. 

2. Select the draw profiles tool (Modeler > Object > Draw Profiles). 

The Draw profile dialog should be familiar to most students as it is a standard GEOPAK tool. When used 
as a Site Modeler tool, it has additional functionality. It has the ability to not only create profiles from TIN 
files, but also from Site Objects and Models. 
3. Set Job Number to 99. 
4. Set Chain to RampNth. 

 
5. Click Profile Cell Control button (indicated by arrow above). 

 
6. Click Place Profile Cell button. (indicated by arrow). 



Lab Exercise: Create Model Surface Profiles 
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7. Populate the dialog as shown below. 

 
8. Place the Profile cell into a clear part of the graphics (in Window 2). 
9. Populate the Draw Profile dialog as shown below. 
10. Set the Details portion of the dialog. 
11. Click Add Surface Settings. 

 
12. The Details>Display Settings show that a Design and Computation Manager item is used. 

This item can be found within the D&C Manager as Drafting Standards>Profiles>ExProCL. 
13. The same process will now be repeated to create the Model profiles for the Chains RampSth, 

ServNth and ServSth. 
14. Exit and save the Site Modeler project. It is not required for the remainder of this step. 



Lab Exercise: Creating Design Profiles 
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LAB EXERCISE: CREATING DESIGN PROFILES 
Now that we have drawn the Model surface profiles, we are ready to create design profiles. 

We already have some constraints that affect this next step. 

The Model profiles show us the elevation at the proposed traffic circle edge – so the design profiles 
must start at that elevation. 

The cross slope of the traffic circles is 2%. For us to get a smooth transition for the incoming roadways 
to the traffic circle, we must start the design profiles using a 2% tangent from the location that we join 
to the traffic circle. 

The service roads cannot be reconstructed any more than 150 feet. We will draw this location into the 
plan and profile to give us a visual indication of this design constraint. 

> SHOW THE 150 FEET RECONSTRUCTION CONSTRAINT IN PLAN. 

1. Start the COGO tool (Applications>GEOPAK Site>Geometry>Coordinate Geometry). 

Note:  In PowerCivil, (Civil > Geometry > Coordinate Geometry). 

 
2. Select Job Number 99 and enter your initials for operator code. 
3. Click OK. 

 
4. Set visualization to Temporary. 

Navigator 



Lab Exercise: Creating Design Profiles 
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5. Click Navigator and minimize the COGO window. 

 
6. Set Element to Chain. 
7. Select and visualize the chains – RampSth, RampNth, ServSth and ServNth. 
8. Close Navigator. 
9. Select the place line tool. (Microstation > Place Line). Draw a line that is perpendicular to 

the chains ServSth and ServNth at the point where they intersect the traffic circle. 
10. Copy the lines parallel 150 feet. 

Note:  This gives us an approximate location for the 150 feet reconstruction constraint in plan view. 

 

Visualize 



Lab Exercise: Creating Design Profiles 
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> SHOW THE 150 FEET RECONSTRUCTION CONSTRAINT IN PROFILE 

1. Open the active chain control tool (Applications > Geopak Site > Geometry > Active 
Chain Control). 

Note:  PowerCivil, (Civil > Geometry > Active Chain Control). 
2. Set Window 2 to a Profile view in the Active Chain Control. This is accomplished by right 

clicking on the View 2 button in the dialog and setting the view to profile. 
 8 View Control Windows 

Curvilinear Coordinates 
 

3. Set View 1 to plan. 
4. Set Active Chain Control to the Chain ServNth and synchronize the views. 

Note:  Synchronize the views by clicking in the ACC Plan view window and Profile View window. 
5. Click Curvilinear Coordinates button. 

 
6. As you move in plan view the curvilinear coordinates will display station and offset. As you 

move in profile view the curvilinear coordinates will display station and elevation. 

Note:  You may need to click the reset button on your mouse once to start coordinate tracking. 
7. In Plan, tentative snap to the line that indicates the maximum extent of reconstruction. 
8. Lock the Station and Permanent Lock controls in the curvilinear coordinates dialog. 

Note:  The stations may be different as we did not accurately draw the reconstruction limit line. 

 
9. MicroStation > Place Line. 
10. Draw a line in the profile view. 

Note:  Due to the effect of the curvilinear coordinates tool, the line will be drawn at the correct station and 
can only be drawn vertically. 
11. Unlock the Station and Permanent Lock controls. 
12. Set Active Chain Control (ACC) to the Chain ServSth and synchronize the views. 
13. Repeat step 7 to step 11 for the ServSth chain. 

Note:  This gives us a visual cue of the 150 feet reconstruction constraint in profile view.  



Lab Exercise: Creating Design Profiles 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 10-25 

> CREATING DESIGN PROFILES USING THE VERTICAL COMPONENT TOOLS 

1. Set active chain control to the chain ServNth. 
2. Synchronize the views. 
3. Use MicroStation view controls to set the allowable reconstruction portion to fill the plan and 

profile designated views. 
4. Start the component profile tools (Applications > GEOPAK Site > Geometry > Layout 

Profile (Component Based)). 

PowerCivil, (Civil > Profiles > Layout Profiles (Component based)). 
 

Tangent Tools Curve Tools 

Store Alignment 
 

5. Tear off the tangent tools and the curve tools. 

    
Note:  These tools provide an alternate to the VPI based Vertical Alignment Generator. They allow the 
user to place vertical components (tangents and curves) to assemble a profile. Where the user has many 
constraints (as it the situation here) they are a very useful alternative to the traditional design profile 
method. 
6. From the tangent tools, click Create Profile Line by Points. 
7. Snap to the end of the Model profile that represents the elevation at the edge of the traffic 

circle. 
8. Set the slope to 2%. 
9. Draw in the tangent. 

 
10. From the Curve tools, click Create Profile Curve by 3 Points. 
11. Set the Microstation snap control to nearest. 
12. Snap to 3 locations on the Model profile in the area of the extent of reconstruction.  

Note:  This gives us a vertical curve that represents the existing service road centerline – so w can join 
back to existing. 

 
13. From the Curve tools, click Create Tangent Profile Curve. 



Lab Exercise: Creating Design Profiles 
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14. Select the profile tangent, data point in the profile view to designate a “through” point on the 
curve and then data point again to finish the curve. 

 
15. From the Curve tools, click Create Profile Curve between 2 Elements. 
16. Select and accept the first profile curve.  
17. Select and accept the second profile curve. 
18. Data point to locate a “through point” for the profile curve and to complete the new profile 

curve. 

 
Note:  Wait and follow you instructor before you attempt these steps if you have not used these tools 
before. 



Lab Exercise: Creating Design Profiles 
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> STORING THE PROPOSED PROFILE 

1. From the vertical components tools, click Store Vertical Alignment. 

If you receive alert messages that COGO needs to be open then answer in the affirmative. The alert 
message is telling us that we need COGO open to store the vertical profile and then asking us if we want 
to open COGO. After answering these prompts then you will need to start the store vertical alignment tool 
again 
2. Key in the proposed profile name “ServNth”. 
3. Select any proposed profile component from the profile view (Window 2). 
4. Data point again to string the components together. 
5. Data point again to actually store the alignment to COGO. 
6. Click COGO – this will raise the COGO window. You can see the commands that have been 

created to store the profile. 

Note:  Remember to follow the prompts displayed in the MicroStation message area during the design 
and store profile process. 

The stored profile can now be loaded into the VPI profile tool in order to round off the grades and stations 
of VPIs as well as check curve lengths for design speed. 

> DETERMINE THE EXTENT OF RECONSTRUCTION 

While we have the ServNth profile activated, we will use this to determine the extent of reconstruction. 
Effectively, where the proposed profile joins back to the existing surface is the end of proposed 
reconstruction. 
1. Set MicroStation snap to intersection mode. 
2. Click Curvilinear Coordinates. 
3. In the profile view, snap to the intersection of the existing and proposed profiles. 
4. Lock the Station and Permanent Lock controls in the curvilinear coordinates dialog. 

Note:  After locking the station you could overtype an even station value if desired.  For example, type in 
7+10.00 rather than the exact computed value of 7+10.50.  This could make your final plans more 
presentable. 
5. Now in plan view draw a line across the ServNth pavement lines. Because of the curvilinear 

coordinates locks it will only draw perpendicular to the alignment. 
6. Now trim the proposed edges of pavement to the line just drawn. 
7. Repeat the proposed profile design for ServSth, RampNth and RampSth. 

 



Lab Exercise: Creating Design Profiles 
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STEP 4 
Objectives 

 Model the incoming roadway pavement areas based on the profiles we just designed and the 
alignment we were provided 

Introduction 
Now that chains and profiles have been created for all of the incoming roadways, the next step is to 
model the incoming roadway surfaces based on those design alignments. 

This involves defining the alignment elements, edge of pavements and curb and gutter sections in the 
Site Model. 

There are two methods that can be employed to do this. 

We will attempt both methods and discuss reasons to choose one method over the other. 

Firstly, we will add the control alignment and then define the associated edge of pavement elements 
using the basic Site Modeler tools. 

Then we will define the other 4 incoming roadways using the Composite Section tool. 

Tools to be used 
 Site Modeler > Elements > New/Edit > Alignment 

 Site Modeler > Elements > New/Edit > Slope/Offset from Site Element 

 Site Modeler > Elements > New/Edit > Section 

 Site Modeler > Elements > Composite Section 



Lab Exercise: Create Roadway Surface from Control Alignment 
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LAB EXERCISE: CREATE ROADWAY SURFACE FROM CONTROL ALIGNMENT 
To ensure that all students have the same data, we will start this exercise in a new dataset. 

> SWAP TO NEW DGN AND GSF 

1. Open the file C:\Data\Geo\Site\Roundabout\Step4\LHSRAB.dgn. 
2. Start Modeler (Applications>GEOPAK Site>Site Modeler>Site Modeling). 

Note:  PowerCivil menu, (Civil > Modeler). 
3. This will open the GEOPAK Site Modeler tool. 

 
4. Click Browse.  
5. Select the file C:\Data\Geo\Site\Roundabout\Step4\LHSRAB.gsf. 
6. Click OK. 
7. In Microstation, turn off level TempCL so the elements there do not confuse us. Remember 

that this level contains the elements for the construction object we created in Step 2. 

 

LAB EXERCISE: ADD THE CONTROL ALIGNMENT 
1. On the Active Site Object Control make sure the active object is set as RAB1. 

 
2. Now start the new element tool (Modeler > Elements > New/Edit > Alignment). 

We do not want the alignment element to impact on the traffic circle, only the pavement outside it. 
Because of this, we will add the Control Alignment to the Object in 2 parts, leaving out the portion across 
the Traffic Circle. 

 
3. Set the dialog as shown above.  

Note:  The begin station is the limit of construction on the west. This was purposely set at an even station 
to make the plans easier to read.  The end station is the point where the alignment meets the traffic 
circle.  You can dynamically set these ranges by snapping to the appropriate points. 
4. Click Apply. 



Lab Exercise: Add the Control Alignment 
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5. Populate the dialog as shown below. 

 
6. Click Apply. 

This will add the 2 required portions of the control alignment to the Object.  



Lab Exercise: Add the Control Alignment 
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> ADD THE EDGE OF PAVEMENT ELEMENTS RELATIVE TO THE CONTROL ALIGNMENT 

1. Continuing with the new element tool (Modeler > Element > New/Edit > Slope/Offset from 
Site Element). 

2. Set the dialog as shown below. 

 
Note:  As there are two (2) different sections of the control alignment. The cross slope for the road area 
is -2%. The cross slope for the bridge area is -1.56%. We will need to project the edge of pavement 
elements to the centerline in 2 steps. 
3. Click Define Elements>Select Element. 
4. Select the 2 edge of pavement complex chains on the western approach. 
5. Click Reference Element>Select Reference. 
6. Select and accept the left western portion of the control alignment element. 
7. Click Apply. 

Now we will repeat these steps for the right hand portion of the control alignment – the 
pavement over the bridge. 

8. Set the dialog as shown below. 

 
9. Click Define Elements>Select Element. 
10. Select the four (4) edge of pavement complex chains on the eastern approach. 
11. Click Reference Element>Select Reference. 
12. Select and accept the eastern portion of the control alignment element. 
13. Click Apply. 



Lab Exercise: Add the Control Alignment 
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> ADD THE CURB AND GUTTER SECTIONS TO THE EDGE OF PAVEMENT 

1. Continuing with the new element tool change to the section tab (Modeler > Elements > 
New/Edit > Section). 

2. Populate the dialog as shown below. 

 
Note:  The required DDB items can be found in the DDB /PayItem/Plan/Roadway directory. 
3. Click Reference Elements > Select Reference Elements. 
4. Select the six (6) previously defined edge of pavement Site Elements. 
5. Click Set. 
6. Move the cursor into the graphics and set the direction so that the arrow points to the outside 

of the edge of pavement. 

 
Note:  There is a dynamic graphic that is attached to the selected elements. GEOPAK is waiting for the 
User to set the positive horizontal (offset) direction for the section elements. 
7. Click OUTSIDE of the selected graphics (so the positive direction is to the outside of the 

edge of pavement). 



Lab Exercise: Add the Control Alignment 
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8. Click Apply. 

We have added the curb and gutter to the edge of pavement elements. 

We will now create the other 4 incoming roadways in a more automated manner using 
Composite Section. 



Lab Exercise: Add the Control Alignment 
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> ADD THE NORTH SERVICE ROAD 

1. Start the composite section tool. (Modeler > Tools > Composite Section). 

Note:  A number of steps are required to populate this dialog with the required information. Shown below 
are dialog captures of each of these steps. 

 
2. Press Alignment Definition button and populate as shown below. 

 



Lab Exercise: Add the Control Alignment 
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3. To define the edge of pavement elements, set the dialog as shown in the lower portion of the 
dialog below. Click Add List Item. (indicated by arrow). 

 
4. To define the curb and gutter, set the dialog as shown below. 

 
5. Click Add List Item. 



Lab Exercise: Add the Control Alignment 
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6. Select both list items. Click Copy List Item. 

 
7. Click Right Side. 
8. Click Paste List Item. 
9. Select the first row item for the right side. 

 
10. Reset the Max. Distance value to 25.5. 
11. Click Modify List Item. 
12. Edit the Right Side Section row. 



Lab Exercise: Add the Control Alignment 
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13. Set the Side to Right. 

 
14. Click Modify List Item. 
15. Click Apply. 

Note:  Composite Section settings files can be saved and reused. To save a file, use the File > Save 
option at the top of the dialog. 



Lab Exercise: Add the Control Alignment 
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> ADD THE OTHER ROADS – SERVICE RD SOUTH 

The Composite Section files have been saved for the other roadways. We can open these files to 
complete the incoming roadways. 
1. Site Modeler > Elements > Composite Section. 
2. File > Open. Select C:\Data\Geo\Site\Roundabout\Step4\ServSth.sec. 
3. Populate the Primary Element portion of the dialog as shown below. 

  
4. Click Apply. 



Lab Exercise: Add the Control Alignment 
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> ADD THE OTHER ROADS – RAMP NORTH 

1. Site Modeler > Elements > Composite Section. 
2. File > Open. Select C:\Data\Geo\Site\Roundabout\Step4\RampNth.sec. 
3. Populate the Primary Element portion of the dialog as shown below. 

  
4. Click Apply 



Lab Exercise: Add the Control Alignment 
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> ADD THE OTHER ROADS – RAMP SOUTH. 

1. Site Modeler>Elements>Composite Section. 
2. File > Open. Select C:\Data\Geo\Site\Roundabout\Step4\RampSth.sec. 
3. Populate the Primary Element portion of the dialog as shown below. 

  
4. Click Apply. 

This completes the areas of the incoming roads that can be defined based solely on the Chain 
and Profile for each roadway. 

 



Lab Exercise: Add the Control Alignment 
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STEP 5 
Objectives 

 Create the curb return elements and then, where required, edit these to ensure that all pavement 
areas provide smooth transitions and drain correctly. 

Introduction 
At this point, we have defined all of the larger pavement areas that have a direct relationship to a 
specific geometric element. 

The traffic circle was defined based on a surface generated from the original control alignment. The 
incoming roadways have been based on their respective chains and profiles. 

The curb return elements, in general, will be defined based on extending recently created pavement 
areas. Deciding where and how these elements will be created will require some educated Engineering 
design “best guesses”. 

Tools to be used 
• Site Modeler > Elements > New/Edit > Slope/Offset from Site Element. 

• Site Modeler > Elements > New/Edit > Drape On Model/Object. 

• Site Modeler > Elements > Edit Profile. 

• Site Modeler > Elements > Section. 



Lab Exercise: Define the remaining Edge Of Pavement elements 
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LAB EXERCISE: DEFINE THE REMAINING EDGE OF PAVEMENT ELEMENTS 
To ensure that all students have the same data, we will start this exercise with a new dataset. 

> SWAP TO NEW DGN AND GSF. 

1. Open the file C:\Data\Geo\Site\Roundabout\Step5\LHSRAB.dgn. 
2. Start Modeler (Applications > GEOPAK Site > Site Modeler > Site Modeling). 

Note:  PowerCivil menu, (Civil > Modeler). 

 
3. Click Browse. 
4. Select the file C:\Data\Geo\Site\Roundabout\Step5\LHSRAB.gsf. 
5. Click OK. 



Lab Exercise: Define the remaining Edge Of Pavement elements 
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> DEFINE THE CURB RETURN ELEMENTS 

19. Select the site element slope offset tool (Modeler > Elements > New/Edit > Slope/Offset 
From Site Element). 

Note:  Most of the remaining curb return elements can be defined by projecting from the outside edge of 
the traffic circle at –2%. 

 
2. Set the dialog as shown above. 
3. Click Define Elements > Select Elements and select all of the curb return elements that are 

shown in heavy weight below (should be 6 elements). 

 
4. Click Reference Element>Select Reference. Select and accept the outside edge of the 

Traffic Circle. 
5. Click Apply. 

Note:  The remaining curb returns we can define by draping the endpoints on the design thus far. 

6. Modeler > Elements > New/Edit > Drape on Model/Object. 



Lab Exercise: Define the remaining Edge Of Pavement elements 
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7. Set dialog as shown above. 
8. Click Define Elements>Select Elements and select all of the curb return elements that are 

shown in heavy weight below. 
 

Select these 
elements. 

 
9. Click Apply. 



Lab Exercise: Define the remaining Edge Of Pavement elements 
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> RE-DEFINE THE CURB RETURN ELEMENTS USING EDIT PROFILE 

The GEOPAK Site Modeler Edit Profile tool is a very powerful design tool. It allows the User to redefine 
any existing Site Element or series of Site Elements by creating a Profile view of the elements and then 
using Vertical Component tools to modify the elevations. 
1. Modeler > Elements > Edit Profile. This will activate the Active Profile Control dialog. 

 
 The dialog contains a number of different tools. 

•  The Profile Cell Status button. 

•  An id button to synchronize between plan view elements and the corresponding profile. 

•  The Vertical Component Tools. 

•  The Define Site Element Profile button: this applies the new profile back to the Site 
Element. 

•  The Curvilinear Coordinates button. 

•  The Active Chain Control view control windows. 

 
2. Open Window 2 and Zoom/Window Area to give you a clear drawing space to place the 

Element Profile. 
3. Right Click on the Profile Cell Status button and select Profile Cell Setting. 
4. Set the dialog as shown below. 

 



Lab Exercise: Define the remaining Edge Of Pavement elements 
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5. Click Select Element. Select all of the edge of pavement elements shown in heavy line 
weight below. 

 
Note:  Each element needs to be selected and accepted. When the elements are correctly selected, they 
will highlight with a series of light blue dots over the element. 
6. Click Place Site Pcell. Move your mouse cursor into a clear drawing space in Window 2 and 

data point. This will place the profile representation of the Site Elements into a Site Profile 
Cell in Window 2. 

 
7. Right click over the Active Chain Control view control window number one (1) and set 

View 1 to a Plan view. 
8. Right click over the Active Chain Control view control window number two (2) and set 

View 2 to a Profile view. 

This will synchronize between Plan and Profile views. 

9. Press the Vertical Component Tools button. The following dialog will activate. 

 



Lab Exercise: Define the remaining Edge Of Pavement elements 
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10. Use the Vertical Component Tools to redefine the portions of the current profile where 
required. 

Note:  Follow your instructor. There will be a discussion on what portions of this profile need to be 
redefined and what portions must not be modified. 
11. After the proposed vertical components have been added to the Profile, we need to return this 

new vertical information back to the Site Elements. 
12. Click Active Profile Control > Define Site Element Profile. 
13. Select one of the proposed vertical components. 
14. Click again – this will string all of the components together. 
15. Click again – this will return the new elevations to the Site Modeler elements. 

Note:  We will redefine the other five (5) curb returns using the same steps. 
 



Lab Exercise: Add Curb and Gutter Section to Curb Returns 

 

 
 Copyright © 2007 Bentley Systems, Incorporated Do Not Duplicate 

1/10/2008 10-48 

LAB EXERCISE: ADD CURB AND GUTTER SECTION TO CURB RETURNS 
The curb returns have been defined to ensure a smooth pavement surface within the intersection. We 
now need to add the missing pieces of curb and gutter to the curb return elements. 

> ADD CURB AND GUTTER SECTION 

1. Start the site element section tool Modeler > Elements > New/Edit > Section. 
2. Populate the dialog as shown below. 

  
Note:  The required DDB items can be found in the DDB /PayItem/Plan/Roadway directory. 

The section can be read from other edges of pavement that already have a section attached with the 
Query button (indicated by arrow). 
3. Click Reference Elements>Select Reference Elements. 
4. Select the eight (8) previously defined edge of pavement Site Elements. 
5. Click Set. 
6. Move the cursor into the graphics to set the direction. 

Note:  There is a dynamic graphic that is attached to the selected elements. GEOPAK is waiting for the 
User to set the positive horizontal (offset) direction for the section elements. 
7. Click OUTSIDE of the selected graphics (so the positive direction is to the outside of the 

edge of pavement). 
8. Click Apply. 

We have added the curb and gutter to the curb returns. 



Lab Exercise: Add Curb and Gutter Section to Curb Returns 
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STEP 6 
Objectives 

 Create the complex traffic circle center island. 

Introduction 
In Step 2 we originally defined the inside edge of the traffic circle. This was a temporary (and fast) 
method to give us a visual indication of what a 2% pavement slope would look like. 

We now need to create the more complex median/island arrangement that was requested by the client.  

Tools to be Used 
• Site Modeler>Elements>New/Edit>Section. 

• Site Modeler>Elements>Composite Section. 



Lab Exercise: Remove the Current Inside Edge of Traffic Circle 
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LAB EXERCISE: REMOVE THE CURRENT INSIDE EDGE OF TRAFFIC CIRCLE 
To ensure that all students have the same data, we will begin this exercise in a new dataset. 

> SWAP TO NEW DGN AND GSF 

1. Open the file C:\Data\Geo\Site\Roundabout\Step6\LHSRAB.dgn. 
2. Start Modeler (Applications>GEOPAK Site>Site Modeler>Site Modeling). 

Note:  PowerCivil menu, (Civil > Modeler). 
3. This will open the Site Modeler tool. 

 
4. Click Browse.  
5. Select the file C:\Data\Geo\Site\Roundabout\Step6\LHSRAB.gsf. 
6. Click OK. 

 



Lab Exercise: Remove the Current Inside Edge of Traffic Circle 
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> REMOVE THE INSIDE TRAFFIC CIRCLE ELEMENT 

1. Select the Section tool. (Modeler > Element > New/Edit > Section). 

Note:  The inside element of the traffic circle was created as a Site section element. To remove this 
element we use the Section tool. 

 
2. Select Reference Elements>Select Reference Elements. Select and accept the outside edge 

of the traffic circle. 
3. Click Remove Section. 
4. The section element will be removed and the traffic circle will be re-triangulated. 
 



Lab Exercise: Create Complex Center Traffic Island 
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LAB EXERCISE: CREATE COMPLEX CENTER TRAFFIC ISLAND 
> CREATE THE COMPLEX CENTER TRAFFIC ISLAND 

1. Start the composite section tool (Modeler > Tools > Composite Section). 
2. File > Open. Select C:\Data\Geo\Site\Roundabout\Step6\RABCenterIsland.sec. 
3. This will populate the Composite Section dialog as shown below. 

 
4. Rather than using a COGO chain and profile we will be using a site element for the primary 

element which will be the outside edge of the traffic circle. 

Note:  We shall look at the settings inside the Composite Section file in detail. 
The inside of the traffic circle has 2 pavement areas and 2 different types of curbing. 

The first row of the dialog creates the first pavement edge. The pavement is 15 feet wide at 
a pavement slope of 2%. 

This is shown in the dialog above. 



Lab Exercise: Create Complex Center Traffic Island 
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The second row creates the first of the curbing sections. 

 
The “gutter” portion of this section is actually created at the same slope as the adjacent 
pavement (2%). Then there is a curbing. 



Lab Exercise: Create Complex Center Traffic Island 
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The third row creates the second pavement surface – in the finished intersection this will be 
a concrete pavement. 

 
This pavement is also at a 2% slope but note that the elevations for this pavement edge will 
be based on the adjacent element rather than the primary element. 

In effect, the edge of pavement elevations will be calculated from the top back of the curb. 



Lab Exercise: Create Complex Center Traffic Island 
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The forth row creates the second of the curb and gutter sections. 

This section also has a positive slope on the gutter section, thus forcing all surface water 
towards the outside of the traffic circle. 

Note:  Draining water to the outside of the traffic circle is a typical design arrangement for this type of 
intersection. While it means that the circulating traffic have an adverse cross slope to maneuver, it does 
prevents ponding at the center island. If the cross slope falls towards the center island and the drainage 
inlets become blocked, the drainage runoff could pond (submerge) the entire intersection before it would 
drain away. 

 
5. Select Primary Element > ID Element. Select and accept the outside edge of the traffic 

circle. 
6. Click Apply. 

 



Lab Exercise: Create Complex Center Traffic Island 
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STEP 7 
Objectives 

 Create the median islands for the incoming roadways. 

Introduction 
The only portion of the project that has not been modeled is the traffic medians/islands. 

These will now be created. 

Tools to be Used 
• Site Modeler>Elements>New/Edit>Drape on Model/Object 

• Site Modeler>Elements> Section 



Lab Exercise: Create a New Median Object 
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LAB EXERCISE: CREATE A NEW MEDIAN OBJECT 
To ensure that all students have the same data, we will begin this exercise with a new dataset. 

> SWAP TO NEW DGN AND GSF 

1. Open the file C:\Data\Geo\Site\Roundabout\Step7\LHSRAB.dgn. 
2. Open Modeler (Applications > GEOPAK Site > Site Modeler > Site Modeling). 

This opens the site modeler. 

 
3. Click Browse. 
4. Select the file C:\Data\Geo\Site\Roundabout\Step7\LHSRAB.gsf. 
5. Click OK. 



Lab Exercise: Create a New Median Object 
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> CREATE A MEDIAN OBJECT 

1. Our preferences do not contain a type for medians, so we will create one. 
2. Open the project preferences (Modeler > Project Preferences). 
3. Choose the Objects section as shown below. 

 
4. Since the Roadway type has most of the settings we want, we can use it to start, so highlight 

Roadway. 

 
5. Overtype the Object type and Name prefix as shown above and press the add list item button. 

This will create a new object type named median with all the same settings as roadway 
objects. 

6. Click Default Slopes and set the default slopes for the Median Object type to “No Slopes”. 
7. Click Modify List Item to modify the slopes. 
8. Press OK on the preferences and save the project. 
9. Now, create a new site object. Modeler > Object > New. 
10. Select the Object Type “Median”. 



Lab Exercise: Create a New Median Object 
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11. The default Object Name is Median1. Leave this as it is. 
12. Click OK. 

> DRAPE OUTSIDE OF MEDIAN ONTO THE RAB OBJECT 

1. Open the new site element tool (Modeler > Element > New/Edit > Drape on 
Model/Object). 

2. Set the dialog as shown below. 

 
3. Click Define Elements>Select Elements. Select the purple graphic that represents the outside 

edge of one of the Medians. 
4. Click Apply. 



Lab Exercise: Create a New Median Object 
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> ADD A SECTION TO THE MEDIAN OBJECT 

1. Change the new/edit element to the section tab. 
2. Set the dialog as shown below. Modify the rows as required. 

 
3. Click Reference Elements > Select Reference Elements. Select and accept the edge of 

median element that was created in the previous step. 
4. Click Set. Point the dynamic direction arrow inside the median shape and data point. 

 
5. Click Apply. 

This completes creation of the first of the four (4) medians. 

6. Create the other 3 medians using the same process. 

This completes our intersection. 
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