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Introduction 
GEOPAK is a comprehensive software package for all of your survey processing needs: from raw 
field data to a finished drawing all within the MicroStation environment. GEOPAK performs traverse 
entry / edit / reduction, coordinate geometry and mapping without having to leave MicroStation. 

VDOT’s implementation of GEOPAK will focus mainly on coordinate geometry and digital terrain 
modeling for post processing of field data. 

Using GEOPAK will help ensure consistency and accuracy of survey data from initial field collection 
all the way to construction staking. 

1.1   File Names 
GEOPAK uses and/or creates files during the design process.  The files are detailed in the table 
below.  

job###.gpk This binary file is created when the user starts a coordinate geometry 
(COGO) session for the first time or through Project Manager and may be 
appended to during the design process. All coordinate geometry elements 
are stored in this file. Multiple users can access this file at the same time, 
and only one file should be created for each project.  The "###" is the only 
variable in this name.  It represents a job number (up to 3 alphanumeric 
characters) unique to a project and is defined by the user upon creation. 

fname###.ioc 
Example: align999.ijd 

ASCII input file for loading data during a COGO session. "###" represents 
the job number and "oc" is the operator code (users initials).  

fname###.ooc 
Example: align999.ojd 

ASCII output file created by GEOPAK during a COGO session. Variables 
are the same as defined above.  

fname.dat 
 

A binary file that contains string and point information to be used for digital 
terrain model construction. 

fname.tin A binary file containing triangular surfaces also known as the digital terrain 
model (DTM). 

project.prj Binary file resulting from the creation of a new project. 

 

1.2   Accessing GEOPAK 
GEOPAK is started upon entering a MicroStation File.  To verify that GEOPAK is active, scan the 
MicroStation menu bar where the Applications menu appears.  Simply pull down Applications > 
GEOPAK SURVEY.  When each GEOPAK tool is selected, the corresponding dialog will appear.  In 
addition, several dialogs may be opened simultaneously. 

To close a dialog, simply click the X in the upper right corner of the dialog.  In addition, the 
Coordinate Geometry dialog and Design and Computation Manager may be closed by selecting the 
File > Exit option.  Other various dialogs have a Cancel button, which exits the dialog.  Exiting the 
MicroStation file automatically closes all GEOPAK dialogs. 
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1.3   User Preferences 
When a user begins Geopak for the first time or after Geopak has been reloaded, there are certain 
User Preferences the user needs to set.  The User Preferences dialog can be accessed from 
Applications > Geopak SURVEY > User Preferences.  The following dialog appears. 

 

Most of the settings in this dialog are defined when the project is set up. 

The Working Directory identifies where the data files for a particular project can be found.  This is to 
say that GEOPAK will look here by default, for any files needed to read or write to by any application. 
If a user does not want to specify a directory, the field may be left blank, and Geopak uses the 
directory wherein the open MicroStation file is located. 

By pressing the COGO Preferences button, the following dialog is invoked. 

Everything about this dialog refers to COGO and the COGO database (.gpk). 

 

Job Open Mode 
This determines the file creation constraints imposed on creating new coordinate geometry database 
file.  Coordinate geometry data is stored into a file named job** .gpk where ** is the user-specified job 
number for a given project.  Each time the Coordinate Geometry window is invoked for a job number 
that does not correspond with a job**.gpk file in the current or specified working directory, GEOPAK 
creates a new job**.gpk file contingent on the constraints imposed by the Job Open Mode parameter. 

Create - Automatically creates a new coordinate geometry database. 

No Create - This mode does not permit creation of a new coordinate geometry database and 
provides a warning. 
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Query - With this mode, the user is queried when a job number is requested that does not 
correspond with a job**.gpk file in the current directory.  Once queried, the designer may proceed 
with the database creation or cancel it. 

Directories 
Job Directory 

The job directory will force the creation of the coordinate geometry database (.gpk) somewhere other 
than the project working directory. This may be desirable simply for file maintenance, to keep the gpk 
separate from all the other project data files. 
COGO Input File Dir. 
COGO Output File Dir.  

Normally, input and output files are stored in the project directory, in which case, these fields would 
be blank.  However, there are times when they are located in other directories, which can be keyed 
into these fields.  In lieu of typing, pressing any of the Select buttons invokes the Select Directory 
Manager, wherein the desired directory may be specified. 

Redefinition of Elements 
When the toggle button is active, existing elements in the Coordinate Geometry component can be 
redefined.  For example, point number 8523 that was previously defined to coordinate values can be 
set to new coordinate values when this toggle is active.  Otherwise, the Coordinate Geometry 
component would not store the new coordinate values with point number 8523 and a warning 
message "Element already exists" is displayed on the screen.  This serves as a protection to the 
integrity of the coordinate geometry database.  The same functionality can be achieved by the 
Redefine toggle in the Coordinate Geometry window. 

Force Redefinition Off Upon COGO Activation 
When this toggle is activated, and coordinate geometry is invoked, the Redefine button is not active, 
so that no redefinition of elements is permitted.  However, at any time during the session, the 
Redefine toggle may be activated. 
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1.4   Feature Preferences 
From the main user preference dialog access can be gained to the GEOPAK survey manager 
database or .smd file. The SMD file is where feature preferences are set so that the field-collected 
features are mapped according to desired symbology. By pressing the Feature Preferences the 
following dialog is invoked. 

 

The SMD File keyin allows for the selection of the desired database. 

From this dialog, if the Edit SMD button is selected, access is granted to the database via the dialog 
below. 

 

From this dialog interface, a complete database can be configured to the desired symbology for 
individual features.  This database contributes to consistency agency wide when field data is mapped 
into a MicroStation file. 

The other two options from the Feature Preferences dialog, Apply Best Match Feature and Plot 
Scale, allow the user to not only to vary scales of the features when mapped but also to control how 
the software matches field codes to those found in the database itself. 
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When the Apply Best Match Feature toggle is activated, the program, when processing the data, 
will search the database for a candidate feature code that most closely matches the code as entered 
in the field. This can be used to your benefit when collecting multiple, like features. 

The last option on the Feature Preference dialog is the Use Shared Cells option. When selected the 
program will enforce the use of shared cells when placing multiple instances of a feature, such as 
trees. 
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User Preferences 
Introduction 

Step 1. Open the MicroStation file c:\data\geo\vdot\s1373\s1373.dgn 

Step 2. Access the GEOPAK User Preferences dialog from the Applications pulldown.  
Applications > GEOPAK Survey > User Preferences. 

Step 3. The User Preferences dialog will appear as shown. 

 

Step 4. Access the COGO Preferences dialog by pressing the COGO Preferences button. 

Step 5. Set the preferences in the dialog as shown on the dialog below and press OK. 
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Step 6. From the main User Preference dialog, press the Feature Preference button. 

 

Step 7. The SMD file for this project will be c:\data\geo\vdot\standards\vdot-e.smd. Press the 
Select button to navigate to: c:\data\geo\vdot\standards\vdot-e.smd  

  

NOTE: Most agencies assign one person as the caretaker of the SMD file and this file is password 
protected. The password protected SMD file is made available to all users. This helps ensure 
consistency in data that is processed. 
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Coordinate Geometry 
2.1   Introduction 
Objectives Learn to set up and access the coordinate geometry database. 

Become proficient in using GEOPAK Coordinate Geometry. 

Tool 

                      

 

Menu Bar Application GEOPAK Survey > Geometry > Coordinate Geometry 

 

The Coordinate Geometry dialog is an interactive graphical user interface for storing coordinate 
geometry elements:  points, lines, curves, spirals, chains, parcels and profiles as well as calculate 
roadway superelevation. 

2.2   Accessing COGO 
If Coordinate Geometry is started from the Survey Tools icon instead of the Survey Operations 
dialog, (without Project Manager running) then the Start-Up Dialog appears. 

 

The fields in the Start-Up dialog are detailed below. 

Project Name Name displayed on reports.  This is an optional entry, with a maximum of 
60 alphanumeric characters.  If Project Manager is active, this field is 
populated automatically. 

Job Number Identifies coordinate geometry database and is a required field. The job 
number is a maximum of three alphanumeric characters.  If Project 
Manager is active, this field is populated automatically. 

Operator Code Unique 2-character code which enables multiple users access to database.  
The user’s initials are suggested.  Note this field is not required for single 
user access, but highly recommended.  If Project Manager is active, this 
field is populated automatically. 

Subject Description for audit trail file with a maximum of 48 alphanumeric 
characters.  Note this field is optional. 
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Note:  The Job Number is the only required field, although the Operator Code is useful for saving the 
audit trail and required for multiple user access. 

After the dialog is populated, and the OK button is pressed, the main coordinate geometry dialog is 
invoked. 

2.3   Coordinate Geometry Dialog 

 

The coordinate geometry dialog box is made up of three separate display areas: 

• Tool Bar (1)  consisting of pull down menus and icons.  The icons are customizable. 
• Command Key-in (2) enables manually typing of commands.  The drop down button allows 

for a history of commands to be seen. 
• Output Display Window (3) shows the results generated by the commands. 

Note the dialog is resizable for ease of use. 

2.3.1   File Utility Commands 

 
The File Utility Commands are located from the File pulldown. They are detailed in the table below. 

Load When selected, a menu appears listing all saved input files. Highlight a file, 
then click the OK button. The input lines from the highlighted file are now 
displayed in the display window for viewing, editing, or processing. 

Append This command is for input files only. A new input file is created by copying 
the contents of an existing input file to the end of the current input file.  The 
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Save command must be used in order to store this new file. 

Catalog When selected, a menu appears listing all saved input files (under the 
current operator code) in the project directory.  This is for reference only, 
no action is taken. 

Delete When selected, a menu appears listing all saved input files. Highlight a file, 
then click the OK button to remove this file from your project directory.  
Although the file is deleted, the elements stored as a result of processing 
the commands are not deleted. 

Output  Writes an ASCII file of the current display for reviewing and / or printing. 
(Fname999.ooc, where 999 is the current job number and oc is the 
operator code). 

Print Input File Sends your input file to the printer. 

Print Output File Sends your output file to a printer. 

Save Saves the current audit trail to a file. (Fname999.ioc, where 999 is the 
current job number and oc is the operator code.). 

 

Additional File Commands 
Export  Exports GEOPAK points, chains and profiles 

into formats for use in various data collectors. 

Import  Imports horizontal and vertical alignments and 
points from various formats into the GEOPAK 
.gpk file. 

Exit Closes the COGO dialog box and ends the 
coordinate geometry session. A prompt to 
save the session appears. Yes saves the 
audit trail, No exits without saving, Cancel 
returns to the COGO session. Whether you 
pick Yes or No everything you did is still 
saved in the .gpk file. 
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2.3.2   Edit Commands 

 
The Edit commands (as displayed in the exploded view above) are detailed in the table below. 

Clear Empties the memory of the current audit trail without saving and initializes 
the line numbers to begin a new sequence of commands.  Note this does 
not clear the display window. 

Delete Deletes input commands in the input buffer by line number (or range of line 
numbers) and re-sequences the line numbers for the remaining 
commands. 

Insert  Adds a command line to the current input buffer before a specified line 
number; subsequent command lines shift down and line numbering is 
automatically re-sequenced. 

Modify  Changes a fragment in a command line. The modified command line is not 
processed until a Read command is performed. 

Read All Processes the specified lines in the audit trail. This may be done for the 
entire file (All) or by specifying a range of line numbers (Line Range). 

Type All Displays the content of the audit trail, (All) or a portion of the audit trail by 
specifying a range of line numbers (Line Range). 

Line Range Allows specifying a line range for reading or typing 

Editor Opens the GEOPAK COGO Command Editor, which enables the user to 
edit the current input file. 
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2.3.3   Element Commands 
The mainstay of GEOPAK Coordinate Geometry is the various element commands.  Tools are 
supported for storing, stationing, adding additional data, deleting, etc.  GEOPAK supports a wide 
variety of elements:  points, curves, spirals, chains or alignments, parcels, and profiles.  Each 
element is detailed below. 

2.3.3.1   Element > Point 

 

One of the most utilized sets of COGO tools are the point commands, as detailed in the table below. 
Cogo now has the ability to automatically determine the next available element name and place in 
any dialog storing an element. This includes all elements and dialogs listed on the above pulldown.   

Utility Provides option to Delete, Print and Display a point. 

Cell Assigns a cell name to a previously stored point. 

Copy Copies points or a point range to a new point number or range within the same 
GEOPAK database 

Elevation Assigns an elevation to a previously stored point 

Equate Stores a new point with the same values as a previously stored point 

Station Adds a station to a previously stored point. 

Store Stores a point by key-in coordinates or by selecting a location graphically.  A 
station, elevation, point code, cell, feature, or description can be optionally stored 
with the point. 
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Transformation Used to transform a set of points to a new coordinate system. 

Compare 
Points to TIN 

Utilizing a set of COGO points (with elevations) compares the COGO elevation to 
the TIN elevation and completes statistical analysis for "goodness of fit." 

Set Elevation 
from TIN 

Utilizing this command, GEOPAK adds or updates an elevation to a previously 
defined point, based on a TIN model. 

2.3.3.2 Element > Line 
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Utility Provides options to Transpose, Delete, Print and 
Visualize. 

Store Allows input for storing a line. 

 

2.3.3.3 Element > Curve 

 

The Curve commands (as displayed in the exploded view above) are detailed in the table below. 

Utility Provides options to Transpose, Delete, Print and Visualize. 

Copy Copies a specified curve to another curve name. 

Data Calculates the geometric parameters of a curve, displaying values for 
Delta, Degree, Tangent, Length and Radius. 

Segment Defines new curves by dividing a stored curve into segments. 

Station By identifying a curve and the position on the curve (PC, PI, or PT), a 
station value may be assigned. 

Store Provides various options for defining and storing lines and curves such as 
Store Curve from Tangents as shown below.  
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2.3.3.4   Element > Spiral 

 

The Spiral commands (as displayed in the exploded view above) are detailed in the table below. 

Utility Provides options for Delete, Print and Visualize. 

Copy Copies a specified spiral to another spiral name. 

Store Provides various options for defining and storing spirals. 
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2.3.3.5   Element > Chain 

 
The Chain (GEOPAK alignment) commands (as displayed in the exploded view above) are detailed 
in the table below. 

Utility Provides options to Compute chain Area, Delete, Describe, Print and 
Visualize. 

Layout Offset  Provides a method for computing station and offset between chains and 
points or other chains. 

Stationing Provides a method for stationing or re-stationing a chain. 

Station Equation  Provides a method for applying a station equation to a chain. 

Store Provides three options for storing a chain in the database, From 
Elements, From Offset Chain and a Transition Chain. (Chain name can 
be between 1-9 alphanumeric characters)  
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2.3.3.6   Element > Parcel 

 

The Parcel commands (as displayed in the exploded view above) are detailed in the table below. 

Utility  Provides options to Delete, Describe, Print and Visualize. 

Store Stores a parcel by adding points, curves and spirals. 

Subdivide Divides a parcel into individual lots. 

Editor Edits a parcel. 

 

2.3.3.7   Parcel Commands (Manual Entry) 
Several parcel commands are supported by manual entry or via the Map Check dialog. Each of these 
commands accept the input of specific names associated with each element. I.e. taken names, 
easement names, etc. 

Store Taken Store the portion of a parcel taken by entering point and curve names in 
either a clockwise or counterclockwise direction. 

Store Easement  Store an easement by entering point and curve names in either a 
clockwise or counterclockwise direction. 

Own Parcel  Stores the name of the owner associated with a previously stored parcel.  

Make Legal  Creates a metes and bounds description and writes it to a user named text 
file. See also Legal Description Editor for the ability to create detailed and 
customizable legal descriptions. 

 

For more detailed parcel information, refer to the GEOPAK Manual or online help. 
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2.3.3.7   Element > Profile 

 
The Profile commands (as displayed in the exploded view above) are detailed in the table below.  
Note additional commands are supported as keyin only commands.  For details, refer to the GEOPAK 
Online Help. 

Utility Provides options for Deleting and Printing. 

Elevation Provides three options for reporting elevations along a selected profile, 
Station, Even Station, Incremental Stations. 

Offset Facilitates the copying of a profile in the vertical direction 

Restation Options for modifying station of an existing profile. 
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2.3.4   View Commands 

 

The View commands (as displayed in the exploded view above) are detailed in the table below. 

Icons Enables the user to customize which icons appear in the tool 
bar. 

Redefine Displays the Redefine box on the tool bar. 

Visualization Displays the visualization items on the tool bar. 

Format Displays the format items (i.e. number of decimals, station 
format, etc.) on the tool bar. 

COGO Key-in Displays the COGO Key-in box for entering commands in the 
dialog. 

Command Output Displays the Command Output Window in the dialog box, and 
controls options for the Command Output Window. 

Error Alert Enables the user to activate a beep and/or restore a minimized 
COGO dialog when an error occurs. 
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2.3.5   Tools Commands  

 

The Tools commands are detailed in the table below. 

Navigator Invokes the COGO Navigator. 

Inverse Calculates the distance and direction between points.   

Locate Stores a point not by specifying coordinates, but based on 
another point using several methods.  To locate by distance and 
bearing, use the Tools > Locate > Traverse as depicted in the 
dialog below. 

 

Intersect  Stores a point at the intersection of the defined elements 
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Best Fit  Calculates a best-fit chain through a set of points. 

Translation and Rotation  Moves, rotates, and scales a data set. 

Map Check  Stores and/or Edits a parcel. 

 

Roadway Intersection  Calculates data for the intersection of two COGO elements, 
usually chains. 

Cul-de-sacs  Calculates data for a cul-de-sac. 

Redraw Visualized Elements  Re-syncs the displayed COGO elements in the MicroStation file 
with the coordinate geometry data. 

Clear Visualized Elements 
(Temporary)  

Removes all temporary visualized elements from the view. 

Clear Visualized Elements 
(All)  

Clears all temporary and permanent visualized elements from 
the MicroStation file. 
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2.3.6   User Preferences 

 

The User Preferences (as displayed in the exploded view above) are detailed in the table below. 

Dialog Allows access to COGO Preferences dialog box. 

Redefinition of Elements Toggles the Redefine option on/off.  If Redefine is on, COGO data can 
be redefined/overwritten. 

Visualization Enables the elements to be displayed in the MicroStation file 
permanently or temporarily. 

Coordinate Display Toggles between displaying NE or XY coordinates. 

Angle Display Toggles between displaying Bearing or Azimuth. 
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2.4   COGO Navigator 
Feature / Function View, edit and display COGO elements. 

Tools 

 

COGO Menu Bar Tools > Navigator 

 

The COGO Navigator is a tool to easily view and edit COGO data. Store, edit, print elements, plus 
visualization and selection set commands are easily accessible via the Navigator, which can be 
accessed by the pull down menu COGO > Tools > Navigator or by the Navigator icon.  The 
following dialog appears. 

 
From the Navigator, points, curves, spirals, chains, survey chains, parcels, and profiles can be 
added, deleted, modified, identified, visualized, printed, or selected. 
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2.4.1   Navigator > Select Tools 
A variety of selection tools can be invoked via the Select pulldown, as depicted in the exploded view 
below. 

 

The tools are detailed in the table below. 

Select All Selects all data items of a certain type.  (I.e. all points) 

Invert Selection Selects all items not previously selected, and unselects all items previously 
selected. 

Clear Selection Unselects all items. 

Selection Set Allows the user to create a selection set that meets particular criteria.  
Same as using the Selection Set icon 

Fit View (Selection 
Set) 

Fits the selected items to the active MicroStation window. 

Show Selected 
Elements Only 

Only the items in the selection set are displayed in the MicroStation 
window. 

Show All Elements All items in the database are displayed in the MicroStation window. 
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2.4.2   Navigator > Tools 
A variety of tools can be invoked via the Tools pulldown, as depicted in the exploded view below.  
Many can also be invoked via the shortcut icons displayed at the top of the Navigator. 

 

Add Element 

 

Enables the selected type of element to be stored.  When selected, the 
appropriate Store Element dialog is invoked. 

Delete Element 

 

Deletes the highlighted of element. 

Edit Element 

 

Invokes the appropriate Store Element dialog, populated with the associated 
data of the selected element for editing. 

Identify Element 

 

When pressed and a COGO element is graphically selected, the element is 
highlighted in the display field.  If the selected element is not the displayed 
element type (i.e., curve or point), the element type is also changed.   

Print/Describe Element 

 

Displays the selected element’s data. 

Edit Element Feature Changes the feature code of the element. 

Visualize Element 

 

Displays the selected elements according to their feature code or default 
symbology. 

Unvisualize Element Un-displays the selected elements. 

Visualize All Displays all of the elements of a certain type, or all elements. 

Redraw Visualized 
Elements 

Re-syncs the coordinate geometry data with the data displayed in the 
MicroStation file. 

Clear Visualized 
Elements (Temporary) 

Clears only temporary visualized elements from the view. 

Clear Visualized Clears all visualized elements from the MicroStation file. 
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Elements (All) 

Settings Enables the user to define certain actions and behaviors of the Navigator. 

 

2.5   COGO Best Fit 
Feature / Function View and edit COGO points to determine best fitted alignment. 

Tools 

 

COGO Menu Bar Tools > Best Fit 

 

Based on a series of points the GEOPAK Best Fit Tool can determine the best fitting line, curve, or 
alignment using a combination of least squares methods and other residual based computations. 

The GEOPAK Best Fit Tool supports the following features: 

• Mass selection and sorting of points in any order or by key-in 
• Single solutions for lines and curves can be computed as well as an entire alignment of 

tangent curves 
• The user can automatically locate where the tangent and curve break points (Line to Arc) are 

or insert/delete them manually 
• The user can interactively force the geometry to the location desired by including/excluding 

points, changing weights, and/or designating how many and which points are between the 
break points  

• Instant visualization of where and what the residuals are and in which direction from the 
calculated geometry, by using color codes 

• Best fit residuals are always perpendicular to the computed geometry 
• Fast point and click navigation to the desired points of interest 
• The user is able to invert the list of points so that the desired direction of the line, curve or 

alignment is correct. 
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• The points are always read from the database on every calculation 
• Compound curves are automatically computed when curves overlap (no two consecutive 

curves can overlap) 
• To display points with offsets add the point to the list but do not include it in the calculation 

(turn it off by using the light bulb) 
• Full capability to modify the tangents and curves to the desired locations after the best fit has 

been done 
• Generates the required commands for automatic input into the GEOPAK coordinate 

geometry database file, with audit trail. 
The best fit tool should be used like a calculator to get the near best fit possible element for the given 
points, which can be accessed by the pull down menu COGO > Tools > Best Fit or by the Best Fit 
icon.  The following dialog depicted below is displayed.   

 

2.5.1   Best Fit > File 
This file is used to save the order of the points and the placement of the PCs and PTs and if the point 
is included in the computations of the best fit or not.  This file then can be imported (opened) back 
into the list at a later time in order to finish any modifications to the best fit list.  IMPORTANT!--Any 
modifications such as moving tangents or changing the radius of the best fit curves will not be saved 
in this file, it is strictly just to get the order of the points back in to the list.  This file can be modified to 
change the order or to place PCs or PTs if the user already knows where they need to be placed.  Be 
careful, all PCs have to have a coinciding PT following it further down in the list.  Changing the radius 
in this file will not change the radius in the dialog box.  Once the (.bft) file is opened, the best fit least 
squares routine will do the calculations.  Doing this sort of bypasses having to import the points all 
over again and then trying to figure out where the geometry (PCs and PTs) need to be. 

 

Open The Open option invokes a File Manager, wherein the Points (.bft) File may 
be selected.  One sample format of this file is depicted below.   
Point    Offset    Station    Weight    Include  
-----    ------    -------    ------    -------  
200     0.0000     0.0000       1         YES  
201     0.0000     50.0000      1         YES  
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PC      Rad=      2000.0000     Tan=    771.0674  
202     0.0000     100.0000     1         YES  
203     0.0000     150.0000     1         YES  
204     0.0000     200.0000     1         YES  
205     0.0000     250.0000     1         YES  
206     0.0000     300.0000     1         YES  
207     0.0000     350.0000     1         YES  
PT      ------     --------     ----      ----  
209     0.0000     450.0000     1         YES  
210     0.0000     500.0000     1         YES  

Save The save option saves current data to active file. 

Save As The Save As option saves current data to new file. 

2.5.2   How The Best Fit Process Works: 
Best Fit calculates the best fit line until geometry (PCs and PTs) are added to the list.   

If the there is only one PC and one PT and they are located at the ends of the list the result will be a 
best fit curve, only if the number of points between the PC and PT exceed the “Pass Thru Point” 
number. 

The process of computing the tangent curve alignments works by calculating the best fit lines and 
intersecting them to get the PIs.  It then computes the curves by least squares or by the average radii 
of the “Pass Thru” points to obtain a radius.  Once a radius is computed, the corresponding PI gets 
assigned the radius value and then the alignment is generated. (Piece Wise Method)   

2.5.3   Fit > Tools 
Add Geometry 
 (Best Guess) 

 

Commences the Best Fit processing.  Use this icon if you want to let Best 
Fit automatically determine where the PCs and PTs are to be placed.  It 
uses the “Max Radius” value to determine this “best guess” placement of 
geometry.  It will not place any PIs (point of intersections) for alignments. 
You will have to do this manually with the Insert Curve Tool. 

Delete All 
Geometry 

 

Deletes all geometry (PCs and PTs) created with the Best Fit 
Processing.   

Insert Curve 

 

Highlight the point in the Residual Display just above where the curve is 
to be added, then press the Insert Curve button.  The list box changes 
as depicted below where the new curve was added.  When a PC and  PT 
are adjacent to each other as shown, this tells best fit to intersect the two 
lines into a point of intersection (PI) or really it is a curve but it has no 
radius.  Only until there is a point between the PC pt1 PT will there be a 
curve radius calculated.  If there is only one point between, the curve will 
pass thru the single point exactly.  If there are two points between, the 
radius of the curve is determined by the average of the two separate 
radii. If there are four points between and the “Pass Thru Points” 
threshold is set to three the radius will be calculated based on a least 
squares routine instead of an averaging of radii. 
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Insert Tangent 

 

Highlight the point in the Residual Display just above where the PT and 
PC lines are to be added, then press the Insert Tangent button.  The 
lines are added as depicted  in the dialog below. 

 

A tangent can only be inserted within a curve (previous PC). When a PT 
and PC are adjacent, best fit will test to see if  the curves should be a 
compound or leave as a small tangent in the middle of two curves.  This 
tangent is considered to be unknown (less than two points on it), 
therefore both curves on each end have to be known (more than the 
“Pass Thru Points” number on it).  If an unknown tangent is adjacent to 
and unknown curve, the solution is impossible and the user will be told 
that there are Too Many Unknowns.  The quickest way to fix this is to 
make sure that all the tangents (PT .. PC) have at least two points 
between them or decrease the number “Pass Thru Points”. 

Invert List 

 

Pressing this icon inverts the Best Fit list.  For example, if the original list 
had 101, 102, PC, 103, PT, 104, and 105, and the icon was pressed, the 
inverted list would be 105, 104, PC, 103, PT, 102 and 101.  Pressing the 
icon reverts the list back to its original listing. 

Identify Point 

 

Press this icon, then select a point by data pointing close to it in 
MicroStation and the corresponding point will be highlighted in the 
Residual Display list. 
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Preferences 

 

 

Max Radius The Maximum radius should be set to a number that is just above what 
the user thinks is the largest radius throughout the series of points.  This 
does not mean that best fit will not calculate a radius above this number.  
This number is used only by the “Add Geometry Best Guess” icon when 
the user lets the computer figure out where the geometry (PCs and PTs) 
need to be placed. 

Pass Thru Points The number of Pass Thru Points can be set to any integer.  It is the 
threshold of where a curve gets calculated by least squares or by just 
averaging the radii of each curve projected (pass thru) through each 
point:  For example: if a curve has only 6 points to define it  (above 17.2 
.bft ) and the pass thru threshold is set to 4, the curve gets a radius value 
calculated based on a least squares routine. In this same example if the 
pass thru threshold was set to 8 the curve would get a radius value that 
is calculated from the average of all 6 radii by the tangent curve that 
passed through each 6 points separately, holding the known tangents 
(200-201 and 209-210). 

If the number of points on a curve (between the PC and PT) exceed the 
number of "Pass Thru Points" the result is a least squares calculation of 
the radius ... if under this threshold, the result is and average of the radii 
derived from having two tangents and passing a separate curve through 
each point. 

Max Shot Dist The Maximum Shot Distance should be set to a number that is just 
above the maximum distance between any two given points in the list.  
This value is very important for best fit to be able to automatically sort the 
points in order.  If best fit finds that this distance has been exceeded, it 
will give an error message saying so. 

Modify Elements 
(Done with Best 
Fit) 

 

At this point, if the user modifies any of the elements, the user cannot go 
back to the best fit without losing all of the modifications (changes in 
radius, tangents, etc) This means no moving points around or shifting the 
PCs and PTs or including/excluding any points in the list box. (anything 
that would cause the best fit to do a recalculation). 

 

The Dynamic Offset toggle allows the user to see the visualized offsets 
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as the elements are being relocated.  If this toggle is turned off the 
offsets will be displayed when the element modification has ceased. 

In this dialog, Points of Intersection can be modified.  Press the 
Identify PI button, then select a PI or end of a line on the screen.  The 
cursor is now attached to the selected element. Activate the desired 
locks and modify as desired.   

Another modification option is Modify Tangent, as depicted below. 

 

Press the Identify Tangent button, then select a tangent within the Best 
Fit elements on the screen.  The cursor is now attached to the selected 
element. Activate the desired locks and modify as desired.   

Another modification option is Modify Radius, as depicted below. 

 

Press the Identify Arc button, then select an arc within the Best Fit 
elements on the screen. This is done by clicking near the PI of that 
curve. The cursor is now attached to the curve.  Activate the desired 
locks and modify as desired.   

Store Elements 
into GPK 

 

 

When every element is considered to be the “best fit”, this icon will let the 
user store the line, curve, or alignment into the database file. 

The Starting Point, Line and Curve Name are specified by the next 
available element in the database, along with the Chain  
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2.5.3   Best Fit > Manipulating Points in the Residual Box 
The Residual Display group box contains the list box for points and associated data, edit buttons to 
add, edit, manipulate, and delete data in the list box, and Include / Exclude buttons to determine 
which data is included in the current Best Fit processing.   

Get Pts from 
Navigator 

 

For elements from the navigator, access the COGO navigator and highlight 
the desired point names.  Then press the icon.    GEOPAK automatically 
populates the dialog. 

Pts from 
MicroStation 
Selection 

 

For the selection set option, place the desired points in a MicroStation 
selection set, then press the icon.  GEOPAK scans the selection set and 
populates the dialog automatically. 

Pts from Key-in Key-in the range of points in any order, one at a time or all at once.  Best fit 
will then sort and order them based on the preferences set.  Once geometry 
(PCs PTs) has been added the keyed in points will be placed into the list box 
after the current high lighted point, no automatic sorting will be performed. 

Once the points are in the list box, they can be edited by use of the edit buttons located at the left 
side of the dialog and detailed below. 

Modify  

 

To modify, highlight the line to be modified and GEOPAK populates the edit 
fields.  Change the desired field(s), then press the Modify button.  This 
button is usually used to edit the weight of a given point. 

Delete 

 

To delete a point, simply highlight the line, then press the Delete button.  If 
the user deletes a PC the next PT will also be deleted. If the user deletes a 
PT the next PC will also be deleted. 

Delete All 

 

To delete all the points in the list box, press the Delete All button.  No 
highlighting is required.  

Move Up 

 

To move an entry up in the list box, simply highlight the line, then press the 
Move Up icon.  Each pressing of the button moves the line up one place, 
and moves other entries down.  No entry is deleted, their order is simply 
changed.  The top entry cannot be moved up.  A PC cannot be swapped 
with a PT. 

Move Down 

 

To move an entry down in the list box, simply highlight the line, then press 
the Move Down icon.  Each pressing of the button moves the line down one 
place, and moves other entries up.  No entry is deleted, their order is simply 
changed.  The bottom entry cannot be moved down.  A PC cannot be 
swapped with a PT. 
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PCs and PTs: 
The two terms (PC and PT) are just representations of  where the break between which points get 
calculated for a line and which are used for the curve.  They are not where the PC and PT are going 
to be placed, but the user should attempt to move these PCs and PTs to where the actual curves 
begin and end to get a better fit of the data. 

The user can change which points are utilized in the Best Fit, without deleting them from the list box.  
To accomplish this, the light bulbs located at the right side of the dialog are utilized, as detailed 
below. 

 

The bright light bulb (top) activates all Include toggles, regardless of their 
current status.  The darkened bulb (second one down) deactivates all 
Include toggles, regardless of their current status, which excludes them from 
the Best Fit.  The bottom two light bulbs activates and de-activates the 
Include toggle.  Note clicking on any line places the associated data directly 
below the list box AND changes the Include toggle from its current status.  
Note the column to the right of the Weight indicates whether the toggle is on 
(Included) or off (Excluded).  If the user double clicks on the point in the list 
box, the Include status is toggled YES/NO accordingly. 

The user can also change which points are utilized in the Best Fit, by giving them different weights.  
This is only used when the least squares methods are being used.  If you have nine points in the list 
and they all but one have a weight of 1 and the other has a weight of a 1000, the solution will be a 
line that gets really close to that one point because it got put into the calculations 999 more times 
than the other points. 

2.6   Additional Information 
Additional COGO commands and information can be found in the GEOPAK Manual, or on-line Help 
under Applications – GEOPAK Survey – Help – Coordinate Geometry. 
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Coordinate Geometry 
2.1   Basic Alignments 

Step 1. Open the MicroStation file c:\data\geo\vdot\s1373\s1373.dgn. 

Important:  Before beginning, attach saved view ALIGN. 

Step 2. Select the Coordinate Geometry icon. 

Step 3. The Coordinate Geometry (COGO) dialog appears. 

 

 This dialog is completely resizable, so you can position it where you’re most comfortable. 
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In the next few steps, we’ll use Coordinate Geometry to store the following alignment: 

 

Step 4. Turn on the PERMANENT Visualization on the main COGO dialog. 

Step 5. Select the Store Point icon as depicted below.   

 

 Store Point 100 with the coordinates shown.  
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Step 6. Select the Locate Traverse icon as depicted below. 

 

 Locate point 101 as shown. 

 

Step 7. Select the Store Curve from Tangents icon as depicted below.   

 

 Store the curve SR1373B-1 as shown.   

 

 Fill in the PC field and DB field by selecting the Visualized points.  
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  Note: The Direction Ahead (DA) is N 67 38 04.38 W. 

Step 8. Select the Store Curve from Tangents icon as depicted below. 

 

 Store the curve SR1373B-2 as shown.   

 
 Notice that we can identify points by the PI, PC and PT of curves, even though a stored 

point doesn't exist at those locations. 

Note:  The Direction Ahead (DA) is N 10 57 14.84 W. 
             The DB is “PI SR1373B-1 TO PT SR1373B-1”. 

Step 9. Select the Store Curve from Tangents icon as depicted below. 

 

 Store the curve SR1373B-3 as shown.   
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Note:  The Direction Ahead (DA) is N 16 50 41.68 E. 
             The DB is “PI SR1373B-2 TO PT SR1373B-2”. 

Step 10. Select the Locate Traverse icon as depicted below. 

 

   

 

Step 11. Select the Store Chain From Elements icon as depicted below. 

 

Store the centerline chain “SR1373B”. 

 

GEOPAK 2004 Edition  2-5 Coordinate Geometry  Lab:



GEOPAK®__________________________________________________________  

 You can fill in the Elements field by typing OR by graphically selecting the visualized 
elements in the design file. 

Step 12. Describe Cha “SR1373B.”   

 

  A fragment of the description is displayed below. 

 

Step 13. Save an audit trail of your commands.  You can access this dialog from the File > Utility 
pulldown and set the option toggle to Save. 
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Step 14. Save an output file.  You can access this dialog from the File > Utility pulldown and set 
the option toggle to Output. 

 

Step 15. Review the input file and output file using the GEOPAK editor. 

Step 16. Select the Navigator icon to access the Navigator dialog. 
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Step 17. Select points 100, 101, and 102 and Visualize by selecting the Eyeglasses icon. 

Step 18. Change the element pulldown to Chains and Visualize chain SR1373B. 

 

Step 19. Exit Coordinate Geometry. 

2.2   Additional Alignments – Graphical COGO 

Important:  Before proceeding, attach saved view BORROW. 

Step 1. Open COGO and turn on the PERMANENT Visualization on the main COGO dialog. 

Step 2. Select the Graphical COGO icon from the Road Tool Palette. 
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Step 3. From the Graphical COGO tool bar select the first icon for storing a point. 

 Store Point 200 using the dialog options as shown below. 

 

 

Step 4. Select the Locate point icon from the Store Elements tool bar as depicted below. 

 

 Locate Point 201 using the settings shown below. 

 

 The bearing from 200 to 201 should be N 41 30 00 W 

This will store point 201 using the bearing and distance above. Be sure to activate the Store 
Line toggle so as to store BP1 in the gpk file. 

Step 5. Locate Point 202 using the settings shown below. 
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 The bearing from 201 to 202 should be N 05 02 00 W 

Step 6. Select the Store Chain icon from the Groups tool bar as shown below. 

 

Step 7. Store the chain PIT as shown below by selecting the element BP1 and BP2 and using 
the dialog settings shown.  

 

 Below is an example of the correct syntax to store the baseline. 
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Step 8. Select the Navigator icon to access the Navigator dialog. 

 

 Select points 200-202 and Visualize by selecting the Eyeglasses icon. 

 Change the element pulldown to Chains and Visualize chain PIT. 
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2.3   Additional Alignments – Spirals 
Step 1. Open the MicroStation file c:\data\geo\vdot\s1373\s1373.dgn. 

Important:  Before beginning, attach saved view SPIRAL. 

Step 2. Select the Coordinate Geometry icon. 

Step 3. The Coordinate Geometry (COGO) dialog appears. 

 

 This dialog is completely resizable, so you can position it where you’re most comfortable. 

In the next few steps, we’ll use Coordinate Geometry to store the following alignment: 
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Step 4. Turn on the PERMANENT Visualization on the main COGO dialog. 

Step 5. Select the Store Point icon as depicted below.   

 

 Store Point 700 with the coordinates shown.  

 

Step 6. Select the Locate Traverse icon as depicted below. 
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Step 7. Select the Store Spiral icon as depicted below.   

 

 Store the spiral C6 as shown.   

 

  Note: The Direction Ahead (DA) is N 22 27 16 W. 

Step 8. Select the Store Spiral icon as depicted below. 
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 Store the spiral C7 as shown.   

 
 Notice that we can identify points by the TS or ST of spirals, even though a stored point 

doesn't exist at that location. 

Note:  The Direction Ahead (DA) is N 76 53 08 W. 

Step 9. Select the Locate Traverse icon as depicted below. 

 

 

GEOPAK 2004 Edition  2-15 Coordinate Geometry  Lab:



GEOPAK®__________________________________________________________  

Step 11. Select the Store Chain From Elements icon as depicted below. 

 

Store the chain “CHN1”. 

 

 You can fill in the Elements field by typing OR by graphically selecting the visualized 
elements in the design file. 

Step 12. Describe Cha “CHN1.”   

 

2.4   Additional Alignments – Import PLT 
The next exercise will review the process of importing VDOT’s traditional PLT files directly into 
COGO. 

Step 1. Open the MicroStation file c:\data\geo\vdot\s1373\s1373.dgn. 

Step 2. Select the Coordinate Geometry icon and open the desired gpk. 
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Step 3. The Coordinate Geometry (COGO) dialog appears. 

 

Step 4. Select from the File pulldown, the option to import the PLT file. File>Import>VDOT PLT 

 

Step 5. When the following dialog appears, use the File button to select the desired PLT file and 
then press the Apply button. 
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Step 6. This will process the PLT file into COGO, automatically storing the points, curves, spirals, 
and chains. 

 

Step 7. Once the COGO elements have been stored you can access the COGO Navigator to 
visualize them MicroStation. 
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2.5   Right of Way Commands in COGO 
This section discusses entering an existing parcel from a deed, offsetting a centerline chain and 
taking additional property from the parcel. During the course of creating the taking area, several 
coordinate geometry commands will be introduced. 

All exercises in this session use Coordinate Geometry JOB123.GPK and use the S1373.DGN file.   

Step 1. Open the S1373.DGN file and invoke the Project Manager.  

Step 2. Attach saved view PLAT. 

Step 3. Invoke Coordinate Geometry by accessing the GEOPAK Survey > Geometry > 
Coordinate Geometry.  Populate the dialog as shown below to access COGO. 

 

Step 4. The COGO session should have the Redefine toggle active, Visualization set to 
Permanent Visualization and the current Feature set to Off.  Depending on how your 
COGO view options are set, a portion of your screen may resemble the graphic below: 
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2.5.1   Parcel Editor/Map Check 
Below is a plat of the parcel we will store in COGO. 
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Step 1. Access the Map Check/Store Parcel tool by selecting Tools > Map Check.  The 
following dialog is displayed. 

 

Step 2. Enter the Parcel Name A by typing over the entry already present.  Press the Starting 
NEZ button and set the starting point as follows: 

 

Step 3. Close the Enter Starting Point dialog.  Set the Curve Parameters to Arc and Radius.  To 
enter data, fill in the edit fields just below the list box, then press one of the edit buttons 
located directly below edit fields.  Several buttons are supported: Add Below, Add After, 
Delete, and Modify.  Enter the first Bearing, Distance and PT / Desc Name in the edit 
fields just below the list box, as depicted in the graphic below.   
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 When complete, press the Add button directly below the edit fields.  The information is 
now displayed in the list box and the edit fields are cleared for subsequent input. 

Step 4. To add the first curve, leave the Bearing and Distance fields blank.  Populate the 
Radius, Arc, Direction, and Curve Name as depicted in the graphics below.   

 

Step 5. When the edit fields are populated, press the Add After (…+) button to add the 
information to the list box. 
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Step 6. Add in the next Bearing (be sure to change the W to E), and Distance.  Note the Pt 
Number automatically incremented.  Once the edit fields are populated, press the Add 
After (…+) button. 

 

Step 7. Continue adding information, utilizing the edit buttons.  If a line is entered incorrectly, 
highlight the line in the list box, change the incorrect data, then press the Modify (/) 
button.  The Clr Input button clears all data in the list box.  When complete, your dialog 
should match the dialog graphic below. 
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Step 8. Press the Closure button to check the closure.  The closure report appears in the COGO 
display output window.  One sample is depicted below. 

<*     1   $               Parcel Closure Report: A                              
                                                                                 
                                                                                 
<*     2   $ - - - - - - - - - - - - - - - - - - - - - - - - - - - -             
                                                                                 
                                                                                 
<*     3   $ Start Coordinates,  North: 401391.9210   East: 3470206.8160  Name:- 
 300                                                                             
                                                                                 
                                                                                 
<*     4   $  Line:   N 32^ 22' 7.00" W   Dist.: 192.2900  PtNum: 301            
                                                                                 
                                                                                 
<*     5   $  Curve: c1  Rad.: 844.1100  Delta:   1^ 53' 13.15" rt.  Arc: 27.80- 
00                                                                               
                                                                                 
                                                                                 
<*     6   $     Degree:   6^ 47' 15.77"  Tan.: 13.9013  Mid Ord.: 0.1145  Ext.- 
 0.1144                                                                          
                                                                                 
                                                                                 
<*     7   $     Chord Bearing: N 31^ 25' 30.43" W   Chord Dist.: 27.7987        
                                                                                 
                                                                                 
<*     8   $  Line:   N 55^ 53' 22.00" E   Dist.: 227.1100  PtNum: 302           
                                                                                 
                                                                                 
<*     9   $  Line:   S 34^ 06' 38.00" E   Dist.: 219.9700  PtNum: 303           
                                                                                 
                                                                                 
<*    10   $  Line:   S 55^ 53' 22.00" W   Dist.: 234.2600  PtNum: 304           
                                                                                 
                                                                                 
<*    11   $ End Coordinates,  North: 401391.9192   East: 3470206.8144           
                                                                                 
                                                                                 
<*    12   $ Error North: -0.0018   Error East: -0.0016                          
                                                                                 
                                                                                 
<*    13   $ Error Direction: N 40^ 22' 39.82" E   Total Distance Error: 0.0024  
                                                                                 
                                                                                 
<*    14   $ Error of Closure: 1/372826.4646                                     
                                                                                 
                                                                                 
<*    15   $ Perimeter: 901.4300                                                 
                                                                                 
                                                                                 
<*    16   $ Area: sq. Feet: 50789.6561  Acres: 1.1660                           
                                                                                 
 
 

Step 9. Once satisfied with the closure, press the Store Parcel button to store the parcel into 
COGO.  Commands are generated to store the parcel points and curves. 
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2.6   Translate & Rotate 
This section discusses using translate & Rotate application to adjust the parcel location. 

All exercises in this session use Coordinate Geometry JOB123.GPK and use the S1373.DGN file.   

Step 1. Open the S1373.DGN file and invoke the Project Manager.  

Step 2. Attach saved view PLAT. 

Step 3. From the Tools pulldown within COGO, select the Translate & Rotate option. 

 

Step 4. Once the dialog appears we will want to adjust everything related to the parcel as shown 
below. 
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Step 5. Once all of the information has been entered into the dialog press the Apply button to 
execute the command. 

Step 6. Now access coordinate geometry and Describe parcel A 
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2.7   Best Fit 
Step 1. Attach the saved view FIT. 

Step 2. Using the MicroStation Select tool, create a selection set of the displayed points. 

 You will want too turn OFF level 3 before creating the selection set. 

Step 3. Now from the Tools pulldown in COGO, select the Best Fit tool. 

 

Step 4. Choose the icon on the bottom of the Best Fit dialog to populate the display window with 
the points in the selection set. 

 

  This will populate the dialog as shown below. 
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Step 5. Now select the first icon Add Geometry on the top left of the dialog to let COGO apply a 
best guess of where the curves and tangents are located in the point data. This should 
now be represented graphically. 

Step 6. Proceed through the list of points until you reach the point shown in the dialog below. 

 

Step 7. Now select the Modify Elements icon to modify the tangent sections. 
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Step 8. Now change the settings as shown below so as to make modifications to the 
tangent section. 

 

Step 9. Select the Id Tangent button and dynamically slide the tangent on the screen to a more 
acceptable location to fit the points. 

Step 10. After the tangent has been placed, select the icon on the far upper right of the dialog and 
populate as shown below. This will allow us to store the alignment into the gpk. 

 

2.8…Export to ASCII 
Step 1. From the COGO File pulldown, select the Export option for writing out ASCII as shown 

below. 
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 This will invoke the following dialog. 

 

Step 2. From this dialog there are several option for controlling the filtering of points, by using the 
control toggles above each column. We will want to generate a list of the PI points 
created from the alignment we previously stored. Scroll down to the bottom of the list until 
reaching the 600 point range. 
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Step 3. Highlight the desired points to export, thus creating a selection set. 

Step 4. Once the dialog settings are made, select the Apply button to create the ASCII file. 

 

Step 5. Now you should have an ASCII file like the one shown below. 
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______________________________________SESSION 3 

Digital Terrain Model 
3.1   Introduction 
Objectives Learn how to create, display and analyze DTMs. 

Tools 

 

Menu Bar Application GEOPAK Road > DTM Tools 

 

A Digital Terrain Model (DTM) represents the topography of a project in the form of a triangulated 
network.  The DTM can be drawn in a 2D or 3D file, and then rotated to see the existing surface of 
the project area. 

Digital Terrain Models can be generated from various sources including MicroStation Elements, 
survey data, photogrammetry data, GEOPAK cross-sections, and geometry data. 

Triangulation is a mathematical process applied to ground points and vertices along longitudinal 
features to create planar surfaces.  The result of triangulation is the creation of triangles connecting 
these points. These triangles are included in the GEOPAK TIN file from which existing ground profiles 
and existing ground cross sections can be generated. 

3.2   Accessing 
Pressing the Existing Ground button from the Road Project: SR95.prj dialog 
within Project Manager invokes the tool frame shown to the right.  All of the DTM 
tools can be accessed from the tool frame or from the DTM menu that can be 
accessed from the top/left icon on the tool frame. 
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3.3   Settings 
Tool 

 

Menu Bar Settings > Stroking 

 

When the Stroking Options tool is opened, the dialog depicted below is displayed. 

 

Two user-defined stroking values can be defined before graphics can be extracted to create a DTM.  
Stroking is the process of automatically adding shots to the DTM Input file by interpolating new shots 
from the linear and curved sections of the data.  If the source topography data is mapped in a 3D-
design file, stroking may be applied.  Stroking is not available if the topography data resides in a 2D-
design file.  

Curve Stroke Tolerance The maximum distance between the arc and the chord used to 
approximate the arc in the DTM. Stroking is only applied to breaks and 
contours. 

Minimum Linear 
Distance 

If a linear segment is greater than the Minimum Linear Distance, points 
are interpolated and added to the segment such that the distance 
between the points in not greater than the Minimum Linear Distance. 
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3.4   Extract Graphics 
Tool 

                 
 

DTM Menu Bar Extract > Graphics 

 

The Extract Graphics tool reformats MicroStation elements into DTM input data.  When accessed, the 
dialog shown below is displayed. 

 

The fields/options are detailed in the table below. 

File Name  The name of the file to be created for storing the input data. 
The .dat extension is automatically assigned so the user is not required to key 
this in; however, an alternate extension may be defined. 
If file already exists, it may be found using the Files button. 

File Type  Format of the new file.  Either format produces the same results.  The difference 
between the two is ASCII files can be viewed and edited with any text editor 
while Binary files process faster, but cannot be viewed.   

For ASCII file designation, the user must define the number of decimal places 
for the data. 

File Open Indicates whether a file is being created (Create) or the user is appending data 
(Append) to an existing .dat file. 
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Feature Type This notifies GEOPAK of the feature type that the extract graphics will put in 

the DTM. 

 

Spots – Random survey points.  Can also be vertices of a Line or a Line 
String. 

Breaks – Designate linear features such as edges of pavement, ditch 
bottoms, ridges, etc.  No triangle leg will cross a Break. 

Boundary – The external boundary of the digital terrain model – only per 
.dat file. 

Contours – For use in extracting digitized or otherwise imported contours. 

Void – Closed shapes representing an area with missing data or obscure 
areas.  (I.e. ponds, headwalls, concrete pads, etc.) The void coordinates 
determine void lines, which are inserted as drape lines on the triangulated 
surface and do not alter the slope or elevations of the TIN. 

Island – Area within a void that contain data and should be included in the 
model. 

Graphic Triangle – For use in extracting triangles from a TIN model that 
has been otherwise created or imported. 

Drape Void – Same as Void, except the Void’s vertex elevations are 
ignored and the triangulated model elevations at these vertex points are 
utilized.  

Break Void – Same as Void, except the void elevations are included in the 
triangulated model at it’s x y coordinates; therefore, the slope and 
elevations are modified on the TIN surface. 
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Mode The Extraction mode calculates XYZ data directly from the coordinate values 

of 3D MicroStation elements.  The Interpolation mode produces XYZ data by 
interpolating between spot elevations along linear MicroStation elements.  This 
mode works in both 2D and 3D files wherein the elements are not represented 
with a defined Z value. 

Select Criteria 

 

The Select Criteria group box provides options to specify the features to be 
extracted.  When a "check" is placed in the box next to Levels, the Select box 
is activated.  Then press the Select button to invoke the Level Mask dialog 
wherein only those levels you want GEOPAK to search for when extracting data 
can be selected.  If the Levels box is not turned on, GEOPAK searches all 
levels.  The same procedure is utilized for other criteria selections.  The three 
buttons located at the bottom of the Select Criteria group box Match, Display 
and Reset enable the user to interactively define, highlight elements that match 
the search criteria or clear the search criteria respectively. 

Extract 

 

The Extract group box has several options for data extraction.  Complex 
Chain reads those elements along adjoining MicroStation elements.  Selection 
Set uses the MicroStation selection set tools to identify elements to extract.  
Fence extracts all elements within a fence boundary.  View1, View2, View3, 
etc. extracts all selected elements displayed in the selected view. 
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3.5   Build Tools 
Tools 
 

 

Menu Bar Build > Triangle 
Build > Lattice 
Build > Merge TINs 
Build > Clip TIN 
Build > Pad 
Build > Delta Surface 

 

Included under the Build pull down and icons are options for creating, manipulating and merging 
DTM models.  This class addresses, in detail, only those options utilized in routine DTM operations.  

3.5.1   Build Triangles 
Tool 

 

DTM Menu Bar Build > Triangle 

 

The Build Triangle tool processes the information stored in a DTM input file (.dat) to create a 
triangulated model (TIN). The file extension TIN (which is automatically assigned) represents a 
triangulated irregular network.  When invoked, the dialog depicted below is displayed. 
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The fields/options in the dialog are detailed in the table below. 

Data File  The DTM input file where the extracted topological features are stored.  
The file can also be selected via the Files button.  If the full path is not 
given, GEOPAK utilizes the working directory to locate the file. 

TIN File  The filename in which the DTM data will be stored in a binary format.  
The file can also be selected via the Files button if the file exists.  If the 
full path is not given, GEOPAK utilizes the working directory to locate 
the file. 

Dissolve Option  This option will allow the elimination of external triangles based on the 
selected option. Note that internal triangles are not affected. The three 
options are: 

None - no external triangles are deleted. 

Sliver - long, thin triangles based on a hard-coded formula within the 
software are deleted. 

Side - external triangles where a side is longer than the user specified 
length are deleted. 

Process Commences the TIN creation process. 

 

3.5.2   Additional Build Options 
Tool 
 

 

Menu Bar Build > Additional Tools 

 

Several additional Build tools are supported, which are detailed in the table below. 

Lattice Creates a gridded mesh (.lat) of the triangulated data (TIN) to create a 
three dimensional visual display of the topography. 

Merge TINs Two triangulated models to be merged together as long as the boundaries 
of one model overlaps the other at a minimum of one point.  This process 
creates a third model (TIN) from the combination of the two existing 
models.   

Clip TIN Creates a new model (TIN) from a portion of an existing model. The area 
is defined as internal or external to a user defined polygon. 

Build Pad Defines a pad (such as a building) and integrates the pad into the existing 
terrain with a variety of slope options. 

Build Delta Tin Creates a new model based on the difference between two other models 
or a model and elevation surface. 
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3.6   Reports 
Tools 

 

Menu Bar Reports > Duplicate Points 
Reports > Crossing Features 
Reports > Tin Statistics 
Reports > Lattice Statistics 

 

Options under the Reports pull down and tool frame include a way to check for duplicate points or 
crossing breaklines, and the ability to generate statistics associated with a TIN or Lattice file. Each 
report is described in the table below. 

Duplicate Points  Reports points with the same x and y coordinates 

Crossing Features  Reports intersecting (same xy location, varying z) breaklines or 
contours. 

Triangle Statistics  
Lattice Statistics  

Displays a summary indicating the total count of each element type and 
minimum and maximum X, Y, Z ranges for the specified TIN or LAT file. 

 

3.7   Utilities 
Tools 

 

Menu Bar Utilities > Convert TIN 
Utilities > ASCII to Binary 
Utilities > Binary to ASCII 
Utilities > Check Triangulation 
Utilities > Metric to English 
Utilities > Export Lattice to Trimble 
Utilities > Import XML 
Utilities > Export XML 

 

Tools under the Utilities pull down and tool frame include a way to check the validity of a triangulated 
file, converting triangulated files from previous versions of GEOPAK, converting the DTM data file 
between ASCII and binary format; as well as exporting the LATTICE information to the Trimble DTX 
format.  They are detailed in the table below. 

Convert TIN  Converts a pre-GEOPAK 98 triangulated file to the current format. 

ASCII to Binary  
Binary to ASCII  

Reformats the DTM data file (.dat). 

Check Triangulation  Verifies the integrity of the triangulated file.  A message appears 
indicating "Triangulation Valid" if the file structure is intact. 
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English to Metric 
Metric to English 
Metric to Imperial 
Custom 

GEOPAK TIN files are neither English nor metric.  English and metric 
preference settings within GEOPAK are for volume purposes and do 
not affect the TIN.  This utility converts an entire TIN file with optional 
translation and rotation tools. 

Export Lattice to Trimble This tool utilizes a lattice file to generate a Trimble DTX file suitable for 
use in Trimble field equipment. 

Import XML Allows the importation of XML data into a .dat file for triangulation. 

Export XML Allows the exportation of .tin data to an XML format. 
 

3.8   Load DTM Features 
Tool 
 

 

Menu Bar Load > DTM Feature 

 

Load is the process by which we can visualize the DTM data, TIN model, lattice model, and contours.  
By selecting the Load DTM Feature icon, the following dialog appears.   

 

The user can choose to load the DTM data (.dat), the TIN file (TIN), or the Lattice file (.lat).  Each of 
these files can be loaded for the model extents, within a fence, or selected view. 

Activating the Display Only toggle enables the user to view the elements without writing them to the 
MicroStation file (temporary display).  Conversely, deactivating the toggle writes the DTM features to 
the MicroStation design file at the defined symbology. These elements can be placed as a graphic 
group when Display Only is deactivated. 
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 Activates the display of all Features. 

 Turns off the Display of all Features. 

 Turns on only the selected Feature. This can also be accomplished by activating the toggle 
(below the list box) or double-clicking on an item that is turned off within the list box. 

 Will turn off only the selected item. This can also be accomplished by activating the toggle 
(below the list box) or double-clicking on an item that is turned on within the list box. 

3.9   Edit Tools 
Tools 

 

Menu Bar Edit > Triangles 
Edit > Duplicate Points 
Edit > Crossing Features 
Edit > Filter Vertices 
Edit > Join Linear Features 
Edit > Z Range Clip 

GEOPAK supports an extensive range of powerful editing tools, both pre- and post TIN generating.  
The tools are detailed in the table below. 

 

Triangles The triangulated model can be dynamically edited in terms of adding, 
deleting or moving spot elevations.  Break lines can be added, draped or 
deleted.   

Duplicate Points  Interactive editing of points in a DTM data file with the same X and Y 
coordinates within the data (DAT) file. 

Crossing Features  Interactive editing of crossing break lines and extracted contours within the 
data (DAT) file. 

Filter Vertices  Removes vertices from break lines or extracted contours  within the data 
(DAT) file when located within the specified Tolerance of another vertex. 

Join Linear Features  The Join Linear Feature is useful when the source break line or contour 
line consists of several elements containing numerous vertices.  In these 
cases, the end of one break line is the beginning of the next break line, so 
the software utilizes this as two separate break lines.  During the Joining 
process, GEOPAK changes these from the beginning and end of individual 
elements to the beginning and subsequent shots of one element. 

Z Range Clip  Deletes individual vertices from the data file (.DAT) based on a user 
defined elevation range. 

GEOPAK 2004 Edition Digital Terrain Model    3-11 



GEOPAK®__________________________________________________________  

3.10   Analysis Tools 
Tools 

 

Menu Bar Analysis > Height 
Analysis > Profile 
Analysis > Volumes 
Analysis > Elevation Differences 
Analysis > Slope Area 
Analysis > Themes 
Analysis > Drainage Tools 
Analysis > Visibility 
Analysis > Trace Slope Path 
Analysis > DTM Camera 
Analysis > Trench Volumes 

 

The Analysis tools allow the user to visually analyze the digital terrain model utilizing numerous tools 
as a profile analysis, thematic analysis, drainage flow patterns, and visual portions on the model from 
any given location. 

 
Height To determine the height and other associated data dynamically based on user-defined 

data points within the model. 

Profile View a profile based on a user defined MicroStation element. 

Volumes To compute the volume between two TIN models, the volume between a TIN model and a 
plane, or the cut and fill totals between two TIN models while applying a shrinkage/swell 
factors. 

Elevation 
Differences 

Will display the elevation difference, or the amount of cut and fill between two TIN models, 
or a TIN model and a plane of constant elevation. 

Slope Area The Slope Area tool displays the horizontal area and actual slope area (area following the 
terrain of the Model). 

Themes Displays the digital terrain model based on different user definable themes such as 
elevation ranges, slope percentage, slope degree, or aspect. 

Drainage Displays and analyzes drainage patterns within a TIN model.  Tools include delineating 
watersheds, drawing flow arrows, determining upstream and downstream traces, finding 
high and low points, and ridge and sump lines. 

Visibility Based on a user-defined point of origin, GEOPAK visually displays which triangles can 
and cannot be seen, or what is visible between two points. 

Trace Slope 
Path 

Traces a path along a tin. 

DTM Camera Views a 3D terrain model in a MicroStation 3D model 

Trench 
Volumes 

Computes trench and bedding volumes from Drainage Project 
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Review of the steps required in creating a surface model and its subsequent output. 

Digital Terrain Model (TIN) 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Analysis 

Ground Profiles & 
Cross Sections Display Features 

Build Lattice 
Build Pad 

 

Triangulated Irregular Network 
TIN 

Triangulation 
(Build Triangles) 

Data File 
DAT 

Feature Types: Spots 
 Breaks 
 Voids 
 Contours 

Boundaries 
Islands 
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3.11   Digital Elevation Models - Importing DEM Files 
A Digital Elevation Model (DEM), consists of a sampled array of elevations for ground positions that 
are normally at regularly spaced intervals.  The basic elevation model is produced by or for the 
Defense Mapping Agency (DMA), but is distributed by the USGS, EROS Data Center, in the DEM 
data record format.  A wealth of information on DEM formatted data can be obtained from 
www.usgs.gov.  When the DEM option is selected in the center section of the dialog, the dialog 
changes to reflect the selection. 

 

 

Within the Input DEM File group box, the data format is 
selected.  The group box changes based on the 
selection.  Once the selection is made, the File Name 
may be typed in, or selected via the Files button. This 
portion of the dialog also provides control for filtering the 
number of points to import. This is necessary due to the 
raw DEM file having a tremendous amount of point data. 
The filter facilitates a more manageable file size based 
on a user definition.  

Once the file is read, the DEM Coordinate system group 
box is populated automatically.  Therefore, the DEM 
Coordinate System group box is display only and the 
values cannot be edited. 
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The Output Coordinate System box includes 
System type, Ellipsoid, and Zone.  As each 
system is selected, the ellipsoid and zone 
unghost as needed.   

 

 

The Output DAT File group box has a single 
key-in field for the file name of the DAT file to 
be created.  This file can be used within the 
Build Triangles dialog in the DTM tools.  
Manually enter the file name or select via the 
File button. 
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_____________________________________EXERCISE 3 

Digital Terrain Modeling 
3.1   Accessing DTM Tools  

Step 1. Open the MicroStation file c:\data\geo\vdot\s1373\s1373.dtm.   

 Access Applications>GEOPAK Road>DTM Tools.   

Step 2. This invokes the DTM Tool Frame.   

 

3.2   Extract Graphic Elements 
 

 
 

Step 1. Select the Extract Graphics icon from the tool frame to invoke the following dialog. 
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Step 2. To extract the ground spot shots, complete the dialog as indicated below: 

File Name ground.dat 

File Type ASCII 

File Open Create 

Feature Spots 

Mode Extraction 
 

 

Step 3. Set the appropriate level for the graphical elements that you wish to extract as Spots.  
Activate the Level Numbers toggle, and press the Select button beside Levels to invoke 
the Level Mask dialog.  Select level 13 and press OK. 

 

Step 4. Ensure that the entire design file has been fit into View 1. 

Step 5. Press Apply to initiate the Extraction of the Spots. 

Step 6. Proceed to extract the Breaks as defined below: 
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File Name ground.dat 

File Type ASCII 

File Open Append 

Feature Breaks 

Mode Extraction 

  

 

 Notice that when the Feature type is switched to Breaks, the Stroking button is 
accessible from the Extract Graphics dialog. Access the Stroking Options dialog by 
pressing this button and populate the dialog as shown below.  

 

 Close the DTM Stroking Options dialog. 

 Also, we are adding the Break elements to the .dat file; therefore, we are Appending 
rather than Creating. 

 Set the Level for the Breaks to Level 14. Be sure to turn off Level 13. 

Step 7. Again, ensure that all graphic elements are fit into View 1 and Press Apply. 

Step 8. Lastly, we will extract the graphical element representing the Obscure area as a Drape 
Void. This will be to ensure that the elevations at the Void coordinates are included in the 
surface model and the slopes will be resolved to the Void when triangulation occurs. 

File Name ground.dat 

File Type ASCII 
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File Open Append 

Feature Drape Void 

Mode Extraction 

 

Step 9. Set the Level for the Drape Void to Level 15. Be sure to turn off level 14. 

Step 10. Ensure that the obscure area is contained within View 1 and press Apply. 

Step 11. Close the Extract Graphics dialog and Save Settings. 
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3.3   Build TIN 
 

  

 

Step 1. Select the Build TIN icon from the tool frame to invoke the following dialog. 

 

Step 2. To Build the TIN file, complete the dialog as indicated below: 

Data File ground.dat 

TIN File ground.tin 

Dissolve Option Side 

Side Length 150 

 

Step 3. Press the Process button to initiate the creation of the TIN file. 

Step 4. Close the Build Triangles dialog and Save Settings. 
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3.4   Display DTM Features 
 

 
 

Step 1. Select the Load Features icon from the tool frame to invoke the following dialog. 

 

Step 2. Change the Load File option to TIN. 

Step 3. Select the TIN file ‘ground.tin’ by pressing the Files button. 

Step 4. Select the Triangles Feature by highlighting in the list box. Notice that initially the display 
is set to OFF. You can control the display of an item three ways: 

  Use the “lightbulb” icons to the right of the dialog  

  Double-click on an item 

  Use the “display” toggle in the lower right corner of the dialog 

  Set the Triangles display to ON. 

Step 5. Set the display symbology for the Triangles as indicated below: 

 

Step 6. Select the Tin Hull (the boundary of the surface model) feature. Activate the Display of 
the feature and set the symbology as follows; Level = 30, Color = 0, Weight = 0, Style = 
0. 
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Step 7. Select the Contours feature. Activate the Display Feature.  Verify that On is set in the 
Display field. 

Step 8. Complete the bottom of the dialog as indicated below. To complete the Minimum and 
Maximum Z, Press the Read button, which will review the active TIN file and determine 
these values. 

 

Step 9. Activate the Display of the Contour Lines and Labels and set the symbology as 
indicated below: 

 Level Color Weight Style Font Th / 
TW 

Distance 

Major Lines 10 4 3 0    

Major Labels 10 4 3 0 23 TH=6 
TW=6 

100 

Minor Lines 9 7 1 0    

Step 10. Set the Load option to Extent, activate the Graphic Group toggle and activate the 
Display Only toggle. 

Step 11. Press the Load button to initiate the process. 

Step 12. Close the Load DTM Features dialog and Save Settings. 
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3.5   Analysis Tools 
We will review several analysis tools in the following exercises.  These include the height, themes, 
and profiles tools. 

3.5.1   Height Tool 

 

 
Step 1. Select the Height icon from the tool frame to invoke the following dialog. 

 

Step 2. Activate the Show Contour and Show Flow Arrow 
toggles. The color may be altered to your choice of colors from 
the active color table on the Height dialog. The weight of the 
contour line and arrow are controlled by the active MicroStation 
settings. 

Step 3. Press the Dynamic button and scan the surface 
model with the cursor to display the values for xyz and the slope 
on the model at the cursor point. 

Step 4. The DP option can be utilized to review this 
information at a specific location and the Draw option will label 
the elevation at the selected data point. 

Step 5. Close the Height dialog. 
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3.5.2   Themes Tool 

 
 

 

Step 1. Select the Themes icon from the Analysis tool box to invoke the dialog depicted below. 

Step 2. Ensure that all graphic elements are Fit in 
View 1. 

Step 3. We will determine the Elevation Range first 
for the TIN File ‘ground.tin’. (This is the first icon on the 
dialog). 

Step 4. Activate the Display Only toggle and the 
Fill toggle. 

 

Step 5. Next, press the Set Range button to access the following dialog. 
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As shown on the right of the Minimum and Maximum Elevation Fields, the values for the active TIN 
elevations are listed.  By pressing these buttons individually, the elevation fields will automatically be 
populated. 

Step 6. Set the Range option to Auto Range Increment. 

Step 7. Set the Auto Range Options as shown below: 

 

Step 8. Press the Set Range button to populate the list box on the bottom portion of the dialog. 

 Selection of any list of elevations will populate the fields at the bottom.  

 

 Utilizing the buttons on the right side of the list box will permit additional ranges to be 
included in the list, modifications to be made to elevation ranges (or the color display of this range), or 
deleting a particular elevation range. 

Step 9. Close the Elevation Range dialog (select the X in the upper right hand corner of the 
dialog). 

Step 10. Press the Process button to initiate the display of the Elevation Ranges for the surface 
model. 

Step 11. Close the Themes dialog and Save Settings. 
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3.5.3   Profile Tool 

 
 

 

Step 1. Select the Profile icon from the Analysis tool palette to invoke the following dialog. 

 

Step 2. Use the Selection tab to identify your surface model (TIN File) which you will generate a 
profile from, and the symbology for your profile. 

Step 3. Select the Tin File ‘ground.tin’ by using the Files button. 

Step 4. Double-click on the symbology box (field to the right of the Files push button) to set the 
symbology representing the ground surface profile. You may choose any symbology you 
wish. Once the symbology has been set, press OK. 

Step 5. Press the Add icon (top icon next to the list box) to add the feature to the collection box. 
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Step 6. Select the Profile Tab. 

Step 7. Press the  Place Element button to cut your actual profile at any desired area by just 
placing two data points (i.e. a line) or a series of data points (i.e. a line-string) across your 
surface model at any location. 

 

Step 8. You can use the Preferences tab to set up a grid for your profile if desired. 

Step 9. Close the Profile dialog and remove the DTM Tools tool frame. 
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3.6 Prismoidal Volumes 
Step 1. From the DTM tool palette select the Analysis>Volumes tool. 

 

Step 2. Make the settings as shown below and select the Process button. 

 

Step 3. Now select the “slam down” button to expand the dialog and fill in as shown below. 
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Step 4. Select the Process button again and then review the file volume.txt to see the final 
calculations. 
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3.7 TIN Editing 
Step 1. Attach the saved MS saved view Edit. 

Step 2. From the DTM tool palette select the Edit Tin icon. 

 

Step 3. This will invoke the 2 dialogs shown below. Make the appropriate settings in the Display 
Settings dialog and select OK. 

   

Step 4. The graphic below identifies a bad shot in the tin file that we will edit in order to clean up 
the tin file. 
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 In order to edit the tin file we need to delete this point and allow the tin to re-triangulate 
the area that is affected. To do this, select the Delete Vertex option from the Tin Edit Tools dialog. 

Step 5. In the delete vertex dialog make sure the Edit toggle is set to Re-Triangulate. 

 

Step 6. Select the Id Vertex button from the dialog and the Id the vertex on the triangles that you 
wish to delete. 

Step 7. Once the Id is made, one more data point to accept the selection will initiate the 
command. 
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Digital Elevation Models 
3.8 Importing DEM Files 

Step 1. Open the file C:\data\geo\vdot\dem\dem3d.dgn 

Step 2. Select the icon for importing DEM files. 

 

Step 3. Using the File button in the Input DEM File portion of the dialog, choose the file 
C:\data\geo\vdot\dem\0001.DEM 

 

Step 4. Once the file has been loaded select the Inquire button to populate the DEM Coordinate 
System portion of the dialog. This process reads the vital information from the DEM file 
and displays it for review. 
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Step 5. Referencing the information in the DEM Coordinate System portion of the dialog, make 
the appropriate settings in the Output Coordinate System portion of the dialog. 

 

 If it is desirable to convert to State Plane Coordinates then settings make be changed to look 
something like the dialog below. 

 

Step 6. The last setting is to assign an output file to write the converted points to. This is done by 
entering a file name into the field in the Output DAT File portion of the dialog. 

 

Step 7. Once this is done, select the Apply button to convert the DEM file. 

Step 8. After the conversion is complete, select the Build TIN icon from the Build tool bar. 

 

Step 9. Using the Files button select the DAT file that was created in the previous steps. 
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Step 10. Now provide the TIN file name and select the Process button. 

 

 Once the TIN has been created any of the query or display tools may be used to review, 
analyze, or edit the tin file. 
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Existing Ground Cross Sections 
4.1   Introduction 
Objectives To generate existing ground cross sections based on a horizontal 

alignment and the surface model beneath the alignment, and to review the 
sections utilizing the Cross Section Navigator tool. 

Tools 

          

Menu Bar Application GEOPAK Road > Cross Sections > Draw Pattern by Station Range 
GEOPAK Road > Cross Sections > Ground Cross Sections from DTM 
GEOPAK Road > Cross Sections > Navigator 

 

The prerequisites to generate existing cross-sections utilizing digital terrain modeling are: 

• ·GEOPAK coordinate geometry database wherein the horizontal alignment is stored. 
• ·GEOPAK binary TIN file, Site Model or Site Object.  If you have not already created your 

binary TIN file, see the DTM online documentation for a detailed discussion of the Digital 
Terrain Modeling features.  The Site Model or Object are created utilizing GEOPAK Site 
Modeler software and are stored within the GEOPAK Site project (gsf) file. 

• Pattern lines if pattern by design is to be utilized. 
 

The generation of existing ground cross sections must be invoked from within the 2D MicroStation 
design file wherein the sections are to be drawn.  GEOPAK does not create this MicroStation design 
file.  The user creates the blank design file utilizing the desired seed file, and then GEOPAK draws 
into it. 
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4.2   Pattern Lines 
Project Manager Draw Pattern 

Tools 

      

Menu Bar Application GEOPAK Road > Cross Sections > Draw Patterns By Station Range 

 

Pattern lines are graphical lines and/or line strings in a MicroStation design file that define locations at 
which the cross sections will be cut. 

From the Project Manager you will select Draw Pattern, and create or select an existing run.  When 
completed, the following Draw Pattern Lines dialog appears.  

 

Once all of the fields have been completed, and the application is initiated, graphic lines (on the 
specified level, color and style) are drawn along the chain.  This is a visual representation of the 
location of the cross sections to be generated. 

Six methods are supported for drawing the pattern lines: 

• Increment – starts at the beginning station, and draws a pattern line at the given increment. 
• Even – draws pattern lines at stations divisible by the given value. 
• Once – draws a pattern line at a given station. 
• Control Points Horizontal – draws a pattern line at each of the critical point (i.e. POT, PC, PT, 

etc.) within a chain. 
• Control Points Vertical – Draws a pattern line at each VPC and VPT in addition to the sag 

and crest station of vertical curves based on the profile defined in the dialog. 
• Superelevation Transitions - The current design file is scanned for Superelevation shapes 

created with the specified chain.  A pattern line is drawn at the beginning and end of each 
Superelevation shape, ignoring the beginning and ending station fields in the dialog.  Note 
the Superelevation shapes cannot be in a reference file. 

 
The pattern lines are drawn into the current MicroStation design file.  The user can use the 
MicroStation Place Smartline or Place Line command to draw additional pattern lines at any user 
defined location.  In addition, MicroStation commands can be utilized to modify pattern lines drawn 
via the dialog to lengthen, shorten, delete, copy, move, etc.   

NOTE: This should be completed before the existing ground cross sections are generated. 
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4.3   Generating Cross Sections 
Tools 

  

Menu Bar Application GEOPAK Road > Cross Sections > Draw Cross Sections from Surfaces 
 

Once the pattern lines have been drawn, the cross sections can be generated.  Note the Job Number 
must be defined in order to populate the Chain list.  Once the Chain is defined, the dialog unghosts 
as depicted below. 

 

The rest of the dialog consists of a menu bar with three listings: 

File Standard file utilities to load, or save settings, plus a dialog exit 
option. 

Edit Options to Cut, Copy and Paste rows in the surfaces list box.  Also, 
save and restore settings in the RSC file or clear list of all surfaces. 

Update Options: User-defined options on how the software handles the redrawing of 
cross sections. 

Delete Existing Elements 
and Redraw  

When this option is activated, any existing ground lines previously 
drawn with this tool are deleted and new ground lines are drawn. 

Delete Non-modified 
Elements and Redraw  

When this option is activated, any existing ground lines previously 
drawn with this tool are deleted and new ground lines are drawn. 

Draw on Top of Existing  When this option is activated, any previously drawn ground lines are 
ignored and a new set is drawn, resulting in two sets of ground lines. 

Query When activated, the user is prompted each time the Draw button is 
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pressed. 

 

 

Two tabs on the dialog support the input data required to draw cross sections: 

XS Cells  Defines the location of cross sections utilizing either pattern by station or 
pattern by design.  In addition, the scale and spacing are defined on within 
this tab. 

Surfaces Define the surfaces utilized for drawing cross sections.  Note multiple 
surfaces may be drawn in a single processing.  Source data includes 
GEOPAK TIN files, Site Models, or Site Objects. 

 

On the XS Cells tab, the Pattern group box has three choices: 

Pattern by Station  Utilizes Begin and End Station values in addition to an Increment/Even option 
and Left and Right Offset fields to determine cross section location.  This 
works well when no sections are needed that are at odd stations, skewed or 
kinked relative to the Chain. 

Pattern by DGN  This method utilizes graphical representation and draws one cross section for 
each line or line string of the specified parameters.  Those parameters include 
Design File which is the name of the file that contains the lines and line 
strings in addition to their associated symbology. 

In Existing Only  No user input is required, as this option draws ground lines only for cross 
section cells which were previously drawn.  Therefore, no other pattern 
requirements are needed. 
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4.4   Cross Section Navigator 
Project Manager Not accessible from within Project Manager 

Tools 

  

Menu Bar Application GEOPAK Road > Cross Sections > Navigator 

 

The Cross Section Navigator tool is used to view and traverse between cross sections.  It can also be 
used to draw cross section information. 

When the Navigator is invoked, the following dialog appears.  

 

The user can scan through the cross sections by either choosing the station from the drop down list, 
or by using the First Section, Previous Section, Next Section, or Last Section icons (arrowheads).  
The Reset Navigator icon window centers the current station to the view.   

 

The Open View Control Dialog enables the user to open several windows to view different 
portions of the cross section at the same time.  The user can view the whole cross section in 
view 1, the left side in view 2, and the right side in view 3, etc. 

 

Cross section elements can be added or modified using MicroStation tools or GEOPAK cross section 
drawing tools, as detailed in the table below. 

DP Offset Elevation 

 

Data points at a given offset/elevation, or find the offset/elevation of the cursor 
location. 

 

DP Delta Distance Slope 

 

Draws a line at a given horizontal distance and slope.  

 

XS Active Angle Tool 

 

Sets the active angle to the given value.  If a MicroStation tool is used with the 
active angle option, this value is used. 

 

Draw XS Line  Draws a cross section line.  The length and/or slope can be specified.  
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4.5   Summary - Basic Steps to Creating Existing Ground Cross 
Sections from a DTM 

Step 1. Requires a horizontal alignment stored in  *.GPK file. 

Step 2. Requires an existing triangle file (TIN) from a DTM. 

Step 3. Draw pattern lines. 

Step 4. Process cross sections through GEOPAK. 

Step 5. Review and modify (if necessary). 
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Existing Ground Cross Sections 
4.1   Draw Patterns 

The first step is drawing MicroStation lines or line strings to define the location of the existing ground 
cross sections.  

Step 1. Open the MicroStation file c:\data\geo\vdot\s1373\s1373.dgn 

 Attach the saved view called borrow. 

Step 2. Select the Draw Pattern button from the Applications>GEOPAK Road>Cross 
Sections>Draw Patterns By Station. 

Step 3. Populate the dialog as depicted below.  

 

Step 4. Press Draw Pattern Lines to initiate the plotting of the patterns into the design file. 

Step 5. Change the interval toggle to Once. Since the pit begins and ends between nominal 
cross sections we will add one for the beginning and end. 
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Step 6. To place a pattern at that station, key in the station value and press Apply. 

 

Step 7. Repeat the process for the ending station of the pit. 

 

Step 8. Review the pattern lines. 

Step 9. Exit the Draw Pattern dialog and Save Settings. 
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4.2   Generate Existing Ground Cross Sections 
Step 1. Open the MicroStation file c:\data\geo\vdot\s1373\xs.dgn 

Step 2. Select Applications>GEOPAK Road>Cross Sections>Draw Cross Sections from 
Surfaces. 

Step 3. Generate the existing ground cross-sections by populating the dialog as shown on the 
following dialogs and pressing the Draw button to initiate the routine. 

      

Step 4. Exit the dialog and Save Settings. 
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4.3   Review Cross Sections 

     
 

 

Step 1. Select the Cross Section Navigator tool from the Road Tools tool frame. 

 

Step 2. Use the Cross Section Navigator to browse and check your existing cross sections.  

Step 3. Exit the XS Navigator dialog when done.  

Step 4. Upon reviewing the sections, it is desirable to “lock” the elements to prevent accidental 
deletion or modification in later steps.  Click Edit > Select All from the MicroStation 
menu bar.  Then click Edit > Lock to lock the elements. 

4.4   Generating Additional Cross Sections (Borrow Pit) 
Additional cross sections may be desired if surveying a borrow pit or waste mound. The next steps 
will show how to add sections to the existing ones created in the previous step. 

Step 1. Access the Draw Cross Sections from Surfaces dialog. 
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 The symbology should appear as shown in the dialog below. 

 

Step 2. This time we can either add the new sections to the list box and process both existing 
and new.  Or delete the previous run and simply process the new. For this exercise we 
will add the pit and process both. 

 

 The symbology should appear as in the dialog below. 

 

Step 3. Press the Draw button and close the dialog. 
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4.5   Closure Report 
Invariably additional cross sections will not tie precisely to the existing ground cross sections. The 
Closure Report will automate the process of connecting non-tied slopes. 

Step 1. Access the Cross Section Reports dialog. 

 

Step 2. From the reports dialog select the Closure Report. 

 

Lab: 4-6    VDOT Survey Training - Lab Exercises GEOPAK 2004 Edition 



__________________________________________________________GEOPAK® 
Step 3. Using the icons shown below identify the existing and as-built surfaces by setting the 

symbology for each, as shown in the dialog below. 

 

 

Step 4. Now select the desired method of correction in the Closure portion of the dialog. We will 
select slope extension for both the left and right sides of our sections. 

 

Step 5. Once done, select the Output Options button so we can set the desired output. 
Complete the dialog as shown below and close. 
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Step 6. From the main dialog press the Apply button. 

 

Step 7. Using the text editor, open the closure.txt file and review the closure operations. 
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______________________________________SESSION 5 

Design and Computation Manager 
5.1   Introduction 
Objectives Understand the use of the D&C Manager to plot horizontal alignments into 

MicroStation.  
Understand the format of the hierarchical database and how to use it. 
 

Road Tool Frame  

      

Plan View Design 

Menu Bar Application 

         

 GEOPAK Road > Design and Computation Manager 
 

 

The Design and Computation Manager (D&C Manager) is a tool that allows the user to standardize 
graphics elements for drafting and pay item quantities. 

A hierarchical database is used with the Design and Computation Manager. This database stores 
information concerning functional classification and display preferences for each feature and item 
used in a MicroStation file. This file is commonly referred to as the ddb file (*.ddb). 

Categories are used to group and classify the features and items used in creating construction 
drawings.  Two common examples of these categories are Pay Items and Drafting Standards as 
shown in the following diagram.  
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These categories each contain sub-categories.  The sub-categories break down each classification 
into more specific items.  For example, Location & Design may be broken into several additional 
categories such as Walks, Curbing, etc. 

 

Within a category (represented by the folder icon), the items that are included are designated 
according to the process that they will be used for (as a drafting item indicated by a paintbrush shown 
in the following diagram): 
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Each entry represents a specific item.  The various icons representing the function they will be 
utilized for can identify items. 

• Calculator (quantities calculations) 
• Paintbrush (draw design elements) 
• Report icon (default, pavement design, pavement markings, etc.) 

 
The database may also be password protected if desired. This can be used as a security measure to 
protect the integrity of the database file and ensure its consistent application on a statewide or 
company wide basis. 

GEOPAK 2004 Edition Design and Computation Manager    5-3 



GEOPAK®__________________________________________________________  

5.2   Accessing the Design and Computation Manager 
When the Design and Computation Manager is accessed, two dialogs are displayed. 

 

The main D&C Manager dialog is composed of two distinct areas: 

• Across the top are icons for the various modes.  The D&C Manager may be configured to 
operate in seven different modes: Display, Design, Set, Compute, Shape, Pavement 
Marking and Preferences.  As various modes are selected, more icons are displayed within 
this area. 

• The Path box displays the name of the attached database file and your current position 
within the database structure.  It lists the categories, sub-categories and items available for 
selection.  This hierarchical data structure functions much like a directory. Double-clicking 
enables the user to move up or down within the database. 

 
A second dialog appears differently depending on the mode of operation.  This dialog enables the 
user to set other options not available on the main dialog. 
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5.2.1   File Commands 

 

For the GEOPAK designer, the only file command options needed are Open and 
Exit.  The other commands such as Save, Merge and Compress are used by 
personnel who maintain the database. 

As mentioned previously, the Password option may be used to password protect 
the database so a user would not be able to make changes to it. 

5.2.2   Edit Commands 
As a designer, the most-used Edit commands will be Find, Identify and 
Review Item.  

Find – This tool will search the database (from your current location) 
for an item or category.  If the database is password protected, all other 
items will be disabled. 

Identify – This tool will allow you to select an element in the design file 
to identify which item it matches in the database. 

Review Item – This tool will allow you to review the settings/symbology 
for a particular item in the database. 

 

5.2.3   Settings 
Display Settings - temporarily changes the display of 
elements on the screen to one common color, then the 
user may specify additional elements to be viewed in their 
original colors.  This tool enhances visualization when 
working on a complex project. 

Design Settings - sets the maximum gap tolerance and 
deduction tolerance used in computations and the drawing 
scale for placing cells. 

 

 

5.2.4   Favorites 
Add to Favorites - saves current D&C Manager path for easy recall in the 
future. 

Organize Favorites – allows the organization of previously saved paths.  
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5.3   Operational Mode - Design 
The Design mode enables the user to draw each roadway element or COGO element (and 
associated attributes) in the design file based on drafting item parameters.  

First, the desired item is highlighted in the main dialog list box, i.e., alignment, edge of pavement, etc. 

 

The Place Influence option sets the level, symbology and attribute tags of elements drawn or copied 
using MicroStation commands.  When the Place Influence toggle is activated, elements are drawn 
using the level, symbology and attributes as defined in the GEOPAK database.  When Place 
Influence is off, elements are drawn using the active level, symbology and attributes of MicroStation. 

 

The Draw Cogo Element button is for drawing COGO elements to a design file.  A single click to this 
button prompts the user for a job number, then opens a dialog that enables the user to choose a 
COGO item to draw. 

 

If an alignment, profile or parcel item is chosen, the Draw Cogo Element button changes to Draw 
Plan and Profile. 
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From the secondary dialog that is opened, press the Draw Plan & Profile button to initiate the 
drawing of COGO elements into the design file. Pressing this button prompts the user for a job 
number (the coordinate geometry database file wherein the COGO elements are stored), and then 
opens a dialog that enables the user to choose a COGO item to draw. Do Not activate the Place 
Influence toggle when using Draw Plan & Profile. 

 

If utilizing the Design & Computation Manager within Project Manager, you are not be 
prompted for a job number since this is associated with the active project. 

 

Eight operations may be accessed from the Plan 
and Profile Draw dialog: Points, Lines, Curves, 
Spirals, Chains, Stationing, Parcels, and Profiles.  
Each of these operations dynamically changes 
the dialog to reflect the selection with the various 
draw and label features used when placing a 
COGO element in a graphics file. 

 

The points and lines dialog boxes have a key-in 
field that allows the user to specify the names of 
the COGO elements to be drawn.  To use the line 
operation, the user must use point numbers to 
specify the ends of the line.  The points/lines are 
drawn immediately after you enter their respective 
names and press the enter key.  To draw more 
than one point or line, place a dash in-between 
the point numbers.  To draw a line without using 
consecutive point numbers, use a forward slash 
(i.e. 10/11). 
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The dialog settings for curves, spirals, chains, 
stationing, parcels, and profiles have a list box 
that display the names of all curves, spirals and 
chains stored in the active coordinate geometry 
database file.  Highlighting one of the available 
elements initiates further commands to draw the 
element into the design file.  Each type of item 
has a list of parameters that can be optionally 
plotted. 

 

 

 

GEOPAK can draw elements to non-active levels.  After elements are drawn, it may be 
necessary to turn on appropriate levels and fit the elements into the view. 
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D&C Manager – Plans Production 
5.1   Accessing Design and Computation Manager 

Step 1. Open the MicroStation file c:\data\geo\vdot\s1373\s1373.dgn 

Step 2. Access D&C Manager from the Road Tools Palette.   

 

Step 3. This should bring up the following dialog. 

 

5.2   Drawing Alignments 
Step 1. A secondary dialog will appear to be used in conjunction with the Design and 

Computation Manager dialog. 
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Step 2. Select the following item: 

  Location & Design > BL50 – 50 Scale Baselines.  

 
Step 3. Next, select the Draw Plan and Profile 

button from the secondary dialog: 

 

Step 4. Select the Chains operation.  Chain 
‘CHN1’ should be displayed in the list 
box as shown.  Notice that the options 
that are to be drawn with the chain are 
already activated. Set the Label Scale 
to 50. 

Step 5. To draw the chain, select CHN1 in the 
list box.  Only click once!! 
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Step 6. Change the Operation to Stationing 
and annotate the alignment CHN1 by 
selecting the chain name in the list box. 

 Close the GEOPAK Plan and Profile 
dialog. 

Step 7. Review the results of Steps five and six. 
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Existing Ground Profiles 
6.1   Introduction 
Objectives Learn to calculate existing ground profiles extracted from a surface model. 

Tools 

 
 

Menu Bar Application GEOPAK Road > Geometry > Ground Profile 

 

The Draw Profile tool enables the user to draw several profiles from a variety of sources simultaneously. 

• GEOPAK coordinate geometry database wherein the vertical alignment is stored.   
• GEOPAK binary TIN file, Site Model or Site Object.  The Site Model or Object are created 

utilizing GEOPAK Site Modeler software and are stored within the GEOPAK Site project (gsf) 
file. 

In addition, if the source data is TIN files or site components, the resultant profile may optionally be 
stored within the coordinate geometry database. 

Invoking the Draw Profile Tool 
The Draw Profile Tool is not supported by Project Manager.  It can be accessed by selecting 
Applications > GEOPAK ROAD > Plans Preparation > Draw Profile or from the GEOPAK ROAD 
Tools tool frame. 

The generation of profiles must be invoked from within the 2D MicroStation design file wherein the 
profile is to be drawn. 
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The initial entries that are required are the Job Number and Chain name.  Once selected, click Dialog 
Profile Cell Control (to the right of the Job Number field).    

 

Select the Active Chain that the new or existing profile is to be stationed along.  If no profile cell 
exists, click Place Profile Cell along the right side of the window to place a new cell.  If multiple profile 
cells exist, highlight the desired cell and click Activate Profile Cell. 

 

Update Options 
Four update options exist that allow the user the control needed to tell the software what to do if a 
profile has been previously drawn in the file and needs updated.  The options are toggled off / on by 
each selection of the option by clicking the Update Options pulldown.  The check to the left of the 
option indicates the option is active.  Only one option may be active at any given time, therefore, if an 
option is selected, the previous active option is de-activated.  The four options are detailed in the 
table below. 
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Delete Existing Elements and 
Redraw 

When this option is activated, any profiles previously drawn with 
this tool are deleted and new ground lines are drawn. 

Delete Non-Modified Elements 
and Redraw 

When this option is activated, any profiles previously drawn with 
this tool and not modified with any MicroStation commands are 
deleted and new ground lines are drawn. 

Draw on Top of Existing When this option is activated, any previously drawn profiles are 
ignored and a new set is drawn, resulting in multiple copies of 
each profile. 

Query When activated, the user is prompted each time the Draw button 
is pressed. 

Surfaces Tab 
The Surfaces tab defines the surfaces utilized as source data when drawing profiles.  Multiple 
surfaces from a variety of sources can be drawn in a single processing.  When the tab is selected 
and a profile cell is placed, the dialog dynamically changes as depicted below. 

 

Each surface to be drawn must be added to the list box.  This is accomplished via the action / edit 
buttons on the right side of the dialog box.  Each surface draws a cross section line string or lines.  
When a line is added to the list box, the profile is drawn.  Note:  clicking on the draw toggle in the list 
box deletes or redraws the profile. 

To add to the list box, simply select the source data and method, Display Settings, Tolerances and 
Offsets, and then add the profile to the list.  Once a profile is drawn, it may be updated at any time by 
using Update Profile.  Refer to the Update Options section to review those options.  Any profile may 
optionally be stored to the GPK file if desired. 
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Display Settings 
The Display Settings group box specifies the element symbology of the cross section elements being 
generated.  The symbology may be specified using Level Symbology or a feature selected from a 
D&C Manager database. 

To use By Level Symbology, set the option to By Level Symbology, then double click on the 
graphic.  This opens the Set Feature dialog box, wherein the symbology can be specified.  Click OK 
when completed. 

To use By Feature, set the option to By Feature.  Next, press the Paintbrush icon, which invokes the 
current Design and Computation Manager.  Select the desired item, and then press the OK button, 
which closes the Design and Computation Manager, and populates the Draw Profile Display Settings 
group box. 

Filter Tolerances 
Both Horizontal and Variance filter tolerances are considered together for each pair of profile 
segments.  The middle point is deleted if both segment lengths are less than the Horizontal filter 
tolerance while the projected distance between the mid-point and the chord between the two end 
points is less than the Variance tolerance. 

 

Offsets 
Vertical or Horizontal Offsets may be specified in terms of master units (i.e., feet or meters).  The 
Horizontal Offset is the distance offset from the Chain.  Once the horizontal location for the profile is 
determined, the data source is utilized to determine the profile.  Any Vertical Offset is applied after the 
profile is generated from the source data. 

Store Profile to COGO 

 
When the profile is drawn, it may also be stored in COGO by 
pressing this button, which opens the dialog box depicted 
below left. 
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The profile may be stored, or just the input file may be 
created.  If an input file is created, the Operator Code and 
File Name are required.  If the dialog box is invoked while in 
a 3D file, the user may toggle on the option to create a 3D 
profile string. The 3D profile string consists of the circles 
denoting every location where the design centerline 
intersects topographic elements.  If the circles are not 
deleted at this time, they can be deleted at any time with a 
single application of the MicroStation "Delete Element" 
command. 
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Cogo Tab 
The Cogo Tab is utilized for drawing any profile that has been previously stored into the GPK file. 

 

To draw a profile, first select the Profile Name to be drawn.  The Vertical Offset defaults to a value of 
0, but can be set to any value.  This instructs the software to draw the profile at a distance above or 
below the elevations in the GPK file.  Station Limits may also be specified to have the software draw 
only a portion of the profile.  If the Display Settings are set to By Feature and a feature is selected, 
the Options area of the dialog box is un-ghosted.  This is where various labeling options for the profile 
can be specified.  If a value is given for the Strip Grade Increment, elevations will be placed at that 
increment along the bottom of the profile. 

Profile Report 
To review a textual report listing stations and elevations of a ground profile, open the GEOPAK 
Coordinate Geometry dialog box.  A couple of different methods can be used to create this listing for 
any profile.   
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By selecting Element > Profile > Utility then highlighting 
a specific profile name and clicking Print.  The results of 
this command will be displayed in the Command Output 
window of the Coordinate Geometry dialog box.  To obtain 
a hardcopy of this information, create an output file using 
the File > File Utility > Output command and supply a 
filename of 1-5 characters.  Then use the File > File 
Utility > Print Output File command to print this to the 
default system printer. 

 

The second method utilizes the COGO Navigator tool to 
create the Print Profile command.  The advantage to this 
method is that multiple profiles can be identified at once 
and printed to the Command Output window.  Start the 
COGO Navigator by clicking Tools > Navigator or 
selecting the icon from the COGO dialog box.  Change the 
Element to Profile then highlight the desired profile(s).  
Once selected, click the Print/Describe Element icon on 
the Navigator to process the profile(s). 

Drawing Profiles with D&C Manager 
As with other COGO elements, 
Design and Computation Manager 
will be utilized to draw any type of 
profile into a MicroStation file:  
existing roadway, proposed 
roadway, utility, special ditch, etc.  
To get started, open D&C Manager 
then navigate to the desired item for 
plotting of the profile.  Upon 
selecting an item, click on the Draw 
Plan & Profile button on the 
supplemental D&C dialog box. 
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The next dialog box that appears is the GEOPAK Draw Plan & Profile window, as depicted below.  

 

If it is not already selected, change the Operation to Profiles.  Displayed in the window is a list of 
profiles currently stored in the GPK file.  Along the right side of the window are labeling options for the 
profile that is to be plotted.  Configure these as desired before selecting a profile to plot.   

• VPI Labels – Labels the station and elevation of the VPI – typically turned off for plotting of 
existing profiles. 

• Horizontal Axis – Places stations along the bottom of the profile. 
• Vertical Axis – Places elevations along the left side of the profile. 
• VC Parameters – Labels the length of the vertical curve if applicable. 
• VPC/VPT Labels – Annotates the station and elevation of a vertical curves control points. 
• Stopping Sight Distance – Places text for crest vertical curves representing the curves 

stopping sight distance as defined by AASHTO. 
 

After selecting a profile to plot, the dialog box below opens.  Since a profile does not have XY 
coordinates, the user must specify a location in the MicroStation file to place the profile and a scale at 
which to plot the profile.  When using a ratio other than 1:1, the horizontal dimensions of the profile 
remain true and the vertical is exaggerated. 
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The location can be selected by clicking on the 
DP button then specifying a location in the file by 
issuing a data point in the view.  The coordinates 
can also be keyed in to the dialog box.  A Profile 
Cell can be drawn into the file to represent the 
location of the data point and associated 
information.  This cell can be used in any other 
GEOPAK tool that needs to know the location of 
the profile.  A PGL Chain must be selected before 
drawing the profile cell.  This chain will be the 
chain that the profile is stationed along.   

If a value is specified for the Strip Grade 
Increment, elevations will be calculated at the 
desired interval along the profile and placed just 
above the Horizontal Axis Labels (stations). 

Click OK to draw the profile. 
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_____________________________________EXERCISE 6 

Existing Ground Profile 
6.1   Extract Existing Ground Profile 

1. Open the MicroStation file c:\data\geo\vdot\S1373\profile.dgn. 

2. Access Applications > GEOPAK Road > Plan Preparation > Draw Profiles 

 
3. Select Job Number 123 and select chain SR1373B. 
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4. Click Dialog Profile Cell Control icon (to the right of Job Number).  

5. Set the Active Chain to SR1373B.     

6. Click Place Profile Cell on the right side of the dialog.   

 
7. Populate the dialog as shown above and then DP anywhere in order to place the profile cell 

into the design file. 

8. Fit the view contents. 

9. Close the Profile Cell Control dialog. 

10. From the Surfaces tab, select the Browse TIN File button in the Details area, then select the 
GROUND.TIN file for the TIN File to cut the profile. 

11. Set the Method to Triangles. 

This instructs the software to compute elevations at each location that the chain intersects a 
triangle leg from the TIN. 

12. Set the option button to By Feature in the Display Settings area of the dialog. 

13. Click the Browser Feature (Paintbrush) icon then navigate to the item shown below.                      

 
14. Click OK 

15. Click Add Surface Settings to add the profile to the list box as well as draw the profile into 
the MicroStation file. 

 

 Store Profiles into COGO Database 

1. Click Store Surface in COGO. 
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2. Populate the dialog as shown above. 

3. Click Apply. 

4. Close the Store Profile dialog. 

5. Click Remove Surface. 

 This erases the profile from the DGN file.  We will re-draw the profile shortly.

GEOPAK 2004 Edition Existing Ground Profile     Lab: 6-3 



GEOPAK®__________________________________________________________  

Review Profiles in COGO 

1. Select the Coordinate Geometry tool. 

2. Click OK to accept your project name, etc. 

3. Select Element > Profile > Utility. 

 
4. Select the profile ‘GROUND’  

5. Click Print. 

6. Review the profile information in the COGO output display window. 

7. Close the Coordinate Geometry dialog.  When prompted to save the COGO session, select 
No. 

 Drawing and Labeling the Existing Centerline Profile 

1. Click the COGO tab then set the Label Scale to 50 in the upper right hand corner. 

 
2. Select the Profile Name MLGROUND in the Details section. 

 
3. Set the option to By Feature in the Display Settings section. 

4. Click the Browser Feature (Paintbrush) icon then navigate to the item shown below. 
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5. Click OK.                      

6. Select General in the Options area and set the Strip Grade Increment to 50.   

This will label the elevations every 50’ along the bottom of the profile area. 

 

7. Click Add COGO Profile Settings to draw the profile. 

This will draw the existing ground profile with the proper symbology in addition to labeling 
the stations and elevations along the bottom of the profile and the elevations along the left 
side of the profile. 

8. Close the Draw Profile dialog. 
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Adjusting Traverses 
Introduction 

GEOPAK Coordinate Geometry has the ability to balance and adjust traverses using the Compass 
Rule method.  Traverses can be run as either Open (no closing coordinate) or Closed (having a 
closing coordinate or direction). The traverse information is entered, course by course as lines in an 
input file. Once the required information is entered, the final command END TRAV will execute the 
adjustment routine. Once completed traverse points will be stored in the .GPK file.  

In the example shown below we will actually run 2 separate traverses. The first one, TRAV 1, will be 
entered into cogo and adjusted.  The second one TRAV 2, will be run from the adjusted points in 
TRAV 1. We will hold the previously adjusted data “Fixed” and adjust the second traverse to it. 
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Below is an example of the input file format and command syntax for the traverse adjustment entry: 

 

1   trav trav1 -  (Executes the Trav Command and name of traverse, in this case TRAV1) 

 

2   compass – (Method of Adjustment) 

 

3   closure 30000 10  - (Closure must meet 1:30,000 angles are +/- 10") 

 

4  back ref 2 to 1 - (Your Backsight Reference) 

 

5   lin 2 to 3 503.88 p 91 43 52 - (Traverse legs, angle Right is "P" angle left is "M") 

 

6   lin 3 to 4 621.05 p 156 28 43  

 

7   lin 4 to 5 583.40 p 187 21 49 

 

8   lin 5 to 6 560.07 p 266 21 36  

 

9   lin 6 to 7 572.06 p 195 56 58 

 

10   lin 7 to 8 770.03 p 257 28 42  - (Closing Leg) 

 

11   end trav   - (End traverse info execute the TRAV command) 

 

In the above example, points 1,2, and 8 must be stored prior to running the traverse adjustment. If no 
azimuth is defined for begin/end azimuth, an assumed backsight reference of North 00 East will be 
used. If you wish to close on a point that does not have a predefined value, you can run as an open 
traverse. Line 1 would be modified to read: (Trav Trav1 Open.) 

 

 

 

Once you type the END TRAV statement, GEOPAK will run the Compass routine.  
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The Output is shown below: 

 

 COMPASS ADJUSTMENT    

 Closure information:     

 Total error  0.067        

 Error in X  -0.036    in Y  -0.057   

  Closure accuracy:  53,632.395    

  Total Perim  3,610.490    Fix Perim  0.000    Perim  3,610.490       

  Closing link  S  31° 58' 33" W       

  CLOSED TRAVERSE          

  Point           Field Coords       Correction    Adjusted Coords                

  2          X      20,600.479         0.000            20,600.479      Y      10,309.304     0.000            
10,309.304                 

  3          X      20,116.340        -0.005            20,116.335      Y      10,448.962    -0.008            
10,448.954                 

  4          X      19,500.505        -0.011            19,500.494      Y      10,368.648    -0.018            
10,368.631                 

  5          X      18,917.105        -0.017            18,917.088      Y      10,367.969    -0.027            
10,367.942                 

  6          X      18,880.897        -0.022            18,880.875      Y      10,926.868    -0.036            
10,926.832                 

  7          X      19,002.205        -0.028            19,002.177      Y      11,485.918    -0.045            
11,485.873                 

  8          X      19,772.226        -0.036            19,772.191     Y      11,489.666     -0.057            
11,489.609                 

 COURSE            ADJUSTED          ADJUSTED             ADJUSTED             

 FROM    TO       DISTANCE           BEARING                 ANGLE   

              

 2       3                503.883            N  73° 54' 36" W          91° 43' 48"        

 3       4                621.057            S  82° 34' 08" W        156° 28' 44"        

 4       5                583.406            S  89° 55' 57" W        187° 21' 49"        

 5       6                560.062            N   3° 42' 26" W         266° 21' 37"        

 6       7                572.050            N  12° 14' 33" E         195° 56' 59"        
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 7       8                770.022            N  89° 43' 19" E          257° 28' 47"        

  

 Chain TRAV1 stored   

 

We will run the second Traverse based on the adjustment of the first Traverse. In this case we will set 
up on point 5 and the Backsight Reference( back ref) will be the adjusted course point 5 to 4. 

Below are the commands and the output: 

 

*     1   trav trav2  

 

*     2   compass 

 

*     3   closure 30000 10 

 

*     4   back ref 5 to 4 

 

*     5   lin 5 to 9 529.90 p 86 18 34 

 

*     6  lin 9 to 10 601.85 p 186 29 08 

 

*     7   ahead ref 10 to 11 ang 268 20 50 – (Here we are turning into a line, 10 to 11 that was 
previously stored.) 

 

*    8   end trav 

 

      COMPASS ADJUSTMENT    

      

Preliminary angle adjustment:                  

 

Total error:        0° 00' 02"            Error per angle:    0° 00' 01"   

        



__________________________________________________________GEOPAK® 

GEOPAK 2004 Edition  Appendix 1-Adjusting Traverses  5 

Closure information: 

 

Total error  0.060      Error in X  -0.015    in Y  0.058       

        

Closure accuracy:  18,860.831           

 

Total Perim  1,131.750    Fix Perim  0.000    Perim  1,131.750     

          

 Closing link  N  14° 27' 59" W    

         

 Warning : Accuracy not achieved. Traverse points will not be stored. 

 

Since our traverse did not meet our stated limit of precision 1:30,000, GEOPAK will not store the 
points in the .GPK file. It is up to the user to review the output data and decide on how to proceed. In 
this case we will accept the closure in X and Y, and modify the input file to lower the level of expected 
precision. As shown below: 

          

*      3   trav trav2                                                            

                                                                                 

                                                                                 

*      4   compass                                                               

                                                                                 

                                                                                 

*      5   closure 10000 10 – (Here we have modified the accepted level of precision to 1:10,000)                             

                                                                                 

                                                                                 

*      6   back ref 5 to 4 – (Backsight Reference) 

                                                                                 

                                                                                 

*      7   lin 5 to 9 529.90 p 86 18 34                                          
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*      8   lin 9 to 10 601.85 p 186 29 08                                        

                                                                                 

                                                                                 

*      9   ahead ref 10 to 11 ang 268 20 50 – (Tying into our existing azimuth) 

                                                                                 

                                                                                 

*     10   end trav                                                              

                                                                                 

        ---------------------- 

          COMPASS ADJUSTMENT   

        ---------------------- 

  

 Preliminary angle adjustment: 

  Total error:        0° 00' 02" 

  Error per angle:    0° 00' 01" 

  

 Closure information: 

  Total error  0.060 

  Error in X  -0.015    in Y  0.058 

  Closure accuracy:  18,860.831 

  Total Perim  1,131.750    Fix Perim  0.000    Perim  1,131.750 

  Closing link  N  14° 27' 59" W      

  

        ------------------ 

          CLOSED TRAVERSE 

        ------------------ 

  

Point           Field Coords       Correction     Adjusted Coords 

5          X      18,917.088         0.000            18,917.088  

            Y      10,367.942         0.000            10,367.942  



__________________________________________________________GEOPAK® 

GEOPAK 2004 Edition  Appendix 1-Adjusting Traverses  7 

9          X      18,951.822        -0.007            18,951.815  

            Y       9,839.182         0.027             9,839.209  

10        X      18,923.186        -0.015            18,923.171  

            Y       9,238.014          0.058             9,238.072  

  

   COURSE            ADJUSTED          ADJUSTED           ADJUSTED 

FROM    TO           DISTANCE           BEARING              ANGLE 

      5       9              529.872         S   3° 45' 28" E               86° 18' 35" 

      9       10            601.820         S   2° 43' 41" W            186° 29' 09" 

 

Since we have achieved the desired level of precision after changing it in the input file, GEOPAK 
automatically stores the new traverse points into the .GPK file for later use. 
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Export Staking Data 
Introduction 

GEOPAK provides the ability to export point, chain and profile data directly to supported data 
collector file formats for easy download. 

 

TDS Chains and Profiles 
The export utility is accessed from the main survey menu bar Geometry > Export. 

 

 

 

Several options are available depending on what is to be exported. In order to export chains and 
profiles to a TDS format the option for Alignments and Profiles is selected. 

This dialog allows the user to select the chain and profile by clicking on the respective buttons and 
making the proper selection. 

Once the desired chain and profile have been selected a file name is entered to save the geometry 
to. After all settings are completed the Apply button is clicked and the file is created 
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This file can then be downloaded to the data collector via the Export > Data Collector option. 

Downloading 
Once the alignment files have been created the points and alignments are ready for downloading to 
the data collector. This is accomplished by selecting from the same menu Geometry > Export and 
then selecting the Data Collector option. 

 

Several export types are supported for TDS data. 

 

Coordinates Coordinate list from the gpk. 

Roadway File Chain and Profile from the gpk. 

ASCII File Coordinate list from any source 

Description Table  
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In the case of exporting a Coordinate file, all the desired coordinates are highlighted in the list 
window and when the OK button is selected a second dialog will appear asking for a job number to 
create on the data collector. 

 

 

This job number will be created and all the highlighted points dumped to the data collector. 

 

 

Another option to downloading directly to the data collector is to change the Export To toggle to File 
(Option). This will create a cr5 file and write the selected points to it, placing it on the hard drive 
instead of placing them directly on the data collector. This option is only available when exporting 
coordinates. 
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Special Reports 
Horizontal Alignment Reports 

In this section we will generate a Horizontal Alignment report using Coordinate Geometry. 

Step 1. Execute C:\data\geo\VDOT\road1\LAB21.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\road1\d17682des.dgn. 

Step 3. Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 4. Select the Coordinate Geometry icon from the Road Project: 17682.prj workflow dialog 
box.  The coordinate geometry dialog box shown below should appear. 

 

  This dialog box is completely re-sizable, so you can position it where you’re most 
comfortable. 
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21.1.1   Describe Chain 
From the COGO dialog window, let’s preview the geometry of the chain MAINLINE. 

Step 1. Select the COGO Navigator icon 

  

 or use the Tools > Navigator option on the 
COGO menu bar to access the COGO Navigator 
dialog box. 

Step 2. Set the element option to Chain and highlight the 
chain MAINLINE. 

Step 3. Press the “Print/Describe Element” icon. 

 

Step 4. The chain geometry output will be displayed in the main COGO window. 
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21.1.2 Create Output File 
 In the following steps we will save an output file with the computations of chain MAINLINE. 

Step 1. Access the File Utility dialog by pressing the File Utility icon 

 

or by selecting File > File Utility.  The dialog below should appear. 

 

Step 2.  To save an output file with the actual results of the computations, set the option button to Output 
on the File Utility dialog.  Enter “MAIN” as the Output File name then click Apply. 

 

 A file named “main101.ovd” will be created in the working directory. 

Step 3. Dismiss the File Utility dialog box by clicking the X in the upper right hand corner. 

Step 4. From the Edit pulldown, select Edit > Clear to ‘clear’ out all the commands that we just previously 
executed. 

 

This will not remove the stored data from COGO.  
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 21.1.3   Create Alignment Relation Report (Layout Offsets) 
From the COGO dialog window, let’s create an Alignment Relation report between chains MAINLINE 
and RAMPA. 

Step 1.     Use the Element > Chain > Layout Offset 
option on the COGO menu bar to access 
the Layout Offset Chain dialog box. 

Step 2. Populate the dialog box as shown. 

Step 3. Click “Compute”. 

 

Step 4. The offsets between chains MAINLINE and RAMPA will be displayed in the main COGO 
window. 
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21.1.4 Create Output File 
 In the following steps we will save an output file with the offset list between chains MAINLINE and 

RAMPA. 

Step 1. Access the File Utility dialog by pressing the File Utility icon 

 

or by selecting File > File Utility.  The dialog below should appear. 

 

Step 2.  To save an output file with the actual results of the offset list, set the option button to Output on 
the File Utility dialog.  Enter “OFF” as the Output File name then click Apply. 

 

 A file named “off101.ovd” will be created in the working directory. 

Step 3. Dismiss the File Utility dialog box by clicking the X in the upper right hand corner. 

Step 4. Exit COGO by clicking the X in the upper right hand corner. 

 

NOTE:  When you are prompted to Save the Session, click 
“No” since you have already saved your input. 

 

GEOPAK 2004 Edition  Appendix 3-Special Reports   5 



GEOPAK®__________________________________________________________  

Step 5. Review the output file by opening “main101.ovd” with the GEOPAK Text Editor.  The file should 
appear as below. 

 

A report of the stored chain which describes its geometry including coordinates, stations, 
distances, bearing, curves, and spiral data. Any break in the stationing detected during the 
description of the chain will be considered a station equation and numeric regions will be 
assigned by GEOPAK starting at one.  If the chain contains station equations, they are listed in 
the description. 
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Step 6. Review the output file by opening “off101.ovd” with the GEOPAK Text Editor.  The file should 
appear as below. 

 

The Layout Offset Chain using the Radial Projection option calculates stations on Chain 
RAMPA and the radial distance from a specified interval on the Chain MAINLINE.  The offset 
distances and direction are perpendicular or radial to the Chain MAINLINE. 

Step 7. Exit MicroStation. 
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21.2   Vertical Alignment Reports 
In this section we will generate a Vertical Alignment report using Coordinate Geometry. 

Step 1. Open the MicroStation file c:\data\geo\VDOT\road1\d17682prof.dgn. 

 

 

It is not required that this report be run while in the profile file.  
It can be run from any MicroStation design file. 

 

Step 2. Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 3. Select the Coordinate Geometry icon from the Road Project: 17682.prj workflow dialog 
box.  The coordinate geometry dialog box shown below should appear. 

 

  This dialog box is completely re-sizable, so you can position it where you’re most 
comfortable. 
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21.2.1   Describe Profile 
From the COGO dialog window, let’s preview the geometry of the profile MAINLINE. 

Step 1. Select the COGO Navigator icon 

  

 or use the Tools > Navigator option on the 
COGO menu bar to access the COGO Navigator 
dialog box. 

Step 2. Set the element option to Profile and highlight the 
chain MAINLINE. 

Step 3. Press the “Print/Describe Element” icon. 

 

Step 4. The profile geometry output will be displayed in the main COGO window. 
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21.2.2 Create Output File 
 In the following steps we will save an output file with the computations of profile MAINLINE. 

Step 1. Access the File Utility dialog by pressing the File Utility icon 

 

or by selecting File > File Utility.  The dialog below should appear. 

 

Step 2.  To save an output file with the actual results of the computations, set the option button to Output 
on the File Utility dialog.  Enter “PROP” as the Output File name then click Apply. 

 

 A file named “prop101.ovd” will be created in the working directory. 

Step 3. Dismiss the File Utility dialog box by clicking the X in the upper right hand corner. 

Step 4. From the Edit pulldown, select Edit > Clear to ‘clear’ out all the commands that we just previously 
executed. 

 

This will not remove the stored data from COGO. 
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21.2.3   Create Profile Grade List 
From the COGO dialog window, let’s create a profile grade list of the profile MAINLINE. 

Step 1.       Use the Element > Profile > Elevation option on 
the COGO menu bar to access the Profile 
Elevation dialog box. 

Step 2. Populate the dialog box as shown. 

Step 3. Click “Compute Elevation”. 

 

 

Step 4. The profile grade list will be displayed in the main COGO window. 
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21.2.4 Create Output File 
 In the following steps we will save an output file with the profile grade list of profile MAINLINE. 

Step 1. Access the File Utility dialog by pressing the File Utility icon 

 

or by selecting File > File Utility.  The dialog below should appear. 

 

Step 2.  To save an output file with the actual results of the profile grade list, set the option button to 
Output on the File Utility dialog.  Enter “GRADE” as the Output File name then click Apply. 

 

 A file named “grade101.ovd” will be created in the working directory. 

Step 3. Dismiss the File Utility dialog box by clicking the X in the upper right hand corner. 

Step 4. Exit COGO by clicking the X in the upper right hand corner. 

 

NOTE:  When you are prompted to Save the Session, click 
“No” since you have already saved your input. 
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Step 5. Review the output geometry file by opening “prop101.ovd” with the GEOPAK Text Editor.  The 
file should appear as below. 

 

Geometric data for the profile name, including stations, elevations (including the high point), grade and 
lengths (back, ahead and total) for VPC's, VPI's and VPT's.
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Step 6. Review the output geometry file by opening “grade101.ovd” with the GEOPAK Text 
Editor.  The file should appear as below. 

 

The Profile Elevation tool computes elevations along a profile based on user-defined parameters.  
Next, the profile grade is calculated and if the station is on a tangent or curve. 

The application reads the Begin stationing, then determines the next even station (divisible by the 
Even Station value).  For example, the beginning station is 200+00.00 and Even 25 is set.  The Even 
25 dictates to the software to display the first station as 200+00.00, followed by 200+25.00, 
200+50.00, etc. 

Step 7. Exit MicroStation. 
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21.3   Cross Section Reports 

 

These reports must be run from the proposed cross section 
file. 

21.3.1   Design Cross Section List 
In this section we will generate a Design Cross List using XS List from the Cross Section Reports. 

Step 1. Open the MicroStation file c:\data\geo\VDOT\road1\d17682xsmainline.dgn. 

Step 2. Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 3. Select the Reports & XS Quantities icon from the Road Project: 17682.prj workflow 
dialog box.  The XS Reports dialog box shown below should appear. 
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Step 4. From the XS Reports dialog box, select the User > Preferences dialog box. 

  

Set the tolerance to .01. 

Step 5. Dismiss the Report Header dialog box by clicking the X in the upper right hand corner. 

Step 6. From the XS Reports dialog box, select the XS List report.  The Cross Section Report 
dialog box below should appear.  Job Number, Chain Name, and Station Range should 
be populated from Project Manager. 

 

Step 7. Click the symbology settings button then populate the Candidate Elements dialog box 
as shown. 

  

 

Note: The levels for XS Elements should only refer to 2-4. These are the levels that 
make up the top of Finish Grade. 

 

Step 8. Dismiss the Candidate Elements dialog box by clicking the X in the upper right hand 
corner. 
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Step 9. Set the option button to “Design Cross Section List”.   

Step 10. Enter “xs-list.txt” for the ASCII File name.   

The Cross Section Report dialog box should appear as below.   

 

Step 11. Click Apply.  A file named “xs-list.txt” will be created in the working directory. 

Step 12. Dismiss the Cross Section Report dialog box by clicking the X in the upper right hand corner. 

Step 13. Review the Cross Section list file by opening “xs-list.txt” with the GEOPAK Text Editor.  The file 
should appear as below. 

 

For each station, the XS List report provides the elevation and offset for each cross section 
element identified via user defined search criteria.  Offsets to the Left of the centerline contain 
an “L” and offsets to the right of the centerline contain an “R”. 

 

Do NOT dismiss the XS Reports dialog box. 
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21.3.2   Seeding Report 
In this section we will generate a Seeding Report from the Cross Section Reports. 

Step 1. From the XS Reports dialog box, select the Seeding report.  The Seeding Report 
dialog box below should appear.  Most of the dialog box should be populated from 
Project Manager. 

 

Step 2. Click the Candidate Seeding Elements symbology settings button then populate the 
Candidate Elements dialog box as shown. 

 

Step 3. Dismiss the Candidate Elements dialog box by clicking the X in the upper right hand 
corner. 

Step 4. Enter “seeding.txt” for the ASCII File name.   

Step 5. Click Apply.  A file named “seeding.txt” will be created in the working directory. 

Step 6. Dismiss the Seeding Report dialog box by clicking the X in the upper right hand corner. 
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Step 7. Review the Seeding Report file by opening “seeding.txt” with the GEOPAK Text Editor.  
The file should appear as below. 

 

The top of the file contains the values from the ByPass Segments and Additional Distances, followed 
by a listing of each station, its left and right slope distances (measured along the slope, not horizontal 
distance).  Utilizing two stations, GEOPAK calculates the average slope distance then computes the 
areas. 

For each station, the Seeding Report provides seeding slope distances left and right.  Then 
GEOPAK computes the average slope distance on each side, and uses the results to compute 
seeding areas.  Areas, in Square Feet, are listed next for the Left side, Right side, and both.  Next a 
subtotal is listed, in Square Feet, for the Left side, Right side, and both. 

At the bottom of the seeding report, totals are provided for the Left side, Right side, and both (in both 
Square Feet and Acres). 
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21.3.3   Staking Detail Report 
In this section we will generate a Staking Detail Report from the Cross Section Reports. 

Step 1. From the XS Reports dialog box, select the Staking Detail report.  The Staking Detail 
Report dialog box below should appear.  The dialog box should be populated from 
Project Manager. 

 

Step 2. Enter “staking-detail.txt” for the ASCII File name.   

Step 3. Click Apply.  A file named “staking-detail.txt” will be created in the working directory. 

Step 4. Dismiss the Staking Detail Report dialog box by clicking the X in the upper right hand 
corner. 

Step 5. Dismiss the XS Reports dialog box by clicking the X in the upper right hand corner. 
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Step 6. Review the Staking Detail Report file by opening “staking-detail.txt” with the GEOPAK 
Text Editor.  The file should appear as below. 

 

For each station, GEOPAK determines the tie down point between the proposed finish grade and the existing 
ground.  

Referencing this tie down point, the Staking Report lists the left and right offset and its corresponding 
elevation, and the slope of the proposed finish grade.  

Next, a “C” or “F” is provided if the tie down point is in Cut or Fill along with a vertical distance to the next 
break point in the original section.   

The centerline elevation (adjusted for pivoting on the inside edge) is given in addition to the superelevation 
rate of the pavement.  
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21.3.4 Detailed Earthwork Computations 
In this section we will generate a Detailed Earthwork Report.  An area of top soil removal will be 
included in this report.  Cross sections that require the top soil removal have been hand drafted using 
a unique symbology.  This will need to be done on any projects where top soil removal is required. 

Step 1. Project Manager should still be invoked. 

Step 2. Click Earthwork from the Project Manager dialog box and create a new run named ML2.  
Open the new run. 

 

Step 3. Populate the XS DGN File section of the dialog box as shown below: 
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Step 4. In the Soil Types section of the dialog box, create the following classifications and soil 
types utilizing the parameters detailed in the table below.   

 

 

Class Soil Type Search Criteria 

Existing Ground Earth Working Alignment Definition 

Proposed Finish Grade Earth Working Alignment Definition 

Existing Unsuitable1 RootMat_Cut LV=29, WT=8, LC=0, CO=3, TYPE=Line 

Existing Unsuitable2 RootMat_Fill LV=29, WT=8, LC=0, CO=7, TYPE=Line 

Existing Unsuitable3 Top_Soil LV=29, WT=8, LC=0, CO=0, TYPE=Line 

Existing Unsuitable4 Exist_Pavt LV=59, WT=3, LC=2, CO=88, TYPE=Line 

Excavation Limit None LV=25, WT=0, LC=0, CO=55, TYPE=Line 

 

 You can manually define the symbologies using the settings in the Search Criteria portion 
of the dialog box. When using these settings, there are also three additional buttons to 
help you. 

Match Prompts you to identify an element. Once you do, it will fill in the symbology  
settings with the symbology of the identified element. 

Display/Undisplay  Highlights all elements in the design file matching the set symbology. 

Reset  Clears all symbology settings. 
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Step 5. In the EW Shapes section of the dialog box, toggle on Draw Earthwork Shapes and 
Stratify Shape Color.  Populate the Set Feature dialog box with the parameters as 
shown below. 

  

Step 6. Populate the Output Format section as shown below.  

 

 NOTE: Use the arrows (< or >) to change the format to Excavation and Fill. 

Step 7. In the Sheet Quantities section, toggle on the Write Sheet Quantities File.  Name the 
file “earth2.txt”.  Add the following columns to the file with Decimal Places = 0 and 
Total Quantity Length = 10: 

Col. Soil Type EW Operation Quantity Type +/- 
1 Earth Common Exc End Area + 
1 RootMat_Cut Common Exc End Area + 
1 RootMat_Fill Common Exc. End Area + 
1 Top_soil Common Exc. End Area + 
1 Exist_Pavt Common Exc. End Area + 
2 Earth Fill End Area + 
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Step 8. Using the Files > Run pulldown, run the earthwork for the proposed cross sections.  
Place your output into a log file as shown in the dialog box below and Pause on Each 
Section. 

 

Step 9. Click Apply.   

Step 10. Review the earthwork quantities.  Toggle off “Pause On Each Section” then click 
“Continue”.   

Step 11. After the process has completed, click “Exit”.  Files named “earth2.log” and 
“earth2.txt” will be created in the working directory. 

Step 12. Dismiss the Earthwork dialog box by clicking the X in the upper right hand corner.  
When prompted to Save Earthwork Settings, click “Yes”. 
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Step 13. Review the Detailed Earthwork Report file by opening “earth2.log” with the GEOPAK 
Text Editor.  The file should appear as below. 

 

The earthwork report consists of four major parts: 

• Individual cross section quantities 

• Grand Total Summary 

• Balance Point Summary (Included only if there are balance points) 

• Centroid Adjustment Summary (Included only if the centroid adjustment option is active.) 

Each station is listed in numerical order (including regions), regardless of the order in the cross 
section design file. Then for each material type, each type of excavation and fill is listed, followed by 
the end areas in master units (either square feet or meters). Then unadjusted and adjusted volumes 
follow.  The last two columns are the multiplication factor used to generate the adjusted volumes from 
the unadjusted volumes, and the mass ordinate, which is the cumulative total of the adjusted 
volumes. 

Step 14. Dismiss the GEOPAK Editor dialog box by clicking the X in the upper right hand corner. 
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Step 15. Review the Sheet Quantity Earthwork Report file by opening “earth2.txt” with the 
GEOPAK Text Editor.  The file should appear as below. 

 

The earthwork component of GEOPAK produces the ASCII text file as a byproduct of the 
standard earthwork volume calculation run.  The first line of the ASCII file is a series of 
0's, 1's, 2's, etc. denoting the columns.   

GEOPAK automatically provides the column denoted by 0's. This column is where the 
station is written by GEOPAK. 

Column 1, 2, etc. contains the earthwork quantities as per the settings in Step 7.  The 
earthwork quantities will be placed on sheets using settings in the Cross Section Sheet 
tool. 

Step 16. Dismiss the GEOPAK Editor dialog box by clicking the X in the upper right hand corner. 

Step 17. Exit MicroStation. 
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21.4   Cross Section Reports Using Visual Basic Applications 

 

The dialog box to access Visual Basic Applications can be 
invoked from either the MicroStation pulldown menus by 
selecting Utilities > Macro > Macros or entering vba run in 
the Keyin Browser. 
 
These reports must be run from the proposed cross section 
file. 

21.4.1   Grade and Superelevation Report 
In this section we will generate a Grade and Superelevation Report utilizing a custom Visual Basic 
Application. 

Step 1. Open the MicroStation file c:\data\geo\VDOT\road1\d17682xsmainline.dgn. 

Step 2. Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 3. From the MicroStation pulldown menu select Utilities > Macro > Macros.  The dialog 
box below should appear. 

 

Step 4. Select modGradeAndSuperReport then click Run. 

Step 5. Populate the Grade and Super Report dialog box with the information below: 

 Job:  101 

 XS Chain:  MAINLINE 

 Report Chain:  MAINLINE 

 Report Profile:  MAINLINE 
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Step 6. Toggle on Superelevation then select C:\data\geo\vdot\road1\ml3_shapes.inp.  The 
Grade and Super Report dialog box should appear as below. 

 

Step 7. Click Generate Report. 

Step 8. In the Save Report As dialog box enter GradeAndSuperReport.doc then click  Save. 

Step 9. When the dialog box below appears, click Yes. 
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Step 10. Review the Grade and Super Report below then exit Microsoft Word. 

 

Station – Cross Section Station. 

Event – Cross Section or Critical point. 

Fin. Grade Elevation – Profile Grade Elevation. 

Grade - % of grade at each station. 

Cross Slopes – Slope of Pavement at each station. 

Offset – Offsets to each edge of pavement at teach station. 

Step 11. Dismiss the Grade and Super Report dialog box by clicking the X in the upper right 
hand corner. 
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21.4.2   ROW Report 
In this section we will generate a Right Of Way Report utilizing a custom Visual Basic Application. 

Step 1. Open the MicroStation file c:\data\geo\VDOT\road1\d17682des.dgn. 

Step 2. From the MicroStation pulldown menu select Utilities > Macro > Macros.  The dialog 
box below should appear. 

 

Step 3. Select modROWReport then click Run. 

Step 4. Populate the Right of Way Report dialog box with the information below: 

 Job:  101 

 Chain:  MAINLINE 

 Beginning Station:  200+00.00 

 Ending Station:  222+06.84 

 Station Increment:  25 

 Beginning Point Number:  D6000 

Step 5. Click Generate Report. 

Step 6. In the Save Report As dialog box enter ROWReport.doc then click Save. 

Step 7. When the dialog box below appears, click Yes. 
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Step 8. Review the Right of Way Report below then exit Microsoft Word. 

 

Point – COGO points stored in Coordinate Geometry 

Station – Cross Section station at Incrementation or Critical Points. 

Offset – Offset from Centerline to Right Of Way line. 

North – Northing Coordinates of the stored point. 

East – Easting Coordinates of the stored point. 

Step 9. Dismiss the ROW Report dialog box by clicking the X in the upper right hand corner. 
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21.4.3   Slope Stake Report 
In this section we will generate a Slope Stake Report utilizing a custom Visual Basic Application. 

Step 1. Open the MicroStation file c:\data\geo\VDOT\road1\d17682xsmainline.dgn. 

Step 2. From the MicroStation pulldown menu select Utilities > Macro > Macros.  The dialog 
box below should appear. 

 

Step 3. Select modSlopeStakeReport then click Run. 

Step 4. Populate the Slope Stake Report dialog box with the information below: 

 Job:  101 

 Chain:  MAINLINE 

Step 5. Click Generate Report. 

Step 6. In the Save Report As dialog box enter SlopeStakeReport.doc then click Save. 

Step 7. When the dialog box below appears, click  Yes. 
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Step 8. Review the Slope Stake Report below then exit Microsoft Word. 

 

LCP – Left side catch point. 

LSP – Left side shoulder point. 

REOP – Right edge of pavement for the left roadway. 

LHP – Left hinge point. 

MAINLINEPG – Profile Grade Line. 

LEOP – Left edge of pavement for the right roadway. 

RSP – Right side shoulder point. 

RHP – Right hinge point. 

BSR – Begin slope rounding. 

1/4 – Quarter of slope rounding. 

1/2 – Half of slope rounding. 

3/4 – Three quarters of slope rounding. 

RCP – Right side catch point. 
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Step 9. Dismiss the Slope Stake Report dialog box by clicking the X in the upper right hand 
corner. 

Step 10. Exit MicroStation. 
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