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 1 Digital Terrain Model 

Introduction 
Objectives Learn how to display and analyze DTMs for use in roadway design. 

 

A Digital Terrain Model (DTM) represents the topography of a project in the form of a triangulated 
network.  The DTM can be drawn in a 2D or 3D file, and then rotated to see the existing surface of the 
project area. 

Digital Terrain Models can be generated from various sources including MicroStation elements, 
survey data, photogrammetry data, GEOPAK cross-sections, and geometry data. 

Triangulation is a mathematical process applied to ground points and vertices along longitudinal 
features to create planar surfaces.  The result of triangulation is the creation of triangles connecting 
these points. These triangles are included in the GEOPAK TIN file from which existing ground profiles 
and existing ground cross sections can be generated. 

Accessing 
Clicking the Existing Ground button from the Road Project: Road1.prj dialog box 
within Project Manager invokes the tool frame shown to the right.  All of the DTM 
tools can be accessed from the tool frame or from the DTM menu that can be 
accessed from the top/left icon on the tool frame. 
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Load DTM Features 

Tool 
 

 

Menu Bar Load > DTM Feature 

Load is the process by which we can visualize the DTM data, TIN model, lattice model, and contours.  
By selecting the Load DTM Feature icon, the following dialog box appears.   

 

The user can choose to load the DTM data (.dat), the TIN file (TIN), or the Lattice file (.lat).  Each of 
these files can be loaded for the model extents, within a fence, or selected view. 

Activating the Display Only toggle enables the user to view the elements without writing them to the 
MicroStation file (temporary display).  Conversely, deactivating the toggle writes the DTM features to 
the MicroStation design file at the defined symbology. These elements can be placed as a graphic 
group when Display Only is deactivated. 

 

 Activates the display of all Features. 

 Turns off the Display of all Features. 

 Turns on only the selected Feature. This can also be accomplished by activating the toggle 
(below the list box) or double-clicking on an item that is turned off within the list box. 

 Will turn off only the selected item. This can also be accomplished by activating the toggle 
(below the list box) or double-clicking on an item that is turned on within the list box. 
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Analysis Tools 
Tools 

 

Menu Bar Analysis > Height 
Analysis > Profile 
Analysis > Volumes 
Analysis > Elevation Differences 
Analysis > Slope Area 
Analysis > Themes 
Analysis > Drainage Tools 
Analysis > Visibility 
Analysis > Trace Slope Path  
Analysis > DTM Camera 
Analysis > Trench Volumes 

 

The Analysis tools allow the user to visually analyze the digital terrain model utilizing numerous tools 
as a profile analysis, thematic analysis, drainage flow patterns, and visual portions on the model from 
any given location. 

 

Height To determine the height and other associated data dynamically based on user-defined 
data points within the model. 

Profile View a profile based on a user defined MicroStation element. 

Volumes To compute the volume between two TIN models, the volume between a TIN model and 
a plane, or the cut and fill totals between two TIN models while applying a 
shrinkage/swell factors. 

Elevation 
Differences 

Will display the elevation difference or the amount of cut and fill between two TIN 
models, or a TIN model and a plane of constant elevation. 

Slope Area The Slope Area tool displays the horizontal area and actual slope area (area following 
the terrain of the Model). 

Themes Displays the digital terrain model based on different user definable themes such as 
elevation ranges, slope percentage, slope degree, or aspect. 

Drainage Displays and analyzes drainage patterns within a TIN model.  Tools include delineating 
watersheds, drawing flow arrows, determining upstream and downstream traces, finding 
high and low points, and ridge and sump lines. 

Visibility Based on a user-defined point of origin, GEOPAK visually displays which triangles can 
and cannot be seen, or what is visible between two points. 

Trace Slope Path Traces a path along a TIN file using a user specified slope and method. 

DTM Camera Allows a 3d visualization camera for the DTM 

Trench Volumes Compute the excavation volume needed along the drainage pipes. 
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 Lab 1:   Digital Terrain Modeling 

Accessing DTM Tools 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB1_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select the DTM Tools frame from the Applications > GEOPAK 
Road > DTM Tools pull down menu. 

 

 

Load DTM Features 
 

  

 

Step 1. Select the Load DTM Features 
icon from the tool frame to 
invoke the following dialog box. 

 

Step 2. Change the Load File option to 
TIN. 

 

Step 3. Select the TIN file 
‘SURVEY.TIN’ by clicking the 
Files button. 

 

Step 4. Enable the toggles for Graphic 
Group but leave the Display 
Only disabled. 
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Step 5. Select the Triangles Feature by highlighting in the list box. Notice that initially the display 
is set to OFF. You can control the display of an item three ways: 

  Use the “lightbulb” icons to the right of the dialog box 

  Double-click on an item 

  Use the “display” toggle in the lower right corner of the dialog box 

Set the Triangles display to ON. At this point your dialog box should resemble the 
following: 

 

Step 6. Set the display symbology for the Triangles as indicated below: 

 

Step 7. Select the Tin Hull (the boundary of the surface model) feature. Activate the Display of 
the feature and set the symbology as follows; Level = Level 30, Color = 0, Weight = 0, 
Style = 0. 

Step 8. Click Load and review the results.   

Step 9. When complete, toggle OFF the triangles and tin hull. 

Step 10. Select the Contours feature. Activate the Display Feature.   

 Verify that On is set in the Display field. 
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Step 11. Complete the bottom of the dialog box as indicated below. To complete the Minimum and 
Maximum Z, click the Read button, which will review the active TIN file and determine 
these values. 

Enable the Display Only toggle since we only want to “preview” our contours but not 
actually write them to the design file. 

 

Step 12. Activate the Display of the Contour Lines and Labels and set the symbology as indicated 
below: 

 Level Color Weight Style Font TH / TW Distance 

Major Lines Level 10 4 3 0    

Major Labels Level 10 5 3 0 0 TH=3, TW=3 200 

Minor Lines Level 9 1 1 0    

Step 13. Click the Load button to initiate the process. 

Step 14. Close the Load DTM Features dialog box. 

 

Analysis Tools 
We will review several analysis tools in the following exercises.  These include the height, themes, 
profiles tools and drainage tools. 
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Height Tool 

 
 

 

Step 1. Select the Height icon from the tool box to invoke the following dialog box. 

 

 

Step 2. Activate the Show Contour and Show Flow Arrow 
toggles.  

The color may be altered to your choice of colors 
from the active color table on the Height dialog box. 
The weight of the contour line and arrow are 
controlled by the active MicroStation settings. 

Step 3. Click the Start button and scan the surface model 
with the cursor to display the values for xyz and the 
slope on the DTM at the cursor point. 

Step 4. Close the Height dialog box. 
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Themes Tool 

 
 

Step 1. Select the Themes icon from the Analysis tool box to invoke the dialog box depicted 
below. 

Step 2. Ensure that all graphic elements are fit in View 1. 

Step 3. We will determine the Elevation Range for the TIN 
File ‘SURVEY.TIN’. (This is the first icon on the 
dialog box). 

Step 4. Activate the Display Only toggle. 

 

Step 5. Next, click the Set Range button to access the following dialog box. 

 

As shown on the right of the Minimum and Maximum Elevation Fields, the values for the 
active TIN elevations are listed.  By clicking these buttons individually, the elevation fields 
will automatically be populated. 

Step 6. Set the Range option to Auto Range Increment. 

 

Step 7. Set the Auto Range Options as shown below: 
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Step 8. Click the Set Range button to populate the list box on the bottom portion of the dialog 
box. 

 Selection of any list of elevations will populate the fields at the bottom.  

 

Utilizing the buttons on the right side of the list box will permit additional ranges to be 
included in the list, modifications to be made to elevation ranges (or the color display of 
this range), or deleting a particular elevation range. 

 

Step 9. Close the Elevation Range dialog box.  

Step 10. Click the Process button to initiate the display of the Elevation Ranges for the surface 
model. 

Step 11. Close the Themes dialog box. 

Profile Tool 

 
 

Step 1. Select the Profile icon from the Analysis tool box to invoke the following dialog box. 

 

Step 2. Use the Selection tab to identify your surface model (TIN File) which you will generate a 
profile from, and the symbology for your profile. 
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Step 3. Select the Tin File “SURVEY.TIN” by using the Select Files icon. 

Step 4. Double-click on the symbology box (field to the right of the Files icon) to set the 
symbology representing the ground surface profile. You may choose any symbology you 
wish. Once the symbology has been set, click OK. 

Step 5. Click the Add icon (top icon next to the list box) to add the feature to the collection box. 

 

Step 6. Select the Profile Tab. 

Step 7. Click the Place Element button to cut your actual profile at any desired area by just 
placing two data points (i.e. a line) or a series of data points (i.e. a line-string) across your 
surface model at any location. 

 

 

Step 8. You can use the Preferences tab to set up a grid for your profile if desired. 
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Step 9. Close the Profile dialog box. 

Drainage Tools 

 
 

Step 1. Select the Drainage Tools icon from the Analysis tool box to invoke the following dialog 
box. 

 

 

Step 2. Select the Drainage Patterns icon.   

 Fill out the dialog as shown. 

 

 Click the Apply button.  The drainage flow lines are drawn into the design file. 

Step 3. Select the GEOPAK Pond Analysis icon, and click the Apply button. 
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Step 4. Select GEOPAK Pond Analysis dialog. Press Apply and data point inside the 
predelineated pond at station 206+00. The volume is calculated as shown below. 
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Step 5. Select the Delineate Watersheds icon.   

 Fill out the dialog as shown. 

 

Click the Apply button.  The watersheds will be drawn into the design file.  Make sure the 
MicroStation View Attribute ‘Fill’ is toggled on. (Settings > View Attributes) 

Step 6. Exit MicroStation. 
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 2 Getting Started 
 

Objective: Introduction to GEOPAK Drainage. 

 

Overview 
Hydrologic and hydraulic capabilities include runoff computations, inlet design and analysis, and pipe 
and ditch design and analysis.  All computations follow recommended methodologies in the FHWA 
publication "Drainage of Highway Pavements" as well as the procedures in the AASHTO Model 
Drainage Manual. 

Runoff computations are performed using either the Rational or SCS method where rainfall 
parameters may be specified with common intensity equations, hydrographs, or by tabular intensity-
duration data.  Drainage area delineation tools allow easy creation of contributing areas and the 
graphical assignment of these to drainage features.  The extremely tedious task of compiling different 
subareas and runoff coefficients is practically eliminated by GEOPAK Drainage's graphical shape tool, 
allowing easy creation of drainage areas and land use boundaries.  Once the boundaries are defined, 
the runoff coefficient and associated hydrologic parameters are computed automatically by delineating 
the land use zones inside of the drainage area.  Any subsequent modifications to the boundaries will 
update the runoff coefficient via a single mouse click. 

Inlet design and analysis capabilities include Curb, Slotted Drain, and Grate inlets both on grade and 
in a sump.  Inlet designs may proceed through a user specified library of standard inlet sizes to 
determine the most suitable design for a given set of user prescribed constraints.  Inlets may also be 
designed or analyzed with by pass flows from one inlet to another, including by pass flows between 
inlets of different networks. 

Most standard pipe configurations may be designed and analyzed including arch, box, circular, 
elliptical and pipe arches.  A library of available sizes in most common materials (Aluminum, 
Concrete, Steel, and Plastic) is provided for the designer to select sizes or simply specify types for 
GEOPAK Drainage to select the appropriate size.  Pipe design selections may be optimized for both 
size and depth of cover. Trapezoidal ditches may also be designed or analyzed anywhere within a 
storm drain network.  The pipe and ditch hydraulics include backwater curve computations and 
junction loss options. 

GEOPAK Drainage File (GDF) 
The first component is the GEOPAK Drainage File (*.gdf).  This binary file contains all the hydraulic 
information about the drainage system.  Each GEOPAK Drainage Project contains Preferences, which 
include hydrologic and hydraulic computation options, visualization symbologies, and project file 
references to the Drainage Library and GEOPAK GPK files.  Spatial data, connectivity and hydraulic 
properties for each drainage feature are stored in this external file. Sufficient data is maintained to 
rebuild the graphical representation of the Drainage Project with the exception of certain features, 
which are defined by MicroStation elements (i.e. Drainage Areas). 
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Main Menu Bar 
GEOPAK Drainage is invoked from within a two dimensional MicroStation graphics file.  At the 
Applications pull down, select GEOPAK Drainage, which accesses the software and displays the main 
GEOPAK Drainage menu bar as depicted below. 

 

Each menu selection accesses GEOPAK Drainage project information, feature placement and tools 
necessary to complete a GEOPAK Drainage project.  Tool frames and toolboxes are also supported 
for all functions and are accessed via the Tools pull down. 

Project Menu Selections 
The Project Menu selections are utilized for creating new GEOPAK Drainage projects, opening 
existing projects, saving projects, establishing the project Preferences, editing the Drainage Library, 
importing and exporting between GEOPAK Drainage Files (gdf). 

 

Component Menu Selections 
The Component menu selections provide the mechanism to add, edit and delete the various 
elements, which comprise a drainage system including Areas, Nodes, Links, Reaches, and Land 
Uses.  Each of these tools invokes a dialog wherein the specific component information can be added 
or edited.   
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Network Menu Selections 
The Network menu selections provide tools to add, edit, delete, and manipulate a drainage Network.  
While work is being done on a particular Network, it can be identified as the Active Network, which 
dictates which features are contained in the calculations and provides quick access to the 
components of a specific Network.  Once a Network is added to the project and set as the Active 
Network, the Design and Analyze options perform their respective hydraulic procedures on the 
Network. 

 

Reports Menu Selections 
The Reports menu selections provide access to the predefined hydrologic and hydraulic reports 
available and to the Custom Report Builder and Generator. 

 

Tools Menu Selections 
The Tools menu selections provide access to all Tool Boxes, Navigator, Labeler, Culvert, Routing and 
DTM Drainage Tools. 
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Project Workflow 
The GEOPAK Drainage workflow mirrors a conventional design process beginning with the design of 
the surface collection system (inlets, drainage areas) followed by the design of the conveyance 
system (subsurface pipes, channels). 

Roadway alignments, vertical profiles, and digital terrain models may be used throughout GEOPAK 
Drainage to provide pertinent information to the drainage design.  All drainage components feature 
interactive graphical placement tools for easy definition of the drainage system. 

Each of these components (inlets, areas, and pipes) is composed of two basic types of information: 

 Spatial information describing its location, shape and connectivity. 
 Hydraulic and Hydrologic information describing its properties, conventions and other 

associated attributes. 
 

 

Drainage Components 
GEOPAK Drainage organizes the components of a drainage system according to their spatial 
characteristics.  Spatial information is stored as Nodes, Links and Networks. 

 Nodes:    A node (inlets, manholes, etc.) is a point with a user-defined location.  The location 
may be in Cartesian coordinates (x,y) or in curvilinear coordinates (station, offset).  

 Links:   A Link represents a linear feature depicting a path connecting two nodes, traversing 
upstream to downstream.  The path may be straight line or curvilinear (along a graphic 
element). 

 Networks:   A network is a system of interconnected nodes and links that form a system 
through which water can flow to a single outlet node. A drainage project accommodates any 
number of Networks. 

Other associated components in GEOPAK Drainage include: 

Areas:   A drainage area can be represented by a closed boundary or simply keyed-in (acres or 
hectares). All flows from a single drainage area are tributary to a single Node. There is a one to one 
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correspondence between a node and an area.  Therefore areas and nodes share the same name 
(ID). A drainage area may contain multiple subareas representing homogeneous features such as soil 
types and land uses (“C” values), thereby allowing composite "C" value calculations. 

Reaches:    A reach represents a path connecting any two nodes in a Network. Reaches provide the 
visualization of profiles between any two nodes in a drainage network. 
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LAB 2: Getting Started 

File Information 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB2_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

 The following files are utilized for this project.  The directory path for the sample project is 
c:\data\geo\VDOT\drain1\ 

Drainage Design File h17682.dgn 

Reference File (land use file) h17682da.dgn 

Reference File (proposed roadway file) d17682des.dgn 

Reference File (existing topography) s17682.dgn 

English Drainage Library vdot.dlb 

English Cell Library drainage.cel 

GPK Alignment File job101.gpk 

GEOPAK Drainage File (to be created) h17682.gdf 

Existing Triangulated Irregular Network file (TIN) survey.tin 

Proposed Triangulated Irregular Network file (TIN) proposed.tin 

 

Invoke GEOPAK Drainage 
Step 1. Access GEOPAK Drainage from MicroStation’s pull-down menu: Applications > Geopak 

Drainage > Drainage. 

Step 2. Create a new drainage project: Drainage > Project > New.  

Step 3. Name the new project : h17682.gdf. 

Step 4. Exit MicroStation. 
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 3 Drainage Library 
 

Objective: Review the Drainage Library. 

Goal: Review the various options contained within the Drainage Library. 

Drainage Library 
The Drainage Library is used to store data and standards which may be shared by different projects 
and designers.  Each GEOPAK Drainage project simply accesses items within the library for use on 
the specific project.  The library contains five major categories: 

 Rainfall Data 
 Land Use Runoff Coefficients 
 Nodes (Inlets, Junctions, etc.) 
 Links (Pipes) 
 Spread Sections 

Note:  The Library is unit specific, i.e., Metric or English. 

The Drainage Library is invoked by selecting Tools > Tool Boxes > Main, then 
identifying the Drainage Library tool, (second column, top box) as depicted to 
the right. 

Alternately, selecting Project > Drainage Library, from the MicroStation Menu bar, 
can also invoke the Drainage Library. 
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The main Drainage Library dialog is displayed on the screen as depicted below. 

 

Five tabs are supported for the major categories within the Drainage Library: 

 Rainfall 
 Land Use 
 Nodes 
 Links 
 Spread Section 

Rainfall Items 
Within the Drainage Library (beneath the Rainfall tab) are the Rainfall Items, which store all the rainfall 
data sources to be used on subsequent GEOPAK Drainage Projects.  GEOPAK Drainage supports 
rainfall sources in the form of intensity duration frequency (IDF) tables, two SCS methods, or as 
coefficients for three different preset intensity duration equation formats. 
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When an Item is modified or added, the Rainfall Data Source Item dialog is invoked as depicted 
below.  

 

Four Rainfall Data Types are supported as depicted in the exploded view below.  Selection of each 
option dynamically changes the dialog to reflect the selection. 

 

Land Use Items 
Land Use Items take advantage of the drainage area delineation tools in GEOPAK Drainage and are 
used to store runoff coefficients and corresponding graphic symbology for various land uses contained 
in Drainage projects.  Under the Land Uses tab, the designer may create as many Items as desired.  
The Land Use Item dialog is depicted below. 
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Item ID  Land Use Item Identification to recall the item from within a GEOPAK 
Drainage project.  (Maximum of 32 alphanumeric characters). 

Description Description of the Land Use Item.  (Maximum of 32 alphanumeric 
characters). 

Land Use Description  Description of each Land Use. (Maximum 32 alphanumeric characters). 

Runoff C  Runoff coefficient for the Rational Method (C Value). 

Level, Color, Style, Weight  Specified element parameters which uniquely identify the various land use 
descriptions. 

Edit Buttons: 

Add (+) 

Delete (-) 

Modify (/) 

To add to the list box, simply key in the required values in the edit fields 
directly below the list box, then press the Add (+) button to the right.   

To delete a line from the list box, simply highlight the line to be deleted and 
press the Delete (-) button. 

Modify a line by highlighting the desired line in the list box; make the desired 
changes in the edit fields directly below the list box, then press the Modify (/) 
button.   

OK / Cancel Action buttons which also close the dialog 

 

Node Items 
Node Library Items define the type of Node structures used on subsequent GEOPAK Drainage 
projects.  The Nodes contain standard inlet configurations for Grate, Curb, and Slotted Drain inlet as 
well as Junctions (i.e., manholes), Outlets, and Other generic Nodes (i.e., grade breaks) as may be 
required for various Drainage projects.  The description, plan view representation, and dimension 
information for each Node item is entered only once in the library and then referenced by each project. 

 



Node Items 

 

VDOT GEOPAK Drainage Training Manual 
1/27/2006 25 

Under each Node Types are various stored Node configurations.  A typical listing may appear as 
follows: 

 

All Node items have certain characteristics in common.  The typical Node item dialog and the 
common data requirements are shown below. 
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Link Items 
The Link Items are used to store all the pipe configurations that may be used on a GEOPAK Drainage 
project and is depicted below. 

 

The Links Tab is the source of shapes, materials, dimensions, and hydraulic properties of these 
features.  When designing these components, the items serve as the means to specify design 
candidates.  If pipe items are deleted, these items will no longer be available for use on a project 
using the specific library.   

 

The Links are categorized by three types of properties for each pipe: 

 Shape 
 Material 
 Type or corrugations 
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Each pipe contains the specific pipe sizes and default roughness coefficients for each shape, and 
material combination.  There are English and Metric libraries provided with GEOPAK Drainage, which 
contain virtually every standard pipe configuration. 

Spread Section 
The Spread Section tab is utilized to store roadway pavement spread information.  When selected, the 
dialog dynamically changes as depicted below. 

 

When double clicking on an entry in the list box, the dialog depicted below opens. 

 

Input is available for the Spread Width, Slope, and Manning’s N value. 
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LAB 3:   Drainage Library 

Review Drainage Library 
The Drainage Library is used to store hydraulic, hydrologic, and construction standards, which may be 
shared by different projects and designers.  Each GEOPAK Drainage project accesses items from the 
Drainage Library for use on the specific project. 

Step 1. Execute c:\data\geo\VDOT\drain1\LAB3_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Project > Open from the Geopak 
Drainage pull down menu. 

Step 5. Select Project > Drainage Library. The library stored in the Preferences will be opened 
by default. 

 The Drainage Library currently contains five (5) tabs as indicated below: 

 Rainfall: Rainfall Data Source 
 Land Uses: Land Uses and their corresponding “C” values and symbology 
 Nodes: Inlets, Junctions, Manholes, Outlets, etc. 
 Links: Circular Pipes, Elliptical Pipes, Pipe-Arch pipes, Boxes, etc. 
 Spread Section: Inventory of varying Spread Cross Sections 
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Rainfall Tab: 
The Rainfall Tab stores the rainfall data information to be used on GEOPAK Drainage Projects.  
GEOPAK Drainage supports rainfall sources in the form of intensity duration frequency (IDF) tables, 
or as coefficients for intensity-duration-equation formats.  Also supported are the HYDRO-35 and TP 
40 methods of rainfall. 

Step 1. Select the Rainfall tab, highlight Campbell, and select Modify: 

 

 

 

 

 Review the various Data Types of Rainfall accepted. 
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Land Use Tab: 
The Land Use Tab is used to store runoff coefficients ("C" values) and corresponding graphic 
symbology for each land use.  Land Uses can then be delineated automatically using the selected 
symbology. 

Step 1. Select the Land Use tab, highlight the VDOT Land Use item and select Modify: 

 

 

 Review the various land uses and their associated symbology. 
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Nodes Tab: 
The Nodes Tab contains standard configurations for Grates, Curbs and Slotted Drain inlets, as well as 
Junctions, Outlets and Other Nodes.  The description, plan view representation, and dimensional 
information are stored for each node.  

Step 1. Select the Node tab, highlight the first curb inlet, and select Modify: 

 

 

 

 

Review the various geometric inputs required for the 
Nodes. 
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Links Tab: 
The Links Tab contains all pipes to be used on the Drainage project.  Each pipe is categorized by 
three properties: Shape, Material, and Type (corrugation); and contains information regarding specific 
pipe geometry, default roughness coefficient, and material combination. 

Step 1.  Select the Links tab, and switch the Shape to Circular and Material to Concrete.  

  Highlight the second Circular Concrete pipe, and select Modify: 

 

 

 Review the various geometric inputs required for the Links. 
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Spread Section: 
The Spread Section stores standard cross sections (for roads, gutters, etc.) to be used on GEOPAK 
Drainage Projects.   

Step 1. Select the Spread Section tab, highlight the 2 LANES+GUTTER section, and select 
Modify: 

 

 

 Review the spread cross-section characteristics for each spread item. 

Step 2. Exit MicroStation.  
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 4 Project Preferences 
 

Objective: Review the Project Preferences. 

Introduction 
GEOPAK Drainage supports a wide array of user defined Preferences which enables the designer to 
set project specific options, or a large organization to set parameters to maintain standards.  Each 
GEOPAK Drainage project contains a set of Preferences and they remain with the project.  
Computation options in the Preferences may be changed easily and the systems completely 
redesigned utilizing the new computation options.  The Preferences are invoked via Project > 
Preferences.  

The Drainage Preferences can also be invoked by selecting Tools > Tool Boxes > Main, then 
identifying the Drainage Preferences tool, (first column, top box). 

 

When invoked, the dialog depicted below is displayed. 

 



Units 

 

VDOT GEOPAK Drainage Training Manual 
1/27/2006 36 

The general Options are displayed in a list box in the left side of the dialog, while the right side 
displays parameters for the highlighted Option.  As different Options are selected in the list box, the 
right side of the dialog will change dynamically to reflect the parameters for highlighted Option. 

Units 
The first Preference is Units, which establishes the input and output units for the current project.  Two 
supported options are English and Metric, as depicted in the dialog below. 

 

Within each group box is a listing of the units utilized for GEOPAK Drainage.  These are display only 
and cannot be changed. 

Note: Projects with mixed units are not supported within GEOPAK.  There are no other unit 
specifications within the project.  The data input is expected to be in the proper units (English and 
Metric).  As fields are entered in the dialogs the units required will be displayed in the MicroStation 
Command Prompt. 

Coordinate geometry databases (GPK files) must also be in the specified units when created within 
GEOPAK ROAD.  For additional information on this topic, refer to the GEOPAK Online help > 
Coordinate Geometry. 
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Project Components 
The Project Components, as depicted in the dialog below, defines the location of all files utilized by the 
project. 

 

Fields in this dialog are described in the table below. 

Drainage Library File 
(DLB)  

Reference to the Drainage Library file containing the Rainfall Parameters, 
Land Use Options, Node Library items, Link Library items and spread 
sections.  This file can be located within the working directory, in which case, 
no path need be specified.  However, a more prudent option is placing the 
Drainage Library File on a central server or directory, so that all hydraulics 
designers can access the same database.  This ensures standardization and 
minimal maintenance.  The file name (and optionally, the path) may be 
supplied.  Pressing the Files button will invoke the MicroStation File 
Manager, wherein the path and database file may be selected. 

GPK Job Number  

(optional) 

GEOPAK coordinate geometry database which contains all alignment and 
profile information for the project.  Creation and manipulation of this binary 
file must be accomplished from within GEOPAK ROAD.  For further 
information, refer to the GEOPAK ROAD User Reference Manual, part II.  
The file name of the database is job*.gpk, where * is a one to three 
alphanumeric name unique to each project.  It is this name that should be 
typed into the GPK Job Number field.  In lieu of typing the name, pressing the 
Select button will invoke a File Manager wherein the GPK file may be 
selected.  

Road Preferences  Invokes the GEOPAK User Preferences dialog as depicted below. 
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The working directory, wherein the GEOPAK coordinate geometry database 
is located, is specified within this dialog.  The directory may also contain 
other project files, which is desirable; however, this is not required by 
GEOPAK Drainage.  

Drainage Cell Library Cell library wherein cells utilized for Nodes contained in the Drainage Library 
are located. 

Site Modeler File To leverage data from a GEOPAK Site project, activate the toggle, then 
select the directory and GEOPAK gsf file. 

Criteria Directory Define the directory wherein the criteria to draw nodes, links and other 
drainage data onto cross sections is stored. 

Automatically Save 
Drainage Updates 

When activated, the GEOPAK drainage file (*.gdf) is automatically saved 
after each update. 

Superelevation Shapes Optionally, GEOPAK superelevation shapes created in GEOPAK Road can 
be leveraged into drainage.  Specify the path and file name by manual entry 
or pressing the Files button to select from the dialog.  In order to utilize and 
extract superelevation data from the shape file, the file must be referenced 
into the active design file. 
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Rainfall Parameters 
The Rainfall Parameters dialog establishes the rainfall parameters for computing intensities and 
discharges for the current project.  When selected from the Options list, the dialog depicted below is 
displayed. 

 

Fields in this dialog are described in the table below. 

Rational Method Rainfall 
Source 

The Rainfall Data Source for computing intensities and discharges, which 
is stored within the Drainage Library File, therefore it may only be selected 
here.   

SCS Method: 
Rainfall Source 

The Rainfall Data Source for computing discharges, which is stored within 
the Drainage Library File.  Therefore, it may only be selected here.  The 
Antecedent Moisture Condition I is the lowest runoff potential (dry soil), 
while Antecedent Moisture Condition II is the average condition, while 
Antecedent Moisture Condition III is the highest runoff potential (saturated 
soil).   

Hydrograph Time Interval Specified in terms of minutes. 
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Land Use Options 
The Land Use dialog establishes the land use options used to delineate subareas and runoff 
coefficients for the current project.  When selected from the Options list, the dialog depicted below is 
displayed. 

 

Fields in this dialog are described in the table below.  Different Single and Multiple Land Use Items 
can be defined for the Rational and SCS Method. 

Single Land Use Item The land use source from the Drainage Library containing the runoff 
coefficients and symbology for land use delineation may be selected 
from the list box. 

Multiple Land Use Item The land use sources from the Drainage Library containing the 
runoff coefficients and symbology for land use delineation.  To 
select, utilize the down arrow in the list box and select the desired 
option.  The item selected must be associated with a symbology that 
matches the symbology of each of the main land use shapes in the 
design file.  
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Frequency Options 
The Frequency Options dialog establishes the computation frequency and runoff peaking factors for 
discharge computations for the current project.  When selected from the Options list, the dialog 
depicted below is displayed. 

 

Fields in this dialog are described in the table below. 

Drainage Library File 
(DLB) 

The current Library File as specified in the Project Component 
option is displayed. It cannot be changed from this dialog, only in the 
Project Components. 

Computation Frequency  The displayed frequencies are selected from the available entries in 
the Rainfall Parameters chosen from the library.  These fields 
cannot be modified except through the Drainage Library dialog.   

Cumulative Frequency The displayed depths are selected from the available entries in the 
Rainfall Parameters chosen from the library.  These fields cannot be 
modified except through the Drainage Library dialog.   

Peaking Factors  Runoff coefficient peaking factors to be applied in the runoff 
computations.  These factors are used to adjust runoff coefficients 
for differing frequency rather than entering multiple set of 
coefficients for each frequency. 
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Intensity Option 
The Intensity Options dialog establishes the intensity computation options for the current project.  
When selected from the Options list, the dialog depicted below is displayed. 

 

Fields in this dialog are described in the table below. 

Drainage Library File 
(DLB) 

The current library file, as specified in the Project Component option, is 
displayed.  It cannot be changed from this dialog, only in the Project 
Components. 

Minimum Time of 
Concentration 

Minimum Time of Concentration to use in discharge computations. This 
is used throughout the computations as the minimum.  In pipe hydraulic 
computations this value will be used until the actual time of 
concentration within the systems exceeds this value.  Specified in 
terms of minutes. 

Accumulate Pipe 
Flow Time by: 
Uniform Flow 
Velocity 
Full Flow Velocity 
Interactive Velocity 

The Accumulate Pipe Flow options adjust the travel time through the 
pipe.  Options include Uniform Flow Velocity and Full Flow Velocity.  If 
the iterative velocity is selected, GEOPAK designs the pipe for three 
iterations, so the travel time is based on the actual velocity for the three 
trials. 

Intensity Options 
group box 

 

Intensity options which allow for specification of an absolute (constant) 
intensity or computed intensities to use throughout the network 
discharge computation procedures. 

Compute Intensity 
from Library Rainfall 
Data Source  

Utilizes the values established and computed from the Rainfall 
Parameters (either default equation or table) from within the Drainage 
Library File.   

Absolute Intensity  A constant intensity that overrides the Drainage Library File and utilizes 
the specified value for all discharge computations.  It is specified in 
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terms of in/hr or mm/hr depending on the project units. 

Weight Time of 
Concentration  

When utilizing combining different types and times of concentration, 
activating this toggle weights the times of concentration such that the 
discharge will not decrease. 

Inlet Computation 
Only  
(group box) 

 

Absolute Intensity  A constant intensity that overrides the Drainage Library File and utilizes 
the specified value for discharge computations required for inlet and 
spread calculations only.  Network hydrologic discharges will be 
computed as specified in the Intensity Options.  Note, however, for the 
value to be utilized, the toggle to the left of the Absolute Intensity within 
the Inlet Computation Only group box must be activated or the value will 
be ignored.  Specified in terms of in/hr or mm/hr depending on the project 
units. 

Junction Losses 
The Junction Losses dialog establishes the junction loss equations and coefficients utilized in Link 
hydraulic calculations for the current project.  When selected from the Options list, the dialog depicted 
below is displayed. 

  

Fields in this dialog are described in the table below.  Unique Loss Coefficients (K) can be specified in 
the fields to the right of each Description.   

Disable All 
Junction Loss 
Computations 

If the toggle is active, no Junction Loss computations are calculated.  Note 
if a single or small number of Junction Losses are not desired, an option is 
provided later in the design to accomplish this.  The toggle here applies to 
the entire project. 

Loss Velocity Losses can be computed on Actual or Full Flow. 

Pressure 
Expansion 

Loss coefficient to be used in pressure (full flow) expansions within the 
system. 
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Free Surface 
Expansion 

Loss coefficient to be used in free surface (partial flow) expansions within 
the system. 

Pressure 
Contraction 

Loss coefficient to be used in pressure (full flow) contractions within the 
system. 

Free Surface 
Contraction  

Loss coefficient to be used in free surface (partial flow) contractions within 
the system. 

Bend Loss Specify the methodology and source of bend loss computations.  

 

Method 1 utilizes Modern Sewer Design, while Method 2 utilizes AASHTO 
methods. 

Terminal Inlet /  
Junction 

Loss coefficient to be used at terminal inlets or junctions (no upstream 
pipes) within the system. 

Simple Junction Specify the methodology for computing junction losses at simple junction 
(one pipe into the junction and one pipe out).   

 

Complex 
Junction  

Specify the methodology for computing junction losses at complex 
junctions (more than one pipe in and only one pipe out).  

 

 

For a detailed discussion of the specific hydraulic algorithms, see the technical reference section of 
the On-Line Help. 
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Inlet Options 
The Inlet Options dialog establishes the default inlet variables to use in the Node Configuration 
Properties dialog for each type of Inlet.   

 

Fields in this dialog are described in the table below.   

Inlet By Pass 
Options  

This option indicates the method by which Inlet by pass flows are 
accounted for in the system.  By Pass as Total Discharge will account for 
by pass flows as the difference between the total discharge to the inlet and 
the inlet capacity.  This difference, expressed in flow units, will be the total 
by pass from the inlet and can be added at a subsequent downstream 
inlet.  By Pass as C x Area Product, on the other hand, is determined 
from the total bypass at the inlet as a product of runoff coefficient and 
drainage area that is contributing to the total bypass at the inlets computed 
intensity.  This product of area and runoff coefficient will then be added to 
the composite runoff coefficient and area at the downstream inlet. 

Link By Pass 
Options 

 

This option indicates the method by which Inlet By Pass flows are 
accounted in the Link discharge computations.  Do Not Allow Inlet By 
Pass in Link Discharges will prevent the system from bypassing 
discharges from one inlet to the next when Link discharges are computed.  
The total discharge that reaches the inlet will be considered entering the 
Link at that point.  This option in no way impacts the inlet computations, 
bypass flows will be reflected in these computations.  Allow Inlet By Pass 
in Link Discharges will account for the discharge that bypasses the inlets 
when the Link discharges are computed.  Only the discharge entering the 
inlet will be considered entering the Link at that location.  Bypass flows will 
be directed to the appropriate inlet and the Link accordingly. 

Default Spread N 
Value 

The default Manning's roughness coefficient for the spread hydraulic 
computations. 
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Node Options 
The Node Options establish the default naming prefix for Node entries and option for automatic link 
updates.  When selected from the Options list, the dialog depicted below is displayed. 

 

Fields in this dialog are described in the table below.   

Default Node ID Prefix This prefix will be added to the beginning of the each defined 
Node element automatically and then numerically sequenced by 
one.  For example, the first Node stored would obtain default ID in 
this case of “CB A – 1” followed by “CB A – 2”, “CB A – 3”, etc. for 
subsequent Nodes. 

Automatic Link Updates 
On Node Relocations  

When activated, moving any Node will automatically update the 
connected Links. 

Scale Node Cells / 
Scale Factor 

When active, the node cells are scaled based on the specified 
scale factor.  In this way, the node cell can utilize standard node 
dimensions, but the cells scaled in plan view. 
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Link Options 
The Link Options dialog establishes the default Link design constraints.  When selected from the 
Options list, the dialog depicted below is displayed. 

 

Fields in this dialog are described in the table below.   

Default Link ID Prefix This prefix, similar to the one found in the Node Options, is added to 
the beginning of the each defined Link element automatically and 
then numerically sequenced by one. For example, the first Link 
stored would obtain default ID in this case of “SS – 1” followed by 
“SS – 2”, “SS – 3”, etc. for subsequent Links. 

Link Profile Options  

 

A pipe profile envelope is developed which represents the minimum 
soffit elevation and maximum invert elevations for each network.  
This envelope is derived from an evaluation of all the constraints of 
the system; minimum and maximum depth, minimum and maximum 
pipe rise, minimum and maximum slope, and any elevations held 
through the system. The Minimize Pipe Size option will use the 
entire envelope to size pipes.  If a smaller pipe will fit within the 
envelope at a steeper slope then it will be selected as the candidate 
of choice.  If using the entire envelope does not result in smaller 
pipes then the top of the envelope will be used and the appropriate 
pipe fitting this slope configuration will be selected. The Minimize 
Depth of Cover will size pipes based on the top of the envelope, 
minimum soffit elevation and the pipe fitting this slope configuration 
will be selected. One Design Optimization method per project may 
be selected, however, the option may be changed anytime during 
the design process, the results quantified, and the effects of the 
Design Optimization reviewed. 

Minimize Pipe Size GEOPAK Drainage bases the design on minimizing pipe size, even 
though this may encourage deeper excavation.   
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Minimize Depth of 
Cover 

GEOPAK Drainage designs the system with minimal excavation, but 
utilizes larger pipe sizes.   

Elevation Option  Two options are supported:  at Hydraulic Center and at Actual Link 
End.  This is reflected in the Link dialog in the condition option. 

Link Design Options  

 

Only one option may be selected for a project, however, this may be 
changed during the design process.   

Design for Maximum 
Capacity 

This option sizes pipe using maximum capacity.  This typically 
occurs at some percentage less than full.  

Design for Full 
Capacity 

This option sizes pipe using full flow (100%) by depth.  If a pipe is 
designed, the smallest size corresponding to a capacity greater than 
the discharge will be selected. 

Design Partial 
Capacity  

(d/D) Ratio  

The ratio of the diameter of the pipe capacity versus the diameter of 
the total pipe to be used as the maximum capacity in pipe sizing as 
depicted in the graphic below.  Note the value is a ratio (in decimal 
format) which must be equal to or smaller than one.  If the value is 
equal to one, the pipe is designed for full capacity. 

 

Design Partial 
Capacity  

(q/Q) Ratio  

The ratio of the pipe capacity versus discharge to be used in 
computing maximum capacity in pipe sizing algorithms. For example 
if the value is set to 0.5 then all pipes designed will have a capacity 
of twice the discharge and if set to 2.0 the pipes would have half the 
capacity of the discharge 

Link Slope Decimal Options range from none to four.  This limits the number of decimal 
places reported for most link slopes. 

Link Criteria File Name of criteria file which draws links onto cross sections. 

Hydraulic Gradeline 
Options  

 

Equal Hydraulic 
Gradeline 

This option for computing hydraulic gradelines assumes that the 
starting downstream hydraulic gradeline of one Link is equal to the 
upstream hydraulic gradeline (plus junction losses if applicable) of 
the downstream Link. 

Equal Energy 
Gradeline 

This option for computing hydraulic gradelines assumes that the 
starting downstream energy gradeline of one Link is equal to the 
upstream energy gradeline (plus junction losses if applicable) of the 
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downstream Link.  The hydraulic gradeline will then proceed from 
the energy gradeline less the velocity head in the pipe.  If the energy 
value in the downstream Link does not exist (too low) in the 
upstream pipe, the minimum specific energy and critical depth are 
used at the downstream end of the Link.  

Design Symbology 
The Design Symbology dialog establishes the element symbology for drawing drainage features 
during the design process.   

When selected from the Options list, the dialogs depicted below are displayed, depending on the Type 
selection. 

 

 

Fields in this dialog are described in the table below. 

Type Selection of the Type, either Plan or Profile, dynamically changes the 
dialog to reflect either Plan or Profile Components.   

Component The supported components are depicted in the graphic above.  Unique 
parameters may be defined for each component or the same parameters 
may be utilized. 

Level Any valid MicroStation level may be specified wherein the component will 
be placed. 

Color The color picker may be utilized to select the desired color for each 
component. 

Text Size For the Plan type, labels will be placed at the specified text size.  No text 
options are supported at this time for the Profile type all profile labels are 
placed at the current MicroStation Text Settings. 

Label For Plan type components, labels will be placed if the Label toggle is 
activated. 

Style or Symbol Any line style may be utilized, but custom line styles have to be utilized via 
the Design and Computation (DDB) tool.  In addition, for Node elements a 
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default plan view cell may be entered under Symbol used in lieu of the 
cells for each Node in the Drainage Library when the DLB file can't be 
retrieved.   

Weight Any valid MicroStation weight may be specified for each component. 
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LAB 4: Project Preferences 

Project Preferences 
The Project Preferences control the graphic and computational options of the drainage system. The 
Project Preferences may be changed at any time and the system can then be redesigned or analyzed 
utilizing the new preferences.  

Step 1. Execute c:\data\geo\VDOT\drain1\LAB4_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Drainage > Project > Open from 
the MicroStation menu. 

Step 5. Select Drainage > Project > Preferences. 

Note: Establish the Preferences by selecting each option in the column and defining the various 
values. 

Step 6. Units:  

 

 Select English units. 
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Step 7. Project Components:  

 

Drainage Library File (DLB)  VDOT.dlb 

GPK Job Number Job101.gpk 

Drainage Cell Library drainage.cel 

Geopak DDB Vdotenglish.ddb 

Step 8. Rainfall Parameters: 

 

 

 

 

 

 

Rational Method Campbell 

SCS Method Type II  

Antecedent Moisture Condition II ON 

Hydrograph Time Interval 5.0 
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Step 9. Land Use Options:  

 

 Set the Rational Method Single Land Use to VDOT. 

Step 10. Frequency Options: 

 

Set Rational Frequency Options to 10 Year with a 1.0 Runoff Coefficient Peaking Factor 
and the Cumulative Frequency to 8 inches for the SCS Method. 
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Step 11. Intensity Options: 

 

Minimum Time of Concentration 5 minutes 

Accumulate Pipe Flow Time by Uniform Flow Velocity 

Intensity Options Use Compute Intensity from Library Rainfall 
Data Source 

Inlet Computation Only Toggle ON , 4.0 

 

 

Step 12. Junction Losses : 

 

 Toggle ON Disable All Junction Losses Computations. 
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Step 13. Inlet Options: 

 

Inlet By Pass Options By Pass as Total Discharge 

Link By Pass Flow Options Do Not Allow Inlet By Pass in Link Discharge 

Default Spread n Value 0.015 

 

Step 14. Node Options: 

 

Default Node ID Prefix 3- 

Scale Node Cells Toggle OFF 

Minimum Freeboard 1.00 
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Step 15. Link Options: 

 

Default Link ID Prefix pipe- 

Design Optimization Minimize Depth of Cover 

Elevation Option at Actual Link End 

Link Design Options Design for Maximum Capacity 

Link Slope Decimal 2 

Hydraulic Gradeline Options Equal Hydraulic Gradeline 

 

Step 16. Plan Symbology: 

 

 Utilize the plan symbology shown above for this project.  Establish the symbology of future 
projects according to your standard conventions. 
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Step 17. Updates:  

 

 

Step 18. Save Options:  

 

Step 19. Press the OK button to accept the Project Preferences. 

Note: The Preferences may be changed at any time during the course of the project. 

Step 20. Exit MicroStation. 
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 5 Drainage Areas and Nodes 
 

Objective: Review Drainage design procedures.  

Introduction 
Drainage Areas in GEOPAK Drainage may be used to simply compute peak discharges or to attach 
computed discharge values to Nodes within a GEOPAK Drainage Project. The physical drainage area 
boundaries may be delineated using a digital terrain model, simply drawn with MicroStation, or just 
keyed in as a total area value. 

The Drainage Library is an integral part of defining and computing discharges for Drainage Areas.  
With graphical definition of the area boundary, runoff coefficients may be automatically computed with 
the use of Land Use Items from a Drainage Library. Intensity values for the peak discharge 
computations are also computed with the use of Rainfall Items from the Drainage Library. 

Graphical definition of Drainage Areas through the DTM Drainage Tools or MicroStation is 
accomplished through the creation of MicroStation closed shapes and subsequent selection of the 
shape during the Drainage Area creation process. 

 

In order to assign Drainage Areas and the resulting peak discharges to Nodes of a storm drain 
network, the Drainage Area ID must match that of the Node. 

Several options are supported to add, edit and delete Areas and are invoked via the Component pull 
down on the main menu bar. 

Alternately, the Area tools are invoked by selecting Drainage > Tool Boxes > Area, then identifying the 
desired tool from the toolbox as depicted below. 

 

Tools from left to right are:   
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 Add Drainage Area 
 Modify Drainage Area 
 Delete Drainage Area 
 Update All Drainage Areas 
 Drainage Area Report 

Delineating Subareas 
In order to delineate and add subareas for a particular Area, select the Delineate Subarea option 
within the Computations group box of the Drainage Area Definition dialog to invoke the Subarea 
Definition Tool.  Subareas are defined as smaller components within a drainage area that exhibit 
different land uses or runoff coefficients.              

 The Subarea Definition tool is utilized to define the subareas within the current Drainage Area.  
The subareas may be delineated from the land use boundaries automatically or entered into 
the table by the designer. 

Introduction to Nodes 
Nodes in GEOPAK Drainage are used to define structure points within a drainage Network.  Nodes 
create all the Inlets, Junctions, and Outlets in the Network and provide for the connectivity of the Link 
system.  Nodes are also used to indicate physical changes in Link sizes or slopes.  Links cannot 
change size or slope, other than at Nodes.  Eight categories of Nodes may be placed in a drainage 
project and are as follows: 

 Curb – used for Curb opening Inlets with or without pipe confluences. 
 Grate – used for Grate opening Inlets with or without pipe confluences. 
 Slotted Drain – used for Slotted Drain Inlets with or without pipe confluences. 
 Junction – used for any confluence of pipes, structure location (that is not an Inlet), pipe size 

or slope change, or flow addition that does not require an Inlet. 
 Other - used for any miscellaneous points in a system such as a confluence of pipes, 

structure location (that is not an Inlet), pipe size or slope change, or flow addition that does 
not require an Inlet.  They are also used between links that are ditches. 

 Outlet – used for the Outlet, or outfall, of a storm drain Network.  
 Bottom – used for the bottom portion of an inlet or node structure. 
 Headwall – for culvert tool only. 

 

The Drainage Library is an integral part of defining Node properties.  The Node types, names, 
descriptions, physical dimensions, hydraulic properties, and plan view representation are all defined 
within the Drainage Library and merely referenced and selected out of the library.   

Several options are supported to define, edit and delete Nodes and are invoked via the Component 
pull down on the main menu bar. 

Alternately, the Node tools are invoked by selecting Drainage > Tool Boxes > Node, then identifying 
the desired tool from the toolbox as depicted below. 

 

Tools from left to right are:   
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 Add Drainage Node 
 Modify Drainage Node 
 Delete Drainage Node 
 Update All Nodes 
 Update Nodes With Pay Items 
 Drainage Node Report – Sump 
 Drainage Node Report – On Grade 
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LAB 5:  Drainage Design 

Introduction 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB5_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Project > Open from the GEOPAK 
Drainage pull down menu. 

  The proposed drainage design will accommodate drainage runoff from the portion of the 
roadway as shown below: 

 

Design Inlet  3 – 1 
Step 1. Visually determine (zoom to) the location of the Proposed Inlet Location: Station 205+86; 

offset –26. 

 

Step 2. Select from the Drainage menu:  Component > Node > Add. 
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Step 3. Highlight Properties in the Options group box on the Node Configuration dialog. Select 
the Node to be used from the Drainage Library and assign its properties as depicted 
below: 

 

Node ID 3-1 

Node Type Curb 

Profile On Grade 

Library Item DI-3B 10 

 

Step 4. Highlight Location to describe the inlet’s location in the design plane: 

 

Reference Chain Select Reference chain: MAINLINE 

Reference PGL Select Reference PGL: MAINLINE 

Align Tangent on Element 

Station 205+86 

Offset -26.00 feet 

  

 

 Press the Enter key to automatically place the inlet at the specified location. 
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Step 5. Highlight Spread Criteria to describe the roadway cross sectional characteristics directly 
in front of the inlet.  These values will be utilized to calculate inlet capacity and resulting 
by-pass flow: 

 

Longitudinal Slope Source Reference PGL 

Spread Cross Section User Supplied 

Max Ponded Depth 0.50 feet 

Max Ponded Width 8.00 feet 

 

 



Design Inlet  3 – 1 

 

VDOT GEOPAK Drainage Training Manual 
1/27/2006 65 

Step 6. Highlight Elevations to assign the inlets vertical elevation and vertical pipe alignment: 

 

Reference Surface Survey.tin 

Elevation Source PGL + Spread Section 

Node Elevation Option Same as Source 

Vertical Alignment Preference Min. Fixed Drop = 0.2 

Minimum Depth 2.67 feet 

Maximum Depth 8.00 feet 

 

Step 7. Highlight Junction Losses to use Defined Equations (defaults to Preferences > 
Junction Loss Settings): 
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Step 8. Highlight Discharge Options to specify the source of the discharge contributing to this 
inlet.  Toggle ON Use Computed Discharge. 

 

Step 9. Highlight Computations to verify the inlet’s hydraulic computations: 

 

Note: The Drainage Area for this node won’t be added until the next step.  Therefore, the 
Computations for the node can’t be completed until a discharge is known. 

Step 10. Click Apply to add this Node to the project. 

Step 11. Press the Edit Area icon to invoke the Drainage Area dialog.  

Step 12. Select Yes to the Alert dialog box, since no area for the inlet is created yet. 

 

Design Drainage Area  3 – 1 
The physical Drainage Area boundary may be delineated using a digital terrain model, simply drawn 
with MicroStation, or just keyed-in as a total area value (in units of acres or hectares). After the 
drainage area is delineated using MicroStation’s drawing tools, runoff coefficients can be automatically 
computed with the use of Land Use Items from the Drainage Library. 
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The basin areas were predefined and were drawn in lv = Level 63. This closed shape will be selected 
to become the drainage area delineation. 

 

Step 1. Turn on Level 63 in MicroStation and follow the instructions in the table below: 

 

Drainage Area ID 3-1 

Base C 0.5 

Time of Concentration 5.00 

 Click Select Shape and select the MS shape for this area. Drainage area value is 
computed. 

Step 2. Highlight Subareas.  
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Step 3. Toggle on Display Only and then Press the Automatic Delineation button.   

 The file is scanned for closed shapes matching the Land Use symbology specified in the 
Drainage Library (Land Use Tab).  

 

Step 4. Press the Apply button to apply the land uses (and their “C” values) to the Drainage Area.   

 Alternately, this table may be populated manually using the key-in fields and the add, 
modify and delete item buttons to the right of the table. 

Step 5. Highlight Computation and press the Compute Discharge button to obtain the drainage 
area’s computations. 

 

Verify the Computations; then press Apply to add the Area to the Project. Review the 
Computations in the Node Configuration dialog. 

Design Inlet  3 – 2 
Step 1. Visually determine (zoom to) the location of the Proposed Inlet Location: Station 206+36; 

offset -26.00.  

Step 2. Select from the Drainage menu:  Component > Node > Add. 

Step 3. Highlight Properties. Verify the Node Properties are defaulted from the previous Node. 
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Node ID 3-2 

Node Type Curb 

Profile Sag 

Library Item DI-3C 6 

 

Step 4. Highlight Location. All Reference information is defaulted from the previous Node (3-1) 
such that only the new Location is required. 

 

Station 206+36 

Offset -26 

 

Press Enter to locate the inlet in the dgn file. 
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Step 5. Highlight Spread Criteria. Set required information to describe the flow to the inlet. 

  

Longitudinal % Slope Left  4.50% 

Longitudinal % Slope Right  8.60% 

% Discharge Left  50 % 

% Discharge Right 50% 

 

Step 6. Highlight Elevations. Set the required information to describe the inlet’s elevation: 

 

Note: Elevation Source, Node Elevation Option, vertical Alignment, Minimum and Maximum Depth 
should be filled out based on the previous node 3-1. 

Step 7. Press the Apply button to include this node in the Drainage Project. 

Step 8. Press the Edit Area icon to associate this inlet with its Drainage Area.   

Step 9. Select Yes to the Alert dialog box, since no area for the inlet is created yet. 
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Create Drainage Area  3 – 2 
This closed shape in lv = Level 63 will be selected to become the drainage area delineation.  

 

Step 1. Follow the instructions in the table below. 

 

Drainage Area ID 3-2 

Base C 0.5 

Time of Concentration 5.00 

 Click Select Shape and select the MS shape for this area. Drainage area value is 
computed. 

Step 2. Highlight Subareas. 
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Step 3. Press the Automatic Delineation button.  

 The file is scanned for closed shapes matching the Land Use symbology specified in the 
Drainage Library (Land Use Tab).  

 

 

Step 4. Press the Apply button to apply the land uses (and their “C” values) to the Drainage Area. 

Step 5. Highlight Computation and press the Compute Discharge button to obtain the drainage 
area’s computations. 

Step 6. Verify the Computations; then press Apply to add the Area to the Project. 

Step 7. Review the computations in the Node Configuration dialog.  

 

 

Design Inlet  3 – 3 
Step 1. Visually determine (zoom to) the location of the Proposed Inlet Location: Station 206+86 

offset -26.00. 

Step 2. Select from the Drainage menu:  Component > Node > Add.  

Step 3. Highlight Properties to select the Node to be used from the Drainage Library and assign 
its properties as depicted below: 
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Node ID 3-3 

Node Type Curb 

Profile On Grade 

Library Item DI-3B 8 

 

Step 4. Highlight Location. Describe the inlet’s location in the design plane. 

 

Station 206+86 

Offset -26 

 Press Enter to automatically place the inlet at the specified location.   

 

Step 5. Highlight Spread Criteria. Set the required information to describe the flow to the inlet. 
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Step 6. Highlight Elevations. Set the required information to describe the inlet’s elevation: 

 

Step 7. Press the Apply button to include this node in the Drainage Project.  

Step 8. Press the Edit Area icon to associate this inlet with its Drainage Area.   

Step 9. Select Yes to the Alert dialog box, since no area for the inlet is created yet. 

Create Drainage Area  3 – 3 
This closed shape in lv = Level 63 will be selected to become the drainage area delineation.   
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Step 1. Follow the instructions below. 

 

Drainage Area ID 3-3 

Base C 0.5 

Time of Concentration 5.00 

 Click Select Shape and select the MS shape for this area. Drainage area value is 
computed. 

Step 2. Highlight Subareas. 

Step 3. Press the Automatic Delineation button.  

 The file is scanned for closed shapes matching the Land Use symbology specified in the 
Drainage Library (Land Use Tab).  

 

Step 4. Highlight Computation to obtain the drainage area’s computations. 

Step 5. Verify the Computations; then Press Apply to add the Area to the Project 

Step 6. Review the computations in the Node Configuration dialog.   
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Design Inlet  3 – 4 
Step 1. Visually determine (zoom to) the location of the Proposed Inlet Location: Station 205+86 

offset 26.00. 

Step 2. Select from the Drainage menu:  Component > Node > Add. 

Step 3. Highlight Properties. Select the Node to be used from the Drainage Library and assign its 
properties as depicted below: 

 

Node ID  3-4 

Node Type Curb 

Profile On Grade 

Library Item DI-3B 16 

 

Step 4. Highlight Location. Describe the inlet’s location in the design plane. 
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Station 205+86 

Offset 26 

Angle 180 

 Press Enter to automatically place the inlet at the specified location.   

Step 5. Highlight Spread Criteria. Set required information to describe the flow to the inlet. 

 

Step 6. Highlight Elevations. Set the required information to describe the inlet’s elevation: 

 

Step 7. Press the Apply button to include this node in the Drainage Project.  
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Step 8. Press the Edit Area icon to associate this inlet with its Drainage Area.   

Step 9. Select Yes to the Alert dialog box, since no area for the inlet.   

Create Drainage Area  3 – 4 
This closed shape in lv = Level 63 will be selected to become the drainage area delineation.   

 

Step 1. Follow the instructions below. 

 

Drainage Area ID 3-4 

Base C 0.5 

Time of Concentration 5.00 
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 Click Select Shape and select the MS shape for this area. Drainage area value is 
computed. 

Step 2. Highlight Subareas. 

Step 3. Press the Automatic Delineation button.   

 The file is scanned for closed shapes matching the Land Use symbology specified in the 
Drainage Library (Land Use Tab).  

 

Step 4. Highlight Computation and press the Compute Discharge button to obtain the drainage 
area’s computations. 

Step 5. Verify the Computations; then press Apply to add the Area to the Project.    

Step 6. Review the computations in the Node Configuration dialog.  

 



Design Inlet  3 – 5 
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Design Inlet  3 – 5 
Step 1. Visually determine (zoom to) the location of the Proposed Inlet Location: Station 206+36; 

offset 26.00.  

Step 2. Select from the Drainage menu:  Component > Node > Add. 

Step 3. Highlight Properties. Verify the Node Properties are defaulted from the previous node 
such we have to change a few properties. 

 

Node ID 3-5 

Node Type Curb 

Profile Sag 

Library Item DI-3C 6 

 

Step 4. Highlight Location. All Reference information is defaulted from the previous Node (3-4) 
such that only the new Location is required: 

 

Station 206+36 

Offset 26 
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Step 5. Highlight Spread Criteria. Set required information to describe the flow to the inlet. 

  

Longitudinal % Slope Left  4.50% 

Longitudinal % Slope Right  8.60% 

% Discharge Left  50 % 

% Discharge Right 50% 

 

Step 6. Highlight Elevations. Set the required information to describe the inlet’s elevation: 

 

Step 7. Press the Apply button to include this node in the Drainage Project. 

Step 8. Press the Edit Area icon to associate this inlet with its Drainage Area.   

Step 9. Select Yes to the Alert dialog box, since no area for the inlet.  
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Create Drainage Area  3 – 5 
This closed shape in lv = Level 63 will be selected to become the drainage area delineation. 

 

Step 1. Follow the instructions in the table below. 

 

Drainage Area ID 3-5 

Base C 0.5 

Time of Concentration 5.00 

 Click Select Shape and select the MS shape for this area. Drainage area value is 
computed. 

Step 2. Highlight Subareas. 
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Step 3. Press the Automatic Delineation button.   

 The file is scanned for closed shapes matching the Land Use symbology specified in the 
Drainage Library (Land Use Tab).  

 

Step 4. Highlight Computation and press the Compute Discharge button to obtain the drainage 
area’s computations.  

Step 5. Verify the Computations; then press Apply to add the Area to the Project. 

Step 6. Review the computations in the Node Configuration dialog.  
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Design Inlet  3 – 6 
Step 1. Visually determine (zoom to) the location of the Proposed Inlet Location: Station 206+86 

offset 26.00. 

Step 2. Select from the Drainage menu:  Component > Node > Add.  

Step 3. Highlight Properties. Select the Node to be used from the Drainage Library and assign its 
properties as depicted below: 

 

Node ID 3-6 

Node Type Curb 

Profile On Grade 

Library Item DI-3B 8 

 

Step 4. Highlight Location. Describe the inlet’s location in the design plane. 

 

Station 206+86 

Offset 26 

 Press Enter to automatically place the inlet at the specified location.   
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Step 5. Highlight Spread Criteria. Set required information to describe the flow to the inlet. 

 

Step 6. Highlight Elevations. Set the required information to describe the inlet’s elevation: 

 

Step 7. Press the Apply button to include this node in the Drainage Project.  

Step 8. Press the Edit Area icon to associate this inlet with its Drainage Area.   

Step 9. Select Yes to the Alert dialog box, since no area for the inlet.  



Create Drainage Area  3 – 6 

 

VDOT GEOPAK Drainage Training Manual 
1/27/2006 86 

Create Drainage Area  3 – 6 
This closed shape in lv = Level 63 will be selected to become the drainage area delineation.   

 

Step 1. Follow the instructions below. 

 

Drainage Area ID 3-6 

Base C 0.5 

Time of Concentration 5.00 

 Click Select Shape and select the MS shape for this area. Drainage area value is 
computed. 

Step 2. Highlight Subareas. 
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Step 3. Press the Automatic Delineation button.  The file is scanned for closed shapes matching 
the Land Use symbology specified in the Drainage Library (Land Use Tab).  

 

Step 4. Highlight Computation and press the Compute Discharge button to obtain the drainage 
area’s computations.  

Step 5. Verify the Computations; then press Apply to add the Area to the Project.  

Step 6. Review the computations in the Node Configuration dialog.  

 

 

Design Inlet 3 – 7 
Step 1. Visually determine (zoom to) the location of the Proposed Inlet Location: Station 208+00 

offset 26.00. 

Step 2. Select from the Drainage menu:  Component > Node > Add.  
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Step 3. Highlight Properties. Select the Node to be used from the Drainage Library   and assign 
its properties as depicted below: 

 

Node ID  3-7 

Node Type Curb 

Profile On Grade 

Library Item DI-3B 16 

 

Step 4. Highlight Location. Describe the inlet’s location in the design plane. 

 

Station 208+00 

Offset 26 

Angle 0 

 

 Press Enter to automatically place the inlet at the specified location.   
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Step 5. Highlight Spread Criteria. Set required information to describe the flow to the inlet. 

 

Step 6. Highlight Elevations. Set the required information to describe the inlet’s elevation: 

 

 

Step 7. Press the Apply button to include this node in the Drainage Project.  

Step 8. Press the Edit Area icon to associate this inlet with its Drainage Area.   

Step 9. Select Yes to the Alert dialog box, since no area for the inlet.  
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Create Drainage Area  3 – 7 
This closed shape in lv = Level 63 will be selected to become the drainage area delineation.   

 

Step 1. Follow the instructions below. 

 

Drainage Area ID 3-7 

Base C 0.5 

Time of Concentration 5.00 

 

Step 2. Highlight Subareas. 
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Step 3. Press the Automatic Delineation button.  The file is scanned for closed shapes matching 
the Land Use symbology specified in the Drainage Library (Land Use Tab).  

 

Step 4. Highlight Computation and press the Compute Discharge button to obtain the drainage 
area’s computations.  

Step 5. Verify the Computations; then press Apply to add the Area to the Project.  

Step 6. Review the computations in the Node Configuration dialog.  
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Design Node: Outlet 
Step 1. Visually determine (zoom to) the location of the Proposed Inlet Location: Station 206+36; 

approximate offset -42.00: 

 

Step 2. Select from the Drainage menu:  Component > Node > Add. 

Step 3. Highlight Properties. Utilize the Standard Outlet for this node: 

 

Node ID Outlet 

Description (Optional) 

Node Type Outlet 

Library Item ES18 

Fix Tailwater Soffit 
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Step 4. Highlight Location. All Reference information is defaulted from the previous Node such 
that only the new Location is required: 

 

Station 206+36 

Offset -42 

Angle -90 

 Press Enter to automatically place the outlet at the specified location. 

Step 5. Highlight Elevations.  Set the Outlet’s elevation using the User Supplied option.  

Note: Since we are discharging into a ditch, the elevation should be the elevation of the top of the 
ditch. During the design of the conveyance system, we will adjust and hold the discharge elevation at 
the invert of the pipe. 

 

Step 6. Press the Apply button to include this node in the Drainage Project. 

Step 7. Exit MicroStation.  
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 6 Conveyance System 
 

Objective: Review Drainage Links 

Introduction 
In GEOPAK Drainage, Links connect and convey runoff from the various Nodes within a Network to 
the Outlet, and may consist of pipes, boxes, or ditches.  A multitude of options for sizing, and profiling 
Links are supported.  

A Link represents a linear feature depicting a path connecting two Nodes.  The path (upstream to 
downstream) need not be indicated because GEOPAK Drainage will determine the direction of flow 
purely based on connectivity.  The path may be a straight line, line string, curvilinear, or a combination 
and series of linear MicroStation elements. 

The Drainage Library is an integral part of designing and analyzing Links.  The library contains all the 
standard pipe configurations based on shape, material, and, if applicable, corrugations which may be 
used in a Drainage project.  Link library items selected to specify pipe sizes or the shape and material 
properties within the library may be used to establish the suitable candidates for design.  

Alternately, the Link tools are invoked by selecting Drainage > Tool Boxes > Link, then identifying the 
desired tool from the tool box as depicted below. 

 

Tools from left to right are:   

 Add Drainage Link 
 Modify Drainage Link 
 Delete Drainage Link 
 Update All Links 
 Update All Links with Pay Items 
 Drainage Link Report – Configuration 
 Drainage Link Report – Computation 

In addition, the dialog can be invoked via the Navigator. 

Five options are supported under the Link pull down as described in the table below. 

Add Utilized to add a Link to the current GEOPAK Drainage project. 

Edit Utilized to select and edit any previously defined and stored Link within the 
current project. Note the Link Edit dialog is identical to the Link Add dialog, 
however, when the Link is identified, all associated data is displayed. 

Delete Utilized to select and delete the specified Link and associated data. 
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Update All Links Updates all link graphics. 

Update All Links with 
Pay Items 

Updates all link graphics with the designated pay items. 

 

Link options and types are shown in the Option list box on the left side of the dialog.  The 
corresponding fields and items appear on the right.  The four options are reviewed below. 

Definition Defines the Link’s path, connectivity, shape, material, roughness coefficient, 
size, and design options.  

Conditions Defines or reviews the elevation condition for the Link including minimum 
depth, soffit, invert, and slope data. It also includes the profiling options for 
holding certain values constant.  

Constraints Defines the Link constraints including the minimum and maximum rise (size), 
slope and velocity used in Link design. 

Computation Reviews the Link hydraulic computations 

 

When all the options have been reviewed and appropriate information supplied, pressing the Add or 
Update button will update the Drainage database.   
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Lab 6: Links 

Link Design 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB6_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Project > Open from the Geopak 
Drainage pull down menu. 

Step 5 Visually determine the tentative location of the first storm sewer pipe.  This link will 
connect Nodes 3-1 and 3-2. 

 

Step 6. Select from the Drainage Menu : Component > Link > Add. 

Step 7. Highlight Definition to Set the pipe's spatial characteristics including From and To Nodes 
ID’s, pipe shape, material, library items, etc.  

 Graphically select the Nodes by clicking the ID button for each one. Link 1 traverses From 
Node 3-1 To Node 3-2: 

 

Shape Circular 



Link Design 

 

VDOT GEOPAK Drainage Training Manual 
1/27/2006 98 

Material Concrete 

Design Size Toggle ON 

Design Barrels Toggle OFF & select 1 

Manning’s n 0.013 

 

Step 8. Highlight Conditions. The elevations shown are based on the From-Node and To-Node 
elevation minus the min/max depth, as specified in the Node Definition Dialog Box for 
Nodes 3-1 and 3-2 respectively.   

 In this case, no entries are necessary; Geopak Drainage will design all the profiles for this 
project. 
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Step 9. Highlight Constraints. Establish the min/max design criteria for Links as follows: 

 

Rise min/max 1.0 / 4.0 (feet) 

% Slope min/max 0.50 / 10.00 (%) 

Velocity min/max 2.00 / 10.00 (fps) 

 

Step 10. Highlight Computations to display the computed hydraulic properties of the Link.   

 

Note: Link hydraulics are not available for review until a Network has been established and designed 
or analyzed (next exercise) successfully. Check back here for computations after the Network has 
been added and designed or analyzed. 

Step 11. Press Apply to incorporate the link to the project. 
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Step 12. Add the remainder of the link conveyance system from the Link Configuration dialog. 

 

 As Links are added, most dialog values default from the previous Link with the exception 
of the node and elevation information. Add Links between all of the following Nodes:  

Link PIPE-2 Traverses From Node 3-3 To Node 3-2 

Link PIPE-3 Traverses From Node 3-4 To Node 3-5 

Link PIPE-4 Traverses From Node 3-7 To Node 3-6 

Link PIPE-5 Traverses From Node 3-6 To Node 3-5 

Link PIPE-6 Traverses From Node 3-5 To Node 3-2 

Link PIPE-7 Traverses From Node 3-2 To Node OUTLET and hold the 
discharge elevation of the pipe at el. 2013.00 

 

Step 13. Exit MicroStation.  
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 7 Networks 
 

Objective: Review Network Computations. 

Introduction 
A GEOPAK Drainage Network is defined as a series an interconnected Nodes and Links draining to a 
single outlet.  GEOPAK Drainage can maintain multiple Networks in a single project.  

 

The Network computations serve as the final calculation process in the design or analysis of a storm 
drain system.  Drainage Areas and Inlets may be computed individually and are not dependent on any 
type of Network topology.  Pipes and Ditches, however, are dependent on the connectivity and 
Network characteristic and therefore, require a Network be defined and successfully built, in order to 
complete the hydraulic computations on these features. 

Several options are supported to add, edit, and delete Networks and are invoked via the Network pull 
down on the menu bar. 

Alternately, the Network tools are invoked by selecting Drainage > Tool Boxes > Network, then 
identifying the desired tool from the tool box as depicted below. 

 

Network tools from left to right are: 

 Add Drainage Network 
 Modify Drainage Network 
 Delete Drainage Network 
 Set Active Network 
 Design Network 
 Analyze Network 
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Six options are supported under the Network pull down: 

Add - Initially utilized to define the Network and associated data.  When invoked, the Network 
Configuration dialog is blank. 

Edit - Utilized to edit any previously defined Network.  When selected, the Select Network dialog is 
invoked, wherein the desired Network is highlighted.   Note the Network Edit dialog is identical to the 
Network Add dialog, however all associated data is displayed. 

Delete - Utilized to delete the specified Network and associated data. 

Design - This mode enables when an Active Network is defined. It's a shortcut to the Design 
procedure without having to invoke the Network dialog. 

Analyze - This mode enables when an active network is defined.  It's a shortcut to the Analyze 
procedure without having to invoke the Network dialog. 

Active Network - GEOPAK Drainage uses an Active Network as a shortcut and organization tool. 
Many of the reporting, query, and navigation tools support the use of the Active Network to limit the 
information viewed to the system currently under design (the Active Network). When selected, the 
Active Network dialog is invoked, wherein a previously defined Network may be specified as active. 
The current Active Network is displayed on the main menu bar for quick reference.  
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LAB 7:  Networks 

Network Design 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB7_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Project > Open from the Drainage 
pull down menu. 

Step 5. Select the Add Drainage Network tool from Drainage > Network > Add or from the 
Network tool palette. 

 

Step 6. In the Add a New Network, enter the following information: 

 

Network ID: SYSTEM1 

Description: (Optional) 

Outlet Node Click the ID button and select the 
OUTLET 

 

Step 7. Click the Build Network button.  This feature verifies the nodal topology and link 
connectivity. The Highlight Network feature highlights all components (areas, inlets, 
pipes, etc.) connected to the active Network. 
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Step 8. Click the Apply button.  Network “SYSTEM1” has been added to the project. 

Step 9. Click the Design button.  This command initiates the hydraulic design of the components 
contained in the Network.  

 

Step 10. Accept the Update Graphics messages to update all node and link data if required (if any 
graphic or hydraulic information is missing from the components, this procedure will 
update the information): 

Step 11. Then GEOPAK will design the network and issue the pertinent Warning messages, if 
necessary. 

 

Step 12. Set the Active Network to System1, so we can review some of the provided reports. 
Drainage > Network > Active Network. 

Step 13. We can now review some of the Geopak provided reports. Drainage > Reports > Storm 
Drain/Links. 

Step 14. Exit MicroStation.  
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 8 Profiles 
 

Objective: Review Profile Computations. 

Introduction 
A Profile is a path between two nodes, spanning one or more links.  Profiles allow users to define a 
path running in any direction (upstream or downstream) in a drainage Network and visualize profiles 
(ground, pipes, depth of cover...) along that path.  All that is needed to define a profile is the 
identification of the From Node and To Node, and GEOPAK Drainage automatically traverses the 
Network and finds the Links connecting the two Nodes.  
 
Several options are supported to add, edit, and delete Profiles and are invoked via the Component 
pull down on the Drainage menu.  Alternately, the Profile tools are invoked by selecting Tools > Tool 
Boxes > Profiles, then identifying the desired tool from the tool box as depicted below. 
 

 

The Drainage Profiles tool box contains seven tools (from left to right). In addition, the tools can be 
invoked via the Navigator.   
 

 Add Drainage Profile : Utilized to add a Profile to the current GEOPAK Drainage project. 
 Drainage Profile List: List of profiles in the current drainage project 
 ID Drainage Profile: Utilized to select and edit any previously defined and stored Profile within 

the current project. 
 Modify Drainage Profile: Utilized to modify the display properties of a plotted profile. 
 Delete Drainage Profile: Utilized to select and delete the specified Profile and associated data. 
 Update All Drainage Profiles 
 Auto Create Profile: The Auto Create Profile tool draws a series of profiles based on the 

specified network.   
 

 
When the Add, Edit, or Delete options are selected, the dialog depicted below is displayed. 
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The dialog is comprised of the Description area and five tabs. The fields detailed in the table 
below are independent of which tab is selected. 
 

Profile ID Identification of the Profile is displayed in the Dialog Title bar. 
(Maximum of 16 alphanumeric characters.) 

View Number Select the view in which the profile is to be drawn. 

Center Profile When clicked, the profile is centered in the specified view. 

Description Description of the Profile. (maximum of 32 alphanumeric characters.) 
This field is always at the top of the dialog, above the tabs. 

Apply Applies the current Profile information in the project. 

 
 
The Edit Drainage Profile dialog under the Registration tab is the one that control the display of 
the profile. Its setup is reviewed in the table below. 

Registration Point: X coordinate corresponding to the specified Station, Elevation. Y 
coordinate corresponding to the specified Station, Elevation. 

DP Identify x, y coordinates using a data point. Click, then identify and 
accept the desired point on the screen. 

Scale: Horizontal and vertical scales.  All profiles are drawn to true dimensions 
in the horizontal, so the scales are used to determine the distortion factor 
of the vertical. 

Node Information: Node used as the starting point of the profile. This is populated using the 
From Node in the New Profile dialog. 

Reset Profile This will reset the profile display to the current setting of the dialog. 

Projection If the Profile is to be projected onto a chain in order to utilize its 
stationing, the toggle is activated and chain parameters specified. 

Grid Stationing and If Chain Projection is not used, the Stationing at the From Node is set to 
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Elevations: 0+00 and is assigned to the Registration Point. If Chain Projection is 
used, the Station matches the Begin Station in the Projection group box. 

The ending station is automatically computed based on the length of the 
profile and the Beginning Station. 

Reference Surface Surface utilized to draw the ground profile above the Profile. A site 
model/object may also be specified. If blank, individual Node elevations 
are utilized. 

 

LAB 8:  Profiles 

Profile Design 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB8_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Project > Open from the GEOPAK 
Drainage pull down menu and make System1 the Active Network using Network > 
Active Network. 

Step 5. Select the Add Drainage Profile tool, Drainage: Component > Profile > Add. 

 

Step 6. Complete the dialog box information as follows: 

 

Profile ID: Profile-1 

Description: Optional 

From Node: Click the ID button and select 3-4. 

To Node: Click the ID button and select OUTLET. 
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Step 7. Click Apply. 

Step 8. Enter the profile information. 

 

 

Reference Surface: Select  proposed.tin 

Min. Elevation: 2010.00 (The profile datum) 

Max. Elevation 2025.00 

Horizontal Scale: 25.0 

Vertical Scale: 5.0 

 

Step 9. Click DP and select a data point in the MicroStation design plane. This is the location 
where the profile will be drawn.    
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Step 10. Select File > Open and select the preferences file : Drain_Profile.ppf located on 
c:\data\geo\vdot\drain1\standards\Geopak\ 

 

Step 11. Click Apply. Geopak Drainage draws the profile. 

 

Step 12. Exit MicroStation.  
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 9 Navigator/Global Editor 
 

Objective: Review the Navigator. 

Goal: Review the Navigator. 

Introduction 
The Navigator tool is an easy method of maneuvering through the components of a GEOPAK 
Drainage Project.  It provides a means to identify, add, edit, delete, and query the components of the 
current project.  The Navigator also provides graphical maneuvering tools to move through the design 
file and view the components with highlighting and window centering functions. 

In addition, the Navigator provides a Global Editor to edit parameters of the project components on a 
system wide basis.  A tool is also provided to update the graphic display of any or all of the 
components in the Navigator List. 

Using the Navigator 
The Navigator is accessed via Tools > Navigator from the main menu bar. 

Alternately, the Navigator tool can be invoked by selecting Drainage > Tool Boxes > Main. When 
selected, the dialog depicted below is invoked. 
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Global Editor 
The Global Editor is used to edit the input and parameters of the project system on a system wide 
basis.  When the View > Global Editor is selected from the Navigator tool bar, the dialog expands as 
depicted below. 
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LAB 9:  Navigator/Global Editor 

Navigating/Global Editing 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB9_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Project > Open from the GEOPAK 
Drainage pull down menu and make System1 the Active Network using Network > 
Active Network. 

Step 5. Select from the Drainage Menu Drainage > Utilities > Navigator. 

 

 

Step 6. The Navigator opens defaulted to All Networks. 
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Step 7. Select the Drainage Nodes button on the Navigator: 

 

Step 8. Toggle ON the Highlight and Window Center tools and click on the nodes in succession 
for easy navigation of any Drainage component. 

Step 9. Expand the Navigator from the Navigator’s View pull-down menu to the Global Editor: 

 

 

Step 10. Select all the Node components.  In the Variable to Edit list box, select Node – Minimum 
Depth, supply a New Value of 3.0 feet, click the Apply Edit No Confirm button to change 
all values. 

Step 11. Redesign it with these changes in effect. Drainage > Network > Edit and select the 
design network icon. 

Step 12. The previously plotted profile will be updated automatically.  

Step 13. Exit MicroStation. 
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 10 Querying 
 

Objective: Review the Navigator’s Query mode. 

 

Querying From the Navigator 
The Navigator provides a Query Tool to specify a subset of the current components based on a query 
of values or constraints.  The Query Tool is only enabled for Areas, Inlets, and Pipes for which 
numerous computed values and design constraints are available for the query.  When the Query 
toggle is activated, GEOPAK Drainage compiles a list for the selected component based on a 
designer’s specified condition(s).  The dialog depicted below illustrates the invocation of the query 
feature.   

 

A query can be one of two types; Values or Constraints.  A Value query will perform a search for 
components whose input or computed value for a specified variable meets the specified Condition and 
Value.  A Constraint query will perform a search for components whose computed value for a design 
constraint meets the Condition. 
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LAB 10: Query 

Query Mode 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB10_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Project > Open from the Geopak 
Drainage pull down menu. and make System1 the Active Network using Network > 
Active Network. 

Step 5. Select from the Drainage Menu : Utilities > Navigator  

 

 
Step 6. Set the Active Component Type to Inlet and toggle the Query option 

. 
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Step 7. Use the Query tool to determine which inlets have exceeded a Ponded Width of 8 ft.  

 

Query Type: Values 

Condition: > 

Variable: Ponded Width 

Value: 8.00 

 

 The components remaining in the navigator meet the conditions of the query. 

Step 8.  Follow the same procedures to determine the following: 

  Which pipes have a velocity greater than 3 fps? ___________________________ 

  Which pipes have exceeded their maximum diameter? ______________________ 

  Which inlets have a ponded width greater than 6 feet? ______________________ 

Step 9. Exit MicroStation.  
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 11 System Modification and Analysis 
 

Objective: Review System Modification. 

Global Editor 
The Global Editor is used to edit the input and parameters of the project system on a system wide 
basis.  When the View > Global Editor is selected from the Navigator tool bar, the dialog expands as 
depicted below. 

 

The left side of the dialog is identical to the Navigator, hence, will not be discussed again.   
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LAB 11: System Modification and Analysis 

Adding Existing Structures 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB11_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Project > Open from the Geopak 
Drainage pull down menu, and make System1 the Active Network using Network > 
Active Network 

Step 5. Add a manhole and incorporate it into the network. Select from the Drainage Menu:  
Component > Node > Add. Add Node ID: MH-1. 

 

Step 6. Highlight Properties. Select the node to be used from the Drainage Library and assign its 
properties as depicted below: 

 

Node Type Junction 

Library Item MH-12 

Node Bottom Toggle OFF 

Note: This manhole is an existing drainage structure. Therefore, we have to override the payitem 
definition set in the VDOT drainage library. 
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Step 7. Toggle On the Override Library Item box.  

 

Step 8. Click on the calculator icon and select Road Design > Drop Inlets > Exist_Structure 
from the Design and Computation Manager. 

 

Step 9. Location > Describe the manhole location in the design plane: 

 

Reference Chain Select Reference chain: MAINLINE 

Reference PGL Select Reference PGL: MAINLINE 

Align Tangent to Chain 

Station 207+35 
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Offset 26.00 feet 

Angle -90 

 

 Press the Enter key to automatically place the inlet at the specified location. 

Step 10. Set the top elevation of the manhole. We will use the proposed.tin file to calculate the 
manhole elevation.  

 

Step 11. Press Apply to add the manhole to the project. 

Step 12. Select from the Drainage Menu:  Component > Link > Edit. 

Step 13. Select PIPE-4 and reconnect it from MH-1 to 3-6. 

 

Step 14. Click Apply. 

Step 15. Add a new pipe connecting 3-7 and MH-1. The new pipe will use the same conditions and 
constraints of the previously stored pipes. 
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System Design Update 
Step 1. Select Drainage > Network > Edit. Edit System1 

Step 2. Rebuild the Network and click Apply to update the Network.  

Step 3. Perform a system re-design. 

 

 

Dynamically Editing Profiles 
Step 1. Select the Edit Profile List tool from Drainage menu: Component > Profile > Edit List. 

Step 2. Select the previously created profile: Profile-1.  

 

Step 3. Click the Center Profile icon, so you can visualize profile Profile-1 in View 1.  

Step 4. Select the Link Profile tab.  

Step 5. Click ID. Select and accept the link you want to modify from the profile view (pipe-6). This 
will make pipe-6 the active link.  

Step 6. In the Details section, click Edit Invert in the left Node group.  
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Step 7. Move your cursor into the profile view. There is a circle around the downstream invert at 
node 3-5.   

Step 8. Move the cursor into the circle and drag the invert down. Link pipe-6 will dynamically 
follow your cursor. 

Step 9. Data point to define a new invert location in the Profile. 

Step 10. Click Apply.  

Step 11. Click NO to the Alert dialog box. 

Note: GEOPAK Drainage redesigns your system aligning the pipes following the Vertical Alignment 
options (Match Soffit, Match Inverts, Allow Drop Manhole, etc.) of your Node configuration. 

Step 12. Close the Edit Drainage Profile dialog. 

System Analysis 
Step 1. Once the system has been designed, pipes sizes and invert elevations are set. If we need 

to run the system thru a different storm for checking or analysis purposes, change the 
frequency in the Drainage > Project > Preferences. 

Step 2.  Select the 25 year storm under Frequency Options. Press OK.   
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Step 3. Select Drainage > Network > Analyze. GEOPAK will run the storm to the preset pipe 
sizes and elevations. 

 

Step 4. Review the changes in the Hydraulic Grade Line in Profile-1 and change the Frequency 
back to the 10 year storm. 

Step 5. Exit MicroStation.  
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 12 Reports 
 

Objective: Review Report features. 

Introduction 
GEOPAK Drainage provides a number of tools to create and generate both custom reports and quick, 
standardized reports.  The standardized reports for Drainage Areas and Inlets are updated 
dynamically as any of the components contained in the report are updated, so the impact of the 
changes can be reviewed on the entire system.  The Storm Drains/Links report dynamically tracks the 
condition of the data and provides notification whether the data is current in the report.  These 
summaries are dependent on the Network computations being performed successfully and whenever 
the Network is designed or analyzed, these report summaries are updated automatically. 

All report functions are invoked by selecting Drainage > Tool Boxes > Reports, then identifying the 
desired tool from the tool box as depicted below. 

 

Tools from left to right are:   

 Drainage Area Report 
 Drainage Node Report – Sump 
 Drainage Node Report – On Grade 
 Drainage Link Report – Configuration 
 Drainage Link Report – Computations 
 Drainage Report Builder 
 Drainage Generate Report 

Of these reports, Drainage Areas, Inlets, and Storm Drains / Links are standardized reports, while the 
Builder and Generate menu selections are utilized for the customized reporting capabilities.  Both 
standardized reports and customized reports can be viewed and subsequently, hard copy output can 
be produced. 

Several useful features are common in most of the standardized reports at the bottom of the dialog as 
depicted in the fragment below. 

 

Network  When initially activated, all components within the project are reported.  The option is All 
Networks.  By selecting Active Network, only those components in the active network are reported.  
Note in order to use this option, an Active Network must be defined prior to selecting the option.  If an 
Active Network is not defined, no warning message is displayed and the list box is not updated. 
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Edit (/)  To edit an element directly from the report summary, highlight the desired element in the list 
box, then press the Edit (/) button, invoking the specified dialog in an update mode.  When the desired 
updates have been made, press the Update button which closes the dialog, returns to the report 
dialog and automatically updates the report with the edited information. 

Highlight  When the toggle is activated, double click on a line in the list box.  The MicroStation 
highlight color is applied to the specified item in the list for easy visual reference.  Note the screen 
maintains the relative window, i.e., it does not perform any Zoom In or Zoom Out commands.  Note 
the Window Center and Highlight toggles may be active simultaneously. 

Window Center  When the toggle is activated, double click on a line in the list box.  The highlighted 
item in the list is window centered on the screen.  Note the screen maintains the relative window, i.e., 
it does not perform any Zoom In or Zoom Out commands.  Note the Window Center and Highlight 
toggles may be active simultaneously. 

ASCII File  The data may be written to an ASCII file.  Manually type in the optional path and name of 
the file, or utilize the Files button to select from Create Area Summary ASCII File dialog.  Note the 
default extension is *.sum.  
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LAB 12: Reports 

Create Customized Reports 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB12_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Drainage > Project > Open from 
the MicroStation menu and make System1 the Active Network using Network > Active 
Network  

Step 5. Select from the Drainage Menu: Reports > Builder 

Step 6. Set the Component Report Basis to Link. Set the Component Data to From Node: 

 

Step 7. Select the first few variables from the Available Data column and click the Include button 
to add them in the Report Data column. 

Step 8. Type in the Default Output File Name and Extension. 

Step 9. Select the number of Decimal Places: 3 

Step 10. Select the Delimiter to Comma.  This sets the output format to a comma separated values 
file.  (Each variable will be separated by a comma for easy spreadsheet importation) 

Step 11. Save this report format for future use from Report File > Save As > : test.drf. 

Step 12. The Generate button commences the report creation process. 
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Step 13. Alternately, the View button produces an on screen display of the data. 

 

Create VDOT Storm Calculation Sheet  
Step 1. Select from the Drainage Menu:  Reports > Generate. 

Step 2. Select the Drainage Report Format File: Stormtab.drf located in the …\standards\geopak 
directory. Press Generate. 

 

Step 3. Select Utilities > Macro > Project Manager from the MicroStation Menu. 

 

Step 4. Load the project:  StormSewerTab.mvba located in the ….\standards\geopak\ directory. 

Step 5. Select the previous loaded macro and press the Macros button.  
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Step 6. Press the Run button. 

 

Note: The previous steps could be replaced by typing the following command in the MicroStation key-
in browser: “vba load ; vba run”  and loading the StormSewer application. 

Step 7. Set the drainage project and drainage report file in the Storm Sewer Tabulation dialog. 

 

 

Step 8. Press Generate Report. 
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Step 9. Provide a name for the new storm tabulation Excel spreadsheet: Storm.xls 

Step 10. Open Storm.xls with Microsoft Excel. Review the Stormtab and Spread worksheet. 

 

Step 11. Exit MicroStation. 
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 13 Plan View Labeling 
 

Objective: Review Plan View Labeling for drainage data 

 

The Labeling automates the composition and placement of plan labels onto drawings.  This interactive 
tool permits the creation of very simple to complex labels using many of the following features:  

 Numerous Computed Text Inserts permit standardized computed values to be easily 
incorporated into labels.  These standardized computed values are based on the type of 
element to be labeled and change as the user selects different elements. Types of elements 
available for computed inserts include points, lines, arcs, complex graphic elements, COGO 
features, and drainage features. 

 User Text Inserts facilitate the simple inclusion of user defined text strings into the label. 
These User Inserts can be customized to include frequently used labeling terms and be saved 
for continual use. 

 Standard shapes can be placed around labels and to accommodate different plan label 
formats. 

 Standard leader lines and leader line terminators can also be utilized to create the desired 
label formats. 

 Frequently utilized labels can be stored as Label Styles for subsequent recall.  The complete 
label, including computed text inserts, user inserts, shapes, and leaders, are all stored within 
the Style. 

 Tools to edit, move, and extract labels are also provided to make manipulation and plan 
changes easier. 

 Enhanced ASCII is supported by use of the (\) symbol. 
 Styles are supported, whereby often used labels and associated settings can be saved off and 

recalled in subsequent sessions. 
 Updating options provide for efficient changing as the project dictates changes in the design. 
  

While the labeler can be used for generic purposes, several of the fields are set up for specific 
applications.  The specialty modes include: 

 Plan View 
 Profile 
 Cross Section 
 Drainage 
 Site 
 Water and Sewer 

Under each mode, the types of elements available to label and the associated text inserts change.  
Other than this change, the remaining functionality operates exactly the same under each mode. 
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LAB 13: Plan View Labeling 

Plan View Labeling 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB13_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Project > Open from the GEOPAK 
Drainage pull down menu and make System1 the Active Network using Network > 
Active Network. 

Step 5. To open the Drainage Labeler, select from the Drainage down menu, Utilities > Labeler: 

Step 6. Select the Text Tab and set the Component to “Area”: 

 

Step 7. Select the first Element ID: “3-1” 

Step 8. Press the Computed Text: “Area – ID” to determine the Value.  Double click the 
Computed Text: Area – ID to add it to the current label. 
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Step 9. Press Return to forward to the next line of label text. 

 

 

Step 10. Use the following Computed Text variables for the Area Label: 

Area ID: 3-1; automatic text 

Time of Concentration: Type the prefix and suffix: Tc =   min 

Discharge: Type the prefix and suffix Q =    cfs 

 

Step 11. Move to the Params Tab and set the Text Preferences/Symbology as shown below: 
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Step 12. Move to the Shape tab and set the Shape Preferences and Symbology as shown below: 

 

 

Step 13. Move to the Leader tab and set the Leader Type, Terminator, and Symbology as shown 
below: 

 

 

Step 14. Move to the Rotate tab and select the Element Angle option: 
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Step 15. Select the Styles tab. Initiate placement of the Area Label by pressing the Place Label 
button. 

 

 

Step 16. Place the Label as shown below: 

 

Step 17. Create a new Style by pressing New Style, provide a style name and press OK. 

Step 18. Save the style by selecting Style Files > Save. 

Step 19. Move to the Text tab and select the second Area: 3-2.  Note that all Computed text is 
updated for the new area.  Place the remainder of the Area labels. 

Step 20. Using the same procedures outlined above, place all the node labels. 

Step 21. Repeat the process for the link labels and save the link style. 

Step 22. Exit MicroStation. 
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 14 Automated Quantities 
 

Objectives Understand the computational modes of the D&C Manager for calculating 
automated quantities. 

Introduction 
The Design and Computation Manager (D&C Manager) is a tool that enables the user to standardize graphics 
elements for drafting and pay item quantities. 

A D&C Manager Pay Item can be used for Node and Link items within the Drainage Library for use in 
performing quantity takeoffs and applying D&C symbology.  Pressing the Select button within the specific 
Drainage Library Node or Link item invokes the Design and Computation Manager, in order to select the 
desired Pay Item. 

 

Operational Modes: Compute 
Several operational modes are supported within the Design and Computation Manager; one of them is 
the Compute mode. 

Through the Compute mode of the Design and Computation Manager, GEOPAK offers tools that 
make the completion of this task much quicker and easier.  In addition, since the software utilizes the 
plan view construction drawings to compile quantities, discrepancies between the drawings and the 
tabulated quantities are non-existent.  Chosen items within either the View or a Fence are calculated. 
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Once the MicroStation plan view design file is accessed, the first step is to invoke the Design and 
Computation Manager and click the shortcut button at the top of the dialog box to Compute. 

The dialog box changes dynamically to reflect the compute operation. 

The Design and Computation Manager dialog box is resizable.  Within the dialog box, the sash (long, 
thin bar between list boxes) enables the user to adjust the partition between the list and collection 
boxes while the overall dialog box size remains constant.  Simply place the cursor over the sash and 
dynamically move. 

In addition to dynamically adjusting the main dialog box to reflect the compute operation, the auxiliary 
dialog box is invoked as depicted below.  Note if the auxiliary dialog box was already invoked from 
another operation, it dynamically changes to reflect the Compute operation. 

The next step is the selection of the correct item from the hierarchy.  GEOPAK computes quantities 
only for those hierarchical items that are configured for the computation of quantities. 

Two selection methods can be employed.  The first method is to select an entire category.  GEOPAK 
computes quantities for every item found in the selected category as well as any child categories.  
This is accomplished by double clicking through the groups until the desired category is contained in 
the Content list box.  Single click onto the desired category and click the Add to Collection button at 
the top of the dialog box. 
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The second method involves the selection of individual features.  This is accomplished by double 
clicking through the categories until the desired item appears in the hierarchy list box.  When seen in 
the hierarchy list box, a single click onto the desired item and subsequent click of the Add to 
Collection button places the item in the Collection box. 

Several output formats are available as described in the table below. 

Item Report  Quantities Summary lists pay items, descriptions, units and total quantities for 
located elements.  File is in ASCII format. 

Comp Book  A more detailed report that lists not only quantity summaries, but also geometric 
properties such as plan view coordinates and station/offsets for located elements.  
File is in ASCII format. 

Item Tables  Contains the same information as the Item Report, but formatted in tabular form. 

CSV by Item Quantities Summary lists pay items, descriptions, units and total quantities for 
located elements.  Format is in CSV format. 

SDF by 
Element  

A more detailed report that lists not only quantity summaries, but also geometric 
properties such as plan view coordinates and station/offsets for located elements.  
Format is CSV format. 

DBMS Very detailed information including calculated and rounded quantities, geometric 
properties, pay item numbers, descriptions, station / offset values, etc. The format 
is the selected database (i.e., Microsoft Access, Oracle, SQL Server, and dbase. 

Table Places the report into the active design file. 

An option button located on the left side of the Compute auxiliary dialog box dictates the Output.  
Options that apply to various Output types are detailed in the table below 

View / Fence If the View toggle is selected, only selected items that can be seen in 
MicroStation view one will be computed.  If the view includes area outside of 
the Range, the Range will override.  If the Fence toggle is selected, a fence 
must be placed, and all specified graphical features, which are inside both 
the fence, and the Range will be tabulated.  The Fence mode is sensitive to 
the MicroStation Inside, Overlap and Clip modes. 

File / Preview If set to File, GEOPAK creates the file whose file format is based on the 
Output type and whose name is defined in the key-in field to the right of the 
File option.  The name can be manually entered or selected via the Files 
(folder) icon.  The file can be created or appended to an existing file.  If 
desired, a full path may be specified, otherwise, the report will be found in the 
current directory.   

If the option is set to Preview, the file is not created and the output is 
displayed in a GEOPAK window. 

Description Any description keyed within this field will be printed at the top of the report.  
There is a maximum of 48 characters supported for this field. 

Display These short cut icons are functionally identical to the Display mode in the 
main dialog box and are discussed in the next section. 

Highlight in 
Computation 

When activated, all MicroStation elements utilized in computations are 
highlighted. 

Compute Commences the computation process. 
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Job Number  GEOPAK Coordinate geometry database (GPK) file wherein the specified 
chain is stored.  

Chain Requires a minimum of one chain, which must be stored in the specified job 
number.   

Select When selected, the Chain Selector dialog box appears, wherein the user can 
select the desired chain.   

Range Left and right offset limits (in master units) from the chain where the 
quantities will be computed.  Any specified item located outside of the limits 
is not included in the report 

Phase Quantities can be separated into various phases, as a means to group 
various pay items.  Default phases include:  Design, Preliminary, and Final.  
Note the user can add new phases, but must be aware of naming limitations 
of downstream applications (i.e., Transport links in Quantities Manager.) 

Run The user may also runs as a method of grouping various quantities and / or 
pay items.   
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LAB 14: Automated Quantities 

Updating Cadd Symbology 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB14_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf and make System 1 the Active Network using 
Network > Active Network. 

Step 5. GEOPAK Drainage can track the component quantities within the Drainage project.  

 Select Drainage > Project > Preferences > Plan Symbology.  

 Disable the Set Node Cell Symbology and press OK. 

 

 

Step 6. Open the Design&Computation Manager from Applications > Geopak Road > 
Design&Computation Manager. 

Step 7. In the Design&Computation Manager, do File > Open and load the VDOTenglish.ddb 
database.  
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Step 8. Select Settings > Design in order to change the updating properties for the drainage 
structure cells.  

 

Step 9. Toggle ON the Influence Graphic Cell Symbology option. Then, close the dialog box. 

 

Step 10. Select from the Drainage menu: Components > Nodes > Update With Pay Items. 

 

Note: Notice the existing manhole being change to a MicroStation Construction Class element. 
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Step 11. Select from the Drainage menu: Components > Link > Update With Pay Items. 
GEOPAK will use the Design and Computation Manager ddb file to update the symbology 
of the drainage pipes. 

 

Automated Quantities 
Step 1. Utilize the MicroStation command Window Area to view the entire Drainage Network in 

view 1.  

 

Step 2. In the Design and Computation Manager, set the Mode to Compute by pressing the 
'calculator' icon button.   
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Step 3. Highlight the Drop Inlets Category under Location&Design, then press the Add to 
Collection button on the Design & Computation Manager toolbar. 

 

Step 4. Set the Compute dialog as shown below. 
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Step 5. Press the Compute Quantities button to start the calculation.  

 

Step 6. Exit MicroStation.  
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 15 Culverts 
 

Objective: Review Culverts. 

Goal: Review the necessary data input required for the design of Culverts. 

Introduction 
GEOPAK Culvert is a powerful tool for the design and analysis of culvert structures.  Located within 
GEOPAK Drainage, the Culvert tool can leverage data from a coordinate geometry database (GPK), a 
site database file (GSF), the drainage database file (GDF) or a binary TIN file.  This enables the user 
to utilize roadway and / or storm sewer data, both existing and proposed.  

Invoking the Culvert Tool 
The Culvert tool can be accessed by selecting Component > Culvert from the main Drainage menu. 

 

Previously stored culverts are displayed in the list box for easy selection and modification.  Four icons 
are supported (from left to right): 

 Add Culvert – invokes the add culvert dialog. 
 Modify Culvert – invokes the culvert dialog populated with data for the specified culvert in the 

list box. 
 Identify Culvert – when pressed and a previously stored culvert is selected on the screen, 

the culvert is displayed in the list box. 
 Delete Culvert – deletes the culvert in the list box. 
 

When the Add Culvert button is selected, the dialog depicted below is displayed.  A prerequisite to 
storing culverts is a headwall must be stored within the Node options in the specified Drainage Library. 
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The Culvert dialog is used for adding, editing, or deleting Culverts. 

 

The dialog consists of three fields at the top, and six tabs.  The fields at the top remain regardless of 
which tab is selected.  As each tab is selected, the dialog changes dynamically to reflect the selected 
tab.  Only the culvert ID and description are constant while manipulating tabs.  These tabs include: 

 Parameters:  Defines the design Discharge and Tailwater as well as the Discharges and 
Tailwater to be used for analysis. 

 Configuration:  Defines the properties of the culvert including the culvert shape, material, size, 
number of barrels, roughness coefficients, and entrance type. 

 Headwall Location:  Defines the location and reference information for the culvert. 
 Overtopping:  Defines parameters used in the calculation of overtopping flow. 
 Computations:  Provides for any combination of culvert, tailwater, and/or overtopping 

calculations and allows for output to an ASCII file. 
 Culvert Profile - Not available in the current version. 

The minimum requirements for storing a culvert are completion of the front three tabs:  Parameters, 
Headwall Locations, and Configurations.  
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LAB 15: Culverts 

Culvert Placement in Plan View 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB15.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Drainage > Project > Open.  

Step 5. Select Drainage > Tool Boxes > Main. Drag the Culvert icon from the Drainage tool 
palette. 

 

Step 6.        The culvert toolbar will be invoked. Click the Add Culvert button. 

 

 

Step 7. Enter the Culvert Name as: Culvert 1 and Click OK. 
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Step 8. The Culvert dialog will open as seen below: 

 

Step 9. Enter the culvert discharges. 

 

Discharge: 
Keyin 75 cfs and click the Add List Item button.  Keyin 120 cfs 
and click the Add List Item button. 

Design 
Discharge: 

Double click next to the 75 cfs within the design column. 
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Step 10. Define the Tailwater: 

 

Slope: 4.0 % 

N Value: 0.040 

 

Step 11. Click the Extract Cross Section button.  Set the Drape Element on Model/TIN and set to 
TIN File.  Then select survey.tin 
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Step 12. Click the Place Element button to locate the postion of the tailwater profile to extract. 
Place a line in a location similar to that shown below: 

 

 

Step 13. The Define Culvert Tailwater Cross Section dialog will now contain the profile along the 
element placed representing the channel cross section at this location. 
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Step 14. Click the OK button and the main culvert dialog will open again. The coordinates of the 
profile will be populated. 

 

 

Step 15. Activate the Configuration tab to define the type of Culvert.  

 

Shape: Circular 

Material: Concrete 

Library Item: 24 inch Dia. Circular 

Manning’s 0.013 

Entrance Type: Headwall Square Edge 
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Step 16. Activate the Headwall Location tab to define the location of the upstream and 
downstream headwalls (nodes). 

Type: Plan View 

Reference Chain: Mainline 

TIN File: Survey.tin 

 

Step 17. Locate the Upstream Node by clicking the Dynamic Place button and setting the 
upstream node at a location similar to that shown below:  

 

 

Step 18. Locate the Downstream Node by clicking Dynamic Place under the Downstream Node 
group.  
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Step 19. Set the Elevations for both the Upstream and Downstream Nodes by toggling the 
Elevation source to TIN/Model. This will extract the elevations at the headwall locations 
with information from the TIN file. 

Step 20. Once the Nodes have been located and the elevations set, the Culvert can be added to 
the project. Click the Apply button and the culvert will be drawn to the symbology in the 
Preferences and labeled. 

 

 

Step 21. The information to this point is enough to check the culvert computations. Activate the 
Computations tab. Toggle on the option to view the Culvert calculations. Click the 
Compute Culvert button to perform the calculations. 
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Culvert Adjustment in Profile View 
Step 1. Select the Headwall Location tab. 

  

 

Step 2. Press the Files button and select : Proposed.tin. This is a proposed dtm file created by 
the Roadway Designers. It incorporates the existing ground data plus the designed cross 
sections of the project. 
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Step 3. Press the Create Profile button. 

 

 

Step 4. Adjust the profile station, elevation and symbology. 

 

Step 5. Press the Place Profile button and place the profile in the dgn file. 

Step 6. Press OK when done.  

Step 7. Press Apply to show the culvert in Profile View. 
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Step 8. Change the type of culvert placement to Profile View, and press OK at the prompt. 

 

 

Step 9. Using the Place button adjust the location of the upstream and downstream headwall. 
The location of the headwall could be done dynamically by moving your cursor close to 
the circle marking the inverts of the culvert in profile view. 
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Step 10. When done press the Apply button to reset the location of the culvert in profile and plan 
view.  

 

 

Step 11. Press the Computations tab and update the calculations. 

Step 12. Exit MicroStation.  
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 16 Special Ditch Profiles 
 

Objectives Review the concept of how to create a special ditch profile for proper 
drainage in GEOPAK and review the tools to automate this process. 

Introduction 
The creation of a special ditch profiles requires the usage of different tools within the GEOPAK software. The 
designer should be able to review the proposed cross sections provided, extract an existing ditch profile and 
then adjust it to create a proposed ditch profile.  

We will explain the major tools inside GEOPAK used to automate this process. 

Cross Section Navigator 
Project Manager Not accessible from within Project Manager 

Tools 

              

Menu Bar Application GEOPAK Road > Cross Sections > Navigator 

 

The Cross Section Navigator tool is used to view and traverse between cross sections.  It can also be 
used to draw cross section information. 

When the Navigator is invoked, the following dialog box appears.  

 

The user can scan through the cross sections by either choosing the station from the drop down list, 
or by using the First Section, Previous Section, Next Section, or Last Section icons (arrowheads).  The 
Reset Navigator icon window centers the current station to the view.   

 

The Open View Control Dialog Box enables the user to open several windows to 
view different portions of the cross section at the same time.  The user can view the 
whole cross section in view 1, the left side in view 2, and the right side in view 3, etc. 

 

Cross section elements can be added or modified using MicroStation tools or GEOPAK cross section 
drawing tools, as detailed in the table below. 
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DP Offset Elevation 

 

Data points at a given offset/elevation, or find the offset/elevation of the 
cursor location. 

 

DP Delta Distance 
Slope 

 

Draws a line at a given horizontal distance and slope.  

 

XS Active Angle 
Tool 

 

Sets the active angle to the given value.  If a MicroStation tool is used with 
the active angle option, this value is used. 

 

Draw XS Line  

 

Draws a cross section line.  The length and/or slope can be specified.  

 

 

XS Reports 
Objectives Create various cross section reports:  

 - for plan use (design elements and quantities) 
 - as input for other programs and/or applications of GEOPAK 
 - for construction layouts. 
Create and draw construction limits in the plan view file. 

Project Manager Reports and XS Quantities 
Limits of Construction 

Tools 

           
 



XS Reports 

 

VDOT GEOPAK Drainage Training Manual 
1/27/2006 165 

 

The GEOPAK Cross Section Report Utility can extract up to 
sixteen different reports from original and design cross-
sections.  For each report generated, the user must set the 
parameters of the existing and/or design cross sections.  
GEOPAK also provides an option to make custom headers for 
each of the reports via the User pull down menu. 

Custom Header 

 

From the XS Report dialog box, select User > Preferences.  A 
Report Header dialog box will appear with all options ghosted 
out.  To activate the individual fields simply toggle on the box 
next to the desired field.  Once you have completed the dialog 
box, the information will be saved as an .hdr file.  This allows 
for the creation of a separate header for each type of report.  
The tolerance field determines the maximum gap allowed 
between cross section elements.   

 

 

Blue and Red Top 
Based on the dialog box settings, GEOPAK determines the offset and elevation of a slope and its 
breakpoints.  Blue refers to the top of pavement and Red is the top of subgrade.  The user must 
determine this by indicating text and level, color, weight and style for each surface. 

Clearing 
The Clearing Report is useful for obtaining clearing and grubbing quantities.  For each station, 
GEOPAK will list the clearing distance on each side of the chain and the width of any exception.  
You can obtain the results in the appropriate units.  Toggle boxes for Cut Slope Rounding, 
Additional Clearing in Cut and Fill, and Minimum Clearing Width are provided for increased control 
over the output. 

GEOPAK can also generate quantity sub-totals based on the value specified in Sub Every. 
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To use the Except Width option, you must have an existing ASCII file that includes the Beginning 
and Ending Station and Exception Width. 

Once everything is set, you can output the information to an ASCII file 

Closure 
The Closure Report provides information on the intersection point between the user-defined 
proposed finish grade and existing ground.  In addition to the ASCII report, the designer may 
instruct GEOPAK to close any gap either by drawing a vertical line between the endpoint of the 
proposed finish element and the existing ground or extending the slope of the last proposed 
element to intersect existing ground.  The procedure will not extend existing ground.  The 
Closure Report can be accessed within any MicroStation cross section file by selecting 
Closure from the main XS Reports dialog box. 

DTM Input 
This process generates XYZ coordinates from cross section elements and places this 
information into an ASCII file for use by the DTM portion of GEOPAK.  To use this dialog box 
simply enter the .gpk job number, chain name and station range.  GEOPAK will read the cross 
section elements based on level, weight, color and style. 

DTM Proposed 3D 
This report is similar to DTM Input except that you can set both original and proposed cross 
sections at the same time.  This report also differs in that it makes break lines across the cross 
sections.   

HEC – 2 
This process reads cross section elements and formats the information in an ASCII text file 
suitable for use in the HEC-2 hydraulic program. 

HEC RAS 
This process reads cross section elements and formats the information in an ASCII text file 
suitable for use in the HEC RAS hydraulic program. 

Multi-Line 
  This report is useful in creating cross-sections for staged construction.  Begin by entering the 

job number, chain name and station limits.  Primary cross section element parameters must be 
completed before secondary element parameters.  This is important due to the order in which 
GEOPAK reads the information.  Once all the parameters have been entered, the new cross 
sections may be drawn to the design file or you may choose the display only option.  An ASCII 
text file will be generated. 



XS Reports 

 

VDOT GEOPAK Drainage Training Manual 
1/27/2006 167 

Profile Grade 
The Profile Grade Report is one of the most versatile reports available.  It prints existing ground 
and design grade elevations and low point elevations for each cross section.  Additionally, this 
report has the ability to search either for the low points or any text string that you specify and create 
horizontal and vertical alignments and store them directly into the .GPK.  Horizontal alignments 
created from this report will have no curves. 

Radial Staking 
The Radial Staking Report is a specialized report created for the U.S. Federal Highway 
Administration (FHWA). 

 RT 40 
The RT 40 Report produces RDS based RT40 data.  To use this dialog box simply fill in the job 
chain name, stationing range and the parameters of the cross section elements you wish to use. 

Seeding 
Other than the usual entries, the user must enter the parameters of the elements to be seeded. 

This dialog box includes slope and subtotal options as well as a way to limit the number of 
segments read (By-Pass Segments).  The user may also establish additional seeding 
specifications (Additional Distance). 

Once all of the settings are complete, the report will produce seed or sod quantities written to an 
ASCII output file for use in plan quantities.  

Slope Stake 
The Slope Stake Report is a special format report developed for the FHWA.  This report 
generates offsets, elevations and superelevation information for each cross section.  To generate 
this report fill in the usual cross section parameters plus Subgrade and Hub Staking information. 
When complete, push Apply and the report is written into an ASCII file. 

Staking Detail 
The Staking Detail Report determines the tie down point between the proposed finished grade 
and the existing ground.  GEOPAK will list the right and left offset, elevation, and slope of the finish 
grade and superelevation rate for each cross section.  To create this report, fill in the project 
information and desired cross section elements’ parameters.  Once complete, you have the choice 
between two formats, a FHWA ASCII report or a Montana DOT report (includes ditch elevations). 
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WSPRO 
    This report takes the cross section elements and turns them into an ASCII file for use as input in 

the WSPRO hydraulic analysis program. 

 XS List 
This report creates a listing of elevations and offsets for each cross section element according 
to user-defined parameters.  You have the option of creating either an original cross section list 
or a design cross section list.  These reports are very similar to RDS cross section lists. 

Vertical Alignment Generator 
Objectives To create and store vertical alignments using the Vertical Alignment 

Generator. 

Project Manager Vertical Alignment 

Tools 

      
 

 

GEOPAK has a variety of tools for generating and storing a proposed profile.  Those tools include: 

 The Vertical Alignment Generator (VPI Based) is a GEOPAK tool that can graphically 
create and modify proposed design profiles or modify an existing ground profile.  The 
designer can generate a profile based on VPI data, design speeds, stopping sight distances, 
and K values.  These operations may be accomplished through a dialog box and/or by 
dynamic manipulation of graphic elements. 

 A profile may also be created with Coordinate Geometry (COGO) input (key in commands).  
In addition, there are VC commands that compute and display vertical geometry and the 
parameters associated to aid in the development and generation of vertical alignments used 
in conjunction with Store Profile commands.  VC commands define parabolas for various 
combinations of stations, elevations, grades, slopes and the rate of vertical curvature (K 
value), and also define the tangents between two parabolas or between a parabola and a 
point. 
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Accessing 

When selecting the Vertical Alignment generator, the first dialog 
box that appears is labeled Settings, as depicted here.  The 
entries in this box set the parameters and define the location 
within the design file where the profile components are to be 
displayed.  All fields must be completed before the design 
process can begin.  Once the OK button is pushed, the Vertical 
Profile Generator dialog box appears. 

Note: This tool also utilizes the cell that was drawn in the 
previous exercise by using the Identify Cell button. 

 

Using the Vertical Alignment Generator 
This tool enables a user to load a previously stored profile or create a new profile.  You will notice the 
dynamic changes in the dialog box throughout the vertical alignment design. 

 

 

Various design parameters must be defined prior to designing a new profile; which are discussed in 
the options supported under the three menu options; File, Tools, and User. 
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File 

 

 

Clear - clears the profile display from MicroStation graphics and removes all VPI’s from 
the dialog box. 

Draw - write the graphic elements of the profile to the MicroStation file. 

Load - retrieves a previously stored profile from the coordinate geometry database 
(.GPK) 

Save - stores a new profile or updates (redefines) a previously stored profile under the 
same name. 

Save As - is used to store the profile or to save a modified profile under a different 
name. 

Exit - ends the process. 

Tools 

 

 

Critical Points - Vertical curves may also be defined by one or two critical points – i.e. 
the curve will pass through these points If mathematically solvable, the vertical curve 
will be drawn and the design speed display adjusted to fit the current parameters. 

Issue Data Point - Permits the user to type in stations and elevations, issue a data 
point that can be part of a MicroStation place line, place a cell or perform other generic 
operations.  This is useful in displaying visual references within the profile that need to 
be considered in design of the vertical profile. 

User 

 

 

Preferences - sets the rounding parameters for each of the items listed in the dialog 
box.  Also contains a toggle that will force the dialog box to window center the view on 
the current VPI.   

K Values - is a table of stopping sight distance K-values for crest and sag conditions 
for various design speeds.  These values are based on the AASHTO Green Book. 

Settings - recalls the Settings dialog box that first appeared upon initializing Vertical 
Layout. 

Creating A New Profile 

Note: The enter/tab key must be used to ensure values are accepted. 

A new profile can be created with the following steps: 

Step 1. Place the first VPI using one of the four supported options. 

 Type station and elevation of the VPI into the appropriate fields in the Profile 
Generator dialog box. 

 Enter station of VPI as precision input (type in value), and allow the elevation to be 
defined through dynamic cursor placement on screen. 
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 Elevation is defined via precision input, and the station is defined through dynamic 
cursor placement on screen. 

 Both values for the VPI can be established dynamically on screen by clicking on the 
Dynamic button and placing a DP in the view at the desired station and elevation. 

 

Step 2. Define ahead (or back tangent) 

 Station, elevation, grade and length parameters may be defined via precision input, 
dynamic manipulation or a combination of both. 

Step 3. Define remaining VPI’s and Grades 

 A repetition of Step 2 with an option to insert VPI’s between two existing VPI’ s. 

Step 4. Define Vertical Curves 

 Simply define the design speed from the Speed option button and GEOPAK will reference 
the K-value table and draw the vertical curve.  If a curve overlap occurs, an overlap 
message will be displayed in the dialog box along with the overlap length.  Length of 
Curve or K-value may also be keyed in. 

Step 5. Adjusting Curve Lengths 

 The vertical curve can be modified by directly keying in either the K-value, curve length or 
defining the design speed in the dialog box.  You will see the values computed 
automatically adjust to reflect the results of any modifications. 

Step 6. Save the Profile 

 Click File > Save As to name and save the newly created profile.  The names of profiles 
are any 1-9 alphanumeric characters. 

Precision Placement Options 

 

 

Options available for creating or modifying vertical curves, VPI’s and grade lines:  

 OFF - Values change. 
 INC (Increment) - Ensures that the designated profile parameter will be adjusted as 

defined in the Preferences dialog box. 
 LCK (Locked) - Forces selected operations to maintain the designated profile 

parameters. 
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LAB 16: Special Ditch Profiles 

Reviewing the Roadway Cross Sections 
Step 1. Execute c:\data\geo\VDOT\drain1\LAB16_V8.EXE. 

Step 2. Open c:\data\geo\vdot\drain1\d17682xsmainline.dgn  

Step 3. Select the Cross Section Navigator tool from Applications > GEOPAK Road > Cross 
Sections > Navigator or from the Road tools palette: 

 

Step 4. Use the Cross Section Navigator to browse and check the elevations of the ditch at the 
right side of the alignment.  

Step 5. Exit the Cross Section Navigator when done. 

 

Extracting a Ditch Profile from Cross Sections 
Step 1. Invoke the Road Tools tool frame from the MicroStation menu bar by selecting 

Applications > GEOPAK Road > GEOPAK Road Tools. 
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Step 2. Access Project Manager using the Project Manager icon from the Road Tools tool frame.  

 

Step 3. Select the Project: d17682.prj located in c:\data\geo\vdot\drain1 and click OK 

 

Step 4. Select the proper User and click OK. 
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Step 5.        You will now see the main workflow dialog box.  

 

Step 6. Select Reports and XS Quantities: 

Step 7. From the XS Reports dialog box, select the User > Preferences dialog box. 

 

 

    

 Set the tolerance to 0.01. 

 Dismiss the Report Header dialog box. 
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Step 8. From the XS Reports dialog box, select the Profile Grade report.  

 We are going to use this report to create a Profile along the bottom of the right side ditch.  

Step 9. Fill out the Profile Grade dialog box as shown.  

 Select the proper symbology for the Existing Ground line and the Proposed Finish Grade.  

  Existing Ground Line : Level1 

  Proposed Finish Grade : Level2,Level3,Level4,Level5 

 

   To add the Text Search information to the collection box, push the ADD button.  (Store 
Text:  FRDTCHR). This text has been previously written in the cross section DGN file at 
the bottom of the ditch. 

Step 10. Click Apply to start processing. Then, dismiss the dialog box. 

Review the Ditch Profile 
Step 1. Access Coordinate Geometry from the Project Manager dialog workflow. 

Step 2. Access then Coordinate Geometry Navigator using Tools > Navigator. 
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Step 3. Use the Profile option to see a list of the stored profiles. 

 

Step 4. Select  Element > Profile > Utility from the Coordinate Geometry menu to invoke the list 
print dialog box.  

 

Step 5. Select the profile “DITCH1” and press Print.  

Step 6. Review the profile information in the COGO output display window.  

Step 7. Check the Redefine box in the Coordinate Geometry dialog. This will allow us to overwrite 
information into the geometry database (job101.gpk). 

 

Step 8. Close the Coordinate Geometry dialog box . When prompted to save the COGO session 
select NO. 

Draw the Ditch Profile 
Step 1. Open c:\data\geo\vdot\drain1\h17682.dgn  

Step 2. Select the Draw Profile tool from the Road Tools palette or Applications > Geopak 
Road > Plans Preparation > Draw Profiles. 
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 The dialog box below will open. 

 

Step 3. Select chain MAINLINE. 
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Step 4. Click the Dialog Profile Cell Control icon (to the right of Job Number).   

 

 Set the Active Chain to MAINLINE. 

 

Step 5. Click the Place Profile Cell icon on the right side of the dialog box.  This will open the 
Place Profile Cell dialog box. 

 

Step 6. Fill the dialog box out as shown above and then DP somewhere in the DGN file in order to 
place the profile cell into the design file.   

Step 7. Close the Profile Cell Control dialog box. 
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Step 8. Click the COGO tab and set the Label Scale to 25. 

 

Step 9. Select Profile Name DITCH1 from the drop down list in the Details area. 

Step 10. Under the Display Settings set the option to By Feature.   

Step 11. Click on the paintbrush icon and select the feature shown below. Then click OK. 

. 
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Step 12. Click the Add COGO Profile Settings icon to draw the profile.  This will draw the ditch 
profile with the proper symbology. 

 

Step 13. Dismiss the Draw Profile dialog box.  

 

Create a Special Ditch Profile  
Step 1. Select the Vertical Alignment button from the Road Project: 17682.prj workflow dialog  
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Step 2. Adjust the Settings for the proposed ditch profile by pressing the Identify Cell button and 
selecting the profile cell in the DGN file. 

 

Step 3. Press the OK button to commence development of the special ditch profile.  

 

Step 4. We are going to develop a special ditch profile between stations 203+50 and 206+00. 
Using the Dynamic button try to locate the first VPI. Be sure to press Enter after each 
entry is made. 

 

Step 5. Press the Insert After button and complete the VPI Station and Elevation of the 
subsequent VPI’s as detailed in the table below. 

VPI Station Elevation 

2 205+00 2018.50 

3 206+00 2020.11 

.  
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Step 6. When completed, select File > Save As from the Profile Generator to save the profile 
DITCHRT1.  

 

Step 7. Exit the Profile Generator. When prompted to save your profile, answer No since we did 
that in the previous step. 

Step 8. Open COGO and use the Element > Profile > Utility > List/Print tool to see a listing of 
information about the profile. The Element > Profile > Elevations tool will provide 
elevations at any station or increment of stations desired. 

 

 

Step 9. Exit the Coordinate Geometry dialog box. Select NO when prompted to save the session. 

Step 10. Now, Roadway designers should be able to incorporate this new profile when they update 
their cross sections runs.  

Step11. Exit MicroStation. 
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 17 Pond Design with GEOPAK Site Modeler 
 

Objective: Provide the user with a general understanding of 
GEOPAK Site Modeler functionality.  Gain a general 
understanding of Site Models, Site Objects and Site 
Element interaction, associations, and terminology 

Goal: Setup a Geopak Site Modeler Project and associated 
Project Preferences. 

Prerequisites: Completion of an existing ground Digital Terrain 
Model. 

Additional References: GEOPAK Site Online Help – Modeler 
 

Introduction 
The GEOPAK Site Modeler enables fast, dynamic development of site models and easy management 
of the many changes that occur on site projects.  It captures design intent as users work and provides 
immediate visual feedback.  The software allows users to perform engineering modeling within a 
Digital Terrain Model (DTM)—without merging or extracting graphics into the DTM.  Many traditionally 
cumbersome processes are reduced to one step: for example, you can dynamically move a building 
pad in a single drag and drop step—without measurement, clipping, merging, and placement steps. 

The Site Modeler offers unprecedented flexibility in interactively working with site designs without the 
limitations of traditional iterative steps.  No cumbersome triangle or point editing is necessary.  The 
software maintains existing ground and provides full control over defining elevations and side slopes 
and balancing cut-and-fill.  Analytical tools are included to afford powerful evaluation of site designs. 

GEOPAK Site integrates digital terrain modeling with interactive 3D site design.  The software allows 
you to incorporate design features in the model while maintaining existing ground.  Move building 
pads. Change pond elevations.  Extend retaining walls.  Trim curbs.  Resize berms.  The Site Modeler 
automatically regenerates the DTM, yet retains full integrity of the models and the original DTM.  
There is no need for merging or extracting graphics into the terrain model. Easy on-the-fly functions let 
you change elevations and side slopes and balance cut-and-fill. You can add features such as 
contours to the model as needed to define your design.  Tools are supported for evaluating the site 
design and producing drawings and site models. 

Site Modeler Project Components 
A GEOPAK Site Project is comprised of three components: Elements, Objects, and Models. 

 GEOPAK Site Elements 
Elements are any MicroStation graphical element assigned an elevation and DTM Feature (breakline, 
boundary, contour, etc.) with GEOPAK Site tools.  They can be placed into a 2D or 3D design file 
utilizing any generic MicroStation command, except Make or Drop Complex Chain.  Once the 
elements are drawn, elevations are assigned with GEOPAK Site tools.  At any time, they can be 
moved, copied, or otherwise manipulated.  Once a group of elements is drawn to the designer's 
satisfaction, they can be defined as an object. 
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Elements can be modified at any time during the site design process.  To move the location of an 
object in the X-Y plane, utilize any MicroStation command, except Create Complex Chain. 

Let's review several types of modifications, their impact on element elevation(s) and their results on 
the site project. If using the Site Element Association feature, the elements elevations will be 
recreated per their original definition. If not using the associations then the following will apply to the 
elevations of the site elements. 

Note:  All modifications support selection sets and fence operations. 

Extend / Shorten Line Use generic MicroStation commands to shorten or lengthen.  The Site 
Modeler holds the elevations of the original element. 

Insert Vertex Elevation of new vertices is interpolated between adjacent vertices. 

Move Element Maintains all vertices at the original elevations. 

Scale Maintains the elevations at all vertices. 

Rotate Maintains the elevations at all vertices. 

Mirror Maintains the elevations.  If there are duplicate vertices due to the 
mirroring, the second elevation is utilized. 

Delete Line Removed from the DTM object. 

 

GEOPAK Site Objects 
Site Objects are collections of Site Elements that are grouped together into Objects for the purposes 
of side slope definition, model merging, volume quantity options, and logical geometric components. 
Site Elements can be added to Objects as they are created or at any point in the design process. Site 
elements can also be removed and included in more than one Site Object.  Examples include: 

 Parking lots 
 Buildings 
 Ponds 

Each object can contain an unlimited number of elements.  In addition, it has other site attributes and 
capabilities that should be considered during object creation: 

 Side slopes - defines the interrelationship between the object and the model.  Cut and fill side 
slopes are automatically generated around the extent or boundary of each Object in the 
model.  The boundary is automatically determined from the extent of the elements contained 
in the object.  Side Slopes can be as basic as a single cut or fill slope from the edge of a 
building to existing ground, or intersecting slopes between two objects, i.e., a building and a 
parking lot.   

 Quantity depth - In order to do excavation quantities, an object may have an associated 
depth.  For example, a building may have a quantity depth of two master units, which 
represents the amount of granular material required beneath the building.  These quantities 
can be easily changed, and quickly computed. 

 A specific set of visualization settings can be applied to each object to control the display 
symbology of each. 

 A Site Model is created by merging each of the triangulated Objects specified in the Model.  
The designer determines which slopes control the merging process by means of a FIFO list.  
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The first object, also referred to as the Base Object is the starting surface.  Each object is 
then merged "on the fly" in the order listed.  To change the controlling slopes for intersecting, 
simply change the order of the list. 

 Site Objects can be raised and lowered in their entirety to easily evaluate design alternatives.  
 The Objects layout and the geometry of the member elements should be evaluated. The 

boundary of Objects is determined from the extent of the elements and the objects 
triangulated representation will include all elements.  Therefore, specific attention to the 
grouping of elements based on vicinity and shape of the desired objects in the model should 
be made. It is recommended to create more objects than fewer as it provides more control 
and more flexibility in the design and evaluation of the final model.   

Objects can be modified at any time during the site design process.  The following are methods of 
modification: 

 Add / remove elements from the object 
 Modify Object Slopes 
 Raise or lower the object 

GEOPAK Site Models 
A model is comprised of an unlimited number of objects, one base object (i.e., existing ground), and a 
“First In – First Out” (FIFO) list which dictates the merging order.  Note the designer does not have to 
merge, as it's done automatically "on the fly."  As a new object is added to the model, its resultant 
slopes, contours, etc., can be displayed on the screen.   

Models can be modified at any time during the site design process. This can be accomplished in three 
methods: 

 Add or remove objects from the model 
 Change the base object, i.e., update existing ground terrain data 
 Changing the FIFO list 

The workflow involved in using the Site Modeler is designed to expedite the creation of digital terrain 
models while providing enough flexibility to easily accommodate design changes. The following 
outlines getting started with the Site Modeler. 

 Establish base design planimetrics in 2D or 3D MicroStation design file. This includes design 
features that define the DTM (e.g., centerlines, curbs, berms, ponds, property line etc.). 

 Obtain design information such as original ground or survey information that serves as the 
basis of the initial design. 

 Review the geometric layout of design features and determine a preliminary concept for the 
type and configuration of Site Objects to be used in the design. 

 Start Site Modeler New Project Wizard. 
 Create an empty Model. 
 Import the base design information into the Model. 
 Select a location to begin the DTM design. 
 Create a new Site Object that fits the starting location. 
 Begin defining the elevations of the Site Elements and adding them to the Active Object. 
 Continue to create Site Objects, Site Elements as needed. 
 Evaluate and analyze the Site Model and adjust Site Elements, Site Objects and Model. 
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Site Modeler Main Menu 
GEOPAK Site is invoked from within a MicroStation design file.  If the Project Wizard dialog is 
bypassed (by activation of the Don't Show this dialog at Startup), the GEOPAK Site Modeler main 
menu bar (along with the Active site Object Control) is automatically displayed.  An alternate method 
of invoking the menu bar is completion (without pressing the Cancel button) of the Project Wizard.   

Each menu selection accesses GEOPAK Site project information, feature placement and tools 
necessary to complete a GEOPAK Site project.  Tool frames and tool boxes are also supported for all 
functions and are accessed via the Tool boxes pull down.  The current Site working directory and 
Project File are displayed in the header of the menu bar. 

Project Menu Options 
The Project Menu selections are utilized for creating new GEOPAK Site projects, opening existing 
projects, saving projects, establishing the project Preferences, Importing and Exporting data in and 
out of the project file, and exiting the Modeler. 

When working on a project, frequent use of the File > Save pull down is important.  Any changes 
made in the project are not recorded in the GEOPAK Site File (GSF) file unless a File > Save or File > 
Save As operation is executed.  Hence, any power interruption or other malfunction will result in loss 
of data that can be avoided through the judicious use of the File > Save tool. 

Each GEOPAK Site project contains a set of Preferences which control the project file components 
and visual symbology which are accessed through this menu selection. 

GEOPAK Site Modeler supports two operations to import data into a site project: 

 Data 
 3D to Object 
 In addition, it supports three operations to export data from a site project: 
 Visualization to DGN (Contours, Triangles, etc) 
 Model / Object (Creates DAT & TIN Files) 
 To COGO (Creates Points in the COGO Database) 
 Export to COGO Profile (Creates a Profile in COGO) 

To exit GEOPAK Site, the designer may utilize the File > Exit tool on the Project pull down. When 
exiting, GEOPAK Site Modeler prompts for saving the current project. 

Project Preferences 
GEOPAK Site Modeler supports a wide array of user defined Preferences which enables the designer 
to set project specific options, or a larger organization to set parameters to maintain standards.  Each 
GEOPAK Site project contains a set of Preferences and they remain with the project. 
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The general groupings of Options are 
displayed in a list box in the left side of 
the dialog, while the right side displays 
parameters for the highlighted Option.  
As different options are selected in the 
list box, the right side of the dialog 
changes dynamically to reflect the 
parameters for highlighted Option.   

 
 

The general groupings of Options are displayed in a list box in the left side of the dialog, while the right 
side displays parameters for the highlighted Option.  As different options are selected in the list box, 
the right side of the dialog changes dynamically to reflect the parameters for highlighted Option.   

These Options and very brief descriptions are detailed below. 

Tolerances Tolerance and stroking options used in the creation of Site Elements. 

Visualization Variety of element symbology and display options 

Updating Toggle for automatic updating 

Objects Standard List of Object Types and default values for Object parameters 

Save Automatic saving and backup options 

 

On the right side of the dialog, the OK and Cancel buttons commence closing the dialog and storing 
the preferences, if required. 

Tolerances 

 

 

Linear Stroking The Linear Stroking option densifies portions of linear elements and is utilized 
to interpolate new spots from the linear elements. 

Curve Stroking The Curve Stroking feature densifies the curved portions of the break lines.  
Curved break lines in GEOPAK are handled by segmenting the curve into small 
chord segments.  The length of the chord segments can be determined by 
setting the Curve Stroking. 

Maximum 
Triangle Length 

External triangles whose external edge is longer in length than the Maximum 
Triangle Length user specified distance are dissolved. 
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Elevation 
Decimal 

The Elevation Decimal controls the number of decimal places displayed on the 
elevation labels for points within the objects and models. 

Note: Stroking is the process of automatically inserting points along Site Elements by interpolating 
new points from the linear and curved sections of the data. 
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Visualization 
 

A variety of user-defined 
parameters are supported, to 
provide the designer with maximum 
flexibility in Visualization.  These 
parameters are briefly detailed 
below. 

 

 

 

View Active Object When activated, the current object listed in the Active Site Object Control 
dialog is displayed. This object will maintain the display settings during 
view updates and changes. All visualization settings are derived from the 
definition of the specific object that is active. 

View Active Model When activated, the current model listed in the Active Site Object Control 
dialog is displayed.  This model will maintain the display settings during 
view updates and changes.  All visualization settings are derived from the 
definition of the specific model that is active.  If the mode is inactive, no 
models are displayed as depicted in the example below, where only the 
MicroStation elements are displayed. 

Smooth Contours When active, an algorithm is employed to smooth contours. 

Construction Elements The element symbology for Site Elements created in the modeler that is 
not contained in a Site Object.  It may be desirable to establish Site 
Elements and their elevations purely as a reference or to construct other 
elements. These Site Elements are not needed in the Site Objects 
themselves and are considered Construction Elements.  Site Elements 
contained in Site Objects are displayed according to the object 
visualization of the object to which they belong.  The Construction 
Elements are displayed using these settings in the preferences. 
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Model Visualization 
When the Model Visualization button is pressed, the dialog below is invoked. 

 

The Visualization tab contains specifications for all features that are available for display in Site 
Models including triangles, boundaries, and vertices.  These settings will be applied to all models 
created subsequent to setting these.  All symbology controls, the sample line and text graphics in this 
case, can be set by double clicking the sample and using the Set Feature dialog shown below. 

 

 

Additional options can be invoked by clicking the right mouse button over these sample controls. 
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Objects 
When the Objects option is selected, the dialog changes as reflected below.  This option is utilized for 
creation, deletion, and manipulation of the library of objects.  The information includes both the Object 
Type and Naming Prefix. 

 

This list box displays all Object Types within the active project.  Default types which are initially 
displayed include:  Parking, Building, Pond, Roadway, Lot, etc.  These Object Types assist in 
organizing and categorizing design features, controlling standard symbology, and establishing defaults 
for Objects created. 

The portion of the dialog titled Object Details allows the user to set Visualization of the highlighted 
Object Type.  Each Object Type may have its own settings, providing maximum flexibility to the user 
to display only specified parameters for the particular Object Type.  Note its similarity to the Default 
Model Visualization dialog. 

When an Object Type is highlighted and the Object Details is set to Default Slopes, the dialog 
depicted below is displayed. 



Site Modeler Main Menu 

 

VDOT GEOPAK Drainage Training Manual 
1/27/2006 192 

 

As new Objects of a particular type are created they will obtain the default settings.  Note that an 
Object slopes can be modified at any time, these defaults are just applied when the object is created 
and remain in effect until the slopes are modified while editing the Object.  Slopes are applied around 
the boundary of the entire object and are generated as the intersection from the Object boundary to 
the Model.  Three Default Side Slope options are supported: 

 No Slopes 
 Cut - Fill Slope 
 Cut-Fill Table 

Corner Options can be specified to generate either Rounded or Straight slopes around corners of 
Objects and can be projected Radial or Planar.  Supported options for Cut and Fill specifications are: 

 Slope run:rise 
 Slope rise:run 
 Slope % 
 Slope Unit / Unit (ft. / ft. or meter/meter) 

Simply specify the desired slope. 

Updating 
The Updating dialog is depicted below. 
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When the Auto Update Model is active, the model is updated whenever a change is made to an 
element, object, or the FIFO of the Active model.  As Models get larger, it may not be necessary to 
update the Model on every single edit.  Deactivating this speeds up the modifications that are being 
performed, but must either be activated or the Model itself processed to view any changes incurred. 

Element Association refers to the relationship elements maintain with the original method by which 
they were defined.  Elements defined by other elements / object / models can always maintain the 
same dependency on the items referenced in their creation. 

When activated (On), it enables the associations.  All subsequent element modifications that occur to 
the dependent elements or referenced identity utilize the original association when computing the 
impact of the modifications.  Turning the toggle off (OFF) disables the associations. 
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Save 
The Save dialog is depicted below. 

 

When the Automatic Backup option is activated, a backup file is always created (in the project 
directory with a *.bak extension) when the project is opened. 

The Automatic Save Option saves the GEOPAK Site project file (.GSF) to the disk at the user 
specified interval.  Automatic Save intervals include 1, 2, 5, 10, & 30 minutes. 

Model Menu 

The Model menu selections provide the mechanism to add, edit and delete 
the various elements which comprise a Model, including Display 
parameters, merging order (FIFO), and Display options.  Each of these 
tools invokes a dialog wherein the specific model information can be added 
or edited, or entire models deleted. 

 

Edit Model 
The Model editing options provide the mechanism to change the list of Objects contained in the model 
and modify the display setting of the model and its objects. When invoked, the dialog depicted below 
is displayed. 

 

 

FIFO Functionality 
The FIFO, or "First in First out," contains the list of all the Site Objects contained in the model and the 
order in which the Objects are to be merged. This Object list is processed from the top to bottom, 
starting with the Base Object any time a change is made to a Site Object or Site Element contained in 
the Model. The Site Preferences contain an option to disable this automatic updating should this 
immediate feedback be unnecessary or grow time consuming as the model grows. Since Objects can 
easily be added and removed from the FIFO list, certain time savings can be achieved by removing 
Objects not needed for the current design process and can be added back at the end or at such time 
as their impact is needed. 

The process used in the creation of the final triangulated Site Model is as follows: 

 The Base Object starts as the initial state of the Model. 
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 The first Object in the FIFO list is retrieved. 
 The boundary of the Site Object is determined from the extent of all the Site Elements 

contained in it. 
 The Side slopes associated with that Object are applied around the boundary down or up to 

the Model depending on the cut fill situation. 
 This Object is then merged into the Model. 
 This new state of the Model with the first Object and its side slopes merged into the base 

Object becomes the initial sate of the model for the next Object in the FIFO list and the 
process is repeated for all the objects in the list. 

Display Model Tab 
The Display Model Tab is utilized to control the visualization settings of the entire model.  The dialog is 
depicted below and contains specifications for features displayed within the Modeler including 
triangles, boundaries, and vertices.  When the toggle to the left of the feature is active, the element is 
displayed.  When inactive, it is not drawn.  To the right of each feature is the level and element 
symbology. 
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Display Objects Tab 
When the Display Objects Tab is selected, the dialog depicted below is displayed. 

 

Object Type List box containing all current Object Types in the current model.  If the 
eye icon is displayed to the left of the Object Type, then all objects of 
the specified type are displayed with their visualization settings. 

Clip Objects from Model When activated, this clips every object out of the model prior to 
display.  It is good for showing proposed vs. existing. 

Display Base Object  This toggle indicates whether the Base Object should be displayed 
with its visualization settings. 

Apply  Commences the display procedure, which reacts to any display 
changes made. 

 

Objects Menu 

The Object menu selections provide 
tools to Add, Edit, Copy, Move, Raise, 
Lower, or Delete an Object.  
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Edit Object 

The object editing options provide the 
mechanism to modify an Object's 
properties, side slopes, and display settings.   

 

 

 

Object Properties 
Under the Properties Tab the Object Name for the object to be edited is displayed in the dialog.  A 
description can be entered if desired.  Quantity Depth is the vertical depth beneath an Object where 
the earthwork volume is adjusted to compensate in the total volume.  Note that this depth is applied to 
the limits of the Object's elements and is optional when Volumes are computed. 

Three tools are supported within the 
Elements group box.  Highlight and/or 
window center Site elements within the 
Active Site Object.  Add previously created 
Site Elements to the Active Site Object and 
Remove Site Elements from the Active Site 
Object. 

 

 

Object Slopes Tab 
The Slopes options dictate the type of side slopes generated from the outer extent or boundary edge 
of the Object.  These slopes are applied when the Object is placed into a Model and computed from 
the Object to whatever the state of the Model when it is merged.  When the Display with Object toggle 
is activated, GEOPAK includes the display of slopes in the Object symbology. 



Site Modeler Main Menu 

 

VDOT GEOPAK Drainage Training Manual 
1/27/2006 198 

 

There are four slopes options available:  No Slopes, Cut - Fill Slope, Cut-Fill Table, Dynamic Slopes.  
Corner Options can be specified to generate either Rounded or Straight slopes around corners of 
Objects. 

 

Display Options Tab 
 The Edit Object Display Tab is utilized to control the visualization settings of the Active Object 
displayed in the dialog.  The dialog is depicted below and contains specifications for features 
displayed within the Modeler including triangles, boundaries, and vertices.  When the toggle to the left 
of the feature is active, the element is displayed.  When inactive, it is not drawn.  To the right of each 
feature is the level and element symbology. 

 
 

Slope Indicators Tab 
The Slope Indicators Tab is used to set the display preferences of Object Slopes Indicators. 
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Copy Object 
 

The copy tool is useful when the object is 
comprised of numerous elements which 
need to be copied.   

To copy an object, simply key in the Elev 
Diff (0 if there is none), then press the Start 
Move / Copy button and identify the object 
to be copied.  A second data point defines 
the revised location.  

Note:  When the Make Copy toggle is not activated, the dialog dynamically changes to a Move Object 
dialog. 

Move Object 

To move an object, simply key in the Elev 
Diff (0 if there is none), then press the 
Start Move / Copy button and identify the 
object to be moved.  A second data point 
defines the revised location. 

 

Raise/Lower Object 

Raise/Lower Object tool can be used to change the 
elevation of an entire object by raising or lowering it.  
Note the value is in terms of master units, i.e., feet or 
meters. 

  

Delete Object 

The Delete Object tool deletes the entire object from the 
project file and (if desired) all the Site elements that are 
part of the Object. 

 
 

Elements Menu 
The fundamental components in the GEOPAK Site Modeler, Site Elements are simply MicroStation 
graphics (2D or 3D) that have been assigned elevations using one of these Site Element tools.  

GEOPAK Site Modeler supports a wide variety of tools that when combined with generic MicroStation 
commands create and modify elements. These operations include: 

 Creating / editing elements 
 Changing element feature types 
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 Change Element Associations 
 Raising/Lowering of elements 
 Copy parallel existing elements 
 Modifying elements 
 Deleting element Z 
 3D elements 
 Composite Sections 
 Edit Profile 
 Obtaining and modifying element information 

The 3D Element is active only within MicroStation 3D design files. 

Element Feature Types 
All Site Elements require a Feature Type to describe the way in which to process and interpret the 
features within the terrain model. 

A Boundary is used to constrain the external boundary of the object or model.  For example, an L-
shaped building can be defined as a boundary, so that no triangles are created within the internal 
corner.  If no boundary elements exist within an object, the limits of the object would result from the 
convex area of all the elements contained in the object. 

  

 

                        

Feature types can be modified at any point in the design to create the desired results.  It is often 
desirable to leave features as break lines until the object design is near completion and then the 
desired elements can be specified as boundaries. 

Break Lines designate linear features such as edges of buildings, parking lots, and other pavement.  
The generated triangles never cross a break line, rather the edges of the triangles are coincident with 
a break line. 

A Contour is an element of constant elevation.  Triangles can intersect and / or cross over contours. 

A Void delineates an area of no data or obscured area and is defined in a series of points forming a 
closed element. 

A Hole is extremely useful when the base object surface (i.e., existing ground) is desired within an 
object.  For example, an area of existing within a building footprint is to be landscaped and remain at 
the original ground elevation, while surrounded by a building pad. 
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Selection Sets 
Many of the Element tools utilize selection sets, therefore, a generic discussion is warranted into the 
operation and use of selection sets.  Two options are supported: the MicroStation Power Selector or 
GEOPAK selection tools within each dialog. 

 

Use Power Selector 

When active, the MicroStation Power Selector (as depicted 
below) is utilized.  To invoke, press the Select Elements 
button in the Element Selection group box. 

 

 

 

GEOPAK Selection Tools 

Selection commands can be utilized without the Power Selector.  
The leftmost button is Select Elements.  Simply press the 
button, then select the desired elements.  To select multiple 
elements, depress the <Control> button on the keyboard while 
selecting.  To view the highlighted elements, rather than the 
"handles," a change in the preferences is needed.  To change, 
select the MicroStation Workspace > Preferences.  Then select 
Input and activate the option Highlight Selected Elements.    

 

 

After utilizing numerous MicroStation commands, the highlighted elements may not be highlighted.  To 
display previously selected elements, press the Reselect Elements button (center of the three) and 
the highlighted elements are displayed again in the specified color.  To remove all selected elements 
from the selection set, press the Reset Selection Set button (rightmost of the three).  The color of the 
selected elements is set with the color picker on the far right side of the group box.  Note that Element 
Selection must be invoked through these selection icons.  While the Site Modeler uses a selection set, 
it must be started through the use of these commands not the MicroStation Selection set commands. 

 

New/Edit Site Elements 
One of the primary tools within Elements is the New / Edit Elements tool.  When invoked, the dialog 
depicted below is displayed. 
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The dialog contains five main options:  Element, Point, Section, Side Slope and Display.  When a tab 
is selected, the dialog dynamically changes to reflect the selection.  The fields below are displayed 
regardless of which tab is selected. 

Add to Active Object When toggled, created and/or edited elements are automatically added 
to the active object. Refer to the Active Object Control toolbar for the 
current active object. 

Current Object Located between the Add to Active Object and the Apply button, the 
active Object can be selected. 

Apply Commences the processing.  This includes redrawing of the elements, 
inclusion into the active object, and if the active object is part of a model, 
reprocessing of the model. 

Element Tab Options 
The element options provide for the primary mechanism for the creation and redefinition of Site 
Elements.  When the Element option is selected, the dialog depicted below is displayed. 

 

Six tools to assign or modify elevations are provided.  As each option is selected, the title bar as well 
as the left side of the dialog dynamically change to reflect the selection.  These options include: 

Slope/Offset from 
Site Elements 

 

The Slope/Offset from Site Element option is used for assigning elevation to 
Site Elements by placing the elements at an optional slope and offset height 
from existing Site Elements. In calculating the elevation from the existing Site 
Element, a projection is performed from the new Site Elements to the 
reference based on the minimum distance from the element to the existing 
reference element. 
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Radial From 
Existing Points 

 

The Radial From Existing Point option is useful for establishing the elevation 
of elements relative to points within another model or object. The tool uses a 
reference data point elevation and an optional slope and offset height to 
compute the elevation for the new element vertices. 

Along Element 
From Existing 
Point 

 

The Along Element from Existing Point tool assigns the elevations along an 
element at a constant slope and/or offset height from a data point.  The data 
point will be projected to the element and the distance along the element from 
this point to the vertices will be used in conjunction with the slope and offset 
height to compute the elevation of the new element vertices. 

Drape on Model / 
Object 

 

The Drape on Model/Object tool is used to establish the elevation of Site 
Elements relative to the elevations contained in a model or object. It is useful 
to set the elevation of elements relative to existing ground or other object. 

Constant 
Elevation 

 

Placing elements at a constant elevation may be utilized when the desired 
elevation of an element is known. It can be used to set the elevation of a 
building or even place a contour into an object.  If the computed contours 
within an Object do not exactly match the desired results, simply draw the 
contour wanted and then place in the Object as a Contour Feature at a 
constant elevation. 

Alignment 

 

The alignment tool is used to create Site Elements from a GEOPAK 
horizontal and vertical alignment.  The alignments must have previously been 
created using one of the GEOPAK Coordinate Geometry features or the 
Horizontal and Vertical Alignment Generators.  Once a Site Element is 
created from an alignment, the curbs, edges of pavement, etc., can be 
created using one of the other Site Element Creation tools.  Typically this 
would be the Slope/Offset from Site Element. 

Point Tab Options 
When the Point Tab is selected within the New/Edit Site Element dialog, the dialog changes as 
displayed below. 

 

Point elements can be created and added to Objects to refine the surfaces or edit the vertices of 
existing Site Elements.  When placing points, the Site Modeler can detect when an existing Site 
Element is snapped to and rather than placing a new point in the Object, the snapped vertex will be 
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changed to the new elevation defined in the Point options. This provides for "pull and tug" editing of 
Site Elements on a vertex by vertex basis.  If no existing Site Element is detected, a MS point graphic 
element will be added to the design file and the Object. 

If a point is snapped to a Site Element, but not to a natural vertex of the graphic element, the Site 
Modeler will actually insert the point along the Site element. This point is now considered dependent 
on the site Element and as the element is modified or moved, so will the point. 

Five options are supported within the Point tab.   

 

As each option is selected, the title bar as well as the left side of the dialog dynamically change to 
reflect the selection.  These options include: 

Constant Elevation 

 

Used to add a point or edit a vertex of an existing Site element at a 
constant elevation. 

Drape on Model / Object 

 

The Drape on Model / Object option is useful for placing or editing 
points and placing them at an elevation relative the elevation in a 
Model or Object. 

 

Slope from Site Element 

 

 

 

The Slope from Site Element option is used for placing points at a 
given slope from a Site Element. 

Min. / Max. Elevation at 
Slope From Elements 

 

The Min. / Max Elevation at Slope from Elements option is used for 
placing points at the minimum or maximum elevation computed from 
a set of Site Elements.  It can be used to insure a low point or high 
point amongst elements. 

Slope from Point to New 
Point 

 

The Slope from Point to New Point option is used to create a point at 
a given slope to an existing point in an object or model. 

Section Tab Option 
Sections are special Site Elements that are created and attached to existing Site Elements that define 
a constant vertical and horizontal offset from the existing element(s).  It can be used to attach curb 
and gutter sections to the edge of pavement, retaining walls or benching sections. 
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Section Elements is another 
feature where the MS 
graphics are actually created 
by the Site Modeler in the 
active MS symbology. Section 
elements cannot be directly 
edited, they are locked and 
connected to the elements on 
which they are placed.  As the 
Site Elements containing the 
section are modified, moved, 
deleted, or elevations 
reassigned, the Section 
Elements are automatically 
updated accordingly. 

 

Provisions for assigning sections to multiple Site Elements at once, even disconnected Site Elements, 
are available.  This capability is provided by gathering all the Site Elements selected for section 
placement and assigning the Direction or which side to place the section element.  The Site Modeler 
may not be able to logically determine a direction given very complex sets of Site Elements.  Suitable 
messages are provided in this case and a smaller selection set of Site Elements should be used. 

Creating Sections 
The following is the procedure for creating Section Elements. 

 Select the Reference Elements to place the section along. It is recommended that the Power 
Selector be used in Single element select mode. If the elements are chosen in an order which 
would easily accommodate chaining the elements together the resulting sections will be 
simplified. 

 Determine if a cell or table of horizontal and vertical offset is desired and fill tables. 
 Set the Direction – this will indicate the side of all the elements for which to place the Section 

Elements. 
 The Site Modeler attempts to chain all the elements together and then determine the side 

based on a single data point.  If the element selection does not easily facilitate this process, it 
may be necessary to hit any key and reselect a smaller set of elements. 

 Once the site modeler has chained the elements together, a dynamic display will indicate 
which direction would correspond to positive offsets. 

 Set the Feature type and press Apply. 
 The Section Elements are created and added to all the Objects that contain the Site Elements 

for which they were placed. 
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Manipulating Sections 
The Manipulate Section has three tools, as detailed in the table below. 

Reverse Section  

 

This button flips all sections currently selected to the other side of the Site 
Elements that they are attached. 

 

 

Remove Section  

 

 

 

This button removes the sections from the selected Site Elements. Since 
Section Elements are locked, this is the only way to remove them from 
graphics. 

Query Section  

 

This button queries a Site Element and populates the offset table with the 
values from the Site Element. 

 

Display Tab Options 
When the Display Tab is selected, the dialog depicted below is displayed. 

 

Element symbology is supported in this dialog for the following elements: 

 All Elements 
 Active Model Elements 
 Active Object Elements 
 Construction Elements 
 Activate the desired elements option.  Options are also supported for: 
 Selected Elements Only 
 Temporary Elements Only 

Both of these toggles may be active simultaneously.  The Reset Display button redisplays the 
Elements within the selected group in the desired symbology. 
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Change Site Element Feature &  Associations 
These two element tools can be used to change the feature type of a previously defined site element 
or group of site elements as well a turn on or off the site element associations. 

 

 

 

 

The dialogs below will appear when their respective tool is selected. 

                      

Raise/Lower Site Elements 

This tool is utilized to change the elevation(s) of an existing element.   

 

Modify Site Elements 

A variety of tools are supported to modify existing site elements.   

The tools (from left to right) are: 

 Site Element Extend Line 
 Site Element Extend Arc 
 Site Element Extend to Intersect 
 Site Elements Extend Both to Intersect 
 Site Elements Fillet 
 Site Elements Chamfer 

 

 

All tools function identically to their generic MicroStation counterparts, except the Extend to Intersect 
and Extend Both To Intersect.  These two commands have elevation options to be considered.  The 
Modify Element Tools are only available within a 2D MicroStation Design File. 
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Delete Site Elements 

This tool is used to delete a Site element that is associated with a 
MicroStation Element. 

 

 

 

3D Element 

Elements placed at the correct X, Y, Z coordinates within a 
MicroStation 3D design file can be utilized within this dialog.  When 
invoked, the dialog depicted below is displayed. 

 

 

Site Element Information 

The Information Tool can be used to display 
coordinate information, Feature type, stroking 
information and Member Objects and Site 
Element Association information.  Most 
importantly however, the Information Tools can 
be used to quickly change element information 
when needed.  The dialog below shows one 
option of the Information Tool.  Each vertices 
of the Site element can be modified to achieve 
the desired result. 

  

Composite Section Tool 
The Composite Section Tool is used to create multiple Site Elements which will be grouped into a Site 
Object.  This tool can be useful for creating Roadways, Channels, Levees, etc.  
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Active Site Object Control Toolbar 
Upon opening an existing GEOPAK Site Project or creation of a new project, the Active Site Object 
Toolbar is displayed as shown below. 

 

The tool bar is resizable and dockable and remains open throughout the entire Site Modeler session. 

Display View When the toggle to the left of Display View is activated, the Active Model 
and/or Active Object are displayed, based on their respective visualization 
settings. 

Model The active model is displayed.  Selection of any other model from the list 
changes the active model.  When the model is selected, all Objects which 
belong to the model are listed in the Object listing to the right.  When <All 
Objects> is selected, all objects in the project are listed.  When <Orphan 
Objects> is selected, all objects which currently do not belong to a model are 
listed. 

Object The Object list changes dynamically based on the Model selection. 

ID?     
Pressing the ID button and then identifying any Site Modeler object highlights 
the selected element and invokes the Select Object dialog depicted below. 

 

Center Window On 
Object 

After setting the Object list to the desired Object, then pressing the Window 
Center on Object button, the Site Modeler window centers (and fits the object) 
to the Display View. 
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Main Toolbar 

The Tools menu selections provide access to all Tool Boxes.  The Main 
Tools tool frame is depicted below and accesses the other tool boxes. 

Each icon in the tool frame (except single tools) is a tool box that one can 
"tear off" to become a "tool box."  The individual tool boxes (except those 
which have single tools) can be docked and resized.  There are seven tool 
boxes, with the following titles (order down first column, then down second 
column): 

 Project tools 
 Object tools 
 Composite Section 
 Exit 
 Elements tools 
 Model tools 
 Analysis tools 

If the function of an icon is not apparent to the user, position the cursor on 
the icon.  A detailed description is displayed in the status bar and a tool tip 
(flyover) appears. 
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Lab 17:  Pond Design 

Creating a Site Modeler Project 
Step 1. Execute C:\data\geo\VDOT\drain1\LAB17_V8.EXE. 

Step 2. Open the MicroStation File C:\Data\Geo\VDOT\Drain1\H17682.dgn. 

Step 3. Access the Project Wizard from the Applications 
> GEOPAK Site > Site Modeler > Site Modeling 
pull down menu or from the Site Modeler Icon on 
the GEOPAK Site Tool Frame shown. 

 

   

Step 4. Select the Create New Project button and 
then press the Next> button to continue. 

 

   

Step 5. The Project Wizard dialog will appear filled 
out as shown. 

Create a New Project file:  H17682.gsf  

Press the Next> button to continue.  
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Defining the Project Preferences 
 

Step 1. Continuing with the Project Wizard dialog as shown. 

 

 Fill out the Project Wizard dialog as shown below.  When complete, click the Set Project 
Preference button. 

 

Create a New Model: Toggle On 

Model Name: H17682-pond 

 

Step 2. The Site Preferences dialog will appear.  The Tolerances Option Item is highlighted.  
Set each field as shown. 

 

Linear Stroking 25.000 

Curve Stroking: 0.010 

Maximum Triangle Length: 100.00 

Elevation Decimal: 2 
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Step 3. Highlight the Visualization item. 

 

 

 Toggle on the View Active Object, View Active Model, and Smooth Contours options. 

 

Step 4. Click the Model Visualization button in the lower right corner of the Site Preferences 
dialog.  The Edit Object Visualization dialog will appear. 
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Step 5. Fill out the dialog as shown.   

 

 To change the symbology of each item, just double click on the sample graphic.  The 
GEOPAK Set Feature dialog will appear.  Make the appropriate changes and then Click 
the OK button.  When finished with all items click the Apply button at the top of the 
dialog. 

 Below are two samples of the GEOPAK Set Feature dialog. 

           

 

Step 6. Highlight the Objects item from the GEOPAK Site Preferences dialog.  The dialog 
changes as depicted below. 
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 Highlight the Existing Ground Object Type and set the Visualization preferences as 
shown.   

 

 See the GEOPAK Set feature sample dialogs. 

Major Contour: Minor Contour: 

  

Elev Interval: 10.000 Elev Interval: 2.000 
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Note: To change the symbology of each item, just double click on the sample graphic. Once the 
appropriate changes have been made click the Modify Icon to save your changes. The 
Modify Icon is located next to the Object Type/Naming Prefix List. 

Step 7. Highlight the Updating Option Item as shown below. 

 

  

Step 8. Highlight the Save Option Item as 
shown. 

Toggle On the Automatic Save 
option and set the interval to 30 
Minutes.   

Click the OK button to save the 
preferences and go back to the 
Project Wizard dialog.  

 

Completing Project Set-up 
Step 1. Once back at the Project Wizard dialog, 

press the Next> button. 

 

 

   

Step 2. The New Model Name and Project Name 
should appear as shown. 

Toggle On the Open Object Import 
Wizard option. 

Click the OK button when finished.  
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Step 3. We will now begin with the Import Data 
Wizard.   

Select the TIN File as the Import Data 
Type option as shown in the dialog.  

Fill out the File Name field as shown or 
use the Browse button to select the Tin 
file: 

 
C:\Data\Geo\VDOT\Drain1\Survey.tin. 

Press Next> when done. 

 

   

Step 4. Fill out the Import Data Wizard dialog 
below as shown.  By selecting the Ground 
Object Type, the Enter New Object 
Name field is automatically filled in.   

Click the Next> button when finished. 
 

   

Step 5. The final step in the Import Data Wizard 
is to set the object Exist Ground 1 as the 
Base Object for the Model H17682-
Pond. 

Click the OK button to initiate the drawing 
of the Active Model, H17682-Pond, and 
the Active Object, Exist Ground 1, into 
View 1 of MicroStation. 

 

 

Creating a Pond Object 
Step 1. Access Modeler > Tools > Pond Design in the MicroStation menu. 
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Step 2. Click Next>. 

 

  

Step 3. Click New to create a new Pond object.  
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Step 4. Define the design constraints as shown below.  

 

Design: Bottom-Up 

To Water Elevation: 2010.00 

Use a Freeboard: 1.00 

 

 

 

Step 5. Click Next> and setup the pond bottom at a Constant Elevation of 2004.0. 
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Step 6. Select the MicroStation element that represents the pond bottom, and click Next>. 

 

Step 7. Setup the Pond Side Slopes, Berm and Side Slopes as shown in the dialog below.  

 

 

Step 8. Click Finish to build the pond. 

Analyzing the Pond Volume 
Step 1. Access the GEOPAK Volume Calculations Tool from the Modeler > Analysis > 

Volumes pull down menu or from the icon shown. 

 

 

 



Analyzing the Pond Volume 

 

VDOT GEOPAK Drainage Training Manual 
1/27/2006 221 

Step 2. Fill out the dialog as shown. 

 

 

Calculation Method: Prismoidal 

Calculation: Plane to Object 

From Plane: 2009.000 

To Object: Pond 1 

Use Range: Toggle On 

 

Step 3. Click the Range button. 
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 The Volume Elevation Range dialog is depicted below. 

Set the Auto Range Options portion 
of the dialog as shown. 

Range:    Auto Range Increment 

Range Increment:                  1.000 

Minimum Elevation:         2004.000 

Maximum Elevation:        2009.000 

Click the Set Range button to fill out 
the bottom portion of the dialog. 

Close the dialog when you are 
finished. 

 

Step 4. Click the Process button on the GEOPAK Volumes Calculation dialog.  The following 
report is generated. Close the dialog boxes when done. 

 

 

 

Computing Time of Concentration 
During this section we will compute the time of concentration for a drainage area using the Seely 
formula under the Rational  Method.  

Step 1. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 2. Access the drainage project h17682.gdf by selecting Drainage > Project > Open from 
the GEOPAK Drainage pull down menu. 

Step 3. Select Add from the Drainage > Components > Area pull down menu in GEOPAK 
Drainage. 
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Step 4. Fill out the Drainage Area Definition dialog as shown. 

  

Drainage Area ID: Area1 

Description: Drainage Area for Routing 

Hydrologic Method: Rational 

Drainage Area: 1.00 

Base C Value: 0.5 

 Click the Apply button when finished. 
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Step 5. Click the Compute TC button located in the middle of the Drainage Area Definition dialog. 

 The Drainage Area Definition dialog will temporarily minimize while we work on the Time 
of Concentration. 

 We will manually enter the hydraulic characteristics of sheet flow and concentrated flow. 

 Fill out the dialog as shown. 

 

Sheet Flow: Toggle On 

Method: Seelye 

Length: 235.00 

Slope: 1.00 

Concentrated Flow: Toggle On 

Method: Kirpich 

Length: 300.00 

Height above outlet: 7.00 

 Click the Compute button and then click Apply to return to the Drainage Area Definition 
dialog. 
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Step 6. Highlight Compute in the Drainage Area Definition dialog and press the Compute 
Discharge button. 

 

Step 7. Click Apply and close the Drainage Area Definition dialog. 

GEOPAK Routing (Create the Runoff Hydrograph) 
During this section we will create a runoff hydrograph according using the Rational Method for the 
previously created drainage area. 

Step 1. Select Add from the Drainage > Components > Routing. Create a new routing 
configuration. 

 

Step 2. Select the Runoff icon (1st icon located in the top middle of the dialog) and highlight the 
Definition item in the Options list. 

 Select ‘Area1’ as the Area ID. 

Step 3. Keyin the storm Duration TC Factor = 1. 

Step 4. Click the Select button and select the Ditch cell. 

 

 Click OK to continue. 
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Step 5. Click the DP button and data point in MicroStation view window 1 in the area where the 
pond is located. 

 

 This will place a cell that graphically represents the routing configuration in MicroStation.   

Step 6. Highlight the Discharge item in the Options list. 

 

 Select the Use Computed Discharge radio button. 

Step 7. Highlight the Computations list item in the Options list. 
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 Click the Compute button. 

Step 8. Click Apply to save this configuration.  Review the results. 

GEOPAK Routing (Create a Reservoir Routing) 
In this section we will create a reservoir (pond) routing configuration which we will use to route our 
runoff hydrograph for Area 1. 

 

Step 1. Click the Add Routing button on the Edit Routing Configuration dialog. 

 Fill out the dialog as shown. 

 

 Click OK to continue. 

Step 2. Select the Reservoir icon and highlight the Definition list item from the Options list. 
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 Select Route1 for the Inflow Runoff ID and set the Starting Water Surface Elevation at 
2005.00. 

Step 3. Click DP and data point for the location of the orifice. 
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Step 4. Highlight the Stage Storage list item from the Options list. 

 

 Select Use Computed Storage radio button. 

 Set the Type option to Site Object and select Pond 1. 

Note: We were able to select a Site Object because in Geopak Drainage under, Drainage > Project 
> Preferences > Project Components we have previously included the name of the Site Modeler 
project: H17682.gsf. 

Step 5. Highlight the Stage Discharge list item from the Options list. 

 Set the type, size, coef., and elevation options as shown. 

 

Type: Orifice 

Size: 1.00 

Coef: 0.60 

Elevation: 2005.00 
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Step 6. Highlight the Computations list item from the Options list. 

 Click the Apply button. 

 Create an output file called StageStorage.txt 

 Click the Compute button. 

 

Step 7. Click the View button to review the Routing calculations. 
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 18 Importing Stream Geometric Data to HEC-RAS 
 

Objective: Provide the user with a general understanding of GEOPAK Cross Section Reports 
and their capability to generate geometric information for the HecRas program. 

Goal: Create stream cross sections and import them to the HecRas software. 

Prerequisites: Completion of an existing ground Digital Terrain Model. 

Additional 
References: 

GEOPAK Cross Sections Online Help 

 

Introduction 
The creation of a stream or river cross sections requires the usage of different tools within the Geopak 
software. 

The Geopak Cross Section Report tool enables us to extract information from the stream cross 
sections in a format accepted by the HecRas software. 

The designer should be able to place a basic alignment along the stream and generate existing 
ground cross sections. These cross sections will be used in the Geopak Cross Section Report to 
format the data accordingly to HecRas Gis format. 

 

XS Reports 
Objectives Create various cross section reports:  

 - for plan use (design elements and quantities) 
 - as input for other programs and/or applications of GEOPAK 
 - for construction layouts. 
Create and draw construction limits in the plan view file. 

Project Manager Reports and XS Quantities 
Limits of Construction 

Tools 

                      
 

Menu Bar Application GEOPAK Road > Cross Sections > Cross Section Reports 
GEOPAK Road > Cross Sections > Construction Limits 
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The GEOPAK Cross Section Report Utility can extract up to 
sixteen different reports from original and design cross-
sections.  For each report generated, the user must set the 
parameters of the existing and/or design cross sections.  
GEOPAK also provides an option to make custom headers for 
each of the reports via the User pull down menu. 

Custom Header 

 

From the XS Report dialog box, select User > Preferences.  A 
Report Header dialog box will appear with all options ghosted 
out.  To activate the individual fields simply toggle on the box 
next to the desired field.  Once you have completed the dialog 
box, the information will be saved as an .hdr file.  This allows 
for the creation of a separate header for each type of report.  
The tolerance field determines the maximum gap allowed 
between cross section elements.   

 

 

HEC – 2 
This process reads cross section elements and formats the information in an ASCII text file 
suitable for use in the HEC-2 hydraulic program. 

HEC RAS 
This process reads cross section elements and formats the information in an ASCII text file 
suitable for use in the HEC RAS hydraulic program. 



Creating a Stream Baseline 

 

VDOT GEOPAK Drainage Training Manual 
1/27/2006 233 

Lab 18:  Importing Stream Geometric Data to 
HecRas 

Creating a Stream Baseline 
Step 1. Execute C:\data\geo\VDOT\drain1\LAB18_V8.EXE. 

Step 2. Open the MicroStation File C:\Data\Geo\VDOT\Drain1\Survey_river.dgn. 

Step 3 Access Store Graphics from the Applications > GEOPAK Road > Geometry > Store 
Graphics pull down menu or from the Store Graphics icon on the GEOPAK Road Tool 
Frame shown 

 

Step 4. Enter the information as shown in the dialog below. 

 

Step 5. Press ID Element and select each of the lines that represent the alignment of the river 
stream until the Store button activates. 

Step 6. Press the Store button. 

Step 7. Press OK at the Store Graphics notification dialog. The alignment will be saved into the 
geometric database and a copy of the generated commands will be written into the ASCII 
file j101ovd.inp. 
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Step 8. Close the Store Graphics dialog and delete the MicroStation lines that represented the 
stream alignment. 

Drawing Alignments 
Step 1. Access the Design and Computation Manager from the Applications > GEOPAK Road > 

Design & Computation Manager pull down menu. A secondary dialog box will appear to 
be used in conjunction with the Design and Computation Manager dialog box. 

 

Step 2. Select the item shown in the dialog box below.  
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Step 3. Next, select the Draw Plan and Profile 
button from the secondary dialog box: 

                

Step 4. Enter the job number: 101 at the dialog 
and press OK. 

                

Step 5. Select the Chains operation.  Each of 
the chains will be displayed in the list 
box as shown.  Notice that the options 
that are to be drawn with the chain are 
already activated. Set the Label Scale to 
25. 

Step 6. To draw the chain, click on the name of 
the chain: River in the list box. Only 
click once!! Each time you ID a chain it 
will be plotted into the design file. 

 

 

 

Step 7. Change the Operation to Stationing 
and modify the dialog settings as shown 
in the image to the right.  

 Annotate the River alignment by clicking 
the chain name in the list box. 

Step 8. Exit the Plan and Profile Draw dialog 
box and close the D&C Manager 
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Existing Ground Cross Sections: Drawing Pattern Lines 
Step 1. Access Draw Patterns from the Applications > GEOPAK Road > Cross Sections > 

Draw Patterns by Station Range pull down menu.  

Step 2. Populate the dialog box as depicted below.  

 

 

 

Step 3. Click Apply to initiate the plotting of the patterns into the design file. 

Step 4. Using the same MicroStation symbology place two more parallel lines at each side of the 
bridge that crosses the stream. 

Step 5. Delete the pattern line at station 5+00. For Hec-Ras purposes, a cross section there is not 
needed. 

Step 6. Close the Draw Pattern Lines dialog box. 

 

Existing Ground Cross Sections: Generating the Stream Cross 
Sections. 

Step 1. Open the MicroStation file c:\data\geo\VDOT\drain1\xsriver.dgn  

Step 2. Access Draw Cross Sections from Surfaces from the Applications > GEOPAK Road 
> Cross Sections pull down menu. 
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Step 3. Generate the existing ground cross-sections by populating the dialog box as shown on 
the following dialogs. 

Note:  The Display Settings for the existing ground line are set to level 1, color 1, style 2, weight 5.   

  

 

Step 4. Press Draw to generate the cross sections. 

Step 5. Exit the dialog box. 

Review Cross Sections 
Step 1. Select the Cross Section Navigator tool from the Applications > GEOPAK Road > 

Cross Sections > Navigator pull down menu. 

 

Step 2. Use the Cross Section Navigator to browse and check your existing cross sections.  

Step 3.  Close the XS Navigator dialog box when done.  
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Exporting to Hec-Ras 
Step 1. Access the HEC-RAS report from the Applications > GEOPAK Road > Cross Sections 

> Reports  pull down menu. 

 

Step 2. Populate the dialog box as shown below. 

  

 

Step 3.  Press Apply to generate the Hec-Ras cross section geometry file. 

Step 4. Exit MicroStation. 
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Importing Cross Section Data into Hec-Ras 
Step 1. Activate Hec-Ras from c:\data\geo\vdot\drain1\hecras\ras.exe.  

 

Step 2. Access the included Hec-Ras project: xsriver.prj located in the c:\data\geo\vdot\drain1 
directory. 

 

 

Step 3. Access the Geometric data module of Hec-Ras by selecting Edit > Geometric Data from 
the Hec-Ras pull down menu. 

Step 4. Select File > Import Geometry Data > GIS Format from the Geometric Data dialog. 
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Step 5. Select the file we created from the Geopak cross sections:  

 c:\data\geo\vdot\drain1\xsriver.geo  

 

 

Step 6. Review the alignment and layout of the imported cross section data. 
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Step 7. Review the generated cross sections by pressing the Cross Section button in the 
Geometric Data dialog box. 

  

Step 8. Review the cross sections graphically by selecting Plot > Plot Cross Sections in the 
Cross Section Data dialog box. 

  

 

Step 9. Save your project data and exit Hec-Ras  
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 19 Ditch Design 
 

Objective: Provide the user with a general understanding of how to design and analyze ditches in 
GEOPAK Drainage. 

Goal: Create a ditch system using Geopak Drainage. 

 

Introduction 
The creation of a ditch system in Geopak Drainage is similar to the construction of a storm sewer 
system, with the difference that instead of specifying a pipe for the link connection, the user needs to 
select the ditch option.  

Geopak Drainage allows the user to specify a fixed ditch geometry or a ditch extracted from a 
reference surface.  

Link/Ditch Configuration 

 

Link options and types are shown in the Option list box on the left side of the dialog.  The 
corresponding fields and items appear on the right.  The four options are reviewed below. 

Definition Defines the Link’s path, connectivity, shape, material, roughness coefficient, 
size, and design options.  

Conditions Defines or reviews the elevation condition for the Link including minimum 
depth, soffit, invert, and slope data. It also includes the profiling options for 
holding certain values constant.  

Constraints Defines the Link constraints including the minimum and maximum rise (size), 
slope and velocity used in Link design. 

Computation Reviews the Link hydraulic computations 
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Lab 19:  Ditch Design 

Introduction 
Step 1. Execute C:\data\geo\VDOT\drain1\LAB19_V8.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\drain1\h17682.dgn.   

Step 3. Select Drainage from the Applications > GEOPAK Drainage > Drainage pull down 
menu. 

Step 4. Access the drainage project h17682.gdf by selecting Project > Open from the Geopak 
Drainage pull down menu.  

Design Ditch Node: ditch1 
Step 1. Select from the Drainage Menu:  Component > Node > Add.  

 

Step 2. Highlight Properties in the Options group box on the Node Configuration dialog. Select 
the Node to be used from the Drainage Library and assign its properties as depicted 
below: 
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Node ID Ditch1 

Node Type Other 

Library Item Ditch_Node 

 

Step 3. Highlight Location to describe the inlet’s location in the design plane: 

 

Reference Chain Select Reference chain: MAINLINE 

Reference PGL Select Reference PGL: MAINLINE 

Align Tangent to Ref. Chain 

Station 209+78.46 

Offset -171.50 

 Press Enter to automatically place the node at the specified location. 

 

Step 4. Highlight Elevations to assign the node an elevation and vertical alignment of the ditch 
node. 
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Elevation Source Reference TIN 

Node Elevation Option Same as Source 

Vertical Alignment Preference Match Invert 

Minimum Depth 0 feet 

Maximum Depth 10.00 feet 

 

Step 5. Highlight Junction Losses to use Defined Equations (defaults to Preference > Junction 
Loss Settings). 

 

 

Step 6. Highlight Discharge Options to specify the discharge getting into the ditch. The actual 
flow was previously calculated. Therefore, keyin 10 cfs at the Supplied Discharge field 
and activate the toggle. 

 

Step 7. Click Apply to add this node to the project.  

Step 8. Close the Node Configuration dialog.  
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Design Ditch Node: ditch2 
Step 1. Select from the Drainage Menu:  Component > Node > Add.  

 

Step 2. Highlight Properties in the Options group box on the Node Configuration dialog. Select 
the Node to be used from the Drainage Library and assign its properties as depicted 
below: 

 

 

Node ID Ditch2 

Node Type Other 

Library Item Ditch_Node 
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Step 3. Highlight Location to describe the inlet’s location in the design plane: 

 

Reference Chain Select Reference chain: MAINLINE 

Reference PGL Select Reference PGL: MAINLINE 

Align Tangent to Ref. Chain 

Station 208+67.91 

Offset -151.86 

  

 Press Enter to automatically place the node at the specified location. 

Step 4. Highlight Elevations to assign the node an elevation and vertical alignment of the ditch 
node. 

 

 

Elevation Source Reference TIN 

Node Elevation Option Same as Source 

Vertical Alignment Preference Match Invert 

Minimum Depth 0 feet 

Maximum Depth 10.00 feet 
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Step 5. Highlight Junction Losses to use Defined Equations (defaults to Preference > Junction 
Loss Settings). 

 

 

Step 6. Highlight Discharge Options to specify the discharge getting into the ditch. This node will 
not receive any direct discharge other than the one coming from the previous node. 
Therefore keyin 0 cfs at the Supplied Discharge field and activate the toggle. 

 

Step 7. Click Apply to add this node to the project. 

Step 8. Close the Node Configuration dialog.  
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Design Ditch Outlet Node: ditch-outlet 
Step 1. Select from the Drainage Menu:  Component > Node > Add.  

 

Step 2. Highlight Properties in the Options group box on the Node Configuration dialog. Select 
the Node to be used from the Drainage Library and assign its properties as depicted 
below: 

 

 

Node ID Ditch_outlet 

Node Type Outlet 

Library Item Ditch_Outlet 

Fix Tailwater Critical Depth 
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Step 3. Highlight Location to describe the inlet’s location in the design plane: 

 

Reference Chain Select Reference chain: MAINLINE 

Reference PGL Select Reference PGL: MAINLINE 

Align Tangent to Ref. Chain 

Station 207+72.29 

Offset -113.57 

 Press Enter to automatically place the node at the specified location. 

 

Step 4. Highlight Elevations to assign the node an elevation and vertical alignment of the ditch 
outlet node. 

 

Elevation Source Reference TIN 

Node Elevation Option Same as Reference 

Vertical Alignment Preference Match Invert 

Minimum Depth 0 feet 

Maximum Depth 10.00 feet 
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Step 5. Click Apply to add this node to the project. 

Step 6. Close the Node Configuration dialog.  

 

Design Ditch Links 
Step 1. Select from the Drainage Menu : Component > Link > Add.  

 

Step 2. Highlight Definition to Set the ditch spatial characteristics including From and To Nodes 
ID’s, and geometry.   

 Graphically select the Nodes by clicking the ID button for each and identifying the Nodes. 
Dtich1-2 traverses From Node ditch1 to Node ditch2 

 

Type Ditch 

Geometry Fixed Geometry 

Manning’s n 0.012 

Ditch Width 3.00 

Design Width Toggle OFF 

Ditch Depth 3.00 

Design Depth Toggle OFF 

Side Slope Ratio 3:1 Left and 3:1 Right 
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Step 3. Highlight Conditions. The elevations shown are based on the From-Node and To-Node 
elevation minus the min/max depth, as specified in the Node Definition Dialog Box for 
Nodes ditch1 and ditch2 respectively.   

 In this case, no entries are necessary; GEOPAK Drainage will design all the profiles for 
this project. 

 

Step 4. Highlight Constraints. Establish the min/max design criteria for Links as follows: 

 

 

Rise min/max 0.1 / 6.0 (feet) 

% Slope min/max 0.10 / 10.00 (%) 

Velocity min/max 1.00 / 10.00 (fps) 
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Step 5. Highlight Computations to display the computed hydraulic properties of the ditch.   

 

Note: Ditch hydraulics are not available for review until a Network has been established and designed 
or analyzed successfully. Check back here for computations after the Network has been added and 
designed or analyzed. 

Step 6. Press Apply to incorporate the link to the project. 

Step 7. Add the remainder of the ditch system from Node ditch2 to Node ditch-outlet using the 
Drainage Menu Component > Link > Add.  

Step 8. After adding the last portion of the ditch, close the Link configuration dialog. 

 

Ditch Network Design 
Step 1. Select Network > Add from the Drainage menu. 
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Step 2. In the Network Configuration dialog, enter the following information: 

 

 

Network ID: DITCH 

Description: (Optional) 

Outlet Node Click the ID button and select the DITCH-
OUTLET node. 

 

Step 3. Click the Build Network button.  This feature verifies the nodal topology and link 
connectivity. The Highlight Network feature highlights all components (ditch nodes and 
ditch links) connected to the active Network. 

 

Step 4. Click the Apply button.  Network “DITCH” has been added to the project. 

Step 5. Click the Design button.  This command initiates the hydraulic design of the components 
contained in the Network.  

Step 6. Then GEOPAK will design the network and issue the pertinent Warning messages, if 
necessary. 

 

Step 7. Set the Active Network to Ditch so we can review some of the provided reports. 
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Step 8. We can now review some of the GEOPAK provided reports. Drainage > Reports > 
Storm  Drain Links. 

 

Step 9. Exit MicroStation.  

 


	Table of Contents
	Chapter 1: Digital Terrain Model
	 
	Introduction
	Accessing
	Load DTM Features
	Analysis Tools

	Lab 1:   Digital Terrain Modeling
	Accessing DTM Tools
	Load DTM Features
	Analysis Tools
	Height Tool
	Themes Tool
	Profile Tool
	Drainage Tools



	Chapter 2: Getting Started
	 
	Overview
	GEOPAK Drainage File (GDF)
	Main Menu Bar
	Project Menu Selections
	Component Menu Selections
	Network Menu Selections
	Reports Menu Selections
	Tools Menu Selections
	Project Workflow
	Drainage Components

	LAB 2: Getting Started
	File Information
	Invoke GEOPAK Drainage


	Chapter 3: Drainage Library
	 
	Drainage Library
	Rainfall Items
	Land Use Items
	Node Items
	Link Items
	Spread Section

	LAB 3:   Drainage Library
	Review Drainage Library
	Rainfall Tab:
	Land Use Tab:
	Nodes Tab:
	Links Tab:
	Spread Section:



	Chapter 4: Project References
	 
	Introduction
	Units
	Project Components
	Rainfall Parameters
	Land Use Options
	Frequency Options
	Intensity Option
	Junction Losses
	Inlet Options
	Node Options
	Link Options
	Design Symbology

	LAB 4: Project Preferences
	Project Preferences


	Chapter 5: Drainage Areas and Nodes
	 
	Introduction
	Delineating Subareas
	Introduction to Nodes

	LAB 5:  Drainage Design
	Introduction
	Design Inlet  3 – 1
	Design Drainage Area  3 – 1
	Design Inlet  3 – 2
	Create Drainage Area  3 – 2
	Create Drainage Area  3 – 3
	Create Drainage Area  3 – 4
	Design Inlet  3 – 5
	Create Drainage Area  3 – 5
	Create Drainage Area  3 – 6
	Create Drainage Area  3 – 7
	Design Node: Outlet


	Chapter 6: Conveyance System
	 
	Introduction

	Lab 6: Links
	Link Design


	Chapter 7: Networks
	 
	Introduction

	LAB 7:  Networks
	Network Design


	Chapter 8: Profiles
	 
	Introduction

	LAB 8:  Profiles
	Profile Design


	Chapter 9: Navigator/Global Editor
	 
	Introduction
	Using the Navigator
	Global Editor

	LAB 9:  Navigator/Global Editor
	Navigating/Global Editing


	Chapter 10: Querying
	 
	Querying From the Navigator

	LAB 10: Query
	Query Mode


	Chapter 11: System Modification and Analysis
	 
	Global Editor

	LAB 11: System Modification and Analysis
	Adding Existing Structures
	System Design Update
	Dynamically Editing Profiles
	System Analysis


	Chapter 12: Reports
	 
	Introduction

	LAB 12: Reports
	Create Customized Reports
	Create VDOT Storm Calculation Sheet


	Chapter 13: Plan View Labeling
	LAB 13: Plan View Labeling
	Plan View Labeling


	Chapter 14: Automated Quantities
	 
	Introduction
	Operational Modes: Compute

	LAB 14: Automated Quantities
	Updating Cadd Symbology
	Automated Quantities


	Chapter 15: Culverts
	 
	Introduction
	Invoking the Culvert Tool

	LAB 15: Culverts
	Culvert Placement in Plan View
	Culvert Adjustment in Profile View


	Chapter 16: Special Ditch Profiles
	 
	Introduction
	Cross Section Navigator
	XS Reports
	Custom Header
	Blue and Red Top
	Clearing
	Closure
	DTM Input
	DTM Proposed 3D
	HEC – 2
	HEC RAS
	Multi-Line
	Profile Grade
	Radial Staking
	RT 40
	Seeding
	Slope Stake
	Staking Detail
	WSPRO
	XS List

	Vertical Alignment Generator
	Accessing
	Using the Vertical Alignment Generator
	Creating A New Profile
	Precision Placement Options


	LAB 16: Special Ditch Profiles
	Reviewing the Roadway Cross Sections
	Extracting a Ditch Profile from Cross Sections
	Review the Ditch Profile
	Draw the Ditch Profile
	Create a Special Ditch Profile


	Chapter 17: Pond Design with GEOPAK Site Modeler
	 
	Introduction
	Site Modeler Project Components
	GEOPAK Site Elements
	GEOPAK Site Objects
	GEOPAK Site Models

	Site Modeler Main Menu
	Project Menu Options
	Model Menu
	Objects Menu
	Elements Menu
	Active Site Object Control Toolbar
	Main Toolbar


	Lab 17:  Pond Design
	Creating a Site Modeler Project
	Defining the Project Preferences
	Completing Project Set-up
	Creating a Pond Object
	Analyzing the Pond Volume
	Computing Time of Concentration
	GEOPAK Routing (Create the Runoff Hydrograph)
	GEOPAK Routing (Create a Reservoir Routing)


	Chapter 18: Importing Stream Geometric Data to HEC-RAS
	 
	Introduction
	XS Reports
	Custom Header
	HEC – 2
	HEC RAS


	Lab 18:  Importing Stream Geometric Data to HecRas
	Creating a Stream Baseline
	Drawing Alignments
	Existing Ground Cross Sections: Drawing Pattern Lines
	Existing Ground Cross Sections: Generating the Stream Cross Sections.
	Review Cross Sections
	Exporting to Hec-Ras
	Importing Cross Section Data into Hec-Ras


	Chapter 19: Ditch Design
	 
	Introduction
	Link/Ditch Configuration

	Lab 19:  Ditch Design
	Introduction
	Design Ditch Node: ditch1
	Design Ditch Node: ditch2
	Design Ditch Outlet Node: ditch-outlet
	Design Ditch Links
	Ditch Network Design



