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1 
OBJECTIVES 

This chapter will cover several different issues dealing mainly with Plat Creation. Different topics to 
be covered will include: 

• 

• 

• 

• 

• 

Parcel Editor 

Legal Description Editor 

R/W Staking Reports 

Survey Plan Preparation Tools 

ASCII Import for Plat Creation 

INTRODUCTION 
GEOPAK provides several different methods for entering parcel data. Each of these has its own 
purpose and proves beneficial in different circumstances. Depending on the type of initial data you 
start with will most likely dictate the approach to storing that data in coordinate geometry. 

PARCELS 
The parcel interface and additional attributes have been greatly enhanced with version 8.8. 
Enhancements include: 

• Additional Occupied Type 

• User Defined Attributes 

• Interface Modifications 

 



Parcels 

 
OCCUPIED TYPE 

 

The new occupied type can be added to a parcel to represent a portion of a parcel that is set aside for 
something such as an inhabited area. This would then be reflected in area totals where a right-of-way 
taking has occurred and it overlaps a portion of a parcel designated as occupied. The resulting areas 
would be indicated as shown below: 

 

Total occupied area:          59542.65531  m² =     5.95427 ha =    14.71325 a 

Occupied in taken area:       58519.61057  m² =     5.85196 ha =    14.46045 a 

Net taken area:               23754.67123  m² =     2.37547 ha =     5.86988 a 

 

USER DEFINED ATTRIBUTES 
Functionality had been added to the parcel element type to attach user defined attributes. These can 
include any information that the user wishes to associate with a parcel such as address, deed books, etc.  

The command line syntax for adding attributes to parcels is shown below. 

Maximum attribute name length = 24 and string size = 256 

STORE ATTRIBUTE elementType elementName  PARCEL parcelName NAME attributeName TYPE 
NUMERIC/STRING VALUE attributeValue 

DELETE ATTRIBUTE elementType elementName  PARCEL parcelName NAME attributeName 
TYPE NUMERIC/STRING 

CHANGE ATTRIBUTE elementType elementName  PARCEL parcelName NAME attributeName 
TYPE NUMERIC/STRING VALUE attributeValue 

Note The user attribute may be specified in graphic COGO and COGO’s Store Parcel dialog 
without using the command line.  
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Parcels 

 
The ability to setup a list of default preferences is also available. This is accomplished by accessing the 
Default Attributes Preferences option from the Element > Parcel pulldown. 

 

 

The dialog is used to compile a list of default preferences that will be displayed when storing any 
parcel. Values for each attribute can be changed as parcels are added to the database. 
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Parcels 

 
When the Store Parcel dialog is accessed the list of defaults will be displayed in the bottom. 

 

The attribute values are changed by simply clicking on any one of the three columns and providing an 
overriding value. 

Parcel attributes can also be changed directly from the COGO Navigator. This is done by highlighting 
the previously stored parcel and right clicking. This action will present a menu where one option will 
be Change Parcel Attribute as shown below. 

 

Parcels                     1-4            Jan-08 
Copyright © 2008 Bentley Systems Incorporated 



Graphical COGO 

 
Once selected, the attribute editing dialog will appear allowing for the adding, deleting or changing of 
the user attributes. 

 

 

GRAPHICAL COGO 
Graphical COGO also supports the addition of user defined attributes when storing graphically. This is 
accessed via the Store Parcel dialog as shown below. 

 

The functionality is identical to assigning the attributes in classic COGO. 
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The new Occupied type has also been added to the graphical Store Parcel dialog as shown below. 

 

New Flood functionality has also been incorporated into the store graphical parcel dialog. This will 
allow the use of MicroStation’s flooding capabilities for generating areas. 
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Lab Exercise: Entering Parcel Data 

 
LAB EXERCISE: ENTERING PARCEL DATA 

> PARCEL EDITOR 

1. Open the MicroStation file C:\60843\s60843.dgn 

2. Attach the saved view ISTAR 

3. Access GEOPAK Survey and open the existing project 60843. 

4. Use the user Mary to access the project. 

5. Click on the button to open Coordinate Geometry 

6. Select the Editor from the Element > Parcel > Editor pulldown. 

 

7. Begin by clicking the Starting NEZ button and entering the POB coordinates. 

Northing 301688.7532 

Easting 3876313.6897 

 

8. Begin with point number D150 

 

9. Close the Starting NEZ dialog. 

Lab Exercise: Entering Parcel Data                     1-7            Jan-08 
Copyright © 2008 Bentley Systems Incorporated 



Lab Exercise: Entering Parcel Data 

 
10. Next, enter the Name 4200 for the parcel and set the Parcel Type to Parent. 

 
 

11. Begin entering the metes and bounds outlined below. 

Note Pay attention to the direction of the bearings in regards to the North Arrow. 

 

12. When completed you should have all of the metes and bounds entered in the dialog as shown 
below. 
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Lab Exercise: Entering Parcel Data 

 

 

13. Click the Closure button and review the closure in COGO. 

Note The Closure should be approximately 1:5200  

14. Click the Store Parcel button to store the parcel. 

 

> STORING PARCEL ATTRIBUTES 

1. Select from the COGO Element pulldown Parcel > Default Attribute Preferences 

2. Add each attribute into the dialog as shown below. 

 

3. Click the Apply button. 

4. Now select Element > Parcel > Store. 
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Lab Exercise: Entering Parcel Data 

 
5. Include the points as shown below and store the parcel. 

 

6. From the Navigator print the parcel and review the information. 
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Lab Exercise: Graphical COGO 

 
LAB EXERCISE: GRAPHICAL COGO 

> STORING A RIGHT-OF-WAY TAKE 

1. Create a new MicroStation file called Parcel.dgn 

2. From the main Survey Menu bar select Plans Preparation > D&C Manager 

3. Navigate the database to the item Survey > Property Line 

 

4. Highlight the item and then click the Draw Plan & Profile button on the companion dialog. 

5. Make sure the Property Lines and Labels are toggled ON and that the Label Scale is set to 50. 

 

6. Now click on the Parcel 4200 in the list window to plot it. 
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Lab Exercise: Graphical COGO 

 
7. Select Applications > GEOPAK Road > Geometry > Graphical Coordinate Geometry. 

 

8. Set the active level to Default. 

9. Place a line representing a proposed right-of-way similar to the image below. 

 

10. Click the icon to store a Parcel. 
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Lab Exercise: Graphical COGO 

 
11. Enter the information as shown below. 

 

12. Data point inside the area making up the right-of-way take. 

13. Enter a second data point to accept the direction for storing the right-of-way take. (A right mouse 
button click will reverse the direction of the arrows). 

14. Next, move your cursor around the perimeter of the area making up the right-of-way take and pick 
a POB for beginning the area and enter a data point. 

15. Print the Parcel in Coordinate Geometry and review the data. 
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Legal Description Editor 

 
LEGAL DESCRIPTION EDITOR 

OBJECTIVES 
In this session we will review how to set up and access the legal description database and become 
proficient in using the Legal Description Editor. 

INTRODUCTION 
The Legal Description Editor is a powerful tool for the automated generation of legal descriptions.  Its 
power lies in the completely customizable terminology, styles, and preferences, all easily 
accomplished via dialogs. 

ACCESSING LEGAL DESCRIPTION EDITOR 
When the Legal Description Editor is accessed a dialog box prompting for the coordinate geometry 
database will appear like the one below. 

 

Once the desired job number is selected the main Editor dialog will appear. 

 

This dialog has several pull-downs allowing for customization of the Editor and default settings for 
how descriptions will be written. 
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Global Settings 

 
GLOBAL SETTINGS 

The first selection should be to set global settings. 

 

This will invoke the following dialog. 

 

Most of these settings are rather self explanatory however probably the most important one is the very 
first one allowing the designation of a COGO chain for referencing stations in the description. 
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Library Settings 

 
LIBRARY SETTINGS 

The Library Settings and the Library itself are without a doubt the most important part of the Legal 
Description Editor. The library provides a way for the user to establish default phrases and add 
customized phrases to a central location for recall at any time. 

 

The first selection is the Set Current Library/Style option. If this is the first time this option has been 
selected you will be prompted to provide a Style name. 

 

If this is not the first time this has been accessed and there is already a default or custom style name 
then you will be prompted with the following dialog where you can create a new style or select an 
existing one. 
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Library Settings 

 
This allows the user to select the library from which to work from or to store defaults to. There is an 
option here to set various styles such as right-of-way, condemnations, etc. This provides the user with 
the flexibility to store and recall various styles depending on the type of descriptions that will be 
written. 

Once a style has been created, that style can be edited from the dialog below by selecting the EDIT 
button. 

 

There are several tabs across the top of this dialog to allow the user to make settings according to 
phrase and defaults he wishes to use for this particular style. 

 

 

The first, as shown above, is for setting up default phrase for when a particular element is encountered. 
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Library Settings 

 
The next option, as shown below, allows the setting of precision variables. 

 

As you review the various tabs the next BEARING FORMAT tab, gives the user the flexibility to 
control how bearings are displayed when the description is automatically written. 

 

Notice how this dialog displays a sample of the desired bearing as the different options are set. 
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Library Settings 

 
The next dialog provides GENERAL SETTINGS for areas and directions. Probably the most 
important settings here is the column width, as this will control the line wrapping and how the 
description is formatted. 

 

The POINT GEOMETRY PHRASE option allows the user to set default phrases for when the 
description encounters particular elements such as a PC or a reverse curve, etc. 
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Library Settings 

 
These phrases are inserted into the description using the <PTGEOM> variable. The <PTGEOM> 
variable may be included as part of a line phrase. It is completely up to the user whether to use the 
<PTGEOM> as part of his line phrases. 

The PARCEL DEFAULT PHRASE option is very similar to the POINT GEOMETRY PHRASES in 
that the user can establish defaults for parcel descriptions from beginning to end. These phrases 
determine what line style will be used for the first line of a parcel, the body of a parcel, and the last line 
of the parcel. 
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Edit Library 

 
The same goes for the CHAIN DEFAULT PHRASES. 

 

EDIT LIBRARY 
Once the Library and Style have been selected the user can edit the selected library or add to it. This is 
where the standard phrases are created and stored. 
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Edit Library 

 
When selected the user must confirm/specify which library he wants to edit. 

 

The following dialog will appear once the desired library is selected and the EDIT button is selected. 

 

The setup of the library interface is very similar to the SMD file and the DDB file as discussed in 
previous chapters. 
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Edit Library 

 
It is a hierarchy database allowing the user to create categories and items. In the dialog below the 
category CLAUSES has been created with various standard clauses set up as items within it. 

 

The clauses will be available for selection when writing the legal description and automatically 
inserted into the description. 

Icons appear on the upper portion of the dialog for creating and editing items and categories. 
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Inserting Phrases 

 
Here you can see an item for DEED REFERENCE that has been set up. This particular item has a list 
created in it so that when inserted into a description the user will have the opportunity to select from a 
list of counties to insert. 

 

 

INSERTING PHRASES 
When the library has been set up and stored the user is ready for writing a legal description. 

This is done by selecting from the INSERT pull-down. 

 

The user uses the insert option to select the desired type of phrase to insert. Once selected, dialogs will 
appear allowing for the selection of that particular type of phrase from the items that were saved in the 
library. 
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Inserting Phrases 

 
For example a TEXT PHRASE could be selected and the following dialog will appear. 

 

The user then selected the type of TEXT PHRASE such as CLAUSES… and then the following dialog 
appears allowing for the selection of the desired clause. 

 

Once highlighted and the INSERT button selected, the phrase will be inserted into the description in 
its entirety. In this case part of the phrase is automatically placed in the description and then the user is 
prompted to provide some variable information. 
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Inserting Phrases 

 
 

Notice the top bar of the secondary dialog is asking for a Deed Book Number. When keyed-in, it will 
be placed in the description and the program will continue building the standard text until another 
variable is encountered. 

In this case once the book and page are provided, yet another variable is encountered but this time the 
user is prompted to select from a list of known options, (counties). 

 

Here you can see the final product of inserting this one phrase. 

 

Remember the above dialog is nothing more than an editor and you have the option of simply typing 
anything in it to supplement or modify what an insert has placed there. 

The last thing to remember is that you can use the FILE>SAVE option to save your completed legal 
description and then import into Microsoft WORD or any other editor of your choice. 
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Inserting Phrases 

 
To insert the entire metes and bounds of a stored parcel, you return to the insert option and select the 
CALLS BY PARCEL/CHAIN option. 

 

This will invoke the following dialog. 

 

The user must then select whether it is a chain or a parcel he wishes to describe and then select the 
INSERT button. This will continue the writing of the description. 
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Legal Description Editor 

 
LEGAL DESCRIPTION EDITOR 

> SETUP OF LEGAL DESCRIPTION EDITOR 

1. Access the Legal Description Editor from the following pulldown on the Survey Menu bar: 

 

2. When the Legal Description Editor is accessed a dialog prompting for the coordinate geometry 
database will appear like the one below. Select the job (job101.gpk) for this project. 

 

3. Once the desired job number is selected the main Editor dialog will appear. 
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Legal Description Editor 

 
 

Note  We will be attempting to create the following description. 
Federal Project Number APD-NHE-111(36) 

State Project Number 77041-2219-64 

Richmond County, Tract 4200 

Owner ISTAR Bowling Centers 

Grantee State of Virginia 

 

DESCRIPTION 

 

EXHIBIT "A" 

 

Beginning at a point of intersection between the south property line of ISTAR 

Bowling Centers and the proposed right of way line of George Washington Memorial 

Highway on highway project no. APD-NHE-111(36), 88.1 feet  right of  centerline 

station 59+20.1; thence South 17 deg. 20 min. 30 sec. East, 375.2 to a point thence 

South 15 deg. 03 min. 00 sec. East, 82.3 to a point thence North 72 deg. 39 min. 

30 sec. East, 199.7 to a point thence North 14 deg. 40 min. 30 sec. West, 82.4 to 

a point thence North 17 deg. 20 min. 30 sec. West, 129.7 to a point thence North 

72 deg. 39 min. 30 sec. East, 120.9 to a point thence North 17 deg. 20 min. 30 sec. 

West, 190.0 to a point thence South 82 deg. 28 min. 00 sec. West, 325.7 to the point 

of BEGINNING 
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Legal Description Editor 

 
4. Select from the Settings pulldown, Define Global Settings to make global settings for our 

description. 

 

5. Make sure that all of the settings match those as shown below. 

 

Note Be sure that the centerline chain is set to Mainline so that all the station references in our 
description will be automatically calculated from this alignment. 

6. Once the global settings have been made, select the OK button to close the dialog. 
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Legal Description Editor 

 
7. Select from the Library pulldown, Set Current Library/Style.  

 

8. Using the File button select the library as shown below. If the GEOPAK environment variable 
Gpk_ldedit_ldbfile was set properly, then the correct library should be selected by default. 

 

9. Once the library is set and the current style selected, choose the Edit button to access the dialog. 
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Legal Description Editor 

 
10. Make the settings as shown in the dialog below. 

 

Note  This will ensure the correct phrases are used when writing the description. 

11. Next select the Precision tab and make the settings as shown below. 
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Legal Description Editor 

 
12.  Select the Bearing tab and enter the settings as shown below. 

 

 

Note Notice how this dialog displays a sample of the desired bearing preferences as they are set. 

13. The next tab provides GENERAL SETTINGS for areas and directions. Probably the most 
important settings here is the column width, as this controls the line wrapping and controls how 
the description is formatted. Enter the settings as shown below. 
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Legal Description Editor 

 

 

14. The POINT GEOMETRY PHRASE option allows the user to set default phrases for when the 
description encounters particular elements such as a PC or a reverse curve, etc. 

 

 

Note These phrases are inserted into the description using the <PTGEOM> variable. The 
<PTGEOM> variable may be included as part of a line phrase. It is completely up to the user 
whether to use the <PTGEOM> as part of his line phrases.  
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Legal Description Editor 

 
15. Enter the settings as they are shown below for the Parcel Default Phrases. 

 

Note The PARCEL DEFAULT PHRASE option is very similar to the POINT GEOMETRY 
PHRASES in that the user can establish defaults for parcel descriptions from beginning to 
end. These phrases determine what line style will be used for the first line of a parcel, the 
body of a parcel, and the last line of the parcel. 
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16. CHAIN DEFAULT PHRASES will also be set as in the dialog shown below. 

 

17. Once completed select the OK button to close the dialog and then select the OK button on the 
dialog shown below to close the edit option. 
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> EDITING THE LIBRARY 

Note Once the Library and Style have been selected the user can edit the selected library or add to 
it. This is where the standard phrases are created and stored. In the exercises below we will 
attempt to create some desired phrases for our descriptions. 

1. Select the Edit Library option from the Library pull-down. 

 

2. When selected the user must confirm/specify which library he wants to edit. Select the library 
as shown below and then select the Edit button. 

 

3. Once selected the following dialog will appear. Now we can begin to set up commonly used 
phrases. Begin by double clicking on the Clauses category. 
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4. Highlight the Clause category, as shown below, and then select the icon to Create New Item. 

 

Note   Below is an example of the standard clause that we want to create. 

CLAUSE NO. 1 
 

 REFERENCE:  All boundaries and descriptions as shown on plans for Highway Project 

No._______ Right-of-Way on file in the Office of the Department of Transportation in Richmond, 

Virginia. 
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5. When the following dialog appears, enter the following information for ID, Description. 

 

6. The Item Type depends on what type of phrase you wish to create. As seen from the dialog 
there are several options. The most logical selection from the available list will be a Text 
Phrase. 
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7. Once the Type is set we can begin to compile the clause. To do this, simply key-in the text for 

the clause up to the point where we encounter a variable. 

 

8. Once the variable is encountered we can utilize the Insert Variables option to build a prompt 
so that the user can be prompted for what is expected next. To do this we decide between the 
two options for Text Variables.  In this case we will want to create a key-in as opposed to a 
list. To do this, simply select Key in text as the type and select Insert. 

 

9. This action provides a dialog so that you can key-in a logical prompt that will be presented to 
the user when it’s time for the insertion. Once entered select the OK button. This will insert 
the prompt into the description as shown below. 
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10. Now the remainder of the clause can be enter as shown below. 

 

11. Once this is completed select the Update button and the clause is completed and stored in the 
library. 
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12. We will create one more insert, called a HEADER. This will contain the Project number, 

county etc. Begin by opening the Text category and selecting the icon to create a new item. 

 

13. Enter the information for the item as shown below. 

FEDERAL PROJECT NO. APD-NHE-111(36) 
STATE PROJECT NO. 77041-2219-64                                          
RICHMOND COUNTY, TRACT 4200 
OWNER: ISTAR BOWLING CENTERS                                                   
GRANTEE: STATE OF VIRGINIA 
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14. When compiling the header below, remember press the <Enter> key after each entry so that it 

appears correctly when inserted.  

 

15. Continue until the header is completed. Once complete select the Update button. 
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> WRITING A LEGAL DESCRIPTION 

1. Access the main editor dialog and begin by entering several carriage returns (CR). This is 
necessary to create several blank lines above and below the active cursor. Once you have 
created 5 blank lines, move the cursor to the third line. 

 

2. Next select from the Insert pulldown, the option to insert Text Phrases. 
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3. This will invoke the following dialog. 

 

4. Select the option to insert Text phrases. And then insert the Header. 

 

5. After answering all of the prompts, you should end up with this portion of the description as 
shown below: 
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6. Now select from the Text phrases, the option to insert the Opening. 

 

7. Selecting SOUTH for the first variable will complete the description up to the variable for the 
owner’s name. When prompted for this you can use the Frequently Used pulldown to select 
from previous remembered key-ins. Select the owner from the list as shown below. 

 

8. Then select the Add button to use this as the inserted variable as shown below and select OK. 
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9. Next provide the variable for the road name. 

 

Note Repeat step 7 & 8 when prompted for the Project No. Select from the Frequently Used List 
the project number that was used in steps 7 & 8. This should complete the Opening Text 
phrase as shown below. 
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11. Close the Insert Text Phrase dialog and return to the Insert pull-down. 
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12. This time choose to insert a Coordinate phrase. 

 

13. Choose from the line types the Lines\Point. 
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14. Once selected use the MicroStation Power Selector to select graphically the beginning point 

you wish to use. 

 

15. Once you have made a MicroStation selection set with the point, you can then use the icon on 
the Coordinate Insert dialog to get the point number from that selection set. 

 

16. Once selected choose the Insert button. This should complete the following portion of the 
description. 
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17. Now we are ready to insert the metes and bounds around the entire Tract. Select from the 
Insert pulldown the option for inserting Lines/Curves/Spiral Phrases. 
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18. Make the following settings in the dialog shown below. 

 

19. Now highlight the desired calls that we wish to describe, that being all the calls from our 
P.O.B. (#4) to the last call. Once selected choose the Insert button. 

 

Note You should now have a completed Legal Description 
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                     1-53            Jan-08 
Copyright © 2008 Bentley Systems Incorporated 



ASCII Import for Plat 
Creation 

Objectives                     2-1                 Jan-08 
Copyright © 2008 Bentley Systems Incorporated 

2 

OBJECTIVES 
In this session we will review importing ASCII formatted data in order to create parcels in coordinate 
geometry. 

INTRODUCTION 
There are several options for importing ASCII data in Coordinate Geometry. Each requires a little 
different approach. One of the simplest ways is to use the Import > ASCII option directly from within 
Coordinate Geometry. 

This tool will directly store a plain ASCII XYZ file; no Survey Chains will be created. The ASCII file 
must have one line of data per point. Enter the name of the file or click Select. Then set the delimiter 
(character between each field in the data). If a comment is in the file, it must be at the end of the line, 
and separated by a unique delimiter. Set the None or Invalid Point Name and Chain name. If the 
Duplicate Filter Tolerance is on, any point within the specified tolerance of another point is ignored. 
The last step is to set the order of the fields within each row (Field Order). If the first row is Point#, X, 
and Y, set the Field Order to Point#, East(X), North(Y), and the rest to None. Click Apply to 
commence processing. 

 



Introduction 

 
Another option would be to import the ASCII data via a Survey dataset. This method would require 
setting up a Survey project and then creating a parcel dataset. 

 

Once a dataset has been created and an ASCII file selected, the interface will allow the user to specify 
the content of the file and control how it is imported. 
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Lab Exercise: Importing ASCII 

 
LAB EXERCISE: IMPORTING ASCII 

> IMPORTING VIA COGO 

1. Open the MicroStation file C:\60843\plat.dgn. 

2. Select from the Survey menu bar Project > Open and open the project 60843. 

 

3. Once in the Project select Geometry > Classic COGO. 

4. In Coordinate Geometry select File > Import > ASCII Points. 
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Lab Exercise: Importing ASCII 

 
5. Using the toggles on the left side of the dialog, set each one based on the format of the ASCII file 

as shown below. 

 

6. The completed toggle settings should look like the dialog below. 

 

7. Complete the remaining portions of the dialog by using Space as a delimiter. 

8. Select the File to Import > Coords.txt. 

9. Click the Apply button. 

10. The dialog below will display when completed. 
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Lab Exercise: Importing ASCII 

 
11. Review the coordinates in COGO. 

 

 

> IMPORTING ASCII VIA SURVEY 

1. From the main Survey Menu bar select Dataset > New. 

 

2. Provide a new name for the dataset. 

3. Make sure that the Data Source is set to ASCII Files & XYZ to Coordinates. 
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Lab Exercise: Importing ASCII 

 
4. Select the top icon located on the right side of the lower portion of the dialog. 

5. Select the file Coord.txt. 

 

6. Click OK. 

7. In the following dialog make sure the Delimiter toggle is set to Space. 

 

8. Highlight one of the rows in the display window. 
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Lab Exercise: Importing ASCII 

 
9. Set the toggles to the appropriate columns of data beneath the display window. 

 

10. Click the Process button. 

11. When the dialog below appears click OK. 

 

12. Allow the point to overwrite the previously stored points be clicking Apply All on the following 
dialog. 

 

13. Review the points in COGO. 

Note This method would be preferable if linking codes are provided in the field data. This method 
would draw the boundary line work where the first import method would not. 
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Lab Exercise: Storing Parcels 

 
 

LAB EXERCISE: STORING PARCELS 
> STORE PARCEL FROM POINTS 

1. This exercise will store each of the two parcels shown below. (4300 & 4301) 
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Lab Exercise: Storing Parcels 

 
2. From the COGO pulldowns select Element > Parcel > Store. 

 

3. Provide a Parcel name in the dialog. 

4. Place cursor in the Element List window of the dialog. 

5. Graphically click on each point that makes up parcel 4300 as shown above. 
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Lab Exercise: Storing Parcels 

 
6. Toggle on the Owners Name and type in Heritage Associates. 

 

7. Toggle on the Attributes option and provide the following attributes by clicking on the Add icon 
to the right side of the window. 

 

8. Click the Store Parcel button. 

9. Describe the parcel in COGO and review. 

10. Repeat the process for parcel 4301. 
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Lab Exercise: Storing Parcels 

 
> SURVEY PLAN PREPARATION TOOLS 

1. Create and open a new file called 4300.dgn. 

2. From the main Survey Menu Bar, select Plans Preparation > D and C Manager. 

3. Navigate to the Property Line item as shown below. 

 

4. Click the Draw Plan & Profile button on the secondary dialog. 
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Lab Exercise: Storing Parcels 

 
5. Make sure the settings are as shown below and click on the parcel 4300 in the list window. 

 

Note You may have to adjust the labels and rotate the view to get the parcel in the desired location. 
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Lab Exercise: Storing Parcels 

 
6. From the main Survey Menu Bar select Plans Preparation > Place Border. 

7. Complete the settings as shown below then click the Place button to place the border. 

 

8. Next select the Place North Arrow from the Plans Preparation pulldown. 

9. Complete the settings as shown below then click the Place button to place the arrow. 

 

10. Next select the Place Coordinate Table from the Plans Preparation pulldown. 
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Lab Exercise: Storing Parcels 

 
11. Complete the settings as shown below then click the Place button to place the table. 

 

Note You have to highlight the point numbers in the list window that you wish to be included in the 
table. 

Note The size of the table itself is controlled by the size of the text. 
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Lab Exercise: Storing Parcels 

 
12. You should now have a plat similar to the one shown below. 
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Plan View Labeling 

 
PLAN VIEW LABELING 

INTRODUCTION 
GEOPAK’s labeling tools allow a user to place “smart” labels in a MicroStation drawing.  These labels 
have the ability to calculate XYZ coordinates, station, offset, direction, length, radius, degree of 
curvature, etc. of the associated element. 

ACCESSING THE PLAN VIEW LABELER 

The Plan View Labeler can be accessed by selecting Plans Preparation > Plan View Labeling from 
the main Survey Menu Bar. 

PLAN VIEW LABELING 
When the Plan View Labeling icon is selected, the dialog depicted below is displayed. 

 

The label to be placed is displayed in the box on the right side of the dialog as shown above.  The 
Space button places a space in the label at the cursor position.  The Return button starts a new line of 
text.  The Clear button starts a new label.  The Delimit button places a line above or below a line of 
text.  The Place Label button attaches the label to the cursor for placement in the drawing.   

The user can select the various tabs to define / modify the label appearance. 

TEXT 

For data to be computed, the job number and the chain need to be selected.  If elevations are to be 
calculated, a TIN file needs to be chosen.   

The Computed Inserts are items that GEOPAK has the ability to calculate for the chosen item.  The list 
of Computed Inserts changes with the type of element that is chosen.  If a line is chosen, the list of 
Computed Inserts will show inserts of bearing, and length.  If a curve is chosen the list of Computed 
Inserts will change to show inserts of radius, curvature, chord length, etc. 

The User Inserts are inserts that a user may use on a regular basis.  This list can be customized for a 
specific user’s needs. 
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Plan View Labeling 

 
The Identify Element button allows the user to choose the element to use for calculations in the label.  
The Data Point button will let the user pick a specific point to calculate the coordinates, station, or 
offset for. 

PARAMETERS 

      

The Parameters tab enables the user set up the text size and symbology for the label. 

By Current sets the symbology to the current MicroStation settings.  By Element allows the user to 
set the symbology by choosing a MicroStation element.  D&C Symbology allows the user to set the 
symbology based on a item stored in the D&C Manager database. Set All sets the symbology for all 
elements in the label (text, delimiters, leader lines, etc.).   

SHAPE 

 

The Shape tab allows the user to place a shape around the label, and set the symbology for the shape. 
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Plan View Labeling 

 
LEADER 

 

The Leader tab allows the user to attach a leader from the label to the point.  Different leader types and 
terminators can be chosen.  The active terminator can also be used. 

ROTATE 

 

The Rotate tab allows the label to be rotated. The rotation can be determined from the current angle, 
the angle of the element, or an angle relative to the alignment. The angle can also be set by two data 
points (first data point set the location, next data point sets the angle) or the active angle. 
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Plan View Labeling 

 
STYLES 

 

The Styles tab allows a user to choose label symbology from a library of pre-defined styles. When the 
user chooses the style, all symbology, leaders, shapes, etc. is set up for the user. 

MENUS 

The Style Files menu allows the user to open a new style library. You must be under the Styles tab in 
order to open a style library. 

Options > Minimize Dialog minimizes the main dialog (when the Place Label button on the main 
dialog is pressed) to allow for easier label placement. The Label Viewer can be used in conjunction to 
still view the sample contained in the Label dialog. 

The main labeling window can be maximized by selecting the Restore Label Dialog icon within the 
appropriate View Label Control tool frame or the labeling tool on the main Road, Site, or Drainage 
tool frame. 

Options > Use Reference File Coordinates - When labeling elements within a reference file, it is 
useful to utilize the reference file coordinates, rather than the current active file.  Simply activate the 
toggle, and subsequent computed text inserts using reference file elements or data points will reflect 
the reference file coordinates, if the snap and locate in the reference file are active. 

Options > Use DP Element Association - This option will enable the association between MS 
elements and DP (data point) labels that are snapped to the element.  If the element is modified, the 
point labels will move with the element when the Label Update feature is used. Note: This only applies 
to elements within the active design file. 

Options > Label Tools invokes the tool frame shown below which enables the user to modify 
GEOPAK labels.  

 

Options > Label Viewer brings up a dialog that allows a user to view and place a label.  
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Plan View Labeling 

 

 

The Scale > Scale Style menu allows the user to choose a plan scale.  All labels will be adjusted 
according to the plan scale.  The user simply keys in a scale, and chooses a Labeling Style.  The 
corresponding label will be placed at the correct size for the scale that was chosen.  

Tools > Label Updater - The Label Update tool is a powerful tool for updating GEOPAK labels.  
When alignments are updated, TIN files modified, labels moved, etc., GEOPAK remembers the 
computed text information utilized in the placement of the original label.  Therefore, the software can 
update the label based on updated data.  The tool utilizes the dialog depicted below. 

 

Tools > Selection Set Labeling - The Selection Set Label tool is a powerful tool for placing or 
updating labels within a selection set.   

When the Selection Set Labeling tool is activated from the pulldown menu, the dialog depicted below 
opens. 
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Plan View Labeling 

 

 

Tools > Plan Label Preferences – Allows for the customization of the plan view labels.  Options 
include Bearing, Distance, Elevation, and Area. 

When the Plan Label Preferences tool is activated from the pulldown menu, the dialog depicted below 
opens. 
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TLab Exercise:   Labeling 

 
LAB EXERCISE:   LABELING 

> ACCESSING THE LABELER 

1. While still in 4300.dgn select Plan View Labeling from the main Survey Menu Bar. (Plans 
Preparation > Plan View Labeling). 

 

> USING PREDEFINED LABEL STYLES 

1. Select the Styles Tab. 

2. Traverse with the Item Selector box to locate the following style: 
Labels > Point Labels > StaOffEleTIN  

3. Next, double click the StaOffEleTIN style. 

 

3. Move back to the Text tab and complete as defined below: 

Job No. 101 
Chain MAINLINE 
TIN File S60843.tin 

In the following steps, we will use the Plan View Labeler to label the station and offset for 
the corners of parcel 4300. 

4. To begin the process, select the DP button and then identify the location that you wish for the 
Station and Offset to be computed. The labeler automatically calculates the information.  
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TLab Exercise:   Labeling 

 

 

5. Use the Params., Shape, Leader and Rotation tabs to experiment with different labeling 
styles.   

6. To place the label, return to the Text tab and click the Place Label button. 

7. The label is now attached to your cursor (without the leader for the delimiter). 

8. Data point at the location you wish the text to be located. 

9. A second data point will define the side of the label, which the leader line will be drawn from 
the delimiter line to the computed location. 
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TLab Exercise:   Labeling 

 
> CREATING AND SAVING A NEW LABEL STYLE 

1. Select the Text tab then click Clear below the label composition window. 

2. On the Plan View Labeler dialog, click the Select GEOPAK or MS Element icon, then 
identify any of the lines representing the parcel and accept. The computed text inserts should 
now contain items such as Bearing, Azimuth, and Length. 

3. Click on the Bearing -> DMS insert. This should show the current value below the Computed 
Text window in addition to a user definable toggle for the number of decimal places. Set this 
to 0, then double click Bearing -> DMS. Click Return to start a new line for the label. 

 

Note Your Bearing may be different depending on which MicroStation line you identified. 

4. Single click on the Length item, set its number of decimal places to 2, then double click 
Length. 

 

Note Your Distance may be different depending on which MicroStation line you identified. 

5. Select the Params. Tab and set the Height, Width, and Line Sp. to 5.0 and the Justification to 
Center-Center. 
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TLab Exercise:   Labeling 

 

 

6. Select the Shape tab, set the Shape Preferences to No Shape. 

7. Select the Leader tab and set the Leader Type to NO Leader and the set the Terminator to No 
Terminator. 

8. Click Continuous Place.  

9. Set the MicroStation snap to Midpoint. Snap the previously identified line and accept. 

10. Data point and accept each of the remaining lines of the parcel. 

11. Select the Styles tab. 

12. In the Item Selector window, double click Labels then double click Line Labels. 

13. Click New Style.   

14. Set the Style name to Bear_Dist.   

15. Click OK to save the style. 

16. Click Style Files > Save to update the def_plan.lsf file. 

17. Exit MicroStation. 
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3 
OBJECTIVES 

This chapter will focus on the critical process within the districts of creating data for borrow pits. 
Attention will be focused on creation of digital terrain models, both existing and proposed, from 
multiple data sources as well as calculating volumes using both the prismoidal and end area methods. 

INTRODUCTION 
Compiling data to create a digital terrain model for the existing ground will allow the user to create 
volumes after construction or excavation. After construction a secondary terrain model provides the 
surface to compute differences with the existing model. 

IMPORTING ASCII DATA 
The first step in processing the ASCII data is to appropriately define the settings in the Dataset dialog. 
This involves the selection of the desired ASCII field data file to be processed. 

 



Creating a Terrain Model 

 
Once the ASCII file has been selected for processing it is simply a matter of identifying the appropriate 
information in each column. 

 

CREATING A TERRAIN MODEL 
Once the data is imported then a digital terrain model can be compiled using the ground shots. Since 
the ground shots have been imported through Survey all information about each shot is known 
regarding DTM inclusion. This information is read directly from the feature code for each shot in the 
SMD feature table. 
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Lab Exercise: Borrow Pits 

 
After importing the ground data, the Build GEOPAK DTM tool is then used to triangulate the data and 
create the terrain model or TIN file. 

 

 

LAB EXERCISE: BORROW PITS 
> IMPORTING ASCII DATA 

1. Open the MicroStation file C:\60843\borrw_pits\S18897BPO.dgn. 

2. Access GEOPAK Survey from Applications > GEOPAK Survey > Survey. 

3. Open the existing project Borrow. 

4. Create a new Dataset called Field1. 
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Lab Exercise: Borrow Pits 

 
5. Using the Dataset Add Source File to List icon on the right of the list window, add the file 

original.txt. 

 

6. Click OK. 

7. Change the Delimiter to Space and highlight one of the lines in the list window. 

 

8. Now set the toggles for each column. 

9. Once completed click the Process button. 

10. When the following prompt appears, make sure the point is set to 1 and click OK. 
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Lab Exercise: Borrow Pits 

 
11. You should now have points displaying similar to the ones shown below. 

 

12. Repeat this process for the ASCII file Final.txt beginning with creating a new dataset called 
Final. 
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Lab Exercise: Borrow Pits 

 
13. When the Chain warning appears provide a prefix name of Final. 

 

14. Click Apply. 

 

 

> CREATING A TIN FILE 

1. To create the TIN file for the existing ground select Build DTM from the DTM pulldown. (DTM 
> Build DTM > From Survey Data) 

 

2. Provide a TIN file name of Original. 

3. Set the Dissolve option to Side and provide a length of 50’. 
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Lab Exercise: Borrow Pits 

 
4. Toggle OFF the Stroking Parameters. 

5. Make sure the Determine DTM Inclusion From option is set to Feature Table (SMD). 

6. Click the Set Search button and select the existing dataset Field1. 

 

Note Toggle OFF the Final dataset. 

7. Click OK. 

8. Click Process on the main dialog. 

 

9. Create a TIN file named Final using the Final dataset. 
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Volume Calculations 

 
VOLUME CALCULATIONS 

The Volumes Tool computes volumes between TIN models or a TIN model and plane. The quantities 
are displayed in the dialog, and can be optionally written into an ASCII file.  

For each volume option, the area about which volume calculations are performed is defined by a 
MicroStation shape or complex shape element (Select mode). An alternative method of defining the 
area about which volume calculations are performed is by interactively defining the area (Place mode). 
Both Select and Place mode operations will be discussed for each volume calculation option. In 
addition, depth ranges may also be utilized for each Volume option.  
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Volume Calculations 

 
Calculation Method: 

Activate one of the two methods to determine the method of calculation. Prismoidal utilizes the 
triangulation models, while the Grid Points utilizes lattice models created on the fly. 

Prismoidal 

When activated, triangulated models are utilized to compute the prismoidal volume. 

Grid Points 

When activated, the program utilizes the user-specified number of Grid Points to create a lattice, and 
then computes lattice volumes. 

Calculation Options 

This group box specifies which TIN files or planes are to be utilized for volume calculations. As the 
Calculation type is selected, the From and To fields directly below dynamically change to reflect the 
selection. 

Calculation 

When TIN to TIN is selected, the fields directly below are From TIN and To TIN. This configuration 
would be common for determining the project volumes, i.e., from existing ground terrain to the 
proposed surface.   

When Plane to TIN is selected, the fields directly below are From Plane and To TIN. In this case, a 
key-in field for the elevation is provided. This example is common for determining volumes between a 
water level (elevation) and the proposed pond.    
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Volume Calculations 

 
Use Range 

Clicking Range opens the dialog depicted below. Note the button is un-ghosted only when the Use 
Range toggle is active. If the toggle is active and no ranges are defined, the Process button remains 
ghosted. 

 

The dialog contains a list box, with edit fields directly below. Options are supported (button to the 
right of the list box) to Add, Modify, and Delete ranges. When the Active toggle is activated, the 
selected range is utilized for computations. A range can be activated or deactivated at any time during 
the processing by highlighting the desired line and changing the Active toggle in the lower right corner 
of the dialog. In this manner, the user has complete control over which ranges are computed at any one 
time.  

To add a single range, simply key in the desired values, set the Active toggle, and click Add. The 
created line is added to the list box. To modify a line, highlight the desired line. The current values are 
displayed in the edit fields. Change the desired field, and then click Modify. GEOPAK updates the list 
box. To delete a line, highlight the line and click Delete. The line is removed from the list box. A 
maximum of 50 ranges is supported. When more than five ranges are specified, the scroll bar and 
arrows on the right side of the dialog are automatically invoked for easy scanning. 

The top of the dialog supports automatic creation of ranges. Two options are supported:  

• Auto Number of Ranges - the number of ranges is specified, along with the Minimum and 
Maximum elevations. GEOPAK divides the Minimum and Maximum elevation difference into the 
specified number of elevation ranges.  

• Auto Range Increment - the range increment is specified, along with the Minimum and 
Maximum elevations. GEOPAK divides the elevation into as many elevation ranges as necessary 
at the specified increment.  

Note the buttons to the right of the Elevations are the Min /Max values for the current TIN Model. 
They are displayed only when TIN file names are specified within the main dialog. To utilize them in 
populating the fields, simply press the appropriate button. 

To utilize the specified ranges for subsequent sessions, several File functions are supported: Save, 
Save As, and Open. 
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Volume Calculations 

This group box contains the Cut Volume, Fill Volume, Balance, and Area tools. Units are 
determined by the User Preferences. In English projects, units are cubic and square yards, while metric 
projects are cubic and square meters. Fields are supported for Cut Factor and Fill Factor. 

Fill Factor  
Cut Factor 

To utilize the Fill Factor or Cut Factor, activate the toggle to the left of the Fill Factor. When 
activated, the Fill Factor is applied to the Fill volume, while the Cut Factor is applied to the Cut 
Volume. The calculations displayed in the Volume Calculations and in the optional report reflect the 
adjusted volumes. The Factors are also applied to the range totals. 

Output 

An optional output can be generated, placing the results in an ASCII file. 

Output to ASCII File 

When activated, the results are placed in the specified ASCII file. 

Files 

Name of ASCII file to be created or appended. In lieu of typing, clicking Files invokes the Create 
ASCII Output File dialog, wherein the desired file may be selected. 

Create File 
Append File 

Setting the option to Create File creates a new output file, while setting the option to Append File 
adds the results of the current processing to the bottom of the previously created output file. 

View 

Pressing this button invokes the Text editor, and automatically loads the output report for review. 

Boundary Selection 

Volume calculations can be performed in a user-defined area(s), rather than the entire model, utilizing 
information within this group box.  

Use Boundary 

When activated, a single user-defined boundary is utilized, rather than computing volumes for the 
entire model. When activated, both the Place and Select buttons are un-ghosted. 

Place 

Clicking Place enables the user to subsequently identify data points within the model to define the 
boundary limits. To close the boundary, place the last data point within the circle at the initial point of 
the boundary.  
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Select 

Clicking this button enables the user to identify a previously defined closed element, wherein volume 
calculations can be computed. 

Volumes by Region 

When activated, the Volumes for multiple boundaries based on element symbology can be computed. 
Clicking Regions opens the Volumes by Region dialog. 

 

To add region(s), enter a Description, and then set the symbology. Click Add   to add the items to the 
list box. To modify a listing, highlight the desired line to be modified, which places the current line in 
the edit fields. Make the desired changes, and then click Modify. The list box is updated. To delete a 
line, simply highlight the line to be deleted, and then click Delete. 

Note numerous regions of the same symbology can be computed by a single entry in the list box. If 
defined areas overlap, their union is utilized for volumes, so the volumes are not included twice in the 
computations. The regions must be closed shapes, as any non-closed shapes are ignored. Closed areas 
comprised of other elements (i.e., lines or line strings) are also not utilized, only MicroStation shapes. 

Each region (one line in the list box) and its associated volume are listed separately within the output 
report, while only the total volume is shown within the Volume Calculations part of the dialog. 

Volume Polygons 

The areas where volumes are computed are displayed or drawn into the design file. The area of the 
volume polygon is identical to the Area value displayed within the Volume Calculations group box.  

Fill Volume Polygons 

When activated, polygons are filled, rather than just outlined. Note the MicroStation fill attribute must 
be active for the fill to display.  

Display Only 

When activated, the polygons which outline the area where volumes have been computed are visually 
displayed, but not drawn into the design file. Therefore, they disappear when the screen is refreshed or 
any view control command is executed. When not activated, the polygons are drawn into the design 
file. 

Process 

Commences the volume calculations. Note this button is ghosted until sufficient data has been 
incorporated within the dialog. 
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LAB EXERCISE: PRISMOIDAL VOLUMES 

> COMPUTING VOLUMES 

1. Open the MicroStation file C:\60843\borrw_pits\S18897BPO.dgn. 

2. Access GEOPAK Survey from Applications > GEOPAK Survey > Survey. 

3. Open the existing project Borrow. 

4. From the main Survey Menu bar select DTM > Volumes. 
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5. Use the Browse buttons to select the From and To TIN files as shown below. 

 

6. Toggle ON the Output to ASCII File and provide a file name. 

7. Click Process. 
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8. Review the volumes in the dialog and ASCII file. 

 

 

9. Exit MicroStation. 
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CROSS SECTIONS 

In this section we will review how to create a baseline in order to calculate end area volumes using the 
same two TIN files from the previous section. 

 

LAB EXERCISE: END AREA VOLUMES 
> CREATING A BASELINE 

1. Open the MicroStation file C:\60843\borrw_pits\S18897BPO.dgn. 

2. Access GEOPAK Survey from Applications > GEOPAK Road > Project Manager. 

 

3. Open the existing project Borrow. 

4. Use the User Name John. 
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5. Using the MicroStation Place Line command, place a line to be used as a baseline in the location 

as shown below. 

 

6. Select from the Applications pulldown Applications > GEOPAK Road > Geometry > Store 
Graphics. 

7. Populate the dialog as shown below and then click on the ID Element button. 

 

8. Data point on the baseline element previously drawn. 

9. Issue one more data point anywhere on the screen to accept the baseline. 

10. Click the Store button that is now un-ghosted on the dialog. 

11. Click OK to finish storing the chain in the COGO database. 
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> CREATING PATTERN LINES 

1. Return the main Project Manager dialog. 

2. Click on the button Draw Pattern. 

3. Select Run > New on the RUN dialog and create a new RUN named Volumes. 

 

4. Click OK. 

5. Open the new RUN. 

6. Make the settings in the dialog as shown below. 

 

 

Note It is important to provide a distance other than zero for the offset values. The Pattern Lines 
MUST cross the baseline. 

7. Click the Draw Pattern Lines button. 

8. Close the Draw Pattern Lines dialog. 
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Note You should now have Pattern Lines as shown below. You may find it necessary to ADD 
additional Pattern Lines particularly at the beginning and end of the area to be calculated. 

 

 

> CREATING GROUND CROSS SECTIONS 

1. Click the button for Existing Ground Cross Sections on Project Manager. 

2. Create a new RUN named volumes. 

Lab Exercise: End Area Volumes                     3-19               Jan-08 
Copyright © 2008 Bentley Systems Incorporated 



Lab Exercise: End Area Volumes 

 
3. Make the settings in the dialog as shown below. 

 

4. Click the Surfaces tab and complete the remaining settings. 

5. In the Details portion of the dialog set the TIN file to Original and the Method to Triangles and 
the Type to Line, 
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6. In the Display portion of the dialog set the toggle to By Feature. 

7. Use the Browse button and select the item Road Design > Cross Section > Existing > EXGR. 

8. Click the Add Item on the right side of the list window. 

 

9. Change the TIN file to Final. 

10. In the Display Settings portion of the dialog change the toggle to By Level Symbology. 

11. Double click on the symbology window and set the dialog as shown below. 

 

12. Click OK. 
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13. Click the Add Item on the right side of the list window. 

 

14. Create and open a new 2D MicroStation file named xs_volumes.dgn. 

15. Click the Draw button on the Existing Ground Cross Section dialog. 

16. You can click OK if you receive the warning below. 

 

Note You should now have both original and final cross sections. 
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> CLOSURE REPORT 

1. Access the Reports & XS Quantities from the main Project Manager dialog. 

2. Click on the Closure report. 

 

3. Using the toggles directly below the list window set the LT & RT sides to Slope Extension by 
adding each to the list window separately. 

 

4. Click the Output Options button. 
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5. You can visualize the affects of running the report by making the settings as shown below. 

 

 

 

6. Once the settings have been made close the Output Options dialog. 

7. Click the Apply button on the main dialog. 

8. Close the Closure Report dialog and review the sections. 

Note The reason the Closure Report did not perform much in the way of clean up on these 
particular sections is the fact that there are multiple line segments beyond the intersection of 
existing and proposed or the fact that an extension of proposed would not tie to existing. 
Because of this we can opt to step through each section and fix or continue on with the 
Earthwork application and perform inter-active corrections as we are computing end area 
volumes. 
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> END AREA VOLUMES 

1. Click on the Earthwork button on the main Project Manager dialog. 

2. Create a new RUN named volumes. 

 

3. Click OK. 

4. Open the new RUN. 

5. Input the XS DGN File information as shown below. 

 

6. Click on Soil Types. 

7. Set the Class toggle to Existing Ground and provide a name like DIRT. 
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8. Toggle on the desired symbology toggles and using the Match button data point on an existing 

ground element and accept it. 

 

9. Click the Add button to add it to the list window. 

10. Repeat this process for the Proposed Finish Grade. 

 

11. Click on Output Format. 

12. Using the toggles change the format to only Excavation and Fil. 
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13. Select File > Run. 

14. Provide a file name to write the volume information into. 

 

15. Click Apply. 

16. When the following error message appears it is warning of an error at a specific coordinate 
location. You can navigate to this location by clicking on the MicroStation Zoom In tool and then 
clicking the DP button on the error dialog. 

 

17. Once zoomed into the problem use any MicroStation commands to fix it and then click on the 
Redo button on the dialog. 

18. Repeat this process on all sections that report back an error. 
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19. Once completed you can review the total volumes. 

 

20. Exit the Earthwork RUN. 

Note The less distance there is between cross sections the more accurate the end area volumes 
will be. 
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CROSS SECTION SHEETS 

The GEOPAK sheet layout component provides an automated tool to draw cross section data in a 
format suitable for producing hard-copy cross section construction drawings.  The input includes 
specifying sheet layout parameters as well as the graphic design file where the cross sections were 
originally created by GEOPAK.  The output is a MicroStation design file of the cross sections.  Each 
cross section is displayed as a reference file and labels such as baseline, station, offsets and elevation 
are added.  There are several advantages to using sheet input: 

• The cross sections will be sorted in numeric order for the specified baseline.  

• The cross sections will be spaced closer together. 

• The original cross section file is left intact and any modifications to the cross sections will be 
automatically displayed in the sheet file due to the use of reference files. 

• The cross sections are placed into "sheet format" according to user specified criteria. 

The parameters for each sheet are defined in a Sheet Library.  In order to lay out sheets, a Sheet 
Library must be attached to the current session.  The name of the currently attached Sheet Library is 
shown in the title bar.  Sheet Libraries have an extension of xssl.  An unlimited number of different 
sheets can be stored within one library. When the user begins the sheet process, he selects the desired 
sheet layout from the attached library, which loads the associated parameters. 

If a different Sheet Library is needed, it can be attached via the menu items File > Sheet Library > 
Attach.  Detailed information on the set-up of the Sheet Library can be found in the online help section 
entitled "Sheet Library Set-up." 
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ACCESSING THE CROSS SECTION SHEET LAYOUT TOOL 

The Cross Section Sheet tool can be accessed by selecting Applications > GEOPAK ROAD > Cross 
Sections > Cross Section Sheet Composition.  It can also be invoked from Project Manager by clicking 
the Cross Section Sheets button or by selecting the Cross Section Sheet Composition icon from the 
GEOPAK ROAD tool frame.   

 

FILE > SHEET LIBRARY 

TOOL DESCRIPTION 

New Create a new Sheet Library. 

Attach Attach a Sheet Library. 

Save Saves a Sheet Library. 

Save As  Save a Sheet Library as a new name. 

Note \\coapp52\proj\geopakv8\road\standards\ 

FILE > SHEET 

TOOL DESCRIPTION 

New Create a new Sheet in a Sheet Library. 

Delete Delete a Sheet in a Sheet Library. 

Copy Copy a Sheet in a Sheet Library. 

Update Update a Sheet in a Sheet Library. 

 

Accessing The Cross Section Sheet Layout Tool                     3-30                
Jan-08 

Copyright © 2008 Bentley Systems Incorporated 



Cross Section Sheets Dialog 

 
FILE > LOAD V7 INPUT FILE 

This option gives the user the ability to load an ASCII input file that was created in previous versions 
of GEOPAK. 

FILE > SAVE SETTINGS 

Saves all dialog settings in Project Manager. 

FILE > LAYOUT SHEETS 

Layout cross sections into sheet format. 

FILE > EXIT 

Exit the Cross Section Sheet Composition application. 

CROSS SECTION SHEETS DIALOG 
The left side of the dialog contains the list of parameters required to compute earthwork.  When each 
parameter is selected, the dialog changes as do the key-in fields to reflect the selected parameter. 

XS DGN File – Tells the software where to locate the cross sections. The Chain and stationing will be 
filled out automatically if defined via the project manager. By default, the software will find all 
elements within the confines of the cross section cell.  
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Sheet DGN File - Specifies which file the cross section sheets will be placed in. Also allows you to set 
the horizontal and vertical scale at which they are to be laid out and the coordinate location in the 
MicroStation Design file at which the sheets will be placed. 

 

If the Detach Existing Sheets before Processing option is toggled on then all elements are removed 
and reference files are detached before new sheets are processed. 

 

Attachment: 

 All Sheets In Active Model – All sheets are placed in the Active Model. 

One Sheet Per Model – Sheets are placed in separate models and no sheets are placed in the 
active model. 

One Sheet Per Model / Display All – Sheets are placed in separate models and all sheets are 
attached to the active model as reference files. 

Note Models are named XS_SHEET_ and the sheet number is added to the name. 
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Sheet Dimensions/Cell – Sheet Dimensions defines the Sheet Height and Sheet Width to be used for 
the cross section sheet.  When Place Sheet Cell is toggled on, the application will place a sheet border 
cell from the specified cell library.  A scale can be applied and the sheet cells can be placed as Shared 
Cells.  Sheet Offset from Cell Origin is the X and Y offset from the sheet border cell origin. 

 

There are two options for Sheet Cell Placement.  The sheet border cell can be placed in the sheet file 
with the cross section reference files as shown above.  It can also be placed once in a reference file 
then the sheet cell file is attached to the file that contains the cross section reference files as many 
times as it is needed.   
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XS Search Criteria – Indicates the search criteria (symbology) for the data to be used as input to the 
sheet layout software.  If you need to look farther than that (i.e. outside of the cell), you can use the 
Lower and Upper Range Limit values to extend beyond the cell limits.  There is also a Horizontal 
Search to look outside the limits of Sheet Width setting. 

 

Sheet Stack Orientation – Determines whether you want the sheets to be stacked vertically or 
horizontally.  Also allows you to set the maximum number of sheets you want placed per column in 
the file as well as the Horizontal and Vertical spacing between sheets. 
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Sheet Stack Columns – Determines whether you want a single stack or a double stack of cross 
sections per sheet.  Baseline X Offset defines the distance from the left-hand edge of the sheet to the 
zero offset position (i.e. baseline) of the cross sections.  If you select Double Stack, you can give an 
offset value which is the distance of the second stack from the left hand edge of the sheet.  There are 
also options for Triple and Quadruple stacking. 

 

Margins and Spacing – Cross Section Clip Limits defines the clipping limits from the left hand edge 
of the sheet.  To the left of the Left Clip X Offset remains clear space and to the right of the Right Clip 
X Offset remains clear space.  All minimum spacing requirements as well as the maximum allowable 
vertical size of any cross section is also set here. 
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Station Labels – Allows you to define the station label locations and plot parameters. 

 

Offset Labels – Allows you to define the offset label positions, increments and plot parameters. 
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Elevation Labels – Allows you to control the elevation label locations, increment and plot parameters.  
Add Top Elevation Label - Activating this toggle adds another elevation label above the current labels 
placed within the elevation labels parameters.  If two sets of elevations labels are placed (one on each 
side of the section), the top elevation is added to both. 

Add Bottom Elevation Label - Activating this toggle adds another elevation label below the single 
label placed within the elevation labels parameters.  If two sets of elevations labels are placed (one on 
each side of the section), the bottom elevation is added to both. 

 

Earthwork Quantity Labels – The user can define the ASCII file that contains the earthwork quantity 
information, as well as set the symbology and location of the earthwork quantity labels.  This will use 
the information gathered during the earthwork run to place the earthwork quantity labels on the cross 
section sheets. 
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Sheet Labels – Allows the placement of numerous labels.  There are three sets of labels that can be 
placed where the labels change from sheet to sheet.  These labels include Sheet Number, Begin 
Station, and End Station.  Any number of custom labels can also be placed.  These labels would be 
something that does not change from sheet to sheet such as Project Number, Designer, etc.  A list of 
labels can be created and each label can have its own symbology.  Location of the labels is controlled 
by the DP Origin and DP Label Justification Point buttons.  The DP Origin button locates the origin of 
the sheet cell and the DP Label Justification Point button sets the X and Y Offset from the sheet cell 
origin for the placement of the label. 
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LAB EXERCISE:   CROSS SECTION SHEETS LAYOUT 

> GENERATING CROSS SECTION SHEETS 

1. Open the MicroStation file c:\60843\borrow_pits\xs_volumes.dgn. 

2. Access Project Manager.  

3. Open the project, borrow. 

 

4. Click Cross Section Sheets from the Project Manager dialog and create a new run named BL. 

5.   Open the new run. 

6. Select File > Sheet Library > Attach.   

7. Select C:\60843\standards\VDOTENG.xssl. 

Note \\coapp52\proj\geopakv8\road\standards\VDOTENG.xssl 
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Note We will be using “XSSHEET” as the sheet name for our Cross Section Sheet layout. 

8. Click Select Sheet DGN File and select the sheet design file xs_sheet.dgn.  
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9. Select Sheet Dimensions / Cell and verify the settings below. 
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10. Select XS Search Criteria and make settings as shown below. 

 

11. Select Sheet Stack Columns and change the Baseline Offset to 8. 
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12. Select Earthwork Quantity Labels and toggle OFF Label Earthwork Quantities. 

 

 

13. Turn off level, Level 63. 

14. Process the cross sections onto the sheets using either the File > Layout Sheets pulldown or 
by clicking the Layout Sheets button. 

15. Close the Cross Section Sheet Composition dialog. 

16. When prompted to Save Settings, click Yes. 

17. When the Cross Section Sheet Layout process is completed, you will be in the sheet file.  
Review your work. 

18. Exit MicroStation. 
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4 
OBJECTIVES 

In this chapter, we will create various cross section reports: 

 for plan use (design elements and quantities). 

 as input for other programs and/or applications of GEOPAK. 

 for construction layout. 

Create and draw construction limits in the plan view file. 

INTRODUCTION 
The GEOPAK Cross Section Report Utility can extract up to sixteen different reports from original 
and design cross-sections.  For each report generated, the user must set the parameters of the existing 
and/or design cross sections.  GEOPAK also provides an option to make custom headers for each of 
the reports via the User pull down menu. 



Accessing Cross Section Reports 

 

ACCESSING CROSS SECTION REPORTS 
The Cross Section Reports dialog can be accessed by selecting Applications > 
GEOPAK ROAD > Cross Sections > Reports.  It can also be invoked from 
Project Manager by clicking the Reports & XS Quantities button or by selecting 
Cross Section Reports from the GEOPAK ROAD tool frame.   

CUSTOM HEADER 
From the XS Report dialog, select User > Preferences.  To activate the 
individual fields simply toggle on the box next to the desired field.  Once you 
have completed the dialog box, the information will be saved as an .hdr file.  
This allows for the creation of a separate header for each type of report.  The 
tolerance field determines the maximum gap allowed between cross section 
elements.   

  

BLUE AND RED TOP 

Based on the dialog box settings, GEOPAK determines the offset and elevation of a slope and its 
breakpoints.  Blue refers to the top of pavement and Red is the top of subgrade.  The user must 
determine this by indicating text and level, color, weight and style for each surface. 

CLEARING 

The Clearing Report is useful for obtaining clearing and grubbing quantities.  For each station, 
GEOPAK will list the clearing distance on each side of the chain and the width of any exception. You 
can obtain the results in the appropriate units.  Toggle boxes for Cut Slope Rounding, Additional 
Clearing in Cut and Fill, and Minimum Clearing Width are provided for increased control over the 
output. GEOPAK can also generate quantity sub-totals based on the value specified in Sub Every. 

To use the Except Width option, you must have an existing ASCII file that includes the Beginning and 
Ending Station and Exception Width. 

Once everything is set, you can output the information to an ASCII file. 

CLOSURE 

The Closure Report provides information on the intersection point between the user defined proposed 
finish grade and existing ground.  In addition to the ASCII report, the designer may instruct GEOPAK 
to close any gap either by drawing a vertical line between the endpoint of the proposed finish element 
and the existing ground or extending the slope of the last proposed element to intersect existing 
ground.  The procedure will not extend existing ground.  The Closure Report can be accessed within 
any MicroStation cross section file by selecting Closure from the main XS Reports dialog. 
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DTM INPUT 

This process generates XYZ coordinates from cross section elements and places this information into 
an ASCII file for use by the DTM portion of GEOPAK.  To use this dialog box simply enter the .gpk 
job number, chain name and station range.  GEOPAK will read the cross section elements based on 
level, weight, color and style. 

DTM PROPOSED 3D 

This report is similar to DTM Input except that you can set both original and proposed cross sections at 
the same time.  This report also differs in that it makes break lines across the cross sections.   

HEC – 2 

This process reads cross section elements and formats the information in an ASCII text file suitable for 
use in the HEC-2 hydraulic program. 

HEC RAS 

This process reads cross section elements and formats the information in an ASCII text file suitable for 
use in the HEC RAS hydraulic program. 

MULTI-LINE 

This report is useful in creating cross-sections for staged construction.  Begin by entering the job 
number, chain name and station limits.  Primary cross section element parameters must be completed 
before secondary element parameters.  This is important due to the order in which GEOPAK reads the 
information.  Once all the parameters have been entered, the new cross sections may be drawn to the 
design file or you may choose the display only option.  An ASCII text file will be generated. 

PROFILE GRADE 

The Profile Grade Report is one of the most versatile reports available.  It prints existing ground and 
design grade elevations and low point elevations for each cross section.  Additionally, this report has 
the ability to search either for the low points or any text string that you specify and create horizontal 
and vertical alignments and store them directly into the .gpk.  Horizontal alignments created from this 
report will have no curves. 

RADIAL STAKING 

The Radial Staking Report is a specialized report created for the U.S. Federal Highway 
Administration (FHWA). 

 RT 40 

The RT 40 Report produces RDS based RT40 data.  To use this dialog box simply fill in the job chain 
name, stationing range and the parameters of the cross section elements you wish to use. 
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SEEDING 

Other than the usual entries, the user must enter the parameters of the elements to be seeded. 

This dialog box includes slope and subtotal options as well as a way to limit the number of segments 
read (By-Pass Segments).  The user may also establish additional seeding specifications (Additional 
Distance). 

Once all of the settings are complete, the report will produce seed or sod quantities written to an ASCII 
output file for use in plan quantities.  

SLOPE STAKE 

The Slope Stake Report is a special format report developed for the FHWA.  This report generates 
offsets, elevations and superelevation information for each cross section.  To generate this report fill in 
the usual cross section parameters plus Subgrade and Hub Staking information. When complete, push 
Apply and the report is written into an ASCII file. 

 STAKING DETAIL 

The Staking Detail Report determines the tie down point between the proposed finished grade and the 
existing ground.  GEOPAK will list the right and left offset, elevation, and slope of the finish grade 
and superelevation rate for each cross section.  To create this report, fill in the project information and 
desired cross section elements’ parameters.  Once complete, you have the choice between two formats, 
a FHWA ASCII report or a Montana DOT report (includes ditch elevations). 

WSPRO 

This report takes the cross section elements and turns them into an ASCII file for use as input in the 
WSPRO hydraulic analysis program. 

XS LIST 

This report creates a listing of elevations and offsets for each cross section element according to user 
defined parameters.  You have the option of creating either an original cross section list or a design 
cross section list.  These reports are very similar to RDS cross section lists. 
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LAB EXERCISE: CROSS SECTION REPORTS 

> REPORTING 

1. Open the MicroStation file c:\60843\d60843xsmailine.dgn. 

2. Open the project 60843 via Project Manager. 

3. Click on the button Reports & XS Quantities. 

 

4. Select from the main dialog User > Preferences and set as shown below. 

 

5. Close the Preference dialog. 
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6. Click on the Slope Stake button and make the settings as shown below. 

 

7. The Existing Ground symbology should be set as follows. 

 

8. The Proposed Finish Grade should be set as follows. 

 

Note The Levels include 4, 11, 10, 2, 3. 

9. Change the Ending Station to 15+00. 

10. Click Apply. 

Lab Exercise: Cross Section Reports                     4-6                 Jan-08 
Copyright © 2008 Bentley Systems Incorporated 



Lab Exercise: Cross Section Reports 

 
11. Review the report. 

 

12. Review some of the other reports on the main dialog. 

13. Close the Report dialog. 
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> HEC-RAS 

1. Open the MicroStation file c:\60843\d60843work.dgn. 

2. Attach the saved view creek1. 

3. Review the creek pattern lines. 

4. Open the MicroStation file c:\60843\xscreek.dgn. 

5. Review the cross sections. 

6. Open the project 60843 with Project Manager. 

7. Click the button Reports & XS Quantities. 

 

8. Click the button for HEC-RAS. 
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9. Set the HEC RAS Element to match existing ground as shown below. 

 

10. Close the symbology dialog. 

11. Provide a report file name of creek1.geo. 

 

12. Click Apply. 

13. Review the report. 

 

14. Exit MicroStation. 
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5 
OBJECTIVE 

In this session we will review the DTM tools for analyzing the TIN files. 

DTM Analysis Tools provide a means to query the terrain model for critical information ranging from 
drainage areas to volumes along with thematic mapping. The tools that will be addressed in this section 
are listed below. 

• 

• 

• 

• 

• 

• 

• 

• 

• 

Height 

Elevation Differences 

Slope Areas 

Themes 

Drainage Tools 

Visibility 

Trace Slope Path 

Camera 

Trench Volumes 

 

INTRODUCTION 
A Digital Terrain Model (DTM) represents the topography of a project in the form of a triangulated 
network.  The DTM can be drawn in a 2D or 3D file, and then rotated to see the existing surface of the 
project area. 

Digital Terrain Models can be generated from various sources including MicroStation Elements, 
survey data, photogrammetry data, GEOPAK cross sections, and geometry data. 

Triangulation is a mathematical process applied to ground points and vertices along longitudinal 
features to create planar surfaces.  The result of triangulation is the creation of triangles connecting 
these points. These triangles are included in the GEOPAK TIN file from which existing ground 
profiles and existing ground cross sections can be generated. 



Analysis Tools 

 
ANALYSIS TOOLS 

Tools 

 

Menu Bar Analysis > Height 
Analysis > Profile 
Analysis > Volumes 
Analysis > Elevation Difference 
Analysis > Slope Area 
Analysis > Themes 
Analysis > Drainage Tools 
Analysis > Visibility 
Analysis > Trace Slope Path 
Analysis > DTM Camera 
Analysis > Trench Volumes 

The Analysis tools allow the user to visually analyze the digital terrain model utilizing numerous tools as a profile 
analysis, thematic analysis, drainage flow patterns, and visual portions on the model from any given location. 

Height To determine the height and other associated data dynamically based on user-
defined data points within the model. 

Profile View a profile based on a user defined MicroStation element. 

Volumes To compute the volume between two TIN models, the volume between a TIN 
model and a plane, or the cut and fill totals between two TIN models while 
applying a shrinkage/swell factors. 

Elevation Difference Will display the elevation difference or the amount of cut and fill between two 
TIN models, or a TIN model and a plane of constant elevation. 

Slope Area The Slope Area tool displays the horizontal area and actual slope area (area 
following the terrain of the Model). 

Themes Displays the digital terrain model based on different user definable themes 
such as elevation ranges, slope percentage, slope degree, or aspect. 

Drainage Displays and analyzes drainage patterns within a TIN model.  Tools include 
delineating watersheds, drawing flow arrows, determining upstream and 
downstream traces, finding high and low points, and ridge and sump lines. 

Visibility Based on a user-defined point of origin, GEOPAK visually displays which 
triangles can and cannot be seen, or what is visible between two points. 

Trace Slope Path From a user-defined point of origin, GEOPAK visually displays or writes into 
the dgn file the route a user-specified slope will follow into the DTM. 

DTM Camera Provides a drive-thru navigation tool along the DTM. 

Trench Volumes The Trench Volume tool utilizes a TIN file (and optional offset) to compute 
trench and bedding volumes. 

Analysis Tools                     5-2                 Jan-08 
Copyright © 2008 Bentley Systems Incorporated 



Lab Exercise: 

 
LAB EXERCISE: 

> HEIGHT 

1. Open the MicroStation file c:\60843\spo60843.dgn. 

2. Select Applications > GEOPAK Road > DTM Tools. 

 

3. Tear off the tool box from the lower left icon. 

 

4. Click the first icon from the left. 

  

To Determine an Elevation or Slope 

1. Click Select File and browse to the desired TIN file.  

2. Select Mode (Elevation or Slope). 

3. If the Mode is Elevation, turn on the desired Show features. 

4. If the Mode is Slope, set the Display Options. 

5. Turn on Display Only if you do not want the data drawn into the MicroStation file. 

6. Click Start. 

7. Move the cursor over any location within the boundary of the triangulated model.  If the Slope 
between points is used, data point per the prompt then move the cursor for data display. 
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8. If a data point is selected outside the hull, the message displayed is: "Point External To Tin." The 

Plan View Coordinates, Elevation, and Slope of the triangulated model are displayed.  

Note The number of decimal places is based on the GEOPAK User Preferences. 

Display Options for Elevation Mode 

Three options are supported within the dialog: 

 Show Contour - displays a contour of the same elevation as the selected point. 

 Show Triangle - identifies the triangle wherein the point is located. 

 Show Flow Arrow - displays an arrow to indicate direction of flow from the selected point. 
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The affected triangle (wherein the identified point is located) displays the flow arrow and elevation and 
the identified point as well as the contour for that elevation. 

 

Display Options for Slope Mode 

Slopes can be displayed in a variety of formats, such as rise:run, run:rise, percent, and unit/unit. The 
slope can be the specified as the triangle slope at the point of the cursors, or between points.  In this 
case, click Start and the user is prompted for a data point as the origin.  Then as the cursor is moved, 
the slope between the origin and the current cursor position is displayed. 
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> PROFILES 

The Profile tool drapes a user defined MicroStation element onto a TIN model.  It creates a series 
of line strings by draping each linear reference element onto the triangulated model, or in the case 
of site modeler, an object.  

The dialog has three tabs: 

Selection 

TIN file specifications, profile element symbology and create legend button. 

Profile 

Profile placement buttons and viewing dialog before drawing the actual profile into the 
MicroStation file. 

Preferences 

Profile and grid scales, text parameters, elevation and station ranges. 

 

To Draw a Profile   

Identify the TIN file(s) through which the profile intersects and set symbology.  

Select or draw the element whose X,Y values are utilized to generate a profile along the TIN, 
This is accomplished via the Profile tab. 

Set the element symbology and text parameters for the grid. In addition, Minimum and 
Maximum Stations and Elevations may also be set. This is accomplished via the Preferences tab. 

Generate the profile and view in the Profile window. Optionally, draw the profile into the 
MicroStation file. These are accomplished via the Profile tab. 

(Optional) Create a Legend or Store the profile into COGO.  These are accomplished via the 
Selection tab. 

 

1. Open the MicroStation file c:\60843\borrow_pits\s18897bpo.dgn. 

2. Access Applications > GEOPAK Road > DTM Tools. 

3. Tear off the Analysis tool bar. 
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4. Select the second icon from the left for Profiles. 

 

5. Use the browse option to identify the original ground TIN file. 

6. Set some symbology for the profile. 

7. Use the icon to the right of the list window to ADD the item to the list. 
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8. Repeat the process using the final ground TIN file and different symbology. 

 

9. Click on the Profile tab. 

10. Click on the Place Element and identify two points on the TIN files. 
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11. Click the Preference tab and make the settings as shown below. 

 

12. Click back on the Profile tab and review the grid. 

 

13. Click on the Place Profile tab and data point in the MicroStation view to place the profile 
graphically. 

14. Close the profile tool. 
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ELEVATIONS DIFFERENCE 

The Elevation Difference tool supports a variety of grid generation, Isopach contour drawing, and cut/fill 
latticing. The tools are: 

•  Difference Point – draws the text of cut / fill elevations, i.e., the cut or fill depth between the two 
specified TIN files at each specified point. In a 3D design file, when in a front or side view, the 
grid displays T's. The T's represent the cut or fill values. The vertical part of the T is the vertical 
length of the cut or fill and the bar of the T is the text value of the cut or fill. The bar of the T is 
placed on the surface of the From TIN. Therefore, in a cut situation, a normal T is placed, while in 
a fill situation the T is inverted. 

•  Difference Grid - draws a textual grid of cut / fill elevations, i.e., the cut or fill depth between the 
two specified TIN files at each grid point. The user specifies the grid interval; therefore, GEOPAK 
determines the number of text placements. In a 3D design file, when in a front or side view, the 
grid displays T's. The T's represent the cut or fill values. The vertical part of the T is the vertical 
length of the cut or fill and the bar of the T is the text value of the cut or fill. The bar of the T is 
placed on the surface of the From TIN. Therefore, in a cut situation, a normal T is placed, while in 
a fill situation the T is inverted. 

•  Cut / Fill Grid - a lattice with a user-defined number of points determining the density with 
different element symbology for cut and fill. The lattice can be wireframe or filled color. 

•  Cut / Fill Contours (Isopach) - which are simply contours of the cut and fill depths. A fill of two 
feet is a positive two contour, while a cut depth of six would be a negative contour. A zero contour 
would be where the surface and plane intersect.  

 

1. Open the MicroStation file c:\60843\borrow_pits\s18897bpo.dgn. 

2. Select the fourth icon from the left on the Analysis tool bar, Elevation Differences. 
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3. Datapoint on the view to display difference elevations at random points. 
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> SLOPE AREAS 

The Slope Area tool displays the horizontal area and actual slope area (area following the 
terrain of the TIN File).  

 

1. Open the MicroStation file c:\60843\borrow_pits\s18897bpo.dgn. 

2. Access Applications > GEOPAK Road > DTM Tools. 

3. Tear off the Analysis tool bar. 

4. Access the fifth icon from the left Slope Areas. 

5. Select the TIN file S18897BPF.tin 

6. Click Process. 

 

7. Close the dialog. 
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> THEMES 

The four options are depicted across the top of the dialog and include (from left to right): 

•  Elevation Range - reflects ranges of elevations. 

•  Slope Range - (in terms of Percent or Degrees) describe the angles of individual triangles. 

•  Aspect Range - describe the direction that the triangle plane faces.  Aspect ranges are 
expressed in degrees. The north axis is defined as zero degrees and angles increase in a 
clockwise direction. Therefore, zero degrees points north, 90 degrees points east, 180 degrees 
points south and 270 degrees points west.  

Note A level triangle is assigned a default aspect of 360 degrees.  

 

 

As each option is selected, the dialog title changes to reflect the selection. The remainder of the main dialog 
remains unchanged.  

Set Ranges. 

Before the Themes processing commences, the user must define the desired ranges and associated 
colors. This is accomplished by clicking Set Range. 

The lower half of the dialog contains the list box, with edit fields directly below. Options are supported 
(button to the right of the list box) to Add, Modify, and Delete ranges. When the Active toggle is 
activated, the selected range is displayed or drawn when the themes are processed. A range can be 
activated or deactivated at any time during the processing by highlighting the desired line and 
changing the Active toggle. In this manner, the user has complete control over which ranges are visible 
on the screen at any one time.  

To add a single range, simply key in the desired values, select a color from the color picker, and click 
Add. The created line is added to the list box. To modify a line, highlight the desired line. The current 
values are displayed in the edit fields. Change the desired field, and then click Modify. GEOPAK 
updates the list box. To delete a line, highlight the line and click Delete. The line is removed from the 
list box. An unlimited number of ranges are supported. When more than five ranges are specified, the 
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scroll bar and arrows on the right side of the dialog are automatically invoked for easy scanning. Note 
the lines are displayed in ascending low value order, regardless of the order in which they were 
created. 

The top of the dialog supports automatic creation of ranges. Two options are supported:  

 Auto Number of Ranges - the number of ranges is specified, along with the Minimum and Maximum 
elevations (or slopes or aspects). GEOPAK divides the elevation into the specified number of ranges.  

 Auto Range Increment - the range increment is specified, along with the Minimum and Maximum 
elevations (or slopes or aspects). GEOPAK divides the elevation into as many ranges as necessary at 
the specified increment.  

By pressing one of the buttons, the value is populated within the Minimum or Maximum Elevation 
field without typing. However, in order to utilize even value ranges, it is prudent to set the Minimum 
Elevation to a number divisible by the Range Increment.  

 

 

1. Open the MicroStation file c:\60843\3D.dgn. 

2. Access the Themes tool from the DTM Analysis tool bar. 

3. Click the first icon from the left Elevation Range. 

4. Use the Browse button to select the TIN file 60843.tin. 
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5. Click the Set Range button and make the settings as shown below. 

 

6. Close the Range dialog. 

7. Toggle ON the Set Graphic Group option. 

 

8. Click Process. 

9. Review the results. 
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6 
OBJECTIVE 

In this session we will review the tools and steps for creating survey chains and profiles form existing 
graphical data. 

INTRODUCTION 
Several tools will be used to create break lines and profiles from existing graphical elements. The tools 
will include the following: 

• 

• 

• 

• 

Extract Graphics 

Import ASCII 

Chain Edit 

Convert Survey Chains 

EXTRACTION OF GRAPHIC ELEMENTS  
Graphic elements in MicroStation 2D or 3D files can be extracted.  In a 3D file where elements are 
drawn coordinate correct (X, Y, and Z), the extraction mode is used. In a 2D file, where the elevations 
are determined by tags or text labels, the interpolation mode must be used for Breaks, Contours, and 
Break Voids.  The Extract mode is used in 2D files for contours and spots.  

Extraction of elements of specified parameters include all elements visible in a view, within a fence or 
within a selection set, whether the elements are in the active file or reference files (with locate 
activated). 



Extraction of Graphic Elements 

 
Extraction Mode 

 

 

Interpolation Mode 
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Whereas the Extraction mode creates a DTM input data file from the coordinate vertices of 
MicroStation elements, the Interpolation mode must first calculate the elevations for the coordinate 
vertices of MicroStation elements. The interpolation process is applicable where elevations are not 
stored with the MicroStation longitudinal reference elements. This occurs when longitudinal reference 
elements are two-dimensional or three-dimensional, but are all drawn at a common elevation. In both 
of these topographic mapping instances, the spot elevations determine the elevations along longitudinal 
reference elements. Therefore, the dialog for the Interpolation mode has two sets of Search Criteria, 
one for the Longitudinal References and a second for the Spot Elevations. 

Spot elevations can be represented by graphical elements or text. For each MicroStation longitudinal 
reference element, GEOPAK locates the spot elevations nearest to and on either side of the element 
endpoint. Then, the elevation at the element endpoint is calculated.  

The interpolation mode is only valid for Feature Types: Breaks, Contours, and Break Voids. For 
contours within a 2D file, the associated elevation must be within the Con Z-range, more commonly 
known as "tagged." Elevations for spot elevations may be determined by textual value (if the origin of 
the text is the origin of the spot) or "tagged" elevations for other element types, i.e., zero length lines or 
cells. 

The resulting input file includes XYZ coordinates for both source spot elevations as well as for 
interpolated endpoints. Inclusion of the source spot elevations is mandatory since the spot elevation 
data often reflects important vertical topological features such as the high and low points along the 
longitudinal reference. Inclusion of interpolated endpoints is mandatory since the endpoints of 
longitudinal reference elements define changes in the horizontal topological features. These alterations 
in the horizontal topology determine break lines. 

DIALOG FIELDS 
File Name Name of DAT file to be created. 

File Type: 

ASCII 
Binary 

The advantage of the binary format is that input data is loaded much 
quicker when generating the triangulated model since the point and/or 
break line data can be read much faster from a binary file than from an 
ASCII file. However, other than reduced loading time, there are no 
functional differences between the ASCII and binary files. One 
advantage of the ASCII file format is that the file may be viewed 
and/or edited with a text editor.  

Decimal  Only valid when the ASCII File option is selected, the number of 
decimal places displayed within the file ranges from zero to six. The 
binary option defaults to double precision, with no user options. 
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File Open: 
Create 
Append 

The data file used as input to the DTM process can be created as a 
new file or the extracted data can be appended to the end of an 
existing data file. When you type the file name or use the Files button 
to access a file, the data file is not actually opened until you establish 
all entries on the dialog and press the Apply button. At that time, 
GEOPAK creates a new file or opens an existing file depending upon 
the setting of the File Open option button.  

If the File Open option is set to Create and the file already exists, an 
Alert dialog appears with the message "Overwrite existing <file 
name>?" when the Apply button is pressed. If you press OK, the 
existing file is overwritten. Pressing the Cancel button permits you to 
return to the main Extract dialog and readjust the file name or File 
Open mode.  

If the Open option button is set to Append and the file does not exist, 
an Alert dialog appears with the message "Create <file name>?" when 
the Apply button is pressed. Pressing OK results in the creation of the 
specified file. Pressing Cancel returns control back to the main 
Extract dialog. 

 

Feature Type: 

Spots 

 

 

Breaks 

 

 

Boundary 

 

 

Contours 

 

 

 

Spots are points that have no functional relationship to any other 
point. Random survey shots in open terrain would be an example of 
random spots. Point elements such as cells, circles, and text strings are 
typical MicroStation elements used to define spot elevations. Lines, 
line strings, and other longitudinal elements are equally valid. 
GEOPAK simply creates a spot elevation for each vertex of each 
longitudinal element. 

Breaks are used to designate linear features such as edges of 
pavement, ditch bottoms, ridges, etc. Any longitudinal element may be 
defined as a break line. Circular arcs are automatically segmented by 
GEOPAK in a manner consistent with the arc radius.  

A Boundary is used to constrain the external boundary of the 
triangulated model. No triangles are created outside the boundary 
polygon. In addition, any point data outside the boundary polygon is 
ignored. A boundary polygon must start and finish with the same 
point. In addition, the boundary polygon must be continuous within 
the data file. 

Contours are a special feature intended for use if the source 
MicroStation elements represent digitized or otherwise created 
contours. Use of this feature insures the integrity of the contour strata 
in the subsequent DTM. Processing of a DTM with contours classified 
as spot elevations invariably results in a DTM that, if subsequently 
contoured, will not match the original extracted contours. 
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Voids 

 

 

 

Island 

 

Graphic Triangle 

 

Drape Void 

 

 

Break Void 

Void areas are closed shapes to demarcate areas of missing data or 
obscure areas. No point or break data located within the void area is 
utilized and no triangles are created inside the void areas. The Void 
coordinates are included in the triangulation and void lines between 
successive void coordinates are inserted as drape lines on the TIN 
surface. Therefore, they do not change the slope or elevations of the 
TIN surface. 

Island - used to place triangulated data within a void, i.e., islands in 
the middle of rivers, lakes, etc. 

Graphic Triangles - by extracting as triangles, the sides of each 
triangle, in addition to the vertices are maintained. If spots are used, 
the vertices would be utilized but not the triangle sides. 

Drape Void - In the drape void, the void coordinates are not included 
in the triangulation. Voids are inserted post triangulation. The void 
coordinates and lines are draped on the TIN surface. Even though a 
user must provide an elevation for the Drape Void vertices, the user 
elevations are changed to the elevation of the TIN surface at the XY 
Drape Void coordinate position. 

Break Void - A void utilizes the elevations of each vertex, while the 
void lines between successive void coordinates are inserted as break 
lines. Therefore, break voids change the slope and elevations of the 
TIN surface. 

Mode: 
Extraction or 
Interpolation 

The Extraction mode determines XYZ data directly from the 
coordinate values of three-dimensional MicroStation elements. The 
Interpolation mode, by contrast, derives XYZ data by locating spot 
elevations on longitudinal MicroStation elements and interpolating. 
Hence, the Interpolation mode can be applied to both two-
dimensional as well as three-dimensional MicroStation files as long as 
a Z-coordinate reading can be ascertained from the spot elevations.  

Stroking Utilized in the interpolation mode, this shortcut button to the Settings 
> Stroking dialog may be used. Changing the dialog from either 
location automatically updates the dialog in the other location. For a 
detailed discussion, refer to the Settings > Stroking documentation. 

Select Criteria 

 

Before extracting MicroStation elements, a description of the desired 
elements must be defined in terms of element types, levels, colors, 
weights and styles. Not every extract operation requires the definition 
of every parameter; only enough parameters to uniquely differentiate 
the desired element from all other graphical elements in the 
MicroStation file. For example, if the elements desired for extraction 
are only present on level 25, then only the level parameter need be 
defined. To the left of each parameter label is a toggle. If the toggle 
for any parameter is deactivated, GEOPAK assumes that the full range 
of settings for this parameter is available. For example, if the Colors 
toggle is deactivated, GEOPAK searches for all colors: 0-256.  

Similarly, a deactivated Colors toggle is equivalent to an activated 
Colors toggle and a key-in of 0-256. If a toggle is activated and no 
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values given, GEOPAK searches for nothing, therefore, be sure if a 
toggle is on that values are defined. 

Level 
Weight 
Styles 
Types 
Colors 

If specific parameter settings are to be considered, the toggle must be 
activated. Once activated, the associated Select button becomes 
available. Simply toggle on the desired parameter, the click Select. 
The Mask dialog is displayed, wherein the desired parameter settings 
may be identified. You may select as few or as many parameters to 
identify the desired elements.  

When the Type > Cell option is activated, all cells with the other 
specified parameters (i.e., level, color, weight) are utilized. However, 
if the Cell option is activated and a cell name is typed into the field to 
the right of Cell toggle, then only the named cell with the other 
specified parameters is utilized. For example, if level 40 is specified in 
the Level Mask, and two cells, SPOT and X are located on level 40, 
and no cell name is specified in the cell field, then both cells are 
extracted. However, if SPOT is typed into the field, then only the 
SPOT cells are extracted, although other cells are located on level 40. 

The Text String also has two options: Origin and Content. When the 
Text String toggle is activated and the option is set to Origin, 
GEOPAK utilizes the origin of the text as the x, y, z coordinates for 
extraction. If the Content option is specified, the x, y coordinates are 
derived from the text origin. However, the z value is not the z value 
within a 3D file, but the actual value of the text, whether a 2D or 3D 
file. 

Match The Match tool is a method of determining and adding the symbology 
of elements to be extracted to the Mask dialogs. First, activate the 
desired toggle(s) to the left of the Select Criteria. Then click Match. 
You are prompted to select the desired element. After identifying and 
accepting the element, its select criteria is added to any criteria whose 
toggle is activated. In addition, any elements of the specified 
parameters are highlighted. The Match button can be utilized 
numerous times to select additional elements. The information is 
appended to the Mask dialogs until the Reset button in the dialog is 
pressed, (which clears all active criteria selections).  

Display Clicking Display displays all elements of the current parameters.  

Reset The Reset button clears all Mask dialogs, so a new match procedure 
may commence.  

Tolerance 
(Interpolation mode only) 

If a spot elevation is within 0.75 master units of a longitudinal 
reference, the software projects the spot onto the reference 
(perpendicular) element and uses the elevation to interpolate. 

Extract Method: 
View 1, 2, ……. 

 

 

The View method extracts every element that is visible in the 
specified active view and satisfies the select criteria. This includes 
elements in both the active as well as reference files if the Locate is 
activated. Simply set the desired View number before pressing the 
Apply button. 
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Fence 

 

 
Complex Chain 
Selection Set 

The Fence method extracts every element that satisfies both the fence 
criteria as well as the selection criteria defined via the Select Criteria 
group box. All MicroStation fence options are supported. Place the 
fence prior to pressing the Apply button. 

Complex Chain - The Select Criteria group box disappears from the 
dialog, since you identify the elements via the cursor; and no file-wide 
searches are involved. Also, notice that the ID Element button 
appears adjacent to the Extract method option button. This button 
initiates the "chaining" of MicroStation elements. The following 
outlines the sequence of operations associated with the Complex 
Chain method.  

1. Establish the desired dialog settings. 

2. Adjust the Extract method option button to Complex Chain. 

3. Press the ID Element button. 

4. Identify and accept the first element that constitutes the beginning of the chain. 

 Selection of subsequent elements is identical to the operation of the 
MicroStation automatic create complex chain command. Successive 
connected elements are highlighted one at a time for inclusion or 
rejection as long as the endpoint of the next element is within a 
specified tolerance to an endpoint of the current element. The 
Tolerance is specified on the MicroStation Automatic Create Complex 
Chain palette. After the first element is selected and accepted, the next 
connected element is highlighted. 

 If more than a single element is located within tolerance to the next 
element endpoint, the message "Fork Accept/reject" appears in the 
MicroStation prompt field. A data point accepts the highlighted 
element. Pressing the reset cursor button rejects the highlighted 
element and highlights another one. 

 Once the end of the chain is reached or the user presses the reset 
cursor button when no more connecting elements are available, the 
identification of component chain elements is complete. At the 
completion of the selection process, the Apply button becomes 
available. The extraction of elements to a DTM input file commences 
when the Apply button is selected. 

Selection Set - This method is identical to the Complex Chain in 
every aspect other than the actual selection of elements. The Selection 
Set method employs the MicroStation Selection Set tool to identify 
the element(s) for processing. This method is particularly useful when 
selecting a single element or a group of disjointed elements few in 
number. The following outlines the sequence of operations associated 
with the Selection Set method.  

1. Establish the desired dialog settings. 
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Importing ASCII files 

 

2. Adjust the Extract method option button to Selection Set. 

3. Click ID Element. 

4. Identify the element(s) comprising the selection set. If more than one element is 
being selected, the control key on the keyboard must be utilized during the 
selection process. 

5. At the completion of the selection process, the Apply button becomes 
available. The extraction of elements to a DTM input file commences when 
Apply is clicked. 

Apply Commences the extraction procedure. Note that the dialog should be 
filled in completely, and the Extract mode selected and applicable 
fence, view, selection set or complex chain identified prior to clicking 
Apply. 

 

IMPORTING ASCII FILES 
All data must be imported into database before mapping, writing to DTM, etc. can be done. Although 
this seems like an extra step, the benefits of a binary database, rather than ASCII OBS/XYZ files as the 
repository of all information, is worth the extra toggle. 

Having the multiple datasets incorporated into a single database provides the following benefits: 

• 

• 

• 

Multi Point Editing- Change multiple points simultaneously by editing their Feature, 
Description, Zone, PCode, etc. 

Display by Set Search- Display uses the Set Search to select what items are displayed. 

Editing simultaneously in different runs. 

The ASCII data extracted from the graphics can be imported using a dataset that specifies X, Y, Z 
information. 
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Survey Chains 

 
SURVEY CHAINS 

CHAIN EDITOR 
The Chain Editing tool enables existing chains to be modified and allows the creation of new chains. 
When the dialog is first loaded, the existing survey chains, if any, will be loaded into memory and the 
dialog will contain the first chain. The most common editing sequence of chains occurs when points 
need to be deleted or added to a chain or when the Geometry of the chain needs to be modified. The 
Geometry of a chain is controlled by the Geometry (Point or Curve) of the individual points which 
comprise the chain. Chains may be a combination of straight lines, circular arcs, or spline curves. The 
following table explains how the Geometry of a chain is constructed: 

Geometry 
Code 
Sequence 

Resulting Element 

P-P... Line. Two or more consecutive P's cause a line element to be 
generated. 

C-C-C Circular Arc. Exactly three consecutive C's cause a circular arc to be 
generated that passes through each of the points. 

P-P-C-P-P Line-Circular Arc-Line. The combination of two P's, exactly one C 
followed by two P's causes a circular arc to be generated that is tangent 
to both of the lines and that passes through the C point. 

C-C-C-C Curve String. Four or more consecutive C's cause a curve string to be 
generated that passes through each of the points. 

Once the chains have been edited and the dialog is closed, the user will be prompted to save the chain 
edit or not. If the edits are saved, a backup file will optionally be written. 
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Convert Survey Chains 

 
The dialog consists of the Name, Feature, Station, Description, Attribute and Zone. The Name field 
is the currently selected chain. A chain name may be selected from the list or sequenced by use of the 
Next Chain and Previous Chain buttons to the right. The Feature field holds the feature name of the 
currently selected chain. The feature of the chain may be changed by keying in another feature into this 
field. The Station field is the starting station of the currently selected chain. The station may be 
changed by entering a new station value into this field in the format of 1+25.48. The Description field 
is the description of the currently selected chain. If a different description is to be associated with that 
chain, then enter the new description value into the field. 

The Attribute option button depicts the DTM attribute the chain is in. The Zone option button to the 
left of the Attribute option button depicts which zone the chain is in. For data collectors that do not 
support this field, it is defaulted to one. 

Icons or processing buttons located across the top of the dialog are described in the table below and 
process an entire chain, rather than a single vertex as in the case of the Chain Points group box 
processing. 

 

CONVERT SURVEY CHAINS 
The Convert Survey Chains tool creates COGO chains (alignments) and optionally profiles from 
survey chains.  

 

 

The COGO Input File field is the name of the ASCII input file (maximum of five characters) to be 
generated for subsequent processing via GEOPAK Coordinate Geometry. The Job Number from the 
project is appended to the end of this name and the extension is in the form of .IOC where OC is the 
operator code as entered for the project. For example, if the name of the input file name was keyed in 
as CGO and the current Job Number was 99 and the current Operator Code was ZZ, then the file would 
be named COGO99.IZZ. Note when the COGO Input File is populated, the input file name is added to 
the Title Bar. Below the COGO Input File field is the option to Create File or Append to an 
Existing File. 

In the case where the file name already exists and the Create File option is selected, the user is 
prompted to overwrite the existing file, while the Append to an Existing File will add the new data to 
the bottom of the existing file. 
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LAB EXERCISE: SURVEY CHAINS 

> EXTRACT GRAPHICS 

1. Open the MicroStation file c:\60843\17059\sdt17059hw.dgn. 

2. Create and open a Survey project named 17059. 

 

3. From the main Survey Menu bar select DTM > DTM Tools. 

4. Create a new run called Breaks. 

 

5. Select the Extract Graphics tool. 

6. Enter a file name for the DAT file of Breaks. 
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Lab Exercise: Survey Chains 

 
7. Make the settings as shown below. 

 

8. Click Apply. 

9. Close the DTM Tools. 

 

> IMPORTING ASCII 

1. From the main Survey Menu bar select Dataset > New. 

2. Create a new dataset named Breaks. 
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Lab Exercise: Survey Chains 

 
3. Use the Dataset Add to browse and add the Breaks.dat created in the previous step. 

 

4. Click OK. 

5. Make the settings as shown below. 

 

6. Click Process. 

7. When prompted for a beginning point number key-in point 1 and click OK. 

 

8. Once the import is complete close the import dialog. 
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> CREATE SURVEY CHAINS 

1. From the main Survey Menu bar select Geometry > Chains > Edit. 

2. Click through the following prompt to begin adding chains. 

 

3. Once in the Chain Edit dialog click on the icon for New Chain. 

4. Enter the information as shown below. 

 

5. Using MicroStation’s Power Selector place all of the points for a single break line into a selection 
set. 

6. Click on the Add Points button. 

 

7. Click on the Create Chain button. 
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8. Repeat these steps form the remaining 3 break lines incrementing the name by 1. 

9. Close the Add Chain dialog. 

10. You should now have 4 Survey Chains listed in the chain pulldown in the Chain Edit dialog. 

 

11. Close the Chain Edit dialog. 

 

 

> STORING CHAINS & PROFILES 

1. From the main Survey Menu bar select Geometry > Chains > Convert Survey Chains. 

2. Make the settings as shown below. 

 

3. Close the Convert Survey Chain dialog. 
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4. From the main Survey Menu bar select Geometry > Navigator. 

5. Set the Navigator Element Toggle to Profiles. 

 

6. Highlight a single ditch or all ditches and click the Print/Describe icon. 

7. Review the profiles in the main COGO window. 

 

8. Exit MicroStation. 

Lab Exercise: Survey Chains                     6-16                 Jan-08 
Copyright © 2008 Bentley Systems Incorporated 



Geodetic Conversions 

Objectives                     7-1                 Jan-08 
Copyright © 2008 Bentley Systems Incorporated 

7 
OBJECTIVES 

This chapter will focus on converting coordinates from one system to another. 

INTRODUCTION 
The processes involved in converting coordinates are relatively simple once an understanding is gained 
of the various tools in GEOPAK and their uses. In this session we will use several different tools 
within GEOPAK as outlined below. 

GEODETIC CONVERSIONS 
The Geodetic conversion utility performs many of the common computations encountered when 
working with geodetic and grid coordinate systems. Points can be individually entered and converted 
or multiple points from a coordinate geometry database (GPK file) can be converted via batch mode. 
All output is directed to an ASCII report file, in addition to a resizable output window. 

 
GEOPAK's conversion tool supports a wide variety of conversions of latitude / longitude, grid 
coordinates in different zones, and systems (assuming they have a common ellipsoid). In addition, 
optional scale factors may also be utilized. 



Conversion Operations 

 
CONVERSION OPERATIONS 

A wide variety of conversion operations are supported including: 

•  converting latitude and longitude to grid coordinates. 

•  converting grid coordinates to latitude and longitude. 

•  converting grid coordinate from one zone to grid coordinates in another zone. 

•  converting grid coordinates from one system to another system. Note that both systems must   
have a common ellipsoid. 

•  computing grid scale factor and convergence angle for grid coordinates. 

•  computing geodetic forward and back azimuth and distance between two geodetic positions. 

•  Computing grid azimuth and grid distance in addition to geodetic forward and back azimuth 
and distance between two points in the same zone. 

•  Computing the line grid scale factor and combined scale factor if elevation data is entered. 

 

SUPPORTED SYSTEMS AND PROJECTIONS 
Several common systems and projections are supported including the following: 

•  HPGN State Plane. 

•  1983 State Plane Coordinate systems (all zones). 

•  1927 State Plane Coordinate systems (all zones). 

•  Universal Transverse Mercator system (all zones, northern and southern hemisphere). 

•  Latitude / Longitude. 

•  User-defined zones based on either the Lambert Conformal or the Transverse Mercator 
projection. 

•  Variety of ellipsoids are supported for the user-defined and UTM projections. 

•  New Zealand Map Grid (1949). 

•  New Zealand Local Circuits (1949). 

•  New Zealand Local Circuits (2000). 

Conversion Operations                     7-2                 Jan-08 
Copyright © 2008 Bentley Systems Incorporated 



File Conversions 

 
Three options are supported for the Vertical Datum: 

•  Not Defined. 

•  NAVD 88. 

•  NAVD 29. 

FILE CONVERSIONS 

 
Input Coordinate System 

This group box includes System type, Ellipsoid, and Zone. As each system is selected, the ellipsoid 
and zone unghost as needed. For example, when 1983 State Plane is selected, the Ellipsoid is ghosted, 
however, a Zone must also be selected from the list. However, when Latitude / Longitude option is 
selected, the Zone field is not present, however, the Ellipsoid is unghosted, as depicted in the sample 
below. 

Output Coordinate System 

The right side of the dialog contains the Output Coordinate System, which has the same fields as the 
Input Coordinate system. Note, however, not all combinations can be converted. For example, when 
converting from UTM to Latitude / Longitude, GEOPAK must utilize the same ellipsoid. Therefore, 
when the ellipsoid option is selected in either coordinate system group box, the other ellipsoid 
dynamically changes to stay in sync. If a selected combination is not supported, i.e., changing from 
1927 to 1983 state plane coordinates, GEOPAK changes the Output coordinate system after the user 
has selected Input coordinate system to reflect a supported option. The opposite is also true, i.e., 
GEOPAK changes the Input coordinate system after the user has selected the Output coordinate 
system. 

File Conversions                     7-3                 Jan-08 
Copyright © 2008 Bentley Systems Incorporated 



Point Conversions 

 
Job No. 

GEOPAK database (gpk file) wherein the points to be converted are stored. The list reflects all gpk 
files in the current directory or project. 

List box 

After selecting the Job No., GEOPAK displays all point numbers and associated information in the list 
box. To convert, simply highlight as few or as many points as desired. Points can be highlighted either 
of the two icons directly below the Job Number. Options include getting points from a MicroStation 
selection set or from the COGO navigator. 

Convert Points 

Commences the procedure. Once converted, the Geodetic conversion Output window is displayed. 

If a conversion not supported by GEOPAK is attempted, an information message is displayed. 

 

POINT CONVERSIONS 

 
Pt. A Coordinate System 

This group box includes System type, Ellipsoid, and Zone. As each system is selected, the ellipsoid 
and zone un-ghost as needed. For example, when 1983 State Plane is selected, the Ellipsoid is ghosted, 
however, a Zone must also be selected from the list. However, when Latitude / Longitude option is 
selected, the Zone field is not present, however, the Ellipsoid is un-ghosted 
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Point Conversions 

 
Pt. B Coordinate System 

The right side of the dialog contains the Pt. B Coordinate System, which has the same fields as the Pt. 
A Coordinate system. Note, however, not all combinations can be converted. For example, when 
converting from UTM to Latitude / Longitude, GEOPAK must utilize the same ellipsoid. Therefore, 
when the ellipsoid option is selected in either coordinate system group box, the other ellipsoid 
dynamically changes to stay in sync. If a selected combination is not supported, i.e., changing from 
1927 to 1983 state plane coordinates, GEOPAK changes the Pt. B coordinate system after the user has 
selected Pt. A coordinate system to reflect a supported option. The opposite is also true, i.e., GEOPAK 
changes the Pt. A coordinate system after the user has selected the Pt. B coordinate system 

Pt. A. 

Point Name (or Number) and associated data. Note the fields are determined by the Pt. A Coordinate 
system option. When the option is changed, these fields dynamically change to reflect the selection. 
For example, when 1927 State Plane is selected as Pt.  

Note that Meters, U.S. Foot and International Foot are supported in coordinate systems that require 
units. In addition, Elevations are also supported. However, when Latitude / Longitude is selected, the 
dialog changes. 

Pt. B 

The second set of data, with the same options as Point A. Note that when the Convert toggle is active, 
the results of converting Point A are displayed in Point B. If the Inverse toggle is active, then the 
geodetic distance and direction between Points A and B are computed and displayed in the output 
window. 

Convert / Inverse Toggles 

Determines the type of processing and affects the action buttons directly below. If Convert is active, 
the user supplies all information regarding Pt. A, the Pt. B Coordinate System options and the Pt. B 
Name. When the Convert > button is pressed, GEOPAK converts the Pt. A data into the specified Pt. B 
system, and populates all fields in the Pt. B group box except the Name. The < Convert button 
commences the opposite process. It utilizes Pt. B data and converts to Pt. A coordinate system. Once 
converted, the Geodetic conversion Output window is displayed. 

If a conversion not supported by GEOPAK is attempted, an information message is displayed. 

When the Inverse option is active, GEOPAK computes the geodetic distance and direction between Pt. 
A and Pt. B. note the arrows on the Inverse > and < Inverse buttons are important as they dictate the 
direction. The Inverse > button inverses from Pt. A to Pt. B, while the < Inverse button inverses from 
Pt. B to Pt. A. To inverse, all associated data for both points must be supplied. The results of the 
inverse are displayed in the output display window 
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DEM CONVERSIONS 

 
Other data sources utilized in the Geodetic Coordinate conversions tools are the various DEM formats 
including DEM, SDTS, and DTED. "A Digital Elevation Model (DEM), consists of a sampled array of 
elevations for ground positions that are normally at regularly spaced intervals. The basic elevation 
model is produced by or for the Defense Mapping Agency (DMA), but is distributed by the USGS, 
EROS Data Center, in the DEM data record format." A wealth of information on DEM formatted data 
can be obtained from www.usgs.gov. When the DEM option is selected in the center section of the 
dialog, the dialog changes to reflect the selection.  

Within the Input DEM File group box, the data format is selected. The group box changes based on the 
selection. Once the selection is made, the File Name may be typed in, or selected via the Files button. 
Each format is discussed in subsequent sub-sections.  

Once the file is read, the DEM Coordinate system group box is populated automatically. Therefore, the 
DEM Coordinate System group box is display only and the values cannot be edited. 

The Output Coordinate system box includes System type, Ellipsoid, and Zone. As each system is 
selected, the ellipsoid and zone unghost as needed. For example, when 1983 State Plane is selected, the 
Ellipsoid is ghosted, however, a Zone must also be selected from the list.  

When Latitude / Longitude option is selected, the Zone field is not present; however, the Ellipsoid is 
unghosted. 

The Vertical Datum options include NAVD88, NAVD 29 or may be Not Defined.  

Supported Horizontal and Vertical Units include Meters, U.S. Ft., and Int'l Ft. 

The Output DAT File group box has a single key-in field for the file name of the DAT file to be 
created. This file can be used within the Build Triangles dialog in the DTM tools. Manually enter the 
file name or select via the File button. 

When the dialog is completely populated, click Apply in the center bottom of the dialog to commence 
processing. 
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Global Geodetic Data 

 
GLOBAL GEODETIC DATA 

The dialog below allows the user to set a global geoid to use when converting. 

 

SCALE, ROTATE, TRANSLATE 
The Translation and Rotation tool translates and/or rotates the coordinate values of geometric 
elements.  A variety of options to specify the distance and direction of the translation, as well as 
several rotation methods provide maximum user flexibility.  
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ELEMENT SELECTION 

The top of the dialog displays the variety of COGO elements which can be translated, rotated or 
scaled. To utilize an element, simply activate the toggle to the left of the element name. Then populate 
the input field with the names of the elements. This can be done by three methods: 

Manual  

 Type in the names separated by comas. For a range, utilize a hyphen.  

Get Elements from Navigator 

For elements from the navigator, access the COGO navigator and highlight the desired element names. 
Then click Get Elements from Navigator. GEOPAK automatically populates the dialog.  

Get Elements from MS Selection Set 

Place the desired elements in a MicroStation selection set, activate the desired element toggles, and 
then click Get Elements from MS Selection Set. GEOPAK scans the selection set and populates the 
dialog automatically.  

INCREMENT / OVERWRITE 
When storing new points, the increment must be specified. This value is added to each existing 
element to obtain the translated element name. If the points are overwritten, no new point number is 
required; hence, the field is not shown. 

PROCESSING 
The rest of the dialog consists of the three types of processing supported in this dialog: Translate, 
Rotate, and Scale. More than one type may be processed simultaneously. For example, elements can be 
just translated, or just rotated, or translated and rotated and scaled. Activate the desire toggles, and then 
populate the appropriate fields.  

TRANSLATE 
Translate 

When active, translation is part of the processing. 

Methods 

Four methods are supported. When selected, the dialog dynamically changes to reflect the selection. 
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Rotation 

 
Direction / Distance 

In this option, the distance direction each point is moved is specified. A variety of directions are 
supported.  

Options include Azimuth, Bearing, QDD.MMSS, two points, and direction ahead or back of curves or 
spirals. The direction of the chord of a curve or spiral is also supported. The distance options include: 
two points, curve radius, chord, length, or tangent, and spiral chord, short tangent, and long tangent. 

Pa to Pb 

The distance and direction between the two specified points are used to translate all points, moving 
them by the same distance and direction. 

Delta North/East/Elev. 

All points are translated by the change in coordinates, i.e., change in North, East, and Elevation. Note: 
For those not needed, set the Delta to 0.00. 

Coordinate Value 

The distance and direction from the Translation Point to the Desired North and East is determined, 
then all points are moved the same distance and direction. 

ROTATION 
The second type is Rotate, which can be utilized by activating the toggle to the left of Rotate. Two 
methods are supported for rotation. The dialog dynamically changes as each is selected. 

Pa to Pb To Bearing 

In the About Point, specify a previously defined point. In addition, two points (Point Back and Point 
Ahead) are specified, and GEOPAK computes the direction between them. It then determines the 
rotation angle by comparing the computed direction and the desired bearing. 

Angle 

In the About Point, specify a previously defined point. The rotation angle is specified with an optional 
add-on. 

SCALE 
The third type is Scale, which can be utilized by activating the toggle to the left of Scale.  

All elements are scaled utilizing the specified scale factors. If scaling is not desired for one factor, set 
the value to 1.00 (default). All scaling is done about the specified point. 

When the dialog has been populated, clicking Apply commences the procedure. 
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Place Coordinate Table 

 
PLACE COORDINATE TABLE 

The Place Coordinate Table tool draws a table using COGO points based on user-defined parameters.   

One use of the table is to create a list of geodetic data including latitude, longitude, geoid height, etc. 

 
 

The table will appear similar to the one below. 
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LAB EXERCISE: COORDINATE CONVERSIONS 

> CONVERTING FROM LATITUDE / LONGITUDE TO DECIMAL DEGREES 

1. Open the MicroStation file C:\60843\coord_conversion\s71741.dgn. 

2. Select Applications > GEOPAK Survey > Survey. 

3. From the main Survey Menu bar select Project > Preferences. 

 
4. On the Project Preferences dialog select Default > Open and select the file 71741.spp. 

Note This is a project preference file with default settings for this project. 

5. Click OK. 

6. From the main Survey Menu bar select Project > New and create a new project. 

 
7. Click OK. 
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Lab Exercise: Coordinate Conversions 

 
8. From the main Survey Menu bar select Geometry > Conversions > Geodetic. 

 
9. Set the radio button in the middle of the dialog to File. 

10. Prior to processing, be sure that the correct GEOID 03 files have been downloaded.  

http://www.ngs.noaa.gov/PC_PROD/GEOID03/index.shtml

g2003u08.bin 

g2003u07.bin 
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Lab Exercise: Coordinate Conversions 

 
 

11. From the Geodetic Coordinate Conversion dialog select Global Geodetics > Set Global Geodetic 
Data. 

12. Make the settings as shown below. 

 
13. Click OK. 

14. Make the remaining settings as shown below. 

 
Note The File Delimiter should be set as a space. 
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Lab Exercise: Coordinate Conversions 

 
15. Before converting the data we will define a point range in COGO. From the main Survey Menu 

bar select Geometry > Classic COGO. 

16. Select Element > Next Available Settings and provide a beginning point as shown below. 

 
17. Click Apply. 

18. Return to the Geodetic Conversion dialog and select File > Output to GPK. 

19. Select the gpk file as shown. 

 
20. Click OK. 

21. Click Convert Pts. On the main Geodetic Conversion dialog. 
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Lab Exercise: Coordinate Conversions 

 
22. Review the Geodetic Conversion Output. 
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Lab Exercise: Coordinate Conversions 

 
23. Open Navigator and review the points in COGO. 
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Lab Exercise: Coordinate Conversions 

 
> CONVERTING METRIC PROJECT COORDINATES 

1. Open both Navigator and Geometry > Conversions > Translate/Roatate/Scale. 

2. Toggle ON the Points option and set the Scale options as shown below. 

 
3. Now highlight the points in Navigator. 
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Lab Exercise: Coordinate Conversions 

 
4. Use the icon on the top right of the Rotation Translation dialog to populate the points. Be sure to 

set the Increment value in order to preserve the original points. 

 
5. Toggle ON the Scale option and enter the scale factors. 

6. Click Apply and scale the points. 

7. Review the coordinates in the Navigator. 

 

Lab Exercise: Coordinate Conversions                     7-18                 Jan-08 
Copyright © 2008 Bentley Systems Incorporated 



Lab Exercise: Coordinate Conversions 

 
> CONVERTING IMPERIAL PROJECT COORDINATES 

Note It may be desirable to create a copy of the GPK file at this point since we are going to create 
Imperial coordinates. 

1. In the Translation and Rotation dialog change the Increment value to 2000 in order to preserve the 
original points. 

2. Toggle OFF the Scale option and toggle ON the Translate option. 

 
Note Be sure to use the original points 101-106. 

3. Click Apply to translate the points. 

4. Toggle OFF the Translate option and toggle ON the Scale option. 
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Lab Exercise: Coordinate Conversions 

 
5. In Navigator highlight the 2000 range points. 

 
6. Use the icon at the top of the Translate and Rotate dialog to bring in the point numbers. 

7. Change the toggle from Increment to Overwrite. 
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Lab Exercise: Coordinate Conversions 

 
8. Set the scaling options as shown below. 

 
9. Click Apply to scale. 
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Lab Exercise: Coordinate Conversions 

 
10. Now change the scaling options as shown below and scale again. 

 
11. Review the points in Navigator. 
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Lab Exercise: Coordinate Conversions 

 
> CONVERTING TO NGVD29 

1. In COGO set the Next Available Point to 3001. 

 
2. Click Apply. 

3. Access the Geodetic Conversion application and make the settings as shown below. 

 
4. Select File > Output to GPK and select the gpk file. 

 
5. Click OK. 

6. Click Convert Pts. 
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Lab Exercise: Coordinate Conversions 

 
7. Review the points in COGO. 

 
Note The XY for this range can be converted to whichever project they will be used with. 
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Lab Exercise: Coordinate Conversions 

 
> REPORTING 

1. From the main Survey Menu bar select Plans Preparation > Place Coordinate Table. 

2. Make the settings as shown below. 

 
3. Highlight the points 101-106. 

4. Click the Place button. 

5. Open and review the text file coord.txt. 

 
6. Exit MicroStation. 

Lab Exercise: Coordinate Conversions                     7-25                 Jan-08 
Copyright © 2008 Bentley Systems Incorporated 



Least Squares Adjustments 

Objective                     8-1                 Jan-08 
Copyright © 2008 Bentley Systems Incorporated 

8 
OBJECTIVE 

This session will focus on adjusting traverse data using the Network Least Squares Adjustment in 
GEOPAK Survey. Also covered will be how to export various geometrical components to Carlson. 

 

INTRODUCTION 
The tools used for adjust traverses are located within GEOPAK Survey. A survey project will retain all 
settings made regarding adjustment options. 

 

NETWORK LEAST SQUARES 
Least Squares allows the computation of coordinate standard errors and error ellipses. While this 
information can be of use, for many applications they are not required. If the Compute coordinate 
standard errors or error ellipses option is off, the Least Squares reduction process operates faster as 
less computations are necessary. 

Robustness is a re-weighting technique used in least squares in an attempt to identify blunders. It is 
simple strategy, which uses the residuals (amount of adjustment), in making the weaker data have less 
effect on the adjustment by giving the weaker data larger error estimates.  

In the process of reducing data, the error estimates can be automatically derived from repetition error 
or defined by user input. Pressing the Error Estimates button opens the dialog depicted below. 

 



Network least Squares 

 
If the Error Estimates option is set to User Defined, then these error estimates are utilized instead of 
error estimates automatically computed from repetition error. If From redundant measurements + 
Add Ons is selected, then the error estimates are automatically computed from repetition error. 

The entered error estimates are utilized without any influence from repetition. That is, if a particular 
angle was measured multiple times, a single user defined error estimate will be used instead of one 
being computed from repetition error. 

 

To the right of the Error Estimation group box is the Add-On group box. If the From Redundant 
Measurements + Add Ons is selected, then these values will be considered add-ons to the errors from 
repetition for least squares error estimation. For example, if a horizontal distance repetition error is 
0.003 m and 0.003 m is specified as the Distance Constant add-on, then the error estimation for that 
shot will be 0.006 m. Notice that there is a separate constant for Distance PPM and Trig Level PPM 
since Trig Elev differences usually erode in accuracy quicker as a function of distance when compared 
to the horizontal distance.  

Located below the User Defined group box, the Setup Error is added to all horizontal angle and 
azimuth measurement error estimates, both from repetition and user defined, and is computed by the 
tangent inverse of the setup error divided by the length of the line. Shorter lines get a larger error added 
to them whereas long lines get essentially no additional error added to them. For example, a 0.005 
setup error amounts to 21 seconds in 50 ft., 2 seconds in 500 ft., and 0.2 seconds in 5000 ft. Since the 
Setup Error is always applied, set it to 0.0 to force non-application if you do not want to use it. One 
may think of setup error as the ability to setup over a point with the tripod and optical plummet. 
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Lab Exercise: Field Traverse 

 
 

LAB EXERCISE: FIELD TRAVERSE 
> LEAST SQUARES ADJUSTMENT 

1. Open the MicroStation file c:\60843\coord_conversion\s71741.dgn. 

2. Access the survey project 71741 via GEOPAK Survey. 

3. From the main Survey Menu bar select Dataset > New. 

4. Make the settings as shown below. 

 
5. Use the Add Source File icon to select the file strv71741.RW5. 

 
6. Click OK. 
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Lab Exercise: Field Traverse 

 
7. Select from the main Survey Menu bar Dataset > Control Editor. 

 
8. Review the control points in the ctl file.. 

9. Close the Control Editor. 

10. Select from the main Survey Menu bar Dataset > Reduce. 

11. Verify settings below and click Process on the reduction dialog. 

 
12. Click OK on the following dialog. 
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Lab Exercise: Field Traverse 

 
13. Review the reduction report. 

 
14. Close the report dialog. 

15. From the main Survey Menu bar select Geometry > Navigator and review the points. 
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Lab Exercise: Field Traverse 

 
16. Using the reports located at Dataset > Review Reports, review the horizontal and the vertical 

adjustment reports. 

 
17. Close the report dialog. 
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Lab Exercise: Exporting Data 

 
LAB EXERCISE: EXPORTING DATA 

> EXPORTING GEOMETRY 

1. Open the MicroStation file c:\60843\su60843.dgn. 

2. Open the project c:\60843\60843 using GEOPAK Survey. 

3. Use the User Name Mary. 

4. From the main Survey Menu bar select Geometry > Export > LandXML1.0 Geometry. 

 
5. Provide a Project Name, Description and export File Name. 

6. Set the Output Mode to Create. 

7. Set the English Unit to Survey Feet 

8. Set the Element Type to  Chains 

  
9. Use the Chain pulldown and select MAINLINE 

10. Click Export. 

Note This XML file can now be downloaded into Carlson to create a CL file. This will give you 
access to horizontal alignment data without having to key it into Carlson. 
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