CHAPTER 5

Horizontal Alignment Tools

5.1 Introduction

Objectives

Create and store horizontal chains using MicroStation elements.

Project Manager
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Menu Bar Application

GEOPAK Road > Geometry > Layout Alignments Horizontal

The Horizontal Layout Tools enable the user to create or modify horizontal geometry (using numerous
tools) including placing spirals, curves, tapers, specified bearings and curves, complex ramp loops
and connectors, and all to user-defined parameters.

When selected, a dialog box is invoked that gives the user a chance to utilize either GEOPAK 98
(Graphic Element Based) or GEOPAK 2000 (COGO Element Based) design tools as depicted below.

| GEOPAK Alignment Startup Option

Horizontal Alignment Tool Compatibility;
| COGO Element Based Mew] |

[T Don't ask me anymare

oK I

Cahicel |

NOTE: When set to COGO Element Based (New), an active session of COGO must be
active.
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Once Horizontal Alignment Generator is selected, the dialog box below appears.

EHmizuntal Alignment Generator ....:"E.j

File Design Tables Tools
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When User > Preferences is selected the User Preferences dialog box below appears and allows
the user to set certain preferences.

Cateqary
E lement Syum | V' Line Symbology
Line W| Curve Symbology

Curve _
Spiral ¥ Spiral Symbalogy

Congtruction Line Grouping: | Mone vl
COGO Element M arnes
Curve Design Tablez
Spiral Deszign Tables
Geometry Settings
Diynamic [ncrements

The Design Tables option allows the user to set up Design Tables for Symmetrical 3 Centered
Curves, Asymmetrical 3 Centered Curves, Taper Curves, and Spiral Curves. These files are stores in

an ASCII format.

EHulizuntal Alignment Generator __Jl_(_j

Fie [N Toos

Sermmetrical 3 Centered Curve

Asymmetrical 3 Centered Curve
Taper Curve
Spiral Curve

The Tools option allows the user to open the Main dialog box or any of the dialog boxes needed do
store a Horizontal Alignment.

E Horizontal Alignment Generator ..?Ej

File Design Tables !m@

Lines / Curves
Curve Combinations

Spiral Combinations
Cornplex Tranzitions
Aligriment
Ianipulate

Values within the dialog boxes dynamically change simultaneously with dynamic graphic
modifications.

Spiral and compound curve commands do not support dynamic manipulation.
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5.2 Lines/Curves Tools
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The Place Line / Curves Commands are detailed in the table below.

Store Line By 2 Points

The store line by two points command requires two new points and a new line. The command
draws the line and the new points.
Store Tangent Line

The Store Tangent Line tool stores a line and its two endpoints in the coordinate geometry
database.

Store Curve By 3 Points
The Store Circular Curve by Three Points tool stores a circular curve (using chord definition).
Store Curve By Center

This tool enables the user to store a circular curve by defining the center point, radius, and
sweep angle.

Store Tangent Curve Unconstrained

The Store an Unconstrained Tangent Curve tool places a curve through a specified point
tangent to the specified curve or line.

Place Curve Between Two Elements

This tool enables the user to store a circular curve between two elements. Options include
offsets, truncate, and the ability to modify once the first curve is displayed.

Place Simple Transition Element

This tool enables the user to draw a transition element between two arcs. Options for the
Transition element include: Tangent, Curve, or Spiral. As the Transition option is changed, the
dialog box dynamically changes to reflect the selection.
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5.3 Curve Combinations Tools

Curve Combinati... x|

The Curve Combinations Commands are detailed in the table below.

Place Compound Curves
This tool enables the user to draw a compound curve between two elements.
Place Three Centered Curves

This tool enables the user to draw a three-centered curve between two elements. The Design
Vehicles group enables the user to select the desired vehicle, based on the data from files stored
in the User Preferences.

Place Reverse Curves

This tool enables the user to store reverse curves between two elements. An option is supported
for an intermediate user-defined Tangent Length.

Place Taper Curves

This tool enables the user to draw taper curves between two elements. The Design Vehicles
group enables the user to select the desired vehicle, based on the data from files stored in the
User Preferences.

5.4 Spiral Combinations Tools
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Spiral Combinations JE |
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The Curve Combinations Commands are detailed in the table below.

Place SC Tangent To Line
This tool enables the user to store a spiral / curve combination tangent to a line.

Place ST Tangent To Curve
This tool enables the user to store a spiral / tangent combination tangent to a curve.

Place SC Tangent To Curve
This tool enables the user to store a compound spiral / curve combination tangent to a curve.

Place SCS (Intersecting Elements)

This tool enables the user to store a spiral / curve combination tangent to a line. The Design
Table enables the user to select the desired Design Speed / Lanes and Degree based on the
data from files stored in the User Preferences.

Place STS (Disjoint Curves)

This tool enables the user to store a spiral tangent spiral combination tangent between two
elements.

Place SCS (Disjoint Curves)

This tool stores a spiral curve spiral combination between two curves. Note the tool also works
with overlapping curves. The Design Table enables the user to select the desired Design Speed /
Lanes and Degree or Radius based on the data from files stored in the User Preferences.

5-4 VDOT Road | Training GEOPAK 2001MR



GEOPAK®

5.5 Complex Transitions Tools

Comp... x|

! L}

The Complex Transitions Commands are detailed in the table below.

- Place Complex Ramp
This versatile tool enables the user to draw simple to complex ramp geometry.

™ Place Ramp Connector

This versatile tool enables the user to draw simple to complex ramp connectors, with a variety of
options.

5.6 Alignment Tools

Alignm.. =]
o] &

The Alignment Commands are detailed in the table below.

?'"* Place Dynamic Alignment

The first Alignment tool is placing a dynamic alignment. You initially select and accept a
beginning element. By moving the cursor, the length of curve and dynamic ahead element
change. Continue placing data points to create curves and intermediate tangents. At any time
during the process, the Entry Radius may be changed. Any subsequent curves are placed with
the revised Radius.

gi Store Chain

The second Alignment tool is storing a chain comprised of graphical elements. This works
similar to Automatic Create Complex Chain, while the chains are automatically being stored into
the COGO database file.
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5.7 Manipulate Tools
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The Manipulate Commands are detailed in the table below.

Move Plan View Element

The Move a Plan View Element enables the user to move / translate an element or to make
copies.

Rotate Plan View Element

The Rotate Plan View Element rotates the selected element about a user-defined point. The
Angle may be manually entered and locked, or dynamically changing.

Extend Plan View Element

The Extend Plan View Element tool can extend or shorten any element.
Delete Element

When using the Delete Element tool, no tool settings dialog box opens.

Select and accept the element to be deleted. The element is removed from the coordinate
geometry database. This tool works with a MicroStation selection set if present. Warning:
there is no undo for this command.
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LAB 5:

Horizontal Alignment Tools

5.1 Accessing Horizontal Alignment Tools

Step 1.

Step 2.

Step 3.

Step 4.

Step 5.

Step 6.

Execute C:\data\geo\VDOT\road1\LAB5.EXE.
Open the MicroStation file c:\data\geo\VDOT\road1\d17682des.dgn.

Access Project Manager. It should automatically access the Road workflow dialog box
since we “remembered” the options in Exercise 2.

Select the Horizontal Alignment icon from the Road Project: 17682.prj workflow dialog
box.

You will see the following dialog box:

| GEOPAK Alignment Startup Option

Horizontal Alignment Tool Compatibility;
| COGO Element Based Mew] |

[T Don't ask me anymare

Set the option to COGO Element Based (NEW) as shown and press OK.

You will see the following dialog box. Click YES.
e |
whould you like to activate the default design

tables?

You will see the following dialog box. Click YES.
e ]

Thiz application requires COGO to be
@ activated.

Wiould pou like to imvolke COGO now?

GEOPAK 2001MR
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Step 7. Activate COGO by pressing OK on the next dialog box.

EEDPAK Coordinate Geometiy 1

Praject Name I1?EB2
Job Murber |'ID'I Select I

Operator Code Ivd
Subject [Chairn EBL4ED. '

QK. | Cancel |

Step 8. Enable Permanent Visualization, then you can either move the COGO window out of the
way or “sink” it using the Bentley icon.

| Coordinate Geometry

= Restore
Move

Size
~ Minimize

O Maximize

X Cloze Alr+F4

Step 9. You should now see the Horizontal Alignment Generator menu bar.

% Horizontal Alignment Generator ﬂ
File Design Tables Toolz

5.2 Preferences

Step 1. Use the File > Preferences pulldown to access the Preferences dialog box. Select the option for
COGO Element Names and complete the dialog box as shown.
[@Puterences ... @

Categony

Element Syrmbology ¥ Save as COGO Elemerts
Line - Beginning Element Hames
Curve
Spiral ¥ Faint RaMPAl

Construction Line I Line |

[COGO Element Names

Curve Design Tables B/ Curve [REHFAT
Spiral Degign Tables ™| Spiral l

Geametry Settings
Dipnamic [ncrements
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Step 2. Select the Curve Design Tables option. Using the Files button, select the appropriate file for
each option. The files are located in the following directory:

C:\data\geo\vdot\roadl\standards\geopak\

Symmetrical 3 Centered Curve HA_3CenteredCurve_Symmetrical_2001English.tbl

Design Table
Asymmetrical 3 Centered Curve | HA_3CenteredCurve_Asymmetrical_2001English.tbl
Design Table
Tapered Curve Table HA_TaperCurve_2001English.tbl
Step 3. Select the Spiral Design Tables option. Using the Files button, select the appropriate file. The

file is located in the following directory:

C:\data\geo\vdot\road1\standards\geopak\

Spiral Design Table HA_Spiral_Rural_VDOTEnNglish.tbl

When complete, dismiss the dialog box by pressing the “X” in the upper corner.

5.3 Store a Complex Ramp

Step 1. Use the Tools > Complex Transitions pulldown to access the following menu bar:

Step 2. Select the first of the two icons to access the Place Complex Ramp dialog box and fill out the
dialog box as shown below:

_ Place Complex Hamp E I

r Back Element(z]

= =)
W | Cuve vI Length vI |115192 E Radius - Iaanuuu =

Intermediate Curve B adius : !280.00000[ E

~ Ahead Element(z]

l‘ Curve vi Length vi |1nn ] E Radius : [230.0000 B
T = R T
| Ahead Offset |12 000 =4

Tiuncate ;| Mone 'I "] Loop [Exterior Construction)
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Step 3. Chains MAINLINE and EBL460 should be visualized in the design file from our previous
exercise. Use your cursor to ID chain MAINLINE with a datapoint, then issue another
datapoint to accept it.

Next, use your cursor again to ID chain EBL460 with a datapoint.

The ramp will now dynamically visualize.

NOTE: As you move the cursor into any of the 4 quadrants of the intersection of
the two alignments, the ramp will re-calculate and re-visualize in that quadrant.

§ =il

Step 4. Issue a datapoint in the westernmost quadrant to store the ramp as shown in the diagram
below:

Step 5. Dismiss the Complex Ramp dialog box and review the COGO output window. Notice that
the 3 curves were automatically stored into the COGO database.

g[innldinale Geometry Job: 101  Operator: ¥D
File Edit Element “iew Tools User

ErEEREEEREEEEE
Dizable Yisualization '"m:! Browse I_iilL‘_I

COGO Keyin | =]
{® 1 FREINT CURVE RAMFPA-3
Curwe Data
¥ T — £
Curwe RAMPA-3
Feature: DEFAULT CHAIH
F.I. 5Station 13+38.62 H 337,913 .8559 E 2,718,952 3970
Delta = 24" 5§9' 59 R1" (RT)
Degres = 247 G54' 40.35"
Tangent = E0.9895
Length = 100. 3560
Radius = 230.0000
External = E.E342
Long Chord = 99 5618
Mid. Ord. = E. 4519
P.C. Station 12487 .63 H 337,.962.8591 E 2,718,966 . 4905
P.T. Station 13487 .98 H 337.875.4001 E 2,718,918 9144
G H 338,026 .4310 E 2,718,745 4507
Back =5 16" 02' 43.58" W
Ahead =5 41" 02' 43.20" W
Chord Bear = S 287 32' 43.39" W
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Step 6. Use the Tools > Alignment pulldown to access the following menu bar:
Alignm.. %]
e
Step 7. Select the second of the two icons to access the Store Chain dialog box. Fill out the
dialog box as shown below:
Stnle Chain m
Id: [REMPFA
Beqin Station: I1D+DD
EDpposingEIement:é Tranzpose VI
b ax Gap: !u.um ujuli]
Step 8. With your cursor, issue an initial datapoint to ID the northernmost curve of the ramp.
Issue a second datapoint to accept it.
Step 9. The entire chain will highlight and you'll see some directional arrows. Issue another
datapoint to accept the direction of the chain.
Step 10. Dismiss the Store Chain dialog box. Review the output in COGO and notice the chain
RAMPA has been stored into COGO.
-_ Coordinate Geometry Job: 101  Operator: »d [_ O] x|
Fil= Edit Element Miews Toole User
8 o 2 E <D !
. - +|xj + . f-: '(‘ = D +ze I-P__' @ f’_’) @ % @ ﬁ ' Fedefine
Fermanent Visualization v!IEIFF [Feature] j Erowsel |_I_| ¥ I
COGO Kewin [STORE CHAIN RAMPA CUUR RAMPA-1 CUR RAMPA-2 CUR RAMPA3 STATION 10+00 [~]
Delta Z 247 B9' B9 g1" (RT) B
Degres = 24" 54' 40, 35"
Tangent = E0. 9895
Length g 100 3560
Radius 2 2200000
External = 5.534z2
Long Chord = 99 G5gl4d
Mid. Ord = 5 4519
F.C. Station 0+00.00 W 337,962 8591 E 2,718,966 4905
P.T. Station 1+00 36 W 337,875 4001 E 2,718,918 9144
LT W 238,026.4310 E 2,718,745 4507
Back =5 16" 02' 43 58" W
Ahead = 5 41" 02' 43.20" W
Chord Bear =S 28" 32' 43 39" W
Curve RAMPA-3 stored
% & STORE CHAIN RAMPA  CUR RAMPA-1 CUR RAMPA-2 CUR RAMPA-3 STATION 10400 [
Chain RANPA stored =]

GEOPAK 2001MR
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Step 11.  Save your input file.

T

Save Az I Rk Pa Subject l Chain BAMPA| |
Files
Mame Subject

=h4E0 CHaAIM EBLAGO
il CHAIM MAIMLINE

Cancel I

Step 12. Exit COGO.

Step 13. Exit MicroStation.
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