
_____________________________________ CHAPTER 4 

GEOPAK 2001MR 4-1 

 

Coordinate Geometry 
4.1   Introduction 
Objectives Learn to set up and access the coordinate geometry database file. Become 

proficient in using GEOPAK Coordinate Geometry. 

Project Manager Coordinate Geometry 

Tool 

  

Menu Bar Application GEOPAK Road > Geometry > Coordinate Geometry 

The Coordinate Geometry database file (*.GPK file) is comprised of stored geometric elements such 
as points, lines, curves, spirals, chains, parcels and profiles.  When COGO calculations are 
completed, the results are stored in the binary database file, which is then utilized throughout the 
design process with many other applications. 

4.2   Accessing COGO 
When Coordinate Geometry is started, the Start-Up Dialog box appears. 

 

The fields in the Start-Up dialog box are detailed below. 

Project Name Name displayed on reports.  This is an optional entry, with a maximum of 
60 alphanumeric characters.  If Project Manager is active, this field is 
populated automatically. 

Job Number Identifies coordinate geometry database file and is a required field. The job 
number is a maximum of three alphanumeric characters.  If Project 
Manager is active, this field populated automatically. This field is required. 

Operator Code Unique 2-character code which enables multiple users access to database 
file.  The user’s initials are suggested.  Note this field is not required for 
single user access, but highly recommended.  If Project Manager is active, 
this field is populated automatically. 

Subject Description of coordinate geometry work (could relate to the project) with a 
maximum of 48 alphanumeric characters.   

Coordinate Geometry    
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This field is optional. 

After the dialog box is populated, and the OK button is clicked, the main coordinate geometry dialog 
box is invoked. 

4.3   Coordinate Geometry   

 

The coordinate geometry dialog box is made up of three separate display areas: 

• Tool Bar (1) consisting of drop down options and icons.  The display of specific icons is 
customizable. 

• COGO Key-in (2) this field enables manual entry of COGO commands.  The drop down 
button allows for a history of commands to be reviewed. 

• Output Display Window (3) shows the results generated by the commands. 
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4.3.1   File Commands 

 
The File commands (as displayed in the exploded view above) are detailed in the table below. 

Append This command is for input files only. A new input file is created by copying the contents of 
an existing input file to the end of the current input file.  The Save command must be used 
in order to store this new file. 

Catalog When selected, a menu appears listing all saved input files (under the current operator 
code) in the project directory.  This is for reference only no action is taken. 

Delete When selected, a menu appears listing all saved input files. Highlight a file, then click the 
OK button to remove this file from your project directory.  Although the file is deleted, the 
elements stored as a result of processing the commands are not deleted. 

Load When selected, a menu appears listing all saved input files. Highlight a file, then click the 
OK button. The input lines from the highlighted file are now displayed in the display 
window for viewing, editing, or processing. 

Output  Writes an ASCII file of the current display for reviewing and / or printing. (Fname999.ooc, 
where 999 is the current job number and oc is the operator code). 

Print  Sends your output/input file to the printer. 

Restore Loads an ASCII file of GEOPAK commands into the display window.  Note no processing 
occurs.  The file must be named j999ooc.inp, where 999 is the current job number and oc 
is the operator code. 

Save Saves the current audit trail to a file. (Fname999.ioc, where 999 is the current job number 
and oc is the operator code.). 

Export  Exports GEOPAK points, chains and profiles into formats for use in various data 
collectors.  

Import  Imports horizontal and vertical alignments and points from RDS and SDMS format into the 
GEOPAK .gpk file. 

Exit Closes the COGO dialog box and ends the coordinate geometry session. A prompt to 
save the session appears. Yes saves the audit trail, No exits without saving, Cancel 
returns to the COGO session. Whether you pick Yes or No everything you did is still 
saved in the .gpk file. 
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4.3.2   Edit Commands 

 
The Edit commands (as displayed in the exploded view above) are detailed in the table below. 

Clear Empties the memory of the current audit trail without saving and initializes the line 
numbers to begin a new sequence of commands.  Note this does not clear the display 
window. 

Delete Deletes input commands in the input buffer by line number (or range of line numbers) and 
re-sequences the line numbers for the remaining commands. 

Editor Opens the GEOPAK COGO Command Editor, which enables the user to edit the current 
input file. 

Insert  Adds a command line to the current input buffer before a specified line number; 
subsequent command lines shift down and line numbering is automatically re-sequenced. 

Modify  Changes a fragment in a command line. The modified command line is not processed 
until a Read command is performed. 

Read All Processes the specified lines in the audit trail. This may be done for the entire file (All) or 
by specifying a range of line numbers (Line Range). 

Type All Displays the content of the audit trail, (All) or a portion of the audit trail by specifying a 
range of line numbers (Line Range). 

Line Range Allows you to specify a beginning line number and ending line number. This range of lines 
can then be either “read” into COGO or just typed/listed in the display window. 
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4.3.3   Element Commands 
The mainstay of GEOPAK Coordinate Geometry are the various element commands.  Tools are 
supported for storing, stationing, adding additional data, deleting, etc.  GEOPAK supports a wide 
variety of elements:  points, curves, spirals, chains or alignments, parcels, and profiles.  Each 
element is detailed below. 

4.3.3.1   Element > Point 

 

One of the most utilized sets of COGO tools are the point commands, as detailed in the table below. 

Cell Assigns a cell name to a previously stored point. This point and associated cell can 
then be plotted later through D&C Manager. 

Copy Copies points or a point range to a new point number or range within the same 
GEOPAK database file 

Delete Deletes a point number (or range of numbers) from the database file. 

Elevation Assigns an elevation to a previously stored point 

Equate Stores a new point with the same values as a previously stored point 

List/Print  Input a range of point numbers.  List displays the point numbers (but no associated 
data) currently stored in the .gpk file within the specified range.  Print displays point 
number, x, y, z coordinates, station value and other stored information in the display 
output window for the requested points.  

Station Adds a station to a previously stored point. 
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Store Stores a point by key-in coordinates or by 
selecting a location graphically.  A station, 
elevation, point code, cell, feature, or 
description can be optionally stored with the 
point. 

  
Transformation Performs coordinate transformations based on user-defined control pairings 

Compare Points 
to TIN 

Utilizing a set of COGO points (with elevations) compares the COGO elevation to the 
TIN elevation and completes statistical analysis for "goodness of fit." 

Set Elevation 
from TIN 

Utilizing this command, GEOPAK adds or updates an elevation to a previously defined 
point, based on a TIN model. 

 

4.3.3.2   Element > Curve 

 

The Curve commands (as displayed above) are detailed in the table below. 

Copy Copies a specified curve to another curve name. 

Data Calculates the geometric parameters of a curve, displaying values for Delta, Degree, 
Tangent, Length and Radius. 

Delete Deletes selected curve from the database file. 

List/Print  List displays only the curve names currently stored in the .gpk file.  Print displays the 
curve data of the selected curve.  

Segment Defines new curves by dividing a stored curve into segments. 

Station By identifying a curve and a control point on the curve (PC, PI, or PT), a station value may 
be assigned. 
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Store Provides various options for defining and storing lines and curves such as Store Curve 
from Tangents as shown below.  

 

Transpose Reverses a previously stored curves direction. 

4.3.3.3   Element > Spiral 

 

The Spiral commands (as displayed in the exploded view above) are detailed in the table below. 

Copy Copies a specified spiral to another spiral name. 

Delete Deletes the selected spiral from the database file. 

List/Print  Displays all spiral data for the selected curve.  List displays only the spiral names 
currently stored in the .gpk file.  Print displays the spiral data of the selected spiral.  

Store Provides various options for defining and storing spirals. 
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4.3.3.4   Element > Chain 

 
The Chain (GEOPAK alignment) commands (as displayed in the exploded view above) are detailed 
in the table below. 

Area Calculates the area of a closed chain 

Delete Deletes selected chains from .gpk database file. 

Layout Offset Project points onto a chain or compute offset distance and direction between two chains 
at each control point or at user defined intervals of a specified station range. 

Describe / List / 
Print  

Displays chain information.  Print displays the name of each chain element.  Describe 
displays the alignment data of each element in the selected chain. 

Stationing Provides a method for stationing or re-stationing a chain. 

Station 
Equation  

Provides a method for applying a station equation to a chain. 

Store Provides three options for storing a chain in the database file, From Elements, From 
Offset Chain and Transition Chain.  (Chain name can be between 1-9 alphanumeric 
characters)  
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4.3.3.5   Element > Parcel 

 

The Parcel commands (as displayed in the exploded view above) are detailed in the table below. 

Delete Deletes selected parcels from the database file. 

Describe /  
List /  
Print  

Displays parcel information.  Describe displays the elements of composition, the area of 
tract stored, taken and remaining and a point, bearing, distance description of the 
specified tract.  Print displays the elements of composition, the area of tract stored, taken 
and remaining. 

Store Stores a parcel by adding points, curves and spirals. 

Subdivide Divides a parcel into individual lots. 

Editor Edits a parcel. 

 

4.3.3.6   Parcel Commands (Manual Entry) 
Several parcel commands are supported only by manual entry and have no associated dialog boxes. 

Store Taken Store the portion of a parcel taken by entering point and curve names in either a 
clockwise or counterclockwise direction. 

Store 
Easement  

Store easements by entering point and curve names in either a clockwise or 
counterclockwise direction. 

Own Parcel  Stores the names of the owners associated with previously stored parcels.  

Make Legal  Creates a metes and bounds description and writes it to a user named text file. See also 
Legal Description Editor for the ability to create detailed and customizable legal 
descriptions. 
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4.3.3.7   Element > Profile 

 
The Profile commands (as displayed in the exploded view above) are detailed in the table below.  
Note additional commands are supported as keyin only commands.   

Delete Deletes selected profiles from the database file. 

Elevation Provides three options for reporting elevations along a selected profile, Station, Even Station, 
Incremental Stations. 

List/Print  Displays profile information. Print displays the data of the selected profile from the database file.

Offset Stores a new profile within a specified Station Range at a defined vertical offset from the original 
profile. 

4.3.4   View Commands 

 
The View commands (as displayed in the exploded view above) are detailed in the table below. 

Icons Enables the user to customize which icons appear in the tool bar. 

Redefine Displays the Redefine box on the tool bar. 

Visualization Displays the visualization items on the tool bar. 

Format Displays the format items (i.e. number of decimals, station format, etc.) on the tool bar. 

COGO Key-in Displays the COGO Key-in box for entering commands in the dialog box. 

Command 
Output 

Displays the Command Output Window in the dialog box, and controls options for the 
Command Output Window.  The Command output window can also be saved to a text 
file in lieu of using the File > Output command. 

Error Alert Enables the user to activate a beep and/or restore a minimized COGO dialog box when 
an error occurs. 
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4.3.5   Tools Commands 
The Tools commands are detailed in the table below. 

Intersect  Stores a point at the intersection of any two COGO elements. 

 

Locate Stores a point or series of points not by specifying coordinates, but based on 
a previously stored point using several methods.  To locate a point by 
distance and bearing, use the Tools > Locate > Traverse as depicted in the 
dialog box below. 

 

Superelevation Calculates the superelevation transitions for a given chain and design speed 
by the Classic Methods delivered prior to GEOPAK 2000. 

Inverse Calculates the distance and direction between points.   

Navigator Invokes the COGO Navigator. See Section 4.4. 
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Best Fit  Calculates a best-fit chain through a set of points. 

Translation and Rotation  Moves, rotates, and scales a data set. 

Map Check  Edits a parcel. 

Roadway Intersections Calculates data for the intersection of two COGO elements, usually chains. 

Cul-de-sacs  Calculates data for a cul-de-sac. 

Redraw Visualized 
Elements  

Re-syncs the visualized COGO elements in the MicroStation file with the 
coordinate geometry data. 

Clear Visualized Elements 
(Temporary)  

Removes all temporary visualized elements from the view. 

Clear Visualized Elements 
(All)  

Clears all temporary and permanent visualized elements from the 
Microstation file. 

 

4.3.6   User Preferences 

 

The User Preferences (as displayed in the exploded view above) are detailed in the table below. 

Dialog Allows access to COGO Preferences dialog box. 

Redefinition of Elements Toggles the Redefine option on/off.  If Redefine is on, COGO data can be 
redefined/overwritten. 

Visualization Enables the elements to be displayed in the MicroStation file permanently, 
temporarily, or not at all. 

Coordinate Display Toggles between displaying NE or XY coordinates. 

Angle Display Toggles between displaying Bearing or Azimuth. 
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4.4   COGO Navigator 
Feature / Function View, edit and display COGO elements. 

Tools 

 

COGO Menu Bar Tools > Navigator 

 

The COGO Navigator is a tool utilized to easily view and edit COGO data. Store, delete, edit, print 
elements, plus visualization and selection set commands are easily accessible via the Navigator. The 
Navigator can be accessed by the pull down menu COGO > Tools > Navigator or by the Navigator 
icon.  The following dialog box opens. 

 

From the Navigator, points, curves, spirals, chains, survey chains, parcels, and profiles  (all COGO 
elements contained in the coordinate geometry database file; *.gpk) can be added, deleted, modified, 
identified, visualized, printed, or selected. 
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4.4.1   Navigator > Select Tools 
A variety of selection tools can be invoked via the Select pulldown, as depicted in the exploded view 
below. 

 

The Select tools are detailed in the table below. 

Select All Selects all data items of a certain type.  (i.e. all points) 

Invert Selection Selects all items not previously selected, and unselects all items previously 
selected. 

Clear Selection Unselects all items. 

Selection Set Allows the user to create a selection set that meets particular criteria.  
Same as using the Selection Set icon 

Fit View (Selection Set) Fits the selected items to the active MicroStation window. 

Show Selected Elements 
Only 

Only the items in the selection set are displayed in the MicroStation 
window. 

Show All Elements All items in database file are displayed in the MicroStation window. 
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4.4.2   Navigator > Tools 
A variety of tools can be invoked via the Tools pulldown, as depicted in the exploded view below.  
Many can also be invoked via the shortcut icons displayed at the top of the Navigator. 

 

Add Element 

 

Enables the selected type of element to be stored.  When selected, the 
appropriate Store Element dialog box is invoked. 

Delete Element 

 

Deletes the highlighted element. 

Edit Element 

 

Invokes the appropriate Store Element dialog box, populated with the 
associated data of the selected element for editing. 

Identify Element 

 

When clicked and a COGO element is graphically selected, the element is 
highlighted in the display field.  If the selected element is not the displayed 
element type (i.e., curve or point), the element type is also changed.   

Print/Describe Element 

 

Displays the selected element’s data. 

Edit Element Feature Changes the feature code of the element. 

Visualize Element 

 

Displays the selected elements according to their feature code or default 
symbology. 

Unvisualize Element Removes display of  selected elements. 

Visualize All Displays all of the elements of a certain type, or all elements. 

Redraw Visualized 
Elements 

Re-syncs the coordinate geometry data with the data displayed in the 
MicroStation file. 

Clear Visualized 
Elements (Temporary) 

Clears only temporary visualized elements from the view. 

Clear Visualized 
Elements (All) 

Clears all visualized elements from the MicroStation file. 
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Settings Enables the user to define certain actions and behaviors of the Navigator. 
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LAB 4:   Coordinate Geometry 
4.1   Accessing COGO 

Step 1.  Execute C:\data\geo\VDOT\road1\LAB4.EXE. 

Step 2. Open the MicroStation file c:\data\geo\VDOT\road1\d17682des.dgn. 

 Access Project Manager.  It should automatically access the Road workflow dialog box 
since we “remembered” the options in Exercise 2. 

Step 3. Select the Coordinate Geometry icon from the Road Project: 17682.prj workflow dialog 
box. 

 The following COGO startup dialog box opens.  Notice that the Project, Job Number and 
Operator Code fields are populated automatically.  This information is taken from the 
project information that we defined when creating the project in Exercise one. 

 

Step 4. Click OK to access the coordinate geometry dialog box shown below. 

 

  This dialog box is completely re-sizable, so you can position it where you’re most 
comfortable. 
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4.2   Store Geometry 
Our course project has 4 alignments. We’ll store two of them using Coordinate Geometry. The first 
alignment will be called MAINLINE and is shown below: 

 

4.2.1   Store Points 
Step 1. Select the visualization option Permanent Visualization on the main COGO dialog box. 

Step 2. Access the Store Point dialog box by pressing the Store Point icon 

   

  or using the Element > Point > Store pulldown. 
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Step 3. To store point D500, manually enter the point number and coordinates as indicated in the 
dialog box below. Activate the Auto Increment toggle which will automatically increment 
the point number by 1 for subsequent Store Point commands. 

 

Step 4. Press the Apply button to store the point into the COGO database. 

Step 5. Continue storing points D501-D503 by utilizing the coordinates shown on the alignment 
diagram. When complete, exit the Store Point dialog box by pressing the “X” in the upper 
right hand corner. 

 

Note that the following point naming conventions should be followed: 
Design – All points should begin with D (e.g. D501, D502, etc.). 
Hydraulic – All points should begin with H (e.g. H501, H502, etc.) 
Survey – All points should begin with S (e.g. S501, S502, etc.) 
Traffic – All points should begin with T (e.g. T501, T502, etc.) 
Right of Way – All points should begin with R (e.g. R501, R502, etc.) 
Environmental – All points should begin with E (e.g. E501, E502, etc.) 
Utilities - All points should begin with U (e.g. U501, U502, etc.) 
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4.2.2   Store Curves 
Step 1. Access the Store Curve from Tangents dialog box by pressing the Store Curve from 

Tangents icon 

  

 or select Elements > Curve > Store > From Tangents from the COGO menu bar. 

Step 2. To store Curve ML-1, complete the dialog box as shown below and press Store. 

 

NOTE: Pressing the “picture” buttons allows you to select from multiple 
methods of defining the Back and Ahead Tangents 

 

 

Step 3. To store Curve ML-2, complete the dialog box as shown below and press Store. 

 

NOTE: Visualized points may be selected to complete any field that 
requires defined points or directions. 

 

 

Step 4. Dismiss the Store Curve from Tangents dialog box by pressing the “X” in the upper right 
hand corner. 
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4.2.3   Store Chain 
Step 1. Invoke the Store Chain dialog box by pressing the Store Chain icon 

  

 or select Element > Chain > Store > From Elements from the COGO menu bar. 

Step 2. Fill in the dialog box as shown below. 

 

 

NOTE: You can enter the elements manually or select the visualized 
elements graphically in order to fill in the dialog box. 

 

Step 3. Press Apply and dismiss the Store Chain dialog box. The chain MAINLINE should be 
visualized in the design file. 
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4.2.4   Describe Chain 
From the COGO dialog window, let’s preview the geometry of the chain we just stored. 

Step 1. Select the COGO Navigator icon 

  

 or use the Tools > Navigator option on the COGO 
menu bar to access the COGO Navigator dialog 
box. 

Step 2. Set the element option to Chain and highlight the 
chain MAINLINE. 

Step 3. Press the “printer” icon. 

 

 

 

Step 4. The chain geometry output will be displayed in the main COGO window. 
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Step 5. To save an input trail of your commands, select File > Save from the COGO menu bar. 
Fill out the dialog box as shown below and press OK. The saved file will be called 
‘ML101.ivd’. 

  

Step 6. To save an output file with the actual results of the computations, select File > Output 
from the COGO menu bar. The saved file will be called ‘ML101.ovd’. 

 

Step 7. From the Edit pulldown, select Edit > Clear to ‘clear’ out all the commands that we just 
previously typed in. 

 

This will not remove the stored data from COGO.  

 

 

 

 

 

GEOPAK 2001MR 4-23 LAB 4:   Coordinate Geometry    



GEOPAK® __________________________________________________________  

4.3   Working Alignment 
Now that we have our alignment, we have another piece of information for the Working Alignment 
definition.  

Step 1. Access the Project Manager Road workflow dialog box. 

Step 2. Click the Define button to access the Working Alignment Definition dialog box. 

Step 3.  Highlight the Plan View option and use the File and Select buttons to populate the 
Design File and Chain fields as shown: 

 

Step 4. Click OK. 
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4.4   Store Another Alignment 
Using the same general steps we learned in storing the previous alignment, use the diagram below to 
store another chain ‘EBL460’. The beginning station of the chain will be 107+00. 

 

 

Save an input trail of your commands. 

Exit COGO.  

Exit MicroStation. 
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