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Contents at a Glance

Chapter | — Introduction: Chapter 1 introduces the General Document
(Windows) version of the Document Manager.

Chapter 2 — Document Retrieval: Chapter 2 provides a step-by-step explana-
tion of the procedures used to retrieve documents for modification or for
viewing, and includes an explanation of how reference files are attached and
managed. This section includes a detailed discussion of how Falcon/DMS
manages requested files and explains the difference between the open and
checkout operations. The procedures used to refresh documents and manage
reference files are also explained.

Chapter 3 — The New Document Commands: Chapter 3 explains how to
use Falcon/DMS to create a document and its database records. Also discussed
in this chapter: Revision Control, the Add Local command, and the Add
Server command.

Chapter 4 — Document Manipulatioin: Chapter 4 covers the Move, Copy,
Copy/Replace, Rename, and Delete commands.

Chapter 5 — Database Operations: Chapter 5 discusses the database operations
available in the Windows version of the Document Manager. Special attention
is given to the database search tools and how the document manipulation
commands presented in Chapter 4 can be used in combination with the

search command. Also discussed is Generate Document List, which allows
users to designate the current file by choosing from a list that displays the
Filename, its Document #, and its Description, and Document Notes, a feature
that provides a easy and powerful way for users to itemize activity for any
document. Included in this chapter is an explanation of the Mass Update
command.
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Introduction

he Document Manager is the user

interface for the Falcon/DMS En-
gineering Document Management Sys-
tem.

Two versions of the Falcon/DMS
Document Manager are available: The
Windows version, the subject of this
guide, is application-independent and
capable of fully managing documents
for any Windows-based program, in-
cluding Microsoft Office applications,
MicroStation and AutoCAD. The Mi-
croStation (MDL) version is seamlessly
integrated with Micro-Station’s graphical
user interface and has virtually all the
capabilities of its Windows counterpart
(see the ‘Document Manager: Micro-
Station [MDL] User Guide’ for more
information).

There are several important differences
between the Windows and MDL versions
of the Document Manager.

One is that while you can manage
any type of document with either, the
only document type you can open with
the MDL version of the Document
Manager is a MicroStation design file.
The Windows Document Manager, on
the other hand, 1s able to launch any
Windows-based application when a

document associated with the application
is opened.

Another i1s the availability of certain
administrator level commands on the
Windows version that are not a included
with the MDL version; these are the
Location Checkout and Check In,
Archive and UnArchive, and Mass
Update commands.

In a Windows environment, the Win-
dows and the MDL versions of the Docu-
ment Manager can be used interchange-
ably. You can start MicroStation from
either the Windows Document Manager
or from a MicroStation icon, and then
open or checkout additional design files
from whichever interface you choose.
When you select and open a design file
from the Windows Document Manager,
you have the additional benefit of being
able to select a MicroStation workspace
or engineering application, provided they
have been defined by the Falcon/DMS
administrator.
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Availability: A database attribute that
identifies whether a document is
available for modification. A docu-
ment’s Availability condition appears
on the General Info tab.

When you select a file and its Avail-
ability is shown as ‘On server’, it is
available to authorized users.

When the file is shown as ‘On Work-
station’, it is checked out for modi-
fication; Falcon/DMS identifies the
workstation on which the document
is located, the user to whom the
document is checked out, and the
checkout date.

Status: Document Status, or Status, is
an attribute that is typically defined
and assigned to documents by an
administrator and usually cannot be
changed by a user. Status assigns an
‘access mode’ to a document.

The three access modes are: modify
(which allows for full access, pro-
vided ‘write’ access is granted by
the operating system), view only,
and no access.

<0 NOTE

Typically, Falcon/DMS is configured
to copy checked out documents to
the workstation. There are several
benefits to placing these ‘working’
versions of documents on the local
hard disk:

First, network traffic is minimized.

Second, an application’s perfor-
mance is optimized.

Third (and perhaps most important),
users can continue to work on local
documents when the server or the
network fail.

The Document Manager (Windows)

Basic Concepts

Opening a single document or checking out one or more documents are the two most
basic Falcon/DMS file retrieval operations.

When you open or check out a document through Falcon/DMS, a copy of that
document (the ‘working” document) is placed in a predefined location on your local hard
disk where it can be modified. The server version of this file (the ‘record” document) is
set to a ‘view only” access mode and remains so until the working document is checked
in. When a working document is checked in it is removed from your workstation

and placed back on the server (becoming the new ‘record’ document), and is once again
available to authorized users for modification.

When you select the Open or Checkout commands, Falcon/DMS checks several
database attributes to determine whether you can access the document. The attributes
most likely to affect your ability to manipulate a document are Availability and Status.

A document that is not checked out shows an Availability of ‘On Server’; this indicates
that the document is available for modification (provided you are authorized to do so). A
document that is checked out to another user shows an Availability of ‘On Workstation’
(or ‘Reserved by User’, see Note). Falcon/DMS identifies the workstation on which the
document is located, the user to whom the document is checked out, and the date on
which it was checked out.

Status refers to Document Access Status. This is a database attribute, typically defined
by an administrator, that assigns access modes of modify, view only or no access to a
document. When a document’s Status has a ‘modify’ access mode you may check out
and modify the document. When the mode is ‘view only’, you are given the option of
proceeding with a read only version of the document or terminating the request. When
the mode is ‘no access’, Falcon/DMS provides a message defined by the administrator.

Each document’s Availability and Status are listed on the General Info tab.
There is relatively little difference between the Checkout and Open commands.

When you check out one or more documents, you reserve those documents for your use,
usually to be opened and modified at a later time.

When you open a document, Falcon/DMS checks out the document, launches the
associated application if necessary, and opens it in that application as part of a single
transaction. Access by other users to any checked out document is limited to ‘view
only’, meaning that they cannot modify the ‘On Workstation” document until it is
checked in.

The Open command is available only when you select a single document. The Checkout
command can be used to checkout one or more documents in a single transaction.

Note: A file format, or document type, can be configured so that checked out documents
are accessed on the server instead of copied to the requesting workstation’s hard disk.
Under this configuration, documents that are checked out will show an Availability of
‘Reserved by user’. (Apart from an increase in network traffic, an important disadvantage
to accessing files directly on the server is that clients are unable to get to their documents
if the network fails.)
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Graphical User Interface
The components of the Windows Document Manager are:

A. Control Bar: Provides standard Windows functions (move, close, minimize,
etc.). Additionally, when the Environments feature is enabled the control bar
displays the current environment.

B. Menu Bar: Provides access to pulldown command menus.

If application properties for MicroStation and AutoCAD are defined, the menu bar
includes pulldown menus for each; when you select a MicroStation or AutoCAD
file the relevant menu activates.

C. Button Bar: Provides quick access to a variety of management operations contained
within the Menu Bar pulldown menus.

D. File Selection Region: Server File Selection is a view of server-based record
documents. Local File Selection is a view of local working documents. From
this area you navigate through the directory structure and select the documents
you wish to work with.

E. Database Information Tabs: These tabs allow you to view different categories
of database information. The five database info tabs are General Information,
Directories & Keywords, Title Block, File Format Keywords, and Document
Notes.

F. Bottom Button Panel: Provides access to the basic management operations: Open,
View, Checkout, Copy Out, Check In, and Search.

G. Status Bar: Provides information and statistics about the current operation.

Falcon/DM5 5 Document Manager [DOT [Master])
File File Selection Database MicroStation  AotoCAD Workspace Help

cC— T I8 Y O =3 % T2

" Server File Selection

AFE] [

File Hame Files Selected: ]
Project [va_dot v| [11011101.dgn . |
D Category |district_1 Y 03000101.dgn
I —I 03100201.dgn s

Discipline Iculverts i | 11011101.dgn

11011102.dan
11011103.dgn
11011104.dgn

LN

[an files - =]

General Information [ Directories & Kewwords [ Title Block I File Format Keywords I Document Notes I

E _— Description ITrafﬁc Control Design Tables: 'L’ distance & channelizing device taper criterii
Document # [1101.11 Rev # A ¢ [izrzam sheet# | | | cae
Status [active =] #[psi29199 File Format igds || _Erev
Availability |On Server L
Lost Modified Date [012598 | Created By [synnott_tm / [1z2em7
F _— Open | View | Checkout | Check In | Search... | Exit
G

|Retrieved database record for =11011101 dan=... |




The Document Manager Menu Bar

File Menu

The File pulldown menu provides access to the following operations:

FiLe MeEnu

New >
New Revision...

Add Server Files...
&
Add Local Files...

File Retrieval Commands

File Manipulation
Commands

Sets >

File Association >
Location...
Archive...

Close

File Selection Menu

Used to create a new document and its database record.
Used to create a new revision of the current document.

Used to add server-based and local files, respectively, to the
database. [Available only when the Server View Mode is set to
Directory.]

Falcon/DMS provides two categories of retrieval commands:
modify and view. The modify commands are Open, Checkout,
and Checkin. The view commands are View and Copy Out.

The file manipulation commands are New, New Revision, Move,
Copy, Copy/Replace, Delete, and Rename.

New, Add to..., View/Remove from...

Add to..., View/Remove from...

Includes the Checkout & Check In operations.
Includes the Archive & Unarchive operations.

Exits the Falcon/DMS Document Manager.

The File Selection pulldown menu provides access to the following operations:

FiLE
SELECTION

Server File Selection

Local File Selection

Checked Out to [User]...

Database Menu

Points Falcon/DMS to the server-based project directories
listed in the Master 'Project’ Table.

Points Falcon/DMS to the local working directories defined for
each file format.

Opens a form listing all the files checked out to the current
user. From this dialog box the user can open or check in any
files that appear in the list.

The Database pulldown menu provides access to the following operations:

DATABASE

Search...

Generate Document List...

Mass Update

MicroStation Menu

Opens the Database Search Form

Provides an expanded view of a directory’s contents that
includes the document number and description for each
filename.

Permits an administrator to perform database updates on
multiple documents.

The MicroStation pulldown menu provides access to the following operations:

Micro-
STATION

Attach Reference File

File Refresh >

Permits users to attach reference files to the active design file.

The Refresh commands facilitate the backup or retrieval of the
most current version of MicroStation files.

The Document Manager (Windows)
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AutoCAD Menu

The AutoCAD pulldown menu provides access to the following operations:

AuTtoCAD Attach Xref

File Refresh >

Workspace

Used to attach Xref files to the active drawing file.

The Refresh commands facilitate the backup or retrieval of the
most current version of AutoCAD files.

The Workspace pulldown menu provides access to the following operations:

WORK-
SPACE

ENVIRONMENTS >

User Prer >

Directory Selection >

Directory List Button

Minimize on Open
Button Bar

Bottom Button Panel
Database Info Tabs

Master Project Description

Subdirectory Description

Post Reference Dialog

Reference File Check

Auto Delete Local
Reference Files

Server View Mode >

Lists the environments for which you are authorized. Used to
select the current environment.

Text List Boxes: This option uses list boxes from which
projects and their subdirectories are chosen. Click the <
button to display a list box.

DirecTorY LisT Box: The option displays project subdirectories
in the standard Windows mode. Click the < button to select a
project and drill down to the required subdirectory.

[ON/OFF] When enabled, the file list won't display until you
click the <List button.

Minimizes the Document Manager after each Open operation.
[ON/OFf] Controls the display of Button Bar.
[ON/OFf] Controls the display of Bottom Button Panel.

[ON/OFf] Controls the display of the database information tabs:
General Info, Directories and Keywords, Title Block, File
Format Keywords (when defined), and Document Notes.

[ON/OFf] Controls the display of project descriptions (project
descriptions are defined by the Falcon/DMS Administrator).

[ON/OFf] Controls the display of subdirectory descriptions
(subdirectory descriptions are defined by the Falcon/DMS
Administrator)

[ON/OFF] Controls the display, or 'posting’, of the Reference
File List dialog box. This dialog box opens as reference files are
copied to the local workstation and provides information about
each reference file's status.

[ON/OFF] When on, Falcon/DMS automatically checks for
reference file attachments; when off, Falcon/DMS will not check
for reference file attachments.

[ON/OFF] When on, Falcon/DMS automatically deletes local
reference files when a design file is checked in; otherwise, the
user deletes local reference files at his discretion.

[Database/Directory] This preference allows you to view the
server-based douments as records in the database (Database
mode) or as items in a directory listing of the actual server
directory (Directory mode).
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The Document Manager Button Bar

The Button Bar menu provides access to the following operations:

(sIv) [elal

WEE

Server File Selection

Local File Selection

Add Server File

Add Local File

File Retrieval Commands

File Manipulation
Commands

Search
Database Info Tabs

Generate Document List

Launch Viewer [optional]

Points Falcon/DMS to the server-based project directories
listed in the Master 'Project’ Table.

Points Falcon/DMS to the local working directories defined for
each file format.

Used to add server-based documents to the database.
[Available when the Server View Mode is set to Directory.]

Used to add local documents to the database.

The file retrieval commands found on the button bar are Open,
View, Checkout, Copy Out and Check In.

The file manipulation commands found on the button bar are
New, Move, Copy, Copy/Replace, Delete, and Rename.

Opens the Database Search form.
[On/Off] Controls the display of the database information tabs.

Provides an expanded view of a directory’s contents that
includes the document number and description for each
filename.

Opens the selected file in AutoVue in view mode.
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File Selection Modes: v TIP
Use the Button Bar commands to

Falcon/DMS restricts users to specific ‘project’ directories on the network file servers and | quickly switch between Server and
to specific ‘working’ directories on the local workstation. The Document Manager’s File | Local File Selection.

Selection option allows you to choose between viewing the contents of the server-based S—
‘project’ directories and the contents of the local working directories. @E

Recall that when Falcon/DMS opens or checks out a design file, it places a copy of that
file (the ‘working” document) in the working directory on the local workstation. The
original (the ‘record’ document) stays on the server, where it remains as a ‘view only’ file
until the document is checked back into the database. A user may select his own checked
out document (where Availability equals ‘On Workstation’) from its server-based home
directory or from the local working directory to which it was checked out. In either case,
Falcon/DMS always opens the local version of the file.

Server File Selection

When Falcon/DMS points to a server it limits access on the server to the directories listed
in the Master ‘Project’ Table.

=cion
(i Laeal e Selestion
Checked Out to < THOMAS / SMOWHMASS >

Local File Selection

v Senven Bile Selection

Local File Selection k
Checked Out to < THOMA,

4 SN MASS >

‘When Falcon/DMS points to the local working directory, it views a replication of the
server directories built as documents are checked out. (When documents are checked in,
Falcon/DMS automatically deletes empty local directories.)
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v TP Navigating Directories & Selecting Files

In addition to selecting a project

from a text list box, you may keyin a The Falcon/DMS Document Manager uses standard Windows conventions to navigate
project name in the ‘Project’ field. through a directory structure and select documents.

v TIP

You may view the current directory structure from Text List boxes or a Directory List

You may select any list box item with . .
4 i box. Use the Directory Selection user preference to set the preferred control.

a double-click.

V TIP 2Falcon/DM5 v5 Document Manager [DOT [Master]) =] B
. File  File Selection Database  MicroStation  AutolA0
To move up through a directory Sy el El
structure when the directory selec- NI A M ; TS TR
tion preference is set to Text List ] ————— o Diegton st BUttor
: ) : i v Di
box, simply click the button associ- e ! Minimize on open
ated with the higher level directory Category | K2 "&“::0” BBa'tt -
. PR v Bottom Button Panel
and select an entry or, double-click Disciptine | ] Diatabase [nfo Tabs
the current directory and press the Master PROJECT Description
delete key Subdirectory Dezcription
Post Reference Dialag
Allfiles (*.%) ~  Reference File Check
Auta Delete Local Reference Files
open View | cgeckout| Checkin |

Server Yiew Mode b —‘

When the Text/List Boxes preference is enabled, the Document Manager displays the
available directories in a list boxes opened by clicking on the associated V buttons.

alcon/DM5 ¥5 Document Manager [DOT [Master]) - D]

File File Selection Databaze MicroStation  SotoCAD Workspace Help
ST [l B Eepe BEE 7
[ Server File Selection [ e A
(19| Discipline Selection kelected: 0
Project [02-098345 N Slestical
Category Wﬂ mechanical
Digcipline ll

IAII files

view | Checkout

=]
:
=

I LCancel |
1

When the Directory List Box preference is enabled, the Document Manager displays
the available ‘Project’ directories in a list box while the subdirectories are shown in the
standard Windows mode.

alcon/DM5 v5 Document Manager [DOT [Master]] M= B
File  File Selection Databaze MicroStation  AuicCAD Workspace Help

(S]] [Fell

| Server File Selection
File Hame

Project |nz-nsss45 v |

I Server: snowmass
3 02-098345

=3 09-002

[_J Erectrical

D Mechanical =

|m| files (-.%) =]

Open View | Cllel:knutl Checkin | Search... | Exit
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If you wish to perform any operation on a single document, the easiest method is to
single-click the document in the Filename window and select the desired command.
‘When you wish to perform a transaction on a single document it is not necessary to list the
filename in the Files Selected window.

1=Falcon/DMS v5 Document Manager [DOT [Master]) M= B
e File Selection  Databaze MicroStation  AufoCAD Warkspace  Help
Sl el PEE 7]
| Server File Selection
File Hame Files Selected: L[]
Project [02-098345 % | [aagp003.dgn . |
Category [09-002 | ”l
Discipline Islructural |
[]
aagp007.dgn ﬂ e |
|aufiles ¢ =l
Open View | Checkout | Checkin | Search | Exit | ‘
IRetrieved databasze record for =sagp003.don=... I

If you wish to perform an operation on two or more documents, the easiest method is to
double-click on the documents in the Filename window. Once the required files display
in the Files Selected window you can select the desired command (Note that when you
select more than one document the Open command is not available.)

To select multiple files you may use the standard <Ctrl>+click or the ‘press & drag’
combinations. Once a group of files is chosen, the group is considered a single selection.
Use the > button to display the items in the Files Selected window.

'.1—‘: Falcon/DMS ¥5 Document Manager [DOT [Master])

File

File Selection Database MicroStation  AuiclAD “wWorkspace Help

(SIL] (e)n)

| Server File Selection

File Hame

EYEE

]

SIS E3

Files Selected:

Project [02-098345 _|

Category Il]s 002 |
Discipline Islructural |

Iaagpl]l]?.dgn

aagp001.dgn
aagp002.dgn
aagpi03.dgn

= |
=
il

IAII files (%)

|

To select all the files in a directory, use the >> button to display the contents of the entire
directory in the Files Selected window.

Use the < and << buttons to deselect combinations of files or all files, respectively.

'-:'Falcon.ﬂ'DMS ¥5 Document Manager [DOT [Master]]

File

File Selection Database MicroStation  SutcliD ‘workspace Help

(SIL] (e)n)

| Server File Selection

(=]

File Hame

SIS E3

Files Selected:

Project [02-098345

[7]

aagp001.dgn

Category [09-002 _|

Discipline Islructural |

aagp001.dgn
aagp002.dgn
aagp003.dgn
aagpi0d.dgn
aagpl05.dgn
aagp006.dgn
aagp007.dgn

aagpl02.dgn
aagpl03.dgn
aagp004.dgn
aagpl05.dgn
aagp006.dgn
aagp007.dgn
aagpl0g.dgn

All files (%)

12
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Environments

The Environments feature allows different groups or departments (or for that matter,
individuals) to work with a configuration set and a user interface specific to their unique
requirements.

-1—‘- Falcon/DMS ¥5 Document Manager [Bridge)
Database Micrastation  AutaEsir

File  File Selection
S o] Shie/els) | W v

Server File Selection 1
. zer Pref 3 m!
File Han__ = dat [master]

Project [02-098345 W | [sagp004.dgn dbalies
Department Ills 002 | aagpl0.dgn UMY ey

aagpll2.dgn traffic
Doc. Type Is‘truc‘tural J aagp003.dgn

An example of how Environments aftect the appearance of the user’s interface appears
below:

The Document Manager for the [Design] environment uses EA#, Highway#, and
SubCategory for its directory labels and has its own ‘EA#’ table. It has six system level
Keyword Categories with unique tables. Compare this with the Document Manager that
appears on the following page.

Falcon/DMS ¥5 Document Manager [Design)
File  File Selection Database MicroStation  SofoCsD Workspace  Help

sle] sl S

" Server File Selection

File Hame Files Selected: LI}
EA# [11-12920 | |o_mb10.dgn . |
Highway# Isr12 _I i .dg o
¢c_mb11.dgn
SubCategory I | c_mb2.dgn

¢_mb3.dgn
schem2d.dgn
schem3d.dgn

sdsch2d.dgn LI o |

[an files )
General Information | Directories & Keywords [ Title Block I File Format Feywords Igocument Motes I
| Directories [ Heyweords
EA# 11-12920 Contractor [lockwood greene [l |l]5.l‘21!98
Highway# sr12 Mile Post [100+5214 x| |osr1108 e
SubCategory: Expenditure# |30-30 I Il]5.f21!98 T
DirLeveld: Project Mar [frank cole =] Josm1198 ;em
DirLevels: County |fairfax R |usr3ms9 =
DirLevels: Survey [topo x| [osr21:98
Open View Checkout Checkin | Search... | Exit

Fetrieved database record for =c_mb10.dgn=... |
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The Document Manager for the [Bridge| environment (below) uses Project, Discipline,
Category, SubCategory, and DocType for its directory labels and has its own ‘Project’
table. It has three system level Keyword Categories with unique tables.

}-Falcon!DMS 5 Document Manager [Bridge)

File  File Selection  Database MicroStation  AoioCAl Workspace  Help

Elu En SkAEEE [EE=EERE Fd

" Server File Selection

File Hame Files Selected: LI}
Iaagpl]l]3.dgn

Project [02-098345

=]

Discipline |l19—002
aagp002.dgn

Category Istructural | aagp003.dgn
SubCategory I |
DocType I |

=]
aagp001.dgn
gp q = >>|

<< | =

[anfites ¢ =l

General Information I Directories & Kepwords I Title Block [ File Format Kewwords I Document Mates I

" Directories I Keywords
Project: 02-055345 Proj. Mngr. [randy mckenney | |[0211/92
Discipline: 03-002 Budget Code [bc-20 ~ | |02M11/92 Saue
Category: =tructural Gen. Contr. [ventron - | (0242492 -
SubCat ]
ul egony: Hext
DocType:
Hot Used
QOpen View Checkout Checkin | Search... | Exit

ISuccessfuIIy zaved record =sagpl03.don=... I

Selecting an Environment (Document Manager):

To set an environment or to Change the current environment:

1. From the Document Manager’s menu bar, select Workspace > Environment
> (Environment Name).

'.}- Falcon/DM5 v¥5 Document Manager [Bridge]
File  File Selection Database MicroStation  AotoCal

el Bl ChE T oy
Server File Selection
- 3
File Nan& dot [mast
Project Ill2-l198346 W I |*.* hwdraulics
Discipline [09-002 | aagp001.dgn [E—
aagp002.dgn traffic
Category Istructural I aagp003.dgn
e wl aagp0id.dgn

2. If the current project is not included in the selected environment, a message box
appears. Press OK on the Falcon/DMS message box and proceed.

Falcon/DMS

Falzan/DMS Syatern
WARMING: |rvalid entry <02-098345:
Might not be an entry in this environment
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The Server View Mode User Preference

The Server View Mode user preference allows you to view the server-based documents as
records in the database or as items in a directory listing of the actual server directory.

Enviranment  »

Directony Selection 3
Directory List Button
Minimize on open
v Button Bar
v Bottom Button Panel
v Databaze |nfo Tabs
M aster PROJECT Description
Subdirectony Description
Post Reference Dialog
v Reference File Check
Auto Delete Local Reference Files
5 ode

w Directomny

[ The Database mode displays only those items that have database records.

[ The Directory mode displays all files located in the current directory, including
those that are not in the database.

[d When in Database mode, the Directory Selection user preference is locked in
Text List Box mode.

[d When in Database mode, only those directories that contain database records
are visible. Once you add a document to an empty directory, you can access
that directory in either mode.

To create a document in an empty directory, first set the Server View Mode
to Directory.

To move or copy a document to an empty directory, first set the Server View
Mode to Directory.

To use the Add Server File command, first set the Server View Mode to
Directory.

[ The Database view allows you to more easily view database records for non-
electronic records and sets; previously these items could be seen only from a
database search result.

[ The Database view is recommended when poor network performance is an
issue.
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his chapter provides a step-by-step

explanation of the procedures used
to retrieve documents for modification or
for viewing. Included is an explanation
of how MicroStation reference files
and AutCAD Xrefs are attached and
managed.

The Falcon/DMS document retrieval
commands include the following opera-
tions:

Open (Modity)

Attach Reference/Xref Files
Refresh Files

Open (View)

Check out (Modify)

Copy Out (View)

Check In

As indicated in Chapter 1, opening a

oodoood

single document or checking out one or
more documents are the two most basic
Falcon/DMS operations.

When you open or check out a docu-
ment through Falcon/DMS, a copy of
that document (the ‘working’ document)
is placed in a predefined location on
your local hard disk where it can be
modified. The server version of this file
(the ‘record” document) is set to a view
only access mode and remains so until
the working document is checked in.

When a working document is checked
in it is removed from your workstation
and placed back on the server (becoming
the new ‘record’ document), and is once
again available to authorized users for
modification.

When you open a document, it is
checked out, if necessary the associated
application is launched, and the docu-
ment is opened in the application, all as
part of the same transaction.

When you check out one or more
documents, Falcon/DMS reserves the
documents for your use, usually to be
opened and modified at a later time.

In each instance, other users’ access to
checked out files is limited to view only;
they cannot be modified until you check
in the documents.

The ‘view’ versions of the Open and
Checkout commands (View and Copy
Out) place a ‘throw away’ copy of a
document on the local hard disk. View
documents cannot be returned to the
server and are deleted at your discretion.
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Open vs Checkout: When you open
a document, Falcon/DMS checks
out the document and, as part of
that transaction, opens the file in
the appropriate application. Given
that the open command checks out
the document as it is opened, it is
not necessary to first use the check
out command before opening a
document.

When you check out one or more
documents, Falcon/DMS reserves
the documents for your use, usually
to be opened and modified at a
later time.

In each instance, other users’ access
to checked out files is limited to
view only; they cannot be modified
until you check them in.

The Open command is available
only when you select a single docu-
ment, while the Checkout command
can be used to reserve multiple
documents.

=" ATTENTION

When a user opens a document that
has already been checked out to
that user’s workstation, Falcon/DMS
knows to open the local version of
the file, even if the user selects the
file from the Server File Selection
region. It is not necessary to set File
Selection to Local File Selection to
open checked out documents.

v TIP

When you select a single file it is
not necessary to display that file-
name in the File Selected window.
Simply click on the desired file—its
name will display in the File Name
field—and select a command.

The Document Manager (Windows)

Open (Modify)

The Open (Modify) command places the working document on your local hard disk.
The record document remains on the server as a view only file.

To open a document:

1. From the Windows Start Button, select Programs > Falcon/DMS > Doc.Manager.
The Falcon/DMS Document Manager opens.

tIH Suzpend

2. From the Server File Selection region, designate the current directory.
3. In the File Name list window, select a single document.

3. On the General Information tab, check the document’s Availability and access
Status.
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4. If the document’s Availability is ‘On Server’, press Open (or select File > Open).

If the document’s Availability is ‘On Workstation’ and the Access status permits
you to view the file, you can press View to copy out the file as a view only
document
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Open (Modify)—From the Checked Out to <user> dialog box

The Checked Out to <user> dialog box lists all the files that are checked out to you on
the current workstation. This command is especially useful when you have checked out
files from multiple projects and subdirectories.

To open a document from the Checked Out to <user> dialog box:

1. From the Document Manager’s menu bar, select File Selection > Checked
Out to <user>.

'.1—‘: Falcon/DM5 ¥5 Document Manager [DOT [Master])
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2. From the Files Checked Out to <user> dialog box, select the file you wish
to open.

3. Press Open.

Files Checked Out to <THOMAS / SNOWMASS>

01-045830004-002 structuraltjis_al.dwg
01-045830004-002'structuralijis_a2.dwg
01-045830004-002 structurallanger.dwg
02-098345109-002\structural'aagp01.dgn
02-09834509-002structural'aagp002.dgn

flood_controllock10-a.dgn
flood_controllock10-b.dgn
flood_controlllock10-c.dgn




The Document Manager (Windows)

1= ATTENTION The Select Application Option

Falcon/DMS can be configured to

redirect MicroStation’s and Auto. Multiple applications can be associated with a single file format. For example, a file format

CAD's File > Open and File > New that describes an image file (tiff; jpeg, bmp, etc.) could be associated with the Windows
commands, and MicroStation’s Refer- Image Viewer (for viewing) and Adobe Photoshop (for imaging editing). In the case of
ence > Attach command. When MicroStation and AutoCAD, difterent applications and workspace configurations can be

the command redirects are enabled,
affected commands will open the

Falcon/DMS Document Manager. When multiple associations exist for a file format, the Document Manager presents a list
box after you select the Open command. To proceed, simply double-click the desired

associated with the ‘igds” and ‘acad’ file formats.

application on the Select Application box.
Application
bridge_{ws) OK

design_(ws) Reference Files and Xrefs
geopak_(app}
microstation :

When Falcon/DMS opens or checks out a MicroStation design file or AutoCAD draw-
ing file, it also determines which files, if any, are externally referenced to document.
Falcon/DMS then ‘copies out’ the reference files to your local workstation. Do not
confuse ‘copy out’ with ‘checkout; to ‘copy out’ a file does not effect its Availability.

Before any reference file is copied to your workstation Falcon/DMS performs a number
of database checks. The first is to insure that Falcon/DMS provides the most current
version of the reference file available on the server. The second is to identify when a
reference file may not be the most current version of the document. This usually occurs
when another user has checked out a file that is referenced to your active document.

In this case, Falcon/DMS identifies the user and the workstation to which the reference
file is checked out.

Typically, the reference file is copied to c:\dms_local\ref for MicroStation files and
c:\dms_local\xref for AutoCAD files. This directory is defined by the Falcon/DMS
administrator.

For MicroStation users: Because MicroStation with Falcon/DMS is configured to look
for reference files in a specific location (i.e. ¢:\dms_local\ref) it is not necessary to enable
the Save Full Path option.

Because the reference files are ‘copied out’ rather than ‘checked out’, they are considered
to be ‘throw-away’ files and cannot be returned to the server. Reference files remain

on your workstation until you delete it (deleting reference files is discussed later in this
chapter).

The Reference File User Preferences

[d Post Reference Dialog: When enabled, the Refence File list box opens each time a
document to which reference files are attached is opened or checked out.

[ Reference File Check: When enabled, Falcon/DMS performs a reference file
check for files as they are opened or checked out. When checking out multiple
files, it is recommended that you turn oft the Reference File Check preference,
then turn it on before you open any checked out document.

[ Auto Delete Local Reference Files: When enabled, Falcon/DMS automatically
deletes local reference files when the parent document is checked in. It is important
to note that when Auto Delete is enabled, Falcon/DMS has to download reference
files each time you open a MicroStation or AutoCAD document, resulting in
increased network traffic.
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The Reference File list box

When the Post Reference Dialog user preference is on, each time a document to which
reference files are attached is opened or checked out, the Reference File List box opens.
In addition to the filename, this list box provides the following information about each
reference file:

The status of each reference file

[ Downloaded for view—a local version is not found; the reference file is copied
out for view.

[ Local version is current with server—a local version is found; because the local
version is identical to the server version no action is taken.

[d Not database record—either a reference file does not have a record or Falcon/DMS
is unable to resolve the attachment; see the Falcon/DMS administrator.

The pesent location of the most current version of theeach reference file.

[ Server—the most current of version of the original file is not checked out.
A <user/workstation>—the most current version of the original file is checked out
to the identified user on the identified workstation.

Filename - Downloaded for view - (Server)

This status indicates that all the attached reference files have been downloaded to the
local hard disk. The notation ‘(Server)’ indicates that the most current version of the
original of each reference file is not checked out. The MicroStation Reference File List
and AutoCAD Xref File List forms shown below are typical.

MicroStation Reference File List

L er)
aagpli1.dgn - Downloaded for View - (Server)
aagp002.dgn - Downloaded for View - (Server)
aagpl07.dgn - Downloaded for View - (Server)
aagp010.dgn - Downloaded for View - (Server)

AutoCAD Xref File List

W - (Server)
pump.dwg - Downloaded for View - (Server)
zkl47_2.dwg - Downloaded for View - (Server)

Filename - Local version is current with server - (Server)

This status indicates that all the attached reference files have already been copied to the
local hard disk and that they are identical to their server versions. In this case no reference
files are recopied to the local hard disk.

MicroStation Reference File List

- - {Server)
aagpl02.dgn - Local version is current with server - {Server)

aagp007.dgn - Local version is current with server - {Server)
aagp010.dgn - Local version is current with server - {Server)
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Filename - Updated local version with server - (Server)

This status indicates that the local versions of two of the five reference files have been
downloaded again. At some point, between the time the active file was closed and/or
checked in and then reopened, another user modified and then checked in the indicated
files.

MicroStation Reference File List

- (Server)
aagp001.dgn - Local version is current with server - (Server)

aagp010.dgn - Local version is current with server - (Server)

Filename - Local version is current with server - (workstation/user)

This status appears when all the attached reference files are already on the local hard disk
and that they are identical to their server versions. However, the indicated files, while
current with their server versions, are no longer the most current versions of the files.
Note that the workstation and user to whom documents are checked out are identified.
(The Refresh Reference File command, available in the MDL version of the Document
Manager, can be used to retrieve a more current version of these files.)

MicroStation Reference File List

-{Server)
aagp001.dgn - Local version is current with server - (Server)
aagp002.dgn - Local version is current with server - (Server)

Filename - No Database Record

This status appears when a reference file does not have a database record or Falcon/DMS
is unable to resolve the attachment Usually a file without a database record will not
display in the parent design file. Please see the Falcon/DMS administrator when this
notation appears.

MicroStation Reference File List

aagp002.dgn - Local version is current with server - (Server)
aagp007.dgn - Updated local version with server - (Server)

aagp010.dgn - Updated local version with server - (Server)
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Attaching MicroStation Reference Files from the Document Manager 1= ATTENTION

It is strongly recommend that you use the Falcon/DMS Attach Reference File command
to attach reference files to the active design file. When you use Falcon/DMS, the
Document Manager writes a system generated reference file path logical to the active
design file. This insures that Falcon/DMS always finds the correct file without the need
to define multiple MS_RFDIR values in workspace configurations. (This occurs only for
database types that permit a specific filename to be used more than once.)

Note: A detailed explanation of how Falcon/DMS uses reference file path logicals is provided
in the Administrator Guide.

Because most organizations now configure Falcon/DMS to use UNC or FTP to access
network resources, the only access to the production design files on a file server is
through Falcon/DMS. This means that when mapped network drives are not defined,
MicroStation’s Attach Reference command cannot see the server-based production
directories.

When MicroStation’s Falcon/DMS file format (igds) is defined, the standard attach
reference file command is often ‘redirected’ to Falcon/DMS. Thus, when a user selects
MicroStation’s File > Reference File > Attach command, the Falcon/DMS Document
Manager opens instead of the standard MicroStation dialog box.

To attach a reference file to the active design file:

Falcon/DMS requires that the document to which you are attaching reference files be
open in MicroStation.

1. If necessary, navigate to the directory that contains the document you wish to
attach as a reference file. (Because Falcon/DMS will build its own path logicals the
document can exist anywhere within the data structure.)

2. Select the document you wish to attach as a reference file. From the Falcon/DMS
menu bar, select MicroStation > Attach Reference File.
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3. At this point Falcon/DMS turns the task over to MicroStation—proceed as
usual.

MicroStation Users: It is important
that new reference file attachments
be made for the following reasons:

1. It is difficult for MicroStation to
access the production area of a
server when mapped network drives
are not defined.

2. Falcon/DMS writes a system gener-
ated reference path logical to the
active design file, insuring that the
Document Manager is always able
to locate all reference files. (This
applies to installations that are not
configured for unique filenames.)

3. Falcon/DMS is often configured
to ‘redirect’ the File > Reference >
Attach command to the Document
Manager.



v TIP

When attaching a reference file with
Falcon/DMS, it is not necessary to
enable the Save Full Path option on
MicroStation’s Attach Reference File
dialog box.

IS ATTENTION

Except for the Attach Reference
command, all reference file opera-
tions are performed with standard
MicroStation Reference File com-
mands.

The Document Manager (Windows)

Attaching AutoCAD Xref Files from the Document Manager

[ The Falcon/DMS Attach Xref command invokes AutoCAD’s standard Insert >
Internal Reference > Attach operation and should be used only when unique
filenames are required.

1 For databases configurations that permit duplicate filenames, continu to attach
Xrefs through the AutoCAD interface.

To attach an external reference file to the active drawing file:

Falcon/DMS requires that the document to which you are attaching external reference
files be open in AutoCAD.

1. If necessary, navigate to the directory that contains the document you wish
to attach as a reference file.

2. Select the document you wish to attach as a reference file. From the Falcon/DMS
menu bar, select AutoCAD > Attach Xref > Attach.

'_1-‘: Falcon/DM5 ¥5 Document Manager [DOT [Master]]
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3. At this point Falcon/DMS turns the task over to AutoCAD—proceed as

usual.
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Detaching a Reference / Xref File v TIP
Because Falcon/DMS verifies refer-
Use the standard method prescribed by MicroStation and/or AutoCAD to detach refer- ence files each time it opens a design
ence files. file, it is recommended that you not
delete local reference files until after
Deleting Local Reference / Xref Files a design file is completed.

Falcon/DMS provides two ways to ‘throw away’ the local reference files:

[d Auto Delete: When enabled, Falcon/DMS automatically deletes the appropriate
local reference files when the parent file is checked in.

[ Local File Selection > Delete: This procedure allows you to view the contents of
the local reference directories and select and delete files at your own discretion.
(The local reference directories are usually c\dmslocal\ref\ [for MicroStation] and/or
c\dmslocal\xref\ [for AutoCAD].)

Enabling Auto Delete:

From the Document Manager’s menu bar select Workspace > User Preference > Auto
Delete Reference Files > On.

As a document is checked in, Falcon/DMS identifies and deletes the appropriate local
reference files, if any.

Manually Deleting Local Reference / Xref Files:
1. Set File Selection to Local File Selection.

2. The Document Manager’s current directory becomes the local working
directory—the default is c¢:\dms_local\.

3. Navigate to c:\dms_local\ref for MicroStation or c:\dms_local\xref for
AutoCAD.

4. Select the file or files that you wish to delete. Press Delete (or select File
> Delete).

On the Falcon/DMS Confirmation box select Yes to delete files individually or
Yes to All to delete all selected files.

Attention MicroStation Users:

You cannot delete a reference file attached to the active file—Falcon/DMS
does not permit reference files attached to the active file to be deleted. If you
attempt to delete any of the active document’s reference files, Falcon/DMS
ignores the operation.




4+ WARNING: Refresh Local

& Refresh Server

USE WITH CAUTION—Be guided
by the basic rule of carpentry when
using these commands: measure
twice, cut once.

Refresh Local File: Because the local
file is overwritten by a fresh copy
of the server-based original, any
modifications made to the local file
are lost.

Refresh Server File: This command
overwrites the server-based record
copy of a file with its working ver-
sion. If the server file is unintentially
refreshed you will have to retrieve a
new record version from backup.

I ATTENTION

The MDL version of the Document
Manager permits you to refresh the
local copies of any reference files
attached to the

The Document Manager (Windows)

File Refresh Commands

Because these commands are essentially copy and replace operations, they should be used
with caution.

The Windows Document Manager provides the following Refresh File operations:

The ‘Refresh Local File’ Command

The File Refresh > Local Design File (MicroStation) and the File Refresh > Local
Drawing File (AutoCAD) commands permit you to automatically retrieve and open a
‘fresh’ version of your current file. Because the local file is overwritten by a fresh copy of
the server-based original, any modifications made to the local file are lost.

To refresh a Local File:
1. From the Document Manager’s memu bar,
choose MicroStation > File Refresh > Local Design File,
or
choose AutoCAD > File Refresh > Local Drawing File.
2. Press OK on the Refresh Local Design File alert box.

The ‘Refresh Server File’ Command

The Refresh Server File command permits you to automatically refresh the server-based
original with the current file without closing the current file. Please note that if the server
file is unintentially refreshed, you will have to retrieve a new record version from backup.
[Use this command with caution.]

To refresh a Server File:

1. From the Document Manager’s memu bar,
choose MicroStation > File Refresh > Server Design File,
or
choose AutoCAD > File Refresh > Server Drawing File.

2. Press OK on the Refresh Server Design File alert box.
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Open (View)

The Open (View) command permits you to view a document without checking it out
from the database. Use this command to view a document that is checked out to another
user. When you view a document, a copy of that document is placed in the ‘view’
directory on the client workstation (usually c:\dms_local\view).

To view a document:

1. From the Server File Selection region, designate the current directory.

2. From the File Name list window, select a document.

3. Press View (or select File > View).

4. The Falcon/DMS Information box indicates that the file is read only. Press OK.
Falcon/DMS copies out and opens the selected document for viewing.

To view a document already copied out for viewing:

A view file that is copied out to the requesting workstation remains available for viewing
until the file is deleted (see next section). If you do not wish to update a copied out

file with its server version, you may view the copied out version of the document by
setting the File Selection to Local.

1. From the File Selection menu, choose Local File Selection.

2. In the Local File Selection region, navigate to the project under the c:\dms_local\view
directory.

3. From the File Name list window, select a document.
4. Press View (or select File > View).

5. A Falcon/DMS Alert box opens, indicates that the file is on your workstation,
and asks if you want to view the server file. Click Cancel to view the local file
or OK to view the server file.

6. A Falcon/DMS Information box opens, indicating that the file is read only.
Press OK.

Falcon/DMS opens the selected document for viewing.




vv HOTTIP

When checking out multiple files, it
is recommended that you turn off
the Reference File Check preference,
then tumn it on before you open a
checked out document.

The Document Manager (Windows)

Checkout (Modify)

The Checkout (Modify) command permits you to checkout one or more dcouments to
a client workstation and reserve them for modification. Until they are checked back
into the database, Falcon/DMS restricts access to the original documents on the server
to view only.

To Checkout a document for modification:

1. From the File Selection menu, choose Server File Selection.

2. From the Server File Selection region, designate the current directory.
3. From the File Name list window, select one or more documents.
4

. Press Checkout (or select File > Checkout).

Copy Out (View)

The Copy Out (View) command permits you to copy multiple files to your workstation
without checking them out from the database; the server-based record version of docu-
ments remain available to be opened or checked out by another user.

When Falcon/DMS is used to view a design file, a copy of that file is placed in a ‘view’
directory under the application’s working directory (usually c:\dms_local\view).

To Copy Out multiple documents for viewing:

1. From the File Selection menu, choose Server File Selection.

2. From the Server File Selection region, designate the current directory.
3. From the File Name list window, select one or more documents.
4

. From the menu bar, select File > Copy Out (View). Use the View command to
open the documents in the associated application.

Deleting ‘View’ Documents

A view file that is copied out to a workstation is considered to be a ‘throw away’
file and may be deleted through the Windows Explorer or through the Falcon/DMS
Document Manager.

To delete a local document/documents copied out for viewing:
1. From the File Selection menu, choose Local File Selection.

2. In the Local File Selection region, navigate to the project under the ¢:\dms_local\view
directory.

3. From the File Name list window, select the documents you wish to delete.

4. Press Delete (or select File > Delete). On the Falcon/DMS Confirmation Box,
press Yes or Yes to All
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Check In

The Check In command returns checked out documents to the server and updates
the database record of affected documents, making each available to other users for
modification. Falcon/DMS provides several ways to check in documents:

To check in a document—Server File Selection:

1. From the File Selection menu, choose Server File Selection.

2. From the Server File Selection region, designate the current directory.
3. From the File Name list window, select the file/files to check in.

4. Press Check In (or select File > Check In).

To check in a document from the Checked Out to <user> dialog box:

The Checked Out to <user> dialog box lists all the files that are checked out to you on
the current workstation. This command is especially useful when checking in files from
multiple projects and subdirectories.

1. From the Document Manager’s menu bar, select File Selection > Checked
Out to <user>.

2. From the Files Checked Out to <user> dialog box, select the file/files to
check in.

3. Press Check In.

Creating Records with the Check In Command

When a list of files selected for check in contains documents for which database records
do not exist, Falcon/DMS can create the necessary records as part of the check in
operation. This feature is especially useful when working with applications that generate
new files locally that you want Falcon/DMS to manage.

For Falcon/DMS to check in a set of files containing these new, local items and create
their database records, you must select the files from a Local File Selection. Otherwise, the
Document Manager will not be able to see the new files.
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The Document Manager (Windows)

To create database records during check in [Local File Selection]:

1. Set the Directory Selection to Local File Selection. Navigate to the desired local
directory and select the files to be checked in. (Whether all files have database
records does not matter at this point.)
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2. Press Check In. Falcon/DMS first checks in all documents with database records.

3. The Document Manager then displays a message box indicating the number of
documents not in the database. You have the option of adding them to the database
or leaving them on the local workstation.

Falcon/DM5

(1)

On the Falcon/DMS message box, click Yes to add the documents to the
database. The Add Local Document dialog box opens. A complete explanation
of the Add Local Document dialog box is provided in Chapter 3 (see Add
Local File command)

For any ‘create-record-on-check-in’ scenario, Falcon/DMS requires that a file
format be assigned to each new record. A file format can be assigned automatically
or manually. The automatic process uses a predefined list to associate a filename
extension with a file format. Each file format, in turn, is associated with one or
more applications. This enables the Document Manager to automatically launch
an application based on a document’s file format.

The File Format region on the Add Local Document dialog box provides two
options: ‘Use Predefined File Format Mapping List <View/Edit>’, and ‘Use
Selected File Formats for all Files’.

The first option is discussed on the following page. Steps 4 and 5 (below)
demonstrate the second option.

‘Use Selected File Format for all Files” allows you to assign the file format selected in
the File Format drop-down list box to all new files. (When a file format association
exists for the current file, the File Format field is automatically filled in.)

4. On the Add Local dialog box, select the ‘Use Selection File Format for all
Files” option and press OK.
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Add Local Document
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5. Select one of the following options:

[ Yes—to add the current local file with the selected file format.

[ Yes to All—to add all the identified local files with the selected file format.

[ No—to skip the current file and advance to the next item in the selection
list.

A Edit Record—to return to the Add Local Document dialog box

[ Cancel—to cancel the current operation.

The ‘Predefined File Format Mapping List’ option:

‘When selected, the ‘Use Predefined File Format Mapping List’ option automatically
associates an extension with a file format. This process uses the System File Format
Mapping list, defined by the Falcon/DMS administrator. Falcon/DMS allows you to
create a local File Format Mapping list to define associations not available in the system
list.

To open the File Format Mapping dialog box, press View/Edit in the File Format
region of the

To define a local File Format Mapping scheme:
1. On the File Format Mapping dialog box, press Add.

2. In the extension field, enter an extension. The maximum length is twenty
characters, not including the period delimeter.

3. From the File Format drop-down list box, select a file format. Press OK.
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Prompt for Backup
Falcon/DMS provides for the automatic backup of MicroStation and AutoCAD docu-

ments.

The backup can be configured to save the file to a designated backup directory on the
server or to the file’s server-based home directory.

The most common backup configuration prompts you for a backup. Under this configu-
ration you are asked to create a backup when you exchange one file for another or when
you exit MicroStation or AutoCAD.

User Defined Filters

Falcon/DMS supports up to four user defined file filters. Simply enter a filter string in the
filename field and press <Enter> or <Tab> out of the field. A rolling list of user defined
filters is added to the bottom of the filter drop-down list box.
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Chapter 3:
The New

N o '.-&- . Document
PR Comma nds

he focus of this chapter is on how
to use Falcon/DMS to create a
document and its database record.
The topics discussed in this chapter
are:
(d The Create New File Command
(1 The New Revision Command
(d The Add Local File Command
(1 The Add Server File Command
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The Create New File Command

The Create New File command permits you to create a new document file and its
database record.

To Create a Document:

1.

On the Document Manager, select File > New > File Format. (Only File
Formats that have templates are available.) The Create New Document dialog

box opens.
Create New File
| u | me_wordwnormal.dot EIDWSB---l ‘
" Hew File Location
Project [11-12820 v | [ile Hame
Inewﬁle.doc| = i
S I " Cancel |
Discipline [sr12 —I [~ Open Document

Ca‘tegoryl W I [~ Checkout Document

™ Display Database Tabs

SubCategory | Y | [~ Unload DOC MAHAGER
DocType I— " I [ Keep Dialog Open After Create

General Info I Fewmmards I Title Black r File Farmat K.ewwords
Description |
Docurnent # | Rev #| | Sheet # [

Status I j ) I File Format Iword vl
Last Modified Date |umms Created By |thomas ! |l]?.f0?.f99 Clear Data |

|F'erform the Create operation. |

If it is necessary to use a template file other than the default, click the Browse
button to the right of the Template field. From the Select a New Template dialog
box, select a template as needed.

Miscellaneous Options:

[d Open document: Checks out and opens the new design file.

(A Checkout document: Checks out the new document (otherwise, the document
is moved up to the server and its Availability set to ‘On Server’).

(4 Display database tabs: Displays the database tabs.

[d Unload DocMan: Closes the Document Manager after the operation
completes.

d Keep dialog box open: Maintains the Create New File dialog box as the

current dialog box.

Select the server-based home directory into which the new file will be placed.

In the File Name field, key in a file name. Fill in database fields as necessary—
Falcon/DMS alerts you to which fields are required.

Press OK.
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Revision Control o TERMS

History Mode: The current
revision is the document
with the original filename.
its (database) revision

Revision Control is designed to track revisions in one of two modes—a History mode
or an As-Built/Work-in-Progress mode. The key difference between modes is in how
each identifies the current revision.

Revision Control schemes can vary between file formats and can be enabled for some number will always be one
and not for others. Revision Control can be configured to create a new revision at file increment greater than the
checkout or file checkin, either automatically or at a prompt. Finally, Revision Control last backup.
can be configured to allow you to create a revision whenever you deem it appropriate. As-Built: The current revi-
We will consider this option—creating a new revision at your discretion. sion is the document whose
filename and (database)
History Mode revision number have the

In the History mode, the current revision is the document with the original filename,

also referred to as the working document. Revision Control creates a backup of the
working document, usually appending a revision number to the filename of the backup,
and incrementing the revision number of the working document’s database record. In
other words, the working document’s filename does not change and its (database) revision
number will always be one increment greater than the last backup.

For example, lock10a.dgn is the working document for which no revision has been
created. Revision Control creates a backup of this document named lock10a.dgn.revO0.
The revision field in the database record for lock10a.dgn, the working document and
current revision, is updated to read revision equal to 1. The revision field in the database
record for lock10a.dgn.rev0, the backup and now previous revision, remains empty.

In this scheme, the current revision is lock10a.dgn because its (database) revision number
has the highest increment.

As-Built/Work-in-Progress Mode

In the As-Built/Work-in-Progress mode, Revision Control copies the working docu-
ment and assigns a new revision notation to its filename. The working document will
always be an incremented version of the original document, which ‘owns’ the original
filename.In other words, both the working document’s filename as well as its (database)
revision number change.

For example, aagp003.dgn.revA is the working document; its (database) revision number
reads revision equal to A. Revision control creates a copy of this document named
aagp003.dgn.revB; its (database) revision number reads revision equal to B.

In this scheme, the current revision is aagp003.dgn.revB because both its filename and its
(database) revision number have the highest increment.
Miscellaneous

For AutoCAD documents, Revision Control is configured to insert the revision notation
between the filename and the extension.

Revision Control is often configured to move the previous revision to a subdirectory
of the current directory. If so, only the current revision will be displayed in the current
directory.

The previous revision can be assigned a Document Status with an access mode of view
only or no access.
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15 ATTENTION To create a new revision—History mode

To create a new revision of a docu-
ment, its Availability must be ‘On
Server’.

1. From the Document Manager, select a filename. Verify that the document’s
availability is ‘On Server’. Note that in the example lock10-a.dgn does not have
yet have a revision number.

3

L Falcon/DMS 5 Document Manager [DOT [Master])

Ldd Lol Fe.. File Hame
Add Server Files... bntrol W I Ilock1l]-a.dgn . |
Open [Modif K i g
EEen [MEW]P] — —I lock10-b.dgn et |
) ki I lock10-c.dgn
Checkout [Modify] lock11-a.dgn
Copy Out [Yiew] lock11-b.dgn e |
Check In lock11-c.dgn
_— lock11-d.dgn [ = |
Mave. ..
Cony.. |.m| files (*.%) |
Copy/Replace... - - - -
= Directories & Kewwords I Title Block I File Format K.ewmsords
ENamE...
Delete
am #10: James River, Richmond: Main equipment & rac
Sets 3
—— lecs . o sl
Location Checkout...
Laocation Check In... vl ! [ Rev #I ! ormat |igds

2. From the Falcon/DMS menu bar, select File > New Revision. The New
Revision dialog box opens.

3. In this example the Document # field can be edited. Edit as required and
click the OK button.

Hew Revision

 Create Mew Revision

Filename lock10-a.dgn

Drawing Number 14 0/37-30CE-REY|

Revision 1 Revision Date I
Status gy Falcon/DM5 ¥5 Document Manager [DOT [Master]) M= E3

File File Selection Databasze MicroStation  AofcCA0 wWoaorkspace Help

— Current f
(SIL] [ln)
File Hame Files Selected: L]

Filehar | ~Server Fie Selection
Project Iﬂood_control W | Ilock1l]-a.dgn -
Revigic - l— ¥ |
eqony |
Status lock10-a.dgn.revd
Discipline I b | lock10-b.dgn

lock10-c.dgn
lock11-a.dgn
lock11-b.dgn

Dirawin

lock11-c.dgn ;I < |
IAII files (*.%) =l
LG | Informati [ Directaries & Kewwards I Tithe Black I File Farmat K.emuaord: I Document Nates I
Description ILock & Dam #10: James River, Richmond: Main equipment & raceways
Document # [DACW37-90CB-REV1 Rev # [1 # [osi11/1998 Sheet # | Save
Status Iac‘tive Ra File Format Iigds Prev
Availability |On Server e
Last Modified Date |nmmsss Created By Isynnott_tm / |n1 231998
Open | View | Checkout | Check In | Search... | Exit

IRe{rieved database record for <lock] 0-a.dgn=... I
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The Add Local Files Command

The Add Local Files command permits you to add files located on a client workstation to

the database, and then move the files to the server. For example:

An outside consultant provides your organization with a set of documents that are to be
used in the development of a project. The documents must be available to every person
working on the project. This is accomplished with the Add Local Files command

To add a local document

1.

From the operating system, place the files in the Falcon/DMS local working
directory (usually c:\dms_local). Open the Document Manager.

From the File Selection menu, choose Local File Selection.
From the File Name list window, select the files you wish add to the database.

On the Document Manager, click the Add Local Files button (or
choose File > Add Local Files).

'.1-‘: Falcon/DM5 ¥5 Documd
File  File Selection  Database

The Add Local File dialog box opens.

Srrver File SelErt

Miscellaneous Options:

'.1—‘: Falcon/DM5 ¥5 Docums
File  File Selection  Database

[d Checkout document: Checks out the new document

(otherwise, the document is moved up to the server, its
Availability set to ‘On Server’).

Display database tabs: Displays the database tabs.

Unload DocMan: Closes the Document Manager after the operation
completes.

Retain database information for current session: Retains the database information

for multiple documents

Use Predefined File Format Mapping List <View/Edit>: Automatically
associates an extension with a file format. Useful when a file set contains files

| I S S W

for different applications and filenames with different extensions. (Please refer
to page twenty seven for additional information.)

[ Use Selected File Format for all Files: Assigns the file format selected in the
File Format drop-down list box to all new files.

In the Add to region, designate the server-based target (or home) directory.
Enter information and define settings on the General Info, Keyword, and Title
Block tabs, as required.

Click the OK button. Select one of the following options:

[ Yes—to add the current local file with the selected file format.

[ Yes to All—to add all the identified local files with the selected file format.
[ No—to skip the current file and advance to the next item in the selection.
(1 Edit Record—to return to the Add Local Document dialog box.

[ Cancel—to cancel the current operation.

=Jd NOTE

This capability is especially useful
when a user is permitted to create
files on his local workstation with
the intention of eventually placing
one or more of these files under the
control of Falcon/DMS.

= NOTE

The Check In command can also be
used to create records for local files
that are not yet controlled by Falcon/
DMS. When using this approach you
do not have the option to checkout
files as their records are created.



m The Document Manager (Windows)

1= ATTENTION The Add Server File Command

The Add Server Files command
is available only when the Server . . . ] } . o
View Mode user preference is set in their server-based home directory. The operation of this command is very similar to
to ‘Directory’. When Server View that of the Add Local command.

Mode is set to Database, files without
database records do not display.

The Add Server File command permits you to create database records for files located

To add a file located on the server:

1. From the operating system, place the files in their server-based home directory
(access to the server is required). Open the Document Manager.

2. From the File Selection menu, choose Server File Selection.Designate the directory
containing the files to be added to the database as the current directory.

3. From the File Name list window, select the files you wish add to the database.
4. On the Document Manager, choose File > Add Server.

The Add Server File dialog box opens.

Miscellaneous Options:

[d Checkout document: Checks out the new document (otherwise, the document
is moved up to the server, its Availability set to ‘On Server’).
Display database tabs: Displays the database tabs.
Unload DocMan: Closes the Document Manager after the operation

Retain database information for current session: Retains the database information
for multiple documents

Use Predefined File Format Mapping List <View/Edit>: Automatically
associates an extension with a file format. Useful when a file set contains files

a
a
completes.
a
a

for different applications and filenames with different extensions. (Please refer
to page twenty seven for additional information.)

[ Use Selected File Format for all Files: Assigns the file format selected in the
File Format drop-down list box to all new files.

5. In the Add to region, enter information and define settings on the General Info,
Keyword, and Title Block tabs, as required.

6. Click the OK button. Select one of the following options:

[ Yes—to add the current local file with the selected file format.

A Yes to All—to add all the identified local files with the selected file format.
[ No—to skip the current file and advance to the next item in the selection.
[ Edit Record—to return to the Add Local Document dialog box.

[ Cancel—to cancel the current operation.
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Chapter 4
Document

Manipulation

Falcon/ DMS helps manage the inevi-
table changes to a database with a
full complement of document manipula-
tion commands. The Move, Copy,
Copy/Replace, Rename, and Delete
commands are designed to make safe
what could be treacherous operations
without Falcon/DMS. For example:

d Falcon/DMS will not move, copy,
delete, or otherwise manipulate a docu-
ment until it satifies all the database rules
that govern such procedures.

[ When a document is renamed a
record of its former name is maintained
in the database.

d Documents are NOT necessarily
deleted, rather they can be marked for
deletion in your database and moved to
a special location from which they can
be easily restored.
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Source Directory—The directory
containing the document/documents
to be moved or copied.

Target Directory—The directory to
which the document/documents is
moved or copied.

I ATTENTION
To move a document, its Availability
must be ‘On Server’.

=<1 NOTE

When a single document is moved,
copied, copied and replaced, or
renamed you may enable either the
‘Open’ or the ‘Checkout’ option.
When multiple documents are
selected only the ‘Checkout’ option
is available.

The Document Manager (Windows)

The Move Document Command

Use the Move command to move documents from one location to another and update
their database records. The directory containing the documents to be moved is the source
directory. The directory to which the documents are moved is the target directory. To
move a document, its Availability must be ‘On Server’.

To move a document:

1. From the Server File Selection region, make the source directory the current
directory.

2. From the File Name list box, select the document or documents to be moved.

3. Press Move (or select File > Move). The Move Document dialog box opens.

Move Document

| Move fromlﬂDDd_l:Drl'lrlJllchk1 0-a.dgn ‘

Project I:flood_control N File Hame

Ilock1 D-a.dgn

I W Cancel
Category [~ Open Document
Discipline I W I [~ Checkout Document Help

™ Display Database Tabs

Item Selection [ Unload DOC MAHAGER

01-045630 -
01-045830

01-045831

i01-047830

012785

012786

02-098345 dz I Title Black r File: Format K.epwaords
02-437560
02-945834
03-437560
03-860540

332323335 = [ Revafa i [m2308 Sheet # [

I File F at I d vl
oK I Cancel | ! |od:28:98 lle Format figds

L L CreatedBy|synnott_tm i |01r23!98 Clear Datal

" Move to

uild

I

River, Richmond: Main equipment & raceways

|S elect a Project from a list of existing Projects. |

Miscellaneous Options:

[ Open document: Checks out and opens the new design file.

[d Checkout document: Checks out the new document (otherwise, the document
is moved up to the server, its Availability set to ‘On Server’).

A Display database tabs: Displays the database tabs.

[ Unload DocMan: Closes the Document Manager after the operation
completes.

4. In the Move To region, designate a target directory.

5. Press OK.
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The Copy Document Command =J NOTE

The Copy command captures the
document’s previous name in the
database. This information is avail-
able to the Falcon/DMS Administra-
tor.

Use the Copy Document command to copy a document/documents and create database
records for the new files.

The Primary Index Key & the Copy Command: The level of filename uniqueness allowed
by Falcon/DMS affects the operation of the Copy Document command:

[d When the database requires unique filenames, the Copy Document command
forces you to specify a new filename.

[d When the database does not require unique filenames, it is possible to use
non-unique filenames in the target directory—you have the option of keeping the
original name, or providing a new name for each file as it is copied. Falcon/DMS
will check the database rules that govern filename uniqueness and indicate whether
a filename is valid. If a filename is invalid, assign a different name.

Copy Document

‘ Copy fromlﬂDDd_ch‘trDl\chk1 0-a.dgn ‘

Project Iflood_con‘trol ll File Hame

Copyto

||ock1n-h.dgn

I Cancel
Category ll [~ Open Document =
Discipline I W | [~ Checkout Document Help

X Display Database Tabs
[~ Unload DOC MAHAGER
™ Keep Same File Hame

To copy a document (Availability = On Server):

1. From the Server File Selection region on the Document Manager, designate the
source directory as the current directory.

2. From the File Name list box, select the document or documents to be copied.
3. Press Copy (or select File > Copy). The Copy Document dialog box opens.
4. In the Copy To region, designate a target directory, then key in a filename.

If the database permits duplicate filenames you may enable the ‘Keep Same
Filename’ option.

5. Press OK.
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To copy a document (Availability = On Workstation [your workstation]):
Use this procedure to copy a file that is checked out to your workstation:

1. From the Server/Local File Selection region, designate the source directory
as the current directory.

2. From the File Name list box, select the checked out document or documents
to be copied.

3. Press Copy (or select File > Copy). The Copy Document dialog box opens.
4. In the Copy To region, designate a target directory and key in a filename.

If the database permits duplicate filenames you may enable the ‘Keep Same
Filename’ option.

5. Press OK. On the message box, press Yes to copy the local file,

or

press No. A second message box opens. Press Yes to copy the server file.
To copy a document (Availability = On Workstation [another workstation]):
Use this procedure to copy a a file checked out to another user’s workstation.

1. From the Server/Local File Selection region, designate the source directory
as the current directory.

2. From the File Name list box, select the checked out document or documents
to be copied.

3. Press Copy (or select File > Copy). The Copy Document dialog box opens.

4. In Copy To region, designate a target directory and key in a filename.

5. Press OK. On the message box, press Yes to copy the server version of the file,
or

press No to terminate the command.
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The Copy/Replace Document Command 1= ATTENTION

The Copy/Replace Document command permits you to replace one document (the target
document) with a copy of another (the source document). The Availability of both the
‘target’ and ‘source’ documents must be ‘On Server’.

The content of the target document changes while its name remains the same.

The target document’s database record is only partially altered—Falcon/DMS keeps the
original creation, archive, backup, and location dates, as well as the archive time.

Why is this information retained? Perhaps an error is made in identifying the target design
file and remains undiscovered for several days or weeks. In other words, the wrong

file was overwritten. Because the archive information is unaltered, the Falcon/DMS
administrator can determine precisely where in your system backup the previous version
of the overwritten target design file can be found .

To copy/replace a document:

1. From the Server File Selection region, designate the source document’s directory
as the current directory.

2. From the File Name list box, select the source document/documents.

3. From the File menu, select the Copy/Replace command. The Copy/Replace
Document dialog box opens.

4. In the Replace File region, designate the target document’s directory as the
current directory.

5. Select the target document—press (<) beside the File Name field. From the File
List list box, choose the target document.

When multiple source documents are selected, Falcon/DMS will prompt you to
identify the next target document.

6. Press OK to close the Copy/Replace Document dialog box.

The Rename Document Command

Use the Rename Document command to rename a document. The Availability of the
documents to be renamed must be ‘On Server’.

The Rename Document command captures the previous name of renamed documents
in the database.

To rename a Document:
1. From the Server File Selection region, designate the current directory.
2. From the File Name list box, select the document or documents to be renamed.

3. Press Rename (or select File > Rename). The Rename Document dialog

box opens.
4. In the File Name input field, enter the document’s new name.

5. Press OK.

To copy/replace a document, its
Availability must be ‘On Server’.

= NOTE

The Copy/Replace command cap-
tures the document’s previous name
in the database. This information is
displayed in the ‘Copied/Renamed
From’ field on the File Access Info
tab on the Database Maintenance
dialog box.

IS" ATTENTION
To rename a document its Availability
must be ‘On Server’.

=3 NOTE

If all rules governing filename unique-
ness are not satisfied, Falcon/DMS
will not allow a document to be
renamed with a filename that already
exists.
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The Delete Document Command

Use the Delete command to delete a document or documents. To delete a document
its Availability must be ‘On Server’.

Note: Falcon/DMS can be configured to move ‘deleted’” documents to a secure area on
the application server rather than actually deleting the files. Typically, files moved to this
area will be maintained for a prescribed period before they are finally deleted. See your
Falcon/DMS Administrator for more information.

To Delete a Document:

1. From the Server File Selection region, designate the current directory.

2. From the File Name list box, select the document or documents to be deleted.
3. Press Delete (or select File > Copy).

4. A Falcon/DMS alert box opens. Press Yes or Yes to All, as required.
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Database

Operations

principal benefit of the Falcon/DMS

engineering document management
system 1s the ability to search the docu-
ment database and produce a search
result based on user-defined criteria.
Additonally, the Document Manager
allows you to perform any of the file
manipulation operations on a file or
combination of files listed in the search
result.

The Document Manager provides the
following database tools:

[d Database Search—a robust , easy to
use searching tool. You can search on
text strings in the Description and Title
Block fields, all fields on the General Info
tab, single or multiple ‘project’ directories
and subdirectories, Keywords, and an
extensive selection of supplemental
fields. The appropriate fields support the
standard SQL comparison operators.

d Generate Document List—an ex-
panded view of a directory’s contents
that includes the document number and
description for each filename.

d Document Notes—provides a way
for you to itemize activity and com-
municate specific information for any
document.

d Mass Update—permits authorized
users to edit selected fields for a set of
files.
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The Database Search Command

Falcon/DMS offers a robust searching environment from which you can search on text
strings (whole and segmented) in the Description and Title Block fields, all fields on the
General Info tab, single or multiple ‘project’ directories and subdirectories, Keywords, and
an extensive selection of supplemental fields.

From the Document Manager menu bar, select Database > Search, or from the
button bar press the search button. The Database Search dialog box opens.

Database Search

| | Tils Block |

The Database Search Command

1.

General Information Directories & Kewwords Supplemental

General Info

Description I*Iock*

Document # I

saws| ]

Availability [Archived

File Format I ﬂ

Reu#l—

Sheet # I

Location I

Created B_vl
File Mame I

User I

Station I

Submit SQL | Clear =i

2. From the Database Search dialog box, define the search criteria.

[d On the main Database Form, above, the example search criteria is a text
string containing the charachters ‘LOCK’ anywhere in the description,
and a status of ‘Archived’.

For additional search criteria, click the supplemental tab. The example shows that
the search is narrowed by specifying all matching files that were archived before

‘1/8/1995°.

4

Directories & Kepwords Title Block Supplemental

General Information

DE Fields Search Criteria

# OF Plots ﬁ! Edit Search Criteria
§ Complete Archive Date
¥ Complebe Date |<1H8H99ﬂ

Appes

Edit: | Accept |

Submit SAL I

Clear

To define a value for a listed field, select the field and press Edit—or double-click
the item—and fill in the input field. When finished, press Accept.

To clear the form and define a new search, press Clear.

3. Press Submit SQL.

4. When the process completes, the File Selection region on the Document Manager
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switches to a search results mode. From this region you can select one or more
files, then the operation you wish to perform.

[ To define a new search criteria or modify the current search criteria, press
New/Modify.

[d When the search returns more than fifty records, press More to view an
expanded list; if necessary, you can continue to expand the list in increments
of fifty items.

[ Press Print to send the search result to the system printer.

[ Press Cancel to exit the search mode.

'.1—‘: FalconfDMS ¥5 Document Manager [DOT [Master]) (= =] =]
File File Selection  Databaze  MicraStation  AutaCAD  Warkspace Help

Y Fln hiEeE ChbkEs &

 Database Search Results
Hore | Cancel
Records: 1-14 of 14
. o Print
Filename Document Humber Description e —
landscap.dgn LOCK-2-COB6D Landscape features - Lock 2 -
Id10topo.dgn LOCH-1-87-57 Topographic features - Lock 1 il
lock10-a.dgn DACWIT-98-B Lock & Dam #0: James River, Richmond: Main equij—
lock10-b.dgn DACWIT-98-A Lock & Dam #10: James River, Richmond: Major Mair
lock10-c.dgn DACWIT-98-C Lock & Dam #10: Downstream control stand - Archit
lock11-a.dgn DACWIT-98-B Lock & Dam #11 - St. Paul: Main equipment & racewa;l

General Information [ Directories & Kewwords r Title Block. I File Format K.emaordz I Document Motes I

Description |

Documnent # IELE\H Rew # | / | Sheet # | Save

Status I j .-"I File Format Iacad Prev

Auvailability |On Server Hext
Last Modified Date W Created By [thomas / [orm199
Open I View | Checkout | Check In | Search... | Exit
|Retrieved databaze record for =elew] dwg=.. |Processing 14 of 14

Using Comparison Operators: The Database Search command supports the
following comparison operators for date and number fields: The format for criteria
using comparison operators is —

[operator] space [value] space [and/or] space [operator] space [value]
< eg <1/1/96
> eg >1/1/96 searches for events that occured after 1/1/96]

[searches for events that occured before 1/1/96]
[
= eg 1/1/96 [searches for events that occured on 1/1/96]
[
[

<= eg. <=1/1/96
>= eg. >=1/1/96

searches for events that occured before or on 1/1/96]

searches for events that occur after or on 1/1/96]

Other examples of ‘and’ / ‘or’ operator combinations are:

>1/1/95and < 1/1/96 [after 1/1/95 and before 1/1/96]
>=1/1/95and < 1/1/96 [after or on 1/1/95 and before 1/1/96]
1/1/950r1/1/96 [on 1/1/95 or on 1/1/96]
1/1/950r > 1/1/96 [on 1/1/95 or after 1/1/96]
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Database Keywords: Keywords are
user-defined database attributes
and are useful in narrowing database
searches. Keywords are selected
from designated drop-down list
boxes appearing on the database
information tabs.

An important benefit of keywords
is the ability to use a well defined
structure for choosing your search
criteria. Discrete categories and
predefined keyword lists give a clear
picture how information is organized
and assist in producing useful search
results.

Falcon/DMS provides six system-
level keyword categories and twenty
file-format keyword categories for
each file-format (igds [MicroStation],
acad [AutoCad], word, excel, etc.).

The Document Manager (Windows)

The Database Search Dialog Box

GENERAL INFO:

FiLE SELECTION
& KeywoRbps

TiTLe BLock

SUPPLEMENTAL

Description
Document #

Status [<]

Availability [< ]

Location
Revision #

File Format [< ]

Create By
File Name
Sheet #
User

Station

Directory Level | [<]

Directory Level 2-5 [<]

1-6 [System Level] [<]

1-6

Date fields

Time

Disk/Volume

Misc

File Format Keyword

80 character document description.
40 character document number.

Click the [<] button to select from a Status Selection list box.
Multiple selections can be made.

Click the [< ] button to select from a Availability Selection list
box. Multiple selections can be made.

Searches the location to which a file is checked.
5 character revision number.

Click the [< ] button to select from a File Format Selection list
box. Multiple selections can be made.

Searches the user who created the document.

80 character limit (defined by Falcon/DMS Administrator).
3 character sheet number.

Searches on user to whom a document is checked out.

Searches on the workstation to which a document is checked
out

Click the [< ] button to select from the Project list box.
Multiple selections can be made.

Click the [<] button to select from a subdirectory list box.
Multiple selections can be made.

Click the [<] button to select from a Keyword list box.
Multiple selections can be made.

Each field supports a 60 character title block entry. The keyin
can be a whole or segmented text string. Wild cards are used
for segmented text strings; for example *arrangement*
searches for all occurences of the word 'arrangement’ in the
indicated title block field.

Keywords 1-6

Creation

Status

% complete

Revision

Last Modified

Last Accessed

Last Plotted (PlotStation only)
Archive

Backup

Total Acitivity
Archive

Archive
Backup

% complete
DOS File Name
Main Local Dir.
# of Plots
Approval

IDL Format File

1-20



Database Operations

The Generate Document List Command

The Generate Document List provides an expanded view of a directory’s contents that
includes the document number and description for each filename.

From the Document Manager menu bar, select Database > Generate Document List,
or from the button bar press Generate Doc List.

[d To select a single file while in Document List mode, simply click on the required
Tilename, then choose a command.

[ To select multiple files while in Document List mode, use the <Shift>+click and
<Ctutrl>+click key combinations, then choose a command.

[d Press Print to send the list to the system printer.

[ Press Cancel to exit Document List mode.

alcon/DMS ¥5 Document Manager [DOT [Master]) M= B3

I N RES Y

| Document Number Results

BIEE] [

Cancel
Records: 1-20
. o Print

Filename Document Humber Description
lock10-a.dgn DACWIT-95-B Lock & Dam #10: James River, Richmond: Main equif «
lock10-b.dgn DACWIT-98-A Lock & Dam #0: Jame=s River, Richmond: Major Mair
lock10-c.dgn DACWIT-98-C Lock & Dam #10: Downstream control stand - Archits
lock11-a.dgn DACWIT-98-B Lock & Dam #11 - 5t. Paul: Main equipment & racewa
lock11-b.dgn DACWIT-98-A Lock & Dam #11 - §t. Paul, Richmond: Major Mainteni
lock11-c.dgn DACWIT-98-C Lock & Dam #11 - 5t. Paul: Downstream control stan-LI

General Information [ Directories & Keywords I Title Block I File Format K.ewwords T Document Motes I

Description |
Document # | Rev # | | Sheet # | Save
Status | =] /] FileFormat| ||| _Prew
Availavitty [ | Hext
Last Modified Date | Created By | s
Open | View | Checkout | Check In | Search... | Exit

Dizplay complete... |Processing Zof 3




Document Notes

The Document Manager (Windows)

The Document Notes feature helps you itemize activity and communicate specific
information for any document. Notes are stored as part of the document’s permenant
database record and can be displayed, modified, and deleted, depending upon your level
of access. You can create, display, and edit notes from either the Windows or the MDL

versions of the Document Manager.

To Display a Document’s Notes:

Click the Document Notes tab. If the selected record has one or more notes,

1. Select a file from the File Name list window.
2.

they are displayed on this tab.
3. Double-click the note you wish to view.

'.1—‘: Falcon/DM5 ¥5 Document Manager [DOT [Master]]

File  File Selection Database MicroStation  SofioCs0 Workspace  Help

sit] [kln] SkdEEIE (ElERoEa]E

" Server File Selection
vl

BIEE] [

Files Selected: L}

File Hame
|]ock1 0-a.dgn

Project Iﬂood_control

Category I ll

=]
B

lock10-a.dgn -
lock10-b.dgn R

Discipline I ll lock10-c.dgn
lock10-d.dgn
lock10-e.dgn L|
lock10-f.dgn
locki1-a.dgn LI il

[an files ) hd|

General Information I Directories & Keywords I Title Block I File Format Kewwords T Document Notes

Date/Time | Author | Type | Subject | Add

07/07/99 03... thomas Comment Design Heview

07/07/99 03... thomas Comment Design Change Delete |
Open View Checkout Check In | Search... | Exit

To Add a Document Note:

1. Select a file from the File Name list window.

2. Click the Document Notes tab.

3. Click the Add button. The Note dialog box opens.

4. Enter information in the Subject input field. Press <Tab> to shift to the Note input
region. Enter information in the Note region. Click the OK button.



Database Operations

To Edit a Document Note:
1. Select a file from the File Name list window.

2. Click the Document Notes tab.

'.1—‘: Falcon/DM5 ¥5 Document Manager [DOT [Master]) M=
File File Selection Databaze MicroStation  2oioCal WwWorkspace  Help

ClY Fln hiEiE ChlbkEs &

| Server File Selection

File Hame Files Selected: ]
Project Iﬂood_control W | |Iock1l]-a.dgn - |

Category I W | lock10-a.dgn N o |

lock10-b.dgn
Discipline I ll lock10-c.dgn
lock10-d.dgn
lock10-e.dgn
lock10-f.dgn
lock11-a.dgn

=l
[anfiles ¢ =]

=

il

General Information I Directories & Kewwords T Title Block r File Format K.emmords I Document Motes I

Date/Time Author Type Subject Add

Delete |

Author th
I omaz oK |

o Hote Type IComment v[ Date/Time IU?HD?H8903:51:1EPM
Open Lancel |

Subject IDesign Review

____thomas Comment Design Review
07707499 03... thomas Comment Design Change

Pleaze review and submit cormmeants by close of business. J_ :I

[ |

3. Double-click on the Document Note that you wish to edit. The Note dialog box
opens. You can modify the Subject and/or the attached note. When finished,
click the OK button.

To Delete a Document Note:
1. Select a file from the File Name list window.
2. Click the Document Notes tab.

3. Select the note you wish to delete. Click the Delete button. Click the Yes button
on the Falcon/DMS Confirmation box.




The Document Manager (Windows)

The Mass Update Command

The Mass Update command permits the Falcon/DMS administrator to edit selected
database fields for multiple files.

Certain record fields are not available to the Mass Update command: these include the
Auvailability and Last Modified fields on the General Info tab, and the Directory Levels
fields on the Directories & Keywords tab.

Running the Mass Update Command:
1. On the Document Manager, select the files whose records you wish to update.
2. From the Document Manager menu bar, select Database > Mass Update.

3. On the Database Info tabs, define the contents of the field or fields that you
wish to update.

4. Click the Process button.
5. A Falcon/DMS option palette opens:

When two or more files are selected you may process the files singly by clicking
the Yes button—this allows you to individually define the contents of the
database fields,

or
to process the group, click the Yes to All button.

Using the Database Search and Mass Update Commands in Combination:

1. Select the Search command.

2. From the Database Search dialog box, define the search criteria. Click the
Submit button.

3. On the search result, highlight the entire list.
4. From the Document Manager menu bar, select Database > Mass Update.

5. On the Database Info tabs, define the contents of the field or fields that you
wish to update.

6. Click the Process button.
7. A Falcon/DMS option palette opens:

When two or more files are selected you may process the files singly by clicking
the Yes button—this allows you to individually define the contents of the
database fields,

or

to process the group, click the Yes to All button.



