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Falcon/DMS

The Document Manager 
(MDL)

Chapter 1:    
Introduction

The Document Manager is the user 
interface for the Falcon/DMS En-

gineering Document Management Sys-
tem. 

Two versions of the Falcon/DMS 
Document Manager are available for 
MicroStation.  The Windows version 
is application-independent and capable 
of fully managing documents for any 
Windows-based program (see the ‘Docu-
ment Manager: Windows User Guide’ 
for more information).  The MicroStation 
(MDL) version, the subject of this 
guide, is seamlessly integrated with 
MicroStation’s graphical user interface 
and has most of the capabilities of its 
Windows counterpart.

There are three primary differences 
between the MDL and Windows versions 
of the Document Manager. 

First, while you can manage any type 
of document with either, the only docu-
ment type you can open with the MDL 
version of the Document Manager is a 
MicroStation design fi le. 

Second, Intelligent Data Link (IDL), 
the bi-directional database linkage 
between the Falcon/DMS database and 
the MicroStation design file, can be 
managed only from MDL.

And third, the Location and Archive 
commands are available only on the 
Windows versions of the Document 
Manager.

The MDL Document Manager does 
not require its own workspace and will 
not interfere with the operation of other 
applications running within MicroStation 
(see the administrator’s ‘Operations 
Guide’ for confi guration hints). Indeed, 
with Falcon/DMS you can easily defi ne 
and manage associations between design 
fi les and data fi les to make working with 
third-party applications more foolproof. 

In a Windows environment, the Win-
dows and the MDL versions of the Docu-
ment Manager can be used interchange-
ably.  You can start MicroStation from 
either the Windows Document Manager 
or from a MicroStation icon, and then 
open or checkout additional design fi les 
from whichever interface you choose.  
When you select and open a design fi le 
from the Windows Document Manager, 
you have the additional benefi t of being 
able to select a MicroStation workspace 
or engineering application, provided they 
have been defi ned by the Falcon/DMS  
administrator.
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✒ TERMS
Availability: A database attribute that 
identifies whether a document is 
available for modifi cation. A docu-
ment’s Availability condition appears 
on the General Info tab.

 When you select a fi le and its Avail-
ability is shown as ‘On server’, it is 
available to authorized users. 

When the fi le is shown as ‘On Work-
station’, it is checked out for modi-
fi cation; Falcon/DMS identifi es the 
workstation on which the document 
is located, the user to whom the 
document is checked out, and the 
checkout date.

Status: Document Status, or Status, is 
an attribute that is typically defi ned 
and assigned to documents by an 
administrator and usually cannot be 
changed by a user.  Status assigns an 
‘access mode’ to a document. 

The three access modes are: modify 
(which allows for full access, pro-
vided ‘write’ access is granted by 
the operating system), view_only, 
and no_access.

✉ NOTE
Typically, Falcon/DMS is confi gured 
to copy checked out documents to 
the workstation. There are several 
benefi ts to placing these ‘working’ 
versions of documents on the local 
hard disk: 

First, network traffi c is minimized.

Second, an application’s perfor-
mance is optimized.

Third (and perhaps most important), 
users can continue to work on local 
documents when the server or the 
network fail.

Basic Concepts
Opening a single document or checking out one or more documents are the two most 
basic Falcon/DMS fi le retrieval operations.

When you open or check out a document through Falcon/DMS, a copy of that 
document (the ‘working’ document) is placed in a predefi ned location on your local hard 
disk where it can be modifi ed. The server version of this fi le (the ‘record’ document) is 
set to a ‘view only’ access mode and remains so until the working document is checked 
in.  When a working  document is checked in it is removed from your workstation 
and placed back on the server (becoming the new ‘record’ document), and is once again 
available to authorized users for modifi cation.

When you select the Open or Checkout commands, Falcon/DMS checks several 
database attributes to determine whether you can access the document. The attributes 
most likely to affect your ability to manipulate a document are Availability and Status. 

A document that is not checked out shows an Availability of ‘On Server’; this indicates 
that the document is available for modifi cation (provided you are authorized to do so).  A 
document that is checked out to another user shows an Availability of  ‘On Workstation’ 
(or ‘Reserved by User’ [see Note, below). Falcon/DMS identifi es the workstation on 
which the  document is located, the user to whom the document is checked out, and 
the date on which it was checked out.

Status refers to Document Access Status. This is a database attribute, typically defi ned 
by an administrator, that assigns access modes of modify, view only or no access to a 
document. When a document’s Status has a ‘modify’ access mode you may check out 
and modify the document. When the mode is ‘view only’, you are given the option of 
proceeding with a read only version of the document or terminating the request. When 
the mode is ‘no access’, Falcon/DMS provides a message defi ned by the administrator.

Each document’s Availability and Status are listed on the General Info tab.

There is relatively little difference between the Checkout and Open commands.

When you check out one or more documents, you reserve those documents for your use, 
usually to be opened and modifi ed at a later time. 

When you open a document, Falcon/DMS checks out the document, launches the 
associated application if necessary, and opens it in that application as part of a single 
transaction. Access by other users to any checked out document is limited to ‘view 
only’, meaning that they cannot modify the ‘On Workstation’ document until it is 
checked in. 

The Open command is available only when you select a single document. The Checkout 
command can be used to checkout one or more documents in a single transaction.

Note: A fi le format, or document type, can be confi gured so that checked out documents 
are accessed on the server instead of copied to the requesting workstation’s hard disk. 
Under this confi guration, documents that are checked out will show an Availability of 
‘Reserved by user’. (Apart from an increase in network traffi c, an important disadvantage 
to accessing fi les directly on the server is that clients are unable to get to their documents 
if the network fails.)
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Graphical User Interface
The components of the MicroStation [MDL] Document Manager are:

A. Control Bar : Provides two control bar functions: move and close. Additionally, 
when the Environments feature is enabled the control bar displays the current 
environment.

B.  Menu Bar: Provides access to pull-down command menus.

C. Top Button Panel: Provides quick access to the most common document 
manipulation operations contained within the File pull-down menu.

D. File Selection Region: Server File Selection is a view of server-based record 
documents. Local File Selection is a view of local working documents. From 
this area you navigate through the directory structure and select the documents 
you wish to work with.

E.  Database Tabs radio buttons: These radio buttons allow you to change the 
active database tab.

F.  Database  Tabs: These tabs allow you to view different categories of database 
information. The fi ve database info tabs are General Information, Directories & 
Keywords, Title Block, File Format Keywords, and Document Notes.

G. Bottom Button Panel: Provides access to the basic management operations: Open, 
View, Checkout, Copy Out, and Check In.

H. Miscellaneous Controls: Use the first two controls to set operating defaults 
(automatic close and reference fi le checking) and the Close button to manually 
exit the Document Manager.

I.   Status Bar: Provides information and statistics about the current operation.

A
B
C

D

E

F

G

H
I
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The Document Manager Interface

The MicroStation Menu Bar—Falcon/DMS

The Falcon/DMS pull-down menu located on the MicroStation menu bar provides 
access to the following operations:

PUORG DNAMMOC NOITPIRCSED

:noitatSorciM
raBuneM

reganaMtnemucoD .reganaMtnemucoDehtfonoisrevLDMehtsnepO

>hserfeReliF tsomehtfolaveirterropukcabehtetatilicafsdnammochserfeRehT
esehtfonoitanalpxedeliatedA.selifngisedfonoisrevtnerruc

.2retpahCnidedivorpsisdnammoc

]resU[ottuOdekcehC morF.resutnerrucehtottuodekcehcselifehtllagnitsilmrofasnepO
ehtniraeppatahtselifynanikcehcroneponacresuehtxobgolaidsiht

.tsil

slacigoLeliFecnerefeRtidE ecnereferafoemanelifehtro/dnalacigolehtyfidomotsresustimreP
,seiradnuobpilc(setubirttas'elifecnereferehtgniniatniamelihwelif

esohtnoylnodilavsinoitareposihT.).cte,noitator,elacs,sksam
ecnerefeRhcattA>eliFSMD/noclaFehthtiwdehcattaselifecnerefer
yekxedniyramirpehthtiwsesabatadrofylno,nehtdnadnammoceliF

.retaergroemaneliF;1levelriDottes

SMD/noclaFtuobA .mrofSMD/noclaFtuobAehtsnepO

SDRGI O[ N O/ FF] SMD/noclaFdezilaicepsehtdnepsusotresuehtselbanE
.stnemeriuqertnemeganamelifSDRGIsserddaotdengisedsnoitarepo
yllacificepsderugifnocsiSMD/noclaFnehwylnoelbaliavasinoitposihT

.SDRGIrof

tixE .noitatSorciMstixE

The Document Manager Menu Bar—File Menu
The File pull-down menu located on the Document Manager menu bar provides access 
to the following operations: 

PUORG DNAMMOC NOITPIRCSED

DOCMAN: FILE

MENU

ecnerefeRhcattA dnammocsihtesuaceB.erudecorpelifecnereferhcattaehtsetaitinI
sihtgnisuelifngisedtnerapehtotlacigolhtapecnereferasenifed

xedniyramirpehthtiwsesabatadroftnatropmiylralucitrapsidnammoc
.retaergroemaneliF;1levelriDottesyek

>hserfeReliF ropukcabehtetatilicafsdnammochserfeRehT.revreS;lacoL;ecnerefeR
deliatedA.selifngisedfonoisrevtnerructsomehtfolaveirter

.2retpahCnidedivorpsisdnammocesehtfonoitanalpxe

...weN .droceresabatadstidnaelifngisednoitatSorciMwenaetaercotdesU

...noisiveRweN .elifngisedtnerrucehtfonoisiverwenaetaercotdesU

ddAdna...seliFrevreSddA
...seliFlacoL

.esabatadehtot,ylevitcepser,seliflacoldnadesab-revresddaotdesU
weiVrevreSehtnehwylnoelabliavasidnammoceliFrevreSddAehT[

].yrotceriDottessiedoM

sdnammoClaveirteReliF dnayfidom:sdnammoclaveirterfoseirogetacowtsedivorpSMD/noclaF
weivehT.nikcehCdna,tuokcehC,nepOerasdnammocyfidomehT.weiv

.tuOypoCdnanepOerasdnammoc

sdnammoCnoitalupinaMeliF ,ypoC,evoM,noisiveRweN,weNerasdnammocnoitalupinamelifehT
.emaneRdna,eteleD,ecalpeR/ypoC

>steS ...morfevomeR/weiVdna,...otddA,weN:sdnammocteS

>noitaicossAeliF ...morfevomeR/weiVdna...otddA:sdnammocnoitaicossAeliF

esolC .reganaMtnemucoDSMD/noclaFehtstixE

✉ NOTE:
The Add Local command, several 
File Manipulation commands, and 
the File Retrieval commands also 
appear on button bars located at the 
top and bottom of the Document 
Manager. 
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File Selection Menu

The File Selection pull-down menu located on the Document Manager menu bar 
provides access to the following operations:

PUORG DNAMMOC NOITPIRCSED

DOCMAN: FILE

SELECTION

noitceleSeliFrevreS ehtnidetsilseirotceridtcejorpdesab-revresehtotSMD/noclaFstnioP
.elbaT'tcejorP'retsaM

noitceleSeliFlacoL elifhcaerofdenifedseirotceridgnikrowlacolehtotSMD/noclaFstnioP
.tamrof

noitceleSeliFecnerefeRlacoL ehtrofyllausu,yrotceridelifecnereferlacolehtotSMD/noclaFstnioP
.yllacolderiuqerregnoloneratahtselifecnerefergniteledfoesoprup

>]resU[ottuOdekcehC morF.resutnerrucehtottuodekcehcselifehtllagnitsilmrofasnepO
ehtniraeppatahtselifynanikcehcroneponacresuehtxobgolaidsiht

ehtnounemnwodllupSMD/noclaFehtmorfelbaliavaoslA.tsil
.rabunemnoitatSorciM

...hcraeS .mrofhcraesdradnatsehtsnepO

tsiLtnemucoDetareneG ,emanelifgniwohsyrotceridtnerrucehtfoweivesabatadasetareneG
.noitpircseddna,rebmuntnemucod

hcraeSmotsuC .mrofhcraesLQSehtsnepO

Workspace Menu: Environments & User Preferences

PUORG DNAMMOC NOITPIRCSED

naMcoD :
ecapskroW

ENVIRONMENTS > .resutnerrucehtrofdezirohtuastnemnorivneehtstsiL

USER PREF >

>noitceleSyrotceriD TEXT LIST BOXES: dnastcejorphcihwmorfsexobtsilsesunoitposihT
ehtkcilC.nesohceraseirotceridbusrieht < .xobtsilayalpsidotnottub

DIRECTORY LIST BOX: ehtniseirotceridbustcejorpsyalpsidnoitpoehT
ehtkcilC.edomswodniWdradnats < llirddnatcejorpatcelesotnottub
.yrotceridbusderiuqerehtotnwod

nottuBtsiLyrotceriD O[ N O/ FF] yalpsidt'nowtsilelifseirotceridtnerruceht,delbanenehW
ehtskcilcresuehtlitnu tsiL< .nottub

sbaTofnIesabataD O[ N O/ FF] lareneG:sbatnoitamrofniesabatadehtfoyalpsidehtslortnoC
nehw(sdrowyeKtamroFeliF,kcolBeltiT,sdrowyeKdnaseirotceriD,ofnI
atidenacsegelivirptneiciffushtiwsresU.setoNtnemucoDdna,)denifed

.sbatesehtmorfdroceresabatads'elifngised

snoitpircseDtcejorPretsaM O[ N O/ FF] tcejorp(snoitpircsedtcejorpfoyalpsidehtslortnoC
.)rotartsinimdASMD/noclaFehtybdenifederasnoitpircsed

snoitpircseDyrotceridbuS O[ N O/ FF] snoitpircsedyrotceridbusfoyalpsidehtslortnoC
SMD/noclaFehtybdenifederasnoitpircsedyrotceridbus(

)rotartsinimdA

golaiDecnerefeRtsoP O[ N O/ FF] tsiLeliFecnerefeRehtfo,'gnitsop'ro,yalpsidehtslortnoC
dnanoitatskrowlacolehtotdeipoceraselifecnerefersaxobgolaid

.sutatsriehttuobanoitamrofnisedivorp

ecnerefeRlacoLeteleDotuA
seliF

O[ N O/ FF] ecnereferlacolseteledyllacitamotuaSMD/noclaF,nonehW
lacolseteledresueht,esiwrehto;nidekcehcsielifngisedanehwselif

.noitercsidsihtaselifecnerefer

>evoMweiVrevreS -revresehtweivotsresuswollaecnereferpsihT]yrotceriD/esabataD[
yrotceridanismetisaroesabatadehtnisdrocersastnemuocdesab

.yrotceridrevreslautcaehtfognitsil
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Starting Falcon/DMS from the MicroStation Icon:
When you start MicroStation from the MicroStation icon in the Falcon/DMS 
folder a ‘banner’ or ‘splash’ fi le opens. The purpose of this fi le is to place you 
in a controlled environment from which you use the MDL version of the 
Document Manager to checkout and check in and otherwise manage fi les. 

Use the following procedure to open or checkout server-based design fi les.

1.  Select Falcon/DMS > MicroStation from the Start menu or double-click the 
MicroStation/Falcon icon in the Falcon/DMS program group. (For UNIX, 
select the designated icon from the GUI, or enter the appropriate command in 
a terminal window.)

2.  Once in MicroStation, select Falcon/DMS > Docu-
ment Manager from the MicroStation menu bar.  
The Document Manager opens

3.  Use the Document Manager to manipulate fi les:

❏ Navigate to a server directory in the Select Server 
File region (see page 7).

❏ Select a document from the File Name list window (see page 8).
❏ Select a command.

At this point Falcon/DMS checks several database items to determine whether 
you can access the document. The attributes effecting your ability to manipulation 
a document are Availability and Status. When a design fi le is not checked out 
the database lists its Availability as ‘On Server’. If the design fi le is checked 
out to another authorized user its Availability is shown as ‘On Workstation’ 
or ‘Reserved by User’. Status refers to Document Status. This is a database 
attribute typically defined by an administrator and assigns access modes of 
modify, view only or no access to a document. When a document’s Status has 
a ‘modify’ access mode you may check out and modify the document provided 
the document is available.

� ATTENTION
To determine whether a file is 
checked out, refer to Availability on 
the Document Manager’s General 
Info tab. When you select a file 
and its Availability is shown as ‘On 
server’ it is available to authorized 
users.  When the file is shown as 
‘On workstation’, it is checked out. 
When a document is ‘On workstation’ 
Falcon/DMS identifi es the worksta-
tion on which the working document 
is located, the user to whom the 
document is checked out, and the 
checkout date.

✒ TERMS
Status: Document Status, or Status, is 
an attribute that is typically defi ned 
and assigned to documents by 
an administrator and cannot be 
changed by a user.  A Status assigns 
an ‘access mode’ to a document. 

The three access modes are: modify 
(which allows for full access, pro-
vided ‘write’ access is granted by 
the operating system), view_only, 
and no_access.
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Starting MicroStation from the Windows Document Manager
NOTE: Additional applications or workspaces may be defi ned for MicroStation and 
associated to MicroStation fi le format (igds). These additional associations are recognized 
by the Windows version of the Falcon/DMS Document Manager. When you select 
and open a design fi le from the Windows Document Manager, you may also select a 
MicroStation workspace or engineering application.

1.  From the Windows Start Button select Programs > Falcon/DMS >Doc. 
Manager.

2.  On the Document Manager:

❏ Navigate to a server directory in the Select Server File region.
❏ Select a design fi le from the File Name list window.
❏ Check the document’s Availability in the General Info region.
❏ Select the File > Open command or press Open.

3.  If the Falcon/DMS administrator has defi ned workspaces or additional application 
properties for the MicroStation fi le format, the Select Application list box opens. 
Double-click on the MicroStation confi guration you wish to use.

✉ NOTE
In a Windows environment you may 
use the MDL and the Windows ver-
sions of the Document Manager 
interchangeably.
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Falcon/DMS and Reference Files
When Falcon/DMS opens a MicroStation design fi le it also determines which reference 
fi les, if any, are attached to the requested document. Falcon/DMS then ‘copies out’ the 
reference fi les to your local workstation. Do not confuse ‘copy out’ with ‘checkout; to 
‘copy out’ a fi le does not effect a document’s Availability. (Recall that checking out 
a fi le changes its Availability from ‘On Server’ to ‘On Workstation’ or to ‘Reserved 
by User’.) 

You may choose which reference fi les Falcon/DMS is to copy to the client workstation. 

Before any reference fi le is copied to your workstation Falcon/DMS performs a number 
of database checks. The fi rst is to insure that Falcon/DMS provides the most current 
version of the reference fi le available on the server. The second is to alert you to when 
a reference fi le may not be the most current version of the document; this usually 
occurs when another user has checked out a reference fi le as their active document. The 
reference fi le options are detailed in Chapter 2, Design File Retrieval. 

Because these reference fi les are ‘copied out’ rather than ‘checked out’  you may delete 
them from your local workstation when they are no longer needed.

File Selection Modes
Falcon/DMS restricts users to specifi c ‘project’ directories on the network fi le servers 
and to ‘working’ directories on the local workstation. The Document Manager’s File 
Selection option allows you to choose between viewing the contents of the server-based 
‘project’ directories and the local working directories. 

� ATTENTION
Falcon/DMS provides several ways to 
manage the reference fi les it copies 
out to your local workstation.

The Document Manager provides a 
user preference that, when enabled, 
automatically deletes local reference 
fi les when the parent design fi le is 
checked in.

The Document Manager also pro-
vides a option that allows you to 
view the contents of the local refer-
ence fi le directory and to delete as 
needed.

If you choose to not use the Auto 
Delete feature you will make more 
effi cient use of Falcon/DMS’s refer-
ence file capabilities. Each time 
Falcon/DMS opens a design fi le to 
which reference fi les are attached, 
it checks to insure that you have 
the most current version of the refer-
ence files. Only when the server-
version of the reference fi le is more 
current than the local version will 
Falcon/DMS update the workstation. 
This feature results in significantly 
reduced network traffi c.

Because Falcon/DMS verifi es refer-
ence fi les each time it opens a design 
fi le, it is recommended that you not 
delete local reference fi les until after 
a design fi le is completed. 
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Recall that when Falcon/DMS opens or checks out a design fi le, it places a copy of that 
fi le (the ‘working document’) in the ‘working directory’ on the local workstation. The 
original (the ‘record document’) stays on the server, where it remains as a ‘view only’ fi le 
until the document is checked back into the database.  A user may select his own checked 
out document (where Availability equals ‘On Workstation’) from its server-based home 
directory or from the local working directory to which it was checked out. In either case, 
Falcon/DMS always opens the local version of the fi le.

Server File Selection

When Falcon/DMS points to a server it restricts access to those ‘project’ directories that 
are listed in the Master ‘Project’ Table.

Local File Selection

When Falcon/DMS points to local ‘working’ directories,  it sees a replication of the  
server directories that are built as documents are checked out. When documents are 
checked in, Falcon/DMS automatically deletes empty local directories. 

The Server View Mode User Preference
The Server View Mode user preference allows you to view the server-based documents as 
records in the database or as items in a directory listing of the actual server directory.

❏ The Database mode displays only those items that have database records.
❏ The Directory mode displays all fi les located in the current directory, including 

those that are not in the database.
❏ When in Database mode, only those directories that contain database records 

are visible. Once you add a document to an empty directory, you can access 
that directory in either mode.
❍ To create a document in an empty directory, fi rst set the Server View Mode 

to Directory.
❍ To move or copy a document to an empty directory, fi rst set the Server 

View Mode to Directory.
❍ To use the Add Server File command, fi rst set the Server View Mode to 

Directory.
❏ The Database view allows you to more easily view database records for non-

electronic records and sets; previously these items could be seen only from a 
database search result.

❏ The Database view is recommended when poor network performance is an 
issue.

✉ NOTE:
There are several benefi ts to placing 
a ‘working’ version of a document 
on the local workstation: First, to 
minimize network traffic, second, 
to optimize an application’s per-
formance, and third (and perhaps 
most important), to allow users to 
continue to work when the network 
goes down.
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Navigating Directories & Selecting Files
The Falcon/DMS Document Manager uses standard Windows conventions to navigate a 
directory structure and select fi les.

You may view the current directory structure from Text List boxes or a Directory List 
box. Use the Directory Selection user preference to set the preferred control. 

When Text/List Boxes is enabled, the Document Manager displays the available directo-
ries in a list boxes opened by clicking on the associated [<] buttons.

When Directory List Box is enabled, the Document Manager displays the available 
‘Project’ directories in a list box while the ‘Project’ subdirectories are shown in the 
standard Windows mode.

✔ TIP
In addition to selecting a project 
from a text list box, you may key in a 
project name in the ‘Project’ fi eld. 

✔ TIP
You may select any list box item with 
a double-click. 

✔ TIP
To move back through a directory 
structure when the directory selec-
tion preference is set to Text List 
box, simply click the button associ-
ated with the higher level directory 
and select an entry or, double-click 
the current directory and press the 
delete key.
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If you wish to perform any operation on a single document, the easiest method is to 
single-click the document in the Filename window and select the desired command. 
(Note that when you wish to perform a transaction on a single document it is not necessary 
to display its fi lename in the Files Selected window.)

If you wish to perform an operation on two or more documents, the easiest method is 
to double-click on the documents in the Filename window.  Select the desired command 
once the required fi les display in the Files Selected window. (Note that when you select 
more than one document the Open command is not available.)

To select multiple fi les you may use the <Ctrl>+click or press & drag combinations. 
Once the fi les are chosen, the group is considered a single selection; use the > button to 
display the items in the Files Selected window.

To select all the fi les in a directory, use the >> button to display the contents of the entire 
directory in the Files Selected window.

Use the < and << buttons to deselect combinations of fi les or all fi les, respectively.

✔ TIP
When Falcon/DMS is confi gured to 
allow only unique fi lenames, you may 
build the ‘fi les selected’ list from dif-
ferent projects and subdirectories. 
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Multiple Environments
Multiple Environments allow different groups or departments (or for that matter, indi-
viduals) to work with confi gurations specifi c to their unique requirements. An environ-
ment defi nition may be confi gured to use global defi nitions for certain controls and to 
specify custom defi nitions for others.

Falcon/DMS uses a set of confi guration fi les and tables defi ned from the Administrator 
for many of the controls and option lists that appear on the Document Manager. The 
new Multiple Environments feature allows different groups or departments (or for that 
matter, individuals) to work with a Document Manager tailored to their specifi c require-
ments. An environment defi nition can use existing confi guration fi les and tables (global 
defi nitions) for certain controls and build unique confi guration fi les and tables for others. 
Also, Falcon/DMS can use any of the existing global defi nitions as a template for a unique 
defi nition, making the Multiple Environments feature easy to confi gure.

Examples of how Environments effect the appearance of the user’s interface appear below. 

The Document Manager for the [highway] environment uses EA#, Highway#, and 
SubCategory for its directory labels and has its own ‘EA#’ table. It has six system level 
Keyword Categories with unique tables. Compare this with the Document Manager that 
appears on the following page.
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The Document Manager for the [structures] environment (below) uses Project, Disci-
pline, Category, SubCategory, and DocType for its directory labels and has its own 
‘Project’ table. It has three system level Keyword Categories with unique tables.

To set an environment or to change the current environment: 

1.  Select Workspace > Environment > (Environment Name) from the Document 
Manager’s menu bar.

2.  If the current project is not included in the selected environment, a message box 
appears. Press OK on the Falcon/DMS message box and proceed.

� ATTENTION
Falcon/DMS  synchronizes the current 
server directory selection for the MDL 
Document Manager with that of the 
Windows Document Manager when 
the two interfaces share the same 
environment. However, when MDL 
is set to an environment different 
from that used by Windows, you 
will be notified that the current 
Windows project is not included 
in the selected MDL environment. 
Simply click OK and proceed.
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The ‘Directory Selection’ User Preferences
The Server File Selection regions displays directory information in two ways:

❏ The Text/List Boxes option uses list boxes from which projects and their 
subdirectories are chosen. Press [<] to display a list box.

❏ The Directory List Box option displays subdirectories in the standard Windows 
mode. Press [<] to display the Text List box from which you choose a project.  
‘Drill down’ to the desired subdirectory from the associated list.

Miscellaneous Controls

Unload Document Manager:
When enabled, this option closes the Document Manager after each operation.

Reference File Check:
When disabled, Falcon/DMS does not check for Reference File attachments.  Access to 
this control is enabled from the Falcon/DMS Administrator’s File Formats/Applications 
environment (see Additional IGDS Parameters > Check For Reference Files > Check 
MDL Dialog Check box).

✔ TIP
Directory List Button: This option is 
provided for systems running over a 
slow or overburdened network.  On 
such networks, performance may 
be affected by the display of a fi le 
list for directories that contain a 
large number of documents.  The 
Directory List Button allows you to 
delay the display of the fi le list until 
the desired directory is selected.

✉ NOTE
The Server View Mode user pref-
erence allows users to choose 
between a database view or a direc-
tory view of documents controlled 
by Falcon/DMS.

The database view is recommended 
for overburdened networks and 
for networks that rely on FTP.  The 
database view  also allows users to 
more easily view database records 
for non-electronic documents and 
for sets; previously such items could 
be seen only from a database search 
result.

The directory view is recommended 
when server-based documents need 
to be added to the database.
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Chapter 2:    
Document 
Retrieval

This chapter provides a step-by-step 
explanation of the procedures used 

to retrieve design fi les for modifi cation or 
for viewing, and includes an explanation 
of how reference fi les are attached and 
managed.

The Falcon/DMS document retrieval 
commands include the following opera-
tions:

❏ Open (Modify)
❏ Attach Reference/Xref Files
❏ Refresh Files
❏ Open (View)
❏ Check out (Modify)
❏ Copy Out (View)
❏ Check In
Opening a single document or checking 

out one or more documents are the two 
most basic Falcon/DMS operations.

When you open or check out a docu-
ment through Falcon/DMS, a copy of 
that document (the ‘working document’) 
is placed in a predefined location on 
your local hard disk where it can be 
modifi ed. The server version of this fi le 
(the ‘record document’) is set to a view 
only access mode and remains so until 
the working document is checked in.  
When a working  document is checked 
in it is removed from your workstation 

and placed back on the server (becoming 
the new ‘record’ document), and is once 
again available to authorized users for 
modifi cation.

When you open a document, it is 
checked out and opened in MicroStation 
as part of the same transaction.

When you check out one or more 
documents, Falcon/DMS reserves the 
documents for your use, usually to be 
opened and modifi ed at a later time. 

In each instance, other users’ access 
to checked out fi les is limited to view 
only; they cannot be modifi ed until you 
check them in.

The ‘view’ versions of the Open and 
Checkout commands (View and Copy 
Out) place a ‘throw away’ copy of  a 
document on the local hard disk. View 
documents cannot be returned to the 
server and are deleted at your discretion.
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✒ TERMS
Open vs Checkout: When you open 
a document, Falcon/DMS checks 
out the document and, as part of 
that transaction, opens the file in 
the appropriate application. Given 
that the open command checks out 
the document as it is opened, it is 
not necessary to fi rst use the check 
out command before opening a 
document.

When you check out one or more 
documents, Falcon/DMS reserves 
the documents for your use, usually 
to be opened and modified at a 
later time. 

In each instance, other users’ access 
to checked out files is limited to 
view only; they cannot be modifi ed 
until you check them in.

The Open command is available 
only when you select a single docu-
ment, while the Checkout command 
can be used to reserve multiple 
documents.

� ATTENTION
When a user opens a document that 
has already been checked out to 
that user’s workstation, Falcon/DMS 
knows to open the local version of 
the fi le, even if the user selects the 
file from the Server File Selection 
region. It is not necessary to set File 
Selection to Local File Selection to 
open checked out documents.

✔ TIP
When you select a single file it is 
not necessary to display that file-
name in the File Selected window. 
Simply click on the desired fi le—its 
name will display in the File Name 
fi eld—and select a command.

 Open (Modify)
The Open (Modify) command places the working document on your local hard disk. The 
record document remains on the server as a view only fi le.

To open a design fi le:

1.  Designate the current directory from the Server File Selection region, .

2.  Select a design fi le from the File Name list window; verify its Availability.

3.  Press Open (or select File > Open).

Falcon/DMS then checks the database for the document’s Availability and Access status. 
Only if the Availability is ‘On Server’ and its Access status indicates that the fi le can be 
modifi ed, will the document be checked out.

Falcon/DMS then determines whether reference fi les are attached. When reference fi les 
are present Falcon/DMS opens the Reference File Selection dialog box. Use this form to 
choose the reference fi les that will ‘copied out’ to the local workstation.

4.  Select the reference fi les that you wish to use from the Reference File Selection 
dialog box.

Press All to select all listed reference fi les. 

Press None if you require no reference fi les. 

Double-click on individual fi les and press OK to choose only the reference 
fi les that you require. 

Use the Remove button, or double-click fi les in the Selected Reference Files 
list, to deselect reference fi les.

Press OK.
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✙ WARNING
“Security Alert: <user> does not have 
[Modify] privileges to this directory.” 
This message indicates that Project 
Security cannot allow your account 
access to the current directory. When 
this or a similar message displays, 
consult either the project administra-
tor or the Falcon/DMS administrator.

✒ TERMS
“Availability: On Server” indicates 
that a document may be opened 
or checked out, provided you are 
authorized to access the fi le. 

✔ TIP
When you select a single file it is 
not necessary to display that file-
name in the File Selected window. 
Simply click on the desired fi le—its 
name will display in the File Name 
fi eld—and select a command.

� ATTENTION
The ability to select which refer-
ence fi les to ‘copy out’ to the local 
workstation can be benefi cial when 
you are working with large data 
sets. You can use the Reference File 
Selection dialog box to choose only 
those reference files required for 
a given design session.  If, after 
bringing down a partial reference fi le 
set, you require a complete set, use 
the reference fi le refresh command 
to bring down reference files not 
chosen at the beginning of the ses-
sion. [Display of the Reference File 
Selection dialog box is controlled 
from the Falcon/DMS Administrator’s 
File Formats/Applications environ-
ment (see ‘Additional IGDS Param-
eters > Check For Reference Files > 
Enable Reference File Tagging’ in the 
Falcon/DMS Administrator Guide).]

5.  The Reference File List box opens. This form provides the following 
information: 

Reference File Name

Whether the fi le has been downloaded, updated, or is current with the server

The Availability of the server-based original.

Press OK.

Open (Modify)—From the Checked Out to <user> dialog box
The Checked Out to <user> dialog box lists all the fi les that are checked out to you on 
the current workstation. This command is especially useful when you have checked out 
fi les from multiple projects and subdirectories.

To open a document from the Checked Out to <user> dialog box:

1.  From the Document Manager’s menu bar, select File Selection > Checked 
Out to <user>.

2.  From the Files Checked Out to <user> dialog box, select the fi le you wish 
to open.

3.  Press Open.
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Reference Files
When Falcon/DMS opens or checks out a MicroStation design fi le, it also determines 
which fi les, if any, are externally referenced to document. Falcon/DMS then ‘copies out’ 
the reference fi les to your local workstation. (Do not confuse ‘copy out’ with ‘checkout; 
to ‘copy out’ a fi le does not effect its Availability.) 

Before any reference fi le is copied to your workstation Falcon/DMS performs a number 
of database checks. The fi rst is to insure that Falcon/DMS provides the most current 
version of the reference fi le available on the server. The second is to identify when a 
reference fi le may not be the most current version of the document. This usually occurs 
when another user has checked out a fi le that is referenced to your active document. 
In this case, Falcon/DMS identifi es the user and the workstation to which the reference 
fi le is checked out.

Typically, the reference fi le is copied to c:\dms_local\ref. This destination directory is 
defi ned by the Falcon/DMS administrator.

Since MicroStation with Falcon/DMS is confi gured to look for reference fi les in a specifi c 
location (i.e. c:\dms_local\ref) it is not necessary to enable the Save Full Path option.

Because the reference fi les are ‘copied out’ rather than ‘checked out’, they are considered 
to be ‘throw-away’ fi les and cannot be returned to the server. Reference fi les remain 
on your workstation until you delete it (deleting reference fi les is discussed later in this 
chapter).

Reference File User Preferences

❏ Post Reference Dialog: When enabled, the Reference File list box opens each time 
a document to which reference fi les are attached is opened or checked out.

❏ Auto Delete Local Reference Files: When enabled, Falcon/DMS automatically 
deletes local reference files when the parent document is checked in. It is 
important to note that when Auto Delete is enabled, Falcon/DMS has to 
download reference fi les each time you open a MicroStation document, resulting 
in increased network traffi c.

Miscellaneous Control

❏ Reference File Check: When enabled, Falcon/DMS performs a reference fi le 
check for  fi les as they are opened or checked out. When checking out multiple 
fi les, it is recommended that you turn off the Reference File Check preference, 
then turn it on before you open any checked out document.

✔ TIP
The ‘Reference File Check’ miscel-
laneous control allows you to control 
whether a reference fi le check will 
be performed. When unchecked, 
Falcon/DMS does not look for refer-
ence fi les.

The display of this option is con-
trolled from the Falcon/DMS  Admin-
istrator’s File Formats/Applications 
environment.

✉ NOTE
Display of the Reference File List 
box is a Document Manager User 
Preference. To enable or disable 
this feature go to Workspace > User 
Preference > Post Reference Dialog 
> On/Off.

� ATTENTION
Falcon/DMS can be configured to 
redirect MicroStation’s File > Open 
and File > New (and Attach Refer-
ence) commands. When the com-
mand redirects are enabled affected 
commands will open the Falcon/DMS 
Document Manager.
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The Reference File list box

When the Post Reference Dialog user preference is on, each time a document to which 
reference fi les are attached is opened or checked out, the Reference File List box opens.  
In addition to the fi lename, this list box provides the following information about each 
reference fi le: 

The status of each reference fi le

❏ Downloaded for view—a local version is not found; the reference fi le is copied 
out for view.

❏ Local version is current with server—a local version is found; because the local 
version is identical to the server version no action is taken.

❏ Not database record—either a reference fi le does not have a record or Falcon/DMS 
is unable to resolve the attachment; see the Falcon/DMS administrator.

The present location of the most current version of the original of each reference 
fi le

❏ Server—the most current of version of the original fi le is not checked out.

❏ <user/workstation>—the most current version of the original fi le is checked out 
to the identifi ed user on the identifi ed workstation.

Filename - Downloaded for view - (Server)

This status indicates that all the attached reference fi les have been downloaded to the local 
hard disk. The notation ‘(Server)’ indicates that the most current version of the original of 
each reference fi le is not checked out.

Filename - Local version is current with server - (Server)

This status indicates that all the attached reference fi les have already been copied to the 
local hard disk and that they are identical to their server versions. In this case no reference 
fi les are recopied to the local hard disk.
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Filename - Updated local version with server - (Server)

This status indicates that the local versions of two of the fi ve reference fi les have been 
downloaded again. At some  point, between the time the active fi le was closed and/or 
checked in and then reopened, another user modifi ed and then checked in the indicated 
fi les. 

Filename - Local version is current with server - (workstation/user)

This status appears when all the attached reference fi les are already on the local hard disk 
and that they are identical to their server versions. However, the indicated fi les, while 
current with their server versions, are no longer the most current versions of the fi les. 
Note that the workstation and user to whom documents are checked out are identifi ed. 
(The Refresh Reference File command, available in the MDL version of the Document 
Manager, can be used to retrieve a more current version of these fi les.)

Filename - No Database Record

This status appears when a reference fi le does not have a database record or Falcon/DMS 
is unable to resolve the attachment Usually a fi le without a database record will not 
display in the parent design fi le. Please see the Falcon/DMS administrator when this 
notation appears.
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Attaching MicroStation Reference Files from the Document Manager

❏ It is strongly recommend that you use the Falcon/DMS Attach Reference File com-
mand to attach reference fi les to the active design fi le.  When you use Falcon/DMS, 
the Document Manager writes a system generated reference fi le path logical to the active 
design fi le. This insures that Falcon/DMS always fi nds the correct fi le without the need 
to defi ne multiple MS_RFDIR values in workspace confi gurations. (This occurs only for 
database types that permit a specifi c fi lename to be used more than once.)

Note: A detailed explanation of how Falcon/DMS uses reference fi le path logicals is 
provided in the Administrator Guide.

❏ Because most organizations now confi gure Falcon/DMS to use UNC or FTP 
to access network resources, the only access to the production design fi les on 
a fi le server is through Falcon/DMS. This means that when mapped network 
drives are not defi ned, MicroStation’s Attach Reference command cannot see the 
server-based production directories. 

❏ When MicroStation’s Falcon/DMS fi le format (igds) is defi ned, the standard attach 
reference fi le command is often ‘redirected’ to Falcon/DMS. Thus, when a user 
selects MicroStation’s File > Reference File > Attach command, the Falcon/DMS 
Document Manager opens instead of the standard MicroStation dialog box.

To attach a reference fi le to the active design fi le:

Note: Falcon/DMS requires that the document to which you are attaching reference 
fi les be the active fi le.

1.  If necessary, navigate to the directory that contains the document you wish to 
attach as a reference fi le. (Because Falcon/DMS will build its own path logicals the 
document can exist anywhere within the data structure.)

2.  Select the document you wish to attach as a reference fi le. From the Falcon/DMS 
menu bar, select MicroStation > Attach Reference File.

3.  At this point Falcon/DMS turns the task over to MicroStation—proceed as  usual.

✔ TIP
It is not necessary to enable the Save 
Full Path option on MicroStation’s 
Attach Reference File dialog box. 
(See the ‘Behind the scenes’ section, 
this page.)

✉ NOTE
Multiple Reference Files:  You must 
repeat the process described in this 
section for each individual reference 
fi le.

� ATTENTION
Except for the  Attach Reference 
command, all reference fi le opera-
tions are performed with standard 
MicroStation Reference File com-
mands.
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Detaching a Reference File
Falcon/DMS does not have a detach reference fi le command. Instead, use the standard 
method prescribed by MicroStation: Select File > Reference Files from the MicroStation 
menu bar, on the Reference Files dialog box select the fi le you wish to detach, then chose 
Tools > Detach from the Reference Files menu bar. 

Additional Reference File Operations
Additional Reference File operations are described in Appendix A. These include the 
Modify Reference File Logicals command, exchanging one reference fi le for another 
while maintaining the reference fi le attributes (scale, clip boundaries, etc.) defi ned for 
the original, and attaching reference fi les with the System Generated, No Logical and 
Key In logical options. 

Manually Deleting Local Reference / Xref Files:

1.  Set File Selection to Local File Selection. 

2.  The Document Manager’s current directory becomes the local working 
directory—the default is c:\dms_local\. 

3.  Navigate to c:\dms_local\ref for MicroStation or c:\dms_local\xref for AutoCAD. 

4.  Select the file or files that you wish to delete. Press Delete (or select File 
> Delete).

On the Falcon/DMS Confi rmation box select Yes to delete fi les individually or 
Yes to All to delete all selected fi les. 

Attention MicroStation Users:

You cannot delete a reference fi le attached to the active fi le—Falcon/DMS 
does not permit reference fi les attached to the active fi le to be deleted. If you 
attempt to delete any of the active document’s reference fi les, Falcon/DMS 
ignores the operation.
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Deleting Local Reference Files

Falcon/DMS provides two ways to ‘throw away’ the local reference fi les:

❏ Auto Delete: When enabled, Falcon/DMS automatically deletes the appropriate 
local reference fi les when the parent fi le is checked in.

❏ Local File Selection > Delete: This procedure allows you to view the contents of 
the local reference directories and select and delete fi les at your own discretion. 
(The local reference directory is c:\dmslocal\ref.)

Enabling Auto Delete:

From the Document Manager’s menu bar select Workspace > User Preference > Auto 
Delete Reference Files > On.

As a document is checked in, Falcon/DMS identifi es and deletes the appropriate local 
reference fi les, if any.

Manually Deleting Local Reference:

1.  Set File Selection to Local File Selection. 

2.  The Document Manager’s current directory becomes the local working 
directory—the default is c:\dms_local\. 

3.  Navigate to c:\dms_local\ref . 

4.  Select the file or files that you wish to delete. Press Delete (or select File 
> Delete).

On the Falcon/DMS Confi rmation box, select Yes to delete fi les individually or 
Yes to All to delete all selected fi les. 
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✙ WARNING: Refresh Local 
& Refresh Server
USE  WITH CAUTION—Keep in mind 
the basic rule of carpentry: measure 
twice, cut once.

Refresh Local File:  Because the local 
fi le is overwritten by a fresh copy 
of the server-based original, any 
modifi cations made to the local fi le 
are lost.

Refresh Server File:  This command 
overwrites the server-based record 
copy of a fi le with its working version. 
If the server file is unintentionally 
refreshed you will have to retrieve a 
new record version from backup.

� ATTENTION
To refresh a document’s reference 
fi les that document must 

Attention—You cannot delete a reference fi le attached to the active fi le.

Falcon/DMS does not permit reference fi les attached to the active fi le to be deleted. If 
you attempt to delete any of the active document’s reference fi les the following message 
appears:

You must fi rst check in or otherwise close the current fi le. Once closed, you may delete 
the local reference fi les.

Refresh File Commands
Because these commands are essentially copy and replace operations, they should be 
used with caution. The MDL version of the Document Manager provides the following 
Refresh File operations: 

❏ Refresh Reference Files: This operation permits the user to refresh all or selected 
reference fi les with their server-based originals.

❏ Refresh Local Design File:  This operation permits the user to automatically 
retrieve and open a ‘fresh’ or unmodifi ed version of the active fi le. Because 
this local fi le is overwritten by a fresh copy of the server-based original, any 
modifi cations made to the fi le are lost.

❏ Refresh Server Design File: This operation permits the user to refresh the 
server-based original with the active fi le.

The ‘Refresh Reference Files’ Command

The Refresh Reference Files command allows users to update any or all of the reference 
fi les attached to their active drawing with a more current version of that fi le. 

Recall that when a fi le to which reference fi les are attached is opened, Falcon/DMS 
indicates which reference fi les are not already downloaded to the local hard disk, which 
reference fi les are current with the server version, and which reference fi les are checked 
out to another workstation and user. You may use this ‘workstation/user id’ to identify 
the person from whom you can request an updated version of your reference fi le; that 
person will refresh the server-based original with their current fi le and you, in turn, will 
refresh your reference fi le.

Users have the option of refreshing all or selected reference fi les.

Attaching a Reference File:

Falcon/DMS does not have a detach reference fi le command. Instead, use the standard 
method prescribed by MicroStation: Select File > Reference Files from the MicroStation 
menu bar, on the Reference Files dialog box select the fi le you wish to detach, then chose 
Tools > Detach from the Reference Files menu bar.
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To refresh a Reference File/Files:

In the process of opening a design fi le the Reference File List box indicates that three 
of the requested document’s reference fi les are checked out to a wyatt_ja on workstation 
ntwk_209.

The user ‘wyatt_ja’ is contacted and asked to either check in or refresh the fi les indicated 
on the Reference File List box. Once done, you are ready to refresh you reference fi les.

Please note that to refresh a document’s reference fi les that document must be opened 
as the active fi le.

1.  From the MicroStation’s menu bar, select Falcon/DMS > File Refresh > 
Reference Files,

or

from the Document Manager’s menu bar select File > File Refresh > Reference 
Files. 

2.  On the Falcon/DMS Alert box, press OK. 

3.  The active design fi le closes temporarily and is replaced by the banner fi le. The 
Reference File Selection dialog box opens. You may select only those reference 
fi les affected by the fi le refresh operation or all reference fi les.

4.  The Reference File List box displays the updated reference file conditions. 
Press OK.
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The ‘Refresh Local File’ Command

The File Refresh > Local Design File command permits you to automatically retrieve and 
open a ‘fresh’ version of your current fi le. Because the local fi le is overwritten by a fresh 
copy of the server-based original, any modifi cations made to the local fi le are lost.

To refresh a Local File:

1.  From the MicroStation’s menu bar, select Falcon/DMS > File Refresh > 
Local Design File,

or

from the Document Manager’s menu bar select File > File Refresh > Local 
Design File. 

2.  Press OK on the Refresh Local Design File alert box.

The ‘Refresh Server File’ Command

The Refresh Server File command permits you to automatically refresh the server-based 
original with the current fi le without closing the current fi le. Please note that if the server 
fi le is unintentionally refreshed, you will have to retrieve a new record version from 
backup. [Use this command with extreme caution.]

To refresh a Server File:

1.  From the MicroStation’s menu bar, select Falcon/DMS > File Refresh > 
Server Design File,

or

from the Document Manager’s menu bar select File > File Refresh > Server 
Design File. 



27
Document Retrieval

Open (View)
The Open (View) command permits you to view a document without checking it out 
from the database. Use this command to view a document that is checked out to another 
user.  When you view a document, a copy of that document is placed in the view 
directory on the client workstation (usually c:\dms_local\view).

To view a design fi le:

1.  From the Server File Selection region, designate the current directory.

2.  From the File Name list window, select a document.

3.  Press View (or select File >  View).

4.  The Falcon/DMS Information box indicates that the fi le is read only. Press OK. 

Falcon/DMS copies out and opens the selected document for viewing.

To view a design fi le already copied out for viewing:

A view fi le that is copied out to the requesting workstation remains available for viewing 
until the fi le is deleted (see next section). If you do not wish to update a copied out 
fi le with its server version, you may view the copied out version of the document by 
setting the File Selection to Local.

1.  From the File Selection menu, choose Local File Selection.

2.  In the Local File Selection region, navigate to the project under the c:\dms_local\
view directory.

3.  From the File Name list window, select a document. 

4.  Press View (or select File > View).

5.  A Falcon/DMS Alert box opens, indicates that the fi le is on your workstation, 
and asks if you want to view the server fi le. Press Cancel to view the local fi le 
or OK to view the server fi le.

6.  A Falcon/DMS Information box opens, indicating that the fi le is read only. 
Press OK. 
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Falcon/DMS opens the selected document for viewing.

7.  A Falcon/DMS Alert box opens, indicating that the fi le is on your workstation 
and asking if you want to view the server fi le. Press Cancel to view the local 
fi le or OK to view the server fi le.

8.  On the Falcon/DMS Information box (indicating that the fi le is read only), 
press OK. 

Falcon/DMS copies out and opens the selected design fi le for viewing.

To delete a local document/documents copied out for viewing:

A view fi le that is copied out to the requesting workstation may be deleted through the 
Windows Explorer or through the Falcon/DMS Document Manager. To delete a view 
fi le/fi les from the Document Manager:

1.  From the File Selection menu, choose Local File Selection.

2.  In the Local File Selection region, navigate to the project under the c:\dms_local\
view directory.

3.  From the File Name list window, select the documents you wish to delete.

4.  Press Delete (or select File > Delete).

5.  On the Falcon/DMS Confi rmation Box, press the Yes or Yes to All buttons.
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Checkout (Modify)
The Checkout (Modify) command permits a user to checkout one or more documents 
to a client workstation and hold them in reserve until they are checked back into 
the database. Falcon/DMS restricts access to the original documents on the server to 
view_only.

To Checkout a document for modifi cation:

1.  From the File Selection menu, choose Server File Selection.

2.  From the Server File Selection region, designate the current directory.

3.  From the File Name list window, select one or more design fi les.

4.  Press Checkout button (or select File > Checkout).

Copy Out (View)
The Copy Out (View) command is designed to permit a user to view two or more 
documents without checking them out from the database; the server-based record version 
of the design fi les remain available to be opened or checked out by another user.

When Falcon/DMS is used to view a design fi le, a copy of that fi le is placed in a ‘view’ 
directory under the application’s working directory (e.g. (c):\dms_local\view).

To Copy Out multiple documents for viewing:

1.  From the File Selection menu, choose Server File Selection.

2.  From the Server File Selection region, designate the current directory.

3.  From the File Name list window, select one or more design fi les.

4.  Press Copy Out [View] (or select File > Copy Out [View]).

Deleting ‘View’ Documents
A view fi le that is copied out to a workstation is considered to be a ‘throw away’ 
fi le and may be deleted through the Windows Explorer or through the Falcon/DMS 
Document Manager. 

To delete a local design fi le/fi les copied out for viewing:

1.  From the File Selection menu, choose Local File Selection.

2.  In the Local File Selection region, navigate to the project under the c:\dms_local\view 
directory.

3.  From the File Name list window, select the documents you wish to delete.

4.  Press Delete (or select File > Delete). On the Falcon/DMS Confi rmation Box, 
press Yes or Yes to All.
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✔ TIP
When Falcon/DMS is confi gured to 
allow only unique fi lenames, you may 
build the ‘fi les selected’ list from dif-
ferent projects and subdirectories. 

Check In
The Check In command returns checked out documents to the server and updates 
the database record of affected documents, making each available to other users for 
modifi cation. Falcon/DMS provides several ways to check in documents:

To check in a design fi le—Server File Selection:

1.  From the File Selection menu, choose Server File Selection.

2.  From the Server File Selection region, designate the current directory.

3.  From the File Name list window, select the fi le/fi les to check in.

4.  Press Check In (or select File > Check In).

To check in a design fi le from the Checked Out to <user> dialog box:

The Checked Out to <user> dialog box lists all the fi les that are checked out to you on 
the current workstation. This command is especially useful when checking in fi les from 
multiple projects and subdirectories.

1.  From the Document Manager’s menu bar, select File Selection > Checked 
Out to <user>.

2.  From the Files Checked Out to <user> dialog box, select the file/files to 
check in.

3.  Press Check In.

Creating Records with the Check In Command
When a list of fi les selected for check in contains documents for which database records 
do not exist, Falcon/DMS can create the necessary records as part of the check in 
operation. This feature is especially useful when working with applications that generate 
new fi les locally that you Falcon/DMS to manage.

For Falcon/DMS to check in a set of fi les containing these new, local items and create 
their database records, you must select the fi les from a Local File Selection. Otherwise, the 
Document Manager will not be able to see the new fi les.

To create database records during check in [Local File Selection]:

1.  Set the Directory Selection to Local File Selection. Navigate to the desired local 
directory and select the fi les to be checked in. (Whether the fi les have database 
records does not matter at this point.)

2.  From the Local File Selection region, navigate to your project directory. Press >> 
to select all the fi les in the current directory. This selection will contain fi les with 
database records and the new fi les without database records. Press Check In. 
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3.  When Falcon/DMS encounters a fi le without a database record a confi rmation  
box appears. Press Yes to add fi les singly; Press Yes to All to add all fi les in 
the fi les selected list.

4.  Because Falcon/DMS requires a fi le format for every document in the database, 
the Assign File Format dialog box appears when it encounters the fi rst fi le that 
does not have a database record. From the ‘Existing File Formats’ list select a fi le 
format and enable one of the three options.

❏ Use as default for all exts:  Assigns the selected fi le format to all fi les

❏ Use as default for current ext:  Assigns the selected fi le format to all fi les with 
the same fi lter as that of the current fi le.

❏ Prompt for each doc:  Assigns the selected fi le format only to the current fi le.

Press OK to process.
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Prompt for Backup

Falcon/DMS provides for the automatic backup of any fi le. This backup can be confi g-
ured to save the fi le to a designated backup directory on the server or to the fi le’s server-
based home directory. Another method is to prompt the user for a backup. When the 
operation is set to ‘prompt user’ you are given the opportunity to create a backup when 
you exchange one fi le for another or when you exit MicroStation.

User Defi ned Filters

Falcon/DMS supports up to four user defi ned fi le fi lters. Simply enter a fi lter string in the 
fi lename fi eld and press <Enter> or <Tab> out of the fi eld. A rolling list of user defi ned 
fi lters is added to the bottom of the fi lter option menu.
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Chapter 3.: 
 The New 
 Document 

Commands

The focus of this chapter is on using 
Falcon/DMS to create a document 

(in this case, a design fi le) and its database 
record. Recall that the Windows version 
of the Document Manager adds new 
files to the database, but relies on an 
application’s File > New command to 
create fi les. The MDL version of the 
Document Manager permits the user to 
create a MicroStation design fi le (and its 
database record) as well as to add fi les 
to the Falcon/DMS database without 
leaving MicroStation.

The topics discussed in this chapter 
are:

❏ The Create New File command
❏ Intelligent Data Link (IDL)
❏ Revision Control
❏ The Add Local command
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The New Design File Command
The New Document command enables the user to create a design fi le and its database 
record from within MicroStation.

To Create a MicroStation Document:

1.  On the Document Manager, press New or choose File > New.

The Create New Document dialog box opens.

Miscellaneous Options:

❏ Display Database Tabs: When enabled, the General Info, Keywords, and 
Title Block ‘tabs’ are available.

❏ Open Document: When enabled, Falcon/DMS opens the new design fi le and 
sets the Availability of the server-based original to on workstation.

❏ Checkout Document: When enabled, Falcon/DMS checks out the new 
design file  and sets the Availability of the server-based original to on 
workstation.

❏ Unload Document Manager: When enabled, the Document Manager closes 
after each document is created operation

2.  If it is necessary to use a seed fi le other than the default, press the < button 
to the right of the Seed File field. From the Seed File Listing dialog box, 
select a seed fi le. 

3.  Select the server-based home directory into which the new fi le will be placed.

4.  In the File Name fi eld, key-in a fi le name. Fill in database fi elds as necessary—
Falcon/DMS alerts you to which fi elds are required.

5.  Press OK on the Create New Document dialog box.

� ATTENTION
Falcon/DMS can be configured to 
redirect MicroStation’s File > New 
command. When the command 
redirect is enabled, selecting the 
MicroStation command opens the 
Falcon/DMS Document Manager. 

✔ TIP
Falcon/DMS can be configured to 
retrieve seed fi les from a central loca-
tion on your network or,  through the 
use of environments, from wherever 
departments or users maintain seed 
fi les.
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Intelligent Data Link (IDL)
Intelligent Data Link, or IDL, establishes a bi-directional link between text node elements 
in a MicroStation design fi le and specifi ed fi elds in the Falcon/DMS database. Integrated 
with the Create New Document command, IDL uses the database fi elds located on the 
General Info, Directory & Keywords,  Title Block, and File Format Keywords tabs found 
on both the Create New Document dialog box and the Document Manager.

IDL is bidirectional—that is, the text displayed on targeted text nodes in a MicroStation 
design fi le can be modifi ed from the document’s database record, or the database record 
can be modifi ed by editing the text nodes with MicroStation’s Edit Text command.

To create a design fi le with an Intelligent Data Link, simply select a seed fi le for which an 
IDL template has been defi ned and fi ll in the appropriate database fi elds.

Creating a design fi le with an Intelligent Data Link:

1.  On the Document Manager, press New (or select File > New).

2.  On the Create New Document dialog box, press the < button to the right of 
the Seed File fi eld. From the Seed File Listing dialog box, select a seed fi le for 
which an IDL template fi le exists.

3.  Fill in the appropriate database fi elds. 

4.  When fi nished, press OK.
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IDL and the Preserve Text Nodes Preference:

To take advantage of IDL’s ability to update text nodes in the design fi le when that 
document’s database record is modifi ed, Falcon/DMS automatically enables the Preserve 
Text Nodes control found in MicroStation’s User Preferences environment. When 
MicroStation opens the fi rst time after IDL is enabled you will be alerted to this automatic 
change. 

This setting preserves the text node status when a node is edited. Should you need 
to reset this control, select Workspace > Preferences from the MicroStation menu bar. 
In the Category list, choose Text. In the Set Text Preferences region, enable Preserve 
Text Nodes.

Modifying an IDL Through the Document Manager
IDL data displayed on text nodes in a MicroStation design fi le is easily modifi ed from the 
Falcon/DMS Document Manager.

1.  Open a design fi le with IDL data.

2.  From the Document Manager’s database info tabs, defi ne new data or modify 
existing data.

In the example: The Document Manager’s General Info tab is used to change 
the Document # and the Revision Number—the revision date changes 
automatically.
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3.  When fi nished, press Save—In the MicroStation design fi le the Drawing Number 
#, the Revision Number, and the Revision Date automatically update.

To illustrate the bi-directional character of the Intelligent Data Link, let’s now look at 
how you modify the document’s database record from the opposite direction.

Modifying an IDL with MicroStation’s Edit Text command
IDL data can also be modifi ed with MicroStation’s Edit Text command. However, 
directly editing a text node will not automatically update the design fi le’s database record. 
To synchronize the database with the IDL data, the user must exit the current design fi le 
either by checking in the document or by opening a second fi le. At such time, the user is 
asked to verify the changes to the IDL data.

1.  Open a design fi le with IDL data.

2.  Select MicroStation’s Edit Text command. Identify and accept an IDL linked 
text node.

3.  In MicroStation’s Edit Text dialog box, edit the selected text and press Apply. 
The text node is altered to refl ect the change made in the Edit Text dialog box. 
However, the design fi le’s database record will not change until the design fi le is 
checked in or a second fi le is opened.
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4.  To update the document’s record to refl ect the change to the IDL data, the user 
must exit the current design fi le either by checking in the document or by opening 
a second fi le. Before the current design fi le is checked in or another design fi le 
opened, the user is asked to verify the changes made to the IDL data.

The IDL Verify List dialog box displays affected categories in red and lists 
discrepancies between the MicroStation IDL data and document’s database 
record.

The user may choose between the following options:

❏ Update Document: 
❏ Update Record: Select Update Record when IDL linked text nodes are 

modifi ed with MicroStation’s Edit Text command.

The Document Manager now shows the changes made in MicroStation to the 
‘Project’ title block fi eld.
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Revision Control
Revision Control is designed to track revisions in one of two modes —a History mode or 
an As-built/work-in-progress mode. The key difference between modes is in how each 
identifi es the current revision. 

Revision Control schemes can vary between fi le formats and can be enabled for some 
and not for others. Revision Control can be confi gured to create a new revision at fi le 
checkout or fi le check in, either automatically or at a prompt. Finally, Revision Control 
can be confi gured to allow you to create a revision at your discretion.

History Mode

In the History mode, each time Revision Control is used to generate a new revision 
of a document, Falcon/DMS creates a backup of that document and appends a notation 
to the copy’s fi lename. If the ‘move revision’ option is enabled by the Falcon/DMS 
administrator, this copy is automatically moved to a designated subdirectory.

For example, lock10a.dgn is a document for which no revisions have yet been created, 
therefore the document’s Rev# database attribute is blank. When the document’s owner 
generates a new revision for lock10a.dgn, Falcon/DMS creates a copy using one of the 
following three notation formats:

❏ fi lename.ext.rev# [e.g. lock10a.dgn.rev0 or lock10a.dgn.revA]
❏ fi lename.rev#.ext [e.g. lock10a.rev0.dgn or lock10a.revA.dgn]
❏ fi lename.# [e.g. lock10a.0 or lock10a.A]

The copy, let’s say lock10a.dgn.rev0, is considered to be the previous revision. Revision 
Control sets the Rev# for document lock10a.dgn to ‘1’. Because lock10a.dgn retains 
the original fi lename and its Rev# indicates the highest number, in the History mode 
this document is considered to be the current revision. (The current revision is also 
referred to as the working document.) The incremented fi lesnames (i.e. lock10a.dgn.rev0, 
lock10a.dgn.rev1, etc.) represent the revision history.

Because its Rev# is currently ‘1’, the next time Falcon/DMS generates a new revision 
for lock10a.dgn, the copy will be named lock10a.dgn.rev1 and the copies Rev# will be 
set to ‘1’. The Rev# database attribute for lock10a.dgn, the current revision or working 
document, is set to ‘2’.

As-Built/Work-in-Progress Mode

In the As-built/work-in-progress mode, Revision Control copies the current revision, 
and assigns a new revision notation to its fi lename—and the copy becomes the current 
revision or working document. (This is the opposite of the History mode, in which the 
original remains the working document.) If the ‘move revision’ option is enabled, the 
previous revision is automatically moved to a subdirectory.

For example, lock10a.dgn is a the working document. No revisions have yet been created, 
therefore its Rev# database attribute is blank. When the document’s owner generates 
a new revision for lock10a.dgn in the As-built mode, Falcon/DMS creates a copy of 
this document, naming the fi le lock10a.dgn.revA and sets the Rev# to ‘A’. In this mode 
the current revision or working document is lock10a.dgn.revA and the previous revision 
is lock10a.dgn.

The next time Falcon/DMS generates a new as-built revision for lock10a.dgn.revA, the 
new revision will be named lock10a.dgn.revB and its Rev# will be set to ‘B’.  If the ‘move 
revision’ option is enabled, lock10a.dgn.revA is automatically moved to the designated 
subdirectory.

✉ NOTE
The previous revision of a document, 
that version that is often moved to a 
designated directory upon genera-
tion of a new current revision, is often 
assigned a Document Status with an 
access mode that is set to view_only, 
meaning that the previous revisions 
cannot be modifi ed.
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 To create a new revision—History mode:

1.. From the Document Manager, select a fi lename. Verify that the document’s 
availability is ‘On Server’. (Note that the Rev# for lock10-a.dgn is blank.)

2.. From the Falcon/DMS menu bar, select File > New Revision. The New 
Revision dialog box opens.

3.. In this example the Document # field can be edited. Edit as required and 
press OK.

In this example the previous revision, lock10-a.dgn.rev0, is not moved to the 
designated directory. Note that the Rev# for lock10-a.dgn, the current revision 
or working fi le, is set to ‘1’.

� ATTENTION
To create a new revision of a docu-
ment, its Availability must be ‘On 
Server’.
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✉ NOTE
This capability is especially useful 
when a user is permitted to create 
files on his local workstation with 
the intention of eventually placing 
one or more of these fi les under the 
control of Falcon/DMS.

✉ NOTE
The Check in command can also be 
used to create records for local fi les 
that are not yet controlled by Falcon/
DMS.  When using this approach you  
do not have the option to checkout 
fi les as their records are created.

� ATTENTION
 [Applies to the Add Local Files and 
the Add Server Files commands] If 
the selected fi les are either *.dgn 
(igds) or *.dwg (acad) files, the 
File Format is automatically set. If 
files with different extensions are 
selected, the Add Local... and Add 
Server... commands prompt the 
user for a File Format each time they 
encounter a different extension.

 

The Add Local Files Command
The Add Local Files command is used to add fi les located on a client workstation to the 
database and move or copy the fi les to the server. For example:  

An outside consultant provides a member of your organization with a set of documents 
that are to be used in the development of a project. The documents must be available 
to every person working on the project. The person in receipt of these fi les can easily 
accomplish this with the Add Local Files command

To add a local document

1.  From the operating system, place the local fi les in MicroStation’s working directory. 
In MicroStation, open the Falcon/DMS Document Manager.

2.  From the File Selection menu, choose Local File Selection.  (If necessary set 
the File Format to ‘igds’, making the directory into which the local fi les were 
moved the current directory.)

3.  From the File Name list window, select the fi les you wish add to the database.

4.  On the Document Manager, press Add Local Files (or choose File > Add Local 
Files). The Add Local File dialog box opens.

5.  In the Add to region, designate the server-based target (or home) directory. 
Enter information and defi ne settings on the General Info, Keyword, and Title 
Block tabs, as required.

6.  Note that the Check in Document option is enabled. If you wish to checkout the 
fi le/fi les as part of this transaction, uncheck the Check in Document option.

7   Press OK.

When two or more fi les are selected you may process the fi les singly by clicking 
the Yes button—this allows you to individually process and defi ne the contents 
of the database fi elds.

To process the group as one, press Yes to All.

When multiple fi les are selected and you click the Yes to All button, Falcon/DMS 
processes all MicroStation design fi les with a ‘.dgn’ extension and all AutoCAD 
drawing fi les with ‘.dwg’ extension and automatically assigns a fi le format of ‘igds’ 
and ‘acad’, respectively. When Falcon/DMS encounters fi les with other extensions 
you must  assign a fi le format from the Assign File Format dialog box.  The Assign 
File Format dialog box provides three options:

❏ Assign fi le format to all extensions
❏ Assign fi le format to current extension
❏ Prompt for each fi le.
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The Add Server... Command
The Add Server command is used to add fi les already located in their server-based 
home directory, but without records, to the Falcon/DMS database. The operation of this 
command is very similar to that of the Add Local command.

To add a fi le located on the server:

1.  From the operating system, place the fi les in their server-based home directory 
(access to the server required) and return to MicroStation.

2.  From the File Selection menu, choose Server File Selection. Designate the directory 
containing the fi les to be added to the database as the current directory.

3.  From the File Name list window, select the fi les you wish add to the database.

4.  On the Document Manager, choose File > Add Server. The Add Server File 
dialog box opens.

5.  In the Add to region, enter information and defi ne settings on the General Info, 
Keyword, and Title Block tabs, as required.

6.  Press OK.

When two or more fi les are selected you may process the fi les singly by clicking 
the Yes button—this allows you to individually process and defi ne the contents 
of the database fi elds.

To process the group as one, press Yes to All.

When multiple fi les are selected and you click the Yes to All button, Falcon/DMS 
processes all MicroStation design fi les with a ‘.dgn’ extension and all AutoCAD 
drawing fi les with ‘.dwg’ extension and automatically assigns a fi le format of ‘igds’ 
and ‘acad’, respectively. When Falcon/DMS encounters fi les with other extensions 
you must  assign a fi le format from the Assign File Format dialog box.  The Assign 
File Format dialog box provides three options:

❏ Assign fi le format to all extensions
❏ Assign fi le format to current extension
❏ Prompt for each fi le.

� ATTENTION
The Add Server Files command 
is available only when the Server 
View Mode user preference is set 
to ‘Directory’. When Server View 
Mode is set to Database fi les without 
database records do not display.

✉ NOTE
Unless specifically instructed to 
open or checkout the fi les as they 
are added to Falcon/DMS, the Add 
Server Files command leaves the fi les 
in their home directories and sets 
their Availability to  ‘On Server’.



43

Falcon/DMS

The Document Manager 
(MDL)

Chapter 4:    
Document   
Manipulation

Falcon/DMS helps manage the inevi-
table changes to a database with a 

full complement of design fi le manipula-
tion commands. The Move, Copy, 
Copy/Replace, Rename, and Delete 
commands are designed to make safe 
what could be treacherous operations 
without Falcon/DMS. For example: 

❏ Falcon/DMS will not move, copy, 
delete, or otherwise manipulate a design 
fi le until it satisfi es all the database rules 
that govern such procedures.

❏ When a design file is renamed a 
record of its former name is maintained 
in the database.

❏ Design files are NOT necessarily 
deleted, rather they can be marked for 
deletion in your database and moved to 
a special location from which they can 
be easily restored.
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✒ TERMS
Source Directory: The directory 
containing the document/documents 
to be moved or copied.

Target Directory: The directory to 
which the document/documents is 
moved or copied.

� ATTENTION
To move a document, its Availability 
must be ‘On Server’.

✉ NOTE

When a single document is moved, 
copied, copied and replaced, or 
renamed you may enable either the 
‘Open’ or the ‘Checkout’ option. 
When multiple documents are 
selected only the ‘Checkout’ option 
is available.

The Move Document Command
Use the Move command to move a document/documents from one location to another 
and update their database records. The directory containing the documents to be moved 
is known as the source directory.  The directory to which the documents are moved 
is known as the target directory.  To move a document, its Availability must be ‘On 
Server’.

To move a document:

1.  From the Server File Selection region, make the source directory the current 
directory.

2.  From the File Name list box, select the document/documents to be moved.

3.  Press Move (or select File > Move).  The  Move Document dialog box opens.

4.  In the Move To region, designate a target directory. 

Open/Checkout Document Options:

❏ The Open/Checkout Document options are available for the Move, Copy, 
Copy/Replace, and Rename commands.

❏ When two or more fi les are selected, only the Checkout Document option 
is available. 

5.  Press OK.
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The Copy Document Command
Use the Copy Document command to copy a document/documents and create database 
records for the new fi les. 

The Primary Index Key & the Copy Command: The level of fi lename uniqueness allowed 
by Falcon/DMS affects the operation of the Copy Document command:

❏ If the Primary Index Key is set to Filename, the Copy Document command forces 
you to specify a new fi lename.

❏ If the Primary Index Key is set to any of the other six options, you are permitted to 
use non-unique fi lenames in the target directory—you have the option of keeping 
the original name, or providing a new name for each fi le as it is copied.

To copy a document (Availability = On Server):

1.  From the Server File Selection region on the Document Manager, designate the 
source directory as the current directory.

2.  From the File Name list box, select the document/documents to be copied.

3.  Press Copy (or select File > Copy).  The Copy Document dialog box opens.

4.  In the Copy To region, designate a target directory, then key in a fi lename.

If the database permits duplicate fi lenames you may enable the ‘Keep Same 
Filename’ option.

5.  Press OK.

✉ NOTE
The Copy command captures the 
document’s previous name in the 
database. This information is dis-
played in the ‘Copied/Renamed 
From’ fi eld on the File Access Info 
tab on the Database Maintenance 
dialog box (available only to the 
Falcon/DMS  Administrator).
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To copy a document (Availability = On Workstation [your workstation]):

Use this procedure to copy a fi le checked out to your workstation:

1.  From the Server/Local File Selection region on the Document Manager, designate 
the source directory as the current directory.

2.  From the File Name list box, select the document/documents to be copied.

3.  Press Copy (or select File > Copy).  The Copy Document dialog box opens.

4.  In the Copy To region, designate a target directory and key in a fi lename.

If the database permits duplicate fi lenames you may enable the ‘Keep Same 
Filename’ option.

5.  Press OK. On the message box, press Yes to copy the local fi le,

or

Press No. A second message box opens.  Press Yes to copy the server version 
of the fi le.

To copy a document (Availability = On Workstation [another workstation]):

Use this procedure to copy a fi le checked out to another user’s workstation.

1.  From the Server/Local File Selection region on the Document Manager, designate 
the source directory as the current directory.

2.  From the File Name list box, select the document/documents to be copied.

3.  Press Copy (or select File > Copy).  The Copy Document dialog box opens.

4.  In Copy To region, designate a target directory and key in a fi lename.

5.  Click the OK button. On the message box, click the Yes button to copy the 
server version of the fi le, 

or

press No to terminate the command.
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The Copy/Replace Document Command
The Copy/Replace Document command permits you to replace one document (the target 
document) with a copy of another (the source document). The Availability of the ‘target’ 
and ‘source’ documents must be ‘On Server’.

The content of the target document changes while its name remains the same. 

The target document’s database record is only partially altered—Falcon/DMS keeps the 
original creation, archive, backup, and location dates, as well as the archive time. 

Why is this information retained? Perhaps an error is made in identifying the target design 
fi le and remains undiscovered for several days or weeks.. In other words, the wrong 
fi le was overwritten! Because the archive information is unaltered, you know precisely 
where in your system backup the previous version of the overwritten target design fi le 
can be found .

To copy/replace  a document:

1.  From the Server File Selection region, designate the source document’s directory 
as the current directory.

2.  From the File Name list box, select the source document/documents.

3.  From the File menu, select the Copy/Replace command. The Copy/Replace 
Document dialog box opens.

4.  In the Replace File region, designate the target document’s directory as the 
current directory.

5.  Select the target document—press the < button beside the File Name fi eld. 
From the File List list box, choose the target document. When multiple source 
documents are selected,  Falcon/DMS will prompt you to identify the next 
target document.

6.  Press OK to close the Copy/Replace Document dialog box.

The Rename Document Command
Use the Rename Document command to rename a document.  The Availability of the 
documents to be renamed must be ‘On Server’. 

The Rename Document command captures the previous name of renamed documents 
in the database.

To rename a Document:

1.  From the Server File Selection region, designate the current directory.

2.  From the File Name list box, select the document/documents to be renamed.

3.  Press Rename (or select File > Rename).  The Rename Document dialog 
box opens.

4.  In the File Name input fi eld, enter the document’s new name.

5.  Press OK.

� ATTENTION
To copy/replace a document its 
Availability must be ‘On Server’.

✉ NOTE
The Copy/Replace command cap-
tures the document’s previous name 
in the database. This information is 
displayed in the ‘Copied/Renamed 
From’ fi eld on the File Access Info 
tab on the Database Maintenance 
dialog box.

� ATTENTION
To rename a document its Availability 
must be ‘On Server’.

✉ NOTE
If all of the requirements governing 
fi lename uniqueness are not satis-
fied, Falcon/DMS will not allow a 
document to  
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The Delete Document Command
Use the Delete command to delete a document or documents.  To delete a document 
its Availability must be ‘On Server’. 

Note: Falcon/DMS can be confi gured to move ‘deleted’ documents to a secure area on 
the application server rather than actually deleting the fi les. Typically, fi les moved to this 
area will be maintained for a prescribed period before they are fi nally deleted. See your 
Falcon/DMS Administrator for more information.

To Delete a Document:

1.  From the Server File Selection region, designate the current directory.

2.  From the File Name list box, select the document/documents to be deleted.

3.  Press Delete (or select File > Copy).  

4.  A Falcon/DMS alert box opens. Press Yes or Yes to All, as required.
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Chapter 5:    
Database    
Operations

A principal benefi t of the Falcon/DMS 
engineering document management 

system is the ability to search the docu-
ment database and produce a search 
result based on user-defined criteria. 
Additionally, the Document Manager  
allows you to perform any of the fi le 
manipulation operations on a file or 
combination of fi les listed in the search 
result.

The MicroStation version of the Docu-
ment Manager provides the following 
database functions:

❏ Database Search—a robust, easy 
to use searching tool. Users can search 
on text strings (whole and segmented) 
in the Description and Title Block 
fi elds,  all fi elds on the General Info tab, 
single or multiple ‘project’ directories 
and subdirectories, Keywords, and an 
extensive selection of supplemental 
fi elds.

❏ Generate Document List—allows 
users to designate  the current fi le by 
choosing from a list that displays the 
Filename, its Document #, and its 
Description.

❏ Document Notes—this feature 
provides a easy and powerful way for 
users to itemize activity for any docu-
ment.
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The Database Search Command
Falcon/DMS offers a robust searching. Users can search on text strings (whole and 
segmented) in the Description and Title Block fi elds,  all fi elds on the General Info tab, 
single or multiple ‘project’ directories and subdirectories, Keywords, and an extensive 
selection of supplemental fi elds.

The Database Search Command

1. Choose File Selection > Database Search on the Document Manager.

2. From the Database Search dialog box, defi ne the search criteria.

❏ On the main Database Form, above, the example search requests that 
Falcon/DMS search for all fi les that contain the text string ‘LOCK’ anywhere 
in the description, with a status of ‘Archived’, and with keywords of ‘frank 
cole’ and ‘bc-30’.
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❏ For additional search criteria, press More to open the SQL Search More Screen. 
The example shows that the search is refi ned by further specifying all matching 
fi les that were archived before ‘1/8/1995’.

To defi ne a value for a listed fi eld, select the fi eld and press Edit—or double-click 
the item—and fi ll in the input fi eld. When fi nished, press OK.

To clear the form and defi ne a new search, press Clear.

3. Press Submit.

4. When the process completes, the File Selection region on the Document Manager 
changes to Database Search Results. From this region you may select one or more 
fi les, then the operation you wish to perform.

❏ When the search returns more than fi fty records, press More to view an 
expanded list; if necessary, you can continue to expand the list in increments 
of fi fty items.

❏ To reopen the Database Search form to defi ne a new criteria or modify the 
current criteria, press New/Modify.

❏ To generate an ASCII text fi le containing the search results, press Print. [You 
cannot print the search results directly from within MicroStation. Hardcopy of 
the search result is generated from the text fi le.]

❏ To exit the Database Search Results mode, press Cancel.
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✒ TERMS
Database Keywords: Keywords are 
user-defined database attributes 
that are central to performing a 
database search. The primary benefi t 
of keywords is the ability to use a 
defi ned structure for choosing your 
search criteria; predefi ned lists give 
you a window into how information 
is organized and assist in producing 
useful search results.

Falcon/DMS provides six system-level 
keyword categories and twenty fi le-
format keyword categories for each 
fi le-format (igds [MicroStation], acad, 
word, excel, etc.). Use keywords 
to refi ne 

Where Do Keywords Come From? 
Keywords and the manner in which 
they are organized can be fully cus-
tomized. Keywords are organized in 
categories. Once categories are cre-
ated, the Falcon/DMS administrator 
builds a series of  keyword tables, 
one for each category.  The items 
contained within these tables are 
then selected from option menus 
appearing on the dialog boxes that 
handle the creating, adding, manipu-
lation, and maintenance of docu-
ments and their database records.

The Database Search Dialog Box

PUORG NOITPO NOITPIRCSED

GENERAL

INFO:
noitpircseD .noitpircsedtnemucodretcarahc08

#tnemucoD .rebmuntnemucodretcarahc04

[sutatS < ] [ehtkcilC < elpitluM.xobtsilnoitceleSsutatSamorftcelesotnottub]
.edamebnacsnoitceles

[ytilibaliavA < ] [ehtkcilC < .xobtsilnoitceleSytilibaliavAamorftcelesotnottub]
.edamebnacsnoitceleselpitluM

noitacoL .dekcehcsielifahcihwotnoitacolehtsehcraeS

#noisiveR .rebmunnoisiverretcarahc5

[tamroFeliF < ] [ehtkcilC < .xobtsilnoitceleStamroFeliFamorftcelesotnottub]
.edamebnacsnoitceleselpitluM

yBetaerC .tnemucodehtdetaercohwresuehtsehcraeS

emaNeliF .)rotartsinimdASMD/noclaFybdenifed(timilretcarahc08

#teehS .rebmunteehsretcarahc3

resU .tuodekcehcsitnemucodamohwotresunosehcraeS

noitatS tuodekcehcsitnemucodahcihwotnoitatskrowehtnosehcraeS

FILE

SELECTION

[1leveLyrotceriD < ] [ehtkcilC < elpitluM.xobtsiltcejorPehtmorftcelesotnottub]
.edamebnacsnoitceles

[5-2leveLyrotceriD < ] [ehtkcilC < elpitluM.xobtsilyrotceridbusamorftcelesotnottub]
.edamebnacsnoitceles

KEYWORDS []leveLmetsyS[6-1 < ] [ehtkcilC < elpitluM.xobtsildrowyeKamorftcelesotnottub]
.edamebnacsnoitceles

TITLE BLOCK 6-1 aebnacniyekehT.yrtnekcolbeltitretcarahc06astroppusdleifhcaE
txetdetnemgesrofdesuerasdracdliW.gnirtstxetdetnemgesroelohw

ehtfosecneruccollarofsehcraes*tnemegnarra*elpmaxerof;sgnirts
.dleifkcolbeltitdetacidniehtni'tnemegnarra'drow



53
Document Retrieval

The Database Search Dialog Box (cont.):
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Using Comparison Operators: The Database Search command supports the 
following comparison operators for date and number fi elds:  The format for criteria 
using comparison operators is —

[operator] space [value] space [and/or] space [operator] space [value]

<  e.g.  < 1/1/96  [searches for events that occurred before 1/1/96]
>  e.g   > 1/1/96  [searches for events that occurred after 1/1/96]
=  e.g.  = 1/1/96  [searches for events that occurred on 1/1/96]
<=  e.g. <= 1/1/96  [searches for events that occurred before or on 1/1/96]
>=  e.g. >= 1/1/96  [searches for events that occur after or on 1/1/96]

Other examples of ‘and’ / ‘or’ operator combinations are:

> 1/1/95 and < 1/1/96  [after 1/1/95 and before 1/1/96]   
>= 1/1/95 and < 1/1/96  [after or on 1/1/95 and before 1/1/96] 
1/1/95 or 1/1/96    [on 1/1/95 or on 1/1/96]  
1/1/95 or > 1/1/96   [on 1/1/95 or after 1/1/96]  
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The Generate Document List Command
The Generate Document List option lists the contents of the current directory as 
Filename, Document #, and Description. To display the fi le list in this format, choose 
Database > Generate Document List.

❏ To select a single fi le from the Document List simply click on the required fi lename 
and choose a command; press Cancel to close the Document List and restore 
the standard directory and fi le list.

❏ To select multiple fi les from the Document List dialog box, use the <Shift>+click 
and <Ctrl>+click key combinations as you click on the required fi les and choose 
a command; press Cancel to close the Document List and restore the standard 
directory and fi le list.
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Document Notes
The Document Notes feature provides a way for users to itemize activity and communi-
cate specifi c information for any document. The notes become part of each document’s 
database record. Users can defi ne a document note and display and edit that information 
from either the Windows or the MDL versions of the Document Manager.

To Display a Document’s Notes:

1.  From the Document Manager, select a fi le from the File Name list window.

2.  Click the Document Notes radio button. If the selected record has associated 
notes, they are displayed on this tab.

To Add a Document Note:

1.  From the Document Manager, select a fi le from the File Name list window.

2.  Click the Document Notes radio button.

3.  Press Add. The Note dialog box opens.

4.  Enter information in the Subject input fi eld. Press <Tab> to shift to the Note input 
region. Enter information in the Note region. Press OK.
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To Edit a Document Note:

1.  From the Document Manager, select a fi le from the File Name list window.

2.  Click the Document Notes radio button.

3.  Double-click on the Document Note that you wish to edit. The Note dialog 
box opens. You may modify the Subject and/or the attached note. When 
fi nished, press OK.

To Delete a Document Note:

1.  From the Document Manager, select a fi le from the File Name list window.

2.  Click the Document Notes radio button.

3.  Select the note you wish to delete. Press Delete. Press Yes on the Falcon/DMS 
Confi rmation box.
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Chapter 6:    
Third-Party 
Applications

As the availability of third-party 
applications for MicroStation has 

grown, so has the ability of Falcon/DMS 
to either provide specifi c interfaces for 
an application or to tailor the capabilities 
of standard commands to accommodate 
its particular requirements.

❏ IGrds: The IGrds interface lists all 
the IGrds working/.hal and plot files 
stored in the current project directory 
(*.hal and *plt.dgn, respectively). This 
list displays when a MicroStation design 
fi le is opened. From the list you select 
the required ‘key’ files; Falcon/DMS 
identifi es and checks out all the additional 
fi les needed for the design session.

❏ CAiCE: Because a CAiCE project 
requires all the fi les found in the project 
directory, you will use the Falcon/DMS 
Checkout command to simply checkout 
all documents from that location. Upon 
completion of a CAiCE design session, 
you will use the Check In command to 
simply check in all documents found in 
the project’s local working directory. 
As part of this check in transaction, 
Falcon/DMS adds any new fi les created 
during the design session to the data-
base.
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IGrds
IGrds, or Interactive Graphics Roadway Design System, is part of the AASHTO (Ameri-
can Association of State Highway and Transportation Offi cials) family of software prod-
ucts developed under the Cooperative Computer Software Development program. .

The Falcon/DMS interface provided for IGrds is designed to make the process of 
managing an IGrds data set as transparent as possible to the user.  With Falcon/DMS, you 
need be concerned with only two categories of IGrds documents: 

❏ the working (or ‘.hal’) fi le/fi les
❏ the plot (*plt.dgn) fi le/fi les

Once the working/.hal and plot fi les, if any, are selected, Falcon/DMS insures that all 
IGrds fi les controlled by a working fi le are checked out and managed as a set.  

The IGrds interface is available when you select a design fi le and invoke the Open and 
Check In commands.

Behind the scenes
With the IGrds On/Off control on the Falcon/DMS pull-down menu set to ‘IGrds 
On’, Falcon/DMS searches for IGrds associations when any design fi le is opened. (The 
Falcon/DMS menu is located on the MicroStation menu bar.)

When you select a design fi le and invoke the Open command Falcon/DMS fi rst checks 
out the design fi le to the local working directory and processes reference fi les, and then 
searches for IGrds associations in the current directory. When IGrds fi les are present, 
the IGrds Associations dialog box displays and lists all working/.hal and plot fi les located 
in this directory.  After you select the desired working/.hal and plot fi les, Falcon/DMS 
checks out all associated style fi les (*.i0*), all fi les associated to the working/.hal fi le, and 
the selected plot fi les to the local working directory. As the fi nal step in the process, the 
design fi le opens in MicroStation .

The IGrds interface also accounts for new fi les created during an IGrds design session. 
When you check in the main design fi le, Falcon/DMS can automatically create database 
records for and check in any new fi le generated during the design session.

The Falcon/DMS—IGrds interface
To enable/disable the Falcon/DMS—IGrds interface:

The IGrds interface control is found on the Falcon/DMS pulldown menu located on 
MicroStation’s menu bar. To enable the control for IGrds documents, select Falcon/DMS 
> IGrds-Ignore Working Files; the control, a toggle, will then display the option IGrds-
Include Working Files. To disable the control for IGrds documents, select Falcon/DMS 
> IGrds-Include Working Files; the control will then display the option IGrds-Ignore 
Working Files.

� ATTENTION
To enable the IGrds interface, set the 
control toggle on the Falcon/DMS 
pull-down menu to ‘IGrds On’. How-
ever, be aware that when set to 
‘IGrds On’, Falcon/DMS checks for 
IGrds associations each time you 
open a design fi le, adding process-
ing time to this operation. When 
IGrds is not required, set the toggle 
to ‘IGrds Off’. 

✉ NOTE:
On the Windows Document Manager 
the only command that recognizes 
IGrds associations is Check in.
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To open a design fi le and checkout IGrds associations:

1.  From the Document Manager, choose the fi le you wish to open and select the 
Open command and process any reference fi les attached to the design fi le. At 
this point the Document Manager’s status fi eld indicates that Falcon/DMS is 
searching for IGrds associations.

Falcon/DMS searches the current directory for IGrds working/.hal fi les and 
fi les that match the string *plt.dgn. When the search returns a match the IGrds 
Associations dialog box opens.

2.  From the IGrds Associations dialog box, select the working/.hal and the plot fi le 
or fi les you wish to checkout. Press Checkout. 

Falcon/DMS checks out the associated style fi les (*.i0*), all fi les associated to 
the working/.hal fi le, and the selected plot fi les to the local working directory, 
and opens the design fi le.

✔ TIP
The IGrds Associations dialog box 
lists the IGrds fi les from which you 
will choose, so it is not necessary to 
display the full contents of the current 
directory.  Because the IGrds func-
tion is triggered when a design fi le 
opens, setting the fi le list window’s 
filter to ‘microstation [*.dgn]’ will 
shorten what is usually a long list 
of fi les.
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To check in a design fi le and local IGrds fi les:

As part of standard check in the IGrds interface can also account for new fi les created 
during the IGrds design session. When you check in the main design fi le, Falcon/DMS 
automatically creates database records for and checks in any new fi le generated during 
the design session.

1.  From the Document Manager, choose the fi le you wish to check in and select 
the Check In command. Remember that you can also check in fi les from the 
Checked Out to <user> dialog box.

Falcon/DMS searches the design file’s local working directory for IGrds 
working/.hal fi les and fi les that match the string *plt.dgn. When the search returns 
a match the IGrds Associations dialog box opens.

2.  From the IGrds Associations dialog box, select the working/.hal and the plot fi le 
or fi les you wish to check in. Press Check In.

Falcon/DMS fi rst checks in the design fi le, then associated style fi les (*.i0*), all 
fi les associated to the working/.hal fi le, and the selected plot fi les server. It is at this 
point that Falcon/DMS also creates database records for and checks in any new 
fi les generated during the design session.
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To checkout or check in a design fi le only:

If you do not wish to checkout IGrds related fi les as you open a design fi le, you may 
either  set the control located on the Falcon/DMS pull-down menu to ‘IGrds Off’, or 
simply not select any fi les on the IGrds Associations dialog box. 

1.  From the Document Manager, choose the fi le you wish to checkout or check in 
and select the appropriate command.

Falcon/DMS searches the design file’s local working directory for IGrds 
working/.hal fi les and fi les that match the string *plt.dgn. When the search returns 
a match the IGrds Associations dialog box opens.

2.  On the IGrds Associations dialog box, DO NOT select any fi les from the Working 
File Selection or Plot File Selection regions. 

Finally, depending upon the direction of the transaction press either Check 
In or Checkout.
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✙ WARNING
It is strongly recommended that you 
turn off the IGrds interface before 
checking in any CAiCE fi les (Micro-
Station menu bar > Falcon/DMS > 
‘IGrds Off’).  With the IGrds interface 
enabled, Falcon/DMS automatically 
searches for IGrds associations caus-
ing processing time to increase 
signifi cantly.

� ATTENTION
In order to check in a set of CAiCE 
fi les containing fi les created during 
the current design session, or in 
other words, files that do not yet 
have database records, you must 
select the data set from a Local File 
Selection. Otherwise, Falcon/DMS 
simply cannot see that new fi les are 
available for selection.

CAiCE
CAiCE (Computer Aided Civil Engineering & Surveying) software includes survey 
data processing, coordinate geometry, site design, earthworks, road design, quantities 
tabulation, automated plans production and other application areas.

Because a CAiCE project requires all the fi les found in the project directory, you will 
use the standard Falcon/DMS Checkout command to simply checkout all documents 
from that location. Upon completion of a CAiCE design session, you will use the Check 
in command to simply check in all documents found in the project’s local working 
directory. As part of this check in transaction, Falcon/DMS can automatically create 
database records for all new fi les generated during the design session.

With CAiCE, the only departure from the standard check in procedure (and this applies 
only when new CAiCE fi les have been created) is that you must set File Selection to 
Local File Selection and check in the contents of the local project directory.  The reason 
for this is that when CAiCE  generates new fi les they are placed in the local project 
directory on your computer’s hard disk. The only way to see these fi les is to set the 
Document Manager’s File Selection mode to Local.

When no new CAiCE fi les are created you may check in from the Server File Selection 
or from the Checked Out to <user> dialog box.

Using Falcon/DMS to manage a CAiCE data set
To checkout a CAiCE data set:

1.  From the Document Manager, press >> to select all the fi les in the current 
CAiCE project.

2.  Press Checkout.
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To check in a CAiCE data set:

1.  From the Document Manager, press >> to select all the fi les in the current 
CAiCE project.

2.  Press Check In. 

To check in a CAiCE data set that contains newly generated fi les [without database 
records]:

1.  From the Document Manager, select File > Selection > Local File Selection.

2.  From the Local File Selection region, navigate to the CAiCE project directory. 
Press >> to select all the fi les in the current CAiCE project. This selection 
will contain files with database records and the new files without database 
records. Press Check In.
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3.  When Falcon/DMS encounters a fi le without a database record a confi rmation  box 
appears. The procedure you will follow for CAiCE is to press Yes to All. 

4.  Because Falcon/DMS requires a fi le format for every document in the database 
the Assign File Format dialog box appears. From the ‘Existing File Formats’ 
list select ‘caice’ and enable the ‘Use as default for all exts.’ radio button. This 
enables Falcon/DMS to assign the ‘caice’ fi le format to all the fi les it process, 
regardless of each fi le’s extension.

Press OK to process the list of new fi les.


